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Introduction

Using IntelliCAD is part of an integrated documentation set that includes this manual 
and a comprehensive collection of help resources to give you the information you 
need to create drawings in IntelliCAD®.

Topics in this chapter

About IntelliCAD and other CAD software ............................................................ 3

Comparing IntelliCAD and CAD to manual drafting ....................................... 5

Using advanced CAD features............................................................................ 12

Getting more information .................................................................................... 13

New in IntelliCAD 12........................................................................................... 14



2 C H A P T E R  1
This manual is organized into chapters that parallel how you work in IntelliCAD, 
according to the tasks you might perform. The tasks are divided and organized into 
the following work-focused chapters:

Introduction: Chapter 1  An overview of the key features of IntelliCAD plus basic con-
cepts of computer-aided design (CAD) as they apply to IntelliCAD.

Getting started: Chapter 2  Installing IntelliCAD, starting and exiting IntelliCAD, 
working with toolbars, and selecting commands. 

Working with drawings: Chapter 3  Opening and saving an existing drawing and start-
ing a new drawing. Using drawing settings to establish paper size, scale factors, and 
text height. Working with colors in your drawings. Using drawing aids such as entity 
snaps and orthogonal mode to draw accurately.

Creating entities: Chapters 4–5  Working with simple entities such as lines, circles, and 
arcs and with complex entities such as polygons, spline curves, planes, wipeouts, 
boundary hatches, and more.

Viewing your drawing: Chapter 6  Moving around in the drawing, changing its magnifi-
cation, creating multiple views, and saving arrangements of windows of the drawing.

Working with coordinates: Chapter 7  Working with Cartesian coordinate systems, 
specifying two-dimensional and three-dimensional coordinates, and defining your 
own user coordinate systems.

Working with the Explorer: Chapter 8  Using IntelliCAD’s Explorer to manage your 
drawings: controlling layers, layer states, linetypes, multiline styles, text styles, table 
styles, dimension styles, multileader styles, coordinate systems, views, visual styles, 
layouts, materials, groups, external references, and blocks and copying information 
between drawings.

Getting drawing information: Chapter 9  Working with the additional information in 
IntelliCAD drawings, calculating areas and distances, and displaying other drawing 
information.

Modifying entities: Chapter 10  Selecting, copying, rearranging, resizing, and editing 
entities.

Annotating and dimensioning your drawing: Chapters 11–12  Using text to annotate 
drawings; using dimensions to annotate the measurement of entities.

Working with blocks, attributes, and external references: Chapter 13  Using blocks and 
external references to combine entities and data for reuse; creating attribute informa-
tion to extract for use in other programs. 

Formatting and printing drawings: Chapter 14  Combining drawings into finished lay-
outs, customizing print options, printing copies, and also publishing mutliple draw-
ings at a single time using sheet sets and sheet lists.

Drawing in three dimensions: Chapter 15  Viewing, creating, and editing three-dimen-
sional entities. And visualizing them using hidden line removal, shading, and photo-
realistic rendering.
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Working with other programs: Chapter 16  Sharing drawings and data with other users, 
documents, and programs.

Customizing IntelliCAD: Chapter 17  Customizing the appearance and operation of the 
program to suit your needs.

Understanding AutoCAD compatibility: Appendix  Describes similarities and differences 
between IntelliCAD and AutoCAD.

This section introduces you to IntelliCAD®, its features, and its comprehensive capa-
bilities for creating drawings of various types. 

About IntelliCAD and other CAD software

IntelliCAD is designed for anyone who wants a fast and efficient CAD program with 
all the power and versatility of standard programs such as AutoCAD® by Autodesk®, 
Inc., or MicroStation® by Bentley Systems, Inc., at an affordable price. Using today’s 
advanced technology, IntelliCAD integrates the Microsoft® Windows® interface with 
a powerful CAD engine. 

IntelliCAD provides unparalleled compatibility with AutoCAD, using most of the 
same file formats including those for drawings (.dwg files), commands, linetypes, 
hatch patterns, and text styles. You can also use AutoCAD menu files and run 
Autodesk® AutoLISP® programs. If you have written your own ADS (Autodesk® 

AutoCAD Development System®) programs, simply recompile them to link with the 
IntelliCAD libraries. Many third-party ADS programs already support IntelliCAD. If 
you have a program that is not already supported, ask your software vendor to pro-
vide an IntelliCAD-compatible version of the program.

IntelliCAD is more compatible with the AutoCAD program than any other CAD 
product, delivers additional tools with advanced CAD features, and has a seamless 
Microsoft® Windows integration. This powerful program provides a superb combina-
tion of features for CAD users like architects, engineers, and designers.

IntelliCAD incorporates standard features found in other CAD programs, along with 
features and capabilities you won’t find anywhere else. Its multiple-document inter-
face (MDI) lets you open and work with several drawings at the same time. You can 
easily copy drawing entities between drawings. In addition, the powerful Explorer 
lets you manage information and settings and quickly copy layers, linetypes, and 
other information between drawings.

Using AutoCAD legacy drawings
IntelliCAD fully supports AutoCAD legacy drawings. IntelliCAD reads and writes 
.dwg files in their native format without any loss of data, from AutoCAD 2007 back 
to Version 11, including AutoCAD LT®. Because IntelliCAD uses Autodesk 
DWG format as its native file format, no translation is required. 
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IntelliCAD provides you with the appropriate tools for your experience level—
whether you are a beginner, intermediate, or advanced CAD user. If you are just start-
ing out with CAD, you may want to use the beginner level, which provides toolbars 
containing the basic tools such as lines, arcs, and circles. As you become more expe-
rienced, you can move to the intermediate level and then to the advanced level, which 
gives you access to more than 300 commands through toolbars, menus, and keyboard 
entries. You can change the experience level in the Options dialog box on the Tools 
menu.

IntelliCAD supports three-dimensional wireframes and surfaces. Three-dimensional 
drawings can be displayed in wireframe, hidden-line view, and surface shading. 
Some versions of IntelliCAD also support creating and editing 3D solids; all versions 
display 3D solids, along with limited editing features. 

Some versions of IntelliCAD support displaying and working with raster images in 
your drawings. However, IntelliCAD does not display images located inside of 
blocks and externally referenced drawings (xrefs). When a drawing containing proxy 
entities is loaded into IntelliCAD, a message displays indicating that some entities 
will not display, however, the entities reappear when you open the drawing later in 
AutoCAD. 

It’s easy to customize IntelliCAD. You can modify menus and toolbars, create 
custom menus, dialog boxes, command aliases, and scripts, and add custom programs 
written in any of several programming languages, including DRX (the program’s 
Autodesk® ARX-compatible language), LISP (the program’s Autodesk AutoLISP-
compatible language), and SDS™ (Solutions Development System™, the program’s 
Autodesk ADS-compatible language). There is also Microsoft® Visual Basic for 
Applications (VBA).

You can run existing Autodesk® AutoLISP applications in IntelliCAD with little or 
no modification. IntelliCAD uses the Appload command so you can easily load LISP 
programs. IntelliCAD reads files that contain dialog control language (DCL) state-
ments as well, which makes IntelliCAD compatible with dialog boxes created for 
AutoCAD.

Using AutoCAD commands with IntelliCAD
Because IntelliCAD supports hundreds of AutoCAD commands, you use the com-
mands you already know. For example, to draw a circle, use the Circle command. To 
copy a circle, use the Copy command. 

When you press Enter or the spacebar, you activate the command—just like in Auto-
CAD. IntelliCAD accepts the special characters used by AutoCAD, such as point fil-
ters (for example, .xy), relative coordinates (the @ symbol), and the apostrophe (the ‘ 
prefix) for transparent commands. IntelliCAD function keys are also similar to those 
used in AutoCAD. 

Because you do not need to learn a new set of commands, you are immediately pro-
ductive with IntelliCAD. 
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Comparing IntelliCAD and CAD to manual drafting

IntelliCAD greatly reduces the time and effort it takes to create and revise drawings. 
Not only can you produce accurate drawings faster, you can also reuse the informa-
tion in your drawings. These are the primary reasons for making the transition to 
CAD from traditional, manual drafting on paper.

As with any tool, however, to use it effectively, you need to be familiar with some of 
the special features, functions, and concepts of CAD. If you are familiar with manual 
drafting, you’ll find some conceptual similarities in CAD as well as some differences.

Drawing to scale
In traditional, manual drafting, you usually determine the scale of the drawing before 
you even start to draw, because you are working with a sheet of paper of a fixed size. 
You may have to reduce or enlarge the entity you are drawing to fit within the con-
fines of the paper.

When you create a drawing in IntelliCAD, you draw everything full-size. You deter-
mine the type of units in which your drawing is measured. If you are drawing a build-
ing, 1 drawing unit might equal 1 inch. If you are drawing a map, 1 drawing unit 
might equal 1 mile. Your drawing environment and the CAD drawing file itself are 
not limited to the size of a particular sheet of paper. 

As you draw, you can use commands such as Pan and Zoom to work on different por-
tions of the drawing and to magnify the display of the drawing to view small details. 
These commands have no effect on the actual size of the entities in your drawing; 
they affect only the way the drawing is displayed on your screen. Only when you 
print or plot your drawing do you need to set the scale so that the printed drawing fits 
within a specific paper size.

1 drawing unit equals 1 inch. 1 drawing unit equals 1 foot.
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Using tools
In manual drafting, you use tools such as pencils, rulers, T-squares, templates, eras-
ers, and so on. When you create a drawing in IntelliCAD, you use a mouse instead of 
a pencil, and you use the mouse to select other tools—commands you select from a 
menu or a toolbar.

You use some tools to create basic entities, such as lines, circles, and arcs, and other 
tools to modify existing entities (for example, to copy or move them or to change 
properties such as color and linetype).

Organizing information
In traditional drafting, you often separate elements such as walls, dimensions, struc-
tural steel members, and electrical plans onto separate, translucent overlays. When 
you want to print the working drawings, you can create several different drawings by 
combining different overlays.

When you create a drawing in IntelliCAD, you use layers to organize elements in a 
similar manner. However, the layers feature in CAD offers numerous advantages 
over physical transparencies. The number of overlays you can combine to print a 
manually drafted drawing is limited by the printing process. There is no such limita-
tion in CAD. With IntelliCAD, you can define an unlimited number of layers, any of 
which can be visible or invisible at any time. You can name each layer and assign 
each its own color, linetype, lineweight, and print style. You can also lock individual 
layers to ensure that information on those layers isn’t altered accidentally. 

Use layers to organize drawing information.
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Drawing accurately
When you create a manual drawing, ensuring accuracy typically requires a lot of 
manual calculations and rechecking. By contrast, IntelliCAD offers a number of 
drawing aids that ensure accuracy from the start. For example, you create and modify 
entities based on an underlying Cartesian coordinate system. Every location in the 
drawing has its own x,y,z-coordinates. You can also display a grid as a visual refer-
ence to your coordinate system.     

Settings such as snap and entity snap allow you to draw accurately without specifying 
coordinates. The snap setting forces the selected points to adhere to the grid incre-
ment or to any other increment you set. Entity snaps let you snap to precise geometric 
points on existing entities—for example, the endpoint of a line or the center of a cir-
cle. Another setting, orthogonal, constrains lines so that they are drawn parallel to the 
vertical and horizontal axes.     

Every location in the drawing has its own x,y,z-coordinates within the underlying Cartesian coordinate 
system. Point 5,2,0 is 5 units to the right (along the x-axis), 2 units up (along the y-axis), and 0 units (along 
the z-axis) from the origin (the 0,0,0 point).

Paper-based drawings lack the high degree of accuracy possible when using CAD. Lines often overlap or fail 
to meet adjacent lines.
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Drawing efficiently
In paper-based, manual drafting, you often have to redraw the same entity several 
times at different scales or from different vantage points. You may also need to 
redraw the border and title block on each new sheet.

One of the most powerful features of IntelliCAD is that when you create a drawing, 
you can reuse individual entities, borders, and title blocks as often as you want. You 
need draw an entity only once; the final printed drawing can show the entity at sev-
eral different scales and viewpoints.

You usually begin drawing in model space on the Model tab, creating the drawing (a 
floor plan, a map, or a three-dimensional part) without regard to the final layout on 
paper. When you are ready to print your drawing, you have the option to switch to 
paper space on a Layout tab, where you lay out the drawing as you want it to appear 
on a sheet of paper. For example, you can insert a drawing file that contains the stan-
dard border and title block that you created. You can define and arrange multiple 
views of the drawing at appropriate scales and with specific portions visible or invisi-
ble—again, without having to redraw the border and title block for each view. 

Snap and entity snap force the cursor to adhere to a specified increment or attach to key geometric points on 
existing entities. You can also constrain lines to vertical and horizontal axes.
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You create the basic drawing in model space on the Model tab.

When you’re ready to print or plot your drawing, you can switch to paper space on a Layout tab, where you provide a 
layout of the drawing as you want it to appear on a sheet of paper.
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Reusing CAD drawings and entities
When you create a paper drawing manually, you can draw repetitive symbols by trac-
ing a plastic template. After you draw a symbol in IntelliCAD, you can reuse that 
symbol without having to redraw it. You simply save the symbol as a block. You can 
then insert copies of that block anywhere in your drawing. You can also save the 
symbol as a separate drawing for use in other drawings.  

In addition, you can reuse entire drawings and insert individual drawings into other 
drawings. You can also use an external reference, which acts as a pointer to another 
drawing rather than a copy of the entire drawing. Using an external reference has an 
added advantage: when you update the externally referenced drawing, each drawing 
that references it can be automatically updated.

You can draw a symbol one time, save it as a block, and then insert multiple copies of that symbol anywhere 
in your drawing.
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Making changes
To make changes to a paper drawing, you erase and then redraw. With IntelliCAD, 
you use commands to modify entities in the drawing. You can move, rotate, stretch, 
or change the scale of entities. When you want to remove an entity, you can delete it 
with a single click of the mouse. If you make a mistake while creating or modifying 
your drawing, you can easily reverse your actions.    

Working with other data and programs
Traditional paper drawings serve only as a means of communicating information 
between the person who created the drawing and the person viewing the drawing. The 
drawings contain no more information than what is visually imparted by the creator 
and seen by the viewer.

IntelliCAD offers rich possibilities for analyzing drawings and attaching additional 
data to them. For instance, although it may be impractical to count entities in a com-
plex paper drawing, this task is simple in CAD. IntelliCAD can calculate the number 
of entities in a drawing and compute area and distance.

CAD drawings can also contain information in addition to visible entities. You can 
attach invisible database information to visible drawing entities and extract the infor-
mation for analysis in a database or spreadsheet. (Working with information in a data-
base requires a program from a third-party vendor, or you can create your own means 
of exporting the data in LISP or SDS. Or, you can also use VBA.)

IntelliCAD provides in-place editing of Microsoft® objects, such as those created in 
Microsoft® Word and Microsoft® Excel software programs. In-place editing makes it 
easy to share data with other users and programs. For example, you can include Intel-
liCAD drawings in files created using Microsoft® Word, and you can insert files cre-
ated using Microsoft® Word into your IntelliCAD drawings.

You can easily change an entity using commands such as move, rotate, stretch, and scale instead of 
redrawing the entity.
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Using advanced CAD features

In addition to being compatible with AutoCAD, IntelliCAD goes several steps further 
by providing you with innovative features to increase your productivity.

Using IntelliCAD’s Explorer
The IntelliCAD’s Explorer has an interface similar to the Windows Explorer, allow-
ing you to view and manage the elements of multiple, open drawings, such as layers, 
blocks, linetypes, views, user coordinate systems, materials, text styles, and more. 

Editing multiple documents simultaneously
With IntelliCAD, you can open and edit multiple drawings simultaneously. You can 
also copy and paste elements between open drawings. 

Editing multiple entities
IntelliCAD allows you to change most of the properties of all selected entities using a 
single, tabbed dialog box. 

Using the CUI dialog box
IntelliCAD has a single dialog box for changing ribbon tabs (if your IntelliCAD ver-
sion supports them), toolbars, menus, keyboard shortcuts, and command aliases. You 
can also use the drag-and-drop method to customize these user interface items. The 
simple, point-and-click action lets you easily create new items and keyboard short-
cuts—no programming or manual text editing required.

Performing unlimited undo and redo
IntelliCAD increases your power with unlimited undo and redo of editing actions.
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Getting more information

In addition to the IntelliCAD documentation, much of the assistance you need as you 
use IntelliCAD is specific to the commands you work with on the screen. To obtain 
immediate information as you work, use these additional sources of information:

• Tooltips — To find out what a specific tool on a toolbar does, pause the cursor 
over it for a moment. A ToolTip appears on the screen.

• Status bar — To find out more detailed information about a tool when you pause 
the cursor over it, look on the status bar at the bottom of the screen.

• Online help — IntelliCAD online help is available on the screen when you press 
F1, choose a command from the Help menu, or click the question mark in a dialog 
box. The online help also presents information that does not appear in this manual, 
including a programming reference that describes how to program in TX/IRX, 
LISP, DCL, SDS, and DIESEL. The programming reference also describes pro-
gramming in VSTA and VBA.

Working with sample drawings

With the IntelliCAD program, you can create a variety of drawings, including two-
dimensional architectural drawings, electrical schematics, and mechanical drawings. 
Viewing and working with sample files can be an easy way to quickly learn how to 
use various IntelliCAD features.

To access the sample files
• Choose File > Open, and then open the Samples folder. 
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New in IntelliCAD 12

New in IntelliCAD 12.1

Performance
• Improved performance when using the OpenGL ES graphics device and panning 

and zooming drawings containing 3D solids.

Working with files
• For IntelliCAD versions that support working with BIM files: 

• Specify the IFC4 or IFC4x3 schema when exporting to .ifc files.

• Set display properties for AEC styles.

Blocks
• Use the Block Editor command to create and edit advanced blocks using parame-

ters, actions, and visibility states.

• Use the Edit Attributes (Single) command to edit the value, text settings, and prop-
erties of each attribute in a block reference.

User interface
• Increase the displayed list of recently used files up to 50 files.

• Drag a .dwg file from Windows File Explorer to a tool palette to add it as a block 
on the tool palette.

• Right-click a drawing file tab to quickly access window tools.

• Click and drag the border of a model space viewport to resize it.

• Toggle the display of the printable area boundary in paper space.

Printing
• Load and save print stamp setting (.pss) files.

• Use print preview for .pc3 printers.

System variables
• ACTIVATEONMOUSEOVER, PSPACEMARGINS, and TEXTALLCAPS.

• SELECTIONEFFECTCOLOR default is now 7.

• NFILELIST default is now 9.

• Updated: CMDECHO and TEXTEVAL.

New in IntelliCAD 12.0

Performance
• Increased speed of opening drawings that contain many blocks or external refer-

ences.
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• Improved zoom and pan performance for drawings with a large number of entities 
and for drawings with geometry far from the origin.

• Faster zooming to extents and copying and pasting entities.

• Faster drawing of lines, panning, copying entities, and switching layouts when 
using the OpenGL ES graphics device.

• Improved scaling performance with blocks.

• Decreased memory usage when opening and closing drawings while using the 
OpenGL graphics device.

Working with Files
• Specify a coordinate system when importing map data from SDF, SQLITE, or 

SHP files.

• Export tables to .csv files.

• Import and export Facet Modeler Binary (.fmb) files.

• For versions that don't include ACIS, import entities as meshes from STEP and 
IGES data files.

• For IntelliCAD versions that support working with BIM files: 

• Select which entities to import from .ifc files and specify import options.

• Include .rvt and .ifc underlays when exporting to .ifc files.

• Attach roof and ceiling plane symbols to walls and reference them while inter-
actively creating roof and ceiling planes using the Plane Solve command.

• Assign levels to AEC entities. Levels contain default settings for bottom and top 
elevations, wall height, on/off status, lock/unlock status, freeze/thaw status, 
offset, and other settings for walls and plane symbols.

• Customize AEC styles for walls, doors, windows, curtain walls and curtain wall 
units, stairs and railings, and slabs.

User interface
• Double-click an entity to display the Quick Properties pane for modifying proper-

ties that are used most often for the entity type. Use the Drawing Settings > Quick 
Properties tab to change the behavior of the Quick Properties pane. Use the Cus-
tomize User Interface command to determine which entity types and properties are 
enabled to use with the Quick Properties pane.

• Use the Customize User Interface command to create and edit legacy image tile 
menus.

• Click the down arrow at the right end of the Layout tab row in the drawing win-
dow to display and choose from a list of Layout tabs.

• Use the new Startup dialog when the STARTUP system variable is set to 1.

• Use Diesel expressions when customizing the ribbon.
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Selecting and modifying entities
• Use the Geometric Center snap to find the centroid of any closed polyline or 

spline.

• Trim all entities to the edge of a cutting entity in a single operation using the 
Quick Trim command.

• Use the Copy Multiple command to copy entities using multiple options.

• Preview modifications when using the Offset, Trim, and Extend commands.

Splines
• Draw splines using control vertices and knot parameterization. Choose Undo to 

erase the previously specified point.

• Choose Join when using the Edit Spline command to combine a selected spline 
with other splines, lines, polylines, or arcs.

Layers
• Use the Layer Isolate VP Freeze command to freeze the layers of selected entities 

in all layout viewports except the current viewport.

• Use the Viewport Layer command to freeze and thaw layers, and also use it from 
the Model tab.

• Control whether entities on layers can be cut by section planes

Tables
• Create and update tables from extracted drawing data.

• Remove formatting overrides from table cells.

• Specify border properties and apply borders to table cells.

Blocks
• Globally edit attribute text associated with blocks using the Global Edit Attributes 

command.

• Use the Rename Block command to create a new block by renaming a single block 
instance.

• Use the Change Block command to change the name of a single block instance 
and then modify it in the Block Editor.

Explorer
• Manage more visual style properties using the Explore Visual Styles command.

• Manage more layout settings using the Explore Layouts command.

• Specify whether to freeze layers automatically in layouts that you create using the 
Explore Layers command.

• Manage data links using the Explore External References command. 
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• Change the column order, visibility of columns, and restore the default display of 
columns in all Explorer panes.

3D modeling
• Use the Project Geometry command to create a projection of lines, curves, or 

points on a three-dimensional solid, surface, or region.

• Use the Show CV and Hide CV commands to display or hide the control vertices 
of selected NURBS surfaces and curves.

• Specify display settings for section planes.

Printing and publishing
• Import page setups from other drawings.

• Use presets when publishing or exporting to .pdf files.

• When publishing or exporting solid fill hatches to .pdf files, choose the Polygon 
option to generate an outer loop by the vectorizer using polygons and then fill it 
with the appropriate color.

• When using the Publish command, manage layer states by choosing Layer States 
Manager in the Layer States column.

More features
• Create reports and report templates using the Extract Data command.

• Use the Super Hatch command to hatch an area using a selected image, texture, 
block, external reference, or wipeout.

• Use the Frames command to show or hide the frames of all images and wipeouts.

• Preview modifications when editing hatches.

• View misspelled words and choose from suggested spellings when using the Edit 
Text command. 

• Use the Set Z All command to change the z-coordinates of all entities contained in 
a drawing.

• Zoom using a mouse wheel while simultaneously panning with a mouse wheel.

• Access many new .NET classes, methods, and properties.
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System variables
• COMMANDPREVIEW, FMDEVIATION, MILLISECS, 

PRINTERCONFIGDIR, PRINTMINPAGEMARGIN, 
PRINTPDFUNDERLAYTRANSPARENCY, QPLOCATION, QPMODE, 
SELECTLOCKEDLAYER, SPLDEGREE, SPLKNOTS, SPLMETHOD, 
SPLPERIODIC, SURFACEAUTOTRIM, VPSCENEAMBIENTCOLOR, and 
VPUSESCENEAMBIENTCOLOR.

• GSDEVICEMODE default is now 3.

• Updated: MTEXTFIXED.

• Environment system variables: PrinterConfigDir and PrinterStyleSheetDir.
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Getting started

This section helps you get started using IntelliCAD software by explaining how to 
install it and providing basic information about how to use it.

This guide assumes that you have working knowledge of Windows-based programs.
If necessary, see the documentation that came with your operating system for infor-
mation about Windows terminology and techniques.
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System requirements

You need the following software and hardware to install and run IntelliCAD: 

• Microsoft® Windows® 11, Windows 10, and Windows 8 on a 64-bit computer

• 1 GHz or faster processor

• 4 gigabytes (GB) of RAM minimum

• 2.5 gigabytes (GB) of free hard disk space recommended for typical installation

• 1024 x 768 VGA or higher resolution, video adapter, and monitor

• Graphics card compatible with OpenGL Version 1.4 or higher

• Keyboard and mouse, or other pointing device

• CD-ROM or DVD drive for installation, if installing from a CD or DVD

• Internet access, if downloading and installing from the Internet

For digitizer tablets, IntelliCAD requires a 64-bit wintab-compatible driver installed.



G E T T I N G  S T A R T E D 21
Installing IntelliCAD

A setup program guides you through the IntelliCAD installation process. The pro-
gram transfers files to a folder that it creates on your hard disk. The program also cre-
ates a menu item on the Start menu.

Installation starts automatically after you insert the IntelliCAD compact disc into 
your CD-ROM drive. If installation does not start, you can install IntelliCAD by 
using the following procedure.

To install IntelliCAD from a compact disc
1 Insert the IntelliCAD compact disc into your CD-ROM drive.

2 Do one of the following:

• Wait for the autorun feature to start.

• Choose Start > Run and in the Open field, type d:\setup, where d is the letter 
assigned to your CD-ROM drive. Click OK.

3 Follow the instructions on your screen.

Some IntelliCAD versions may not come with a compact disc. 
For example, if you downloaded the program from the Internet, follow the instruc-
tions that came with the program.
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Starting IntelliCAD

To start IntelliCAD, choose Start > All Programs > ITC > IntelliCAD (may vary, 
depending on your operating system).

Each time you start IntelliCAD, the Start Page displays on your screen (unless on the 
Start Page you have marked Skip Start Page Next Time). Use the Start Page to 
quickly open drawings, create new drawings, and send feedback about the program.

The Recent Document list on the Start Page is customizable. 
Right-click an item in the Recent Document List and choose whether to move the item 
to the top of the list, delete it from the list (the document itself is not deleted), or copy 
its path. You can also choose whether single- or double-clicking a filename or thumb-
nail image opens the corresponding drawing.

For versions of IntelliCAD that don’t have a Start Page, the program opens a new, 
blank drawing based on a default template, icad.dwt. Using a template as the basis for 
a new drawing has several advantages: 

• You can use predetermined units of measure, grid settings, text heights, and other 
settings appropriate for the type of drawing you’re creating.

• You can predefine special layers.

• You can predefine the type of print style table.

• You can include predefined title blocks and borders.
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Working in IntelliCAD

You can work with the IntelliCAD window and its elements in a variety of ways. For 
example, you can display and rearrange tool palettes, the toolbars, display the com-
mand bar, and enable the status bar. The toolbars and command bar can also be 
floated anywhere on the screen or docked to the edges of the main IntelliCAD win-
dow. 

Use a shortcut to turn window elements on or off all at once.
When multiple window elements are enabled, the size of the drawing window is 
reduced, which can limit how much drawing data can be displayed. If you want more 
screen space dedicated to drawing, simply choose Clean Screen On/Off in the status 
bar. The window elements will hide until you choose the toggle again.

Displaying file tabs for drawings
Multiple drawings can be open at the same time. By default, each drawing displays its 
own tab. Select a tab to switch the active drawing.

To toggle the display of file tabs for drawings
1 Do one of the following:

• On the ribbon, choose View > File Tabs (in Display)

• On the menu, choose View > File Tabs.

• Type filetab or filetabclose and then press Enter.

Open drawings can also be arranged side by side.
For more details about viewing drawings, see “Working with multiple drawings” on 
page 246. 

Displaying commands on a shortcut menu
Shortcut menus provide quick access to specific commands. A shortcut menu dis-
plays when you right-click an entity, toolbar, status bar, the Model tab name, or a 
Layout tab name. The selections presented in the shortcut menu depend on what you 
right-clicked.      

When you right-click the drawing, you can choose from a wide range of commands, 
including recently used commands. When you right-click a toolbar, the program dis-
plays a shortcut menu that lets you toggle the command bar, status bar, and various 
toolbars on and off. If you select one or more entities and then right-click, the pro-
gram displays a shortcut menu from which you can choose a command to modify the 
selected entities. To display a shortcut menu from which you can choose an entity 
snap, press and hold down the Shift key, and then right-click anywhere within the 
drawing window.
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Displaying and hiding the ribbon 
The ribbon contains several areas from which to choose commands:

• Application button — The Application button in the upper left corner contains 
file-related commands, such as New, Open, Import, Export, and more.

• Quick Access toolbar — Contains commonly used commands. Click the Quick 
Access toolbar down arrow to choose which commands display and to customize 
various visual elements of the drawing window.

• Tabs — Contains related commands grouped together, for example, on the tabs 
named Home, Edit, Draw, etc.

• Panels — Contains sub-categories of commands within a tab, for example Draw, 
Modify, and Layers on the Home tab.

To customize the Quick Access toolbar
1 To add a command to the Quick Access toolbar, right-click the command in the 

ribbon, then choose Add to Quick Access Toolbar.

2 To remove a command from the Quick Access toolbar, right-click the command to 
delete, then choose Remove from Quick Access Toolbar. 

To customize a tab in the ribbon
1 Right-click anywhere in the tab of the ribbon you want to customize.

2 Do one of the following:

• Choose Show Tab, then choose the tabs you want to display or hide.

• Choose Show Panel, then choose the areas that you want to display or hide for 
that tab.

A Click the Application button to view and select 
file-related commands.

B Displays groups of commands in panels.
C Click to lock the expanded panel open.
D Click to expand the panel to show additional 

commands below it.

E Click to expand the panel and view related 
commands below.

F Click a tab to view different commands.
G Click a tool on the Quick Access Toolbar. You 

can also click the arrow on the right to choose 
additional options.
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The ribbon can be customized in other ways.
You can use the Customize UI command or manually edit the .cui file for the rib-
bon. For more details, see “Customizing the ribbon” on page 879. Also see 
“Working with user interface customization files” on page 916.  

To minimize the ribbon
1 Do one of the following:

• Double-click the name of a ribbon tab.

• Click the down arrow on the Quick Access toolbar, then choose Minimize the 
Ribbon.

To show both the ribbon and menus at the same time
1 Right-click anywhere in the ribbon.

2 Choose Menu Bar.

To hide the ribbon
1 Do one of the following:

• Right-click anywhere in the menus or ribbon, then choose Switch to Menu Bar. 
This hides the ribbon and displays the menus instead.

• Type ribbonclose and press Enter to hide the ribbon only.

To display the ribbon
1 Do one of the following:

• Right-click a menu or any toolbar, then choose Switch to Ribbon.

• Type ribbon and press Enter.

When using the ribbon, switch between drawings using file tabs or using the status bar.
Click a drawing’s file tab to display the drawing. If file tabs are not visible, type 
filetab and press Enter. You can also switch between drawings using Show Window 
Menu on the status bar.

Workspaces also can control the ribbon.
The IntelliCAD Classic workspace shows toolbars and the Drafting and Annotation 
workspace shows the ribbon. For more details about workspaces, see “Using work-
spaces” on page 33 in this chapter. 

Ribbon display can also be affected by Clean Screen On/Off on the status bar.
To control whether the ribbon is included when you click Clean Screen On/Off on the 
status bar, right-click the icon and mark or unmark Ribbon.



26 C H A P T E R  2
Displaying and hiding the Tool Palettes pane 
The Tool Palettes pane displays groups of organized commands and blocks for easy 
selection. 

The Tool Palettes pane can be either docked or floating. A floating pane has a Close 
box and options along the right, can be located anywhere on the screen, and can be 
resized. A docked pane has a title bar, a Close button in the upper right only when the 
cursor moves over it, cannot be resized, and is attached along one of the edges of the 
drawing window.

To display the Tool Palettes pane
1 Do one of the following:

• On the ribbon, choose View > Tool Palettes (in Display).

• On the menu, choose View > Display > Tool Palettes.

• Right-click a ribbon tab (if your version has a ribbon), toolbar, or menu and 
choose Tool Palettes.

• Type toolpalettes and press Enter.

A Click a palette to show its commands. Right-click 
for more options.

B Double-click to dock the pane. Right-click for 
more options.

C Click and drag to move the pane to a new 
location. Right-click for more options.

D Click to scroll the list of commands. Right-click 
for more options.

E Click a tool to start its command. Right-click for 
more options.

F Click to display a menu of options: close, 
dockable, fix to left, fix to right, autohide, and 
transparency.

G Click to auto-hide the pane.
H Click to close the pane.
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To close the Tool Palettes pane
1 Do one of the following:

• On the ribbon, choose View > Tool Palettes (in Display).

• On the menu, choose View > Display > Tool Palettes.

• On the Tool Palettes pane when it is undocked, click ( ) in the upper right 
corner.

• Right-click a ribbon tab (if your version has a ribbon), toolbar, or menu and 
choose Tool Palettes.

• Type toolpalettesclose and press Enter.

The display of tool palettes can be affected by other commands too.
To control whether tool palettes are included when you click Clean Screen On/Off on 
the status bar, right-click the icon and mark or unmark Tool Palettes.

To display or hide multiple items at once — tool palettes, drawing tabs, the ribbon 
and quick access toolbar (for versions that have a ribbon) — type showpalettes or 
hidepalettes in the command bar.

To auto hide the Tool Palettes pane
1 Do one of the following:

• Right-click the Tool Palettes pane title bar and choose Auto Hide.

• On the Tool Palettes pane when it is undocked, click Auto Hide ( ).

• On the Tool Palettes pane when it is undocked, click the menu ( ), and choose 
Auto Hide.

To move the Tool Palettes pane
• Click and drag the title bar of the Tool Palettes pane to the desired location in the 

drawing window.

To dock or undock the Tool Palettes pane
1 On the Tool Palettes pane when it is undocked, click the menu ( ), and choose 

Dockable if it is unchecked.

2 Do one of the following:

• Double-click the title bar of the Tool Palettes pane to dock or undock it.

• Drag the Tool Palettes pane title bar to the far right or left of the drawing 
window to dock it, or drag it to a different area of the drawing window to undock 
it.

• On the Tool Palettes pane when it is undocked, click the menu ( ), and choose 
Fix to Left to dock the palette on the left side of the drawing window, or choose 
Fix to Right to dock the palette on the right side.
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Tool palettes are customizable.
You can change the transparency of the Tool Palettes pane; add, delete and rear-
range tool palettes; and add new customized commands and blocks. For more 
details, see “Customizing tool palettes” on page 864. 

Displaying and hiding menus
Related commands are grouped together on menus. You can use the menus with or 
without the ribbon. 

To customize the display of menus
1 Right-click anywhere in the menus or ribbon.

2 Choose Show Menu, then choose the menus you want to display or hide.

There are more ways to customize menus.
You can use the Customize UI command or manually edit the .mnu file for the 
menus. For more details, see “Customizing menus” on page 869. Also see “Work-
ing with user interface customization files” on page 916. 

To display or hide menus when using the ribbon
For IntelliCAD versions that have a ribbon. 

1 Right-click anywhere in the menus or ribbon.

2 Choose Menu Bar.

Menu display can also be affected by Clean Screen On/Off on the status bar.
To control whether menus are included when you click Clean Screen On/Off on the 
status bar, right-click the icon and mark or unmark Menu Bar.
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Displaying and hiding toolbars
When you start IntelliCAD the first time, multiple toolbars are displayed. IntelliCAD 
provides more than a dozen toolbars, which you can customize by adding and delet-
ing tools. You can also move and resize toolbars, and you can create new toolbars. 
You can use a shortcut menu to display or hide toolbars and to lock or unlock toolbar 
locations. 

Toolbars are displayed large or small. You can choose to display or hide tooltips, 
which provide descriptions of tools that display when you pause the cursor over them. 
Go to View > Toolbars to make these selections.

Toolbars are either docked or floating. A floating toolbar can be located anywhere on 
the screen and can be resized. A docked toolbar cannot be resized and is attached 
along one of the edges of the drawing window. 

• To dock a toolbar, drag it to the perimeter of your drawing; to undock it, drag it 
away from the perimeter.

• To position a toolbar in a docking area without docking it, press Ctrl while you 
drag it.

• To move a toolbar, drag it to a new location.

• To resize a toolbar, move your cursor to the edge until it changes to a resize arrow, 
and then drag.

• To lock toolbars in their current locations, right-click the head of any toolbar or 
menu, then choose Lock Location > Floating Toolbars and/or Docked Toolbars.

To choose which toolbars to display
1 Do one of the following:

• On the ribbon, choose View > Toolbars (in Interface).

• On the menu, choose View > Toolbars.

• Right-click anywhere on a visible toolbar (docked, undocked, or the toolbar area 
at the top of the window) to display the toolbar shortcut menu, and then choose 
Toolbars. You can also select the toolbars you want displayed directly on the 
shortcut menu.

• Type toolbar or tbconfig and then press Enter.

2 In the Toolbar Settings dialog box, mark the toolbars you want displayed, and then 
click OK.
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Toolbar display can also be affected by Clean Screen On/Off on the status bar.
To control whether all chosen toolbars are included when you click Clean Screen On/
Off on the status bar, right-click the icon and mark or unmark Toolbars.

Using the command bar
The command bar is a dockable window in which you type IntelliCAD commands 
and view prompts and other program messages. By default the command bar displays 
the three most recent lines of prompts, but you can extend the window to display 
more lines. Move or resize the command bar by dragging it.

To display or hide the command bar
• On the ribbon, choose View > Command Bar (in Display).

• On the menu, choose View > Display > Command Bar.

• Type cmdbar, then choose Toggle.

• Press Ctrl+9.

A Select the menu group that contains the toolbar 
you want to modify.

B Mark to display a toolbar; clear to hide the 
toolbar. 

C Select to display large tools; clear to display 
small tools.

D Select to display tooltips when you hover over 
tools on the toolbar; clear to not display tooltips.

E Highlight the toolbar name that you want to 
rename or delete.

F Click to open the Customize User Interface 
dialog box and customize toolbars.

G Click to delete the selected toolbar (does not 
delete all checked toolbars).

H Click to type a new name for the selected toolbar 
(does not rename all checked toolbars).

A

C

E

G
H

D

FB
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Command bar display can also be affected by Clean Screen On/Off on the status bar.
To control whether the command bar is included when you click Clean Screen On/Off 
on the status bar, right-click the icon and mark or unmark Command Bar.

When the command bar is docked or floating, you can drag the top or bottom of the 
window to change the number of lines of text it displays. You can dock the command 
bar at the top, bottom, left, or right of the drawing. You can auto-hide and auto-dis-
play the command bar in its current location by clicking its pin button. 

Colors of command bar items can be customized. 
To change the color of various parts of the command bar, use the Options command. 
For details, see “Setting colors of the main window” on page 840. 

When you type in the command bar, IntelliCAD suggests names of matching com-
mands as you type. The suggested names appear in an AutoComplete window. Sim-
ply select the desired command in the list. In addition to command names, 
suggestions can include names of external commands, system variables, aliases, and 
LISP functions. 

To turn on AutoComplete for typing in the command bar
1 Do one of the following:

• On the menu, choose View > Display > AutoComplete.

• Right-click the command bar and then choose AutoComplete.

• Type autocomplete, press Enter, then choose AutoComplete.

• Choose Tools > Options, click the Display tab, then mark Enable 
AutoComplete.

When turned on, the AutoComplete window automatically displays when you type in 
the command bar, and then automatically closes when you activate a command.

For more details about customizing settings for the AutoComplete window, see “Cus-
tomizing how suggestions display in the command bar” on page 834. 
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Using the status bar
If you elect not to use the command bar, the status bar displays information about the 
selected command or tool. It also displays the current cursor coordinates, the name of 
the current layer, mode settings, and other information about current settings.

In addition to displaying information, the status bar is a quick way to access many 
features. You can click status bar items to make changes, and right-click items to dis-
play short-cut menus that allow you more choices.          

To change the items that display on the status bar
1 Right-click an empty area of the status bar.

2 Select an item to add or remove it.

To change the setting of an item on the status bar
1 Do one of the following:

• Double-click the status bar item.

• Right-click the status bar item you want to change, and then select the desired 
setting.

To display or hide the status bar
1 Do one of the following:

• On the ribbon, choose View > Status Bar (in Display).

• On the menu, choose View > Display > Status Bar.

• Type statbar and then press Enter.

Using view and visual style controls
The view and visual style controls display in the upper-left corner of the current 
viewport and allow you to easily apply a different view and visual style to the model. 

To display or hide the view and visual style controls
1 Do one of the following:

• On the ribbon, choose View > View Control (in Interface).

• On the menu, choose View > Display > View Control.

• Type vpcontrol, press Enter, then type on or off, and press Enter.

To use the view control
• From the list of views, choose the one you want to apply to the model.

For more details about named views, see “Creating and switching to named 
views” on page 690. 
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To use the visual style control
• From the list of visual styles, choose the one you want to apply to the model.

The list of visual styles depends on your graphics device. For more details, see 
“Customizing graphics device options for display performance” on page 846. 

Using prompt boxes
IntelliCAD commands often provide several options. These options appear in the sta-
tus bar or command bar and can also optionally appear in a prompt box (called a con-
text menu in AutoCAD) initially displayed in the upper right corner of the screen. 
You can move the prompt box by dragging it; future prompt boxes will appear where 
you last placed it. The options appear as menu selections. Choose the appropriate 
option by selecting it in the prompt box. To close a prompt box, click the Close box.   

The prompt box is hidden by default. To turn on the display of prompt boxes, choose 
Tools > Options, click the Display tab, and then click the Display Prompt Boxes 
check box.    

Using workspaces
Workspaces are a convenient way to customize the display of commands in the Intel-
liCAD main window. Each workspace stores visibility settings for the following:

• Menus — Visibility settings are saved for each top-level menu (for example, the 
Draw menu) and each nested menu (for example, the Draw > Arc submenu).

• Toolbars — Visibility settings are saved for each toolbar, its orientation at the top, 
bottom, left, right, or floating, number of button rows, x-coordinate, and y-coordi-
nate.

• Ribbon — For IntelliCAD versions that have a ribbon, visibility settings are saved 
for whether the ribbon itself displays, along with visibility settings for each ribbon 
tab (for example, the Home tab) and each panel (for example, Home > Modify).

Command options appear in a prompt box.
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Use a shortcut to make more space for drawing in the IntelliCAD main window.
Click Clean Screen On/Off on the status bar to hide multiple user interface items at 
the same time. To customize what hides (or displays), right-click the icon and make 
your selections for the next time you click the icon.

To create a workspace
1 Organize the menus, toolbars, and ribbon the way you want them.

2 Do one of the following to choose Save Workspace ( ):

• On the ribbon, choose Tools > Save Workspace (in Manage).

• On the menu, choose Tools > Save Workspace.

• On the status bar, click Switch Between Workspaces, then choose Save Current 
As.

• Type wssave, press Enter.

• Type workspace, press Enter, then choose SaveAs.

3 Enter the name of the new workspace.

4 Click OK.

To save the current visibility settings to an existing workspace
1 Organize the menus, toolbars, and ribbon the way you want them.

2 Do one of the following to choose Save Workspace ( ):

• On the ribbon, choose Tools > Save Workspace (in Manage).

• On the menu, choose Tools > Save Workspace.

• On the status bar, click Switch Between Workspaces, then choose Save Current 
As.

• Type wssave, press Enter.

• Type workspace, press Enter, then choose SaveAs.

3 Select an existing workspace name from the list.

4 Click OK.

To switch to a workspace
1 Do one of the following:

• On the ribbon, choose the desired workspace from the Workspaces list ( ).

• On the status bar, click Switch Between Workspaces ( ), then choose the 
desired workspace.

• On the Workspaces toolbar, choose the desired workspace.

• Type workspace, press Enter, choose Set Current, then enter the name of the 
desired workspace.
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The My Workspace tool (Workspaces toolbar) loads a specific workspace.
Click the My Workspace tool ( ) to switch to your preferred workspace. To set 
which workspace loads when you click the My Workspace tool, click ( ) on the 
status bar, choose Workspace Settings, then choose the workspace in My Work-
space.

 Selecting commands

Select commands using any of these methods:

• Choose a command from the ribbon.

• Choose a command from a menu.

• Click a tool in the Tool Palettes pane.

• Click a tool in a toolbar.

• Type the command in the command bar.

Some commands remain active until you end them, so you can repeat an action with-
out having to select a command repeatedly. You can end a command by pressing Esc.

Using commands
You can use most commands while another command is active. For example, while 
drawing a line, you may want to use the Pan command to move the drawing across 
the screen to select the endpoint of the line. You can also change the settings of draw-
ing aids such as snap or grid while other commands are active.

After started, many commands have options that you can select in the command bar, 
status bar, or prompt box. 

Starting commands using the ribbon
To start a command from the ribbon, choose it from the list of options available. If a 
command has an arrow, click the arrow to see related commands. For example, 
choose Home, then click the arrow for Array (in Modify) to choose the 3D Array 
command.

Starting commands using tool palettes
To start a command from a tool palette, click a tool and respond to the prompts. 

If the palette contains several tools, you might need to use the scroll bars to see the 
full list of available tools for that palette.
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Starting commands using toolbars
To start a command from a toolbar, click a tool and respond to the prompts. 

The available toolbars depend on the experience level that is set. 
To change the current experience level, choose Tools > Options, and then click the 
General tab.

Some tools, such as Line or Arc, contain flyouts, which are options either for using 
the basic tool with different methods or that contain other, related tools. Flyouts are 
indicated by a small triangle in the lower right corner of a tool. To display a flyout, 
click the tool and hold down the mouse button. To select a tool from a flyout, point to 
the tool you want and then release the mouse button. The tool you select on the flyout 
becomes the default tool on the toolbar.

Starting commands using menus
To start a command from a menu, choose it from the list of menu options available.

The available menu options depend on the experience level that is set. To change the 
current experience level, choose Tools > Options, and then click the General tab.

Starting commands using the command bar
Type a command, and then press Enter. If the command bar is displayed, the com-
mand you typed appears there. If the command bar is not displayed, the command 
you typed appears in the status bar.

Quickly start commands using the command bar by copying, cutting, and pasting text. 
In the command bar or Prompt History window, right-click to select various cut, 
copy, and paste commands.

Repeating a command
You can repeat a command you used previously without having to reselect it. 

To repeat the command you just used
1 Do one of the following:

• Press the spacebar.

• Press Enter.

• Click the right mouse button in the drawing.
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To repeat commands you used previously
1 Do one of the following:

• In the command bar or Prompt History window, press Ctrl and double-click the 
previous command text.

• In the command bar or Prompt History window, right-click, choose Recent 
Commands, and then choose the desired command.

• Use the Up and Down arrows to display previously used commands, if Use Up/
Down Arrows for Command History Navigation is selected in Tools > Options.

Run a command multiple times using the command bar. 
If you are using the command bar to type commands, you can type multiple before 
starting some commands (Circle, Arc, and Rectangle, for example) to repeat a com-
mand indefinitely. When you are done with a command, press Esc.

Nesting a command
If you are working in the command bar, you can use another command from within a 
command, called nesting. To use a command inside an active command, type an 
apostrophe before you type the command, such as ‘circle, ‘line, or ‘pyramid. You can 
nest commands indefinitely in IntelliCAD. Many menu and toolbar macros work this 
way by default; for example, select color, reference grid, zoom, and snap. When you 
have finished with the nested command, the original command resumes. 

Modifying a command
If you are working in the command bar, there are special ways that you can modify a 
command as you work. You can modify the active command using any of the follow-
ing options:

• Entity snaps — Type an entity snap command, such as nearest or midpoint, to 
enable a one-time entity snap for a single selection. You can also use a one-time 
entity snap to override a running entity snap.

• Extension snaps — Type int after selecting a command, such as Line or Circle, to 
enable a one-time snap to the logical location where two entities would intersect if 
they were of infinite length. Type app to enable a similar one-time snap if the 
extensions would not intersect in three-dimensional space but would intersect in 
the current view. 

• Midpoint snaps — Type m2p or mtp to enable a one-time snap to the midpoint of 
two points that you specify. 
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Using the Prompt History window
The Prompt History window displays a history of the commands and prompts issued 
since you started the current session of IntelliCAD. By default, the program tracks up 
to 256 command lines. There is no limit to the number of command lines you can 
track, but program performance may be degraded if you choose to track an exces-
sively high number of lines.

To display or close the Prompt History window 
1 Do one of the following to choose Prompt History Window:

• On the ribbon, choose View > Prompt History Window (in Interface).

• On the menu, choose View > Display > Prompt History Window.

• Type pmthist and then press Enter.

• Press F2.

To view entries in the Prompt History window 
1 Do one of the following:

• Use the scroll bars.

• Use the Up and Down arrows to display previously used commands, if Use Up/
Down Arrows for Command History Navigation is selected in Tools > Options.

To copy or paste text in the Prompt History window 
1 If copying text, do one of the following: 

• Highlight text using your mouse.

• Press Ctrl + Shift + arrow keys to highlight text.

2 Right-click and choose whether to copy or paste.

You can also copy the entire command history or the last command line.
Choose Copy History or Copy Last Line. 

To change the number of command lines to track
1 Do one of the following:

• Choose Tools > Options, and then click the Display tab.

• Type options and then press Enter. Click the Display tab.

2 In the Command Lines To Track field, type the number of command lines you 
want to display, and then click OK.
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Using mouse shortcuts
You can use your mouse, often combined with the keyboard, to start commands and 
perform other actions. 

Using keyboard shortcuts
Keyboard shortcuts are key combinations that start commonly used IntelliCAD com-
mands. The following table describes function key shortcuts, but there are many more 
shortcuts available. For a full list, choose Tools > Customize UI and choose Key-
board Shortcuts in the Current Customization list. 

Mouse shortcuts
Shortcut Action
Hold and drag left mouse button Move selected entities when not in a command

Ctrl + Hold and drag left mouse button Copy and move selected entities when not in a 
command

Ctrl + Hold and drag right mouse button Constrained Z Orbit command

Ctrl + Left-click mouse Cycle-select entities located below the cursor

Ctrl + Shift + Hold and drag left mouse button Real-Time Zoom command

Ctrl + Shift + Hold and drag middle mouse button 
(wheel)

Free Orbit command

Alt + Shift + Hold and drag middle mouse button
or
Shift + Hold and drag middle mouse button

Constrained Orbit command

Shift + Left-click mouse Deselect entities

Shift + Right-click mouse Entity snap shortcut menu

Hold and drag left mouse button Move selected entities

Right-click mouse Display shortcut menu for the selected entity

Rotate mouse wheel Zoom In and Zoom Out commands; if over the 
ribbon, scrolls ribbon tabs

Hold mouse wheel, then move mouse Real-Time Pan command

Ctrl + Rotate mouse wheel when command bar 
is active

Zoom in and out of the command bar

Function key shortcuts
Command Typed Entry Shortcut Description
Coordinate COORDINATE F6, Ctrl+D, Ctrl+I Switches coordinate display between On, Off, and Angle/

Distance. 

Entity Snap ESNAP F3, Ctrl+F Turns entity snaps on and off.

Entity Snap Tracking ENTTRACK F11 Switches entity snap tracking on and off

Exit EXIT Alt+F4, Ctrl+Q Closes all drawings and exits IntelliCAD. 

Grid GRID F7, Ctrl+G Turns the reference grid display on and off. 
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Using scripts
The IntelliCAD Script Recorder captures and saves many of your actions so you can 
play them back. After you enable the Script Recorder, all commands and options that 
you type in the command bar are recorded until you type a command to stop 
recording. When you run the script, the program carries out the recorded commands 
in succession.

Correcting mistakes

IntelliCAD tracks the commands you use and the changes you make. If you change 
your mind or make a mistake, you can undo, or reverse, the last action or several pre-
vious actions. You can also redo any actions that you reversed. 

You can undo and redo multiple actions by choosing Undo and Redo from the Quick 
Access toolbar of the ribbon to view and select a range of actions. You can also type 
undo and then specify the number of actions to undo. 

Many commands also have an Undo option that you can choose (or press Ctrl + Z) to 
undo the last action, for example, choose Undo when creating a line to remove the 
previously specified point.

Grid Snap SNAP F9, Ctrl+B Turns grid snap settings on and off. 

Help HELP F1 Starts online Help.

Isometric Plane ISOPLANE F5, Ctrl+E Switches the isometric plane between Top, Right, and Left. 

Orthogonal ORTHOGONAL F8, Ctrl+L Switches the orthogonal mode on and off.

Polar Tracking POLARTRACK F10, Ctrl+U Switches polar tracking on and off

Prompt History Window PMTHIST F2 Turns the Prompt History window on and off. 

Tablet TABLET F4 Controls the tablet configuration. 

VBA Editor VBA Alt+F11 Opens the Visual Basic for Applications editor so that you 
can create or modify a VBA macro.

Window Close WCLOSE Ctrl+F4 Closes the active drawing window.

Function key shortcuts
Command Typed Entry Shortcut Description

A Click Undo to reverse the last action.
B Click Redo to reverse the previous undos.

A B
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Customizing IntelliCAD

You can tailor many aspects of IntelliCAD to better suit your needs. For example, 
you can easily create and modify menus using the Customize User Interface (cui) 
command or create and modify toolbars by simply dragging and dropping icons. 
IntelliCAD stores your customized settings in a .cui file; you can also store them in a 
profile.

IntelliCAD supports the most important AutoCAD customization files, including 
linetypes, hatch patterns, text fonts, the unit conversion file, menus, toolbars, and 
aliases. In addition, IntelliCAD unifies many AutoCAD customization functions with 
a single cui command: command aliases, menus, toolbars. keyboard shortcuts, and 
double-click actions. And for versions of IntelliCAD that have a ribbon, this list for 
the cui command also includes ribbons, quick access toolbars, application buttons, 
and contextual menus. For more details about customizations, see Chapter 17, 
“Customizing IntelliCAD.” 

You can also add custom programs written in any of several programming languages, 
including the following:

• ODA SDKs and IRX (similar to the Autodesk® ARX language)

• LISP (the program’s Autodesk® AutoLISP-compatible language)

• SDS (similar to the Autodesk® ADS language)

• DCL (Dialog Control Language)

• DIESEL

• Microsoft® Visual Basic for Applications (VBA)

• .NET

For more details about custom programs, see “Programming IntelliCAD” on page 
944. 

Migrating customizations from a previous IntelliCAD version
Customizations that you made in a previous IntelliCAD version can be easily 
migrated to your IntelliCAD current version. You can merge or replace custom 
settings made to workspaces and customization files (.cui files), including menus, the 
ribbon if your version supports it, toolbars, keyboard shortcuts, aliases and double-
click actions. 
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To migrate customizations from a previous IntelliCAD version
1 Use one of the following methods to choose Migrate UI ( ):

• On the ribbon, choose Tools > Migrate UI (in Manage).

• On the menu, choose Tools > Migrate UI.

• Type migrate and then press Enter.

2 Enter the file path and filename of the .cui file that contains the customization you 
want to migrate to the current IntelliCAD version. If necessary, type ? and press 
Enter to see a list of available .cui files.

3 Choose one of the following:

• Replace with given — Replaces the current customization entirely with the one 
from the selected .cui file.

• Merge prefer given — Merges customizations with a preference to the previous 
installation if conflicts occur.

• Merge prefer current — Merges customizations with a preference to the current 
installation if conflicts occur.

Getting online Help

IntelliCAD includes online Help, which contains task-oriented topics, a command 
reference, a system variables reference, and a programming language reference.

You can display online Help ( ) in any of these ways:

• On the ribbon, choose Help, then choose a command.

• On the Standard toolbar, click Help.

• Press F1.

• Choose a command from the Help menu.

• Click the question mark in a dialog box.

• Type help in the command bar.
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Saving a drawing

You can save your drawing at any time.

Use one of the following methods to choose Save ( ):

• On the Quick Access toolbar of the ribbon, click Save.

• On the ribbon Application button, choose Save.

• On the Standard toolbar, click Save.

• On the menu, choose File > Save.

• Type save and then press Enter.

When you save a drawing the first time, the program displays the Save Drawing As 
dialog box so that you can choose a directory and type a name for the drawing. To 
save the drawing later using another name, do the following:

• Choose File > Save As and type the new name.

Exiting IntelliCAD

When you have finished working in IntelliCAD:

• On the ribbon Application button, choose Exit.

• On the menu, choose File > Exit. 
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Working with drawings

CAD drawings help you organize information for greater efficiency. With Intelli-
CAD, you can draw entities representing different types of information on various 
layers and use those layers to control color, linetype, and visibility. IntelliCAD also 
includes drawing aids that help you draw accurately.

This section explains setting up drawings and using built-in drawing aids, including 
how to:

• Create new drawings, open existing drawings, and save changes to drawings.

• Use aids such as the grid, snap, and orthogonal settings to draw accurately.

Topics in this chapter

Creating a new drawing ...................................................................................... 46

Opening a drawing.............................................................................................. 47

Setting up a drawing ........................................................................................... 51

Working with colors............................................................................................. 71

Using the grid, snap alignment, cursor restriction, and dynamic input ............... 79

Using orthogonal locking .................................................................................... 85

Using entity snaps .............................................................................................. 91

Saving your drawing ......................................................................................... 108
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Creating a new drawing    

When you start IntelliCAD, the program automatically creates a new drawing based 
on a template drawing, icad.dwt. This template includes predefined settings such as 
drawing units, text size, print style table type, and drawing area. You can either use 
these settings or change them according to your needs. There is nothing unique about 
a template drawing. You can use any drawing as a template for future drawings.              

You can save many steps by basing a new drawing on an existing template (.dwt file). 
By doing this, a new drawing will contain all the settings and entities you need. When 
you open a new drawing from your custom template, you can modify existing settings 
and delete any entities that you don’t need. When you save a drawing that was created 
using a template, you do not change the template.

To create a new drawing
1 Do one of the following to choose New ( ):

• On the Quick Access toolbar of the ribbon, click the New tool.

• Type qnew and then press Enter.

To create a new drawing based on a template    
1 Do one of the following to choose New ( ):

• On the ribbon Application button, choose New.

• On the menu, choose File > New.

• Type new or newwiz and then press Enter.

2 Click Use A Template Drawing, and then click Next.

3 To display the Open Template dialog box, click Browse.

4 Select the template (.dwt) file that you want, and then click Open.

You can also choose any drawing (.dwg) file to use as a template.

5 Click Finish.
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Opening a drawing    

You can open drawing (.dwg) files, Drawing Exchange Format (.dxf) files, Design 
Web Format (.dwf) files, and drawing template (.dwt) files.

You can also open and check drawings that you suspect are damaged. 

Opening an existing drawing
You can open any of these drawing files:

• Standard drawing files with a .dwg extension. 

In addition to your own drawing files, you can open and use one of the sample 
drawings that are included with IntelliCAD.      

• Drawing Exchange Format files with a .dxf file extension.

• Design Web Format files with a .dwf file extension.

• Drawing templates with a .dwt file extension.

To open an existing drawing 
1 Use one of the following methods to choose Open ( ):

• On the Quick Access toolbar of the ribbon, click the Open tool.

• On the menu, choose File > Open.

• On the Standard toolbar, click the Open tool.

• Type open and then press Enter.

2 In Files of Type, choose the type of file you want to open.

3 Choose the folder containing the desired file.

4 Do one of the following:

• Choose the drawing you want to open, and then click Open.

• Double-click the drawing you want to open.

If the drawing requires a password, enter the password, click OK to verify the 
password, and then click Open again.

You can also open drawings while browsing files on your computer. 
Simply double-click the file or drag it to the drawing area in IntelliCAD. Using pro-
grams that came with your operating system, such as Windows File Explorer or My 
Computer, you can find the drawing you want by viewing thumbnail images of the 
drawing files as you browse them. If needed, choose Tools > Options and on the Gen-
eral tab, click Set Files Association to specify which filetypes are associated with 
IntelliCAD.
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The most recently opened drawings are tracked for easy opening. 
To quickly open a drawing file that you recently used, choose File > filename, or if 
your program version has a ribbon, choose the filename from the Application button 
or Start Page.       

A If a thumbnail image exists in the selected drawing, displays an 
image of the drawing before you open it.     

B Turns the drawing preview on or off.
C Unavailable when opening drawings; available only when saving 

drawings.
D Opens the drawing as read-only to prevent making changes to 

the file.    

E Displays a description of the file size, creation date, and other 
information about the drawing.

F Click to see more options for working with files. 
G Defines how drawings display in the list, including file details and 

thumbnail images.

A

B
C

E

D

F

G
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Opening a damaged drawing
Files can become damaged for many reasons. For example, if you are working on a 
drawing during a power outage, a system crash, or a hardware failure, your drawing 
file may become damaged. IntelliCAD allows you to open and check damaged files 
to attempt file recovery.

Recovering a file attempts to open one of the following file types:

• Standard drawing files with a .dwg extension. 

• Drawing Exchange Format files with a .dxf file extension.

• Design Web Format files with a .dwf file extension.

• Drawing templates with a .dwt file extension.

You can also audit any open file to check it for errors. You specify whether you want 
IntelliCAD to fix any errors that are found automatically. IntelliCAD fixes as many 
errors as possible and any errors that cannot be fixed are reported as “Ignored” in the 
Prompt History window.

In addition to recovering and auditing drawings, if you open a drawing that does not 
display all entities, it might be because those entities are assigned invalid z-coordi-
nates. Use the Set Z All command to set all z-coordinates to a new value so that all 
missing entities are then properly displayed.

To open a damaged file
1 Do one of the following to choose Recover ( ):

• On the ribbon Application button, choose Drawing Utilities > Recover.

• On the menu, choose File > Recover.

• Type recover and then press Enter.

2 In Files of Type, choose the type of file you want to recover.

3 Choose the directory containing the damaged file.

4 Choose the damaged file you want to recover.

5 Click Open.

If you want to check all drawings for errors automatically when you open them, 
choose Tools > Options > General tab and mark the check box for Open Drawings 
using Recover.
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To check a drawing file for errors
1 With the drawing open that you want to check, do one of the following to choose 

Audit ( ):

• On the ribbon Application button, choose Drawing Utilities > Audit.

• On the menu, choose File > Audit.

• Type audit and then press Enter.

2 Choose whether you want IntelliCAD to fix any found errors automatically, and 
then press Enter.

An ASCII file describes the audit. 
If the AUDITCTL system variable is set to On and errors are found during a file 
recovery or audit, an ASCII file is created that describes the audit. The ASCII file is 
saved in the same folder as the audited drawing and has the same name as the draw-
ing file, but with an .adt extension. 

To fix a drawing that contains invisible entities assigned invalid z-coordinates
1 With the drawing open that you want to fix, do one of the following to choose Set 

Z All ( ):

• On the ribbon, choose Express Tools > Set Z All (in Tools).

• On the menu, choose Express Tools > Tools > Set Z All.

• Type setz and then press Enter.

2 Enter a new value for the z-coordinates of all entities in the drawing.
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Setting up a drawing    

You can specify individual settings when you create a new drawing or when you 
modify settings in a drawing created from a template.

Setting the current layer
Layers are like the overlays that you use in manual drafting. You use layers to orga-
nize different types of drawing information. Every drawing has at least one layer, the 
default layer, named “0.” Your drawing can also contain an unlimited number of 
additional layers. When you create an entity, it is created on the current layer.     

To set the current layer
1 Do one of the following to choose Explore Layers ( ):         

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Format toolbar, click the Explore Layers tool .

• Type explayers and then press Enter.

• Type la and then press Enter.

2 Double-click the layer name that you want to make current.

Use the status bar shortcut.
On the status bar, right-click the current layer control, and from the list, select the 
layer you want to make current.

Use the layer of an entity you select to set the current layer.
Type LAYMCUR in the command bar, and select the entity with the layer you want to 
be current.
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Setting the current entity color
An entity’s color determines how it is displayed and, if you are using a color printer, 
how it prints. Entities are created in the current color. 

When you open a new drawing, entities are created in the color BYLAYER, which 
adopts the color of the current layer. Initially, layer 0 is both the only layer and the 
current layer. Its default color is white, so your entities appear as white.      

There are index colors, which contain two additional color properties that are often 
referred to as colors, true colors, and color book colors. The two additional color 
properties are BYLAYER and BYBLOCK. These color properties cause an entity to 
adopt the color either of the layer or of the block in which it is a member.

To set the current entity color
1 Do one of the following to choose Drawing Settings ( ):      

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Entity Creation tab.

3 Click Select Color.

4 In the Color dialog box, click one of the following tabs and select a color:

• Index Color — Click BYBLOCK, BYLAYER, or one of the 255 index colors. 
You can also type the color number in the Index box.

• True Color — Click a basic color, click a color in the color palette, enter the Hue, 
Saturation, and Luminance (HSL) values, or enter the Red, Green, Blue (RGB) 
values. There are more than 16 million true colors from which you can choose.

• Color Books — Select a color book from the list, then click a color. You can 
select Show Only Color Book Colors Used in Drawing to limit the selection to 
only those color book colors that are used in the current drawing.

5 Click OK.

6 Click OK again.

Use the status bar shortcut. 
On the status bar, right-click the current color, and select from the list the color you 
want to use for new entities. You can also click Select Color to choose additional col-
ors.

For more details about using color in the many aspects of your drawing, see “Work-
ing with colors” on page 71 in this chapter.  
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Setting the current linetype
Linetypes help convey information. You use different linetypes to differentiate the 
purpose of one line from another. A linetype consists of a repeating pattern of dots, 
dashes, or blank spaces. Linetypes determine the appearance of entities both on the 
screen and when printed. By default, every drawing has at least three linetypes: CON-
TINUOUS, BYLAYER, and BYBLOCK. Your drawing may also contain an unlim-
ited number of additional linetypes.           

When you create an entity, it is created using the current linetype. By default, the cur-
rent linetype is BYLAYER. IntelliCAD indicates that the entity linetype is deter-
mined by the current layer’s linetype by assigning the BYLAYER property as the 
default linetype setting. When you assign BYLAYER, changing a layer’s linetype 
changes the linetype of all the entities assigned that layer (if they were created using 
the linetype BYLAYER).     

You can also select a specific linetype as the current linetype, which overrides the 
layer’s linetype setting. Entities are then created using that linetype, and changing the 
layer linetype has no effect on them.

As a third option, you can use the linetype BYBLOCK property, in which case new 
entities are drawn using the CONTINUOUS linetype until you group them into a 
block. The entities then inherit the block’s linetype setting when you insert the block 
into a drawing.

To set the current linetype
1 Do one of the following to choose Drawing Settings ( ):          

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Entity Creation tab.

3 In the Linetype list, choose the linetype that you want to make current.

4 Click OK.

Use the status bar shortcut.
On the status bar, right-click the word BYLAYER for the current linetype, click Prop-
erties, and then choose the linetype that you want to make current.
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Setting the linetype scale    
You can specify the linetype scale. The smaller the scale, the more repetitions of the 
linetype pattern are generated per drawing unit. For example, a linetype pattern is 
defined as a sequence of dashed lines and open spaces, each 0.25 units long. The line-
type scale uses the drawing scale factor to determine the length. A scale factor of 0.5 
would reduce the length of each line and space to 0.125 units; a scale factor of 2 
would increase the length of each to 0.5 units.         

Note that setting the linetype scale too large or too small may result in a line pattern 
looking like a solid line, depending on what the scale view is or at what scale the 
drawing is printed.

You can control a new entity’s individual linetype scale factor as well as the overall 
or global scale factor applied to all the entities in the drawing. If you use annotation 
scaling for entities such as text and dimensions, you can also set up linetype scaling to 
coordinate with various annotation scaling scenarios.

To set the current individual linetype scale
1 Do one of the following to choose Drawing Settings ( ):

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Entity Creation tab.

3 In the Linetype Scale field, type or choose the linetype scale that you want to 
make current.

4 Click OK.

To change the global linetype scale
1 Do one of the following to choose Drawing Settings ( ):     

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Entity Creation tab.

3 In the Global Linetype Scale field, type or choose the global linetype scale that 
you want to change.

4 Click OK.
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To set up linetype scaling to be the same in model space and paper space
1 Set the global linetype scale (mentioned previously) to the drawing scale. For 

example, enter .25 for the scale factor 1/4" - 1".

2 Type PSLTSCALE and press Enter, then enter 0 to turn this system variable off. 
Customized linetype scaling specific to paper space will be turned off.

3 Type MSLTSCALE and press Enter, then enter 0 to turn this system variable off. 
Customized linetype scaling specific to model space will be turned off.

To set up linetype scaling to be different in model space and paper space
1 Set the global linetype scale (mentioned previously) to 1. This sets the default 

linetype scale factor to be the same as the drawing scale.

2 Type PSLTSCALE and press Enter, then enter 1 to turn this system variable on. 
Customized linetype scaling specific to paper space will be turned off.

3 Type MSLTSCALE and press Enter, then enter 1 to turn this system variable on. 
Customized linetype scaling specific to model space will be turned off.

4 For drawings that also use annotation scaling, do the following:

• On the status bar, right-click Annotations Scales List.

• Choose the current annotation scale, for example 1/4" - 1". This makes the 
linetype scale set to the annotation scale.

Linetypes will be the same for all viewports that have the same annotation scale. 
Setting up linetype scaling so it can be different in model space and paper space is 
the preferred method for drawings with details, profiles, or plan views that are not 
always the same scale. Paper space viewports will look and print as intended, and 
you can adjust the model space annotation scale for it to match the display in 
paper space. For more information about annotation scaling, see “Understanding 
scale factors” on page 62 in this chapter. 

Setting the current lineweight
Lineweights help differentiate the purpose of one line from another. Lineweights 
determine how thick or thin entities appear both on the screen and when printed. 
Every drawing has these lineweights: DEFAULT, BYLAYER, BYBLOCK, and 
many additional lineweights in millimeters (or you can use inches).            

When you create an entity, it is created using the current lineweight. By default, the 
current lineweight for a new entity is BYLAYER. This means that the entity line-
weight is determined by the current layer. When you assign BYLAYER, changing a 
layer’s lineweight changes the lineweight of all the entities assigned that layer (if they 
were created using the lineweight BYLAYER).     
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You can also select a specific lineweight (or DEFAULT) as the current lineweight, 
which overrides the layer’s lineweight setting. Entities are then created using that lin-
eweight (or the DEFAULT lineweight), and changing the layer lineweight has no 
effect on them.

As a third option, you can use the lineweight BYBLOCK property, in which case new 
entities are drawn using the DEFAULT lineweight until you group them into a block. 
The entities then inherit the block’s lineweight setting when you insert the block into 
a drawing.

If you choose a lineweight that is less than .025 millimeter, it displays as one pixel 
when you create your drawing. When you print your drawing, it prints at the thinnest 
lineweight that is available for your printer.

You cannot assign lineweights to planes, points, TrueType fonts, or raster images (if 
supported in your version of IntelliCAD).

To set the current lineweight
1 Do one of the following to choose Drawing Settings ( ):         

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings or choose Tools > Lineweight.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Entity Creation tab.

3 In the Lineweight list, choose the lineweight that you want to make current.

4 Click OK.

Use the status bar shortcut.
On the status bar, right-click the word BYLAYER for the current lineweight, and then 
choose the current lineweight. You can also double-click the word LWT to toggle the 
display of lineweights on and off.

Lineweights need to be turned on to be visible.
To see lineweights in your drawing, you may need to turn on their visibility. For 
details, see “Displaying lineweights” on page 251. 
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Setting the current print style
Print styles are used to change the appearance of an entity when it prints, without 
actually changing the entity in the drawing. 

If your drawing uses named print style tables, you can specify a print style for any 
entity. Named print style tables contain print styles that you set up. If your drawing 
uses color-dependent print style tables, the print style is BYCOLOR, which cannot be 
changed. These types of print style tables determine printing requirements by the 
color assigned to an entity or layer. For details about converting a drawing that uses 
color-dependent print style tables to use named print style tables, see “Changing the 
print style table type of a drawing” on page 657. 

When you create an entity in a drawing that uses named print style tables, the entity is 
created using the current print style. By default, the current print style is BYLAYER. 
When you assign BYLAYER, changing a layer’s print style changes the print style of 
all the entities assigned that layer if they were created using the print style 
BYLAYER.     

You can also select a specific print style as the current print style, which overrides the 
layer’s print style setting. Entities are then created using that print style, and changing 
the layer print style has no effect on them.

As a third option, you can use the print style BYBLOCK, in which case new entities 
use the Normal print style until you group them into a block. The entities then inherit 
the block’s print style setting when you insert the block into a drawing.

To set the current print style in a drawing that uses named print style tables
1 Do one of the following to choose Drawing Settings ( ):          

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Entity Creation tab.

3 In the Print Style list, choose the print style that you want to make current. If nec-
essary, choose Other and then select a print style.

4 Click OK.

Use the status bar or command bar shortcut.
On the status bar, right-click the word BYLAYER for the current print style, click 
Other, and then choose the print style that you want to make current. Or, 
type printstyle to choose the current print style.
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Setting drawing units    
With IntelliCAD, you typically draw at full-size (1:1 scale), and then set a scale fac-
tor when you print or plot your drawing. Before you begin drawing, however, you 
need to determine the relationship between drawing units and real-world units.            

For example, you can decide whether one linear drawing unit represents an inch, a 
foot, a meter, or a mile. In addition, you can specify the way the program measures 
angles. For both linear and angular units, you can also set the degree of display preci-
sion, such as the number of decimal places or smallest denominator used when dis-
playing fractions. The precision settings affect only the display of distances, angles, 
and coordinates. IntelliCAD always stores distances, angles, and coordinates using 
floating-point accuracy.     

If your drawing contains Architecture, Engineering, and Construction (AEC) entities, 
you also set the AEC drawing units. To provide compatibility for your drawing with 
Autodesk Architecture, drawings with AEC entities require two drawing units: one 
for .dwg file compatibility and one for architecture object compatibility.

To set the linear drawing units    
1 Do one of the following to choose Drawing Settings ( ):

• On the ribbon, choose Application button > Drawing Utilities; Application 
Button > Drawing Utilities > Drawing Units; Home > Drawing Settings (in 
Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Drawing Units tab.

3 Click the Linear Units tab.

4 Under Unit Types, select a unit type.

5 For Display Precision, type the display precision according to the number of deci-
mal places you want, or click the arrows to select it.

The box above this setting shows an example of the linear unit type at the current 
precision.

6 For Insertion Scale Units, select the units used when inserting blocks, external ref-
erences and images from drawings that use different units than the current draw-
ing.

7 For AEC Entity Units, select the drawing units to use for inserting and scaling 
AEC entities.

8 Mark Scale Existing Entities upon Drawing Unit Change to scale AEC entities in 
the current drawing if the AEC units change. If not marked, existing AEC entities 
are not scaled and the new AEC units affect only new AEC entities.

9 Mark Match Insertion Unit to Drawing Unit Change to make the Insertion Scale 
Units change to match AEC units if the AEC units change. 



W O R K I N G  W I T H  D R A W I N G S 59
10 Click OK. 

A Determines the type of units you are controlling.
B Select the type of linear units.
C Choose the display precision for linear units. 
D Displays only if your program version supports 

working with AEC entities.
E Mark to make the insertion scale units change to 

match AEC units if AEC units change.

F Mark to scale AEC entities if AEC units change.
G Select drawing units to use for inserting and 

scaling AEC entities.
H Select the units used when inserting items from 

drawings that use different units than the current 
drawing.

B

C

A

E
F
G

H

D
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To set the angular drawing units                   
1 Do one of the following to choose Drawing Settings ( ):

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Drawing Units tab.

3 Click the Angular Units tab.

4 Under Unit Types, select a unit type.

5 Under Display Precision, type the display precision according to the number of 
decimal places you want, or click the arrows to select it.    

The field above this setting shows an example of the angular unit type at the cur-
rent precision.

6 Under Angle Direction, select the direction in which angles increase when you 
specify a positive angle value.    

7 Under Angle Base, specify the compass location for the zero angle.    

For example, by default, angle 0 is at the “three o’clock” or “east” position.

The adjacent icon shows the current location of the angle base.

8 Click OK.



W O R K I N G  W I T H  D R A W I N G S 61
A Determines the type of units you are controlling.
B Select the type of angular units.
C Choose the display precision for angular units.

D Select the angle base, the direction of the zero 
angle.

E Select the direction in which angles increase.

E

B

C

A

D



62 C H A P T E R  3
Understanding scale factors    
Instead of drawing to a particular scale, you draw everything in the program full-size. 
Although it’s a good idea to keep your scale factor in mind when setting up a draw-
ing, you don’t need to set the scale until you print it. For example, when you draw a 
mechanical part 40 inches in length with IntelliCAD, you actually draw it as 40 
inches, rather than applying a scale factor as you draw. When you print your drawing, 
you can assign the scale at which the drawing is to print.          

Scale, however, does affect the way a few elements such as text, arrows, or linetypes 
print or plot and even display in your drawing. You can set up annotation scaling to 
control the scale of entities such as text, arrows, and linetypes, or you can make man-
ual adjustments when you first set up your drawing so that annotations print and dis-
play at the correct size. For example, when you draw text, you need to determine the 
text size so that when you print it later at a particular scale, the text height is correct.     

After you determine the eventual scale of your finished drawing, you can calculate 
the scale factor for the drawing as a ratio of one drawing unit to the actual scale unit 
represented by each drawing unit. For example, if you plan to print your drawing at 
1/8” = 1’-0”, your scale factor ratio is 1:96 (1/8” = 12” is the same as 1 = 96). If you 
want your printed scale to be 1 inch = 100 feet, your scale factor ratio is 1:1200.        

The following table shows some standard architectural and engineering scale ratios 
and equivalent text heights required to create text that measures 1/8-inch high when 
you print the drawing at the specified scale.           

Standard scale ratios and equivalent text heights 
Scale Scale factor Text height
1/16” = 1’-0” 192 24”

1/8” = 1’-0” 96 12”

3/16” = 1’-0” 64 8”

1/4” = 1’-0” 48 6”

3/8” = 1’-0” 32 4”

1/2” = 1’-0” 24 3”

3/4” = 1’-0” 16 2”

1” = 1’-0” 12 1.5”

1 1/2” = 1’-0” 8 1”

3” = 1’-0” 4 0.5”

1” = 10’ 120 15”

1” = 20’ 240 30”

1” = 30’ 360 45”

1” = 40’ 480 60”
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You can use these scale factors to predetermine the size of your drawing to make sure 
that it fits on a specific size paper when you print it. You control the size of your 
drawing by the drawing limits. To calculate the drawing limits to match the size of 
your paper, multiply the dimensions of your paper size by your scale factor.        

For example, if the paper you use to print measures 36 inches x 24 inches and you 
print your drawing at 1/8” = 1’-0” (in other words, using a scale factor of 96), the size 
of your drawing measured in drawing units is 36 x 96 (or 3,456 units) wide and 24 x 
96 (or 2,304 units) high.

Keep in mind that you can print the finished drawing at any scale, regardless of the 
scale factor you calculate. You can also print on paper of a different size and use the 
Layout tabs to create different views of your drawing and to position and scale those 
views differently. The scaling factor is not related to the size of the entities you draw; 
it simply provides a preliminary guide to help you establish the text height and draw-
ing limits when you begin your drawing. You can change the text height and drawing 
limits at any time.

1” = 50’ 600 75”

1” = 60’ 720 90”

1” = 100’ 1200 150”

Standard scale ratios and equivalent text heights 
Scale Scale factor Text height
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Setting up annotation scaling
Annotation scaling allows you to control individual entities so their size will consis-
tently display when a drawing is displayed or printed at different scales. You don’t 
have to use annotation scaling, but it is a convenient way to control the scaling of the 
following entities: text, tolerances, dimensions, leaders, multileaders, attributes, 
hatches, and blocks. 

These individual entities can be annotative, and so can text styles, dimension styles, 
and multileader styles; text, dimensions, or multileaders assigned an annotative style 
will have annotation scaling turned on by default. 

IntelliCAD comes ready to use annotation scaling, however, you may want to cus-
tomize some of the settings according to your needs.

Customizing the scales list
The scales list defines all of the scales that are available to assign to annotative enti-
ties. For example, to assign an annotation scale to a text entity, you choose it from the 
scales list. The scales list displays when you do any of the following:

• Set the current annotation scale — On the status bar, right-click Annotations 
Scales List.

• Assign an annotation scale to an entity — Select an entity and use the Properties or 
Entity Scale command.

• Print — Choose the Print command. 

After you set up your scales list, you may want to create a drawing template with the 
default scales or export your scale list so you can easily import the list into other 
drawings.
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To customize the scales list
1 Do one of the following to choose Scale List ( ):

• On the ribbon, choose Annotate > Scale List (in Annotation Scaling).

• On the menu, choose Format > Scale List.

• On the status bar, click Annotation Scales List.

• Type scalelistedit and then press Enter.

2 To add a scale to the list, do the following:

• Click Add.

• Enter the name of the scale, which will appear in the list.

• Enter the paper units to drawing units ratio.

• Click OK.

3 Do any of the following to further customize the list:

• Select a scale and click Modify to change a scale’s name or ratio.

• Select a scale and click Delete to remove it from the list.

• Select a scale and click Move Up or Move Down to reposition it in the list.

4 Optionally click Export to save your scales list to a file that you can easily import 
into other drawings.

5 Click OK.
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Purging unused annotation scales can increase performance.
Older drawings from other CAD programs can sometimes have thousands of unused 
annotation scales. Click Purge in the Edit Drawing Scales dialog box to remove 
unused annotation scales and increase performance.

Customizing styles to be annotative
Text styles and dimension styles determine whether text and dimension entities that 
are assigned those styles are annotative by default. Multileader styles can also be 
annotative, but IntelliCAD only supports the display of multileaders, not the creation 
of multileaders or multileader styles.

For text styles, see “Working with text styles” on page 474. 

For dimension styles, see “Controlling dimension fit” on page 532. 

A Displays the scales available for annotative 
entities.

B Click to allow deleting scales that are used in the 
drawing.

C Click to display scales from attached external 
references in the list.

D Click to save the scales list to a file.
E Click to open and load a scales list from a file.
F Click to remove all unused scales from the list.

G Click to remove all custom scales and restore 
the default scale list.

H Click to remove the selected scale.
I Click to move the selected scale down one 

position in the list.
J Click to move the selected scale up one position 

in the list.
K Click to modify the selected scale.
L Click to create a new scale and add it to the list.

H

D
E

A

F

I
J
K
L

B
C

G
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Setting up automatic annotation scaling
Automatic annotation scaling automatically assigns the current annotation scale to 
annotation entities that have annotation scaling turned on.

To set automatic annotation scaling and the current annotation scale
1 On the status bar, click Automatic Annotation On/Off.

2 On the status bar, click Annotations Scales List. 

3 Choose the current annotation scale.

Setting the text height            
The text height setting controls the height of text, measured in drawing units. Set this 
value initially so that text used for your most common annotations, when scaled to the 
size at which you will print a drawing, measures 1/8-inch high on the printed draw-
ing.              

For example, if you plan to print your drawing at 1/8” = 1’-0” and you want your text 
to be 1/8-inch high in the final drawing, create that text 1 foot high (in your real-
world drawing units) so that when you print it, it appears 1/8-inch high on the paper. 
You must create text 4 feet high that you want to print 1/2-inch high.

To set the text height
1 Do one of the following to choose Drawing Settings ( ):

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Entity Creation tab.

3 Click the Text tab. If necessary, click the right arrow to scroll the tabs horizontally 
to view the Text tab.

4 In the Default Text Height field, select the text height or type the text height value 
that you want. If you have chosen an annotative text style, you enter the paper text 
height.

5 Click OK.   
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The default text height applies only if the current text style height is 0.0.
Otherwise, the text height for the current style takes precedence.

Setting the drawing limits    
You can specify the drawing limits that form an invisible boundary around your 
drawing. You can use the drawing limits to make sure that you do not create a draw-
ing larger than can fit on a specific sheet of paper when printed at a specific scale.       

For example, if you plan to print your drawing at 1/8” = 1’-0” (in other words, using a 
scale factor of 96) on a sheet of paper measuring 36 inches x 24 inches, you can set 
drawing limits to 3,264 units wide (that is, 34 x 96) and 2,112 units high (22 x 96), 
which allows a 1-inch margin around the edges of the printed image.

A Choose Text. B Specify the text height in drawing units.

A

B
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To set the drawing limits    
1 Do one of the following to choose Drawing Settings ( ):         

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click either the Coordinate Input tab or the Display tab.

3 Click the Limits tab.

4 Specify the x-coordinate and y-coordinate of the upper right drawing limit and the 
lower left drawing limit.

You can also click Select to specify the drawing limits by selecting points in the 
drawing.

5 To constrain your drawing to these drawing limits, click the Disallow Input 
Beyond Limits check box.

6 Click OK.
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A Choose Limits.
B Specify the x-coordinate and y-coordinate of the 

upper right drawing limit.
C Specify the x-coordinate and y-coordinate of the 

lower left drawing limit.

D When selected, the program prevents you from 
drawing outside the drawing limits.

E Specify the drawing limits by selecting points in 
the drawing.

E
B
C

A

D
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Working with colors

An entity’s color determines how it is displayed and, if you are using a color printer, 
how it prints. Entities are created in the current color specified for the drawing.

Layers can also control the color of entities. When you open a new drawing, entities 
are created in the color BYLAYER, which adopts the color of the current layer. Ini-
tially, layer 0 is both the only layer and the current layer. Its default color is white, so 
your entities appear as white.      

For entities and layers in IntelliCAD, there are three different types of colors:

• Index colors

• True colors

• Color book colors

True colors and color books are unavailable in some cases.
For example, for dimension entities and cursor display.

You can choose colors by selecting them from the Color dialog box. In the command 
bar or in some dialog boxes, you specify a color either by name or by number. 

Using index colors
There are 255 standard index colors and two additional color properties that are often 
referred to as colors (BYLAYER and BYBLOCK). You can use seven of the 255 
standard index colors by name: red, yellow, green, cyan, blue, magenta, and white. 
(Numbers eight and nine are not named.) Each index color has a unique number from 
1 to 255. The two additional color properties are BYLAYER and BYBLOCK. These 
color properties cause an entity to adopt the color either of the layer or of the block in 
which it is a member. BYLAYER is color number 256, and BYBLOCK is color num-
ber 0. In all commands for which you would use a color, you can indicate BYLAYER 
and BYBLOCK as well as by numbers 256 and 0, respectively.

To select an index color
1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 

Properties, or Multiline Text.

The Color dialog box opens.

2 Click the Index Color tab.

3 Do one of the following:

• Click BYBLOCK.

• Click BYLAYER.

• Click the color of your choice, or type the color number in the Current box.

4 Click OK.    



72 C H A P T E R  3
Using true colors
There are more than 16 million true colors from which you can choose. True colors 
are defined using 24-bit color. 

Even with so many colors available, you can quickly choose a color from the display 
of basic colors or by clicking the color palette. Alternatively, if you know the values 
used to define the desired color, you can enter the Hue, Saturation, and Luminance 
(HSL) values, or you can enter the Red, Green, Blue (RGB) values.

To select a true color
1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 

Properties, or Multiline Text.

The Color dialog box opens.

2 Click the True Color tab.

A Click to select one of the standard colors.
B Click to select one of the gray shades.
C Click to select any one of the available index 

colors.

D Indicates the current color.
E Displays the color number, or enter the color 

number.
F Click to set the color to BYLAYER.
G Click to set the color to BYBLOCK.

A

B

D E

G

F

C
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3 Do one of the following:

• Click a basic true color.

• Click a true color in the color palette.

• Enter HSL values for the desired true color.

• Enter RGB values for the desired true color.

4 Click OK.   

A Click to select one of the basic true colors.
B Click to select one of the custom true colors, if 

any are defined.
C Click to add the selected color to the custom 

color area.
D Enter (or view) the amount of red, green, and 

blue of the desired true color.

E Enter (or view) the amount of hue, saturation, 
and luminance of the desired true color.

F Slide or click to adjust the color luminance. 
G Click to select a true color in the color palette.

A

C

D
B

E

F

G
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Using color books
IntelliCAD uses color books to store collections of colors. For example, you can store 
a unique color scheme for a client in a color book and then use colors only from that 
color book for the client’s drawings.

Selecting a color book color

To select a color book color
1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 

Properties, or Multiline Text.

The Color dialog box opens.

2 Click the Color Books tab.

3 Select a color book from the list.

4 If you want to narrow your color search, do one of the following:

• In the list of colors, select a color book page, if one is available. Pages are partic-
ularly helpful in large color books — they help group colors so you can find 
them quickly.

• Select Show Only Color Book Colors Used in Drawing. Only those color book 
colors that are used in the current drawing will display in the list.

5 Select the desired color.

6 Click OK. 
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Creating color books
You may have a color book given to you by a client, developed by a third-party, or 
you can create your own. Each color book has an .acb extension and is saved auto-
matically in Extensible Markup Language (XML) format. 

To create a color book
1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 

Properties, or Multiline Text.

The Color dialog box opens.

2 Click the Color Books tab.

3 Click Color Book Editor.

4 In the Color Book Editor dialog box, click the New tool ( ).

5 In Color Book Name, enter the name of the color book. This name will appear in 
the list of color books on the Color Books tab in the Color dialog box.

A Select a color book.
B Click to select a color book color.
C Select to list only those color book colors that are 

used in the current drawing.

D Click to create and modify color books.
E Displays the selected color and its RGB values.

A

B
E

C

D



76 C H A P T E R  3
6 Do the following to define organizational pages in the color book:

• In the contents of the color book, click an existing page or color where you want 
to add a page. 

• Define a color in the palette.

• Enter the name of the page, and then click Add Page.

7 Do the following to define colors in the color book:

• In the contents of the color book, click an existing page or color where you want 
to add a color.

• Define a color in the palette.

• Enter the name of the color, and then click Add Color.

8 Do any of the following to change existing pages and colors in the color book:

• Modify pages and colors — Select a page or color in the color book, define its 
new color settings in the palette, enter any changes to its name, and then click 
Modify.

• Delete pages and colors — Select a page or color in the color book, and then 
click Delete.

• Rearrange pages and colors — Select a page or color in the color book, and then 
click the up arrow ( ) or down arrow ( ).

9 In the Color Book Editor dialog box, click the Save tool ( ).

10 Enter a filename for the color book, and then click Save.

By default, the file is saved in the default folder where IntelliCAD searches for 
color books.
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A Click New to create a color book; click Open to 
open a color book; click Save to save the color 
book; click Save As to save the color book with a 
new filename.

B Select a page or color to modify, delete, or 
reorder it, or to view its settings.

C Click to create a new page in the color book 
using the current color settings.

D Click to create a new color in the color book 
using the current color settings.

E Click to delete the selected page or color from 
the color book.

F Click to redefine the selected page or color to 
use the current color settings.

G Click to move the selected page or color up or 
down one position in the color book.

H Enter the name of the page or color as you want 
it to appear in the color book.

I Enter (or view) the amount of red, green, and 
blue of the desired color.

J Enter (or view) the amount of hue, saturation, 
and luminance of the desired color.

K Slide or click to adjust the color luminance. 
L Click to select a color.
M Enter the name of the color book.

A

B

D

H

E

C

G

I

J

K

L

F

M
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Modifying color books
You can modify your own color books and the color books that came with Intelli-
CAD. If you modify a color book that came with IntelliCAD, it is recommended that 
you save it with a new filename first so the original color book is not overwritten. 

To modify a color book
1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 

Properties, or Multiline Text.

The Color dialog box opens.

2 Click the Color Books tab.

3 Select the color book you want to modify.

4 Click Color Book Editor.

5 In Color Book Name, enter any changes to the color book name. This name 
appears in the list of color books on the Color Books tab in the Color dialog box.

6 Do any of the following to modify pages or colors in the color book:

• Add pages — In the contents of the color book, click an existing page or color 
where you want to add a page. Define a color in the palette, enter the name of 
the page, and then click Add.

• Add colors — In the contents of the color book, click an existing page or color 
where you want to add a color. Define a color in the palette, enter the name of 
the color, and then click Add.

• Modify pages and colors — Select a page or color in the color book, define its 
new color settings in the palette, enter any changes to its name, and then click 
Modify.

• Delete pages and colors — Select a page or color in the color book, and then 
click Delete.

• Rearrange pages and colors — Select a page or color in the color book, and then 
click the up arrow ( ) or down arrow ( ).

7 Do one of the following to save the color book:

• To save the color book with the same filename, click the Save tool ( ) in the 
Color Book Editor.

• To save the color book with a new filename or in a new location, click the 
Save As tool ( ) in the Color Book Editor.
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Loading color books
If you have a color book given to you by a client or developed by a third-party, sim-
ply save it on your computer in a folder where IntelliCAD can find it. By default, 
color books are stored in following folder: \Documents and Settings\YourName\My 
Documents\Color Books.

To load a color book
1 Save the color book in the folder where IntelliCAD searches for color books. 

To verify the folder location, choose Tools > Options, click the Paths/Files tab, 
and find the Color Book folder in the Paths list.

2 In a Color dialog box, click the Color Books tab. 

The previously loaded color book displays in the list of color books.

Using the grid, snap alignment, cursor restriction, and dynamic input

Grid and snap settings are effective tools to use in your drawing to ensure accuracy. 
Although many users find it convenient to match grid points to snap settings, they are 
independent of each other and should not be confused. Grid points are for visual ref-
erence only; they do not affect your drawing and they do not print. Snap points are, 
by themselves, not visible; however, when set, they constrain the creation of new 
entities. 

In addition, the cursor can be restricted to move orthogonally only or guides can dis-
play on the screen automatically at specified polar angle increments.    

Setting a reference grid
A reference grid displays as a pattern of regularly spaced dots or lines. You can turn 
the grid on and off, and you can specify how far apart the dots or lines are spaced.       

By default, the reference grid displays as lines, which has much better display perfor-
mance than a grid that displays as points (dots), and it is adaptive (it proportionately 
scales according to the zoom ratio), helping you to align entities and visualize dis-
tances between entities. If desired, the grid can be constrained to only display within 
the limits of the drawing.
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To turn the grid on or off and set the grid spacing
1 Do one of the following to choose Drawing Settings ( ):         

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Coordinate Input tab.

3 Click the Snap and Grid tab.

4 Click the Grid On check box to turn the grid on or off.

5 Under Grid Spacing, in the X field, choose the horizontal grid spacing.

6 Under Grid Spacing, in the Y field, choose the vertical grid spacing.    

7 Click OK.

Use the shortcuts for toggling the grid display on and off.
Double-click the GRID setting on the status bar, click the Reference Grid tool ( ) 
on the Settings toolbar, or press F7.       
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A Click to enable orthogonal mode.    
B Click to enable crosshairs locking to the nearest 

snap point.
C Click to enable snap mode.
D Specify the x and y snap spacing.
E Specify the polar snap spacing (available if Snap 

Type is set to Polar).
F Select whether to use standard grid snapping 

(Grid) or to use polar snapping (Polar).
G Click to use a rectangular or isometric snap. If 

isometric, select the initial isoplane: top, left 
(default), or right.   

H Specify the x- and y-coordinates of the snap 
origin.

I Specify the snap rotation angle. The grid will 
display rotated to match the snap setting.    

J Click to display a dotted grid for paper sheets 
and layouts (Layout tabs); otherwise a lined grid 
displays.

K Click to display a dotted grid for model space 
(Model tab); otherwise a lined grid displays.

L Click to display the grid beyond the limits area.
M Click to split the grid if the zoom level is smaller 

than the grid unit (available if adaptive grid is 
turned on).

N Click to enable an adaptive grid, which 
proportionally scales according to the zoom 
ratio.

O Enter the number of minor grid lines to display 
for every major grid line.

P Specify the x and y grid spacing.
Q Click to display the reference grid.

A

K

L

C
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Setting snap spacing 
Another way to ensure drawing accuracy is to turn on and set snap spacing. When 
snap is turned on, the program restricts the selection points to predetermined snap 
intervals. Although it is often helpful to match the snap spacing to some interval of 
the grid spacing or another related setting, the settings do not have to match.           

To turn snap settings on and set snap spacing
1 Do one of the following to choose Drawing Settings ( ):

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Coordinate Input tab.

3 Click the Snap and Grid tab.

4 Click the Snap On check box to turn Snap on.

5 Under Snap Spacing, in the X field, choose the horizontal snap spacing.

6 Under Snap Spacing, in the Y field, choose the vertical snap spacing.

7 Click OK.

Use the shortcuts for toggling the snap settings on and off. 
?lick the Entity Snap Settings button on the status bar or press F9.       

In addition to setting the snap spacing, you can change the snap and grid orientation. 
You can also rotate the alignment of the grid or set it to create isometric drawings.
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Changing the snap and grid angle and base point
The snap and grid are both normally based on the drawing origin, the 0,0 coordinate 
in the World Coordinate System (WCS). You can relocate the snap and grid origin, 
however, to help you draw entities in relation to a different location. You can also 
rotate the grid to a different angle to realign the crosshairs to the new grid angle. If the 
grid is on, and the grid spacing is 0,0, then the grid defaults to the snap spacing.                 

To change the snap angle and base point
1 Do one of the following to choose Drawing Settings ( ):        

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Coordinate Input tab.

3 Click the Snap and Grid tab.

4 Click the Snap On check box to turn Snap on.

5 Click the Grid On check box to turn Grid on. 

6 In Snap Basepoint, type the x-coordinate and y-coordinate of the new snap origin.

7 In Rotation, type the snap rotation angle, which also changes the display of the 
grid.

8 Click OK. 

 

Default grid and snap alignment. Rotated grid and snap alignment.



84 C H A P T E R  3
Using isometric snap and grid
You can use the Isometric Snap and Grid option to create two-dimensional isometric 
drawings. With the isometric option, you are simply drawing a simulated three-
dimensional view on a two-dimensional plane, much the same as you might draw on 
a piece of paper. Do not confuse isometric drawings with three-dimensional draw-
ings. You create three-dimensional drawings in three-dimensional space.                       

The isometric option always uses three preset planes, which are denoted as left, right, 
and top. You cannot alter the arrangement of these planes. If the snap angle is 0, the 
three isometric axes are 30 degrees, 90 degrees, and 150 degrees.

When you use the Isometric Snap option and select an isometric plane, the snap inter-
vals, grid, and crosshairs align with the current plane. The grid is always shown as 
isometric and uses y-coordinates to calculate the grid spacing. If you click the Draw 
Orthogonal check box, the program restricts the drawing of entities to the current iso-
metric plane.

Use the shortcut to toggle between isometric planes.
Press F5.

To turn the Isometric Snap and Grid option on
1 Do one of the following to choose Drawing Settings ( ):        

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Coordinate Input tab.

3 Click the Snap and Grid tab.

4 Click the Snap On check box to turn Snap on.

5 Click the Grid On check box to turn Grid on. 

6 Under Snap Type, choose Isometric, then choose the option for the initial isomet-
ric plane you want (Top, Left, or Right).

7 Click OK.
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Using orthogonal locking   
You can restrict cursor movement to the current horizontal and vertical axes so that 
you can draw at right angles, or orthogonally. For example, with the default 0-degree 
orientation (angle 0 at the “three o’clock” or “east” position), when the Draw Orthog-
onal option is enabled, lines are restricted to 0 degrees, 90 degrees, 180 degrees, or 
270 degrees. As you draw lines, the rubber-banding line follows either the horizontal 
or vertical axis, depending on which axis is farthest from the cursor. When you 
enable the isometric snap and grid, cursor movement is restricted to orthogonal 
equivalents within the current isometric plane.            

Sometimes orthogonal locking is not used even when it is turned on. 
IntelliCAD ignores orthogonal locking when you type coordinates in the command 
bar or when you use entity snaps. Additionally, orthogonal locking and polar track-
ing cannot be used at the same time — turning one option on turns the other option 
off.

To enable orthogonal locking
1 Do one of the following to choose Drawing Settings ( ):       

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Coordinate Input tab.

3 Click the Draw Orthogonal check box.

4 Click OK.

Toggle orthogonal locking on and off.
On the status bar, click Orthogonal On/Off ( ) or press F8. You can also click the 
Draw Orthogonal tool ( ) on the Settings toolbar.    

Isometric planes left (A), right (B), top (C).     

A B

C
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Using polar tracking
When polar tracking is turned on, guides display on the screen automatically at the 
polar angle increment that you specify. For example, if you draw a line with polar 
tracking turned on at 45 degrees, the rubber-banding line displays at 45 degree angle 
increments.

Polar tracking and orthogonal locking cannot be used at the same time — turning one 
option on turns the other option off.         

To enable polar tracking and specify the polar angle increment
1 Do one of the following to choose Drawing Settings ( ):       

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Coordinate Input tab.

3 Click the Polar Tracking tab.

4 Click the Polar Tracking check box.

5 Do one of the following to specify the polar angle increments:

• In Increment, select an angle.

• Mark the Additional Angles check box and click New to define a custom angle 
increment.

6 Click OK.

Toggle polar tracking on and off. 
Click Polar Tracking On/Off on the status bar, type POLARTRACK in the command 
line, press F10, or press Ctrl+U.    
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A Select Polar Tracking. 
B Select to display polar tracking guides on the 

screen.
C Select the angle at which you want the guides to 

display.

D Select to specify angle increments that are not 
defined in the Increment Angle list.

E Click to add a new angle increment.
F Click to delete the currently selected angle from 

the Additional Angles list.

B

C
D

E
F

A
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Using dynamic input
When dynamic input is turned on, guides display on the screen automatically as you 
draw and edit your drawing. Dynamic input can display when you are prompted for a 
point, prompted for dimensions such as distances and angles, and prompted for com-
mand input that you would typically enter at the command line. You can determine 
many settings for how dynamic input prompts for input and even how the tooltips dis-
play on your screen.      

To turn on dynamic input
1 Do one of the following to choose Drawing Settings ( ):       

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Dynamic Input tab.

3 Choose which parts of dynamic input you want to turn on:

• Enable pointer input A field near the cursor that displays and accepts coordinate 
values when a command asks you for a point.

• Enable dimension input A field near the cursor that displays and accepts 
distance and angle values when a command prompts you for a second point or 
a distance.

• Show command prompting and command input near the crosshairs A prompt 
near the cursor that allows you to type command input.

4 Click OK.
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Toggle dynamic input on and off. 
On the status bar, click Dynamic Input On/Off to turn pointer input, dimension input, 
and command prompting on or off all at once.

A Mark box to turn on pointer input.
B Click to specify various options for pointer input.
C Mark to display command prompts and allow 

command input in dynamic input tooltips.

D Click to choose tooltip appearance settings.
E Click to specify various options for dimension 

input.
F Mark to turn on dimension input.

A

B

C

D

F
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To customize pointer input settings
1 In the Drawing Settings dialog box, click the Dynamic Input tab.

2 In Pointer Input, click Settings.

3 Choose whether you want pointer input to default to Polar or Cartesian format for 
default second and next points.

4 Choose whether you want pointer input to default to Relative or Absolute coordi-
nates for second and next points.

5 Choose when you want pointer input tooltips to display:

• After Starting to Type Coordinate Data Pointer input tooltips appear only when 
you start typing coordinate data. 

• When a Command Prompts for a Point Pointer input tooltips automatically 
appear when a command prompts for a point.

• Always - Even When Not in a Command Pointer input tooltips always display.

6 If you want to always display a symbol indicating the point format, mark Show 
'@' or '#' Before Coordinates.

7 Click OK.

To customize dimension input settings
1 In the Drawing Settings dialog box, click the Dynamic Input tab.

2 In Dimension Input, click Settings.

3 Choose one of the following to determine when dimension input displays during 
grip editing:

• One Dimension Input Field Only Displays one dimension input field which can 
vary depending on the entity selected.

• Two Dimension Input Fields Displays two dimension input fields which can 
vary depending on the entity selected.

• Any Combination of Dimension Input Fields Displays all enabled dimension 
input fields that you select: resulting dimension mark, length change mark, 
absolute angle mark, angle change mark, and arc radius mark.

4 If you want to use the ANGBASE system variable when specifying the north 
direction relative to the current UCS, mark Use ANGBASE Angle. If unmarked, 
ANGBASE is ignored which can lead to unpredictable results in some cases.

5 Click OK.
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To customize the appearance of dynamic input tooltips
1 In the Drawing Settings dialog box, click the Dynamic Input tab.

2 Click Tooltip Appearance.

3 In Model Space Colors, select a color for the text and background of dynamic 
input tooltips that display in model space. 

4 In Paper Space Colors, select a color for the text and background of dynamic input 
tooltips that display in paper space. 

5 In Size, move the slider to specify the size of dynamic input tooltips and text. 

6 In Transparency, move the slider to specify the transparency of dynamic input 
tooltips and text. 

7 Click OK.

Using entity snaps   

Entity snaps enable you to quickly select exact geometric points on existing entities 
without having to know the exact coordinates of those points. With entity snaps, you 
can select the endpoint of a line or arc, the center point of a circle, the intersection of 
any two entities, or any other geometrically significant position. You can also use 
entity snaps to draw entities that are tangent or perpendicular to an existing entity.              

You can use entity snaps any time the program prompts you to specify a point—for 
example, if you are drawing a line or other entity. You can work with entity snaps in 
one of two ways:

• Enable a running entity snap that remains in effect until you turn it off by choosing 
an entity snap when no other command is active.    

• Enable a one-time entity snap for a single selection by choosing an entity snap 
when another command is active. You can also use a one-time entity snap to over-
ride a running entity snap.    

If you type the name of entity snaps, you don’t need to type the whole name.
Type only the first three letters of the snap name.    

When using entity snaps, the program recognizes only visible entities or visible por-
tions of entities. You cannot snap to entities on layers that have been turned off or fro-
zen.

When you specify one or more entity snaps, an entity snap target box is added to the 
crosshairs. In addition, an icon appears adjacent to the crosshairs indicating the active 
entity snap. When you select an entity, the program snaps to the snap point closest to 
the center of the target box.            
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Setting entity snaps             
You can set entity snaps using any of the following methods:        

• On the ribbon, choose Draw and in Entity Snaps, choose the entity snap you want 
to set.

• Choose Tools > Entity Snaps, and choose the entity snap you want to set.

• On the Entity Snaps toolbar, click one of the entity snap tools.

• In the command bar, type an entity snap command.

• In the status bar, click Entity Snap Settings and choose the entity snap you want to 
set.    

• Press and hold down the Shift key while right-clicking anywhere within the draw-
ing window to display the entity snap shortcut menu, and then choose the entity 
snap you want to set.    

You can also set entity snaps using the Drawing Settings dialog box. To do this, 
choose Tools > Entity Snaps > Entity Snap Settings. The Drawing Settings dialog box 
is displayed with the Coordinate Input tab active. In the Entity Snap Modes list, click 
the check box for each of the entity snaps that you want to set.

There are several indicators if an entity snap is active. 
If you select an entity snap, a check mark appears next to the entity snap in the menu, 
the associated tool if the Entity Snaps toolbar is active, and the corresponding box is 
checked in the Coordinate Input tab of the Drawing Settings dialog box. 

To change the size of the entity snap target box      
1 Do one of the following to choose Drawing Settings ( ):

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Coordinate Input tab.

3 Click the Entity Selection tab.

4 Under Entity Snap Aperture, change the value in the Aperture field.

5 Click OK. 
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Nearest snap
Use the Nearest snap to snap to the nearest point of another entity. You can snap to 
the nearest point on an arc, circle, ellipse, elliptical arc, line, point, polyline segment, 
ray, spline, infinite line, or hatch pattern that is visually closest to the cursor.

To set the Nearest snap    
Do one of the following to choose Nearest ( ):

• On the ribbon, choose Draw > Nearest (in Entity Snaps).

• On the menu, choose Tools > Entity Snaps > Nearest.

• On the Entity Snaps toolbar, click the Nearest tool.

• Type nearest and then press Enter.

Endpoint snap
Use the Endpoint snap to snap to the endpoint of another entity. You can snap to the 
closest endpoint of an arc, line, polyline segment, ray, hatch pattern, plane, or three-
dimensional face. If an entity has thickness, the Endpoint snap also snaps to the end-
points of the edges of the entity.       

A Choose Entity Selection. B Type or select the entity snap aperture size.

B

A
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To set the Endpoint snap
Do one of the following to choose Endpoint ( ):

• On the ribbon, choose Draw > Endpoint (in Entity Snaps).

• On the menu, choose Tools > Entity Snaps > Endpoint.

• On the Entity Snaps toolbar, click the Endpoint tool.

• Type endpoint and then press Enter. 

 

Midpoint snap
Use the Midpoint snap to snap to the midpoint of another entity. You can snap to the 
midpoint of an arc, ellipse, line, polyline segment, plane, infinite line, spline, or hatch 
pattern. In the case of infinite lines, the midpoint snaps to the first defined point. If an 
entity has thickness, the midpoint entity snap also snaps to the midpoint of the edges 
of the entity.        

Type m2p or mtp to enable a one-time snap to the midpoint between two points. 
You specify the points, such as two points selected using entity snaps.   

To set the Midpoint snap
Do one of the following to choose Midpoint ( ):

• On the ribbon, choose Draw > Midpoint (in Entity Snaps).

• On the menu, choose Tools > Entity Snaps > Midpoint.

• On the Entity Snaps toolbar, click the Midpoint tool.

• Type midpoint and then press Enter.  

To snap to the endpoint, select anywhere on the entity near its endpoint (A).

To snap to the midpoint, select anywhere on the entity near its midpoint (A).

A

A
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Center snap
Use the Center snap to snap to the center point of another entity. You can snap to the 
center of an arc, circle, polygon, ellipse, or elliptical arc. To snap to the center, you 
must select a visible portion of the entity.    

To set the Center snap
Do one of the following to choose Center ( ):    

• On the ribbon, choose Draw > Center (in Entity Snaps).

• On the menu, choose Tools > Entity Snaps > Center.

• On the Entity Snaps toolbar, click the Center tool.

• Type center and then press Enter.  

Geometric Center snap
Use the Geometric Center snap to snap to the centroid of another entity. You can snap 
to the geometric center of any closed polyline or spline. To snap to the geometric cen-
ter, you must select a visible portion of the entity.   

To set the Geometric Center snap
Do one of the following to choose Geometric Center ( ):    

• On the ribbon, choose Draw > Geometric Center (in Entity Snaps).

• On the menu, choose Tools > Entity Snaps > Geometric Center.

• On the Entity Snaps toolbar, click the Geometric Center tool.

• Type gcenter and then press Enter.  

To snap to the center, select anywhere on the visible portion of the entity (A).

To snap to the geometric center, select anywhere on the visible portion of the 
entity (A).

A
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Perpendicular snap
Use the Perpendicular snap to snap to a point perpendicular to the selected entity. 
You can snap to an arc, circle, ellipse, line, polyline, infinite line, ray, spline, hatch 
pattern, or edge of a plane to form a perpendicular alignment with that entity or with 
an imaginary extension of that entity.    

To set the Perpendicular snap    
Do one of the following to choose Perpendicular ( ):

• On the ribbon, choose Draw > Perpendicular (in Entity Snaps).

• On the menu, choose Tools > Entity Snaps > Perpendicular.

• On the Entity Snaps toolbar, click the Perpendicular tool.

• Type perpendicular and then press Enter.  

Tangent snap
Use the Tangent snap to snap to the tangent point of another entity. You can snap to 
the point on an arc, ellipse, spline, or circle that, when connected to the previous 
point, forms a line tangent to that entity.

To set the Tangent snap       
Do one of the following to choose Tangent ( ):

• On the ribbon, choose Draw > Tangent (in Entity Snaps).

• On the menu, choose Tools > Entity Snaps > Tangent.

• On the Entity Snaps toolbar, click the Tangent tool.

• Type tangent and then press Enter.  

To form a perpendicular angle (A) to an entity (B), select anywhere on 
the entity.

To snap to a tangent, select the entity near the tangent point (A).

A

B

A
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Quadrant snap
Use the Quadrant snap to snap to the quadrant point of another entity. You can snap 
to the closest quadrant of an arc, circle, ellipse, or elliptical arc.

To set the Quadrant snap    
Do one of the following to choose Quadrant ( ):

• On the ribbon, choose Draw > Quadrant (in Entity Snaps).

• On the menu, choose Tools > Entity Snaps> Quadrant.

• On the Entity Snaps toolbar, click the Quadrant tool.

• Type quadrant and then press Enter.  

To snap to a quadrant, select the entity near the quadrant point (A).

A
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Insertion Point snap
Use the Insertion Point snap to snap to the insertion point of an attribute, block, or 
text entity.              

To set the Insertion Point snap
Do one of the following to choose Insertion Point ( ):

• On the ribbon, choose Draw > Insertion Point (in Entity Snaps).

• On the menu, choose Tools > Entity Snaps> Insertion Point.

• On the Entity Snaps toolbar, click the Insertion Point tool.

• Type insertion and then press Enter.  

Node snap
Use the Node snap to snap to a point entity.        

To set the Node snap
Do one of the following to choose Node ( ):

• On the ribbon, choose Draw > Node (in Entity Snaps).

• On the menu, choose Tools > Entity Snaps > Node.

• On the Entity Snaps toolbar, click the Node tool.

• Type node and then press Enter.  

To snap to an insertion point, select anywhere on the entity (A).

To snap to a point entity, select the entity (A).

A

A

A
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Extension snap
Use the Extension snap to snap to a temporary extension line of an arc or line. To 
make the extension line visible, pause the cursor over the endpoints of the entity.   

To set the Extension snap

Do one of the following to choose Extension ( ):    

• On the ribbon, choose Draw > Extension (in Entity Snaps).

• On the menu, choose Tools > Entity Snaps > Extension.

• On the Entity Snaps toolbar, click the Extension tool.

• Type extension and then press Enter. 

Parallel snap
Use the Parallel snap to show parallel guides when picking second and subsequent 
points of new linear entities. Guides display parallel to lines, infinite lines, rays, or 
linear segments of polylines that you indicate with the cursor.       

Turn Orthogonal off before using parallel snapping
On the status bar, click Orthogonal On/Off ( ) or press F8 to turn it off or on.

To set the Parallel snap
Do one of the following to choose Parallel ( ):

• On the ribbon, choose Draw > Parallel (in Entity Snaps).

• On the menu, choose Tools > Entity Snaps > Parallel.

• On the Entity Snaps toolbar, click the Parallel tool.

• Type parallel and then press Enter. 

Select the first point of an entity (A), hover over the desired parallel entity (B), 
then move the cursor back to the new entity to view the guide.

B

A
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To draw a parallel linear entity
1 Choose a command, for example, line.

2 Select the entity’s first point.

3 Type par and then press Enter.

4 Move the cursor over the desired linear entity. A small “x” marks the position on 
the linear entity.

5 Select additional entities if necessary. You can also deselect an entity by moving 
the cursor over its corresponding “x.”

6 Move the cursor back to the entity you are creating and use the parallel guide to 
specify the next point of the entity.

Apparent Intersection snap
The Apparent Intersection snap snaps to the intersection of two entities that do not 
intersect in three-dimensional space but seem to intersect in the current view. You 
can snap to the intersection of any two entities in the combination of an arc, circle, 
line, infinite line, polyline, ray, ellipse, elliptical arc, spline, hatch pattern, polygon 
mesh, or polyface mesh. You can also snap to an intersection point within a single 
entity, including a polyline or spline.          

The Extended Apparent Intersection snap snaps to the logical location where two 
entities (lines, arcs, or elliptical segments) would intersect if they were of infinite 
length. Dashed extension lines are drawn to help show the extended apparent inter-
section.

There are two types of intersection snaps. 
You can set the Apparent Intersection snap or Intersection snap, but you cannot use 
both at the same time. 

To set the Apparent Intersection snap      
Do one of the following to choose Apparent Intersection ( ):

• On the ribbon, choose Draw > Apparent Intersection (in Entity Snaps).

• On the menu, choose Tools > Entity Snaps > Apparent Intersection.

• On the Entity Snaps toolbar, click the Apparent Intersection tool.

• Type apparent and then press Enter.
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To snap to an extended apparent intersection point
1 Choose a command, for example, line.

2 Type app and then press Enter.

3 Select an extended apparent intersection point.

The Extended Apparent Intersection snap turns off automatically after you select a 
point.

From Point snap
Use the From Point snap to set a temporary base point from which to offset point 
selection. The From Point snap can be used only while another active command is 
requesting a point.

To set a temporary offset point
1 Choose a command, for example, type line or move.

2 Do one of the following to choose From Point ( ):

• On the ribbon, choose Draw > From Point (in Entity Snaps).

• On the menu, choose Tools > Entity Snaps > From Point.

• On the Entity Snaps toolbar, click the From Point tool.

• Type from and then press Enter.

3 Select where to place the temporary base point.

4 Enter the offset distance from the base point, for example, (@8.5,0), where you 
want to locate the next point. Note that entering (8.5,0) places an absolute point 
from the UCS origin, not a relative point from the base point.

5 Continue with the original command.

To snap to an intersection, select the apparent intersection (A).

A
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Track Point snap
Use the Track Point snap to set a temporary tracking point while using a command. 
The Track Point snap can be used only while another active command is requesting a 
point.

To set a Track Point snap
1 Choose a command, for example, type line or move.

2 Do one of the following to choose Track Point ( ):

• On the ribbon, choose Draw > Track Point (in Entity Snaps).

• On the menu, choose Tools > Entity Snaps > Track Point.

• On the Entity Snaps toolbar, click the Track Point tool.

• Type tt and then press Enter.

3 Select a point to mark a temporary tracking point.

4 Continue with the original command.

Mid Between 2 Points snap
Use the Mid Between 2 Points snap to set a temporary midpoint snap between two 
points. The Mid Between 2 Points snap can be used only while another active com-
mand is requesting a point.

To set a temporary midpoint snap between two points
1 Choose a command, for example, line or move.

2 Do one of the following to choose Mid Between 2 Points ( ):

• On the ribbon, choose Draw > Mid Between 2 Points (in Entity Snaps).

• On the menu, choose Tools > Entity Snaps > Mid Between 2 Points.

• On the Entity Snaps toolbar, click the Mid Between 2 Points tool.

• Type m2p (or mtp) and then press Enter.

3 Select the first point.

4 Select the second point. The midpoint is calculated automatically.

5 Continue with the original command.

Clearing entity snaps
Use the Clear Entity Snaps command to turn off all entity snap settings, regardless of 
how they were set: by menu, tool, command, or in the Drawing Settings dialog box.

To clear entity snaps
Do one of the following to choose Clear Entity Snaps ( ):

• On the ribbon, choose Draw > Clear Entity Snaps (in Entity Snaps).

• On the menu, choose Tools > Entity Snaps > Clear Entity Snaps.
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• On the Entity Snaps toolbar, click the Clear Entity Snaps tool.

• Type none and then press Enter.

Using fly-over snapping 
Fly-over snapping is a visual aid to help you see and use entity snaps more efficiently. 
When fly-over snapping is turned on, IntelliCAD displays a colored marker at match-
ing entity snap points as you move the crosshairs around the drawing. 

Viewing fly-over snap markers
Each entity snap has its own marker. 

Fly-over snap markers    
Marker Entity snap

Endpoint

Nearest

Midpoint

Center

Geometric Center

Perpendicular

Tangent

Extension

Quadrant

Insertion Point

Parallel

Node

Intersection

Apparent Intersection
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Setting up fly-over snapping
When fly-over snapping is enabled and multiple entity snaps are on, you can press 
Tab to cycle through the available entity snap points of the entities covered by the tar-
get box. For example, when the Endpoint and Midpoint snaps are on and the aperture 
box is located on a line, press Tab to cycle between the line's closest endpoint and 
midpoint.

To set the fly-over snapping options 
1 Do one of the following to choose Drawing Settings ( ):

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings or choose Tools > Entity Snaps 
> Entity Snap Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Coordinate Input tab.

3 Click the Entity Snaps tab.

4 Click Display Options. The Options dialog box opens to the Snapping tab. 

5 Mark Enable Fly-Over Snapping to turn on fly-over snapping. 

6 Set the fly-over options, including the color, size, and thickness of the snap 
marker. 

7 Click OK. 

8 Click OK again. 

For details about the various fly-over snapping options, see “Changing the options on 
the Snapping tab” on page 860. 
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Using entity snap tracking
When entity snap tracking is turned on, guides display at specified angles outward 
from temporary tracking points. This can help you draw and modify entities using the 
relative position of existing entities, for example, inserting a block with the same y-
coordinate of an existing line. 

Temporary tracking points are marked with a red plus sign, and can be placed any-
where in the drawing. To select where tracking points display, first activate a com-
mand that requests a point, then:

• Move the cursor and hover over an entity snap point to add a tracking point.

• Choose the Track Point command, then select anywhere in the drawing for the 
tracking point to reside.

• Move the cursor and hover over an existing tracking point to remove a tracking 
point.

You can set up entity snap tracking to display guides at 90-degree increments or addi-
tional increments that are defined for polar tracking. You can also set up entity snap 
tracking to display guides relative to the current UCS or relative to the last segment 
drawn. 

To use entity snap tracking, at least one entity snap must be turned on and running 
snaps cannot be turned off. Polar tracking does not have to be turned on in order to 
use entity snap tracking.       

To turn entity snap tracking on or off
1 Do one of the following to choose Drawing Settings ( ):       

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Coordinate Input tab.

3 Click the Entity Snaps tab.

4 Click the Entity Snap Tracking checkbox.



106 C H A P T E R  3
Toggle entity snap tracking on and off. 
Click the Entity Snap Tracking On/Off on the status bar, type ENTTRACK, or press 
F11.    

To specify settings for entity snap tracking
1 Do one of the following to choose Drawing Settings ( ):       

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Coordinate Input tab.

3 Click the Polar Tracking tab.

4 Select one of the following to specify entity tracking settings:

• Orthogonal Only 90-degree angle increments are used for entity snap tracking, 
regardless of polar tracking settings.

• Use all polar tracking angles All defined polar tracking angles, including those 
other than 90-degree angle increments, are used for entity snap tracking.

5 Select one of the following to specify how the angles of guides are calculated for 
entity snap tracking:

• Absolute Guides display at angles relative to the current UCS.

• Relative to last segment Guides display at angles relative to the last segment 
drawn, if creating entities with multiple segments (otherwise guides display at 
absolute angles).

6 Click OK.

Start a command, hover over one or more entity snap points to mark them with a 
tracking point (A then B), then move the cursor to view the guides (C). In this 
example, the Midpoint snap is turned on and entity snap tracking displays at 90-
degree increments.

A

B

C
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A Select to use either 90-degree increment angles 
or all angles specified in Increment Angle and 
Additional Angles for polar tracking.

B Select whether angles for guides are calculated 
relative to the current UCS or relative to the last 
previously drawn segment when drawing entities 
with more than one segment.

A

B
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Saving your drawing    

When you save a drawing, your work is saved in a drawing (.dwg) file. 

After you have saved your drawing for the first time, you can save it with a new 
name. In addition to drawing (.dwg) files, you can also save a drawing in a Drawing 
Exchange Format (.dxf) file or a drawing template (.dwt) file. 

If you created your drawing using a template, saving the drawing does not alter the 
original template.

If you need an added level of security for your drawing files, you can save the draw-
ing with a password so only you and those who know the password can open the 
drawing.

Saving a drawing
To save a drawing, choose any of the following methods to choose Save ( ):

• On the ribbon Quick Access toolbar, click Save, or on the ribbon Application but-
ton, choose Save.

• On the menu, choose File > Save.

• On the Standard toolbar, click Save.

• Type save and then press Enter.

• Type qsave and then press Enter.

When you save a drawing the first time, the program displays the Save Drawing As 
dialog box so that you can choose a directory and type a name for the drawing. You 
can use any name when you first save the drawing. 
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Saving a drawing with a new name or file format
You can save a drawing with a new name and in any of the following file formats:

• Standard drawing files with a .dwg extension. You can choose a .dwg file format 
that is compatible with various versions of AutoCAD.

• Drawing Exchange Format files with a .dxf file extension. You can choose a .dxf 
file format that is compatible with various versions of AutoCAD.

• Drawing templates with a .dwt file extension. Drawing templates allow you to eas-
ily create new drawings that reuse your drawing settings and entities.

To save a drawing with a new name or file format 
1 Do one of the following to choose Save As: 

• On the ribbon Quick Access toolbar, click Save As, or on the ribbon Application 
button, choose Save As.

• On the menu, choose File > Save As.

• Type saveas and then press Enter.

2 In the Save Drawing As dialog box, under Save As Type, choose the file format.

3 Specify the name of the file you want to create.

4 Click Save.

A Displays a description of the file size, creation 
date, and other information about the drawing.

B Unavailable when saving drawings; available 
only when opening drawings.

C Turns the drawing preview on or off.
D Saves the drawing with a password.
E Displays an image of the drawing before you 

save it.     

A

B
C

E

D
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Drawings can also be saved by exporting to various file formats. 
For more details, see “Exporting drawings” on page 799. 

Saving a drawing with a password
Sometimes drawings may contain confidential information and you want to control 
who has access to that information. If you need an added level of security, you can 
save a drawing with a password so only you and those who know the password can 
open the drawing.

To save a drawing with a password, you must save it as a .dwg file for AutoCAD ver-
sion 2004 or newer.

Record passwords or use familiar words. 
If you forget a drawing’s password, the drawing cannot be opened or recovered. You 
may want to store all passwords in a safe place.

To save a drawing with a password
1 Do one of the following to choose Save As: 

• On the ribbon Quick Access toolbar, click Save As, or on the ribbon Application 
button, choose Save As.

• On the menu, choose File > Save As.

• Type saveas and then press Enter.

2 In the Save Drawing As dialog box, under Save As Type, choose a .dwg file for 
AutoCAD version 2004 or newer.

3 Click Password Protect.

4 Choose a folder where you want to save the drawing.

5 In File Name, specify the name of the file you want to create.

6 Click Save.

7 In the Password dialog box, enter a password.

8 If desired, record and store the password in a safe place. If you forget the draw-
ing’s password, the drawing cannot be opened or recovered.

9 Click OK.
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Creating simple entities  

Simple entities include lines (both finite and infinite), circles, arcs, ellipses, elliptical 
arcs, points, and rays. In addition, IntelliCAD includes a freehand sketch tool that can 
be used to create simple entities.

This section explains several methods for creating simple entities, including how to:

• Use menu commands on the Draw menu.

• Use the tools on the Draw toolbar.

• Type commands in the command bar.

In some cases, there are a number of different ways to create an entity. For the most 
part, one or two are given in this guide. Refer to the Command Reference in the 
online Help to learn how to create entities using other methods.

When you use a tool or a drawing command, the program prompts you to enter coor-
dinate points, such as endpoints or insertion points. You can enter the points or dis-
tances either using a mouse or by typing coordinate values in the command bar. As 
you draw, IntelliCAD also displays a context-sensitive prompt box with appropriate 
additional options for the type of entity you are drawing.

After you create entities, you can modify them using the entity modification tools.

Topics in this chapter

Drawing lines .................................................................................................... 112

Drawing circles ................................................................................................. 113

Drawing arcs..................................................................................................... 117

Drawing ellipses................................................................................................ 121

Drawing elliptical arcs ....................................................................................... 122

Drawing point entities ....................................................................................... 123
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Drawing infinite lines......................................................................................... 126

Drawing construction lines................................................................................ 128

Drawing freehand sketches .............................................................................. 135
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Drawing lines

A line consists of two points: a start point and an endpoint. You can connect a series 
of lines, but each line segment is considered a separate line entity.  

To draw a line
1 Do one of the following to choose Line ( ):

• On the ribbon, choose Home > Line or choose Draw > Line.

• On the menu, choose Draw > Line.

• On the Draw toolbar, click the Line tool.

• Type line and then press Enter.

2 Specify the start point.

3 Specify the endpoint.

4 In the prompt box, choose Done to complete the command.

The prompt box provides several options as you draw. For example, when you draw 
the first line segment, you can specify its length or orientation angle. After you draw 
at least one line segment, you can click Undo to remove the previous line segment. 
You can click Done to end the line command. After you draw two or more line seg-
ments, you can click Close to complete the line command by drawing a line segment 
that connects to the start point of the first line segment you drew.

If the last entity you drew was an arc, you can also draw a line tangent to and starting 
from the endpoint of the arc.

To draw a line as a continuation from the end of an arc 
1 Do one of the following to choose Line ( ):

• On the ribbon, choose Home > Line or choose Draw > Line.

• On the menu, choose Draw > Line.

• On the Draw toolbar, click the Line tool.

• Type line and then press Enter.

2 In the prompt box, choose Follow.

3 Specify the length of the line.

Start point (A) and endpoint (B).

A

B
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Drawing circles

The default method for drawing a circle is to specify a center point and radius. You 
can draw circles using any of the following methods:         

• Center-Radius ( )

• Center-Diameter ( ) 

• 2-Points ( ) 

• 3-Points ( )

• Radius-Tangents ( ) 

• Tan-Tan-Tan

• Convert Arc to Circle ( )

To draw a circle by specifying its center and radius 
1 Do one of the following to choose Circle Center-Radius ( ): 

• On the ribbon, choose Home > Circle Center-Radius or choose Draw > Circle 
Center-Radius.

• On the menu, choose Draw > Circle > Circle Center-Radius.

• On the Draw toolbar, click the Circle Center-Radius tool.

• Type circle and then press Enter.

2 Specify the center point.

3 Specify the radius of the circle.

Endpoint of previous arc (A) and length of the line (B).

A

B

Center point (A) and radius (B).

A
B
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To draw a circle by specifying its center and diameter
1 Do one of the following to choose Circle Center-Diameter ( ): 

• On the ribbon, choose Home > Circle Center-Diameter or choose Draw > Circle 
Center-Diameter. Skip step 3.

• On the menu, choose Draw > Circle > Circle Center-Diameter. Skip step 3.

• On the Draw toolbar, click the Circle tool.

• Type circle and then press Enter.

2 Specify the center point.

3 In the prompt box choose Diameter.

4 Specify the second point indicating the diameter of the circle.

To draw a circle by specifying two endpoints of the diameter
1 Do one of the following to choose Circle 2-Points ( ): 

• On the ribbon, choose Home > Circle 2-Points or choose Draw > Circle 2-
Points. Go to step 3.

• On the menu, choose Draw > Circle > Circle 2-Points. Go to step 3.

• On the Draw toolbar, click the Circle tool.

• Type circle and then press Enter.

2 In the prompt box choose 2 Points.

3 Specify the first endpoint of the diameter of the circle.

4 Specify the second endpoint of the diameter of the circle.

Center point (A) and diameter (B).

A

B

First endpoint (A) and second endpoint (B).

A

B
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To draw a circle by specifying three points on the circumference
1 Do one of the following to choose Circle 3-Points ( ): 

• On the ribbon, choose Home > Circle 3-Points or choose Draw > Circle 3-
Points. Go to step 3.

• On the menu, choose Draw > Circle > Circle 3-Points. Go to step 3.

• On the Draw toolbar, click the Circle tool.

• Type circle and then press Enter.

2 In the prompt box choose 3 Points.

3 Specify the first point on the circumference of the circle.

4 Specify the second point on the circumference of the circle.

5 Specify the third point on the circumference of the circle.

To draw a circle by specifying its radius and two tangent points
1 Do one of the following to choose Circle Radius-Tangents ( ): 

• On the ribbon, choose Home > Circle Radius-Tangents or choose Draw > Circle 
Radius-Tangents. Go to step 3.

• On the menu, choose Draw > Circle > Circle Radius-Tangents. Go to step 3.

• On the Draw toolbar, click the Circle tool.

• Type circle and then press Enter.

2 In the prompt box, choose Tangent-Tangent-Radius.

3 Select the first entity that you want the circle to touch

4 Select the second entity that you want the circle to touch.

5 Specify the radius of the circle.

First point (A), second point (B), third point (C).

A

B

C
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To draw a circle tangent to three entities 
1 Do one of the following to choose Tan-Tan-Tan ( ): 

• On the ribbon, choose Home > Circle Tan-Tan-Tan or choose Draw > Circle 
Tan-Tan-Tan. Go to step 3.

• On the menu, choose Draw > Circle > Tan-Tan-Tan. Go to step 3.

• On the Draw toolbar, click the Circle tool.

• Type circle and then press Enter.

2 In the prompt box, choose Tangent-Tangent-Tangent.

3 Select the first entity that you want the circle to touch

4 Select the second entity that you want the circle to touch.

5 Select the third entity you want the circle to touch.

To convert an arc to a circle
1 Do one of the following to choose Convert Arc to Circle ( ): 

• On the ribbon, choose Home > Convert Arc to Circle or choose Draw > Convert 
Arc to Circle.

• On the menu, choose Draw > Circle > Convert Arc to Circle.

• On the Draw toolbar, click the Convert Arc to Circle tool. 
Go to step 3.

• Type circle and then press Enter.

2 In the prompt box, choose Turn Arc Into Circle.

3 Select the arc you want to convert to a circle. 

Tangent lines (A) and (B) and radius of circle (C).

A

B
C

First tangent entity (A), second tangent entity (B) and third 
tangent entity (C).

A

B

C
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Drawing arcs

An arc is a portion of a circle. The default method for drawing an arc is to specify 
three points—the start point, a second point, and the endpoint. You can draw arcs 
using any of the following methods:                                                

• Three points on an arc ( ).

• Start point-center-endpoint ( ), or Start point-endpoint-center ( ), or Center-
start point-endpoint ( ).

• Start point-center-included angle ( ), or Start point-included angle-center 
( ), or Center-start point-included angle ( ).    

• Start point-center-chord length ( ), or Center-start point-chord length ( ).   

• Start point-endpoint-radius ( ), or Start point-radius-endpoint ( ). 

• Start point-endpoint-included angle ( ), or Start point-included angle-endpoint 
( ).

• Start point-endpoint-starting direction ( ), or Start point-starting direction-end-
point ( ).

• Start point-radius-angle ( ).

• As a tangent continuation of the previous arc or line ( ).

Select an arc (A) to convert to a circle.

A
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To draw an arc by specifying three points
1 Do one of the following to choose 3-Point Arc ( ):

• On the ribbon, choose Home > 3-Point Arc (in Draw) or choose Draw > 3-Point 
Arc (in Draw).

• On the menu, choose Draw > Arc > 3-Point Arc.

• On the Draw toolbar, click the 3-Point Arc tool.

• Type arc and then press Enter.

2 Specify the start point.

3 Specify a second point.

4 Specify the endpoint.

The prompt box provides additional options for drawing arcs. For example, after you 
specify the start point of an arc, you can choose Angle, Center, Direction, Endpoint, 
or Radius. You can select the options in a different order as well. For instance, you 
can draw an arc by specifying its start point, endpoint, and radius, or you can specify 
the start point, radius, and then endpoint.

To draw an arc by specifying its start point, center point, and endpoint
1 Do one of the following to choose Arc Start-Center-End ( ): 

• On the ribbon, choose Home > Arc Start-Center-End (in Draw) or choose Draw 
> Arc Start-Center-End (in Draw).

• On the menu, choose Draw > Arc > Arc Start-Center-End.

• On the Draw toolbar, click the Arc Start-Center-End tool.

• Type arc and then press Enter.

2 Specify the start point.

3 In the prompt box, choose Center.

4 Specify the center point.

5 Specify the endpoint.

Start point (A), second point (B), and endpoint (C).

A

B
C
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To draw an arc by specifying two points and an included angle     
1 Do one of the following to choose Arc Start-End-Angle ( ):

• On the ribbon, choose Home > Arc Start-End-Angle (in Draw) or choose Draw 
> Arc Start-End-Angle (in Draw).

• On the menu, choose Draw > Arc > Arc Start-End-Angle.

• On the Draw toolbar, click the Arc Start-End-Angle tool.

• Type arc and then press Enter.

2 Specify the start point.

3 In the prompt box, choose Angle or type angle.

4 To draw an arc in a counterclockwise direction, enter a positive value for the 
included angle.

To draw an arc in a clockwise direction, enter a negative value for the included 
angle.

5 Specify the endpoint.
 

If the last entity you drew was an arc or a line, you can also draw an arc tangent to and 
starting from the endpoint of the arc or line.

Start point (A), center point (B), and endpoint (C).

A

B

C

Start point (A), endpoint (B), and included angle (C).

A

B

C
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To draw an arc tangent to an arc or line 
1 Do one of the following to choose Tangent Arc ( ):

• On the ribbon, choose Home > Tangent Arc (in Draw) or choose Draw > 
Tangent Arc (in Draw).

• On the menu, choose Draw > Arc > Tangent Arc.

• On the Draw toolbar, click the Tangent Arc tool. Go to step 3.

• Type arc and then press Enter.

2 In the prompt box, choose Follow.

3 Specify the endpoint.

Arcs can be converted to circles 
On the Draw toolbar, click the Convert Arc To Circle flyout tool ( ).

Endpoint (A).

A
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Drawing ellipses

The default method for drawing an ellipse is to specify the endpoints of one axis of 
the ellipse, and then specify a distance representing half the length of the second axis. 
The endpoints of the first axis determine the orientation of the ellipse. The longer axis 
of the ellipse is called the major axis, and the shorter one is the minor axis. The order 
in which you define the axes does not matter. The program determines the major and 
minor axes based on their relative lengths. You can draw ellipses using any of the fol-
lowing methods:  

• Axis-Axis ( )

• Axis-Rotation ( )

• Center-Axes ( ) 

• Center-Rotation ( )

To draw an ellipse by specifying the axis endpoints
1 Do one of the following to choose Ellipse Axis-Axis ( ): 

• On the ribbon, choose Home > Ellipse Axis-Axis or choose Draw > Ellipse 
Axis-Axis.

• On the menu, choose Draw > Ellipse > Ellipse Axis-Axis.

• On the Draw toolbar, click the Ellipse Axis-Axis tool.

• Type ellipse and then press Enter.

2 Specify the first endpoint.

3 Specify the second endpoint. 

4 Specify the half-length of the other axis.

First axis endpoint (A), second axis endpoint (B), and half-length of other axis (C).

A
C

B
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Drawing elliptical arcs

An elliptical arc is a portion of an ellipse. The default method for drawing an ellipti-
cal arc is to specify the endpoints of one axis of the ellipse, and then specify a dis-
tance representing half the length of the second axis. Then you specify the start and 
end angles for the arc, measured from the center of the ellipse in relation to its major 
axis. You can draw elliptical arcs using any of the following methods: 

• Axis-Axis ( ) 

• Axis-Rotation ( )

• Center-Axes ( ) 

• Center-Rotation ( )

To draw an elliptical arc by specifying the axis endpoints
1 Do one of the following to choose Elliptical Arc Axis-Axis ( ):

• On the ribbon, choose Home > Elliptical Arc Axis-Axis or choose Draw > Ellip-
tical Arc Axis-Axis.

• On the menu, choose Draw > Elliptical Arc > Elliptical Arc Axis-Axis.

• On the Draw toolbar, click the Elliptical Arc Axis-Axis tool.

• Type ellipse and then press Enter, and then type a (for Arc) and press Enter.

2 Specify the first endpoint.

3 Specify the second endpoint.

4 Specify the half-length of the other axis.

5 Specify the start angle of the arc.

6 Specify the end angle.

IntelliCAD draws elliptical arcs in the direction you specify. 
Go to Tools > Drawing Settings > Drawing Units tab. Click the Angular Units tab. 
The default setting is counterclockwise.

First axis endpoint (A), second axis endpoint (B), half-length of other axis (C), start angle of arc (D), and 
end angle (E).

A

D

C
E

B
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Drawing point entities

A point entity is a single x,y,z-coordinate location formatted as either a single dot or 
as one of 19 other possible display styles.         

Drawing points
You can draw points one at a time or several at a time. 

To draw a point
1 Do one of the following to choose Point ( ):

• On the ribbon, choose Draw > Point.

• On the menu, choose Draw > Point.

• On the Draw toolbar, click the Point tool.

• Type point and then press Enter.

2 Specify the location of the point.

To draw several points
1 Do one of the following to choose Point ( ):

• On the ribbon, choose Draw > Point.

• On the menu, choose Draw > Point.

• On the Draw toolbar, click the Point tool.

• Type point and then press Enter.

2 In the prompt box, choose Multiple Points.

3 Specify the location of each point.

4 In the prompt box, choose Done to complete the command.

Changing the size and appearance of point entities
Changing the size and appearance of point entities affects all point entities already in 
the drawing, as well as all points that you subsequently draw. Positive values repre-
sent the absolute size of the point entity measured in drawing units. Negative values 
represent a percentage relative to the drawing screen, so that points retain their visual 
size as you use the Zoom command to change the magnification of the drawing.

To change the size and appearance of point entities
1 Do one of the following: 

• Choose Format > Point Style.

• Type ddptype and then press Enter.

2 Under Point Display Type, select the style you want.

3 Under Point Size, select the point size, or choose one of the options.
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4 Click OK.

When you regenerate the drawing, all point entities change to reflect the new size and 
appearance settings. 

A To increase or decrease the point size, type or 
select a value. 

B To use one of the preset point size options, click 
the one that you want.

C Select the point display type that you want.

A

B

C
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Drawing rays

A ray is a line in three-dimensional space that starts at a point and extends to infinity. 
Because rays extend to infinity, they are not calculated as part of the drawing extents. 
The default method for drawing a ray is to select the start point of the ray and then 
specify its direction. You can draw a ray in any of the following ways:

• Horizontal draws the ray parallel to the x-axis of the current user coordinate sys-
tem (UCS). 

• Vertical draws the ray parallel to the y-axis of the current UCS.

• Angle draws the ray parallel to a specified angle.

• Bisect draws the ray perpendicular to an existing entity.

• Offset draws the ray parallel to an existing entity.

To draw a ray
1 Do one of the following to choose Ray ( ):

• On the ribbon, choose Home > Ray or choose Draw > Ray.

• On the menu, choose Draw > Ray.

• On the Draw toolbar, click the Ray tool.

• Type ray and then press Enter.

2 Specify the start point.

3 Specify the direction.

4 To complete the command, press Enter.

Start point (A) and direction (B).

A B
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Drawing infinite lines

An infinite line is a line through a given point, oriented at a specified angle in three-
dimensional space and extending to infinity in both directions. Because infinite lines 
extend to infinity, they are not calculated as part of the drawing extents.  

The default method for drawing an infinite line is to select a point along the line and 
then specify the direction of the line. You can draw an infinite line in any of the fol-
lowing ways:

• Horizontal draws the infinite line parallel to the x-axis of the current UCS. 

• Vertical draws the infinite line parallel to the y-axis of the current UCS.

• Angle draws the infinite line parallel to a specified angle.

• Bisect draws the infinite line perpendicular to an existing entity.

• Parallel draws the infinite line parallel to an existing entity.

To draw an infinite line
1 Do one of the following to choose Infinite Line ( ):   

• On the ribbon, choose Home > Infinite Line or choose Draw > Infinite Line.

• On the menu, choose Draw > Infinite Line.

• On the Draw toolbar, click the Infinite Line tool.

• Type infline and then press Enter.

2 Specify a point along the line.

3 Specify the direction.

4 To complete the command, press Enter.
.

You can also draw infinite lines at a specific angle or at an angle relative to an exist-
ing entity.

Point along the infinite line (A) and the direction (B).

A
B
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To draw an infinite line at a specified angle relative to another entity
1 Do one of the following to choose Infinite Line ( ):

• On the ribbon, choose Home > Infinite Line or choose Draw > Infinite Line.

• On the menu, choose Draw > Infinite Line.

• On the Draw toolbar, click the Infinite Line tool.

• Type infline and then press Enter.

2 In the prompt box, choose Angle.

3 In the prompt box, choose Reference.

4 Select the reference entity.

5 Specify the angle of the infinite line in relation to the selected entity.

6 Specify the location of the infinite line.

7 To complete the command, press Enter.

Reference entity (A) and angle in relation to entity (B).

A B
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Drawing construction lines

A construction line is a special type of infinite line that is typically used when quick 
drafting techniques are required, for example, to make projections of front and side 
views.

Similar to an infinite line, a construction line is a line through a given point, oriented 
at a specified angle in three-dimensional space and extending to infinity in both direc-
tions. Because construction lines extend to infinity, they are not calculated as part of 
the drawing extents.  

Construction lines are drawn automatically on their own layer, which by default is 
named CLINE. This makes it easy to change the appearance of construction lines; 
simply change the properties of the layer such as its color, transparency, etc. Addi-
tionally, you can specify a different layer for locating construction lines using the 
CLINELAYER system variable.

You can easily draw construction lines in any of the following ways:

• Select a point along the construction line and then specify the direction of the line 
(default drawing method). 

• Horizontally, vertically, or both. 

• By bisecting an existing point, an entity, or two entities.

• According to a specified angle.

• Parallel to or on top of an existing entity.

Construction lines are drawn to match the current UCS.
You can quickly rotate the UCS using Draw > Construction Line > Rotate UCS Z and 
Rotate UCS World (also available on the Construction Lines toolbar).

Drawing construction lines by specifying a basepoint
There are many quick ways to draw construction lines, but the default method is by 
specifying a basepoint along the construction line and then its direction. Using this 
method you can quickly draw an array of construction lines.



C R E A T I N G  S I M P L E  E N T I T I E S 129
To draw a construction line by specifying a basepoint
1 Do one of the following to choose Construction Line > Array from Basepoint 

( ):   

• On the ribbon, choose Draw > Construction Line > Array from Basepoint.

• On the menu, choose Draw > Construction Line > Array from Basepoint.

• On the Construction Line toolbar, click the Array from Basepoint tool.

• Type cline then press Enter.

2 Specify a point along the line.

3 Specify the direction.

4 To complete the command, press Enter.
.

Drawing construction lines by bisecting an angle or entity
Bisection is a quick way to draw construction lines. You can bisect an angle that you 
specify, or you can bisect one or two lines, arcs, or polyline segments.

To draw a construction line by bisecting an angle
1 Do one of the following to choose Construction Line > Bisect Angle ( ):   

• On the ribbon, choose Draw > Construction Line > Bisect Angle.

• On the menu, choose Draw > Construction Line > Bisect Angle.

• On the Construction Line toolbar, click the Bisect Angle tool.

• Type cline, press Enter, then choose Bisect in the prompt box.

2 Select an existing vertex point from which to reference the angle.

3 Specify the first point of the bisection angle.

4 Specify the second point of the bisection angle.

5 To complete the command, press Enter.

Point along the construction line (A) and the direction (B).

A
B
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To draw a construction line by bisecting a line, arc, or polyline segment
1 Do one of the following to choose Construction Line > Bisect Entity ( ):   

• On the ribbon, choose Draw > Construction Line > Bisect Entity.

• On the menu, choose Draw > Construction Line > Bisect Entity.

• On the Construction Line toolbar, click the Bisect Entity tool.

• Type cline, press Enter, choose Bisect in the prompt box, then choose Entity in 
the prompt box.

2 Select a line, arc, or polyline segment to bisect.

To draw a construction line by bisecting two lines, arcs, or polyline segments
1 Do one of the following to choose Construction Line > Bisect Two Entities ( ):   

• On the ribbon, choose Draw > Construction Line > Bisect Two Entities.

• On the menu, choose Draw > Construction Line > Bisect Two Entities.

• On the Construction Line toolbar, click the Bisect Two Entities tool.

• Type cline, press Enter, choose Bisect in the prompt box, then choose Two 
Entities in the prompt box.

2 Select a line, arc, or polyline segment.

3 Select the second line, arc, or polyline segment.

Drawing construction lines horizontally and vertically
Construction lines can be drawn parallel to the x-axis of the current UCS (horizontal), 
parallel to the y-axis of the current UCS (vertical), or parallel to both the x- and y-axis 
of the current UCS (both horizontal and vertical).  

Point to bisect (A), start of the bisection angle (B), and the 
end of the bisection angle (C).

A

C

B
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To draw a horizontal construction line
1 Do one of the following to choose Construction Line > Horizontal ( ):   

• On the ribbon, choose Draw > Construction Line > Horizontal.

• On the menu, choose Draw > Construction Line > Horizontal.

• On the Construction Line toolbar, click the Horizontal tool.

• Type cline and then press Enter.

2 Specify a point along the line.

3 To complete the command, press Enter.
.

To draw a vertical construction line
1 Do one of the following to choose Construction Line > Vertical ( ):   

• On the ribbon, choose Draw > Construction Line > Vertical.

• On the menu, choose Draw > Construction Line > Vertical.

• On the Construction Line toolbar, click the Vertical tool.

• Type cline and then press Enter.

2 Specify a point along the line.

3 To complete the command, press Enter.
.

Point through which you want the horizontal construction 
line to pass (A).

A

Point through which you want the vertical construction line 
to pass (A).

A
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To draw both horizontal and vertical construction lines
1 Do one of the following to choose Construction Line > Both Horizontal and Verti-

cal ( ):   

• On the ribbon, choose Draw > Construction Line > Both Horizontal and 
Vertical.

• On the menu, choose Draw > Construction Line > Both Horizontal and Vertical.

• On the Construction Line toolbar, click the Both Horizontal and Vertical tool.

• Type cline and then press Enter.

2 Specify a point where both construction lines intersect.

3 To complete the command, press Enter.

Horizontal and vertical construction lines can also be drawn automatically.
Choose Draw > Construction Line > Automatic Horizontal, Automatic Vertical, or 
Automatic Both, then select the entities around which you want to draw construction 
lines. Construction lines are drawn automatically without creating duplicates for 
overlapping vertices or entities.

Drawing construction lines by specifying the angle

You can also draw construction lines at a specific angle or at an angle relative to an 
existing entity.

To draw a construction line at a specified angle relative to another entity
1 Do one of the following to choose Construction Line > Angled ( ):   

• On the ribbon, choose Draw > Construction Line > Angled.

• On the menu, choose Draw > Construction Line > Angled.

• On the Construction Line toolbar, click the Angled tool.

• Type cline, choose Angle, and then press Enter.

2 In the prompt box, choose Reference.

3 Select the reference entity.

4 Specify the angle of the construction line in relation to the selected entity.

5 Specify the location of the construction line.

6 To complete the command, press Enter.

Reference entity (A) and angle in relation to entity (B).

A B
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Drawing construction lines that parallel other entities
There are two options for drawing construction lines that parallel existing entities:

• Offset Draws a construction line parallel to an existing entity by a specified offset 
distance.

• Match Draws a construction line on top of an existing entity.

To draw a construction line that parallels another entity and specify an offset 
distance
1 Do one of the following to choose Construction Line > Offset ( ):   

• On the ribbon, choose Draw > Construction Line > Offset.

• On the menu, choose Draw > Construction Line > Offset.

• On the Construction Line toolbar, click the Offset tool.

• Type cline, choose Offset, and then press Enter.

2 Enter the distance you want the construction line drawn from an entity. 

3 Select the entity that you want the construction line to parallel.

4 Select the side of the entity where you want to draw the construction line.

5 To complete the command, press Enter.
.

To draw a construction line that parallels another entity and specify a through 
point
1 Do one of the following to choose Construction Line > Offset ( ):   

• On the ribbon, choose Draw > Construction Line > Offset.

• On the menu, choose Draw > Construction Line > Offset.

• On the Construction Line toolbar, click the Offset tool.

• Type cline, choose Offset, and then press Enter.

2 Choose Through point.

3 Select the entity that you want the construction line to parallel.

4 Specify the point through which you want the construction line to pass.

5 To complete the command, press Enter.

Entity you want to parallel (A) and the side for the 
construction line (B).

A

B
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To draw a construction line that parallels another entity and matches its location
1 Do one of the following to choose Construction Line > On Entity ( ):   

• On the ribbon, choose Draw > Construction Line > On Entity.

• On the menu, choose Draw > Construction Line > On Entity.

• On the Construction Line toolbar, click the On Entity tool.

• Type cline, choose Match, and then press Enter.

2 Select the entity that you want the construction line to match.

3 To complete the command, press Enter.

Erasing construction lines
You can delete construction lines as you would any other entity, but there are two 
tools designed to make it easy to filter them automatically when selecting them for 
deletion.

To delete one or more construction lines
1 Do one of the following to choose Construction Line > Erase ( ):   

• On the ribbon, choose Draw > Construction Line > Erase.

• On the menu, choose Draw > Construction Line > Erase.

• On the Construction Line toolbar, click the Erase tool.

• Type cline, choose Erase, and then press Enter.

2 Select one or more construction lines to delete.

3 To complete the command, press Enter.

To delete all construction lines in a drawing
1 Do one of the following to choose Construction Line > Clear ( ):   

• On the ribbon, choose Draw > Construction Line > Clear.

• On the menu, choose Draw > Construction Line > Clear.

• On the Construction Line toolbar, click the Clear tool.

• Type cline, choose Clear, and then press Enter.

Entity you want to parallel (A) and the point through which 
you want the construction line to pass (B).

A

B
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Drawing freehand sketches

A freehand sketch consists of many straight line segments, created either as individ-
ual line entities or as a polyline.   

Creating freehand sketches
Before you begin creating a freehand sketch, you must set the length, or increment, of 
each segment. The smaller the segments, the more accurate your sketch, but segments 
that are too small can greatly increase the file size

After you specify the length of the sketch segments, the crosshairs change to a Pencil 
tool. Your freehand sketch is not added to the drawing until you “write” the sketch 
into your drawing. This means that you temporarily save the segment that you’ve 
drawn and the segment length, and you can continue sketching. 

To create a freehand sketch
1 Do one of the following to choose Freehand ( ): 

• On the ribbon, choose Draw > Freehand (in Draw) or Draw 3D > Freehand (in 
Curves).

• On the menu, choose Draw > Freehand.

• On the Draw toolbar, click the Freehand tool.

• Type freehand and then press Enter.

2 Specify the length of the sketch segments.

3 Click the mouse button to place the Pencil tool ( ) on the drawing to begin 
sketching.

4 Move the pencil image to draw a temporary freehand sketch.

5 Click the mouse button to lift the pencil up to stop sketching.

6 In the prompt box, choose Write, Then Resume to write the temporary freehand 
sketch into the drawing.

7 Click the mouse button to put the pencil down again and resume sketching.

8 Click the mouse button again to lift the pencil up to stop sketching.

9 In the prompt box, choose Done to write the temporary freehand sketch into the 
drawing and end the command.

A freehand sketch consists of individual line entities or a polyline.
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Erasing freehand sketch lines
You can erase temporary freehand sketch lines that have not yet been written into the 
drawing by choosing the Delete On option in the prompt box. The pencil changes to 
an Eraser tool. You can erase portions of the line when you move the eraser over a 
temporary freehand line without clicking the mouse button.

To erase freehand sketch lines
1 Do one of the following to choose Freehand ( ):

• On the ribbon, choose Draw > Freehand (in Draw) or Draw 3D > Freehand (in 
Curves).

• On the menu, choose Draw > Freehand.

• On the Draw toolbar, click the Freehand tool.

• Type freehand and then press Enter.

2 Specify the length of the sketch segments.

3 Select a point on the drawing to display the Pencil tool and begin sketching.

4 Click the mouse button to lift the pencil up to stop sketching.

5 In the prompt box, choose Delete On.

6 Move the Eraser tool ( ) to the beginning or end of the freehand sketch line that 
you drew, and then move it as far along the line as you want to erase.

7 Click the mouse button to put the Pencil tool down to resume sketching.

Setting the sketch method and accuracy
Using polylines for freehand sketches makes it easier to go back and edit sketches. 
You control whether to create freehand sketches using line segments or polylines in 
the Drawing Settings dialog box. You can also control the length of sketch segments 
in this dialog box. 
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To specify lines or polylines when sketching
1 Do one of the following to choose Drawing Settings ( ):

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Choose the Entity Creation tab.

3 Click the Freehand Sketches tab.

4 Under Freehand Sketching Methods, click either Freehand Command Creates 
Lines or Freehand Command Creates A Polyline.

5 Click OK.        

A Select the sketch method. B Specify the default length of sketch segments.

A

B
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5

Creating complex entities

Complex entities include polylines (including rectangles, squares, and polygons), 
spline curves, donuts, and planes. In addition, IntelliCAD includes tools for adding 
tables, wipeouts, revision clouds, leaders, hatching, and gradients to your drawings.   
In some cases, there are a number of different ways to create an entity. For the most 
part, one or two are given in this guide. Refer to the Command Reference in the 
online Help to learn how to create entities using other methods.

When you type a drawing command or select a tool, the program prompts you to 
enter coordinate points, such as endpoints or insertion points. As you draw, the pro-
gram displays a context-sensitive prompt box with appropriate additional options for 
the type of entity you are drawing.

After you create complex entities, you can modify them using the entity-modification 
tools. Several of these entity types require special editing commands. 

Topics in this chapter

Drawing rectangles and squares ...................................................................... 140

Drawing polygons ............................................................................................. 142

Drawing polylines.............................................................................................. 144

Drawing multilines............................................................................................. 147
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Creating planes................................................................................................. 161
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Drawing revision clouds .................................................................................... 190

Adding multileaders .......................................................................................... 193

Defining boundaries.......................................................................................... 209

Adding hatching and gradients ......................................................................... 212
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Drawing rectangles and squares

Rectangles are closed polylines with four sides and a square is a rectangle with four 
equal sides.    

You draw a rectangle by specifying its opposite corners. The rectangle is normally 
aligned parallel to the current snap and grid alignment, but you can use the Rotated 
option to align the rectangle to any angle.

You draw a square using the Square option of the Rectangle command. The square is 
normally aligned parallel to the current snap and grid alignment, but you can use the 
Rotated option to align the square to any angle.

To draw a rectangle
1 Do one of the following to choose Rectangle ( ):

• On the ribbon, choose Home > Rectangle or choose Draw > Rectangle.

• On the menu, choose Draw > Rectangle.

• On the Draw toolbar, click the Rectangle tool.

• Type rectangle and then press Enter.

2 Specify one corner of the rectangle.

3 Specify the opposite corner of the rectangle.   
 

You can edit each side of a rectangle individually using the Edit Polyline tool ( ) 
on the Modify toolbar. You can convert the sides into individual line entities using 
the Explode tool ( ) on the Modify toolbar. You can control whether wide rectan-
gle lines are shown filled or as outlines using the Fill tool ( ) on the Settings tool-
bar.

You can also use the Rectangle tool to draw a square. Instead of specifying the oppo-
site corners, you specify the length of one side and the alignment of the square.

Opposite corners (A and B) and resulting rectangle.

A
B
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To draw a square    
1 Do one of the following to choose Rectangle ( ):

• On the ribbon, choose Home > Rectangle or choose Draw > Rectangle.

• On the menu, choose Draw > Rectangle.

• On the Draw toolbar, click the Rectangle tool.

• Type rectangle and then press Enter.

2 In the prompt box, choose Square.

3 Specify one corner of the square.

4 Specify the length of one side of the square by selecting its other end.

The point you specify determines both the size and alignment of the square.
   

You can control the line width of rectangles.
Choose the Width Of Line option in the prompt box. After you change the width of the 
line, the new width setting remains in effect for subsequent rectangles until you 
change it again.

Endpoints of one side of the square (A and B) and resulting square.                               

A

B
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Drawing polygons

Polygons are closed polylines composed of a minimum of three and a maximum of 
1,024 equal-length sides. The default method for drawing a polygon is to specify the 
center of the polygon and the distance from the center to each vertex. You can draw a 
polygon using any of the following methods:

• Center-Vertex ( )

• Center-Side ( )

• Edge ( )

Drawing polygons by vertex
You can create an equal-sided polygon defined by its center point and the distance to 
its vertices. First specify the number of sides, then the center point, and then the loca-
tion of one vertex, which determines both the size and orientation of the polygon.

To draw a polygon by vertex    
1 Do one of the following to choose Polygon Center-Vertex ( ):

• On the ribbon, choose Home > Polygon Center-Vertex or choose Draw > 
Polygon Center-Vertex.

• On the menu, choose Draw > Polygon > Polygon Center-Vertex.

• On the Draw toolbar, click the Polygon Center-Vertex tool.

• Type polygon and then press Enter.

2 Type 5 to specify five sides for the polygon.

3 Specify the center of the polygon.

4 Specify the vertex of the polygon.

 
The center (A) and vertex (B) and resulting polygon.    

A

B
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Drawing polygons by side
You can create a polygon with equal-length sides defined by its center point and the 
distance to the midpoint of a side. First specify the number of sides, then the center 
point, and then the location of the midpoint of one side, which determines both the 
size and orientation of the polygon.

To draw a polygon by side   
1 Do one of the following to choose Polygon Center-Side ( ):

• On the ribbon, choose Home > Polygon Center-Side or choose Draw > Polygon 
Center-Side.

• On the menu, choose Draw > Polygon > Polygon Center-Side.

• On the Draw toolbar, click the Polygon Center-Side tool.

• Type polygon and then press Enter.

2 Type 3 to specify three sides for the polygon.

3 Specify the center of the polygon.

4 Specify the midpoint of the side.
 

Drawing polygons by specifying the length of an edge
You can create a polygon with equal-length sides defined by the length of one of the 
polygon edges. First specify the number of sides, then the edge start point, and then 
the edge end point, which determines both the size and orientation of the polygon.

To draw a polygon by specifying the length of an edge   
1 Do one of the following to choose Polygon Edge ( ):

• On the ribbon, choose Home > Polygon Edge or choose Draw > Polygon Edge.

• On the menu, choose Draw > Polygon > Polygon Edge.

• On the Draw toolbar, click the Polygon Edge tool.

• Type polygon and then press Enter.

2 Type 5 to specify three sides for the polygon.

3 Specify the first point of an edge on the polygon.

4 Specify the second point of the edge on the polygon.

The center (A) and midpoint of one side (B) and resulting polygon.

A
B
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You can edit each side of a polygon individually using the Edit Polyline tool ( ) on 
the Modify toolbar. You can convert the sides into individual line entities using the 
Explode tool ( ) on the Modify toolbar. You can control whether wide polygon 
lines are shown filled or as outlines using the Fill tool ( ) on the Settings toolbar.              

Drawing polylines    

A polyline is a connected sequence of arcs and lines that is treated as a single entity. 
You can draw a polyline with any linetype and using a width that either remains con-
stant or tapers over the length of any segment. When editing a polyline, you can mod-
ify the entire polyline or change individual segments.         

You can edit entire polylines and individual segments using the Edit Polyline tool 
( ) on the Modify toolbar. You can convert polylines into arc and line entities 
using the Explode tool ( ) on the Modify toolbar. You can control whether wide 
polylines are shown filled or as outlines using the Fill tool ( ) on the Settings 
toolbar.

Drawing a polyline with straight segments
After you specify the start point of a polyline, a prompt box provides several options 
as you draw, such as Distance, Halfwidth, and Width. You can specify different start-
ing and ending widths to create a tapered polyline segment.      

After you draw at least one polyline segment, you can use the Undo tool ( ) to 
remove the previous segment. After you draw two or more polyline segments, you 
can use the Close option to complete the command by drawing a segment that ends at 
the start point of the first polyline segment you drew. Choose Done to complete the 
command without closing the polyline.       

Start point of side (A) and end point of side (B) and resulting polygon.

A

B

Curved polyline with tapered width, polyline with straight segments, and closed polyline.
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To draw a polyline with straight segments
1 Do one of the following to choose Polyline ( ):

• On the ribbon, choose Home > Polyline or choose Draw > Polyline.

• On the menu, choose Draw > Polyline.

• On the Draw toolbar, click the Polyline tool.

• Type polyline and then press Enter.

2 Specify the start point.

3 Specify the endpoint of each segment.

4 To complete the command, choose Close or Done.

Drawing a polyline with arc segments
With the Draw Arcs option, you can continually draw arc segments until you select 
the Draw Lines option to go back to drawing line segments. When you draw arc seg-
ments, the first point of the arc is the endpoint of the previous segment. By default, 
you draw arc segments by specifying the endpoint of each segment. Each successive 
arc segment is drawn tangent to the previous arc or line segment. If you choose Close 
while in the Draw Arcs option, the closing segment is created as an arc. 

You can also specify the arc using any of the following methods:

• Start point, included angle, center point 

• Start point, included angle, radius

• Start point, center point, endpoint

• Start point, included angle, endpoint

• Start point, center point, included angle

• Start point, center point, chord length

• Start point, direction, endpoint

• Start point, radius, included angle

• Start point, second point, endpoint

Polyline start point (A) and segment endpoints (B).

A

B

B

B

B
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To draw a line segment followed by an arc polyline segment
1 Do one of the following to choose Polyline ( ): 

• On the ribbon, choose Home > Polyline or choose Draw > Polyline.

• On the menu, choose Draw > Polyline.

• On the Draw toolbar, click the Polyline tool.

• Type polyline and then press Enter.

2 Specify the start point.

3 Specify the endpoint.

4 In the prompt box, choose Draw Arcs.

5 Specify the endpoint of the arc segment.

6 To complete the command, choose Done.

Polyline start point (A), line endpoint/arc start point (B), and arc endpoint (C).

A
B

C
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Drawing multilines    

A multiline is made from multiple parallel lines (two lines by default), which consist 
of linear segments connected together. The end of the current segment is the start of 
the next segment. Ends of segments are the vertices of the multiline.

Drawing a multiline

To draw a multiline
1 Do one of the following to choose Multiline ( ):

• On the ribbon, choose Draw > Multiline.

• On the menu, choose Draw > Multiline.

• On the Draw toolbar, click the Multiline tool.

• Type mline and then press Enter.

2 Specify the start point.

3 Specify additional vertices.

4 After specifying the last endpoint, choose Done or press Enter.

Specifying justification and scale
When you draw a multiline, you specify the vertices of one of the lines that makes up 
the multiline — the additional parallel lines are drawn in position according to the 
justification. Vertices can be specified on the top, middle, or bottom of a multiline, 
according to the selected justification. 

You can also determine the overall width of the multiline, which affects the distance 
between parallel lines, by adjusting the multiline scale. 

NOTE If you change the multiline scale, you might need to make equivalent changes to 
the linetype scale to prevent dots or dashes from being disproportionately sized.

Multiline startpoint (A), vertices (B), and endpoint (C).

B C

A

B B
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To draw a multiline with different justification or scale
1 Do one of the following to choose Multiline ( ):

• On the ribbon, choose Draw > Multiline.

• On the menu, choose Draw > Multiline.

• On the Draw toolbar, click the Multiline tool.

• Type mline and then press Enter.

2 Select justification and choose one of the following options:

• Top Specified vertices define the top line; additional parallel lines are drawn 
below the specified vertices.

• Zero Specified vertices define the middle of the multiline.

• Bottom Specified vertices define the bottom line; additional parallel lines are 
drawn above the specified vertices.

3 Select Scale and enter a new scale value according to the following:

• Greater than 1 — Multilines are wider. 

• Less than 1 — Multilines are narrower.

• Equal to 1 — Multilines collapse into a single line.

• Negative value — Flips the justification when multilines are drawn and alters 
the scale according to the set value.

4 Specify the start point of the multiline.

5 Specify additional vertices.

6 After specifying the endpoint, choose Done or press Enter.
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Working with multiline styles
When you create a multiline, the program draws it on the current layer, using the cur-
rent multiline style. Each multiline has a corresponding multiline style, which con-
trols the appearance of the multiline, such as the number of parallel lines, the spacing 
between each line and each line’s color and linetype, start and end caps, and more. 

You can create, save, modify, and delete named multiline styles. You can also set any 
multiline style to be the current one that is assigned to new multilines as you add 
them to your drawing. Multiline styles can be exported and imported as .mln files 
which makes it easy to share them between computers.

Multiline styles can also be managed using the Explorer. For more details, see 
“Working with multiline styles” on page 315. 

Creating or modifying a multiline style
Multiline styles provide a way for you to change various settings that control the 
appearance of multilines. You can then save those settings for reuse. If you don’t 
define a multiline style before creating multilines, the program uses the Standard 
multiline style, which stores the default multiline settings. 

If you modify a multiline style, all multilines entities that are assigned that style will 
be updated.

To create a multiline style
1 Do one of the following to choose Multiline Styles Manager ( ):    

• On the ribbon, choose Express Tools > Multiline Styles Manager (in Tools).

• On the menu, choose Format > Multiline Styles Manager or choose Express 
Tools > Tools > Multiline Styles Manager.

• On the Styles toolbar, click the Multiline Styles Manager tool.

• Type mlstyle and then press Enter. 

2 Click New.

3 In Style Name, type the name of the new multiline style.

4 In Start With, select an existing multiline style on which to base the new multiline 
style. 

5 Click Continue.

6 In the Create New Multiline Style dialog box, make your selections for the multi-
line style as necessary.

7 When finished, click OK.



150 C H A P T E R  5
To modify a multiline style
1 Do one of the following to choose Multiline Styles Manager ( ):   

• On the ribbon, choose Express Tools > Multiline Styles Manager (in Tools).

• On the menu, choose Format > Multiline Styles Manager or choose Express 
Tools > Tools > Multiline Styles Manager.

• On the Styles toolbar, click the Multiline Styles Manager tool.

• Type mlstyle and then press Enter. 

2 Select the multiline style you want to modify, then click Modify.

3 In the Modify Multiline Style dialog box, make your selections for the multiline 
style as necessary.

4 When finished, click OK.

A Enter a description for the multiline style.
B Select whether to include a line to cap the start 

or end of multilines assigned this style. 
C Select whether to include an arc for outer lines to 

cap the start or end of multilines assigned this 
style.

D Select whether to include an arc for inner lines to 
cap the start or end of multilines assigned this 
style.

E Select whether to include an angled line to cap 
the start or end of multilines assigned this style.

F Select the color fill for multilines assigned this 
style.

G Select whether to include a line at joints of 
multilines assigned this style. If turned on, a line 
is drawn from the two outer vertices of the 
multiline's joint.

H Click to select the linetype for the element.
I Select the line color for the element. 
J Enter the distance to offset the element, or line, 

from the previous element.
K Click to add a new element according to the 

current offset, color, and linetype selections.
L Click to delete the selected element.
M Displays a list of the offset, color, and linetype 

combinations assigned to each element, or line.

A

B
C
D
E

F

G H

I

J
K
L

M
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Setting the current multiline style
When you create a multiline, it is automatically assigned the multiline style that is set 
to current. By default, the program uses the Standard multiline style, which stores the 
default multiline settings. Or you can choose a different multiline style to be the cur-
rent one.

If you choose a different multiline style as current, that style is assigned to multilines 
that you create in the future, not existing multilines.

To set a multiline style as current
1 Do one of the following to choose Multiline Styles Manager ( ):   

• On the ribbon, choose Express Tools > Multiline Styles Manager (in Tools).

• On the menu, choose Format > Multiline Styles Manager or choose Express 
Tools > Tools > Multiline Styles Manager.

• On the Styles toolbar, click the Multiline Styles Manager tool.

• Type mlstyle and then press Enter.   

2 In the Multiline Styles Manager dialog box, select a multiline style from the list.

3 Click Set Current.

4 Click OK.

Assigning a style to a multiline
You can assign a different multiline style to a multiline at any time.

To assign a style to a multiline
1 Select a multiline in the drawing.

2 Do one of the following:   

• On the Styles toolbar, select the style in the Multiline Style list.

• Right-click the multiline, choose Properties, then in Style, select the style.
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Renaming a multiline style
Use the Multiline Styles Manager dialog box to rename a multiline style. Note that 
the Standard multiline style cannot be renamed.

To rename a multiline style
1 Do one of the following to choose Multiline Styles Manager ( ):   

• On the ribbon, choose Express Tools > Multiline Styles Manager (in Tools).

• On the menu, choose Format > Multiline Styles Manager or choose Express 
Tools > Tools > Multiline Styles Manager.

• On the Styles toolbar, click the Multiline Styles Manager tool.

• Type mlstyle and then press Enter.  

2 In the Multiline Styles Manager dialog box, select the multiline style to rename.

3 Click Rename.

4 Type the new name, then click OK.

5 Click OK.

Deleting a multiline style
Use the Multiline Styles Manager dialog box to delete a multiline style. Note that the 
Standard multiline style cannot be deleted, and multiline styles that are in use also 
cannot be deleted.

To delete a named multiline style
1 Do one of the following to choose Multiline Styles Manager ( ):  

• On the ribbon, choose Express Tools > Multiline Styles Manager (in Tools).

• On the menu, choose Format > Multiline Styles Manager or choose Express 
Tools > Tools > Multiline Styles Manager.

• On the Styles toolbar, click the Multiline Styles Manager tool.

• Type mlstyle and then press Enter.   

2 In the Multiline Styles Manager dialog box, select the multiline style to delete.

3 Click Delete.

4 To confirm the deletion, click OK.

5 Click OK.
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Importing and exporting multiline style files 
Multiline styles can be imported and exported as .mln files which makes it easy to 
move multiline styles between computers.

To export a multiline style file
1 Do one of the following to choose Multiline Styles Manager ( ):  

• On the ribbon, choose Express Tools > Multiline Styles Manager (in Tools).

• On the menu, choose Format > Multiline Styles Manager or choose Express 
Tools > Tools > Multiline Styles Manager.

• On the Styles toolbar, click the Multiline Styles Manager tool.

• Type mlstyle and then press Enter.   

2 In the Multiline Styles Manager dialog box, select the multiline style to export.

3 Click Export.

4 Specify the name and location for the .mln file, then click Save.

5 Click OK.

To import a multiline style file
1 Do one of the following to choose Multiline Styles Manager ( ):   

• On the ribbon, choose Express Tools > Multiline Styles Manager (in Tools).

• On the menu, choose Format > Multiline Styles Manager or choose Express 
Tools > Tools > Multiline Styles Manager.

• On the Styles toolbar, click the Multiline Styles Manager tool.

• Type mlstyle and then press Enter.  

2 In the Multiline Styles Manager dialog box, click Import.

The Import Multiline Style from File dialog box displays a list of the multiline 
styles that have already been loaded.

3 Click File.

4 Navigate to and select the .mln file to import, then click Open.

5 Click OK.
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Drawing traces

With the Trace command, you can draw a two-dimensional solid line of specified 
width. The Trace command is not commonly used — most users use the Polyline 
command instead.

To draw a trace
1 Type trace and then press Enter. Or on the ribbon, choose Draw > Trace.

2 Specify the width of the trace.

3 Specify the start point.

4 Specify additional vertices.

5 After specifying the last endpoint, choose Done or press Enter.

Trace startpoint (A), vertices (B), and endpoint (C).

B C

A

B B
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Drawing splines    

A spline is a smooth curve. You can use splines to create sculptured shapes such as 
the cross section of a turbine blade or an airplane wing.        
You can define the shape of the spline with either fit points or control vertices. 

Drawing a spline by specifying fit points
Splines can pass through or near fit points that you specify to define the spline shape.

By default, a spline passes through all of the fit points, but when you draw a spline, 
you can change this by specifying the fit tolerance. The fit tolerance value determines 
how closely the spline fits the set of points you specify. For example, a fit tolerance 
value of 0 causes the spline to pass through the fit points. A value of 0.01 creates a 
spline that passes through the start and endpoints and within 0.01 units of the interme-
diate fit points.

Fit-point splines are additionally affected by knot parametrization, can include tan-
gents, and can be open or closed.

The start point and endpoint (A) of a closed fit-point 
spline.

A
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To draw a spline that passes through or near fit points     
1 Do one of the following to choose Spline Fit ( ):

• On the ribbon, choose Draw > Spline Fit (in Draw) or Draw 3D > Spline Fit (in 
Curves).

• On the menu, choose Draw > Spline > Spline Fit.

• On the Draw toolbar, click the Spline Fit tool.

• Type spline, press Enter, choose Method, then choose Fit.

2 Specify the first fit point of the spline.

3 Optionally choose Knots, and choose Chord, Square root, or Uniform to determine 
how the curve segments between successive fit points within a spline are blended.

4 Optionally choose Fit Tolerance, enter a new fit tolerance, and then press Enter.

5 Specify the second fit point of the spline.

6 Continue specifying as many fit points as you want, then press Enter or choose 
Close to close the spline.

7 Specify the start tangent point to give the spline additional shape, or press Enter if 
you do not want to add a start tangent.

8 Specify the end tangent point to give the spline additional shape, or press Enter if 
you do not want to add an end tangent. 

If you are drawing a closed spline, you are prompted for only one tangent.

The display of control vertices can be turned on or off, even for fit-point splines.
Use the Show CV command to display control vertices; use the Hide CV command to 
hide them.

Drawing a spline by specifying control vertices
Splines drawn using control vertices display with a control frame when the spline is 
selected. You can then use the control frame to modify the shape of the spline. Con-
trol-vertex splines are affected by polynomial degrees and can be open or closed.

Initial spline and resulting spline with starting tangent point (A) and ending tangent point (B).                                                

A B
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To draw a spline defined by control vertices     
1 Do one of the following to choose Spline CV ( ):

• On the ribbon, choose Draw > Spline CV (in Draw) or Draw 3D > Spline CV 
(in Curves).

• On the menu, choose Draw > Spline > Spline CV.

• On the Draw toolbar, click the Spline CV tool.

• Type spline, press Enter, choose Method, then choose CV.

2 Specify the first control vertex of the spline.

3 Optionally choose Degree and enter the polynomial degree for the spline: 1 for lin-
ear, 2 for quadratic, 3 for cubic, etc. up to 10.

4 Specify the second control vertex of the spline.

5 Continue specifying as many control vertices as you want.

6 When you have finished, press Enter or choose Close to close the spline.

Converting a spline-fit polyline to a spline
Both 2D and 3D spline-fit polylines can be converted to splines. If necessary, you can 
use the Polyline Edit command (Spline option) to convert a polyline to a spline-fit 
polyline.

To convert a spline-fit polyline to a spline 
1 Do one of the following to choose Spline CV or Spline Fit ( ):

• On the ribbon, choose Draw > Spline CV (in Draw) or Draw 3D > Spline CV 
(in Curves).

• On the menu, choose Draw > Spline > Spline CV.

• On the Draw toolbar, click the Spline CV tool.

• Type spline and then press Enter.

2 Choose Entity.

3 Select the 2D or 3D polyline that fits the spline, then press Enter.

Other two-dimensional entities can be converted to splines using the Convert to NURBS 
command.
The Convert to NURBS command is typically used to convert solids and surfaces to 
NURBS surfaces, but can also be used to convert two-dimensional entities (for exam-
ple, lines, polylines, arcs, circles, etc.) to splines. For more details, see “Converting 
surfaces and solids to NURBS surfaces” on page 745. 
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Drawing helices

A helix is a three-dimensional spiral that is open at both ends. The base and top can 
be equal values, similar to a coil or spring, or they can be different values, similar to a 
cone. 

Helices are often used to create other entities.
In particular, the Sweep, Loft, and Revolve commands can all be used with helices in 
more complex drawings to create spiral stairs, spiral parts, and more.

To draw a helix
1 Do one of the following to choose Helix ( ):

• On the ribbon, choose Draw > Helix (in Draw) or Draw 3D > Helix (in Curves).

• On the menu, choose Draw > Helix.

• On the Draw toolbar, click the Helix tool.

• Type helix and then press Enter.

2 Specify the center point of the helix.

3 Specify the radius (or diameter) of the bottom of the helix.

4 Specify the radius (or diameter) of the top of the helix.

5 Optionally set any of the following:

• Turns Specify the number of full turns. The default number of turns is three. The 
maximum is 500.

• Turn height Specify the height of one full turn, which updates the number of 
turns automatically. This option is available only if you have not specified a 
number of turns.

• Twist Specify the direction of helix turns: clockwise (CW) or counterclockwise 
(CCW).

6 Specify the height and position of the helix by choosing one of the following:

• Choose Axis endpoint and specify the endpoint of the helix, which determines 
the position and direction of the helix.

• Specify the height of the helix. If the height is zero, the helix will be a two-
dimensional spiral, but if the start and end radius are the same it will look like a 
circle.
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Drawing donuts

Donuts are solid, filled circles or rings created as closed, wide polylines. You can 
draw a donut using one of several methods. The default method is to specify the 
inside and outside diameters of the donut, and then specify its center. You can then 
create multiple copies of the same donut by specifying different center points until 
you press Enter to complete the command. 

To draw a donut
1 Do one of the following to choose Donut ( ):

• On the ribbon, choose Draw > Donut.

• On the menu, choose Draw > Donut.

• On the Draw toolbar, click the Donut tool.

• Type donut and then press Enter.

2 Specify the inside diameter of the donut.

3 Specify the outside diameter of the donut.

4 Specify the center of the donut.

5 Specify the center point to draw another donut, or choose Done to complete the 
command.

Helix center point (A), bottom radius (B), top radius (C), and height (D).

A

B,C

D
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The prompt box provides additional options for drawing donuts. For example, you 
can specify the width of the donut and two points on the diameter of the donut, or you 
can specify the width and three points on the donut. You can also draw a donut tan-
gent to existing entities.   

A donut can be a completely filled circle. 
Donuts are completely filled if the inside diameter is zero.

To draw a donut tangent to existing entities
1 Do one of the following to choose Donut ( ): 

• On the ribbon, choose Draw > Donut.

• On the menu, choose Draw > Donut.

• On the Draw toolbar, click the Donut tool.

• Type donut and then press Enter.

2 In the prompt box, choose Radius Tangent Tangent.

3 Specify the width of the donut.

4 Specify the diameter of the donut.

5 Select the first tangent entity to which to draw the donut.

6 Select the second tangent entity to which to draw the donut.

Inside diameter (A) and outside diameter (B).

A

B

Width (A) and diameter (B) of the donut and tangent entities (C).

A

B

C

C
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You can edit donuts using the Edit Polyline tool ( ) on the Modify toolbar. You 
can convert donuts into arc entities using the Explode tool ( ) on the Modify 
toolbar. You can control whether donuts are shown filled or as outlines using the Fill 
tool ( ) on the Settings toolbar.

You can control the default outside and inside diameter of donuts. 
Choose Tools > Drawing Settings, click the Entity Creation tab, and choose the 
options you want.

Creating planes    

With the Plane tool, you can draw rectangular, triangular, or quadrilateral areas filled 
with a solid color. The default method is to specify the corners of the plane. After you 
specify the first two corners, the plane is displayed as you specify the remaining cor-
ners. Specify corner points in a triangular manner. The program prompts you for the 
third point and then the fourth point. If you continue specifying points, the third- and 
fourth-point prompts toggle until you press Enter to complete the command.   

Creating planes in IntelliCAD is similar to the Solid command in AutoCAD.

To draw a quadrilateral plane
1 Do one of the following to choose Plane ( ):

• On the ribbon, choose Draw > Plane.

• On the menu, choose Draw > Plane.

• On the Draw toolbar, click the Plane tool.

• Type plane and then press Enter.

2 Specify the first point.

3 Specify the second point.

4 Specify the third point.

5 Specify the fourth point.

6 To complete the command, press Enter.

After you select the first two points (A) and (B), the sequence in which you select the third (C) 
and fourth (D) points determines the shape of the resulting quadrilateral plane.

B

A

D

C

B

A D

C



162 C H A P T E R  5
The prompt box provides additional options for drawing planes. For example, you 
can draw rectangular, square, or triangular planes.

To draw a rectangular plane
1 Do one of the following to choose Plane ( ):

• On the ribbon, choose Draw > Plane.

• On the menu, choose Draw > Plane.

• On the Draw toolbar, click the Plane tool.

• Type plane and then press Enter.

2 Choose Rectangle.

3 Specify the first point.

4 Specify the opposite corner.

5 Specify the rotation angle.

6 To complete the command, specify the opposite corner to draw another rectangle, 
or press Enter.

You can control whether planes are shown filled or as outlines using the Fill tool 
( ) on the Settings toolbar. You can convert planes into individual line entities cor-
responding to the outline of the plane using the Explode tool ( ) on the Modify 
toolbar.                             

Opposite corners (A and B) and rotation angle (C) and resulting plane.

A BC
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Drawing architectural entities   

Architectural entities, commonly called AEC entities, are custom entities that you can 
use to quickly draw walls, doors, windows, slabs, roofs, and more.

Drawing a wall
Walls can be drawn as interior, exterior, fireproof, foundational, and more. 

After you draw a wall, you can modify it as you would other entities using modify 
entity commands. You can also use the Properties pane to change the width, style, 
automatic cleanup, etc. And when you select a wall, grips display allowing you to 
resize and reorient the wall in real-time. 

To draw a wall
1 Do one of the following to choose Walls ( ):

• On the ribbon, choose AEC > Walls and then the wall style (in Draw).

• On the menu, choose AEC > Walls and then the wall style.

• On the Walls toolbar, click a wall style.

• Type wall and then press Enter.

2 Specify the start point of the wall.

3 Specify the endpoint of each segment.

4 After specifying the last endpoint, press Enter.

Drawing a door
Doors can be drawn in a wide variety of styles: single swing, double swing, sliding, 
revolving, and many more.

After you draw a door, you can modify it as you would other entities using modify 
entity commands. For example, doors can be easily moved and resized within a wall. 
You can also use the Properties pane to change the width, style, etc. And when you 
select a door, grips display allowing you to resize and reorient the door in real-time. 
There is also a special arrow grip for doors that allows you to change the swing with a 
single click.
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To draw a door
1 Do one of the following to choose Doors ( ):

• On the ribbon, choose AEC > Doors and then the door style (in Draw).

• On the menu, choose AEC > Doors and then the door style.

• On the Doors toolbar, click a door style.

• Type door and then press Enter.

2 Select the wall where you want to locate the door, or press Enter if not choosing an 
existing wall.

3 Specify the point where you want to locate the door.

4 After specifying the last location, press Enter.

Drawing a window
Windows can be drawn as single hung, double hung, picture, pivot, and many more. 

After you draw a window, you can modify it as you would other entities using modify 
entity commands. For example, windows can be easily moved and resized within a 
wall. You can also use the Properties pane to change the width, style, etc. And when 
you select a window, grips display allowing you to resize and reorient the window in 
real-time. There is also a special arrow grip for windows that allows you to change 
the opening orientation with a single click.

To draw a window
1 Do one of the following to choose Windows ( ):

• On the ribbon, choose AEC > Windows and then the window style (in Draw).

• On the menu, choose AEC > Windows and then the window style.

• On the Windows toolbar, click a window style.

• Type window and then press Enter.

2 Select the wall where you want to locate the window, or press Enter if not choos-
ing an existing wall.

3 Specify the point where you want to locate the window.

4 After specifying the last location, press Enter.
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Drawing stairs
Stairs can be drawn in different types and styles such as spiral, straight, cantilever, a 
ramp, and more. 

After you draw stairs, you can modify them as you would other entities using modify 
entity commands. For example, stairs can be easily moved and resized relative to a 
wall or slab. You can also use the Properties pane to change the stair width, tread 
dimensions, landing dimensions, turn on/off stringers, etc. When stairs are modified, 
any attached railings are updated to match the stair modifications (length, angle, 
width, etc.). And when you select stairs, grips display allowing you to resize and 
reorient them in real-time.

To draw stairs
1 Do one of the following to choose Stairs ( ):

• On the ribbon, choose AEC > Stairs and then the stair style (in Draw).

• On the menu, choose AEC > Stairs and then the stair style.

• On the Stairs toolbar, click a stair style.

• Type stair and then press Enter.

2 If necessary, choose an option to change the default value for the stairs you want 
to draw.

3 When done entering values, specify the point where you want to start the stairs.

4 Enter the stair segment length, then press Enter.

5 Specify the endpoint of the stairs.

Drawing a railing
Railings can be drawn in different styles such as standard, bollard, vertical or hori-
zontal cable, and many more.

After you draw a railing, you can modify it as you would other entities using modify 
entity commands. For example, standalone railings can be easily moved and resized. 
You can also use the Properties pane to change the style, rail height, post placement, 
etc. And when you select a railing, grips display allowing you to resize and reorient 
the railing in real-time.

To draw a railing attached to stairs
1 Do one of the following to choose Railings ( ):

• On the ribbon, choose AEC > Railings and then the railing style (in Draw).

• On the menu, choose AEC > Railings and then the railing style.

• On the Railings toolbar, click a railing style.

• Type railing and then press Enter.

2 Choose Attach.
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3 Specify the stairs where you want to attach a railing.

4 Choose the location of the railing on the stairs: left, right, or center.

To draw a railing that is not attached to stairs
1 Do one of the following to choose Railings ( ):

• On the ribbon, choose AEC > Railings and then the railing style (in Draw).

• On the menu, choose AEC > Railings and then the railing style.

• On the Railings toolbar, click a railing style.

• Type railing and then press Enter.

2 Specify the start point where you want to locate the railing.

3 Specify additional points to create railing segments.

4 After specifying the last point, press Enter.

Drawing a curtain wall
Curtain walls can be drawn in different styles and can also be converted from existing 
two-dimensional entities such as lines, arcs, circles, and polylines.

After you draw a curtain wall, you can modify it as you would other entities using 
modify entity commands. You can also use the Properties pane to change settings for 
divisions, infill, mullion and frame. And when you select a curtain wall, grips display 
allowing you to resize and reorient the curtain wall in real-time.

To draw a curtain wall
1 Do one of the following to choose Curtain Wall ( ):

• On the ribbon, choose AEC > Walls > Curtain Wall (in Draw) or AEC > 
Windows > Curtain Wall (in Draw).

• On the menu, choose AEC > Walls > Curtain Wall or AEC > Windows > 
Curtain Wall.

• On the Walls toolbar, click a wall style.

• Type curtainwall and then press Enter.

2 If desired, choose Height to enter the height of the curtain wall.

3 If desired, choose Style and enter the name of the curtain wall style. To view the 
list of all styles, choose ?. 

4 Specify the start point of the curtain wall.

5 Specify the endpoint of each segment.
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6 If you want to add an arc segment, do the following:

• Choose Arc.

• Specify the midpoint of the arc segment.

• Specify the endpoint of the arc segment. 

• Choose Line to continue adding line segments or choose Close to add the last 
endpoint at the start point.

7 After specifying the last endpoint, press Enter.

To convert two-dimensional entities to a curtain wall
1 Do one of the following to choose Curtain Wall ( ):

• On the ribbon, choose AEC > Walls > Curtain Wall (in Draw) or AEC > 
Windows > Curtain Wall (in Draw).

• On the menu, choose AEC > Walls > Curtain Wall or AEC > Windows > 
Curtain Wall.

• On the Walls toolbar, click a wall style.

• Type curtainwall and then press Enter.

2 Choose Convert.

3 Select lines, arcs, circles, or polylines to convert to curtain walls, then press Enter.

4 Choose Yes to delete the original two-dimensional entities, or choose No to retain 
the original two-dimensional entities.

Drawing steel
Steel entities can be drawn in many different shapes. 

To draw steel
1 Do one of the following to choose Steel ( ):

• On the ribbon, choose AEC > Steel and then the steel style (in Draw).

• On the menu, choose AEC > Steel and then the steel shape.

• On the Steel toolbar, click a steel shape.

• Type steel and then press Enter.

2 Select the steel dimensions from the list.

3 Click OK.

4 To mirror the shape about its x-axis, choose XFlip. To mirror the shape about its 
y-axis, choose YFlip.

5 Specify the insertion point.

6 Specify the angle of rotation.

7 Specify the length. If the length is 0, a two-dimensional steel shape is created.
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Drawing a stud, joist, or track
Studs, joists, and track can be drawn in many different shapes and styles. 

To draw studs, joists, or track
1 Do one of the following to choose Studs, Joists, Track:

• On the ribbon, choose AEC > Steel and then Stud, S-Stud, Joist, or Track (in 
Draw).

• On the menu, choose AEC > Steel and then Stud, S-Stud, Joist, or Track.

• On the Steel toolbar, click Stud, S-Stud, Joist, or Track.

• Type sjt and then press Enter.

2 Select the desired dimensions of the shape from the list.

3 Click OK.

4 To mirror the shape about its x-axis, choose XFlip. To mirror the shape about its 
y-axis, choose YFlip.

5 Specify the insertion point.

6 Specify the angle of rotation.

7 Specify the length. If the length is 0, a two-dimensional shape is created.
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Drawing a beam
Beams are architectural elements placed between columns, walls and other beams.

After you draw a beam, you can modify it as you would other entities using modify 
entity commands. For example, beams can be easily moved and resized relative to a 
wall. You can also use the Properties pane to change the thickness, style, etc. And 
when you select a beam, grips display allowing you to resize and reorient the beam in 
real-time.

To draw a beam
1 Type beam and then press Enter.

2 Specify the start point.

3 Specify the end point.

4 After specifying the last endpoint, press Enter.

You can also set custom options for beams.
At the prompt, choose Style to specify a beam style, Start Offset or End Offset to enter 
the distance that you want the beam segment to offset from the start or end point, Jus-
tify to specify the beam position relative to the baseline, or Roll to rotate the beam 
segment around the baseline.

To create a beam using an existing entity as the beam path
1 Type beam and then press Enter.

2 Choose Convert.

3 Select the lines, arcs, or polylines to convert to beam paths, then press Enter.

4 If you selected a polyline to convert, choose Yes to create a separate beam for 
each polyline segment, or choose No to convert the selected polyline to a single 
beam.

5 Choose Yes to delete the selected entities or No to retain the selected entities.
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Drawing wood
Wood details can be drawn as lumber and TJI joists shapes in many different standard 
sizes.

To draw wood
1 Do one of the following to choose Wood ( ):

• On the ribbon, choose AEC > Wood and then Lumber or TJI Joists (in Draw).

• On the menu, choose AEC > Wood and then Lumber or TJI Joists.

• Type wood and then press Enter.

2 Select the desired dimensions from the list.

3 Click OK.

4 To mirror the shape about its x-axis, choose XFlip. To mirror the shape about its 
y-axis, choose YFlip.

5 Specify the insertion point.

6 Specify the angle of rotation.

7 Specify the length. If the length is 0, a two-dimensional shape is created.

Drawing a slab
Slabs are foundations that are easy to draw at the beginning of an architectural project 
or at any time later relative to walls. 

After you draw a slab, you can modify it as you would other entities using modify 
entity commands. For example, slabs can be easily moved and resized relative to a 
wall. You can also use the Properties pane to change the thickness, style, etc. And 
when you select a slab, grips display allowing you to resize and reorient the slab in 
real-time.

To draw a slab
1 Do one of the following to choose Slab ( ):

• On the ribbon, choose AEC > Slab (in Draw).

• On the menu, choose AEC > Slab.

• Type slab and then press Enter.

2 Specify the start point of the slab.

3 Specify the endpoint of each segment.

4 After specifying the last endpoint, press Enter.
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Drawing a roof
Architectural roofs can have a slope, gables, hips, overhangs, etc. As you draw the 
roof, IntelliCAD automatically calculates the dimensions, slopes, etc. according to 
the segment points you select.

After you draw a roof, you can modify it as you would other entities using modify 
entity commands. For example, roofs can be easily moved, resized, scaled, etc. You 
can also use the Properties pane to change the thickness, slope, overhang, etc. And 
when you select a roof, grips display allowing you to change its shape from gable to 
hip and resize and reorient the roof in real-time.

To draw a roof
1 Do one of the following to choose Roof ( ):

• On the ribbon, choose AEC > Roof (in Draw).

• On the menu, choose AEC > Roof.

• Type roof and then press Enter.

2 Specify the start point of the roof.

3 Specify the endpoint of each segment.

4 After specifying the last endpoint, press Enter.

Drawing a roof slab
A roof slab is a flat roof that is similar to a slab except it is drawn above walls instead 
of below.

After you draw a roof slab, you can modify it as you would other entities using mod-
ify entity commands. For example, roof slabs can be easily moved and resized rela-
tive to a wall. You can also use the Properties pane to change the thickness, style, etc. 
And when you select a roof slab, grips display allowing you to resize and reorient the 
roof slab in real-time.

To draw a roof slab
1 Do one of the following to choose Roof Slab ( ):

• On the ribbon, choose AEC > Roof Slab (in Draw).

• On the menu, choose AEC > Roof Slab.

• Type roofslab and then press Enter.

2 Specify the start point of the roof slab.

3 Specify the endpoint of each segment.

4 After specifying the last endpoint, press Enter.
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Converting 2D entities to walls and slabs
You can convert several 2D entity types to walls or slabs: lines, circles, arcs, and 
polylines.

To convert entities to a wall
1 Do one of the following to choose Convert to Wall ( ):

• On the ribbon, choose AEC > Convert to Wall (in Convert).

• On the menu, choose AEC > Convert to Wall.

• Type wall, press Enter, then choose Convert.

2 Select the 2D entities to convert.

3 Choose whether to delete the 2D entities when they are converted to walls.

To convert entities to a slab
1 Do one of the following to choose Convert to Slab ( ):

• On the ribbon, choose AEC > Convert to Slab (in Convert).

• On the menu, choose AEC > Convert to Slab.

• Type slab, press Enter, then choose Convert.

2 Select the 2D entities to convert.

3 Choose whether to delete the 2D entities when they are converted to slabs.
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Drawing a section line
A section line can be drawn in any three-dimensional drawing to determine a two-
dimensional projection of the area you want to view. The section line is a polyline 
that can consist of continuous segments that define the area you want to view.

After you draw a section line in your drawing, you can modify its segments and 
length, then update the two-dimensional projection view.

To draw a selection line
1 Do one of the following to choose Section Line ( ):

• On the ribbon, choose AEC > Section Line (in Sections).

• On the menu, choose AEC > Section Line.

• Type sectionline and then press Enter.

2 Specify the start point of the section line.

3 Specify the end point of each segment.

4 Specify the end point of the section line, then press Enter.

5 To turn on the visibility of hidden lines, choose No. To keep hidden lines invisi-
ble, choose Yes.

6 Specify the insertion point of the 2D projection.

To add a new 2D projection from an existing section line
1 Type sectionlinegenerate and then press Enter.

2 Select the section line, then press Enter.

3 Specify an insertion point for the new 2D projection view.

Use a shortcut.
Right-click the section line you want to generate a new projection for, then choose 
Generate 2D Section.

To modify the position of an existing section line
1 Select the section line.

2 Move its start point, segments, end point, or length.

If Use Model Extents for Height is set to Yes in the Properties pane, the section 
line height and lower extension are matched automatically. If set to No, you can 
change the height and lower extension separately.

3 If automatic updating is turned off, right-click the 2D projection, then choose 
Refresh.
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To modify the properties of a section line symbol
1 Select the symbol of a section line.

2 In the Properties pane, select new properties, including the label text. Note that the 
symbol is annotative and can be scaled.

Use the AECAUTOUPDATE system variable to control automatic updating.
If AECAUTOUPDATE is set to 1, two-dimensional projection views update automat-
ically after a section line or elevation line changes. If set to 0, you need to manually 
refresh projection views after changes.

Drawing an elevation line
An elevation line can be drawn in any three-dimensional drawing to create a two-
dimensional projection view of the drawing.

You can modify existing elevation lines and therefore their related projection views. 
You can also modify the elevation symbol that marks the elevation line.

To draw an elevation line
1 Do one of the following to choose Elevation Line ( ):

• On the ribbon, choose AEC > Elevation Line (in Sections).

• On the menu, choose AEC > Elevation Line.

• Type elevationline and then press Enter.

2 Specify the start point of the elevation line.

3 Specify the end point of the elevation line.

If you want to include all entities in the 2D projection view, make sure the start 
and end points are beyond the start and end of the model.

4 To turn on the visibility of hidden lines, choose No. To keep hidden lines invisi-
ble, choose Yes.

5 Specify the insertion point of the 2D projection view.

To add a new 2D projection from an existing elevation line
1 Type elevationlinegenerate and then press Enter.

2 Select the elevation line, then press Enter.

3 Specify an insertion point for the new 2D projection view.

Use a shortcut.
Right-click the elevation line you want to generate a new projection for, then choose 
Generate 2D Elevation.
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To reverse the direction of an existing elevation line
1 Type elevationlinereverse and then press Enter.

2 Select the elevation line, then press Enter.

3 If automatic updating is turned off, right-click the 2D projection view, then choose 
Refresh.

Use a shortcut.
Right-click the elevation line you want to reverse, then choose Reverse.

To modify the position of an existing elevation line
1 Select the elevation line.

2 Move its start point, end point, or length.

If Use Model Extents for Height is set to Yes in the Properties pane, the elevation 
line height and lower extension are matched automatically. If set to No, you can 
change the height and lower extension separately.

3 If automatic updating is turned off, right-click the 2D projection view, then choose 
Refresh.

To modify the properties of an elevation line symbol
1 Select the symbol of an elevation line.

2 In the Properties pane, select new properties, including the label text. Note that the 
symbol is annotative and can be scaled.

Use the AECAUTOUPDATE system variable to control automatic updating.
If AECAUTOUPDATE is set to 1, two-dimensional projection views update automat-
ically after a section line or elevation line changes. If set to 0, you need to manually 
refresh projection views after changes.
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Drawing tables

Tables contain data in columns and rows. When you draw a table, you assign it a 
table style which affects its layout, formatting, and color, and specify whether the 
table content is empty initially or filled automatically with data from a spreadsheet. 
After you draw a table—empty or filled with linked data, you can add text and mod-
ify various cell and table settings.

Drawing an empty table
When you draw a table, you assign a table style, determine the number of columns 
and rows, and other options. Tables are inserted in the drawing by either specifying 
the upper-left corner of the table or by specifying a window that specifies its total 
width and height.

To draw an empty table
1 Do one of the following to choose Table ( ):

• On the ribbon, choose Home > Table (in Annotation) or Annotate > Table (in 
Tables).

• On the menu, choose Draw > Table.

• Type table and then press Enter.

2 In Table Style, choose a table style for the table. If necessary, click ( ) to create 
or modify table styles.

3 In Insert Options, select Start from Empty Table. 

4 Determine how you want to insert the table in the drawing by choosing one of the 
following:

• Specify insertion point Specify the location of the upper-left corner of the table 
when you insert it. You can specify the insertion point directly in the drawing or 
enter coordinate values in the command bar. If the table reads from bottom to 
top (as specified for the table direction in the table style), the insertion point 
specifies the location of the lower-left corner of the table.

• Specify window Specify a location and size for the table when you insert it. 
Specify two points of the window directly in the drawing or  specify their 
coordinates in the command bar.

5 Specify column settings:

• Columns Enter the number of columns. If Specify Window is also selected, the 
column width is determined automatically by the width of the table.

• Column Width Enter the width of the columns. If Specify Window is also 
selected, the number of columns is determined automatically by the width of the 
table.
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6 Specify data row settings:

• Data Rows Enter the number of data rows. If Specify Window is also selected, 
the row height is determined automatically by the height of the table.

• Row Height Enter the height of data rows. If Specify Window is also selected, 
the number of data rows is determined automatically by the height of the table.

7 Specify cell settings:

• First row cell style Choose the cell style for the first row of the table.

• Second row cell style Choose the cell style for the second row of the table.

• All other rows' cell style Choose the cell style for all other rows.

8 When finished, click OK.

9 In the drawing, follow the prompts to insert the table.

A Select a table style for the table.
B Click to create or modify table styles.
C Select to create an empty table.
D Click to turn the preview display on or off.
E Choose the cell style for all rows other than the 

first and second rows.
F Choose the cell style for the second row of the 

table.
G Choose the cell style for the first row of the table.
H Specify the number of data rows. If Specify 

Window is also selected, the row height is 
determined automatically.

I Specify the height of rows. If Specify Window is 
also selected, the number of data rows is 
determined automatically.

J Specify the number of columns. If Specify 
Window is also selected, the column width is 
determined automatically.

K Specify the width of columns. If Specify Window 
is also selected, the number of columns is 
determined automatically.

L Choose whether to insert the table by specifying 
its upper-left corner as the insertion point or by 
specifying a window for its overall size.

A

E

l
B

F
G

I

K

H

J

D

C
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Drawing a table using content from a spreadsheet
Tables can contain content from a linked .xls or .xlsx file, allowing you to easily 
share and update data between CAD drawings and external spreadsheets.

When you insert the table, specify the data link that references the content you want 
to include. The number and size of rows and columns of the new table are determined 
automatically based on the content in the spreadsheet.

For details about data links, see “Working with data links” on page 590. 

To draw a table that contains content from a spreadsheet
1 Do one of the following to choose Table ( ):

• On the ribbon, choose Home > Table (in Annotation) or Annotate > Table (in 
Tables).

• On the menu, choose Draw > Table.

• Type table and then press Enter.

2 In Table Style, choose a table style for the table. If necessary, click ( ) to create 
or modify table styles.

3 In Insert Options, select From Data Link.

4 In the data link list, choose the data link that contains the content you want to 
include in the table. If necessary, select Open Data Link Manager ( ) to create a 
data link or modify an existing one.

Data links are references to external files.
If you share your drawing with other uses, make sure you include any referenced 
.xls/.xlsx files.

5 Click OK.

6 In the drawing, follow the prompts to insert the table.
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A Select a table style for the table.
B Click to create or modify table styles.
C Click to create or modify data links.
D Select to use content from an external file for the 

new table.

E Select the data link that contains the content you 
want to include.

F Click to turn the preview display on or off.
G Disabled because this information is supplied by 

the linked spreadsheet.

A

E

B

F

D

C
B

G
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Drawing a table using content from report data
Tables can be created with content from linked report data. When you insert the table, 
you specify the options for extracting data from entities located in one or more draw-
ings. The number and size of rows and columns of the new table are determined auto-
matically based on the report data.

Later, the table contents can be updated automatically to include the latest report data.

For more details about extracting data and creating reports, see “Reporting informa-
tion about entities” on page 383. 

To draw a table that contains content from report data
1 Do one of the following to choose Table ( ):

• On the ribbon, choose Home > Table (in Annotation) or Annotate > Table (in 
Tables).

• On the menu, choose Draw > Table.

• Type table and then press Enter.

2 In Table Style, choose a table style for the table. If necessary, click ( ) to create 
or modify table styles.

3 In Insert Options, select From Data Extraction.

4 Click OK.

5 Make your selections for extracting data to include in the table. Click [?] for 
details about each option. 
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A Select a table style for the table.
B Click to create or modify table styles.

C Select to create table content with data extracted 
from one or more drawings.

D Disabled because this information is supplied by 
the linked spreadsheet.

A
B

C

B

D
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Editing table text
You can edit table text just as you would edit multiline text in the drawing.

To edit table text
1 Double-click a table cell directly in the drawing, or do one of the following to 

choose Edit Table ( ):

• On the ribbon, choose Annotate > Edit Table (in Tables).

• On the menu, choose Modify > Edit Table.

• Type tabledit and then press Enter.

• Double-click inside a table cell.

2 If you chose the Edit Table command, click inside a table cell.

3 Enter or modify text. 

4 To change the properties of text, use the Text Editor tab (if your program version 
supports it) or toolbar that displays automatically. For more details about multiline 
text properties, see “Creating paragraph text” on page 470. 

5 When you are done making changes to the text, press Enter.
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Modifying a table
Use the Properties pane to change a table’s style, direction, table breaks, and more. 
Tables can also be modified by inserting and deleting rows and columns, merging 
cells, locking cells, and specifying the data format.

To modify a table
1 Select a table.

2 Use the Properties pane to change settings for the table.

3 To modify table cells, do the following:

• Select the table cells you want to change. To select multiple cells, press Shift 
while clicking the first and last cell in the range. To select an entire row or 
column, click the row or column name.

• Right-click the table cells or use the Table Cell tools to make your selections for 
highlighted cells.

Tool Name Description
Insert Above Click to insert a row above the current row.

Insert Below Click to insert a row below the current row.

Delete Row(s) Click to delete the current row.

Insert Left Click to insert a column to the left of the 
current column.

Insert Right Click to insert a column to the right of the 
current column.

 Delete Column(s) Click to delete the current column.

Merge Cells Click to combine selected cells together. 
Choose Merge All, Merge by Row, or Merge 
by Column. (Available only if more than one 
cell is selected.)

Unmerge Cells Click to separate selected cells. (Available 
only if selected cells are merged.)

Match Cell Click to copy the properties of a source table 
cell and apply them to selected cells.

Remove Overrides Click to undo all the changes made to the 
selected table cell or range of cells.

Justification Select the justification for selected cells.

Edit Borders Click to modify border properties of the 
selected cell or range of cells. For more 
details, click Help in the dialog box that 
displays.
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Cell Style Select a style to apply to selected cells.

Fill Color Select a color to fill selected cells.

Cell Locking Click to select lock options for selected cells: 
Unlocked, Content Locked, Format Locked, 
Content and Format Locked. 

Data Format Click to select the format for the data in 
selected cells: Angle, Currency, Date, 
Decimal Number, General, Percentage, 
Point, Text, Whole Number. (Not available if 
the format is locked.)

Block Click to insert a block into the selected cell 
or range of cells. For more details, click Help 
in the dialog box that displays.

Field Click to insert a field in a selected cell. For 
more details, click Help in the dialog box that 
displays.

Formula Click to insert a Sum, Average, Count, Cell, 
or Equation formula, and then follow the 
prompts.

Manage Cell 
Contents

Click to specify how text and blocks are 
positioned relative to each other within a 
selected cell. For more details, click Help in 
the dialog box that displays. Available only 
when the selected table cell contains 
multiple text entities and/or blocks.

Tool Name Description
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Working with table styles
When you draw a table in a drawing, the table uses the current table style by default. 
A table style determines the table direction, various cell styles, formatting, and other 
characteristics.

Every table has a default table style, named Standard. You cannot delete the Standard 
style, but you can rename it or modify it. You also can create and use an unlimited 
number of additional table styles.

Table styles can also be managed using the Explorer. For more details, see “Working 
with table styles” on page 324. 

To create a table style
1 Do one of the following to choose Table Styles Manager ( ):

• On the ribbon, choose Annotate > Table Styles Manager (in Tables).

• On the menu, choose Format > Table Styles Manager.

• Type tablestyle and then press Enter.

2 Click New.

3 In New Style Name, type the name of the new table style.

4 In Start With, select an existing table style on which to base the new table style. 

5 Click Continue.

6 To use an existing table as a base for the new table style, click ( ) and select a 
table in the drawing.

7 In Table Direction, choose Down to create a table that reads from top to bottom, or 
choose Up to create a table that reads from bottom to top.

8 In Cell Styles, do the following:

• Select Data from the list, then select options for data cells.

• Select Header from the list, then select options for header cells.

• Select Title from the list, then select options for title cells.

Click [?] in the dialog box for more details about each option.

9 If you need to create a new cell style, click ( ), enter a name for the cell style, 
then click Continue. When you return to the New Table Style dialog box, make 
your selections.

Cell styles can be renamed and deleted.
In the list of cell styles, select the one you want to rename, click ( ), enter a new 
name, then press Enter. To delete a cell style, select it from the list, then click 
( ). Data, Header, and Title cell styles cannot be renamed or deleted.

10 When finished, click OK.
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To modify a table style
1 Do one of the following to choose Table Styles Manager ( ):

• On the ribbon, choose Annotate > Table Styles Manager (in Tables).

• On the menu, choose Format > Table Styles Manager.

• Type tablestyle and then press Enter.

2 Select the table style you want to modify, then click Modify.

3 In the Modify Table Style dialog box, make your selections for the table style as 
described previously for creating a new table style.

4 When finished, click OK.

A Click to select a table in the drawing to use as a base 
for the table style.

B Click to remove a start table from the table style.
C Choose Down to create a table that reads from top to 

bottom. Choose Up to create a table that reads from 
bottom to top.

D Displays a preview of a table with the style.
E Displays a preview of the table cell with current 

settings.
F Mark to combine new rows or columns created with 

the current cell style into one cell.
G Specify the spacing between the top and bottom cell 

borders and the contents of the cell.

H Specify the spacing between the left and right cell 
borders and the contents of the cell.

I Choose whether the cell style is for data or a label.
J Click [...] to set the data format of the cell style.
K Choose how you want the text to be justified in the 

cell.
L Select the background color of the cell.
M Click which options you want to change: general, 

text, or border options.
N Click to rename the selected cell style.
O Click to delete the selected cell style.
P Click to create a new cell style.
Q Select the cell style you want to modify.

A

D

E

Q

B

F

G

I

L

H

K

C

P

N
O

M

J
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To assign a table style to an existing table
1 Select a table in the drawing.

2 On the Properties pane in Table Style, change the table style.

Drawing wipeouts

Wipeouts are unique entities that can help you hide areas of your drawing. They dis-
play with the current background color, so the details behind the wipeout do not dis-
play or print.

Wipeouts are similar to other entities — you can copy, mirror, array, erase, rotate, 
and scale them, and they can be used in both model space and paper space.

If you want to print the wipeout entities located in a drawing, you must print to a ras-
ter-capable printer. Note that in some cases you may have unexpected results when 
printing drawings that contain wipeout entities, for example, if printing on colored 
paper.

Wipeouts are created using existing polygons, closed zero-width polylines made up 
of only line segments, or new polylines that you draw while using the Wipeout com-
mand.

The display of wipeouts varies depending on your version of IntelliCAD.
If your IntelliCAD version does not include raster image capability, wipeout entities 
display, but the details behind the wipeouts also display.

Drawing a wipeout
To draw a wipeout
1 Do one of the following to choose Wipeout ( ):

• On the ribbon, choose Home > Wipeout (in Annotation) or Annotate > Wipeout 
(in Markup).

• On the menu, choose Draw > Wipeout.

• On the Draw toolbar, click the Wipeout tool.

• Type wipeout and then press Enter.

2 Specify the start point.

3 Specify the endpoint of each segment.

4 After specifying the last endpoint, choose Done or press Enter.
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Creating a wipeout using existing polygons and polylines

To create a wipeout using an existing polygon or polyline
1 Do one of the following to choose Wipeout ( ):

• On the ribbon, choose Home > Wipeout (in Annotation) or Annotate > Wipeout 
(in Markup).

• On the menu, choose Draw > Wipeout.

• On the Draw toolbar, click the Wipeout tool.

• Type wipeout and then press Enter.

2 Choose Polyline.

3 Select the closed polyline to use for the wipeout.

4 Choose one of the following:

• Yes — Creates the wipeout and deletes the polyline used to create the wipeout. 

• No — Creates the wipeout and keeps the polyline used to create the wipeout. 

Turning wipeout frames on or off
Each wipeout has a frame along its boundary. Wipeout frames can be turned on or off 
for any drawing. When wipeout frames are on, you can select and modify wipeouts. 
You may want to turn off wipeout frames when it’s time to print.

To turn wipeout frames on or off
1 Do one of the following to choose Wipeout ( ):

• On the ribbon, choose Home > Wipeout (in Annotation) or Annotate > Wipeout 
(in Markup).

• On the menu, choose Draw > Wipeout.

• On the Draw toolbar, click the Wipeout tool.

• Type wipeout and then press Enter.

2 Choose Frames.

3 Choose On or Off.

Existing drawing. Drawing with wipeout.
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You can also turn wipeout and image frames on or off using a single command.
Type tframes to turn all wipeout and image frames in the drawing on or off. Or use 
the IMAGEFRAME and WIPEOUTFRAME system variables. 

Wipeout frames turned on. Wipeout frames turned off.
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Drawing revision clouds

Revision clouds are cloud shapes that mark areas of a drawing that require further 
attention. They are especially helpful when revising a drawing; add a revision cloud 
to each modified area so reviewers can find changes easily. 

Revision clouds are polylines, so you can work with and modify them in the same 
way you would a polyline: move, copy, mirror, and scale the entire revision cloud or 
select and move individual vertices to adjust the arcs that make up the revision cloud. 

Drawing a revision cloud
Drawing a revision cloud is easy: simply select a start point and move the mouse.

To draw a revision cloud
1 Do one of the following to choose Revision Cloud ( ):

• On the ribbon, choose Home > Revision Cloud (in Annotation) or Annotate > 
Revision Cloud (in Markup).

• On the menu, choose Draw > Revision Cloud.

• On the Draw toolbar, click the Revision Cloud tool.

• Type revcloud and then press Enter.

2 Specify the start point.

3 Move the mouse, encircling the desired area.

When you return to the starting point, the revision cloud command finishes auto-
matically.

Edit revision clouds just as you would a polyline. 
Select the revision cloud and move its vertices or use the Edit Polyline tool ( ) on 
the Modify toolbar. 

Select start point (A), then move the mouse 
around the desired area and back towards the 
start point (A).

Resulting revision cloud.

A
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Creating a revision cloud using existing entities
In addition to drawing new revision clouds, you can also convert existing entities — 
lines, arcs, circles, 2D polylines, and splines — into revision clouds.

To create a revision cloud using an existing entity
1 Do one of the following to choose Revision Cloud ( ):

• On the ribbon, choose Home > Revision Cloud (in Annotation) or Annotate > 
Revision Cloud (in Markup).

• On the menu, choose Draw > Revision Cloud.

• On the Draw toolbar, click the Revision Cloud tool.

• Type revcloud and then press Enter.

2 Choose Entity.

3 Select the existing line, arc, circle, 2D polyline, or spline to be converted.

4 Choose whether to reverse the direction of the individual arcs of the revision 
cloud. Choose No to keep the arcs pointing inward. Choose Yes to flip the arcs to 
point outward.

A revision cloud is created, and the selected entity remains or is deleted depending 
on the DELOBJ system variable setting. 

Customizing default revision cloud settings
All revision clouds are drawn using default settings that can be customized:

• Minimum arc length — The individual arcs that make up a revision cloud can be 
made smaller or larger by setting the minimum arc length.

• Maximum arc length — The individual arcs that make up a revision cloud can be 
made smaller or larger by setting the maximum arc length. 

• Style — Revision clouds can appear as if they had been drawn with a regular pen 
or a calligraphy pen.

Only new revision clouds will be drawn with the new settings. Existing revision 
clouds are not affected.
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To customize revision cloud settings
1 Do one of the following to choose Revision Cloud ( ):

• On the ribbon, choose Home > Revision Cloud (in Annotation) or Annotate > 
Revision Cloud (in Markup).

• On the menu, choose Draw > Revision Cloud.

• On the Draw toolbar, click the Revision Cloud tool.

• Type revcloud and then press Enter.

2 Choose Arc Length.

3 Enter the minimum length of the individual arcs that make up the revision cloud, 
then press Enter.

4 Enter the maximum length of the individual arcs that make up the revision cloud, 
then press Enter. The value cannot be set to more than three times the minimum 
arc length.

Arc lengths can also be scaled.
The setting of the DIMSCALE system variable also affects arc length.

5 Choose Style and select one of the following:

• Normal — Draws new revision clouds as if they were drawn with a regular pen. 

• Calligraphy — Draws new revision clouds as if they were drawn with a callig-
raphy pen. 
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Adding multileaders

Multileaders consist of line segments or a spline curve that connects a feature in a 
drawing to multiline text or a block. Generally, you place an arrowhead at the first 
point, and the multiline text or block is placed immediately adjacent to the last point. 
Landing lines can also be placed horizontally between the leader and content (the 
multiline text or block).  

Creating multileaders
By default when you create a multileader, the multileader includes an arrow, line seg-
ments, and  multiline text at the endpoint. However, you can choose a spline instead 
of line segments and a block (or nothing) instead of multiline text. 

There are more options too. Use the Multileader prompts once you start the Multi-
leader command. For more control over format, use multileader styles. For more 
details, see “Working with multileader styles” on page 198 in this chapter. 

To create a multileader that includes multiline text
1 Do one of the following to choose Multileader ( ):  

• On the ribbon, choose Home > Multileader (in Annotation) or Annotate > Multi-
leader (in Leaders).

• On the menu, choose Dimensions > Multileader.

• On the Multileader toolbar, click the Multileader tool. Or on the Dimensioning 
toolbar, click the Multileader tool.

• Type mleader and then press Enter.   

2 Specify the starting point of the multileader.

3 Specify the endpoint of the multileader line segment.

4 Specify additional multileader line segment endpoints, if the maximum number of 
points is set to greater than two.

5 After you specify the last endpoint, press Enter.

6 In the Multiline Text editor, type the annotation.

7 When finished, click outside the Multiline Text editor.  

Specify the starting point of the multileader (A) and the endpoint of the multileader (B). Then 
type multiline text (C).

A

B

C

Sample
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To create a multileader that includes a block
1 Do one of the following to choose Multileader ( ):   

• On the ribbon, choose Home > Multileader (in Annotation) or Annotate > Multi-
leader (in Leaders).

• On the menu, choose Dimensions > Multileader.

• On the Multileader toolbar, click the Multileader tool. Or on the Dimensioning 
toolbar, click the Multileader tool.

• Type mleader and then press Enter.  

2 Choose Options, choose Content Type, then choose Block.

3 Type the name of the block to include at the end of the multileader, then press 
Enter.

4 Choose Exit.

5 Specify the starting point of the multileader.

6 Specify the endpoint of the multileader line segment.

7 Specify additional multileader line segment endpoints, if the maximum number of 
points is set to greater than two.

8 After you specify the last endpoint, press Enter.

To create a multileader that does not include multiline text or a block
1 Do one of the following to choose Multileader ( ):  

• On the ribbon, choose Home > Multileader (in Annotation) or Annotate > Multi-
leader (in Leaders).

• On the menu, choose Dimensions > Multileader.

• On the Multileader toolbar, click the Multileader tool. Or on the Dimensioning 
toolbar, click the Multileader tool.

• Type mleader and then press Enter.  

2 Choose Options, choose Content Type, then choose None.

3 Choose Exit.

4 Specify the starting point of the multileader.

5 Specify the endpoint of the multileader line segment.

Specify the starting point of the multileader (A) and the endpoint of the multileader (B). The 
specified block is drawn automatically.

A

B
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6 Specify additional multileader line segment endpoints, if the maximum number of 
points is set to greater than two.

7 After you specify the last endpoint, press Enter.

To specify options for a multileader before creating it
1 Do one of the following to choose Multileader ( ):   

• On the ribbon, choose Home > Multileader (in Annotation) or Annotate > Multi-
leader (in Leaders).

• On the menu, choose Dimensions > Multileader.

• On the Multileader toolbar, click the Multileader tool. Or on the Dimensioning 
toolbar, click the Multileader tool.

• Type mleader and then press Enter.  

2 Choose Options, then choose from the following:

• Leader type Select whether the leader line type is straight, a spline, or has no 
leader line.

• Leader landing Select whether to place a landing line horizontally between the 
leader and text or block content.

• Content type Select whether a multileader with this style contains multiline text, 
a block, or neither. 

• Maxpoints Select to enter the number of maximum points for the leader line.

• First angle Select to specify the constraint angle of the first line segment.

• Second angle Select to specify the constraint angle of the second line segment.

3 When finished, choose Exit, then continue creating the multileader.

You can specify more multileader options using multileader styles. 
For more details, see “Working with multileader styles” on page 198 in this chapter. 

Specify the starting point of the multileader (A) and the endpoint of the multileader (B).

A

B
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Adding and removing leader lines from multileaders
Each multileader can have more than one leader line attached to it.

To add leader lines to a multileader
1 Do one of the following to choose Add Leader Lines ( ):   

• On the ribbon, choose Home > Add Leader Lines (in Annotation) or Annotate 
> Add Leader Lines (in Leaders).

• On the Multileader toolbar, click the Add Leader Lines tool. 

• Type aimmleadereditadd and then press Enter. 

2 Select the desired multileader. 

3 Select an arrowhead location for a new leader. 

4 Continue selecting points to add additional leader lines, then press Enter when fin-
ished.

To remove leader lines from a multileader
1 Do one of the following to choose Remove Leader Lines ( ): 

• On the ribbon, choose Home > Remove Leader Lines (in Annotation) or 
Annotate > Remove Leader Lines (in Leaders).

• On the Multileader toolbar, click the Remove Leader Lines tool. 

• Type aimmleadereditremove and then press Enter. 

2 Select the entities to include in the selection set for leader removal.

3 Select a leader line to remove. 

4 Continue selecting leader lines to remove, then press Enter when finished.

Aligning multileaders
It’s easy to align and distribute multileaders. You can also collect multileaders and 
place them in one location. Note that multileaders with block content can be col-
lected, not multileaders with text content. 
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To align multileaders
1 Do one of the following to choose Align Multileader ( ): 

• On the ribbon, choose Home > Align Multileader (in Annotation) or Annotate 
> Align Multileader (in Leaders).

• On the Multileader toolbar, click the Align Multileader tool.

• Type mleaderalign and then press Enter.  

2 Select the multileaders to align, then press Enter.

3 Choose options if you want to customize the alignment, then choose from the fol-
lowing:

• Distribute Places multileader block or text content between two points that you 
select. 

• Make Leader Segments Parallel Places multileader block or text content where 
the last leader line segments will be parallel.

• Specify Spacing Places multileader block or text content according to the 
spacing that you specify.

• Use Current Spacing Places multileader block or text content according to the 
current spacing that was previously specified.

The following prompts display for the Distribute option, which is the default.

4 Select the start point to use for distributing the multileader block or text content.

5 Select the end point to use for distributing the multileader block or text content. 

Content will be aligned and distributed between the two points.

To collect multileaders that include blocks into a row or column
1 Do one of the following to choose Collect Multileader ( ):   

• On the ribbon, choose Home > Align Multileader (in Annotation) or Annotate 
> Collect Multileader (in Leaders).

• On the Multileader toolbar, click the Collect Multileader tool.

• Type mleadercollect and then press Enter.  

2 Select the multileaders to collect, then press Enter.

3 Choose how you want to collect and align multileader content:

• Horizontal Places collected multileaders horizontally. 

• Vertical Places collected multileaders vertically.

• Wrap Wraps the collected multileaders according to a width and number per row 
that you specify. 

4 Specify the upper left corner of the new location for the selected multileaders.



198 C H A P T E R  5
Working with multileader styles
When you create a multileader, the program draws it on the current layer, using the 
current multileader style. Each multileader has a corresponding multileader style, 
which controls the appearance of the multileader, such as the arrowhead type, text 
style, colors, and more. 

You can create, save, modify, and delete named multileader styles.You can also set 
any multileader style to be the current one that is assigned to new multileaders as you 
add them to your drawing.

Multiline styles can also be managed using the Explorer. For more details, see 
“Working with multileader styles” on page 330. 

Creating a multileader style
Multileader styles provide a way for you to change various settings that control the 
appearance of multileaders. You can then save those settings for reuse. If you don’t 
define a multileader style before creating multileaders, the program uses the Standard 
multileader style, which stores the default multileader settings. 

To create a multileader style
1 Do one of the following to choose Multileader Styles Manager ( ):   

• On the ribbon, choose Home > Multileader Styles Manager (in Annotation) or 
Annotate > Multileader Styles Manager (in Leaders).

• On the menu, choose Format > Multileader Styles Manager.

• On the Multileader or Styles toolbar, click the Multileader Styles Manager tool. 
Or on the Format toolbar, click the Multileader tool.

• Type mleaderstyle and then press Enter.  

2 Click New.

3 In New Style Name, type the name of the new multileader style.

4 In Start With, select an existing multileader style on which to base the new multi-
leader style. 

5 In Annotative, select to make multileaders with this style affected by annotation 
scaling.

6 Click Continue.

7 In the Create New Multileader Styles dialog box, make your selections for the 
multileader style as necessary. For details about the available options, click [?] in 
the dialog box.

8 When finished, click OK.
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Setting the current multileader style
When you create a multileader, it is automatically assigned the multileader style that 
is set to current. By default, the program uses the Standard multileader style, which 
stores the default multileader settings. Or you can choose a different multileader style 
to be the current one.

If you choose a different multileader style as current, that style is assigned to multi-
leaders that you create in the future, not existing multileaders.

To set a multileader style as current
1 Do one of the following to choose Multileader Styles Manager ( ):  

• On the ribbon, choose Home > Multileader Styles Manager (in Annotation) or 
Annotate > Multileader Styles Manager (in Leaders).

• On the menu, choose Format > Multileader Styles Manager.

• On the Multileader or Styles toolbar, click the Multileader Styles Manager tool. 
Or on the Format toolbar, click the Multileader tool.

• Type mleaderstyle and then press Enter.    

2 In the Multileader Styles Manager dialog box, select a multileader style from the 
list.

3 Click Set Current.

4 Click Close.

Assigning a style to a multileader
You can assign a different multileader style to a multileader at any time.

To assign a style to a multileader
1 Select a multileader in the drawing.

2 Do one of the following:   

• On the ribbon, choose Home then in Annotation, select the style in the Multi-
leader Style list. Or choose Annotate then select the style (in Leaders).

• On the Multileader or Styles toolbar, select the style in the Multileader Style list.

• Right-click the multileader, choose Properties, then in Style, select the style.
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Renaming a multileader style

To rename a multileader style
1 Do one of the following to choose Multileader Styles Manager ( ):  

• On the ribbon, choose Home > Multileader Styles Manager (in Annotation) or 
Annotate > Multileader Styles Manager (in Leaders).

• On the menu, choose Format > Multileader Styles Manager.

• On the Multileader or Styles toolbar, click the Multileader Styles Manager tool. 
Or on the Format toolbar, click the Multileader tool.

• Type mleaderstyle and then press Enter.  

2 In the Multileader Styles Manager dialog box, select the multileader style to 
rename.

3 Click the name a second time, type the new name, then press Enter.

4 Click Close.

Deleting a multileader style

To delete a named multileader style
1 Do one of the following to choose Multileader Styles Manager ( ):   

• On the ribbon, choose Home > Multileader Styles Manager (in Annotation) or 
Annotate > Multileader Styles Manager (in Leaders).

• On the menu, choose Format > Multileader Styles Manager.

• On the Multileader or Styles toolbar, click the Multileader Styles Manager tool. 
Or on the Format toolbar, click the Multileader tool.

• Type mleaderstyle and then press Enter.  

2 In the Multileader Styles Manager dialog box, select the multileader style to 
delete.

3 Click Delete.

4 To confirm the deletion, click OK.

5 Click Close.

Controlling leader format settings for multileader styles 
You can control leader format settings that affect the type, color, linetype, lineweight, 
arrowhead, and break size. Any changes you make affect the multileader style you’re 
working with (a new or existing one). The image tile on the right side of the Create 
New/Modify Multileader Styles dialog box shows the appearance of a multileader 
based on the current multileader style settings.  
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To set the leader format for multileader styles 
1 Do one of the following to choose Multileader Styles Manager ( ):   

• On the ribbon, choose Home > Multileader Styles Manager (in Annotation) or 
Annotate > Multileader Styles Manager (in Leaders).

• On the menu, choose Format > Multileader Styles Manager.

• On the Multileader or Styles toolbar, click the Multileader Styles Manager tool. 
Or on the Format toolbar, click the Multileader tool.

• Type mleaderstyle and then press Enter. 

2 Select a multileader style, then click Modify. Or if you want to create a new multi-
leader style instead, see “Creating a multileader style” on page 198 in this chapter. 

3 Click the Leader Format tab and make your selections.

4 Click OK when finished.
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A Select the leader line type: straight, spline, or no 
leader line.

B Select the leader line color for multileaders 
assigned this style. 

C Select the leader linetype for multileaders 
assigned this style.

D Select the leader lineweight for multileaders 
assigned this style.

E Select the leader line arrowhead for multileaders 
assigned this style.

F Enter or select the leader line arrowhead size for 
multileaders assigned this style.

G Enter or select the leader break size for 
multileaders assigned this style. The break size 
is used when the Dimension Break command is 
used with multileaders that are assigned this 
style.
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Controlling leader structure settings for multileader styles 
You can control settings affecting leader constraints, landing settings, and leader 
scale. Any changes you make affect the multileader style you’re working with (a new 
or existing one). The image tile on the right side of the Create New/Modify Multi-
leader Styles dialog box shows the appearance of a multileader based on the current 
multileader style settings. 

To set the leader structure for multileader styles 
1 Do one of the following to choose Multileader Styles Manager ( ):   

• On the ribbon, choose Home > Multileader Styles Manager (in Annotation) or 
Annotate > Multileader Styles Manager (in Leaders).

• On the menu, choose Format > Multileader Styles Manager.

• On the Multileader or Styles toolbar, click the Multileader Styles Manager tool. 
Or on the Format toolbar, click the Multileader tool.

• Type mleaderstyle and then press Enter.  

2 Select a multileader style, then click Modify. Or if you want to create a new multi-
leader style instead, see “Creating a multileader style” on page 198 in this chapter. 

3 Click the Leader Structure tab and make your selections.

4 Click OK when finished.
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A Select to limit the number of points for leader 
line, then enter or select the maximum number of 
points.

B Select to specify the angle of the first line 
segment, then enter or select the angle. 

C Select to specify the angle of the second line 
segment, then enter or select the angle.

D Select to include a landing line horizontally 
between the leader and text content.

E Select to specify the length of the landing line, 
then enter or select the length of the landing line.

F Select to specify that multileaders with this style 
are affected by annotation scaling.

G Select whether to scale multileaders 
automatically according to layout scaling or to 
enter a fixed scale. (Available for non-annotative 
styles.)
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Controlling content settings for multileader styles 
You can control settings for the content located at the end of multileaders. Specifi-
cally, choose whether the content is multiline text, a block, or none. Then you make 
further selections. The image tile on the right side of the Create New/Modify Multi-
leader Styles dialog box shows the appearance of a multileader based on the current 
multileader style settings.  

To set the content settings for a multileader style with multiline text 
1 Do one of the following to choose Multileader Styles Manager ( ): 

• On the ribbon, choose Home > Multileader Styles Manager (in Annotation) or 
Annotate > Multileader Styles Manager (in Leaders).

• On the menu, choose Format > Multileader Styles Manager.

• On the Multileader or Styles toolbar, click the Multileader Styles Manager tool. 
Or on the Format toolbar, click the Multileader tool.

• Type mleaderstyle and then press Enter. 

2 Select a multileader style, then click Modify. Or if you want to create a new multi-
leader style instead, see “Creating a multileader style” on page 198 in this chapter. 

3 Click the Content Settings tab.

4 In Multileader Type, choose Mtext.

5 Continue making your selections.

6 Click OK when finished.
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A Select whether a multileader with this style 
contains multiline text or a block, or none. The 
options in the dialog box change depending on 
your selection.

B Displays the default text for the multiline text 
content. Click [...] to specify the default text. 

C Select a text style for the multiline text. Click [...] 
to manage text styles.

D Select whether the rotation angle of multiline text 
is as-inserted, always right-reading, or always 
horizontal.

E Select a color for the multiline text.
F Enter or select the height of the multiline text.
G Select to always left justify the multiline text.

H Select to attach multiline text content to the 
multileader horizontally or vertically. The options 
that display depend on your selection.

I Select the location of multiline text when it is 
attached to the left (for horizontal) or top (for 
vertical) of the leader line.

J Select the location of multiline text when it is 
attached to the right (for horizontal) or bottom 
(for vertical) of the leader line.

K Enter or select the distance between the landing 
line and multiline text.

L Select to extend the multileader to the text when 
needed. (Available only for horizontal 
attachments.)

M Select to add a frame around the multiline text.
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To set the content settings for a multileader style with a block 
1 Do one of the following to choose Multileader Styles Manager ( ): 

• On the ribbon, choose Home > Multileader Styles Manager (in Annotation) or 
Annotate > Multileader Styles Manager (in Leaders).

• On the menu, choose Format > Multileader Styles Manager.

• On the Multileader or Styles toolbar, click the Multileader Styles Manager tool. 
Or on the Format toolbar, click the Multileader tool.

• Type mleaderstyle and then press Enter.  

2 Select a multileader style, then click Modify. Or if you want to create a new multi-
leader style instead, see “Creating a multileader style” on page 198 in this chapter. 

3 Click the Content Settings tab.

4 In Multileader Type, choose Block.

5 Continue making your selections.

6 Click OK when finished.
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A Select whether a multileader with this style 
contains multiline text or a block, or none. The 
options in the dialog box change depending on 
your selection.

B Select the block to use at the end of the 
multileader. 

C Select which point to use for attaching the block 
to the multileader: insertion point that you specify 
or center point.

D Select the color of the block, which is applied if 
the block entity color is ByBlock.

E Enter or select the scale of the block.
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Defining boundaries

A bounded polyline is an area bound by a single closed entity or by multiple entities 
that intersect and is used for hatching.

For details about adding hatching after you create a boundary, see “Adding hatching 
and gradients” on page 212 in this chapter. 

Understanding boundaries
With the Boundary command, you can designate a specific area of a drawing for 
operations such as hatching and dimensioning. You create a boundary by selecting an 
area inside a closed loop. The area you select can be bounded by a single closed entity 
or by multiple entities that intersect. The resulting boundary can be a polyline or 
region, if your program version supports working with regions.

In cases where entities intersect, IntelliCAD interprets the boundary as the closed 
loop closest to the point specifying the area. In the following figure, for example, the 
area point selected in the rectangle results in a boundary consisting of the closed loop 
nearest the point selection, as opposed to the closed loop formed by the rectangle 
itself.
 

To make boundaries more specific, you can create a boundary set. A boundary set 
specifies which entities are considered in determining the boundary path. This can 
make creating the boundary faster if you are working with a complex drawing.

In the following figure, the circle and triangle are the selected entities. If you select an 
area anywhere inside the circle or the triangle, the result is a polyline (or region if 
your program version supports regions) that bounds the shaded area.

Selected point (A) and resulting boundary (B).

A

B
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Defining a boundary
When you create a boundary, you select an existing entity or multiple entities to 
define the boundary.

To define boundaries from enclosed areas
Advanced experience level

1 Do one of the following to choose Boundary ( ):

• On the ribbon, choose Home > Boundary (in Draw) or choose Draw > Boundary 
(in Draw).

• On the menu, choose Draw > Hatch > Boundary.

• On the Draw toolbar, click the Boundary tool.

• Type boundary and then press Enter.

2 In Boundary Set, optionally specify a subset of entities to consider when creating 
the boundary:

• Click Select Boundary Set.

• In the drawing, select the entities to consider when creating the boundary, and 
press Enter when finished. 

The Boundary Creation dialog box displays again and the Current Selection Set 
option becomes selected automatically, which indicates that the entities you 
selected will be considered when creating the boundary.

You don’t have to select entities again using Select Boundary Set. 
The Current Selection Set option uses the last set of entities you selected with 
Select Boundary Set.

3 Mark Island Detection if you want to consider all internal, closed boundaries, 
called islands, for defining a boundary.

Selected entities (A and B) and the point specified in the selected area (C), which results in a 
new boundary around the shaded area.
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4 In Entity Type, choose whether to create the resulting boundaries as polylines or 
regions. Regions are available only for program versions that support working 
with regions. 

5 Click Pick Internal Points.

6 In the drawing, click inside the area whose closed perimeter forms the boundary, 
not on the entity itself. If desired, continue clicking inside additional closed perim-
eters.

7 To complete the selection and create the boundaries, press Enter. 

To define a boundary around a hatch
1 Type hatchgenerateboundary and then press Enter.

2 Select the hatch entities around which you want to create boundaries, then press 
Enter.

The boundaries are created as polylines and are not associated with the hatch enti-
ties.

A Click to pick enclosed areas used to create new 
boundaries.

B Click to customize the selection set of entities in 
the drawing to be considered when creating 
boundaries.

C If you clicked Select Boundary Set, choose 
whether to consider all visible entities when 
creating boundaries or only the entities in the 
custom selection set.

D Click to consider all internal, closed boundaries 
when creating boundaries.

E Select whether to create the boundary as a 
polyline or region (for program versions that 
support working with regions).
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Adding hatching and gradients

When you add hatching or gradients to a drawing, IntelliCAD fills entities or 
enclosed areas with a pattern.            

Adding hatching or gradients is a four step process:

1 Specify a hatch or gradient pattern.

2 Specify entities or areas.

3 Optionally specify island detection options.

4 Specify additional options.

Hatch patterns and gradients are memory intensive. Because hatch and gradient pat-
terns can take a considerable amount of time to draw and display, you may want to 
add hatching and gradients during the last steps of drawing creation or insert them on 
a separate layer that you can freeze as you continue to work on your drawing. For 
example, instead of using a small-scaled line pattern to create a solid fill, use the 
SOLID hatch pattern instead as this will print and display much faster.       

Specifying a hatch or gradient pattern
A hatch pattern consists of a repeating pattern of lines, dashes, and dots. You can 
select one from a set of predefined patterns, define a pattern of your own, or choose a 
pattern from a custom hatch library.

A gradient pattern consists of a gradual or smooth change from one color to another 
color. You simply select colors and a pattern.

Existing hatches and gradients can be modified.
Type hatchedit to modify an existing hatch or gradient, double-click it in the drawing, 
or change its settings in the Properties pane.

Specifying a predefined hatch pattern
Predefined hatch patterns are stored in the following hatch pattern library files:

• icad.pat — American National Standards Institute (ANSI)-compliant patterns.

• icadiso.pat — International Standards Organization (ISO)-compliant patterns. 

To specify a predefined hatch pattern    
1 Do one of the following to choose Hatch ( ):

• On the ribbon, choose Home > Hatch (in Draw) or Draw > Hatch (in Draw).

• On the menu, choose Draw > Hatch > Hatch.

• On the Draw toolbar, click the Hatch tool.

• Type bhatch and then press Enter.
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2 Click the Hatch tab.

3 In Type, select Predefined.

4 In Pattern, select the desired pattern. You can also click [...] or click the swatch to 
open the Hatch Patterns dialog box and select a pattern from the ANSI, ISO, or 
Other Predefined tabs.

5 Specify any of the following options:

• Color In the first (left) color list, select the color of the hatch lines. In the second 
(right) color list, select the color of the hatch background.

• Angle Enter the angle of the hatch pattern relative to the x-axis in degrees (1-
360). The default angle is clockwise; you can change the angle by entering a 
numerical value.

• Scale Enter the scale factor as a percentage of the default. Changing the scale 
factor makes the hatch pattern larger or smaller than the default size. If you 
selected an ISO standard pattern, the scale affects the ISO pen width.

• Related to paper space Select to scale the hatch pattern relative to the units 
defined for paper space. (Available for named layouts.)

• ISO pen width Enter the pen width if you selected an ISO standard pattern. 

6 In Hatch Origin, select whether to draw the hatch pattern from the default origin or 
a new origin. If you choose to specify a new origin, do one of the following:

• Click ( ) to pick the new origin directly in the drawing.

• Select Default to Boundary Extents to set the origin to the top left, top right, 
bottom left, bottom right, or center of the boundary extents.

A new origin can be saved as the new default.
To store the new hatch origin as the default, select Store as Default Origin. The 
hatch origin will be saved in the HPORIGIN system variable.

7 To continue, specify entities or areas for hatching. For details, see “Specifying 
entities or areas for hatching and gradients” on page 220 in this chapter. 

To specify a user-defined hatch pattern 
1 Do one of the following to choose Hatch ( ):

• On the ribbon, choose Home > Hatch (in Draw) or Draw > Hatch (in Draw).

• On the menu, choose Draw > Hatch > Hatch.

• On the Draw toolbar, click the Hatch tool.

• Type bhatch and then press Enter.

2 Click the Hatch tab.
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3 In the Type list, select User Defined.

4 Specify any of the following options:

• Color In the first (left) color list, select the color of the hatch lines. In the second 
(right) color list, select the color of the hatch background.

• Angle Enter the angle of the hatch pattern relative to the x-axis in degrees (1-
360). The default angle is clockwise; you can change the angle by entering a 
numerical value.

• Double Select to cross-hatch the pattern, which places another copy of the 
pattern at a 90-degree angle over the original.

• Related to paper space Select to scale the hatch pattern relative to the units 
defined for paper space. (Available for named layouts.)

• Spacing Enter the line spacing for the hatch pattern.

5 In Hatch Origin, select whether to draw the hatch pattern from the default origin or 
a new origin. If you choose to specify a new origin, do one of the following:

• Click ( ) to pick the new origin directly in the drawing.

• Select Default to Boundary Extents to set the origin to the top left, top right, 
bottom left, bottom right, or center of the boundary extents.

A new origin can be saved as the new default.
To store the new hatch origin as the default, select Store as Default Origin. The 
hatch origin will be saved in the HPORIGIN system variable.

6 To continue, specify entities or areas for hatching. For details, see “Specifying 
entities or areas for hatching and gradients” on page 220 in this chapter. 

Specifying a custom library hatch pattern
You can use custom external hatch pattern libraries (.pat files), such as a standard 
library used in your office, customized patterns, and libraries available from vendors 
or standards organizations. The .pat files can be in any location.

Each .pat file contains one hatch pattern, and the filename must match the name of 
the hatch pattern. The hatch pattern definition is as follows:

*[Name],[Description]

angle, x-origin, y-origin, delta-x, delta-y [, dash1, dash2, …]

Alternatively, you can add a custom hatch pattern to icad.pat and use predefined 
hatch patterns described previously instead of a custom library pattern below.



C R E A T I N G  C O M P L E X  E N T I T I E S 215
To use a custom library pattern
1 Do one of the following:

• Copy the custom pattern file (.pat file) to the Patterns folder where you installed 
IntelliCAD. To check where IntelliCAD searches for pattern files, choose Tools 
> Options, click Paths/Files, and check the folders listed for Hatch Patterns.

• Choose Tools > Options, click Paths/Files, and add the location of the custom 
pattern file (.pat file) to the folders listed for Hatch Patterns.

2 Do one of the following to choose Hatch ( ):

• On the ribbon, choose Home > Hatch (in Draw) or Draw > Hatch (in Draw).

• On the menu, choose Draw > Hatch > Hatch.

• On the Draw toolbar, click the Hatch tool.

• Type bhatch and then press Enter.

3 Click the Hatch tab.

4 In Type, choose Custom.

5 In Custom Pattern, select a pattern from the list. You can also click [...] to open the 
Hatch Patterns dialog box and select a pattern from the Custom tab.

6 Specify any of the following options:

• Color In the first (left) color list, select the color of the hatch lines. In the second 
(right) color list, select the color of the hatch background.

• Angle Enter the angle of the hatch pattern relative to the x-axis in degrees (1-
360). The default angle is clockwise; you can change the angle by entering a 
numerical value.

• Scale Enter the scale factor as a percentage of the default. Changing the scale 
factor makes the hatch pattern larger or smaller than the default size.

• Related to paper space Select to scale the hatch pattern relative to the units 
defined for paper space. (Available for named layouts.)

7 In Hatch Origin, select whether to draw the hatch pattern from the default origin or 
a new origin. If you choose to specify a new origin, do one of the following:

• Click ( ) to pick the new origin directly in the drawing.

• Select Default to Boundary Extents to set the origin to the top left, top right, 
bottom left, bottom right, or center of the boundary extents.

A new origin can be saved as the new default.
To store the new hatch origin as the default, select Store as Default Origin. The 
hatch origin will be saved in the HPORIGIN system variable.

8 To continue, specify entities or areas for hatching. For details, see “Specifying 
entities or areas for hatching and gradients” on page 220 in this chapter. 
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A Select to create a hatch pattern.
B Select the type of hatch pattern.
C Select a predefined hatch pattern from the list or click [...] to 

select it in the Hatch Patterns dialog box.
D Click to select a hatch pattern.
E Select the color of the hatch lines.
F Select a custom hatch pattern from the list or click [...] to select 

it in the Hatch Patterns dialog box.
G Enter the angle of the hatch pattern in relation to the x-axis.
H Select to cross-hatch a user defined pattern.
I Enter the line spacing for a user defined pattern.

J Enter the pen width for an ISO-standard predefined pattern.
K Select to use the default hatch origin or to specify a new origin.
L Click to pick the new hatch origin in the drawing.
M Select to set the new hatch origin to the top left, top right, 

bottom left, bottom right, or center of the boundary extents.
N Select to save the new hatch origin as the new default.
O Select to scale the hatch pattern relative to the units defined for 

paper space. (Available for named layouts.)
P Enter the scale factor as a percentage of the default.
Q Select the color of the hatch background.
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Specifying a super hatch pattern
In addition to standard hatch patterns, you can use the Super Hatch command to apply 
a hatch pattern created by automatically repeating an image, texture, block, external 
reference, or wipeout. 

Different than a standard hatch pattern, after you create a super hatch pattern, it is not 
associative with the boundary used to create it.

To use a super hatch pattern
1 Do one of the following to choose Super Hatch ( ):

• On the ribbon, choose Home > Super Hatch (in Draw), Draw > Super Hatch (in 
Draw), or Express Tools > Super Hatch (in Draw).

• On the menu, choose Draw > Hatch > Super Hatch or Express Tools > Draw > 
Super Hatch.

• Type superhatch and then press Enter.

2 In Curve Error Tolerance, optionally enter a tolerance value when approximating 
vectors of super-hatch boundaries that are curved.

3 Select which type of entity you want to use as a hatch pattern:

• Image Click to select an image file to use as a hatch pattern. In the Attach Image 
dialog box, specify additional settings for inserting the image file in the 
drawing.

• Texture Click to select a texture file to use as a hatch pattern. Textures are image 
files with a seamless design and are easy to use with super hatches. In the Attach 
Image dialog box, specify additional settings for inserting the texture file in the 
drawing. Several textures are available with the program. 

• Block Click to open the Insert Block dialog box and choose the drawing file or 
existing block to use as a hatch pattern.

• Xref Click to open the Attach External Reference dialog box and choose an 
external reference file to use as a hatch pattern.

• Wipeout Click to create a hatch using a new wipeout entity.

Alternatively, if the image, block, external reference, or wipeout you want to use 
as a hatch already exists in the drawing, click Select Pattern to select it in the 
drawing, then follow the prompts.

4 Click OK.

5 Optionally choose Advanced to specify more options for defining the area bound-
ary.

6 Pick a point inside the enclosed area you want to hatch.

You may want to turn off image and wipeout frames after you create a super hatch.
Type tframes to turn image and wipeout frames off (and on).
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Specifying a gradient pattern
A gradient pattern consists of a gradual or smooth change from one color to another 
color. Simply select the colors, a pattern, and orientation settings.

To specify a gradient pattern 
1 Do one of the following to choose Gradient ( ):

• On the ribbon, choose Home > Gradient (in Draw) or Draw > Gradient (in 
Draw).

• On the menu, choose Draw > Hatch > Gradient.

• On the Draw toolbar, click the Gradient tool.

• Type gradient and then press Enter.

2 In Color, choose one of the following:

• One Color Specify one color for the gradient pattern, then specify the color in 
Color1. The color you specify will be smoothed with the color white or black, 
depending on the GFCLRSTATE system variable.

• Two Colors Specify two colors for the gradient pattern, then specify the colors 
in Color1 and Color2. Color1 will be smoothed with Color2.

3 In the 3x3 display of gradient patterns, select a gradient pattern.

4 Specify the orientation options:

• Centered Select to center the gradient pattern. If not selected, the gradient 
pattern appears to have a light source above and to the left (the pattern is shifted 
up and to the left).

• Angle Enter or select the angle of the gradient pattern.

5 To continue, specify entities or areas for gradients. For details, see “Specifying 
entities or areas for hatching and gradients” on page 220 in this chapter. 
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A Select to create a gradient pattern.
B Select to specify one or two colors for the gradient pattern.
C Select the first color of the gradient pattern; click [...] for more 

color options.
D Select the second color if creating a two-color gradient pattern; 

click [...] for more color options.

E Select a gradient pattern.
F Select to center the gradient pattern; if not selected, the pattern 

will shift up and to the left.
G Enter or select an angle for the gradient pattern.
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Specifying entities or areas for hatching and gradients
You can specify either entities or areas in which to apply hatches and gradients: 

• Select entities — Add hatching or gradients to any entity that forms a closed 
boundary, for example, a circle or rectangle. You can assign hatching or gradients 
to a single entity or several entities at the same time. 

• Select areas — Add hatching or gradients to an area enclosed by entities that form 
a boundary. The hatch or gradient is created in the enclosed area, not the entities 
themselves. The entire hatch or gradient, once drawn, is treated as a single entity 
and it is either associative or independent of the boundary entities.

To select entities or areas for hatching and gradients
1 Do one of the following to choose Hatch ( ) or Gradient ( ):

• On the ribbon, choose Home > Hatch or Home > Gradient (in Draw); or choose 
Draw > Hatch or Draw > Gradient (in Draw).

• On the menu, choose Draw > Hatch > Hatch, or Gradient.

• On the Draw toolbar, click the Hatch tool or Gradient tool.

• Type bhatch or gradient and then press Enter.

2 Click one of the following:

• Add: Pick points Specifies areas for which to apply hatching and gradients. In 
the drawing, click inside the closed perimeter of a boundary, not on the 
boundary itself. If desired, continue clicking inside additional closed perimeters. 
To complete the selection, press Enter.

• Add: Select entities Specifies entities for which to apply hatching and gradients. 
In the drawing, click the entities individually or by choosing a selection method 
from the prompt box, and then press Enter when done.

• Remove boundaries Removes boundaries from the selection set. In the drawing, 
click the boundaries to remove from the selection set.

• Recreate boundary Creates a polyline or region around a hatch or gradient. In 
the drawing, click the hatch or gradient for which you want to create a boundary.

• View selections Displays the selection set. In the drawing, press Enter when 
done viewing the selection set.

3 To continue, specify additional options. For details, see “Specifying additional 
hatch and gradient options” on page 223 in this chapter. 

A warning message displays when you create the hatch or gradient if the number of 
entities selected exceeds the HPOBJWARNING system variable value.
If the warning displays, to improve performance before continuing with hatch cre-
ation, select fewer entities. Hatch patterns are memory intensive and can take a 
considerable amount of time to draw. 
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A Click to select a point inside one or more entities that create 
a boundary.

B Click to select one or more entities.
C Click to remove a boundary from the selection set.

D Click to view currently selected entities in the drawing.
E Click to select a hatch or gradient for which to surround with 

a polyline or region.

EDA B C
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Specifying islands and island detection
Islands are closed loops that reside inside other closed loops. IntelliCAD provides 
island-detection options so that you can specify which islands, if any, should be con-
sidered in the area selection for a boundary. 

The following figure shows a rectangular polyline with two islands. The circle is 
referred to as the outer island, and the octagon is referred to as a nested island.  

You can choose from three island-detection methods.

• Nested Islands The outer entity and all its islands are considered for the polyline.

• Outer Only Only the outer entity and its outer island are considered for the 
polyline.

• Ignore Islands Only the outer entity is considered for the polyline.

 

Rectangular polyline (A) with outer island (B), with point (C) specifying the area selection, and nested island 
(D).

Nested islands (A), with outer island (B), and with ignore islands (C).

A

B

C

D

A B C
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To specify island detection options    
1 Do one of the following to choose Hatch ( ) or Gradient ( ):

• On the ribbon, choose Home > Hatch or Home > Gradient (in Draw); or choose 
Draw > Hatch or Draw > Gradient (in Draw).

• On the menu, choose Draw > Hatch > Hatch, or Gradient.

• On the Draw toolbar, click the Hatch tool or Gradient tool.

• Type bhatch or gradient and then press Enter.

2 In Islands, select Island Detection and then choose one of the following:

• Normal The outer entity and all its islands are considered for hatching.

• Outer Only the outer entity and its outer island are considered for hatching.

• Ignore Only the outer entity is considered for hatching.

Specifying additional hatch and gradient options
There are many options that can be specified for hatches and gradients, including for-
matting options and specific options related to boundaries.

Existing hatches and gradients can be modified.
Type hatchedit to modify an existing hatch or gradient, double-click it in the drawing, 
or change its settings in the Properties pane.

To specify additional hatch and gradient options    
1 Do one of the following to choose Hatch ( ) or Gradient ( ):

• On the ribbon, choose Home > Hatch or Home > Gradient (in Draw); or choose 
Draw > Hatch or Draw > Gradient (in Draw).

• On the menu, choose Draw > Hatch > Hatch, or Gradient.

• On the Draw toolbar, click the Hatch tool or Gradient tool.

• Type bhatch or gradient and then press Enter.

2 Select any of the following formatting options:

• Annotative Makes the display and printing of the hatch or gradient pattern 
affected by annotation scaling.

• Associative Associates the hatch or gradient pattern with its boundary entities. 
An associative pattern updates automatically if you move any of its boundaries.

An associative hatch can be selected automatically when its boundary entities are 
selected.
Use the Hatch Selection command to turn the setting on or off. On the ribbon if 
your program version includes one, choose Home > Hatch Selection (in Draw) or 
Draw > Hatch Selection (in Modify), or on the menu choose Draw > Hatch > 
Hatch Selection.
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• Create Separate Hatches Creates multiple hatches or gradients when more than 
one closed boundary is selected.

• Draw Order Determines the order in which the hatch or gradient pattern is drawn 
relative to its boundary.  

• Layer Determines the layer on which the hatch or gradient pattern is assigned.

• Transparent Determines the transparency of the hatch or gradient. If you select 
Specify Value, enter the transparency value or use the slider.

• Inherit Properties Allows selection of a hatch or gradient from which to copy 
settings and load those settings in the Hatch and Gradient dialog box.

3 From the Hatch and Gradient dialog box, click > if necessary to expand the dialog 
box.

4 Select any of the following boundary-related options:

• Boundary Retention Keeps any new entities that are created for drawing the 
hatch or gradient. If turned on, select whether to create new entities as polylines 
or regions. Existing entities are always retained.

• Boundary Set Determines the area of entities that is considered for creating a 
boundary when using the Add: Pick Points option. Choose Current Viewport to 
make available all entities within the current viewport. Choose Existing Set to 
make available only those entities within the area specified with the New option. 
Click New to specify a new area.

• Gap Tolerance Determines the tolerance that non-touching entities can be 
within and still be used to create a boundary. For example, if two lines do not 
meet at the same point but the distance between their endpoints falls within the 
hatch tolerance, they will be considered closed and can be used to create a 
boundary. IntelliCAD calculates the gap tolerance automatically, depending on 
the size of the IntelliCAD window.

• Inherit Options Determines whether to use the current origin or the original 
hatch origin when you use Inherit Properties.

5 Click OK.
  

Hatch patterns are memory intensive. 
Because hatch patterns can take a considerable amount of time to draw and display, 
you may want to add hatching during the last steps of drawing creation or insert 
hatches on a separate layer that you can freeze as you continue to work on your 
drawing. In addition, be sure to use the appropriate hatch scale and pattern. For 
example, instead of using a small-scaled line pattern to create a solid fill, use the 
SOLID hatch pattern instead as this will print and display much faster.
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A Select to make the hatch or gradient annotative.
B Select to update the hatch or gradient automatically if you move 

any of its boundaries.
C Select to create a separate hatch or gradient when more than 

one closed boundary is selected.
D Click to select a hatch or gradient in the drawing from which to 

copy settings.
E Select the transparency of the hatches or gradients; if Specify 

Value, enter the transparency value or use the slider.
F Select the layer of the hatches or gradients.
G Choose the hatch or gradient origin to apply when using Inherit 

Properties.

H Select the order of the hatch or gradient relative to the 
boundary.

I Enter the tolerance that non-touching entities can be within and 
still be used to create the hatch pattern boundary.

J Select the area of entities to consider for creating a boundary 
when using the Add: Pick Points option.

K Click to specify a new area for boundary selection when using 
the Add: Pick Points option.

L If Retain Boundaries is turned on, select whether to create 
boundaries as polylines or regions.

M Select to keep any new entities that are created for drawing the 
hatch or gradient.

N Determines how hatching and gradients interact with islands.
O Select to detect islands when determining boundaries.

M
L

K

I

O

FEA B C

N

G

D

H

J
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6

Viewing your drawing

IntelliCAD provides many ways to display and view your drawing. You can also 
change various display settings to speed up the display or printing of a drawing. This 
section explains how to:

• Navigate within a drawing by scrolling, panning, and rotating the view.

• Change the magnification of a drawing by zooming in and out.

• View a drawing with annotation scales.

• Work with multiple windows or views of a drawing.

• Control the display of elements to optimize performance when working with large 
or complex drawings.

When working with three-dimensional drawings, see “Viewing entities in three 
dimensions” on page 688. To hide, shade, or render a drawing, see “Hiding, shading, 
and rendering” on page 767. 

Topics in this chapter

Redrawing and regenerating a drawing ............................................................ 228

Moving around within a drawing ....................................................................... 229

Changing the magnification of your drawing..................................................... 233

Changing the view of annotative entities .......................................................... 238

Displaying multiple windows ............................................................................. 242

Controlling visual elements............................................................................... 248
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Redrawing and regenerating a drawing     

As you work on a drawing, visual elements may remain after the completion of a 
command. You can remove these elements by refreshing, or redrawing, the display.            

To redraw (refresh) the current window display
Do one of the following to choose Redraw ( ):

• On the ribbon, choose View > Redraw (in Navigate).

• On the menu, choose View > Redraw.

• On the Zoom toolbar, click the Redraw tool.

• Type redraw and then press Enter.

Information about drawing entities is stored in a database as floating point values, 
ensuring a high level of precision. Sometimes a drawing must be recalculated, or 
regenerated, from the floating-point database to convert those values to the appropri-
ate screen coordinates. This occurs automatically. You can also manually initiate a 
regeneration. When the drawing is regenerated, it is also redrawn.       

To regenerate the current window, type regen in the command bar. If more than one 
window is displayed, type regenall to regenerate all the windows.    
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Moving around within a drawing  

You can move the view of a drawing displayed in the current viewport by scrolling, 
panning, or rotating the view. Doing this changes the portion of the drawing you are 
viewing without changing the current magnification. Scrolling lets you move around 
in the drawing horizontally and vertically. Panning lets you move the drawing in any 
direction. Rotating lets you view your drawing from any angle.          

You can also move to a different view using the following:

• Model and Layout tabs. For more details, see “Viewing drawings in paper space 
and model space” on page 618. 

• Preset views. For more details, see “Switching to a preset viewing direction” on 
page 688. 

• Named views. For more details, see “Creating and switching to named views” on 
page 690. 

• Cameras. For more details, see “Using a camera to view the drawing” on page 
704. 

Using scroll bars
To assist you in navigating within a drawing, horizontal and vertical scroll bars are 
available in each drawing window. The size of the scroll box in relation to the scroll 
bar indicates the current level of drawing magnification. The position of the scroll 
box in relation to the scroll bar indicates the location of the center of the drawing in 
relation to the extents of the drawing (the smallest rectangle containing all the entities 
in the drawing).       

To turn scroll bars on or off
Do one of the following to choose Scroll Bars:

• On the ribbon, choose View > Scroll Bars (in Display).

• On the menu, choose View > Display > Scroll Bars.

• Choose Tools > Options > Display tab, and select Show Scroll Bars. 

• Type scrollbar, press Enter, and then select On, Off, or Toggle.
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Panning a drawing
You can move the drawing in any direction using the Pan tool ( ) on the View 
toolbar. Panning shifts or slides the view of the drawing horizontally, vertically, or 
diagonally. The magnification of the drawing remains the same, as does its orienta-
tion in space. The only change is the portion of the drawing displayed.        

If you often pan (and zoom) to a certain area of a drawing, you can create and re-use a 
view using the View Manager.
For details, see “Working with named views” on page 333. 

Panning (and zooming) can be affected by smooth view transitions.
Type vtoptions to specify whether smooth view transitions are used when panning 
and zooming, and to specify speed and performance settings.

Panning by specifying two points
For precise panning, specify two points defining the magnitude and direction of the 
pan. The first point, or base point, indicates the starting point of the pan. The second 
point indicates the amount of pan displacement relative to the first point.

To pan by specifying two points
1 Do one of the following to choose Pan ( ):

• On the ribbon, choose View > Pan (in Navigate).

• On the menu, choose View > Pan > Pan.

• On the View toolbar, click the Pan tool.

• Type pan and then press Enter.

2 Specify the pan base point either by typing the coordinates or by specifying a point 
in the drawing window.

3 Specify the pan displacement point either by typing the coordinates or by specify-
ing a point in the drawing window. 

 

Select the pan base point (A), and then select a 
second point (B) to specify the pan displacement.

Result.

A
B
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Panning in real time
By panning in real time, you control the pan at the same time you move your mouse. 

To pan in real time    
1 Do one of the following to choose Real-Time Pan ( ):

• On the ribbon, choose View > Real-Time Pan (in Navigate).

• Choose View > Pan > Real-Time Pan.

• On the Zoom toolbar, click the Real-Time Pan tool.

• Type rtpan and then press Enter.

2 Click and hold the left mouse button. 

3 Move the cursor in the direction you want to pan.

4 To stop panning, release the mouse button.

Panning using a mouse with a wheel
You can use the wheel of your mouse to help move around in a drawing. 

The MBUTTONPAN system variable controls this feature.

To pan using a mouse with a wheel    
• Press and hold the wheel, and then move the mouse in the direction you want to 

pan. 

Panning using the arrow keys
To pan in small increments, use the arrow keys. 

You can pan using the arrow keys if Use Up/Down Arrows for Command History 
Navigation is not marked on the Display tab in Tools > Options.

To pan using the arrow keys
• Press the up, down, right, or left arrow keys.

Orbiting the drawing in real time
IntelliCAD allows you to orbit the drawing, or rotate the view, in real time. This 
allows you to view your model from any angle while in model space. You cannot 
rotate the view while in paper space.      

Using 3D Orbit commands in large drawing files can be memory intensive. 
It may be helpful to set the ZOOMDETAIL system variable to a higher value to 
reduce the number of entities that display during the command. For example, if the 
value is set to 10, entities with a pixel size less than or equal to 10 become invisible, 
and when finished orbiting in real time, the entities become visible again.
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To orbit the drawing   
1 Do one of the following to choose Constrained Orbit ( ):

• On the ribbon, choose View > Constrained Orbit (in Navigate).

• On the menu, choose View > 3D Orbit > Constrained Orbit.

• On the 3D Orbit toolbar, click the Constrained Orbit tool.

• Type 3dorbit and then press Enter.

2 Do one of the following:

• Click and drag the left mouse button to orbit the drawing.

• Choose Set to pick a different point on which to orbit, then click and drag the 
mouse to orbit the drawing.

3 To stop orbiting, release the mouse button.

Use a shortcut. 
Press and hold Shift while viewing a drawing, then click and drag the middle mouse 
button (wheel) to orbit the drawing. 

To orbit the drawing using continuous motion   
1 Do one of the following to choose Continuous Orbit ( ):

• On the ribbon, choose View > Continuous Orbit (in Navigate).

• On the menu, choose View > 3D Orbit > Continuous Orbit.

• On the 3D Orbit toolbar, click the Continuous Orbit tool.

• Type 3dcorbit and then press Enter.

2 Do one of the following:

• Click and drag the left mouse button to orbit the drawing.

• Choose Set to pick a different point on which to orbit, then click and drag the 
mouse to orbit the drawing.

3 Release the mouse button. The view continues to orbit.

4 When finished, press Enter or Esc, or right-click the drawing.

You can orbit without locking any axis or choose a different axis to lock. 
Use the Free Orbit command to orbit the drawing without any axis locked. Use the 
Constrained X Orbit, Constrained Y Orbit, and Constrained Z Orbit commands to 
orbit the drawing while maintaining the chosen axis. You can also press Ctrl and use 
the right mouse button to rotate the view about the z-axis.
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Changing the magnification of your drawing  

You can change the magnification of your drawing at any time by zooming. The 
cursor changes to a magnifying glass ( ) when a zoom tool is active. Zoom out to 
reduce the magnification so you can see more of the drawing, or zoom in to increase 
the magnification so you can see a portion of the drawing in greater detail. Changing 
the magnification of the drawing affects only the way the drawing is displayed; it has 
no effect on the dimensions of the entities in your drawing.             

If you often zoom (and pan) to a certain area of a drawing, you can create and re-use a 
view using the View Manager.
For details, see “Working with named views” on page 333. 

If you cannot zoom in a layout viewport, the layout viewport may be locked. 
The scale and view do not change in model space while panning or zooming in a 
locked layout viewport. For more details, see “Modifying layout viewports” on page 
628. 

Understanding zoom
One of the easiest ways to change the magnification of the drawing is to zoom in or 
out by a preset increment. On the Zoom toolbar, the Zoom In tool ( )doubles the 
current magnification of the drawing. The Zoom Out tool ( ) reduces the magnifi-
cation of the drawing by half. The portion of the drawing located at the center of the 
current viewport remains centered on the screen as you zoom in and out.           
 

Zooming (and panning) can be affected by smooth view transitions.
Type vtoptions to specify whether smooth view transitions are used when zooming 
and panning, and to specify speed and performance settings.

Zoom in. Zoom out.
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Zooming in to an area using a window
You can create a window that defines the portion of the drawing to which you want to 
zoom.

To zoom in to an area using a window
1 Do one of the following to choose Zoom Window ( ):

• On the ribbon, choose View > Zoom Window (in Navigate).

• On the menu, choose View > Zoom > Window.

• On the Zoom toolbar, click the Zoom Window tool.

• Type zoom and then press Enter.

2 Select one corner of the window around the area you want to magnify.

3 Specify the opposite corner of the window around the area you want to magnify.

Zooming in to one or more entities
You can zoom in to specific entities that you select. The window fills with the entities 
that you select.

To zoom in to one or more entities  
1 Select one or more entities.

2 Do one of the following to choose Zoom Entity ( ):

• On the ribbon, choose View > Zoom Entity (in Navigate).

• On the menu, choose View > Zoom > Entity.

• On the Zoom toolbar, click the Zoom Entity tool.

To specify a rectangular window around the 
area you want to magnify, select first one corner 
(A), and then select the opposite corner (B).

Result.

A

B
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Zooming in real time
By zooming in real time, you control the zoom at the same time you move your 
mouse. 

Using real-time zoom in large drawing files can be memory intensive. 
It may be helpful to set the ZOOMDETAIL system variable to a higher value to 
reduce the number of entities that display during the command. For example, if the 
value is set to 10, entities with a pixel size less than or equal to 10 become invisible, 
and when finished zooming in real time, the entities become visible again.

To zoom in real time    
1 Do one of the following to choose Real-Time Zoom ( ):

• On the ribbon, choose View > Real-Time Zoom (in Navigate).

• On the menu, choose View > Zoom > Real-Time Zoom.

• On the Zoom toolbar, click the Real-Time Zoom tool.

• Type rtzoom and then press Enter.

• Simultaneously press and hold Ctrl + Shift.

2 Click and hold the left mouse button.

3 To zoom in, move the cursor up the screen; to zoom out, move the cursor down the 
screen.

4 To stop zooming, release the mouse button.

To zoom in real time using a mouse with a wheel    
• Rotate the wheel away from you to zoom in or toward you to zoom out.

Customize the mouse wheel.
Settings for the mouse wheel can be customized to accommodate your work style 
using the ZOOMWHEEL (wheel direction), ZOOMPERCENT (display accuracy for 
curved entities), and ZOOMFACTOR (zoom factor for the wheel) system variables.
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Displaying the previous view of a drawing
After you zoom in or pan to view a portion of your drawing in greater detail, you may 
want to restore the previous view to see the entire drawing.

To display the previous view of a drawing
1 Do one of the following to choose Zoom Previous ( ):

• On the ribbon, choose View > Zoom Previous (in Navigate).

• On the menu, choose View > Zoom > Previous.

• On the Zoom toolbar, click the Zoom Previous tool.

Selecting this tool repeatedly steps back through up to 25 successive zoomed or 
panned views.      

Zooming to a specific scale  
You can increase or decrease the magnification of your view by a precise scale factor 
measured relative to the overall size of the drawing or in relation to the current dis-
play. When you change the magnification factor, the portion of the drawing located at 
the center of the current viewport remains centered on the screen.    

To change the magnification of the view relative to the overall size of the drawing, 
type a number representing the magnification scale factor. For example, if you type a 
scale factor of 2, the drawing appears at twice its original size. If you type a magnifi-
cation factor of .5, the drawing appears at half its original size.

You can also change the magnification of the drawing relative to its current magnifi-
cation by adding an x after the magnification scale factor. For example, if you type a 
scale factor of 2x, the drawing changes to twice its current size. If you type a magnifi-
cation factor of .5x, the drawing changes to half its current size.

To zoom to a specific scale relative to the current display    
1 Do one of the following to choose Zoom In ( ):

• On the ribbon, choose View > Zoom In (in Navigate).

• On the menu, choose View > Zoom > Zoom In.

• On the Zoom toolbar, click the Zoom In tool.

• Type zoom and then press Enter.

2 Type the scale factor, followed by an x (such as 2x).

3 Press Enter.

Combining zooming and panning  
You can specify the point you want at the center of the view when you change the 
drawing magnification. You can specify the point you want at the lower left of the 
view when you change the magnification of the drawing with the Zoom Left tool 
( ) on the Zoom toolbar. With the exception of the Zoom Window tool, the other 
zoom tools zoom in or out from the center of the current view.        
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To change the center of the current view
1 Do one of the following to choose Zoom Center ( ):    

• On the ribbon, choose View > Zoom Center (in Navigate).

• On the menu, choose View > Zoom > Center.

• On the Zoom toolbar, click the Zoom Center tool.

• Type zoom, press Enter, and then in the prompt box, choose Center.

2 Select the point you want located at the center of the new view.

3 Specify the zoom scale factor or the height of the drawing in drawing units.

Displaying the entire drawing
There are two main ways you can zoom to display the entire drawing:

• Zoom all — Displays the entire drawing. If you have drawn any entities outside 
the defined limits of the drawing, the extents of the drawing are displayed. If all 
entities are within the limits of the drawing, the drawing is displayed all the way to 
the drawing limits.                 

• Zoom extents — Displays the drawing to include all entities (to its extents), mak-
ing the image fill the display to the greatest possible magnification.

To display the entire drawing
1 To display the entire drawing, do one of the following to choose Zoom All ( ):

• On the ribbon, choose View > Zoom All (in Navigate).

• On the menu, choose View > Zoom > All.

• On the Zoom toolbar, click the Zoom All tool.

Or, to display the drawing to its extents, do one of the following to choose Zoom 
Extents ( ):

• On the ribbon, choose View > Zoom Extents (in Navigate).

• On the menu, choose View > Zoom > Extents.

• On the Zoom toolbar, click the Zoom Extents tool.

Current view showing the point to be centered in the new view (A), and the new view zoomed using a scale 
factor of 2x.

A
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Changing the view of annotative entities

If your drawing contains annotative entities, such as text and dimensions, you can 
change the scale, or size, of these entities by setting the annotation scale.  

Entities that can be annotative include text, multiline text, tolerances, dimensions, 
leaders, multileaders, attributes, hatches, and blocks. If Annotative is set to Yes for 
one of these types of entities and you change the annotation scale, the entity will dis-
play at a different scale than other entities in the drawing. For example, if you set the 
annotation scale to 1:2, all annotative entities will display at that scale (if Automatic 
Annotation is turned on) or only those annotative entities that support the 1:2 scale 
will display at that scale (if Automatic Annotation is turned off). 

Text styles, dimension styles, and multileader styles also can be annotative, so text, 
dimensions, or multileaders assigned an annotative style can also be affected. 

Turning on scaling of annotative entities
Annotation scaling allows you to control certain entities so their size will consistently 
display when a drawing is displayed or printed at different scales. You don’t have to 
use annotation scaling, but it is a convenient way to control the scaling of the follow-
ing entities: text, tolerances, dimensions, leaders, multileaders, attributes, hatches, 
and blocks. 

Text styles, dimension styles, and multileader styles can also use annotation scaling. 
Text, dimension, and multileader entities that are assigned an annotative style will 
have annotation scaling turned on by default. For details about text styles, see “Work-
ing with text styles” on page 474. For details about dimensions styles, see “Using 
dimension styles and variables” on page 523.  IntelliCAD supports the display of 
multileaders and their styles, but not editing.)

Zoom extents (displays all entities). Zoom all (displays to drawing limits).
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To turn annotation scaling on or off for one or more entities 
1 Do one of the following to choose Properties ( ):

• On the ribbon, choose View > Properties (in Panes).

• On the menu, choose View > Display > Properties or Modify > Properties. 

• On the Modify toolbar, click the Properties tool.

• Type entprop and then press Enter.

• Press Ctrl +1.

The Properties pane displays.

2 Select the desired entities.

3 In Annotative, select one of the following:

• Yes Entities display according to the currently set annotation scale.

• No Entities are not affected by the currently set annotation scale. 

To assign a scale to all annotative entities automatically
1 On the status bar, turn on automatic annotation by double-clicking Automatic 

Annotation On/Off.

2 On the status bar, click Annotations Scales List.

3 Choose the annotation scale.

All annotative entities (all entities with Annotative set to Yes) will be assigned the 
selected annotation scale.

To add the current annotation scale to one more entities
1 Do one of the following to choose Add Current Scale ( ):

• On the ribbon, choose Annotate > Add Current Scale (in Annotation Scaling).

• On the menu, choose Modify > Annotative Scale > Add Current Scale.

• Type aiobjectscaleadd and then press Enter.

2 Select the desired entities.

To remove the current annotation scale from one more entities 
1 Do one of the following to choose Delete Current Scale ( ):

• On the ribbon, choose Annotate > Delete Current Scale (in Annotation Scaling).

• On the menu, choose Modify > Annotative Scale > Delete Current Scale.

• Type aiobjectscaleremove and then press Enter.

2 Select the desired entities.
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To add or remove annotation scales for one or more entities
1 Do one of the following to choose Add/Delete Scales ( ):

• On the ribbon, choose Annotate > Add/Delete Scales (in Annotation Scaling).

• On the menu, choose Modify > Annotative Scale > Add/Delete Scales.

• Type objectscale and then press Enter.

2 Select the desired entities.

The Annotation Scales dialog box displays a list of annotation scales that are 
assigned to the entities. 

3 Do one of the following:

• Click Add to select a scale and it to all selected entities.

• Select a scale and click Delete to remove it from all selected entities.

4 Click OK.
  

Changing the scale of annotative entities
The annotation scale of a drawing determines the size of annotative entities without 
changing the scale of other, non-annotative entities.

If automatic annotation is turned on, changing the annotation scale changes the scale, 
or size, of all entities that have annotation scaling turned on. If automatic annotation 
is turned off, the size is changed only for annotative entities that are assigned the 
selected annotation scale.

A Displays the annotation scales assigned to 
selected entities.

B Select whether to display all annotation scales 
assigned to selected entities or only those that 
are in common.

C Click to delete the selected annotation scale 
from selected entities.     

D Click to select an annotation scale to assign to 
selected entities.

B

C
A

D
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To set the annotation scale
1 On the status bar, click Annotations Scales List.

2 Choose the annotation scale.

All enabled annotative entities that have the selected scale assigned to them will 
display at the new scale.

To assign and set the scale automatically for all annotative entities
1 On the status bar, turn on automatic annotation by double-clicking Automatic 

Annotation On/Off.

2 On the status bar, click Annotations Scales List.

3 Choose the annotation scale.

All enabled annotative entities (all entities with Annotative set to Yes) will be 
assigned the selected annotation scale and display at that scale.

Use a system variable.
Automatic annotation can also be set using the ANNOAUTOSCALE system variable.

Displaying and hiding certain annotative entities
An annotative entity can be assigned numerous scales that are used for viewing and 
printing. By default, if an annotative entity is not assigned the current annotation 
scale, it still displays but at the default scale. Alternately, you can hide annotative 
entities that are not assigned the current annotation scale.

You can set the display status for the Model tab and for each Layout tab.

To display or hide annotative entities
1 Click the desired Model tab or Layout tab.

2 On the status bar, double-click Annotation Visibility On/Off.

Returning scale views of annotative entities to their default 
positions
Each scale view of an enabled annotative entity can be moved to different locations 
using grip editing. If various scale views of an annotative entity have been reposi-
tioned, you can easily return those scale views to their original basepoint.

To return scale views of annotative entities to their default positions
1 Do one of the following to choose Synchronize Multiple-Scale Positions ( ):

• On the ribbon, choose Annotate > Sync Scale Positions (in Annotation Scaling).

• On the menu, choose Modify > Annotative Scale > Synchronize Multiple-Scale 
Positions.    

• Type annoreset and then press Enter.

2 Select the desired entities.
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Displaying multiple windows

When you begin a new drawing, it is displayed in a single window. You can view the 
drawing in a second window, or you can divide one window into multiple windows. 
You can also open and display multiple drawings.          

Working with multiple windows of a single drawing
You can open and work with several views of the same drawing simultaneously. 
There are two methods for dividing the current drawing into multiple views:

• Open a new window of the open drawing.

• Divide the current window into multiple windows.

After you divide a single window into multiple windows, you can control each win-
dow separately. For example, you can zoom or pan in one window without affecting 
the display in any of the other windows. You can control the grid, snap, and view ori-
entation separately for each window. You can restore named views in individual win-
dows, draw from one window to another, and name window configurations 
individually so you can reuse them later.       

As you draw, any changes you make in one window are immediately visible in the 
others. You can switch from one window to another at any time, even in the middle of 
a command, by clicking the window’s title bar.

Opening a new window of the same drawing
You can open additional windows to create more than one view of a drawing. To 
open a new window, choose Window > New Window. After you open a new win-
dow, you can change its display without affecting any of the other windows.    

When you open more than one window for a single drawing, each window is assigned 
a unique number (for example, mydrawing:1, mydrawing:2, and so on). If your cur-
rent window is maximized, you can switch to another open window by selecting its 
name from the bottom of the Window menu.              

The names of other open drawings appear at the bottom of the Window menu. You 
can also use the Cascade, Tile Horizontally, and Tile Vertically commands to arrange 
all the open windows and drawings. To arrange all the windows and drawings into a 
stack of identically sized windows, choose Window > Cascade. Arranging windows 
and drawings in this way makes it easy to see the title bar for each window.       

To arrange all the windows and drawings horizontally so they are placed in order 
from top to bottom, choose Window > Tile Horizontally. Arranging windows and 
drawings in this way displays each open window. The windows are resized to fit 
within the available space.    

To arrange all the windows and drawings vertically so they are placed side by side, 
choose Window > Tile Vertically. Arranging windows and drawings in this way dis-
plays each open window. The windows are resized to fit within the available space.
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To manage all the windows from one dialog box, choose Window > Windows to 
open the Windows dialog box.

IntelliCAD uses the commands in the following table to control its windows.  

Dividing the current window into multiple windows
You can divide a single drawing window into multiple tiled windows (called view-
ports) on the Model tab. You can control the number of windows created and the 
arrangement of the windows. You can also save and restore named window configu-
rations and display a list of the current and saved window configurations.

While working in a viewport, use the Maximize Viewport command to enlarge the 
view to full size, allowing you to easily work on the geometry in that view. When 
done, use the Minimize Viewport command to switch back to the original scale and 
center point of the viewport.

To create multiple viewports   
1 Do one of the following to choose Viewports ( ):    

• On the ribbon, choose View > Viewports (in Viewports).

• On the menu, choose View > Viewports.

• On the View toolbar, click the Viewports tool.

• Type viewports and then press Enter.

2 In the prompt box, choose Create 2 Viewports, Create 3 Viewports, or Create 4 
Viewports.

3 In the prompt box, choose the viewport orientation.  

IntelliCAD window-control commands
Command Result
vports Splits the current window into two, three, or four tiled windows.

wcascade Cascades (overlaps) all open windows.

close Closes the current window.

closeall Closes all windows; also closes all drawings.

closeallother Closes all windows except the current drawing window.

wcloseall Closes all windows; also closes all drawings.

wiarrange Arranges window icons.

wopen Opens another window of the current drawing.

wvtile Tiles all windows vertically.
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Viewports can be resized.
Click and drag the border of a viewport to resize it.

To switch to a different viewport
1 Do one of the following:

• Click the edge of the viewport you want to make active.

• Press Ctrl+R to make the next viewport active.

To maximize the current viewport
1 Do one of the following:

• On the ribbon, choose View > Maximize Viewport (in Viewports).

• On the menu, choose View > Viewports > Maximize Viewport.

• On the status bar, click Maximize Viewport ( ).

• Type vpmax and then press Enter.

The viewport is enlarged.

You can divide a drawing window into two windows arranged vertically (A) or horizontally (B); three windows 
arranged left (C), right (D), above (E), below (F), vertically (G), or horizontally (H); or four tiled windows (I).

A B C

D E F

G H I



V I E W I N G  Y O U R  D R A W I N G 245
To minimize the current viewport (if it is maximized)
1 Do one of the following:

• On the ribbon, choose View > Minimize Viewport (in Viewports).

• On the menu, choose View > Viewports > Minimize Viewport.

• On the status bar, click Minimize Viewport ( ).

• Type vpmin and then press Enter.

The viewport returns to its original scale and center point.

Saving window configurations
If you have divided the drawing window into multiple views, you can save the current 
window arrangement so that you can recall it to the screen later. The number and 
placement of the windows are saved exactly as they are currently displayed. The set-
tings for each window are also saved.  

To name and save a window configuration        
1 Do one of the following to choose Viewports ( ):

• On the ribbon, choose View > Viewports (in Viewports).

• On the menu, choose View > Viewports.

• On the View toolbar, click the Viewports tool.

• Type viewports and then press Enter.

2 In the prompt box, choose Save.

3 Type a configuration name, and then press Enter.

The name can be up to 255 characters in length and can contain letters, numbers, 
the dollar sign ($), hyphen (-), and underscore (_), or any combination.      

To restore a named window configuration    
1 Do one of the following to choose Viewports ( ):

• On the ribbon, choose View > Viewports (in Viewports).

• On the menu, choose View > Viewports.

• On the View toolbar, click the Viewports tool.

• Type viewports and then press Enter.

2 In the prompt box, choose Restore.

3 Type the name of the window configuration you want to restore.
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Working with multiple drawings
With the multiple-document interface (MDI) feature, you can open more than one 
drawing inside of IntelliCAD. Because you can open and work on several drawings at 
one time, you can copy, cut, or paste an entity from one drawing to another.          

Each drawing appears in a drawing window, which has the following advantages:

• You can see two or more drawings side by side.

• You can easily copy entities from one drawing to another.

• Using IntelliCAD’s Explorer, you can copy such elements as layers, linetypes, and 
text styles from one drawing to another.

• Like viewports on the Model tab, you can tile or overlap drawing windows; unlike 
viewports on the Model tab, drawing windows maximize or reduce to an icon. 

Each drawing window that you open and work on retains in the Prompt History log 
all the commands that you perform, but the command line does not indicate when you 
have switched windows.

When you work with more than one drawing open in its own window, you can easily 
move, cut, copy, and paste in between drawings. If you move an entity from one win-
dow to another and then want to undo this action, you must undo it in both drawings 
for it to take effect. If you copy an entity from one window to another and then want 
to undo that action, you must undo it from the drawing into which you copied the 
entity. If you cut and paste an entity and then want to undo that action, you must undo 
it in both drawings.

One session of IntelliCAD with four drawings open.
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In the upper right corner of each window are buttons that help manage the display of 
open drawing windows. The buttons that are available depend on the state of the win-
dow. Minimize reduces a window to an icon, Restore expands a window to its normal 
size, Maximize expands and fills a window in the drawing area, and Close closes a 
drawing window. Each window can also be resized by dragging its edges and posi-
tioned by dragging its titlebar. 

IntelliCAD’s primary window type (or document type) is for .dwg drawings. The 
Start Page is another document type. You can customize IntelliCAD to display com-
mands according to the document type using the Visibility option of the Customize 
UI command. For details about how to set this option for menus, see “Setting proper-
ties of menu items” on page 874.  
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Controlling visual elements  

The number of entities in your drawing and the complexity of the drawing affect how 
quickly IntelliCAD can process commands and display your drawing. You can 
improve overall program performance by turning off the display of certain visual ele-
ments, such as solid fills and text, while you work on the drawing. When you are 
ready to print your drawing, turn on the display of these elements so your drawing 
prints the way you want.       

You can also improve performance by turning off entity-selection highlighting, turn-
ing off the display of marker blips created when you select locations in the drawing, 
and by turning off the display of lineweights.

Displaying solid fills
You can reduce the time it takes to display or print a drawing by turning off the dis-
play of solid fill. When solid fills are turned off, all filled entities, such as wide 
polylines and planes, display and print as outlines. When you turn solid fills on or off, 
you must redraw the drawing before the change is displayed.        

A check mark appears next to the Fill command  on the Settings menu when it is 
turned on. 

To turn the display of solid fills on or off
1 Do one of the following to choose Fill ( ):

• On the menu, choose View > Display > Fill.

• On the Settings toolbar, click the Fill tool.

• Type fill and then press Enter.

2 Choose View > Redraw.

  

Fill on. Fill off.
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Displaying quick text  
Text entities require a considerable amount of time to display and print. You can 
reduce the time it takes to display or print a drawing by enabling quick text. For 
example, if you’re doing a preliminary check print of a drawing, you may want to 
turn quick text on to speed up printing. When quick text is enabled, text entities are 
replaced by rectangular boxes that indicate the outline of the area occupied by the 
text. When you turn quick text on or off, you must regenerate the drawing before the 
change is displayed.          

To turn the display of quick text on and off
1 Do one of the following to choose Drawing Settings ( ):

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type qtext, press Enter, and then in the prompt box, choose On or Off.

2 Click the Display tab.

3 Click the secondary Display tab.

4 Select or clear the Enable Quick Text check box.

5 Click OK.

6 To regenerate your drawing, do one of the following to choose Regen ( ):

• On the ribbon, choose View > Regen.

• On the menu, choose View > Regen.

• On the View toolbar, click the Regen tool.

• Type regen and then press Enter.

Quick Text off. Quick Text on.
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Displaying highlighting
When you select entities to modify, the program can highlight them using a dashed 
line pattern or a glow effect. This highlight disappears when you finish modifying the 
entities or when the entities are cleared.

Sometimes highlighting entities can take a considerable amount of time, and you may 
want to improve overall program performance by turning highlighting off. 

To turn highlighting on and off
1 Do one of the following to choose Drawing Settings ( ):

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type highlight, press Enter, and then in the prompt box, choose On or Off.

2 Click the Display tab.

3 Click the secondary Display tab.

4 Choose from the following options:

• Highlight selected entities Displays selected entities highlighted in a dashed 
line. When unchecked, selected entities remain unchanged.

• Selection effect Displays selected entities with a glowing highlight instead of a 
dashed line. This option only applies if Highlight Selected Entities is turned on. 
The glowing highlight effect applies only when the graphics device is set to 
OpenGL ES.

5 Click OK.
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Displaying blips
You can turn blips off. They are the temporary markers that appear on the screen 
when you select an entity or location. Blips are visible only until you redraw the 
drawing. You cannot select blips; they are used only for reference and never print.

To turn the display of blips on and off
1 Do one of the following to choose Drawing Settings ( ):

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type blipmode, press Enter, and then in the prompt box, choose On or Off.

2 Click the Display tab.

3 Click the secondary Display tab.

4 Select or clear the Show Marker Blips check box.

5 Click OK.

Displaying lineweights
You can reduce the time it takes to display a drawing by turning off the display of lin-
eweights. When you turn off lineweights, all entities display as outlines. 

You can also specify a lineweight scale. Specify a smaller scale to display thinner 
lines; specify a larger scale to display thicker lines. For example, a scale factor of 0.5 
would display a .80 millimeter lineweight as .40 millimeter; a scale factor of 2 would 
increase the same lineweight to display at 1.6 millimeters. This can help you differen-
tiate various lineweights that display in a drawing. Adjusting the lineweight display 
scale affects how the lineweights appear on your screen, not how they appear when 
printed.  

Lineweight scale can affect performance.
Setting the lineweight scale too high may result in slower system performance.

You can also adjust the units for measuring lineweights, and the default lineweight.        

Blips on. Blips off.
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To control the display of lineweights
1 Do one of the following to choose Drawing Settings ( ):

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

• Type lweight and then press Enter.

2 Click the Display tab.

3 Click the Lineweights tab.

4 Select or clear Display Lineweights.

5 In Units for Listing, choose Millimeters or Inches.

6 In Default, select the lineweight assigned to layers and entities that use the Default 
lineweight.

7 In Adjust Display Scale, move the slider to the scale you want. By default, the 
slider begins at 1.00.

8 Click OK.

Use a shortcut.
To turn the display of lineweights on or off, use the LWDISPLAY system variable or 
double-click the word LWT on the status bar.

You can turn lineweights on or off when you print. For details, see “Specifying print 
options specifically for layouts” on page 640. 
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Working with coordinates

For accuracy in a drawing, you can locate specific points by entering coordinates as 
you draw or modify entities. When you create two-dimensional entities, you enter 
two-dimensional coordinates; for three-dimensional entities, you specify three-
dimensional coordinates.

You can also specify coordinates in relation to other known locations or entities in a 
drawing. In particular, when you work in three-dimensional drawings, it is often eas-
ier to specify coordinates in relation to a two-dimensional working plane, called a 
user coordinate system (UCS).

This section explains how to work with coordinates, including how to:

• Use two-dimensional and three-dimensional coordinate systems.

• Specify absolute and relative coordinates.

• Specify polar, spherical, and cylindrical coordinates.

• Define and manipulate user coordinate systems.

Topics in this chapter

Using Cartesian coordinates ............................................................................ 254

Using two-dimensional coordinates .................................................................. 257

Using three-dimensional coordinates ............................................................... 260

Using xyz point filters........................................................................................ 263

Defining user coordinate systems..................................................................... 265
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Using Cartesian coordinates 

Many commands in IntelliCAD require that you specify points as you draw or modify 
entities. You can do so by selecting points with the mouse or by typing coordinate 
values in the command bar. The program locates points in a drawing using a Carte-
sian coordinate system.

Understanding how coordinate systems work 
The Cartesian coordinate system uses three perpendicular axes — x, y, and z — to 
specify points in three-dimensional space. Every location in a drawing can be repre-
sented as a point relative to a 0,0,0 coordinate point, referred to as the origin. To draw 
a two-dimensional entity, you specify horizontal coordinate positions along the x-axis 
and vertical coordinate positions along the y-axis. Thus, every point on a plane can be 
represented as a coordinate pair composed of an x-coordinate and a y-coordinate. 
Positive coordinates are located above and to the right of the origin; negative coordi-
nates are located to the left and below the origin.        
    

When you work in two dimensions, you need enter only the x- and y-coordinates; the 
program assumes that the z-axis value is always the current elevation. When you 
work in three dimensions, however, you must also specify the z-axis value. When you 
look at a plan view of your drawing (a view from above, looking down), the z-axis 
extends straight up out of the screen at a 90-degree angle to the xy plane. Positive 
coordinates are located above the xy plane, and negative coordinates are below the 
plane.

The three perpendicular axes of the Cartesian coordinate system.
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All IntelliCAD drawings use a fixed coordinate system, called the World Coordinate 
System (WCS), and every point in a drawing has a specific x,y,z-coordinate in the 
WCS. You can also define arbitrary coordinate systems located anywhere in three-
dimensional space. These are called user coordinate systems and can be located any-
where in the WCS and oriented in any direction.          

You can create as many user coordinate systems as you want, saving or redefining 
them to help you construct three-dimensional entities. By defining a UCS within the 
WCS, you can simplify the creation of most three-dimensional entities into combina-
tions of two-dimensional entities.    

To help you keep your bearings in the current coordinate system, the program dis-
plays a coordinate system icon. When you begin a new drawing, you are automati-
cally in the WCS, indicated by the letter W in the icon. When you display a drawing 
in plan view, you see the coordinate system icon from the top, with the z-axis directed 
straight toward you. When you display a three-dimensional drawing in a view other 
than plan view, the coordinate system icon changes to reflect your new viewpoint.        

The visible portions of the axes are the positive directions.  
The invisible portions are the negative directions. 

   

The IntelliCAD UCS icon looks different from the UCS icon in AutoCAD, because it 
presents more information. Three colors represent the three axes, making it easier for 
you to recognize the orientation in three-dimensional space:

• x-axis: red

• y-axis: green

• z-axis: blue 

If you prefer a single color for the cursor and UCS icon, you can make that change 
with the config or options command.

WCS icon. Plan UCS icon. 3D View WCS icon.
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Changing how coordinates display
The current position of the cursor is displayed as x,y,z-coordinates in the status bar 
and, by default, updates dynamically as you move the cursor. There are several dis-
play modes to choose from in IntelliCAD:        

• Absolute for points — Updates the display with absolute coordinates only when 
you specify a point.

• Absolute continuos — Updates the display with absolute coordinates as you move 
the cursor and make selections. This is the default.

• Relative continuos — The same as absolute always when moving the cursor and 
making selections, with the addition of displaying relative distances and angles 
(rather than x,y,z-coordinates) when you have previously selected a point or entity 
and the program displays a rubber-band line. If no command is active, absolute 
coordinates display.         

• Geographic continuos — Updates the display with geographic coordinates as you 
move the cursor and make selections.

To change how coordinates display in the status bar
1 Do one of the following to choose Drawing Settings ( ):         

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Display tab.

Use a shortcut.
In the status bar, right-click Drawing Coordinates and choose Coordinate Set-
tings to open the Drawing Setting > Display tab.

3 Choose one of the following:

• Absolute coordinates update only when specifying points

• Absolute coordinates update continuously

• Relative polar coordinates update continuously

• Geographic coordinates update continuously

4 Click OK.

Use a shortcut.
On the status bar, click Drawing Coordinates to switch to the next display mode, or 
press Ctrl+I.
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Finding the coordinates of a point
To find the x,y,z-coordinates for a point on an entity, such as the endpoint of a line, 
select an appropriate entity snap (such as Endpoint) before selecting the entity. If you 
have no entity snaps set, the x,y-coordinates of the point you specified is displayed, 
with the z-coordinate equal to the current elevation.  

To find the coordinate of a point in the drawing
1 Do one of the following to choose ID Coordinates ( ): 

• On the ribbon, choose Tools > ID Coordinate (in Inquiry).

• On the menu, choose Tools > Inquiry > ID Coordinates.

• On the Inquiry toolbar, click the ID Coordinates tool.

• Type idpoint and then press Enter.

2 Select the point for which you want to find the coordinates.

If the command bar is activated, the x,y,z-coordinates for the point you selected 
display in the command bar.

If the command bar is not activated, the Prompt History window displays, show-
ing the x,y,z-coordinates for the point you selected.

Using two-dimensional coordinates

When working in two dimensions, you specify points on the xy plane. You can spec-
ify any point as an absolute coordinate (or Cartesian coordinate), using the exact x-
coordinate and y-coordinate locations in relation to the origin (the 0,0 coordinate 
point at which the two axes intersect), or as a relative coordinate in relation to the pre-
vious point. You can also specify points using relative or absolute polar coordinates, 
which locate a point using a distance and an angle. 

Entering absolute Cartesian coordinates
To enter absolute Cartesian coordinates, type the coordinate location of the point in 
the command bar. For example, to use absolute Cartesian coordinates to draw a line 
from the origin (0,0) to a point 3 units to the right and 1 unit above the origin, start the 
Line command and respond to the prompts as follows:     

Start of line: 0,0

Angle • Length • <Endpoint>: 3,1  
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When using absolute Cartesian coordinates, you need to know the exact point loca-
tions for anything you draw. For instance, to use absolute Cartesian coordinates to 
draw an 8.5-unit square with its lower left corner at 4,5, you must determine that the 
upper left corner is at coordinate 4,13.5, the upper right corner at 12.5,13.5, and the 
lower right corner at 12.5,5.

Entering relative Cartesian coordinates
Another, simpler method is to use relative Cartesian coordinates: you specify a 
location in the drawing by determining its position relative to the last coordinate you 
specified. To use relative Cartesian coordinates, type the coordinate values in the 
command bar, preceded by the at symbol (@). The coordinate pair following the @ 
symbol represents the distance along the x-axis and the y-axis to the next point. For 
example, to draw an 8.5-unit square with its lower left corner at 4,5 using relative 
Cartesian coordinates, start the Line command, and then respond to the prompts as 
follows:

Start of line: 4,5

Angle • Length • <Endpoint>: @8.5,0

Angle • Length • Follow • Undo • <Endpoint>: @0,8.5

Angle • Length • Follow • Close • Undo • <Endpoint>: @-8.5,0

Angle • Length • Follow • Close • Undo • <Endpoint>: C

Drawing a line using the absolute Cartesian coordinate method.

1

3Y

-Y

-X X

(3, 1)
(0, 0)
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The first relative coordinate (@8.5,0) locates the new point 8.5 units to the right 
(along the x-axis) from the previous point of 4,5; the second relative coordinate 
(@0,8.5) locates the next point 8.5 units above (along the y-axis) the previous point, 
and so on. Entering C (for Close) draws the final line segment back to the first point 
specified when you started the Line command.                      

Entering polar coordinates
Using relative polar coordinates makes drawing a square tilted at a 45-degree angle a 
simple task. Polar coordinates base the location of a point on a distance and angle 
from either the origin (absolute coordinate) or from the previous point (relative coor-
dinate).                                

To specify polar coordinates, type a distance and an angle, separated by the open 
angle bracket (<). For example, to use relative polar coordinates to specify a point 1 
unit away from the previous point and at an angle of 45 degrees, type @1<45.                

To draw the square from the example in the previous section, “Entering relative Car-
tesian coordinates,” this time tilted at a 45-degree angle, start the Line command, and 
then respond to the prompts as follows:     

Start of line: 4,5

Angle • Length • <Endpoint>: @8.5<45

Angle • Length • Follow • Undo • <Endpoint>: @8.5<315

Angle • Length • Follow • Close • Undo • <Endpoint>: @8.5<225

Angle • Length • Follow • Close • Undo • <Endpoint>: C 

Drawing a square using the relative Cartesian coordinates method; enter C to close.
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This example assumes the program’s default settings.
Like all examples in this guide, the example assumes default settings: Angles increase 
counterclockwise and decrease clockwise. An angle of 315 degrees is the same as -45 
degrees.

Using three-dimensional coordinates  

Specifying coordinates in three-dimensional space is similar to working in two 
dimensions, except that you also use the z-axis to locate coordinates. Three-dimen-
sional coordinates are represented in the format x,y,z (for example, 2,3,6).

Using the right-hand rule   
To visualize how IntelliCAD works with three-dimensional space, use a technique 
known as the right-hand rule. Hold up your right hand in a loose fist with your palm 
facing you. Extend your thumb in the direction of the positive x-axis and your index 
finger upward in the direction of the positive y-axis. Then extend your middle finger 
straight toward you in the direction of the z-axis. These three fingers are now pointing 
in the positive x, y, and z directions, respectively.       

You can also use the right-hand rule to determine the positive rotation direction. Point 
your thumb in the positive direction of the axis about which you want to rotate, and 
then curl the rest of your fingers toward your palm. These fingers are curling in the 
positive rotation direction.     

Drawing a tilted square using the relative polar coordinates method; enter C to close.
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Entering x,y,z-coordinates  
When working in three dimensions, you can specify x,y,z-coordinates as absolute dis-
tances in relation to the origin (the 0,0,0 coordinate point at which the three axes 
intersect) or as relative coordinates based on the last point selected. For example, to 
specify a point 3 units along the positive x-axis, 4 units along the positive y-axis, and 
2 units along the positive z-axis, specify the coordinate 3,4,2.    

Entering spherical coordinates
When working in three-dimensional space, you can use spherical coordinates to spec-
ify a three-dimensional point by entering its distance from either the origin (absolute 
distance) or the last point (relative distance), along with its angle in the xy plane and 
its angle up from the xy plane. In spherical format, you separate each angle with the 
open angle bracket (<).              

Thus, to draw a line from the origin to a point 10.2500 drawing units away, at an 
angle of 45 degrees from the x-axis and 35 degrees from the xy plane, start the Line 
command, and then respond to the prompts as follows:

Start of line: 0,0,0

Angle • Length • <Endpoint>: 10.2500<45<35 

The right-hand rule helps you determine the positive direction of the x-, y-, and z-axes and the 
positive rotation direction.

Y

Z

X
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Entering cylindrical coordinates  
When working in three-dimensional space, you can also use cylindrical coordinates 
to specify a three-dimensional point. You specify a point by entering its distance from 
either the origin (absolute distance) or the last point (relative distance), its angle in the 
xy plane, and its z-coordinate value.      

In cylindrical format, you separate the distance and angle with the open angle bracket 
(<) and separate the angle and z value with a comma. For example, to draw a line 
from the last point to a point 7.4750 units away, at an angle of 27 degrees from the x-
axis in the xy plane and 3 units up in the z direction, start the Line command, and then 
respond to the prompts as follows: 

Start of line: (select point A)

Angle • Length • <Endpoint>: @7.4750<27,3 

 

When you draw a line from a start point (A) to an endpoint (B) using spherical coordinates, you 
specify its length (C, in this case 10.2500 units), the angle in the xy plane (D, in this case 45 
degrees), and the angle from the xy plane (E, in this case 35 degrees).

When you draw a line from a start point (A) to an endpoint (B) using cylindrical coordinates, 
you specify its length (C, in this case 7.4750), the angle in the xy plane (D, in this case 27 
degrees), and the distance in the z direction (E, in this case 3 units).

A

Z
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Using xyz point filters  

Point filters provide a method of locating a point in a drawing relative to another 
point without specifying the entire coordinate. Using a point filter, you can enter par-
tial coordinates, and then the program prompts you for the remaining coordinate 
information. To use xyz point filters, respond to the prompt for a coordinate with a 
filter in the following form:         

.coordinate

where coordinate is one or more of the letters x, y, and z. The program then prompts 
you for the filtered coordinate(s). For example, if you type .xy, the program prompts 
you to select a point whose xy-coordinate you want, and then prompts you for the z-
coordinate. The filters .x, .y, .z, .xy, .xz, and .yz are all valid filters.

Using point filters in two dimensions
You can use point filters when you work in two dimensions to locate points in rela-
tion to existing entities. For example, to draw a circle centered in a rectangle, start the 
Circle command, and then respond to the prompts as follows:

2Point • 3Point • RadTanTan • Arc • Multiple • <Center of circle>: .y

Select Y of: mid

Snap to midpoint of: (select the left side of the rectangle)

Still need XZ of: mid

Snap to midpoint of: (select top of the rectangle)

Diameter • <Radius>: (specify radius of circle) 

  

You can use point filters to center the circle by separately selecting the midpoints of 
two sides of the rectangle (A and B) and then specifying its radius.

A

B
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Using point filters in three dimensions
You can use point filters when you work in three-dimensional space to locate points 
in two dimensions and then specify the z-coordinate as the elevation above the xy 
plane. For example, to begin drawing a line from a point with a z-coordinate 3 units 
above the center of a circle, insert the circle, and then start the Line command and 
respond to the prompts as follows:      

ENTER to use last point • Follow • <Start of line>: .xy

Select XY of: cen

Snap to centerpoint of: (select a point on the circle)

Still need Z of: 3 (locates the starting point 3 units above the center of 

the circle)

Length of line: (specify the length of the line) 

  

You can use point filters to draw a line by first selecting a point in the xy plane (A), 
specifying the z-coordinate (B), and then specifying the length of the line (C).

A

B

C
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Defining user coordinate systems  

A user coordinate system (UCS) is a Cartesian coordinate system with origins and 
orientation defined by the user.

Understanding user coordinate systems
When working in three-dimensional space, you can define a UCS with its own 0,0,0 
origin and orientation separate from the WCS. You can create as many user coordi-
nate systems as you want, and then save and recall them as you need them to simplify 
construction of three-dimensional entities.              

For example, you can create a separate UCS for each side of a building. Then, by 
switching to the UCS for the east side of the building, you can draw the windows on 
that side by specifying only their x- and y-coordinates. When you create one or more 
user coordinate systems, the coordinate entry is based on the current UCS. 
  

Defining a user coordinate system
To define a UCS, you can use any of the following methods:

• Specify a new origin and points on the positive x- and y-axes.

• Specify a new origin and point on the positive z-axis.

• Align the UCS with an existing entity.    

• Rotate the current UCS around any of its axes.    

• Align the UCS with its z-axis parallel to the current viewing direction.

• Align the UCS xy plane perpendicular to the current view.

When you define a new UCS, the UCS icon changes to indicate the origin and orien-
tation of the new UCS.

UCS aligned with the front wall of the house.
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To define a UCS by specifying a new origin and points on the positive x- and y-
axes    
1 Do one of the following to choose User Coordinate Systems ( ): 

• On the ribbon, choose Draw > User Coordinate Systems or choose View > User 
Coordinate Systems.

• On the menu, choose Tools > User Coordinate Systems > Select a Predefined 
UCS.

• On the UCS toolbar, click the Select a Predefined UCS tool.

• Type setucs and then press Enter.

2 In the User Coordinate Systems dialog box, click Explore UCSs.

3 In the Explorer, be sure that Coordinate Systems is selected, and click the New 
Item tool ( ).    

4 In the prompt box, choose 3 Point.

5 Select the new origin.

6 Select a point on the positive x-axis.

7 Select a point in the positive y direction.

8 In the Explorer - Coordinate Systems element, type the name for the new UCS, 
and then close the dialog box. 

 

Define the new UCS by selecting the origin (A), a point on the positive x-axis 
(B), and a point in the positive y direction (C).

A

B

C
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Using a preset user coordinate system
IntelliCAD lets you select a preset UCS. The six planes defined by looking along the 
x,y,z-axes align the UCS with the top, left, front, bottom, right, or back, based on 
either the WCS or the current UCS in effect when you select the tool. You can also 
select the previous UCS, align the UCS to the current view, or select the WCS.

When you select a UCS, the cursor orientation and UCS icon change to reflect the 
new UCS. The display does not change, however, unless you select the Change View 
To Plan View Of The Selected UCS check box.     

After you align the UCS to a preset UCS, you can use IntelliCAD’s Explorer to save 
the UCS. To do this, in the Explorer window, choose Edit > New > UCS, and then 
select Current.

To select a preset UCS 
1 Do one of the following to choose User Coordinate Systems ( ): 

• On the ribbon, choose Draw > User Coordinate Systems or choose 
View > User Coordinate Systems.

• On the menu, choose Tools > User Coordinate Systems > Select a Predefined 
UCS.

• On the UCS toolbar, click the Select a Predefined UCS tool.

• Type setucs and then press Enter.

2 Under Set The Selected UCS Relative To, select either Current UCS to change to 
the new UCS by reorienting relative to the current UCS or World Coordinate Sys-
tem (WCS) to base the new UCS orientation on the WCS.

3 Under Select UCS, click the button corresponding to the UCS you want as the new 
current UCS.  

Preset UCSs are also available with a dialog box.
Choose Format > User Coordinate Systems, then select a predefined UCS from the 
list. The preset UCSs are also available directly on the UCS toolbar.
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Working with the Explorer

IntelliCAD’s Explorer provides a powerful and convenient way to maintain and man-
age many settings of your drawings. You can use the Explorer to work with numerous 
elements within the current drawing or to copy this information between drawings. 
This section explains how to use the Explorer to:

• Organize information on layers, manage layers, and work with layer states.

• Create and use linetypes and multiline styles.

• Load text fonts and create text styles.

• Create and modify table styles.

• Work with named views, visual styles, and coordinate systems.

• Copy, cut, and paste dimension styles between drawings.

• Save, insert, and manage blocks, groups, and external references.

• Work with layouts and materials.

Topics in this chapter

Using the Explorer ............................................................................................ 270

Organizing information on layers................................................................275

Working with linetypes ...................................................................................... 306

Working with multiline styles............................................................................. 315

Working with text styles .................................................................................... 319

Working with table styles .................................................................................. 324

Working with dimension styles.......................................................................... 327

Working with multileader styles ........................................................................ 330

Working with named views ............................................................................... 333

Working with visual styles................................................................................. 338

Working with coordinate systems ..................................................................... 342

Working with blocks .......................................................................................... 345

Working with groups ..................................................................................353

Working with references to external files ....................................................355

Working with layouts ......................................................................................... 359

Working with materials...................................................................................... 362
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Using the Explorer 

IntelliCAD’s Explorer allows you to view, create, copy, and edit layers, layer states, 
linetypes, text styles, coordinate systems, blocks, dimension styles, and more within 
your drawings. You can also use the Explorer to copy these elements from one open 
drawing to another. The Explorer is a great way to manage and maintain your draw-
ings.

Displaying the Explorer
The Explorer opens in its own, separate pane or window, which you can move or 
resize. The Explorer has its own menu and tools.

To display the Explorer
Do one of the following to choose Explorer ( ):    

• On the ribbon, choose Tools > Explorer (in Explorer) or View > Explorer (in 
Panes).

• On the menu, choose View > Display > Explorer or Tools > Explorer > Explore 
Layers (or any other item).     

• On the Tools toolbar, click the Explorer tool.

• Type explorer and then press Enter.       

By default, the Explorer displays as a pane.
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You can click the Show as Pane tool to display the Explorer as a dialog box instead, 
which allows you to view the elements for each open drawing. The Explorer displays 
elements, such as layers, layer states, linetypes, etc., on the left and corresponding 
drawing settings on the right.   

A Click to close the Explorer pane.
B Click to turn auto-hide on or off for the pane. Available 

when the Explorer is an undocked pane.
C Click to choose the position and transparency of the 

pane. (Available when an undocked pane.)

D Lists the elements you can control. Double-click an 
item to open its pane.      

E Tools on the Explorer toolbar provide controls 
common to all elements.

C
B

D

EA
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Using the Explorer, you can create, delete, or modify any of the settings for the cur-
rently selected element for a given drawing. You can also copy the contents of any 
element from one drawing to another. The common tools and menu items in the 
Explorer provide the following functions:         

A Tools on the Explorer toolbar vary depending on the element.
B The Elements pane shows the name of every drawing currently open 

and lists the elements you can control in each drawing.      
C Click a setting to change it.

D The named settings for the selected element. Click a column title to 
sort by category. Click and drag a column title to change the column 
order. Right-click a column title to choose which columns display or to 
restore all column settings to the default settings.

E Other tools appear, depending on the Elements pane selection.

A
B

C

D
E

Common Explorer tools    
Tool Function

( ) New Item Creates a new layer, linetype, text style, coordinate system, view, block, 
external reference, or dimension style.

( ) Current Makes the selection current.

( ) Cut Cuts the selection to the Clipboard.

( ) Copy Copies the selection to the Clipboard.

( ) Paste Pastes the selection from the Clipboard into the appropriate list of a 
different drawing.

( ) Delete Deletes the selection from the list.

( ) Purge Eliminates unreferenced elements from your drawing file.
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Copying settings   
A particularly powerful feature of the Explorer is its capability of copying many of the 
settings — layers, linetypes, text styles, coordinate systems, views, blocks, or dimen-
sion styles — from one drawing to another. If you have more than one drawing open, 
the Explorer makes it easy to reuse information. For example, when you copy layers 
from one drawing to another, the layer names as well as their linetypes, colors, and 
other settings are also copied, but not the entities on those layers.    

To copy layers from one open drawing to another open drawing
1 Do one of the following to choose Explore Layers ( ):    

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 In the Elements pane, select the drawing from which you want to copy layers.

3 If necessary, click the plus (+) symbol to expand the Elements list for the drawing, 
and then click Layers.

4 In the Layers Settings In Drawing list (right pane), select the layers you want to 
copy.

5 Choose Edit > Copy, or click the Copy tool ( ).

6 In the Elements pane, select the drawing to which you want to copy the layers.

7 If necessary, click the plus (+) symbol to expand the Elements list for the drawing, 
and then click Layers.

8 Choose Edit > Paste, or click the Paste tool ( ).

( ) Regen Recalculates the display for the current window.

( ) On/Off Regen Turns on and off the display recalculation.

( ) Show as 
Dialog (or Show as 
Pane)

Displays the Explorer as a pane or a dialog box.

( ) Help Displays online help for the Explorer.

Common Explorer tools    
Tool Function
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Deleting settings   
You can use the Explorer to delete many of the items that appear in the Elements list. 
You can delete a layer, linetype, text style, coordinate system, view, block, or dimen-
sion style.     

Because you may have already created entities on a particular layer or using a partic-
ular linetype or text style, deleting one of these elements requires that you make cer-
tain choices from options the program presents. For example, if you attempt to delete 
a layer, the program prompts you to specify whether you want to move any entities 
from that layer to another layer. Every drawing has at least one layer, the default 
layer, named “0.” You cannot delete or rename this layer. Your drawing can also con-
tain an unlimited number of additional layers, each of which you assign a unique 
name.    

If you try to delete a linetype, the program prompts you to specify whether you want 
to convert all entities drawn using that linetype to a different linetype. If you attempt 
to delete a text style, the program prompts you to specify whether you want to convert 
all text entities created using that style to a different style.    

To delete a layer and relocate its entities to another layer
1 Do one of the following to choose Explore Layers ( ):     

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 From the Layer Name list, select the layer that you want to delete.

If that layer is the current layer, layer 0 automatically becomes the current layer.

3 Click the Delete tool ( ).

4 From the dialog box that displays, click the Change option and then select the 
layer to which you want to relocate entities.

Delete a layer and its entities.
In the command bar, type LAYDEL, then select an entity that is assigned the layer 
you want to delete. Using this method also deletes all entities assigned the layer.
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Purging elements    
From within the Explorer, you can eliminate unused blocks, layers, linetypes, text 
styles, dimension styles, or annotation scales from your drawing file. Purging unused 
elements can significantly reduce the drawing file size.

To purge an element
1 Do one of the following to choose Explorer ( ):

• On the ribbon, choose Tools > Explorer (in Explorer).

• On the menu, choose Tools > Explorer.

• On the Tools toolbar, click the Explorer tool.

• Type explayers and then press Enter.

2 Select the element from which you want to purge unreferenced elements.

3 Choose Edit > Purge, or click the Purge tool ( ). 

Organizing information on layers 

Understanding layers
Layers in IntelliCAD are like the transparent overlays you use in manual drafting. 
You use layers to organize different types of drawing information. In IntelliCAD, 
each entity in a drawing exists on a layer. When you draw an entity, it is created on 
the current layer.    

You can control the visibility of layers in individual viewports. When you turn a layer 
off, entities drawn on that layer are no longer visible, and they do not print. Although 
a layer may be invisible, you can still select it as the current layer, in which case new 
entities are also invisible until you turn the layer back on. Entities on invisible layers 
can also affect the display and printing of entities on other layers. For example, enti-
ties on invisible layers can hide other entities when you use the Hide command to 
remove hidden lines.    

You can also freeze and thaw layers, and control whether layers are frozen by default 
in newly created layout viewports. Entities drawn on frozen layers do not display, do 
not print, and do not regenerate. When you freeze a layer, its entities do not affect the 
display or printing of other entities. For example, entities on frozen layers do not hide 
other entities when you use the Hide command to remove hidden lines. In addition, 
you cannot draw on a frozen layer until you thaw it, and you cannot make a frozen 
layer current.     

You cannot freeze the current layer. If you attempt to freeze the current layer, a dia-
log box appears prompting you to specify a different layer. You also cannot freeze or 
thaw a viewport layer unless you are working in a Layout tab.
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You can lock or unlock layers. The entities on a locked layer are still visible and will 
print, but you cannot edit them. Locking a layer prevents you from accidentally mod-
ifying entities. You can also control whether entities on layers can be cut by section 
planes, which is helpful if you use section planes to visualize models.     

You can control whether entities on each layer are included or omitted when you 
print the drawing.

Each layer has its own properties, such as color, linetype, lineweight, transparency, 
print visibility, and more. For drawings that use named print styles, layers can also 
have their own print style. Entities you draw on a particular layer are displayed in the 
color, linetype, and lineweight associated with that layer unless you override these 
settings. You control all of the associated settings for layers using the Layers element 
in the Explorer. You can also access layer settings for entities using the Entity Proper-
ties toolbar.   

Some drawings contain large lists of layers, in which case you can search for layers 
by name, or you can organize layers into subsets using layer filters. Layer states are 
also useful for drawings that contain many layers. With layer states, you can assign 
properties to individual layers and save them in a layer state, then apply those settings 
at any time.

Displaying layer information in the Explorer

To display layer information
1 Do one of the following to choose Explore Layers ( ):       

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Tools toolbar, click the Explorer tool ( ).

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 If desired, view information for only certain layers by doing one of the following:

• On the toolbar, type the name of the desired layers, including wildcards, and 
press Enter. 

• In the list of layer filters, select All Used Layers to display only those layers that 
are used in the drawing.

• In the list of layer filters, select an existing group filter or properties filter. 

For details about filtering and searching layers, see “Filtering and finding layers” 
on page 279 in this chapter. 
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Creating and naming layers
You can create an unlimited number of layers in every drawing and use those layers 
for organizing information. When you create a new layer, it is initially assigned the 
color white (or black, depending on your system settings) and the linetype CONTIN-
UOUS. By default, a new layer is also visible. After you create and name a layer, you 
can change its color, linetype, visibility, and other properties.     

A Select to display all layers, all layers that are in use, or a filtered 
subset.

B Click to collapse or expand the display of layer filters.
C Lists named layers in the current drawing. The list contains all layers or 

a subset if viewing by filter or only used layers. A check mark indicates 
the current layer.

D Displays the color assigned to each layer.
E Indicates the linetype assigned to each layer.
F Indicates the visibility status of each layer.     
G Indicates the locked or unlocked status of each layer. 
H Indicates the frozen or thawed status of each layer for all viewports.

I Indicates the lineweight assigned to each layer.
J Indicates the transparency percentage assigned to each layer.
K Indicates the material assigned to each layer.
L Indicates the print style assigned to each layer.
M Indicates the print status of each layer.
N Indicates whether entities on each layer can be cut by section planes.
O Indicates whether each layer is frozen by default in newly created 

layout viewports.
P Click a column title to sort by category. Click and drag a column title to 

change the column order. Right-click a column title to choose which 
columns display or to restore all column settings to the default settings.

C E F G I J K LH MA B PD N O
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To create a new layer
1 Do one of the following to choose Explore Layers ( ):     

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Do one of the following:

• Choose Edit > New > Layer.

• Click the New Item tool ( ).

A new layer is added to the Layer Name list, with the default name NewLayer1.

3 Type a name for the new layer over the highlighted default name, and then press Enter.

4 To complete the command and return to your drawing, close the window.

To change a layer name in the current drawing
1 Do one of the following to choose Explore Layers ( ):     

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 In the Layer Name list, select the layer you want to rename.

3 Do one of the following:

• Choose Edit > Rename, type a new name, and then press Enter.

• Highlight the layer name you want to change, type a new name, and then press 
Enter.

• Right-click the layer name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter.

4 To complete the command and return to your drawing, close the window.    

The layer named “0” is reserved.  
You cannot rename it.
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Filtering and finding layers
Some drawings contain large lists of layers. To limit the layers that appear in the list, 
you can search layers by name (including wildcards) and you can also create layer fil-
ters. 

By default, there are two predefined filters. One displays all layers and the other dis-
plays all layers that are used in the drawing.

There are two types of layer filters that you can create:

• Properties filter — Includes layers according to properties that you specify. This 
filter is dynamic, that is, if a new layer meets the requirements for the property fil-
ter, it is automatically added to the filter.

• Group filter — Includes layers that you include in the group. This filter is static, 
that is, new layers are handled manually.

After you create a layer filter, you can turn all of its layers on or off, thaw or freeze 
the layers, and lock or unlock the layers. Layer filters can also be inverted, imported, 
and exported. 

Layer filters can affect several lists of layers.
In addition to the list of layers in the Explorer, layer filters can also be applied to the 
layer controls on the ribbon Home tab and Quick Access toolbar (if the ribbon is 
available in your program version), Layer Tools toolbar, and Entity Properties tool-
bar. Click Apply Layer Filter to Layer Control to change whether the current layer 
filter selected in the Explorer is applied to these layer lists.
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0 

A Displays the list of layer filters.
B Click to create a new layer property filter.
C Click to create a new layer group filter.
D Click to invert the currently selected layer filter.

E Click to display the Layer States Manager.
F Click to export the currently selected layer filter to an .lft file.
G Click to import a layer filter (.lft file).
H Type a search term, including wildcards, then press Enter to search 

layer names.

B D G HC E

A

F
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Searching layers by name

To search for layers by name
1 Do one of the following to choose Explore Layers ( ):

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 In the Explorer toolbar, type the search name, including the following wildcards:

• * Matches any character or series of characters.

• ? Matches a single character.

• # Matches any numerical character.

• @ Matches any alphabetic character.

• . Matches any character that is not alphabetic or numeric.

• [ ] Matches any of the characters inside the brackets.

• ~ Matches any characters except for those after the tilde.

• [~] Matches any of the characters except for those inside the brackets.

• [-] Matches a range of characters inside the brackets.

• ’ Matches the exact characters located  after the quote mark. This is most often 
used when searching for layer names that include wildcards, for example, 
@Floor or Field#.

3 To view all layers again in the list, delete the search term.

4 Click OK.
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Filtering layers by property
Layer property filters include layers according to properties that you specify. For 
example, a property filter can display all layers with a dashed linetype, then you can 
easily turn those layers on or off.

To create a properties filter
1 Do one of the following to choose Explore Layers ( ):

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Click the Properties Filter tool ( ) or press Alt + F.

Filters can be nested.
To create a sub-filter of an existing filter, right-click the existing filter and choose 
New Properties Filter or New Group Filter.

3 Type a name for the filter.

4 Do any of the following in Filter Definition:

• Click the column of an empty row to specify the property to match. All layers 
that match the specified properties of any row will be included.

• Click the column of an existing row to specify an additional property that a layer 
must match to be included in the filter. All layer properties in a single row must 
be matched for the layer to be included.

• Right-click a row and choose Delete Row to delete a row you no longer need.

• Right-click a row and choose Duplicate Row to make a copy of an existing row.

The filter preview displays the layers that will be included in the filter.

5 Click OK.

6 To complete the command and return to your drawing, close the window.
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To modify a properties filter
1 In the Explorer, select Layers, then do one of the following:

• To rename a properties filter, select it and type a new name.

• To delete a properties filter, select it and press Delete.

• To change the definition of a properties filter, double-click it.

• To change the list order of filters, drag and drop a properties filter to a new 
location in the list. To sort all filters in alphabetical order, right-click the top 
item, All, and choose Sort Filters.

Use a shortcut.
Right-click a properties filter to modify it.

A Type a name of the new layer properties filter.
B Click the column of an existing filter to specify an 

additional property that a layer must match to be 
included in the filter.

C Click the column of an empty row to select the 
property to match.

D Displays the layers that match the settings of the 
layer properties filter.

A

D

B
C
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To modify the layers in a properties filter
1 In the Explorer, select Layers.

2 To change the visibility of all layers in a properties filter, right-click the properties 
filter, choose Visibility, then choose one of the following: 

• On / Off

• Thaw / Freeze

• Isolate Freeze

These additional options are available if you’re working on a Layout tab:

• Current Viewport Thaw / Freeze

• Current Layout All Viewports Thaw / Freeze

• Isolate Viewport Freeze

3 To change the accessibility of all layers in a properties filter, right-click the prop-
erties filter, choose Lock, then choose one of the following: 

• Lock

• Unlock

Filtering layers by group
Layer group filters include any layer that you select for the group. For example, a 
group filter can display all layers that contain text entities, then you can freeze or 
thaw those layers as needed.

To create a group filter
1 Do one of the following to choose Explore Layers ( ):

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Click the Group Filter tool ( ) or press Alt + G.
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Filters can be nested.
To create a sub-filter of an existing filter, right-click the existing filter and choose 
New Properties Filter or New Group Filter.

3 Type a name for the new group filter, then press Enter.

4 To choose layers for the group filter, do one of the following:

• Right-click the group filter, choose Select Layers > Add, then select entities in 
your drawing that reside on layers to include in the group. Press Enter when 
done. Choose Select Layers > Replace if the group filter has existing layers that 
you want to remove before adding new layers.

• Double-click the group filter, then mark and unmark the desired layers.

5 Click OK.

6 To complete the command and return to your drawing, close the window.

Create a group filter by converting an existing property filter.
In the Explorer, view layer filters, right-click a property filter, and choose Convert to 
Group Filter.

 

A Click the circle green to include its layer in the 
layer group filter. Click again to exclude it.

B Displays layers in the drawing.
C Displays the layer description, if available.

A

CB
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To modify a group filter
1 In the Explorer, select Layers, then do one of the following:

• To rename a group filter, select it and type a new name.

• To delete a group filter, select it and press Delete.

• To change the layers included in a group filter, double-click it. 

• To change the list order of filters, drag and drop a group filter to a new location 
in the list. To sort all filters in alphabetical order, right-click the top item, All, 
and choose Sort Filters.

• To select new layers for the group filter directly in the drawing, right-click the 
group filter. Choose Select Layers > Add if you want to keep all existing layers 
in the group filter and select new ones to add directly in the drawing. Choose 
Select Layers > Replace if you want to remove all existing layers from the group 
filter and select new ones directly in the drawing. 

Use a shortcut.
Right-click a group filter to modify it.

To modify the layers in a group filter
1 In the Explorer, select Layers.

2 To change the visibility of all layers in a group filter, right-click the group filter, 
choose Visibility, then choose one of the following: 

• On / Off

• Thaw / Freeze

• Isolate Freeze

These additional options are available if you’re working on a Layout tab:

• Current Viewport Thaw / Freeze

• Current Layout All Viewports Thaw / Freeze

• Isolate Viewport Freeze

3 To change the accessibility of all layers in a group filter, right-click the group fil-
ter, choose Lock, then choose one of the following: 

• Lock

• Unlock
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Inverting layer filters
Layer filters can be inverted, for example, you can invert the All Used Layers filter to 
display a list of all layers that are unused in the drawing.

To invert a layer filter
1 Do one of the following to choose Explore Layers ( ):

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Select a layer filter.

3 Click the Invert Filter tool ( ).

4 To complete the command and return to your drawing, close the window.

The filter stays inverted until it’s turned off.
If the contents of a filter look incorrect, it could be because it is inverted.

Importing and exporting layer properties filters
Layer properties filters can be imported and exported as .lst files.

To import layer properties filters
1 Do one of the following to choose Explore Layers ( ):

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Click the Import Layer Filter tool ( ).

3 Navigate to where you want to save the layer filter, type a name, then click Save.

4 To complete the command and return to your drawing, close the window.
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To export layer properties filters
1 Do one of the following to choose Explore Layers ( ):

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Select the layer filter you want to export.

3 Click the Export Layer Filter tool ( ).

4 Locate the layer filter (.lft file) and select it.

5 Click Open.

6 To complete the command and return to your drawing, close the window.

Setting the current layer
When you create new entities, they are drawn on the current layer. To draw new enti-
ties on a different layer, you must first make that layer the current layer.   

To make a layer current 
1 Do one of the following to choose Explore Layers ( ):

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 In the Layer Name list, select the layer you want to make current.

3 Do one of the following:

• Choose Edit > Current.

• In the Layer Name list, select the name you want to make current, and then click 
the Current tool ( ).

• Double-click the layer name in the Layer Name list. 

• Right-click the layer name you want to change, and from the shortcut menu 
select Current. 

4 To complete the command and return to your drawing, close the window.
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To set the current layer to that of an existing entity
1 Do one of the following to choose Set Layer By Entity ( ):      

• On the ribbon, choose Home > Set Layer By Entity (in Layers).

• On the menu, choose Format > Layer Tools > Set Layer By Entity.

• On the Layer Tools toolbar, click the Set Layer By Entity tool.

• Type setlayer or laymcur and then press Enter.

2 Select the entity to set the current layer.    

Use the command bar.
In the command bar, type laybyent and choose Set, then select an entity that is 
assigned the layer you want to be current.

Controlling layer visibility   
A layer can be visible or invisible. Entities on invisible layers are not displayed and 
do not print. By controlling layer visibility, you can turn off unnecessary information, 
such as construction lines or notes. By changing layer visibility, you can put the same 
drawing to multiple uses.    

For example, if you are drawing a floor plan, you can draw the layout of light fixtures 
on one layer and the location of plumbing lines on another. By selectively turning 
layers on and off, you can print the electrical engineering drawings and the plumbing 
drawings from the same drawing file. For even more convenience, you can control 
the visibility of layers within individual viewports, so that layers that display in one 
viewport are invisible in other viewports in the same drawing.

When you turn a layer off, entities drawn on that layer are no longer visible. When 
you turn the layer back on, the entities on that layer are redisplayed.

To turn layers on or off
1 Do one of the following to choose Explore Layers ( ):     

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Click the On/Off column for the layer you want to turn on or off.

3 To complete the command and return to your drawing, close the window.
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Select an entity that is assigned to the layer you want to turn off.
In the command bar, type laybyent and choose Off or type layoff, then select an entity 
that is assigned the layer you want to turn off.

Use a shortcut to turn on all layers.
Choose Format > Layer Tools > Turn All Layers On or type layon in the command 
bar to turn on all layers in a drawing.

To control the visibility of external reference layers and save any changes made to 
them in the current drawing, turn on xref visibility.

To turn on xref layer visibility
1 Do one of the following to choose Explore Layers ( ):    

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter

2 Choose View > Records from Xref Visibility.

Use the system variable. 
You can also turn on xref layer visibility by typing visretain to access the system vari-
able.

You can also freeze layers to improve the performance of operations such as zooming 
and panning or producing hidden lines or shaded images. When a layer is frozen, 
entities drawn on that layer are no longer visible.    
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To freeze or thaw layers
1 Do one of the following to choose Explore Layers ( ):    

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Click the Freeze/Thaw column for the layer you want to freeze or thaw.

3 To complete the command and return to your drawing, close the window.

Select an entity that is assigned to the layer you want to freeze.
In the command bar, type laybyent and choose Freeze or type layfrz, then select an 
entity that is assigned the layer you want to freeze.

Use a shortcut to thaw all layers.
Choose the Thaw All Layers command (type laythw) to thaw all layers in a drawing.

To freeze layers automatically when new layout viewports are created
1 Do one of the following to choose Explore Layers ( ):    

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Click the New VP Freeze column for the layer you want to freeze automatically in 
new layout viewports that you create.

3 To complete the command and return to your drawing, close the window.

Select entities that are assigned layers you want to freeze in existing layout viewports.
In the command bar, type layvpi to freeze layers of selected entities in all layout view-
ports except the current viewport.
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Locking and unlocking layers 
Locking a layer makes it easy to refer to information contained on the layer, but pre-
vents you from accidentally modifying its entities. When a layer is locked (but visible 
and thawed), its entities remain visible, but you cannot edit them. If you lock the cur-
rent layer, you can still add new entities to it. Unlocking a layer restores full editing 
capabilities.    

To lock or unlock layers
1 Do one of the following to choose Explore Layers ( ):

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Click the Lock/Unlock column for the layer you want to lock or unlock.

3 To complete the command and return to your drawing, close the window.

Select an entity that is assigned to the layer you want to lock or unlock.
In the command bar, type laybyent and choose Lock or Unlock or type laylck or 
layulk, then select an entity that is assigned the layer you want to lock or unlock.

To specify how faded entities on locked layers display
1 Do one of the following ( ):

• On the ribbon, choose Home > Locked Layer Fade Control (in Layers).

• Type laylockfadectl and then press Enter.

2 Specify the fade percentage to apply when displaying entities on locked layers.

The fade percentage can also be specified using the Options command.
Choose Options, and on the Display tab, click Fade Control. For more details, see 
“Setting the main window options” on page 837. 
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Controlling layer printing   
Controlling layer printing is another way you can specify which entities print in your 
drawing. 

By controlling layer printing, you can turn off unnecessary information during print-
ing. For example, if you are drawing a floor plan, you can draw the layout of light fix-
tures on one layer and the location of plumbing lines on another. By selectively 
turning layers on and off when you print, you can print the electrical engineering 
drawings and the plumbing drawings from the same drawing file. By changing layer 
printing, you can put the same drawing to multiple uses.    

When you turn off printing for a layer, entities drawn on that layer are still visible, but 
they do not print. If you turn off a layer’s visibility, entities drawn on that layer do not 
display or print. Controlling layer printing can be especially helpful if you want layer 
visibility on, but do not want to print entities on that layer. 

Layer visibility must be turned on in order to print entities drawn on that layer.

To turn layer printing on or off
1 Do one of the following to choose Explore Layers ( ):     

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Click the Print column for the layer you want to turn printing on or off for. 
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Controlling whether a layer is sectionable   
If you use section planes to visualize a model, you can also determine whether enti-
ties on a layer are affected by the section planes you draw. This helps you control 
which entities can be cut by section planes. For more details about section planes, see 
“Using a section plane to view a drawing” on page 701. 

To control whether a layer is sectionable
1 Do one of the following to choose Explore Layers ( ):

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Click the Sectionable column for the layer you want to include or exclude from 
cutting by section planes.

3 To complete the command and return to your drawing, close the window.

Setting the layer color   
Each layer in a drawing is assigned a color. IntelliCAD uses the BYLAYER color as 
the default color setting for entity creation so that new entities are drawn in the color 
of the layer on which they are inserted (set in the Drawing Settings dialog box).    

Using the Explorer, you can set or change the color assigned to a layer. With the 
direct-editing feature, you can click on the color you want to change, and then select a 
new color from the dialog box that appears. Changing a layer’s color automatically 
changes the color of all entities on that layer with the BYLAYER color.
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To change the layer color
1 Do one of the following to choose Explore Layers ( ):     

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Click the Color column for the layer you want to change.

3 In the Color dialog box, select a color on one of the following tabs:

• Index Color — Click BYBLOCK, BYLAYER, or one of the 255 index colors. 
You can also type the color number in the Index box.

• True Color — Click a basic color, click a color in the color palette, enter the Hue, 
Saturation, and Luminance (HSL) values, or enter the Red, Green, Blue (RGB) 
values. There are more than 16 million true colors from which you can choose.

• Color Books — Select a color book from the list, then click a color. You can 
select Show Only Color Book Colors Used in Drawing to limit the selection to 
only those color book colors that are used in the current drawing. If necessary, 
create or edit color books by clicking Color Book Editor. For more details, see 
“Using color books” on page 74. 

4 Click OK. 

Entities don’t have to use the layer’s color. 
You can assign a specific color to an entity, which overrides the layer’s color setting. 
When you create a new entity, use the Format > Colors > Select Color command to 
change the current color. For an existing entity, select the entity, right-click for the 
shortcut menu, and choose Properties to change the entity’s color using the Proper-
ties pane.        

For more details about using color in the many aspects of your drawing, see “Work-
ing with colors” on page 71. 

Setting the layer linetype    
Each layer uses a default linetype (a repeating pattern of dashes, dots, or blank spaces). 
Linetype determines the appearance of entities both on the screen and when printed.    

It’s a good idea to assign the BYLAYER linetype to any entities that you draw on that 
layer. IntelliCAD uses the BYLAYER linetype as the default linetype setting for 
Entity Creation (in the Drawing Settings dialog box).
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Using the Explorer, you can set or change the linetype assigned to a layer. With the 
direct-editing feature, you can click on the linetype you want to change, and then 
select a new linetype from the dialog box that appears. Changing the linetype 
assigned to a layer changes the linetype of all entities drawn on that layer with the 
BYLAYER linetype.

Only those linetypes already set in the drawing can be assigned to layers. For more 
information about setting additional linetypes, see “Working with linetypes” on page 
306 in this chapter. 

To change the linetype assigned to one or more layers
1 Do one of the following to choose Explore Layers ( ):    

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Click the Linetype column for the layer you want to change.

3 In the Linetype dialog box, select a new linetype for the layer, or click Browse to 
select your linetype file.

Entities don’t have to use the layer’s linetype.
You can also assign a specific linetype to an entity, which overrides the layer’s line-
type setting. When you create a new entity, use the Tools > Explorer > Explore Line-
types command to change the current linetype through the Explorer. For an existing 
entity, select the entity, right-click for the shortcut menu, and choose Properties. You 
can then modify the entity’s linetype using the Properties pane.    
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Setting the layer lineweight 
Each layer uses a default lineweight. Lineweights determine the thickness of entities 
both on the screen and when printed.              

All new layers are assigned the DEFAULT lineweight, which is .25 millimeters or 
.01 inches. If you want a different lineweight assigned to a layer, you can easily 
change it using the Explorer. For example, you may want different lineweights on 
each layer of your drawing to show separate elements, such as walls, dimensions, 
structural steel, and electrical plans. Changing the lineweight assigned to a layer 
changes the lineweight of all entities drawn on that layer with the BYLAYER line-
weight.

When you create new entities, it’s a good idea to assign the BYLAYER lineweight to 
any entities that you draw on that layer, unless you want to override the layer line-
weight. IntelliCAD uses the BYLAYER lineweight as the default lineweight setting 
when you create entities (in the Drawing Settings dialog box). 

You can change the default lineweight.
To change the DEFAULT lineweight, choose Tools > Drawing Settings, click the 
Display tab, click the Lineweights tab, and then select a new default.

To change the lineweight assigned to one or more layers
1 Do one of the following to choose Explore Layers ( ):    

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Click the Lineweight column for the layer you want to change.

3 In the Lineweight list, select a new lineweight for the layer, then click OK.

Entities don’t have to use the layer’s lineweight.
You can assign a specific lineweight to an entity, which overrides the layer’s line-
weight setting. When you create a new entity, use the Tools > Drawing Settings > 
Entity Creation tab to change the current lineweight. For an existing entity, select the 
entity, right-click for the shortcut menu, and choose Properties. You can then modify 
the entity’s lineweight using the Properties pane.     
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Setting the layer transparency 
Each layer uses a transparency value from 0 to 90, where zero is no transparency (reg-
ular visibility) and 90 is the most transparency (almost invisible).

By default, each layer is assigned zero transparency. If you want a different transpar-
ency assigned to a layer, you can easily change it using the Explorer. 

To change the transparency assigned to one or more layers
1 Do one of the following to choose Explore Layers ( ):    

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Click the Transparency column for the layer you want to change.

3 Enter a new value for the transparency, then press Enter.

Setting the layer material 
Each layer can be assigned a material. By default, each layer is assigned the Global 
material. If you want a different material assigned to a layer, you can easily change it 
using the Explorer. 

To change the material assigned to one or more layers
1 Do one of the following to choose Explore Layers ( ):    

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Click the Material column for the layer you want to change.

3 In the Material list, select a new material for the layer.
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Setting the layer print style 

If your drawing uses named print style tables, you can specify a print style for each 
layer. Named print style tables contain print styles that you set up to control what enti-
ties look like when they print, without actually changing the entities in the drawing.

If your drawing uses color-dependent print style tables, you cannot specify a print 
style for a layer. These types of print style tables automatically determine printing 
requirements by the color assigned to a layer or an entity. For details about converting 
a drawing that uses color-dependent print style table to use named print style tables, 
see “Changing the print style table type of a drawing” on page 657. 

In drawings that use named print style tables, the default print style is Normal for all 
new layers. If desired, you can assign a print style using the Explorer. Changing the 
print style assigned to a layer changes the print style of all entities drawn on that layer 
with the BYLAYER print style.

When you create new entities, it’s a good idea to assign the BYLAYER print style to 
any entities that you draw on that layer, unless you want to override the layer print 
style. IntelliCAD uses the BYLAYER print style as the default print style setting 
when you create entities (in the Drawing Settings dialog box).

To change the print style assigned to one or more layers (only in a drawing that 
uses named print style tables)
1 Do one of the following to choose Explore Layers ( ):    

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Click the Print Style column for the layer you want to change.

3 If necessary, select a different print style table in the Active Print Style Table list.

4 In Print Styles, select a print style.

5 Click OK. 

Entities don’t have to use layer’s print style. 
For drawings that use named print style tables, you can also assign a specific print 
style to an entity, which overrides the layer’s print style setting. When you create a 
new entity, use the Tools > Drawing Settings > Entity Creation tab to change the cur-
rent print style. For an existing entity, select the entity, right-click for the shortcut 
menu, and choose Properties. You can then modify the entity’s print style using the 
Properties pane.    
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Undoing changes made to layers
Changes made to layer settings can be reversed. For example, you can reverse 
changes made to a layer’s color, transparency, freeze/thaw state, etc.

Some changes cannot be reversed. You cannot restore the original name of a layer if 
it was renamed, restore a layer if it was deleted or purged, or remove a layer if it was 
added.

To undo changes made to layers
1 Do one of the following to choose Layer Previous ( ):    

• On the ribbon, choose Home > Layer Previous (in Layers).

• On the menu, choose Format > Layer Tools > Layer Previous.

• On the Layers toolbar, click the Layer Previous tool.

• Type layerp and then press Enter.

2 Repeat the command to undo a set of changes one-by-one. 

Working with layer states
Layer states are collections of individual layers and their properties. You can restore 
layer states at any time, which makes it easy to switch between layer configurations 
according to your tasks. Additionally, you can specify whether to restore a layer state 
to the current viewport, all viewports, all layouts and viewports, or the Model tab.

Layer states can also be imported and exported. For example, to quickly create all the 
layers you need in a new drawing, create and export a layer state from an existing 
drawing that has the layers you need, and then import the layer state to the new draw-
ing. 

Layer states are saved in the drawing, including drawing templates and exported or 
imported drawings.

For each layer included in a layer state, you can set the following properties:

• Color

• Linetype

• On/Off

• Lock/Unlock

• Freeze/Thaw

• Lineweight

• Transparency

• Print

• New Viewports
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Displaying layer states in the Layer States Manager

To display the Layer States Manager
1 Do one of the following to choose Layer State Manager ( ):

• On the ribbon, choose Home > Layer States Manager (in Layers).

• On the menu, choose Format > Layer State Manager or choose 
Format > Explore Layers, then click the Layer States Manager tool.

• On the Format or Layers toolbar, click the Layer States Manager tool.

• Type layerstate and then press Enter.

A Displays layer states.
B Click to hide layer states located in externally 

referenced drawings.
C Click to turn off drawing layers that are not in the 

selected layer state when it is restored.
D Click to apply layer properties as overrides in the current 

viewport when the selected layer state is restored.
E Click to freeze drawing layers in the current viewport 

that are not in the selected layer state when it is 
restored.

F Select whether to restore the layer state to the current 
viewport, all viewports, all layouts and viewports, or the 
Model tab. If the Model tab is active, you can only 
restore the layer state to the current viewport.

G Click to export the selected layer state to an .las file.
H Click to import a layer state (.las file).
I Click to mark all checkboxes.
J Click to remove marks from all checkboxes.
K Select which properties to restore for the selected layer 

state.
L Click to create a new layer state.
M Click to modify the settings of the selected layer state.
N Click to copy current layer settings from the drawing to 

the selected layer state.
O Click to change the name or description of the selected 

layer state.
P Click to delete the selected layer state.

A

C

K

E I

J

B

F

O N M L

GH

D

P
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Creating layer states 
Creating a layer state saves the current layer settings so you can restore them at a later 
time, modify them, and even import and export them for use in other drawings.  

To create a layer state
1 Create all of the layers that you want to be in the layer state.

Although you can modify the layer state later, first you should set up your drawing 
with its layers and properties so when you create the layer state, it captures all of 
the settings. If you don’t want to lose your current layer settings, simply save them 
as a layer state that you can restore later.

2 Do one of the following to choose Save Layer State ( ):

• On the ribbon, choose Home > Save Layer State (in Layers).

• On the menu, choose Format > Layer Tools > Save Layer State.

• On the Layer Tools toolbar, click the Save Layer State tool.

• Type layerstatesave and then press Enter.

3 Enter a name and description, then click OK.

To create a layer state using Layer State Manager
1 Create all of the layers that you want to be in the layer state. 

Although you can modify the layer state later, first you should set up your drawing 
with its layers and properties so when you create the layer state, it captures all of 
the settings. If you don’t want to lose your current layer settings, simply save them 
as a layer state that you can restore later.

2 Do one of the following to choose Layer States Manager ( ):

• On the ribbon, choose Home > Layer States Manager (in Layers).

• On the menu, choose Format > Layer State Manager or choose Format > 
Explore Layers, then click the Layer States Manager tool.

• On the Format or Layers toolbar, click the Layer States Manager tool.

• Type layerstate and then press Enter.

3 Click New.

4 Enter a name and description, then click OK.

5 Click Edit and do any of the following:

• Click any column for any layer to change its setting. The new setting applies 
only when this layer state is applied (restored).

• Click the Add Layer tool and select a layer to add to the layer state.

• Select a layer and click the Delete Layer tool to remove a layer from the layer 
state.

6 Click OK.

7 Click Close.
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A Displays the layers included in the layer state. 
Click to select a layer.

B Click to add a layer to the layer state.
C Click to delete the selected layer from the layer 

state.
D Click to change a layer’s color for this layer 

state only.
E Click to change a layer’s linetype for this layer 

state only.
F Click to toggle a layer’s on/off status for this 

layer state only.
G Click to toggle a layer’s lock/unlock status for 

this layer state only.

H Click to toggle a layer’s freeze/thaw status for 
this layer state only.

I Click to change a layer’s lineweight for this 
layer state only.

J Click to change a layer’s transparency for this 
layer state only.

K Click to change a layer’s print style for this 
layer state only.

L Click to change a layer’s print status for this 
layer state only.

M Click to change a layer’s visibility in new 
viewports for this layer state only.

N Click a column title to sort by category.

A

D F G

N

E H IB C J K L M
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Applying a layer state

To apply the settings of a layer state
1 Do one of the following to choose Layer State Manager ( ):    

• On the ribbon, choose Home > Layer States Manager (in Layers).

• On the menu, choose Format > Layer State Manager or choose
Format > Explore Layers, then click the Layer States Manager tool.

• On the Format or Layers toolbar, click the Layer States Manager tool.

• Type layerstate and then press Enter.

2 Select the layer state to apply.

3 Layer states by design don’t always contain all layers of a drawing. Make selec-
tions for the following:

• Layers not found in state are turned off — After the layer state is applied, the only 
layers that will be turned on are those that are included in the layer state. If 
unmarked, the on/off status of unmatched layers is not changed.

• Layers not found in state are frozen in current viewport — After the layer state is 
applied, the only layers that will be thawed in the current viewport are those that 
are included in the layer state. If unmarked, the freeze/thaw statuses of 
unmatched layers are not changed.

4 To apply layer properties as overrides in the current viewport, mark Apply Proper-
ties as Viewport Overrides.

5 In Restore Layer State To, select whether to restore the layer state to the current 
viewport, all viewports, all layouts and viewports, or the Model tab. If the Model 
tab is active, you can only restore the layer state to the current viewport.

6 In Layer Properties to Restore, mark which properties of all layers included in the 
layer state to apply. If a property is not marked, that property will not be applied 
for matching layers. 

7 Click Restore.
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Displaying layer states in the Explorer

To display layer states
Do one of the following or choose Explore Layer States ( ): 

• On the ribbon, choose Tools > Layer States (in Explorer).

• On the menu, choose Tools > Explorer > Explore Layer States.

• On the Explorer toolbar, click the Explore Layer States tool.

• Type explayerstates and then press Enter.

• Choose Tools > Explorer, and then click the Layer States element.

Importing and exporting layer states from files 
Layer states can be imported and exported as .las files. Exporting layer states from 
one drawing and importing them in a new drawing is a quick way to create all the 
new layers you need for the new drawing.

To import a layer state from a file
1 Do one of the following to choose Layer States Manager ( ):

• On the ribbon, choose Home > Layer States Manager (in Layers).

• On the menu, choose Format > Layer State Manager or choose Format > 
Explore Layers, then click the Layer States Manager tool.

• On the Format or Layers toolbar, click the Layer States Manager tool.

• Type layerstate and then press Enter.

2 Click Open.

3 Select the .las file to import.

4 Click Import.

To export a layer state to a file
1 Do one of the following to choose Layer State Manager ( ):

• On the ribbon, choose Home > Layer States Manager (in Layers).

• On the menu, choose Format > Layer State Manager or choose Format > 
Explore Layers, then click the Layer States Manager tool.

• On the Format or Layers toolbar, click the Layer States Manager tool.

• Type layerstate and then press Enter.

2 Select the layer state to export. 

3 Click Export.

4 Enter a name for the .las file.

5 Click OK.
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Working with linetypes 

Linetypes are sequences of alternating line segments, dots, and blank spaces that 
affect the appearance of a line.

Understanding linetypes
IntelliCAD provides simple and complex linetypes:

• A simple linetype consists of a repeating pattern of dots, dashes, or blank spaces.

• A complex linetype contains embedded shape and text entities along with
dots, dashes, and spaces.

You can use different linetypes to represent specific kinds of information. For exam-
ple, if you are drawing a site plan, you can draw roads using a continuous linetype, a 
fence using a using a linetype of dashes with square posts, or a gas line using a com-
plex linetype showing the text “GAS”.

By default, every drawing has at least three linetypes: CONTINUOUS, BYLAYER, 
and BYBLOCK. You cannot rename or delete these linetypes. Your drawing may 
also contain an unlimited number of additional linetypes. You can load more line-
types into the program from a linetype library file or create and save linetypes you 
define. 
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Displaying linetype information in the Explorer

To display the Explorer Linetypes element
Do one of the following to choose Explore Linetypes ( ):    

• On the ribbon, choose Tools > Linetypes (in Explorer).

• On the menu, choose Tools > Explorer > Explore Linetypes.

• On the Explorer toolbar, click the Explore Linetypes tool.

• Type expltypes and then press Enter.

Setting the current linetype
You normally draw an entity using the linetype assigned to the current layer, indi-
cated as BYLAYER. You can also assign linetypes on a per-entity basis, which over-
rides the layer’s linetype setting. A third option is to assign the BYBLOCK linetype, 
whereby you draw new entities using the default linetype until you group them into a 
block. The entities inherit the current linetype setting when you insert the block into 
the drawing.    

A Lists names of linetypes loaded in the current 
drawing. A check mark indicates the current 
linetype.

B Describes linetypes loaded in the current drawing.
C Shows how linetypes will appear in the drawing.

D Click a column title to sort by category. Click and 
drag a column title to change the column order. 
Right-click a column title to choose which columns 
display or to restore all column settings to the 
default settings.

A B C

D
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To make a linetype current
1 Do one of the following to choose Explore Linetypes ( ):    

• On the ribbon, choose Tools > Linetypes (in Explorer).

• On the menu, choose Tools > Explorer > Explore Linetypes.

• On the Explorer toolbar, click the Explore Linetypes tool.

• Type expltypes and then press Enter.

2 In the Linetype Name list, select the linetype you want to make current.

3 Do one of the following:

• Choose Edit > Current.

• Select it in the Linetype Name list and click the Current tool ( ).

• Double-click the linetype name.

4 To complete the command and return to your drawing, close the window.

Use the status bar.
On the status bar, right-click on the word BYLAYER for the current linetype, click 
Properties, and then choose the linetype that you want to make current.

Loading additional linetypes 
Before you can select a new linetype to use in a drawing, you must either create the 
linetype definition or load a predefined linetype from a linetype library file (*.lin). 
IntelliCAD includes a linetype library file, icad.lin, which contains more than 100 
predefined linetypes.    

To load a new linetype from a linetype library
1 Do one of the following to choose Explore Linetypes ( ):    

• On the ribbon, choose Tools > Linetypes (in Explorer).

• On the menu, choose Tools > Explorer > Explore Linetypes.

• On the Explorer toolbar, click the Explore Linetypes tool.

• Type expltypes and then press Enter.

2 Using one of the following methods, open the New Linetype dialog box:

• Choose Edit > New > Linetype.

• Click the New Item tool ( ).

• With the cursor in the right side of the window, right-click to display the 
shortcut menu, and then choose New > Linetype.
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3 Select the linetype to load.

4 If necessary, click Browse to choose a different linetype library file that contains 
the linetype definitions you want to load.

5 Click OK.
 

Creating and naming linetypes 
In addition to loading predefined linetypes from a linetype library file, you can create 
new linetypes. You can save new linetypes you create to a linetype library file for use 
in other drawings.   

Creating a new simple linetype

To create a new simple linetype   
1 Do one of the following to choose Explore Linetypes ( ):    

• On the ribbon, choose Tools > Linetypes (in Explorer).

• On the menu, choose Tools > Explorer > Explore Linetypes.

• On the Explorer toolbar, click the Explore Linetypes tool.

• Type expltypes and then press Enter.

A Displays the name of the current linetype library 
file that contains the linetype definitions from 
which you can choose.

B Click to select and load a linetype.
C Click to create a new linetype definition for the 

current linetype library file.

D Click a column title to sort by category.
E Click to open a different linetype library file that 

contains the linetypes you want to choose.

D

B

EA

C
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2 Using one of the following methods, open the New Linetype dialog box:

• Choose Edit > New > Linetype.

• Click the New Item tool ( ).

• With your cursor in the right side of the window, right-click to display the 
shortcut menu, and choose New > Linetype.

3 Click New.

4 Type the name of the line linetype. Do not use spaces between words in the new 
linetype name.

5 If necessary, in Linetype File Name, specify a different linetype library file to 
which you want to add the new linetype.

6 In Linetype Description, type the linetype description.

You can type anything in this field that will help you remember the purpose or 
appearance of this linetype. For example, it is helpful to type text or symbols such 
as __..__.. that approximate the appearance of the linetype.

7 In Linetype Definition, type the linetype definition.

The definition consists of positive and negative numbers separated by commas. A 
positive number draws a solid line segment for the specified number of drawing 
units; a negative number creates a gap for the specified number of units; a zero 
creates a dot.   

8 Click OK.

 

A Type a name of the new linetype.
B Enter the path to the linetype library file to which 

you want to add the new linetype.
C Type any description in this box that helps you 

remember the purpose or appearance of the 
linetype.

D Type the definition of the linetype, consisting of 
positive and negative numbers separated by 
commas.

E Click to browse and select a different linetype 
library file.

D
A

C

B

D
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Creating a new complex linetype

To create a new complex linetype
A complex linetype can denote utilities, boundaries, contours, and so on. As with 
simple linetypes, complex lines are dynamically drawn as the user specifies vertices. 
Shapes and text entities embedded in lines are always displayed completely; they are 
never trimmed.

1 Do one of the following to choose Explore Linetypes ( ): 

• On the ribbon, choose Tools > Linetypes (in Explorer).

• On the menu, choose Tools > Explorer > Explore Linetypes.

• On the Explorer toolbar, click the Explore Linetypes tool.

• Type expltypes and then press Enter.

2 Using one of the following methods, open the New Linetype dialog box:

• Choose Edit > New > Linetype.

• Click the New Item tool ( ).

• With your cursor in the right side of the window, right-click to display the shortcut 
menu, and choose New > Linetype.

3 Click New.

4 Type the name of the line linetype. Do not use spaces between words in the new 
linetype name.

5 In Linetype Description, type the linetype description.

You can type anything in this field that will help you remember the purpose or 
appearance of this linetype. For complex linetypes, it is helpful to type a text 
description of the linetype.

6 In Linetype Definition, type the linetype definition.

As for the simple linetypes, the syntax for a complex linetype is a comma delimi-
nated list of pattern descriptors. For more details, see “Syntax for a complex line-
type definition” on page 312 in this chapter. 

7 Click OK.



312 C H A P T E R  8
Syntax for a complex linetype definition
Complex linetypes can include shape and text entities as pattern descriptors, as well 
as the dash and dot descriptors of simple linetypes.

The shape descriptor syntax
You can add a shape entity to a complex linetype using the following syntax:

[shape_name, shape_filename] or [shape_name, shape_filename, transform]

The definitions of the fields in the syntax are as follows.

shape_name 

The name of the shape to add to the linetype. The shape name must exist in the 
specified shape file (shape_filename).

shape_filename 

The name of a compiled shape definition file (extension *.shx). If no path is 
defined for the shape file name, the library path is searched for the file.

transform 

The transform argument is optional and can be any series of the following (each 
preceded by a comma):

R=value Relative rotation

A=value Absolute rotation

S=value Scale

X=value X offset

Y=value Y offset

In this syntax, value represents a signed decimal number. The rotation is expressed 
in degrees while the other options are in linetype scaled drawing units.

rotation 

R=value or A=value

R= determines a relative or tangential rotation with respect to the line’s elabora-
tion.

A= determines an absolute rotation of the shape with respect to the origin. All 
shapes have the same rotation regardless of their relative position to the line. The 
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value can be appended with a d for degrees (default), r for radians, or g for grads. 
If rotation is omitted, 0 relative rotation is used.

scale 

S=value

Determines a factor by which the shape's internal scale is multiplied. If the shape's 
internal scale is 0, the scale value is used as the scale.

X offset 

X=value

Determines a shift of the shape along the X axis of the linetype computed from the 
end of the linetype definition vertex. If X offset is omitted or is 0, the shape is 
elaborated with no offset. Include this field if you want a continuous line with 
shapes. This value is not scaled by the scale factor defined by S.

Y offset 

Y=value

Determines a shift of the shape along the Y axis of the linetype computed from the 
end of the linetype definition vertex. If Y offset is omitted or 0, the shape is elabo-
rated with no offset. This value is not scaled by the scale factor defined by S.

The text descriptor syntax
You can add a text entity to a complex linetype using the following syntax:

["string", style_name] or ["string", style_name, transform]

The definitions of the fields in the syntax are as follows.

string 

The text to be used in the complex linetype. You cannot use the ` or the " charac-
ters in the text string. To use these characters, enter a control code (%%) with the 
ASCII value for the character instead.

style_name 

The name of the text style to be elaborated. The specified text style must be 
included. If it is omitted, use the currently defined style.

transform 

The transform argument is optional and can be any series of the following (each 
preceded by a comma):

R=value Relative rotation

A=value Absolute rotation

S=value Scale

X=value X offset

Y=value Y offset
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In this syntax, value represents a signed decimal number. The rotation is expressed 
in degrees while the other options are in linetype scaled drawing units.

rotation 

R=value or A=value

R= determines a relative or tangential rotation with respect to the line’s elabora-
tion.

A= determines an absolute rotation of the text with respect to the origin. All text 
has the same rotation regardless of its relative position to the line. The value can 
be appended with a d for degrees (default), r for radians, or g for grads. If rotation 
is omitted, 0 relative rotation is used.

Rotation is centered between the baseline and the nominal cap heights box.

scale 

S=value

Determines a factor by which the style's height is multiplied. If the style's height is 
0, the scale value is used as the scale.

Because the final height of the text is defined by both the scale value and the 
height assigned to the text style, you will achieve more predictable results by set-
ting the text style height to 0. It is recommended that you create separate text 
styles for text in complex linetypes to avoid conflicts with other text in your draw-
ing.

X offset 

X=value

Determines a shift of the text along the X axis of the linetype computed from the 
end of the linetype definition vertex. If X offset is omitted or is 0, the text is elab-
orated by using the lower left corner of the text as the offset. Include this field if 
you want a continuous line with text. This value is not scaled by the scale factor 
that is defined by S.

Y offset 

Y=value

Determines a shift of the text along the Y axis of the linetype computed from the 
end of the linetype definition vertex. If Y offset is omitted or is 0, the text is elab-
orated by using the lower left corner of the text as the offset. This value is not 
scaled by the scale factor that is defined by S.



W O R K I N G  W I T H  T H E  E X P L O R E R 315
Modifying linetypes

To change a linetype name   
1 Do one of the following to choose Explore Linetypes ( ):    

• On the ribbon, choose Tools > Linetypes (in Explorer).

• On the menu, choose Tools > Explorer > Explore Linetypes.

• On the Explorer toolbar, click the Explore Linetypes tool.

• Type expltypes and then press Enter.

2 Do one of the following:

• Select the linetype, and then choose Edit > Rename. 

• Click the linetype name you want to change, and then type the new name.

• Right-click the linetype name you want to change, and from the shortcut menu, 
select Rename.

3 To complete the command and return to your drawing, close the window.

The linetypes named CONTINUOUS, BYBLOCK, and BYLAYER are reserved. 
You cannot rename them.

Working with multiline styles

A multiline style is a named, saved collection of format settings that determines the 
appearance of multilines.

Understanding multiline styles
When you create a multiline in a drawing, it is created using the current multiline 
style. The multiline style determines the number of parallel lines, the spacing 
between each line, and more. 

Every drawing has at least one multiline style, named Standard. You cannot delete 
the Standard style, but you can rename it or modify it. You can use an unlimited num-
ber of multiline styles in your drawing. 

Displaying multiline style information in the Explorer
To display the Explorer Multiline Styles element
Do one of the following to choose Explore Multiline Styles ( ):   

• On the ribbon, choose Tools > Multiline Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Multiline Styles.
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• On the Explorer toolbar, click the Explore Multiline Styles tool.

• Type expmlinestyles and then press Enter.
 

 

Creating and naming multiline styles
By using the Multiline Styles element in combination with the Modify Multiline 
Style dialog box, you can create new multiline styles and modify them.

To create a new multiline style
1 Do one of the following to choose Explore Multiline Styles ( ):   

• On the ribbon, choose Tools > Multiline Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Multiline Styles.

• On the Explorer toolbar, click the Explore Multiline Styles tool.

• Type expmlinestyles and then press Enter.

2 Click the New Item tool ( ).

A new style is added to the multiline styles list.

A Lists names of multiline styles defined in the 
current drawing. A check mark indicates the 
current multiline style.

B Describes multiline styles loaded in the current 
drawing.

C Shows how multilines will appear in the drawing.

D Click to modify the corresponding multiline style.
E Click a column title to sort by category. Click and 

drag a column title to change the column order. 
Right-click a column title to choose which 
columns display or to restore all column settings 
to the default settings.

A B

E

C D
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3 Type the name for the new style by typing over the highlighted default text, and 
then press Enter.

4 Optionally click the Description and type text, and then press Enter. 

5 Click ( ) for the new style and make your selections.

For more details about the available settings, see “Working with multiline styles” 
on page 149. 

To change a multiline style name in the current drawing
1 Do one of the following to choose Explore Multiline Styles ( ):   

• On the ribbon, choose Tools > Multiline Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Multiline Styles.

• On the Explorer toolbar, click the Explore Multiline Styles tool.

• Type expmlinestyles and then press Enter.

2 Do one of the following:

• Click the multiline style name you want to change, type a new name, and then 
press Enter. 

• Right-click the multiline style name you want to change, and from the shortcut 
menu, select Rename, type a new name, and then press Enter.

Modifying multiline styles
A new multiline style is initially assigned default values that you can change. You 
can change these values for both new and existing multiline styles.

To modify a multiline style   
1 Do one of the following to choose Explore Multiline Styles ( ):   

• On the ribbon, choose Tools > Multiline Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Multiline Styles.

• On the Explorer toolbar, click the Explore Multiline Styles tool.

• Type expmlinestyles and then press Enter.

2 Click ( ) for the multiline style you want to modify, and then make your selec-
tions.

For more details about the available settings, see “Working with multiline styles” 
on page 149. 
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Setting the current multiline style
When you insert a multiline in a drawing, the multiline is created using the current 
multiline style. You can also assign a different multiline style when you create a mul-
tiline.    

To make a multiline style current
1 Do one of the following to choose Explore Multiline Styles ( ):   

• On the ribbon, choose Tools > Multiline Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Multiline Styles.

• On the Explorer toolbar, click the Explore Multiline Styles tool.

• Type expmlinestyles and then press Enter.

2 In the Multiline Style Name list, click the style you want to make current.

3 Click the Current tool ( ).

Use a shortcut. 
You can also make a multiline style current by double-clicking the multiline style 
name or by right-clicking the multiline style name and then choosing Current.    
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Working with text styles 

A text style is a named, saved collection of format settings that determines the 
appearance of text.

Understanding text styles
When you add text to a drawing, it is created using the current text style. The text 
style determines the font, size, angle, orientation, if the text is annotative by default, 
and other text characteristics.   

Every drawing has at least one text style, named Standard, which initially uses the 
Arial font. You cannot delete the Standard style, but you can rename it or modify it. 
For example, you can change the font or the oblique angle applied to the font. You 
also can use an unlimited number of additional text styles in your drawing.    

From the Explorer, you can directly edit any setting associated with a text style by 
using the single-click editing method to change the setting.   

Displaying text style information in the Explorer
To display the Explorer Text Styles element
Do one of the following to choose Explore Text Styles ( ):    

• On the ribbon, choose Tools > Text Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Text Styles.

• On the Explorer toolbar, click the Explore Text Styles tool.

• Type expstyles and then press Enter.
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Creating and naming text styles 
Fonts are character sets that consist of letters, numbers, punctuation marks, and sym-
bols. Each font is stored in its own font file. Text styles apply additional formatting to 
fonts. You can create multiple text styles based on the same font, changing the vari-
ous characteristics to alter the appearance of the font. To create a new text style, you 
assign formatting characteristics to a font.    

IntelliCAD uses *.shx font files and provides a selection of fonts. These fonts are 
located in the IntelliCAD/Fonts directory. You can also use any font designed to 
work with AutoCAD as well as Windows system fonts. Many fonts are available 
from third-party vendors.    

A Lists names of text styles defined in the current drawing. A 
check mark indicates the current style.    

B Indicates whether text will be annotative by default; you can 
click to turn the option on or off.

C Indicates whether annotative text in paper space will be 
oriented according to the layout viewport; you can click to turn 
the option on or off.

D Displays the height for the text style; you can type a new 
height.

E Displays the width factor for the text style; you can type a new 
width factor.    

F Displays the oblique angle for the text style; you can enter a 
new oblique angle.    

G Displays the font name on which the style is based; you can 
select a new font.

H Displays the font style, such as bold or italic; you can select a 
new font style.

I Displays the language on which the text style is based; you 
can select a new language.

J Displays whether Asian language big font files are used (for 
.shx file fonts only).

K Indicates whether text will appear backward; you can click to 
turn the option on or off.    

L Indicates whether text will appear upside down; you can click 
to turn the option on or off.

M Indicates whether text will appear vertically; you can click to 
turn the option on or off.

N Click a column title to sort by category. Click and drag a 
column title to change the column order. Right-click a column 
title to choose which columns display or to restore all column 
settings to the default settings.

A B C D E G H I KF NJ L M
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To create a new text style
1 Do one of the following to choose Explore Text Styles ( ):     

• On the ribbon, choose Tools > Text Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Text Styles.

• On the Explorer toolbar, click the Explore Text Styles tool.

• Type expfonts and then press Enter.

2 Do one of the following:

• Choose Edit > New > Text Style.

• Click the New Item tool ( ).

A new style is added to the text styles list with the default name, NewStyle1.

3 Type the name for the new style by typing over the highlighted default text, and 
then press Enter.

4 Click the columns for the items you want to change and make your selections for 
the new text style.

5 To complete the command, close the window.

To change a text style name in the current drawing
1 Do one of the following to choose Explore Text Styles ( ): 

• On the ribbon, choose Tools > Text Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Text Styles.

• On the Explorer toolbar, click the Explore Text Styles tool.

• Type expfonts and then press Enter.

2 Do one of the following:

• Select the text style, choose Edit > Rename, type a new name, and then press 
Enter.

• Click the text style name you want to change, type a new name, and then press 
Enter. 

• Right-click the text style name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter.

3 To complete the command and return to your drawing, close the window.
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Modifying text styles
A new text style is initially assigned default values for height, width factor, oblique 
angle, and other characteristics. You can change these values for both new and exist-
ing text styles. You can also change the font assigned to the text style. If you change 
the font or orientation properties of a text style assigned to text previously inserted in 
the drawing, all text using that style is regenerated to reflect the changes. Oblique 
angle and height, if specified, are given by the style definition when text is created, 
but are not updated for existing text when the style is changed.    

A fixed text height value of 0 allows you to specify the text height at the time you 
insert text into the drawing. Any other value sets height of the text to that value; the 
program does not prompt for the text height when you insert text into the drawing. 
The width factor determines the horizontal scaling of text. A value less than 1 com-
presses the text (for example, 0.75 compresses the text 25 percent); a value greater 
than 1 expands the text (for example, 1.50 expands the text 50 percent). The oblique 
angle determines the forward or backward slant of text as an angle offset from 90 
degrees. Negative values slant text to the left; positive values slant text to the right.

To modify a text style   
1 Do one of the following to choose Explore Text Styles ( ):     

• On the ribbon, choose Tools > Text Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Text Styles.

• On the Explorer toolbar, click the Explore Text Styles tool.

• Type expfonts and then press Enter.

2 Click the desired column for the text style you want to change, then make the 
desired changes.

3 To complete the command, close the Explorer window.    
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Setting the current text style
When you insert text in a drawing, the text is created using the current text style. You 
can also assign a different text style when you create text.    

To make a text style current
1 Do one of the following to choose Explore Text Styles ( ):     

• On the ribbon, choose Tools > Text Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Text Styles.

• On the Explorer toolbar, click the Explore Text Styles tool.

• Type expfonts and then press Enter.

2 In the Text Style Name list, click the style you want to make current.

3 Use one of the following methods to make the style the current style:

• Choose Edit > Current.

• Click the Current tool ( ).

• With the cursor in the right side of the window, right-click to display the 
shortcut menu, and choose Current.

4 To complete the command and return to your drawing, close the Explorer window.

Use a shortcut. 
You can also make a text style current by selecting it in the Text Style Name list and 
clicking the Current tool ( ) or by double-clicking the text style name in the Text 
Style Name list.    
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Working with table styles 

A table style is a named, saved collection of format settings that determines the 
appearance of tables.

Understanding table styles
When you add a table to a drawing, it is created using the current table style. The 
table style determines the table direction, text and border properties, and other set-
tings. 

Every drawing has at least one table style, named Standard. You cannot delete the 
Standard style, but you can rename it or modify it, for example, to change the table 
direction. You can use an unlimited number of table styles in your drawing. 

Displaying table style information in the Explorer

To display the Explorer Table Styles element
Do one of the following to choose Explore Table Styles ( ): 

• On the ribbon, choose Tools > Table Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Table Styles.

• On the Explorer toolbar, click the Explore Table Styles tool.

• Type exptablestyles and then press Enter.
 

A Lists names of table styles defined in the current 
drawing. A check mark indicates the current table 
style.

B Click to modify the corresponding table style.

A B
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Creating and naming table styles
By using the Table Styles element in combination with the Modify Table Style dialog 
box, you can create new table and cell styles and modify them.

To create a new table style
1 Do one of the following to choose Explore Table Styles ( ): 

• On the ribbon, choose Tools > Table Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Table Styles.

• On the Explorer toolbar, click the Explore Table Styles tool.

• Type exptablestyles and then press Enter.

2 Click the New Item tool ( ).

A new style is added to the table styles list.

3 Type the name for the new style by typing over the highlighted default text, and 
then press Enter.

4 Click ( ) for the new style and make your selections.

For more details about the available settings, see “Working with table styles” on 
page 185. 

To change a table style name in the current drawing
1 Do one of the following to choose Explore Table Styles ( ): 

• On the ribbon, choose Tools > Table Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Table Styles.

• On the Explorer toolbar, click the Explore Table Styles tool.

• Type exptablestyles and then press Enter.

2 Do one of the following:

• Click the table style name you want to change, type a new name, and then press 
Enter. 

• Right-click the table style name you want to change, and from the shortcut 
menu, select Rename, type a new name, and then press Enter.
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Modifying table styles
A new table style is initially assigned default values that you can change. You can 
change these values for both new and existing table styles.

To modify a table style   
1 Do one of the following to choose Explore Table Styles ( ): 

• On the ribbon, choose Tools > Table Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Table Styles.

• On the Explorer toolbar, click the Explore Table Styles tool.

• Type exptablestyles and then press Enter.

2 Click ( ) for the table style you want to modify, and then make your selections.

For more details about the available settings, see “Working with table styles” on 
page 185. 

Setting the current table style
When you insert a table in a drawing, the table is created using the current table style. 
You can also assign a different table style when you create tables.

To make a table style current
1 Do one of the following to choose Explore Table Styles ( ): 

• On the ribbon, choose Tools > Table Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Table Styles.

• On the Explorer toolbar, click the Explore Table Styles tool.

• Type exptablestyles and then press Enter.

2 In the list of table styles, click the style you want to make current.

3 Click the Current tool ( ).

Use a shortcut. 
You can also make a table style current by double-clicking the table style name or by 
right-clicking the table style name and then choosing Current.    
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Working with dimension styles    

From the Explorer, you can use the Dimension Styles element to cut, copy, and paste 
dimension styles from one drawing to another. 

A dimension style contains the settings that control the appearance of a dimension. 
Although you cannot control these settings from within the Explorer, you can use the 
Modify Dimension Style dialog box to control settings related to the appearance of 
arrows, lines, text, units, and other formatting characteristics.     

Displaying dimension style information in the Explorer

To display the Explorer Dimension Styles element
Do one of the following to choose Explore Dimension Styles ( ):    

• On the ribbon, choose Tools > Dimension Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Dimension Styles.

• On the Explorer toolbar, click the Dimension Styles tool.

• Type setdim and then press Enter.
 

A Lists the names of dimension styles defined in 
the current drawing.

B Click to edit the corresponding dimension style.

A B
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Creating and naming dimension styles 
By using the Dimension Styles element in combination with the Modify Dimension 
Style dialog box, you can create new dimension styles, modify them, and copy them 
into a different drawing. 

To create a dimension style
1 Do one of the following to choose Explore Dimension Styles ( ):

• On the ribbon, choose Tools > Dimension Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Dimension Styles.

• On the Explorer toolbar, click the Explore Dimension Styles tool.

• Type expdimstyles and then press Enter. 

2 In the Dimension Styles Manager dialog box, click New.

3 Type the name of the new dimension style.

4 Click the Edit icon for the new dimension style.

5 In the Modify Dimension Style dialog box, select the desired options.

6 Click OK.

To change a dimension style name in the current drawing
1 Do one of the following to choose Explore Dimension Styles ( ):

• On the ribbon, choose Tools > Dimension Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Dimension Styles.

• On the Explorer toolbar, click the Explore Dimension Styles tool.

• Type expdimstyles and then press Enter. 

2 Do one of the following:

• Select the dimension style, choose Edit > Rename, type a new name, and then 
press Enter.

• Click the dimension style name you want to change, type a new name, and then 
press Enter.

• Right-click the dimension style name you want to change, and from the shortcut 
menu, select Rename, type a new name, and then press Enter.

3 To complete the command and return to your drawing, close the window.
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Copying dimension styles
You can copy and paste dimension styles between drawings. In addition to the steps 
below, you can also select a dimension style and use the Windows shortcut keys 
(Ctrl+A to select all, Ctrl+X to cut, Ctrl+C to copy, Ctrl+V to paste) to copy it in the 
Explorer. You can use these shortcut keys with all other Explorer elements as well.

To copy a dimension style from one drawing to another
1 Do one of the following to choose Explore Dimension Styles ( ):

• On the ribbon, choose Tools > Dimension Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Dimension Styles.

• On the Explorer toolbar, click the Explore Dimension Styles tool.

• Type expdimstyles and then press Enter. 

2 Right-click the dimension style name you want to copy.

3 From the shortcut menu, select Copy.

4 On the left, select the drawing to which you want to copy the dimension style.

5 Click the Dimension Styles element for that drawing.

6 On the right, right-click, and then from the shortcut menu, select Paste.

Each drawing contains a dimension style named Standard. 
You cannot delete this dimension style, but you can rename it from within the 
Explorer or modify its properties in the Modify Dimension Style dialog box.    
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Working with multileader styles

A multileader style is a named, saved collection of format settings that determines the 
appearance of multileaders.

Understanding multileader styles
When you create a multileader, it is created using the current multileader style. The 
multileader style determines the arrowhead type, text style, colors, and more. 

Every drawing has at least one multileader style, named Standard. You cannot delete 
the Standard style, but you can rename it or modify it. You can use an unlimited num-
ber of multileader styles in your drawing. 

Displaying multileader style information in the Explorer

To display the Explorer Multileader Styles element
Do one of the following to choose Explore Multileader Styles ( ):    

• On the ribbon, choose Tools > Multileader Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Multileader Styles.

• On the Explorer toolbar, click the Explore Multileader Styles tool.

• Type expmleaderstyles and then press Enter. 

 

A Lists the names of multileader styles defined in 
the current drawing.

B Click to modify the corresponding multileader 
style.

A B
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Creating and naming multileader styles
By using the Multileader Styles element in combination with the Modify Multileader 
Style dialog box, you can create new multiline styles and modify them.

To create a new multileader style
1 Do one of the following to choose Explore Multileader Styles ( ):   

• On the ribbon, choose Tools > Multileader Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Multileader Styles.

• On the Explorer toolbar, click the Explore Multileader Styles tool.

• Type expmleaderstyles and then press Enter.

2 Click the New Item tool ( ).

A new style is added to the multileader styles list.

3 Type the name for the new style by typing over the highlighted default text, and 
then press Enter.

4 Click ( ) for the new style and make your selections.

For more details about the available settings, see “Working with multileader 
styles” on page 198. 

To change a multileader style name in the current drawing
1 Do one of the following to choose Explore Multileader Styles ( ):   

• On the ribbon, choose Tools > Multileader Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Multileader Styles.

• On the Explorer toolbar, click the Explore Multileader Styles tool.

• Type expmleaderstyles and then press Enter.

2 Do one of the following:

• Click the multileader style name you want to change, type a new name, and then 
press Enter. 

• Right-click the multileader style name you want to change, and from the 
shortcut menu, select Rename, type a new name, and then press Enter.



332 C H A P T E R  8
Modifying multileader styles
A new multileader style is initially assigned default values that you can change. You 
can change these values for both new and existing multileader styles.

To modify a multileader style   
1 Do one of the following to choose Explore Multileader Styles ( ):   

• On the ribbon, choose Tools > Multileader Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Multileader Styles.

• On the Explorer toolbar, click the Explore Multileader Styles tool.

• Type expmleaderstyles and then press Enter.

2 Click ( ) for the multileader style you want to modify, and then make your 
selections.

For more details about the available settings, see “Working with multileader 
styles” on page 198. 

Setting the current multileader style
When you insert a multileader in a drawing, the multileader is created using the cur-
rent multileader style. You can also assign a different multileader style when you cre-
ate multileaders.    

To make a multileader style current
1 Do one of the following to choose Explore Multileader Styles ( ):   

• On the ribbon, choose Tools > Multileader Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Multileader Styles.

• On the Explorer toolbar, click the Explore Multileader Styles tool.

• Type expmleaderstyles and then press Enter.

2 In the Multileader Style Name list, click the style you want to make current.

3 Click the Current tool ( ).

Use a shortcut. 
You can also make a multileader style current by double-clicking the multileader 
style name or by right-clicking the multileader style name and then choosing Current.    
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Working with named views 

A named view is a saved collection of view settings that determines a view’s direc-
tion, boundaries, UCS, visual style, background, and perspective, etc. Named views 
can be saved and restored in the current window at any time. Use the Explorer to 
manage named views and quickly switch between views.

Also accessible from the Explorer is the View Manager, which is used to create new 
views and modify any view settings. For more details, see “Creating and switching to 
named views” on page 690. 

Displaying views in the Explorer

To display views in the Explorer
Do one of the following to choose Explore Views ( ):    

• On the ribbon, choose Tools > Views (in Explorer).

• Choose Tools > Explore Views.

• On the Explorer toolbar, click the Explore Views tool.

• Type expviews and then press Enter.

• Choose Tools > Explorer, and then click the Views element.

Named views are stored in the drawing.
You can use the Explorer to copy and paste named views from one drawing to 
another. Click the Show as Dialog tool to display the Explorer as a dialog box to see 
the currently open drawings, then copy and paste between them.
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A Lists names of views defined in the current drawing.
A check mark indicates the current view.    

B Displays the height of the view in drawing units.   
C Displays the width of the view in drawing units.
D Displays the direction of the view, expressed as a three-

dimensional coordinate in the WCS.

E Click a column title to sort by category. Click and drag a 
column title to change the column order. Right-click a 
column title to choose which columns display or to restore 
all column settings to the default settings.

F Click to open the View Manager to specify additional view 
settings.

A B C D

E

F
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Saving and naming views 
You can save the view displayed in the current window as a named view. After you 
save a named view, you can restore that view in the current window at any time.    

To save a portion of the current view as a named view
1 Do one of the following to choose Explore Views ( ):     

• On the ribbon, choose Tools > Views (in Explorer).

• On the menu, choose Tools > Explorer > Explore Views.

• On the Explorer toolbar, click the Explore Views tool.

• Type expviews and then press Enter.

2 Do one of the following:

• Choose Edit > New > View.

• On the Explorer toolbar, click the New Item tool ( ).

3 Specify the first corner of the view window.

4 Specify the opposite corner of the view window.

5 Type a new name for the view, and then press Enter.

Named views can be created in more ways using the View Manager.
From Explore Views, click the View Manager tool. For more details, see “Creating 
and switching to named views” on page 690. 
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Restoring named views   
After you save one or more named views, you can restore any of those views in the 
current window using either the View command or IntelliCAD’s Explorer.    

To restore a named view from the Explorer
Do one of the following:

• Select the view name in the list of View settings, and then choose Edit > Current.

• Select the view name in the list of View settings, and then click the Current tool 
( ).

• Double-click the view name in the View list.

To restore a named view using the View command
1 Do one of the following to choose View Manager ( ):

• On the ribbon, choose View > View Manager (in Views).

• On the menu, choose View > View Manager.

• On the View toolbar, click the View Manager tool.

• Type view and then press Enter.

2 Select the view you want to restore.

3 Click OK.

Restoring a named view can be affected by smooth view transitions.
Type vtoptions to specify whether smooth view transitions are used when restoring a 
named view (the view rotation), and to specify speed and performance settings.

Modifying the settings of named views
Once you create a named view you can modify its properties, such as the target direc-
tion and twist angle. This gives you access to many of the view settings after a view 
has been defined. Some properties are available directly in the Explorer, while others 
are available in the Views Manager.   

Only named views that you create can be changed; preset views cannot be modified.
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To change the view options
1 Do one of the following to choose Explore Views ( ):

• On the ribbon, choose Tools > Views (in Explorer).

• On the menu, choose Tools > Explore Views.

• On the Explorer toolbar, click the Explore Views tool.

• Type expviews and then press Enter.

2 To rename a view, do one of the following:

• Select the view, choose Edit > Rename, type a new name, and then press Enter.

• Click the view name you want to change, type a new name, and then press Enter.

• Right-click the view name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter.

3 Click the Height, Width, or View Direction column for the view you want to 
change, and then type your changes.

4 To make additional changes, click the View Manager tool ( ), change the 
desired settings, and then close the dialog box.
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Working with visual styles

Visual styles are used to control how CAD geometry displays in real-time: 2D where-
fore, hidden-line, shaded, shaded with materials, etc. Visual styles vary based on the 
capabilities of the OpenGL and OpenGL ES graphics devices.

Understanding visual styles
Visual styles can change the display of a drawing as you work in real-time. The 
current visual style determines whether a background displays, halo gap percentage, 
face settings, edge settings, and more. 

Every drawing has a predefined list of visual styles, which cannot be deleted or 
renamed. However, you can create additional visual styles and change the properties 
of any visual style.

For more details about visual styles, see “Using dynamic visual styles for hiding, 
shading, and rendering” on page 767. 

Displaying visual style information in the Explorer
To display the Explorer Visual Styles element
Do one of the following to choose Explore Visual Styles ( ):   

• On the ribbon, choose Tools > Visual Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Visual Styles.

• On the Explorer toolbar, click the Explore Visual Styles tool.

• Type expvstyles and then press Enter.
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A Lists names of visual styles defined in the current drawing. A check 
mark indicates the current visual style.

B Controls whether default lighting is on or off (for example, if a drawing 
has its own lights).

C Controls the style used to display faces: None, Real (realistic), or 
Gooch (non-realistic).

D Controls the opacity level applied to faces from 0 (fully transparent) to 
1 (fully opaque).

E Controls whether materials and textures display.
F Controls the level of specular highlight used to display faces that do not 

have materials.
G Controls whether a background displays.
H Controls whether to display edges, and whether to display them as 

isolines or facet edges.

I Controls whether isolines display on top of shaded entities.
J Controls whether to display silhouette edges, which are the edges that 

connect a back facing entity with a front facing entity.
K Controls the number of pixels used to display silhouette edge width.
L Controls the number of pixels that lines and edges display beyond their 

endpoints for a hand-drawn effect.
M Controls the number of lines that are offset for a pencil effect.
N Controls the angle used for displaying crease edges.
O Controls the gap size displayed where one entity is hidden by another 

entity.
P Click a column title to sort by category. Click and drag a column title to 

change the column order. Right-click a column title to choose which 
columns display or to restore all column settings to the default settings.

A B C

P

D E F G H I J K L M N O
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Creating and naming visual styles
Using the Explorer, you can create new visual styles and modify their properties.

To create a new visual style
1 Do one of the following to choose Explore Visual Styles ( ):   

• On the ribbon, choose Tools > Visual Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Visual Styles.

• On the Explorer toolbar, click the Explore Visual Styles tool.

• Type expvstyles and then press Enter.

2 Click the New Item tool ( ).

A new style is added to the visual styles list.

3 Type the name for the new style by typing over the highlighted default text, and 
then press Enter.

4 Optionally click the Description and type text, and then press Enter.

To change a visual style name in the current drawing
1 Do one of the following to choose Explore Visual Styles ( ):   

• On the ribbon, choose Tools > Visual Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Visual Styles.

• On the Explorer toolbar, click the Explore Visual Styles tool.

• Type expvstyles and then press Enter.

2 Click the visual style name you want to change, type a new name, and then press 
Enter. Predefined visual styles cannot be renamed.

Modifying visual styles
A new visual style is initially assigned default values that you can change. 

To modify a visual style   
1 Do one of the following to choose Explore Visual Styles ( ):   

• On the ribbon, choose Tools > Visual Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Visual Styles.

• On the Explorer toolbar, click the Explore Visual Styles tool.

• Type expvstyles and then press Enter.

2 Change the properties for the visual style you want to modify.
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You also use the Properties pane to modify a visual style.
When no entities are selected, the Properties pane displays properties for the draw-
ing file. In Visual style, select the visual style you want to modify, then change its 
properties.

Setting the current visual style
The current visual style is the style used to display the drawing.    

To make a visual style current
1 Do one of the following to choose Explore Visual Styles ( ):   

• On the ribbon, choose Tools > Visual Styles (in Explorer).

• On the menu, choose Tools > Explorer > Explore Visual Styles.

• On the Explorer toolbar, click the Explore Visual Styles tool.

• Type expvstyles and then press Enter.

2 In the Visual Style Name list, click the style you want to make current.

3 Click the Current tool ( ).

Use a shortcut. 
In the upper left corner of the drawing window, click the visual style control and 
choose a visual style to make it current. Or using the Explorer, you can also make a 
visual style current by double-clicking the visual style name or by right-clicking the 
visual style name and then choosing Current.    
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Working with coordinate systems 

A coordinate system is a system of points that represents the drawing space in rela-
tion to an origin (0,0,0) and a set of axes that intersect at the origin. 

Understanding coordinate systems
When you create entities in a drawing, they are located in relation to the drawing’s 
underlying Cartesian coordinate system. Every drawing has a fixed coordinate system 
called the World Coordinate System (WCS). You cannot delete or modify the WCS.   

Your drawing may contain additional coordinate systems, however, each with its own 
0,0,0 origin and orientation. You can create as many user coordinate systems as you 
want, and then save and recall them as you need them. You can edit the origin of a 
coordinate system from within IntelliCAD’s Explorer by single-clicking the origin 
coordinates and then typing new coordinates.

For example, you can create a separate user coordinate system (UCS) for each side of 
a building. Then, by switching to the UCS for the east side of the building, you can 
draw the windows on that side by specifying only their x- and y-coordinates.

You can create and then switch between various user coordinate systems by selecting 
Coordinate Systems in the Explorer.

Displaying coordinate system information in the Explorer

To display the Coordinate Systems element
Do one of the following to choose Explore Coordinate Systems ( ):    

• On the ribbon, choose Tools > Coordinate Systems (in Explorer).

• On the menu, choose Tools > Explorer > Explore Coordinate Systems.

• Choose Tools > User Coordinate Systems > Explore Coordinate Systems.

• On the Explorer toolbar, click the Explore Coordinate Systems tool.

• Type expucs and then press Enter. 
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Defining and naming user coordinate systems 
A drawing can contain as many coordinate systems as you want and can be named 
appropriate names so you can remember how they are used in your drawing for 
recalling them later.

To define new user coordinate systems in the Explorer
1 Do one of the following to choose Explore Coordinate Systems ( ):   

• On the ribbon, choose Tools > Coordinate Systems (in Explorer).

• On the menu, choose Tools > Explorer > Explore Coordinate Systems.

• On the Explorer toolbar, click the Explore Coordinate Systems tool.

• Type expucs and then press Enter.

2 Do one of the following:   

• Choose Edit > New > UCS.

• Click the New Item tool ( ).

• With your cursor in the right side of the window, right-click to display the 
shortcut menu, and choose New > UCS.

A Lists names of coordinate systems defined in the current 
drawing. A check mark indicates the current coordinate 
system.

B Displays the origin of the coordinate system in relation to 
the WCS.

C Displays the x-axis direction of the coordinate system in 
relation to the WCS.

D Displays the y-axis direction of the coordinate system in 
relation to the WCS.

E Click a column title to sort by category. Click and drag a 
column title to change the column order. Right-click a 
column title to choose which columns display or to 
restore all column settings to the default settings.

F Select the base user coordinate system.

A B C D

E

F
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3 Select a method from the prompt box or command bar by which to define the UCS 
in the drawing window. 

For example, select 3 Point and then specify three points in the drawing window 
to define the x, y, and z axes for your coordinate system.

4 Type the name for the new user coordinate system by typing over the highlighted 
default text, and then press Enter.

5 To complete the command, close the window.

To change a user coordinate system name in the current drawing
1 Do one of the following to choose Explore Coordinate Systems ( ):

• On the ribbon, choose Tools > Coordinate Systems (in Explorer).

• On the menu, choose Tools > Explorer > Explore Coordinate Systems.

• On the Explorer toolbar, click the Explore Coordinate Systems tool.

• Type expucs and then press Enter.

2 Do one of the following:

• Select the user coordinate system, and then choose Edit > Rename, type a new 
name, and then press Enter.

• Click the user coordinate system name you want to change, type a new name, 
and then press Enter.

• Right-click the user coordinate system name you want to change, and from the 
shortcut menu, select Rename, type a new name, and then press Enter.

3 To complete the command and return to your drawing, close the window.

Setting the current user coordinate system
When you draw new entities, they are created in relation to the current coordinate 
system. You can set the current UCS from the Explorer.    

To set the current UCS from the Explorer
Do one of the following:

• Double-click the UCS name in the UCS Name list.

• Select the UCS in the UCS Name list, and then choose Edit > Current.

• Select the UCS in the UCS Name list, and then click the Current tool ( ).     
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Working with blocks 

Blocks represent a special type of entity that, once saved, can be inserted and manip-
ulated in the drawing as a single entity. 

Understanding blocks
A block can consist of visible entities such as lines, arcs, and circles as well as visible 
or invisible data called attributes. You can use attributes to track things such as part 
numbers and prices and to export attribute information to an external database. You 
can also track the number of parts by counting the number of times a block has been 
inserted into the drawing. Blocks are stored as part of the drawing file.    

External references have similar uses to blocks. Using external references, you can 
attach entire drawings to your current drawing. Unlike a block, however, an external 
reference does not become part of the current drawing.    

You can save blocks to an external .dwg file from the Explorer. You can also use the 
Explorer to manage and insert copies of blocks. The Explorer window lists the names 
of all blocks contained in the current drawing, along with other information about 
each block or external reference.    

You can also rename a block, modify its insertion point, and change the path of an 
externally referenced drawing by single-clicking on the property and making your 
edits within the Explorer.

In addition to the Explorer, you can also work with blocks by using the Block Editor, 
by using various block commands, and by adding blocks to tool palettes. For more 
details about the Block Editor and various block commands, see “Working with 
blocks” on page 546. For more details about tool palettes, see “Customizing tool pal-
ettes” on page 864. 

Displaying block information in the Explorer

To display blocks in the Explorer
Do one of the following to choose Explore Blocks ( ):    

• On the ribbon, choose Tools > Blocks (in Explorer).

• On the menu, choose Tools > Explorer > Explore Blocks.

• On the Explorer toolbar, click the Explore Blocks tool.

• Type expblocks and then press Enter.
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The Blocks element in the Explorer defaults with icons on. The Icons view shows you 
a small image of each block.    

When blocks are displayed, additional tools on the Block toolbar provide the func-
tions described in the following table: 
    

To see more information about each block, click the Details tool ( ). In the Details 
view, you can edit the path and the insertion point by clicking the setting and typing 
your changes.      

 The Images view shows an image of each block in the selected drawing. Click an image to select it.

Additional tools on the Block toolbar   
Tool Function

( ) Icons Displays an image of each block.

( ) Details Displays information about each block.

( ) Insert Inserts a block.

( ) Insert External File Block Inserts a drawing available from disk as a block.

( ) Save Block Saves the selected block as an independent.dwg file. If 
more than one block is selected, saves each block as an 
independent .dwg file in a folder you specify.

( ) Edit Block Reference Redefines the definition of a block.
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A Lists names of blocks defined in the current drawing.    
Click and type to modify it.

B Displays the number of occurrences of the block in the 
current drawing.      

C Displays the insertion point of the block in the current 
drawing. Click and type to modify it.

D Indicates whether the block is annotative by default; click 
to turn the option on or off.

E Indicates whether the block, when located in paper space, 
is oriented automatically according to the layout viewport; 
click to turn the option on or off. (Available only for 
annotative blocks.)

F Indicates whether the block must scale proportionately; 
click to turn the option on or off. 

G Indicates whether the block can be exploded; click to turn 
the option on or off.

H Displays the description of the block. Click and type to 
modify it.

I Click a column title to sort by category. Click and drag a 
column title to change the column order. Right-click a 
column title to choose which columns display or to restore 
all column settings to the default settings.

A B C
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Creating and naming blocks
You can combine any number of entities into a single block. After you create a block, 
you can insert copies of it into a drawing. Each block insertion is treated as a single 
entity; for example, you can rotate or scale each block when you insert it. The program 
adds the name of the new block you insert to the Block Name list in the Explorer.    

To create a block
1 Do one of the following to choose Explore Blocks ( ):     

• On the ribbon, choose Tools > Blocks (in Explorer).

• On the menu, choose Tools > Explorer > Explore Blocks.

• On the Explorer toolbar, click the Explore Blocks tool.

• Type expblocks and then press Enter.

2 Do one of the following:

• Choose Edit > New > Block.

• On the Explorer toolbar, click the New Item tool ( ).

3 In the Block definition dialog box, enter a name and description for the new block.    

4 Specify the insertion point for the block by doing one of the following:

• Specify on Screen Mark this check box to select the base point in the drawing 
after you click OK.

• Pick Base Point Click ( ) to temporarily close the dialog box immediately, 
select the base point in the drawing, then return to the dialog box. This option is 
available only if Specify on Screen is not marked.

• X, Y, and Z Enter the x-, y-, and z-coordinates of the base point. This option is 
available only if Specify on Screen is not marked.

5 Select the entities to be combined into the block by doing one of the following:

• Specify on Screen Mark this check box to select the entities in the drawing after 
you click OK.

• Select entities Click ( ) to temporarily close the dialog box immediately, 
select the entities in the drawing, then return to the dialog box. Or you can click  
( ) to select entities by type or value. This option is available only if Specify 
on Screen is not marked.

6 Select what to do with the entities after the block is created:

• Retain entities Entities selected for the block remain in the drawing.

• Convert to block Entities selected for the block are converted to the block, 
which remains in the drawing.

• Delete entities Entities selected for the block are removed from the drawing.



W O R K I N G  W I T H  T H E  E X P L O R E R 349
7 Select any of the following options for the block:

• Annotative Determines whether the block is annotative by default. The display 
and printing of annotative blocks is affected by annotation scaling. If annotative 
by default, you can determine whether the block, when located in paper space, 
is oriented automatically according to the layout viewport.

• Scale uniformly Mark this check box to retain the aspect ratio if the block is 
scaled. Annotative blocks must be scaled proportionately.

• Allow exploding Mark this check box to allow the block to be exploded into 
separate entities.

• Unit Defines the unit of the block, for example inches or millimeters.

8 Click OK.

The program adds a new block to the blocks list, with the name you entered for it.
  

A Enter the name of the block.
B Enter a description of the block.
C Select to pick the base point in the drawing after 

you click OK.
D Select to pick the base point now in the drawing.
E Displays the base point coordinates or you can 

enter them manually.
F Select to select entities to include in the block 

after you click OK.
G Click to select entities now in the drawing. 
H Select whether to keep, convert, or delete 

entities after the block is created.

I Click to select entities by type or value.
J Choose block units.
K Select to allow the block to be exploded into 

entities.
L Select to maintain aspect ratio if the block is 

scaled.
M Select to make the block, when located in paper 

space, oriented according to the layout viewport 
(available only if Annotative is marked).

N Mark to make the block annotative by default.

B
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To change a block name in the current drawing
1 Do one of the following to choose Explore Blocks ( ):

• On the ribbon, choose Tools > Blocks (in Explorer).

• On the menu, choose Tools > Explorer > Explore Blocks.

• On the Explorer toolbar, click the Explore Blocks tool.

• Type expblocks and then press Enter.

2 Do one of the following:

• Select the block, choose Edit > Rename, type a new name, and then press Enter.

• Click the block name you want to change, type a new name, and then press 
Enter.

• Right-click the block name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter.

3 To complete the command and return to your drawing, close the window.

Inserting a block
You can insert into a drawing any block listed in the Block Name list in the Explorer. 
This includes blocks contained within any open drawing (you copy and paste the 
block first) and also dynamic blocks that were created using a different CAD applica-
tion. 

To insert a block
1 Do one of the following to choose Explore Blocks ( ):     

• On the ribbon, choose Tools > Blocks (in Explorer).

• On the menu, choose Tools > Explorer > Explore Blocks.

• On the Explorer toolbar, click the Explore Blocks tool.

• Type expblocks and then press Enter.

2 If you want to insert a block from another open drawing, select the drawing in the 
left side of the Explorer window, copy the block, and paste it in the destination 
drawing. (If the block is contained within the same drawing, you can skip this 
step.)

3 Select the block to be inserted.

4 On the Explorer toolbar, click the Insert tool ( ).

5 In the drawing, specify the insertion point.    

If inserting a dynamic block, you can press Ctrl while left-clicking the mouse to 
cycle through block insertion points defined by its dynamic parameters.

6 Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, 
select Done.   

7 To complete the command and return to your drawing, close the window.
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The scale can easily be changed after insertion.
To change the scale of a block after insertion, choose Express Tools > Blocks > 
Block Scale. You can also change the position, scale, and rotation using the Proper-
ties pane.

Use a shortcut.
You can insert a block by choosing Tools > Explorer, and then double-clicking the 
name of the block you want to insert in the Block Name list. And, you can also insert 
a block from the Insert menu, see Chapter 13, “Working with other files in your 
drawings.” 

Inserting a drawing as a block      
You can insert another drawing as a block into the current drawing. After you do this, 
the block name is added to the Block Name list in the Explorer. Changes made later 
to the inserted drawing will not be reflected in this drawing.    

To insert a drawing as a block
1 Do one of the following to choose Explore Blocks ( ):     

• On the ribbon, choose Tools > Blocks (in Explorer).

• On the menu, choose Tools > Explorer > Explore Blocks.

• On the Explorer toolbar, click the Explore Blocks tool.

• Type expblocks and then press Enter.

2 On the Explorer toolbar, click the Insert External File Block tool ( ).    

3 In the Insert Block dialog box, select the drawing you want to insert, and then 
click Open.   

4 In the drawing, specify the insertion point.

5 Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, 
select Done.

6 To complete the command and return to your drawing, close the window.

The scale can easily be changed after insertion.
To change the scale of a block after insertion, choose Express Tools > Blocks > 
Block Scale. You can also change the position, scale, and rotation using the Proper-
ties pane.
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Saving a block as a separate drawing
You can save a block as a separate drawing, and then you can open and modify that 
drawing as you would any other drawing.     

To save a block as a separate drawing file
1 Do one of the following to choose Explore Blocks ( ):     

• On the ribbon, choose Tools > Blocks (in Explorer).

• On the menu, choose Tools > Explorer > Explore Blocks.

• On the Explorer toolbar, click the Explore Blocks tool.

• Type expblocks and then press Enter.

2 Select the block you want to save.

3 On the Explorer toolbar, click the Save Block tool ( ).

4 In the Save Block dialog box, select the folder in which you want to save the 
block.

5 In the File Name field, type a name for the new drawing file (or accept the default, 
in which case the new drawing name is the same as the name of the block), and 
then click Save.    
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Working with groups 

In IntelliCAD’s Explorer, you can manage groups — collections of entities saved 
together as one unit — that exist in an open drawing, create new groups, manage the 
entities contained in a group, and change the settings of groups. 

Displaying information about groups in the Explorer

To display groups in the Explorer
1 Do one of the following to choose Explore Groups ( ):    

• On the ribbon, choose Tools > Groups (in Explorer).

• On the menu, choose Tools > Explorer > Explore Groups.

• On the Format toolbar, click the Explore Groups tool.

• Type expgroups and then press Enter.

Creating a new group using the Explorer
To create a new group using the Explorer
1 Do one of the following:

• Choose Edit > New > Group.

• On the Explorer toolbar, click the New Item tool ( ).

A new group is added as Anonymous.

2 Type the name for the new group by typing over the highlighted default text, and 
then press Enter.

3 Click the [+] tool to select the entities to be included in the group; click the [-] tool 
to select the entities to remove from the group.

You can also click the Number of Entities column and choose Add Entities or 
Remove Entities.

4 Press Enter when done selecting entities.

5 To complete the command, close the window.
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Modifying groups

To modify a group using the Explorer
1 In the Explorer, select Groups.

2 To rename a group, do one of the following: 

• Select the group, choose Edit > Rename, type a new name, and then press Enter.

• Click the group name you want to change, type a new name, and then press 
Enter.

• Right-click the group name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter.

3 To add entities to a group, select the group and click the [+] tool, select the entities 
in the drawing to be included in the group, then press Enter when done selecting 
entities.

4 To remove entities from a group, select the group and click the [-] tool, select the 
entities in the drawing to remove from the group, then press Enter when done 
selecting entities.

5 To make a group selectable or unselectable in the drawing, click Selectable for it. 

6 To reorder the entities in a group, select the group and click the Reorder tool, 
make you selections, then click OK. 

7 To select a group in the drawing and have that group highlighted in the list of 
groups, click the Highlight tool, select the desired group, then press Enter. The 
appropriate group will be highlighted in the list.

8 To complete the command, close the window.   

For more details about working with groups, see “Grouping entities” on page 450. 
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Working with references to external files 

In IntelliCAD’s Explorer, you can work with any file that is referenced from an open 
drawing. In addition to commonly used xrefs, or externally referenced drawing files, 
you can manage other attached external files such as data links, raster images, .dwf 
files, .dgn files, .pdf files, and point clouds directly from the Explorer. If your pro-
gram version supports working with BIM files, you can also manage .ifc, .rvt, and .rfa 
files.

When you reference an external file from a drawing, the contents of referenced file 
appear in the current drawing, but the contents themselves are not added to the draw-
ing.

Displaying information about referenced files in the Explorer

To display information about referenced files
1 Do one of the following to choose Explore External References ( ):    

• On the ribbon, choose Tools > External References (in Explorer).

• On the menu, choose Tools > Explorer > Explore External References.

• On the Explorer toolbar, click the Explore External References tool.

• Type exprefs and then press Enter.

2 Do one of the following:

• Click the Icons tool ( ) to see a small image of each referenced file,

• Click the Details tool ( ) to see more detailed information about each block. 
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A Lists names of files referenced from the current 
drawing.

B Displays the load status of the file in the current 
drawing.

C Displays the number of times the file is 
referenced from the current drawing.

D Displays the size of the file.

E Displays the type of file.
F Displays the date of the file.
G Displays the location of the file.
H Click a column title to sort by category. Click and 

drag a column title to change the column order. 
Right-click a column title to choose which 
columns display or to restore all column settings 
to the default settings.
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Attaching referenced files

To attach an externally referenced file
1 Do one of the following to choose Explore External References ( ):     

• On the ribbon, choose Tools > External References (in Explorer).

• On the menu, choose Tools > Explorer > External References.

• On the Explorer toolbar, click the Explore External Reference tool.

• Type exprefs and then press Enter.

2 Do one of the following:

• Choose Edit > New > External Reference.

• On the Explorer toolbar, click the New Item tool ( ).

3 In Files of type, select the type of file to attach, then click Open.

4 Specify the insertion point for the file and complete the additional prompts.

5 To complete the command and return to your drawing, close the window.

After an external file is attached, the Manage Xrefs icon displays in the status bar, 
notifying that the drawing contains a linked external reference file.

Modifying the settings for referenced files
Any referenced file can be modified from the Explorer, including renaming, linking 
to a new location, clipping, and more.    

To change the name of a referenced file in the current drawing
1 Do one of the following to choose Explore External References ( ):

• On the ribbon, choose Tools > External References (in Explorer).

• On the menu, choose Tools > Explorer > Explore External References.

• On the Explorer toolbar, click the Explore External Reference tool.

• Type exprefs and then press Enter.

2 Do one of the following:

• Select the file, choose Edit > Rename, type a new name, and then press Enter.

• Click the file name you want to change, type a new name, and then press Enter.

• Right-click the file name you want to change, and from the shortcut menu, select 
Rename, type a new name, and then press Enter.

3 To complete the command and return to your drawing, close the window.
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To change the name of a referenced file in the current drawing
1 Do one of the following to choose Explore External References ( ):

• On the ribbon, choose Tools > External References (in Explorer).

• On the menu, choose Tools > Explorer > Explore External References.

• On the Explorer toolbar, click the Explore External Reference tool.

• Type exprefs and then press Enter.

2 Do one of the following:

• Select the file, choose Edit > Rename, type a new name, and then press Enter.

• Click the file name you want to change, type a new name, and then press Enter.

• Right-click the file name you want to change, and from the shortcut menu, select 
Rename, type a new name, and then press Enter.

3 To complete the command and return to your drawing, close the window.

To manage an externally referenced file
1 Do one of the following to choose Explore External References ( ):

• On the ribbon, choose Tools > External References (in Explorer).

• On the menu, choose Tools > Explorer > Explore External References.

• On the Explorer toolbar, click the Explore External Reference tool.

• Type exprefs and then press Enter.

2 Do one of the following:

• Select a file in the list, choose Edit, then the desired option.

• Right-click the desired file, and from the shortcut menu, select the desired 
option.

• Click either the Image Manager tool ( ) or the Xref Manager tool ( ).

3 To complete the command and return to your drawing, close the window.

For more details about working with external references, see “Working with external 
references” on page 571. 
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Working with layouts 

Each drawing that you create contains the area where you do most of your work on 
the Model tab and can also contain numerous layouts on Layout tabs that simulate the 
paper on which you will print a copy of the drawing.

Using the Explorer, you can manage the layouts in a drawing, assign a page setup, 
and you can also easily copy layouts to be reused in other drawings. 

Making a layout active in the Explorer is the equivalent of clicking its corresponding 
tab in the drawing window.

Displaying layouts in the Explorer

To display layouts in the Explorer
Do one of the following to choose Explore Layouts ( ):    

• On the ribbon, choose Tools > Layouts (in Explorer).

• On the menu, choose Tools > Explore Layouts.

• On the Explorer toolbar, click the Explore Layouts tool.

• Type explayouts and then press Enter.

• Choose Tools > Explorer, and then click the Views element. 
 

A Lists names of layouts defined in the current 
drawing. A check mark indicates the current 
layout.    

B Displays the coordinates of the lower-left corner 
of the layout.

C Displays the coordinates of the upper-right 
corner of the layout.

D Controls whether linetype scaling in layout 
viewports is always the same regardless of the 
zoom factor. (Layouts only; not the model.)

E Displays the number of viewports in the layout.
F Choose the page setup for the layout. Choose 

Page Setup Manager to modify page setups.
G Displays whether a layout is ready to print.
H Click a column title to sort by category. Click and 

drag a column title to change the column order. 
Right-click a column title to choose which 
columns display or to restore all column settings 
to the default settings.
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Creating and naming layouts
Each drawing can contain one layout for the model and up to 255 other layouts.

To create a new layout
1 Do one of the following to choose Explore Layouts ( ):     

• On the ribbon, choose Tools > Layouts (in Explorer).

• On the menu, choose Tools > Explorer > Explore Layouts.

• On the Explorer toolbar, click the Explore Layouts tool.

• Type explayouts and then press Enter.

2 Do one of the following:

• Choose Edit > New > Layout.

• Click the New Item tool ( ).

A new layout is added to the layouts list with a default name.

3 Type the name for the new layout by typing over the highlighted default text, and 
then press Enter.

4 To complete the command, close the window.

To change a layout name using the Explorer
1 Do one of the following to choose Explore Layouts ( ): 

• On the ribbon, choose Tools > Layouts (in Explorer).

• On the menu, choose Tools > Explorer > Explore Layouts.

• On the Explorer toolbar, click the Explore Layouts tool.

• Type explayouts and then press Enter.

2 Do one of the following:

• Select the layout, choose Edit > Rename, type a new name, and then press Enter.

• Click the layout name you want to change, type a new name, and then press 
Enter. 

• Right-click the layout name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter.

3 To complete the command and return to your drawing, close the window.

Specifying page setup options for a layout
Each layout can have its own page setup assigned to it. This enables you to accommo-
date unique print settings for each layout. If some layouts use the same print settings, 
those layouts can be assigned the same page setup.

Assigning a page setup to a model or layout doesn’t mean it will always print with the 
specified settings. All of the print settings specified for a page setup can be overrid-
den at print time.
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For more details about page setups, see “Working with page setups” on page 630. 

To assign a page setup to layouts   
1 Do one of the following to choose Explore Layouts ( ):     

• On the ribbon, choose Tools > Layouts (in Explorer).

• On the menu, choose Tools > Explorer > Explore Layouts.

• On the Explorer toolbar, click the Explore Layouts tool.

• Type explayouts and then press Enter.

2 Select one or more layouts.

3 In the Page Setup column for one of the layouts, select the desired page setup from 
the list.

4 To complete the command, close the Explorer window.

To modify the settings of an assigned page setup   
1 Do one of the following to choose Explore Layouts ( ):

• On the ribbon, choose Tools > Layouts (in Explorer).

• On the menu, choose Tools > Explorer > Explore Layouts.

• On the Explorer toolbar, click the Explore Layouts tool.

• Type explayouts and then press Enter.

2 In the Page Setup column for the desired layout, choose Page Setup Manager.

3 Select the page setup that requires changes, then click Modify.

4 Select the new options, then click OK.

5 If necessary, select the page setup that you want to assign to the layout, then click 
Set Current.

6 Click Close.

7 To complete the command, close the Explorer window.
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Working with materials

Materials are images or textures that enhance the visual appearance of entities when 
they are rendered. From IntelliCAD’s Explorer, you can use the Materials element to 
load materials from a material library to your drawing so your drawing contains only 
those materials you need, which helps reduce the drawing file size. You can also cut, 
copy, and paste materials from one drawing to another.

Once you import materials to the drawing in the Explorer, you can then assign them 
to entities and layers, include them in packages created with the eTransmit command, 
and render them with visual styles directly in IntelliCAD.

Display materials in the drawing using the Realistic visual style. For more details 
about working with visual styles, see “Using dynamic visual styles for hiding, shad-
ing, and rendering” on page 767. 

Displaying information about materials in the Explorer

To display materials in the Explorer
1 Do one of the following to choose Explore Materials ( ):    

• On the ribbon, choose Tools > Materials (in Explorer).

• On the menu, choose Tools > Explorer > Explore Materials.

• On the Format toolbar, click the Explore Materials tool.

• Type expmaterials and then press Enter.
 

A Choose to view the materials in a list or image view.
B Click to add materials to the drawing from the 

library so materials can be assigned to entities and 
layers.

C Choose to preview the selected material on the 
right as a cube, sphere, or plane.

D Double-click a material to set it as the current 
material.

E Lists the names of materials available in the current 
drawing.

F Displays the selected material on a shape.

E

A 

F

D 

B 
C 
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Importing materials to the drawing
Materials are stored in a library with an .icmat file extension. To reduce the file size 
of drawings, you import from the library only those materials you need in the draw-
ing.

Imported materials are stored in the drawing, and then you can work with them 
throughout IntelliCAD, including assigning them to entities and layers, include them 
in packages created with the eTransmit command, purge them, and display them on 
entities using any visual style other than 2D Wireframe.

To import materials to a drawing
1 Do one of the following to choose Explore Materials ( ):    

• On the ribbon, choose Tools > Materials (in Explorer).

• On the menu, choose Tools > Explorer > Explore Materials.

• On the Format toolbar, click the Explore Materials tool.

• Type expmaterials and then press Enter.

2 On the Explorer toolbar, click the Import Materials tool ( ). 

Use a shortcut.
At the command bar, type materialimport to open the Import Materials dialog box.

3 Right-click either list, and from the shortcut menu, choose how to view materials 
while you select them.

4 On the left, choose the category of materials you want to view.

5 On the right, select the materials you want to add to the drawing. Press Shift + 
click to select multiple materials.

6 Click Import.

The selected materials are added to the drawing and appear in the Material 
Explorer.

7 Click Close when done importing.

Materials of older file formats can be updated to the current format.
If you open a drawing that contains materials that were created in older formats, type 
CONVERTOLDMATERIALS at the command prompt to update them to the current 
format.
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Assigning materials to entities and layers
When you create new entities, they are drawn with the current material. To draw new 
entities with a different material, you must first make that material the current mate-
rial.   

You can also separately assign materials to specific entities and layers. 

To make a material current 
1 Do one of the following to choose Explore Materials ( ):    

• On the ribbon, choose Tools > Materials (in Explorer).

• On the menu, choose Tools > Explorer > Explore Materials.

• On the Format toolbar, click the Explore Materials tool.

• Type expmaterials and then press Enter.

2 Select the material you want to make current.

3 Do one of the following:

• Click the Current tool ( ).

• Double-click the material name. 

• Right-click the material name, and from the shortcut menu, select Current.

To assign a material to an entity
1 Do one of the following:    

• Drag-and-drop a material from the Materials Explorer to an entity.

• Select an entity and in the Properties pane, choose the desired material.

• Select an entity, type change, and follow the prompts to modify the material 
property.

To assign a material to a layer
1 Do one of the following to choose Explore Layers ( ):     

• On the ribbon, choose Home > Explore Layers (in Layers) or choose Tools > 
Layers (in Explorer).

• On the menu, choose Format > Explore Layers or choose Tools > Explorer > 
Explore Layers.

• On the Explorer toolbar, click the Explore Layers tool.

• Type explayers and then press Enter.

2 Click the Material column for the desired layer.

3 Select a material from the list. 
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Copying materials
You can copy and paste materials between drawings. In addition to the steps below, 
you can also select a material and use the Windows shortcut keys (Ctrl+A to select 
all, Ctrl+X to cut, Ctrl+C to copy, Ctrl+V to paste) to copy it in the Explorer. You can 
use these shortcut keys with all other Explorer elements as well.

To copy a material from one drawing to another
1 Do one of the following to choose Explore Materials ( ):    

• On the ribbon, choose Tools > Materials (in Explorer).

• On the menu, choose Tools > Explorer > Explore Materials.

• On the Format toolbar, click the Explore Materials tool.

• Type expmaterials and then press Enter.

2 Right-click the material you want to copy.

3 From the shortcut menu, select Copy.

4 If necessary, click Show as Dialog ( ) to display Material Explorer as a dialog 
box instead of a pane. (Panes display information about the current drawing only.)

5 On the left, select the drawing to which you want to copy the material.

6 Click the Materials element for that drawing.

7 On the right, right-click, and then from the shortcut menu, select Paste.

Each drawing contains a material named Global. 
You cannot delete or rename this material.    
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Getting drawing information

IntelliCAD stores accurate, detailed information about all the entities in a drawing. 
You can get details about an existing drawing and its entities using the tools for mea-
suring distances and calculating areas. You can create a table or external file that 
reports details about entities in one or more drawings. You can also track the amount 
of time you spend editing a drawing. This section explains how to:

• Measure distances along an entity.

• Measure distances and angles.

• Divide an entity into a number of equal segments.

• Calculate areas.

• Display information about entities in a drawing.

• Track the amount of time spent editing a drawing.

• Report and update information about entities in one or more drawings.

Many of the functions described in this section require that you set IntelliCAD to the 
Advanced experience level.

Topics in this chapter

Specifying measurements and divisions........................................................... 368

Calculating areas.............................................................................................. 372

Calculating distances and angles ..................................................................... 376

Displaying information about your drawing .................................................378

Reporting information about entities ..........................................................383
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Specifying measurements and divisions      

You can divide a line, arc, circle, polyline, ellipse, or spline into a number of equal 
segments or mark off intervals of a specific length along an entity. (Note that divide is 
not the same as break.) For example, you may want to place station-point markers 
every 50 feet along the centerline of a roadway or divide the plan view of a window 
into three equal-width sections of glass, placing a mullion at each division point.    

Understanding measurements and divisions
To specify measurements and divisions, use these commands:

• For the length of the segments, use the Measure command.

• For the number of equal-length segments, use the Divide command.

You can measure or divide arcs, circles, lines, polylines, ellipses, and splines. With 
either command, you can identify the segments by placing either a block or point 
entity at the end of each interval. If you use points, you can snap to the ends of inter-
vals using the point entity snap. The appearance of the point entities is determined by 
the current point display type, which you control in the Drawing Settings dialog box.    

To use a block as the marker, the block must already be defined in the current draw-
ing. You can further indicate whether to rotate the block to align perpendicularly to 
the entity you are measuring or dividing.  
 

IntelliCAD begins measuring or dividing based on the point at which you select the 
entity and the type of entity with which you are working. For most entities, measuring 
starts from the endpoint closest to the point you used to select the entity. If you select 
the entity to be measured or divided using a method other than pointing (for example, 
using a window or fence selection), the program prompts you to specify the end from 
which you want to begin measuring.

Block not aligned with entity. Block aligned with entity.
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Measuring intervals on entities
You can mark specified length increments along the length or perimeter of a selected 
entity using either a point entity or a block.    

You can measure intervals on lines, arcs, circles, ellipses, polylines, and splines.

To measure intervals along an entity and mark them using point entities
Advanced experience level

1 Do one of the following to choose Measure ( ):

• On the ribbon, choose Edit > Measure (in Modify).

• On the menu, choose Modify > Measure.

• On the Modify toolbar, click the Measure tool.

• Type measure and then press Enter.

2 Select the entity.

3 Specify the segment length, and then press Enter.

Points on the entity might not be visible immediately.
You can change the style and size of all points in the drawing. On the Drawing Set-
tings - Entity Creation tab, choose Points. Or type ptype in the command bar.

  

When you select the entity by pointing, intervals are measured from the end 
closest to the point at which you select the entity (A). Blocks or point entities (B) 
are placed along the entity at the specified interval.

A B
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To measure intervals along an entity and mark them using blocks 
Advanced experience level

1 Do one of the following to choose Measure ( ):    

• On the ribbon, choose Edit > Measure (in Modify).

• On the menu, choose Modify > Measure.

• On the Modify toolbar, click the Measure tool.

• Type measure and then press Enter.

2 Select the entity.

3 Choose Insert Blocks.

4 Type the name of the block you want to insert as the marker.

5 Choose either Yes-Align Blocks to rotate each insertion of the block so that its 
vertical alignment is always perpendicular to the entity or No-Do Not Align to 
insert each copy of the block with a zero rotation angle.

6 Specify the segment length, and then press Enter.
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Dividing entities into segments
You can place markers along a selected entity, dividing that entity into a specified 
number of equal-length segments. You can use either a point entity or a block to mark 
the segments.    

You can divide lines, arcs, circles, ellipses, polylines, and splines.

To divide an entity into equal segments and mark them using point entities
Advanced experience level

1 Do one of the following to choose Divide ( ):    

• On the ribbon, choose Edit > Measure (in Modify).

• On the menu, choose Modify > Divide.

• On the Modify toolbar, click the Divide tool.

• Type divide and then press Enter.

2 Select the entity.

3 Specify the number of segments, and then press Enter.

Points on the entity might not be visible immediately.
You can change the style and size of all points in the drawing. On the Drawing Set-
tings - Entity Creation tab, choose Points. Or type ptype in the command bar.

  

When you select the entity by pointing, divisions are marked beginning from the end closest to the 
point at which you select the entity (A). Blocks or point entities (B) are placed along the entity to 
mark it in equal intervals.

A

B
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To divide an entity into equal segments and mark them using blocks    
Advanced experience level

1 Do one of the following to choose Measure ( ):

• On the ribbon, choose Edit > Measure (in Modify).

• On the menu, choose Modify > Divide.

• On the Modify toolbar, click the Divide tool.

• Type divide and then press Enter.

2 Select the entity.

3 Choose Insert Blocks.

4 Type the name of the block you want to insert as the marker.

5 Choose either Yes-Align Blocks to rotate each insertion of the block so that its 
vertical alignment is always perpendicular to the entity or 
No-Do Not Align to insert each copy of the block with a zero rotation angle.

6 Specify the number of segments, and then press Enter.

Calculating areas       

You can calculate the area and perimeter of entities or areas defined by points you 
specify. You can also determine the area of several combined entities and add or sub-
tract the area of one or more entities from a total combined area.

Calculating areas defined by points
You can find the area and perimeter of any closed region by specifying a series of 
points. The program calculates the area and perimeter of the space that is enclosed by 
an imaginary polygon consisting of straight-line segments connecting each point.

To calculate the area defined by points you specify
1 Do one of the following to choose Area ( ):

• On the ribbon, choose Tools > Area (in Inquiry).

• On the menu, choose Tools > Inquiry > Area.

• On the Inquiry toolbar, click the Area tool.

• Type area and then press Enter.

2 Specify the first point.

3 Specify the second point.
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4 Continue specifying points in sequence to define the perimeter of the area you 
want to measure.

As you select each successive point, the resulting polygon is displayed on the 
screen.

5 To complete the calculation, press Enter.

The calculations of the area you defined are displayed. For example, the following 
type of information is displayed:

Area = 11.0583, Perimeter = 15.3092  

  

Calculating areas of entities
You can find the area of entities, such as circles, arcs, ellipses, polylines, polygons, 
splines, 3D solids, facet model meshes, and planes.

In addition, the program calculates the perimeter of the entity, depending on the type of 
entity you select.

To calculate the area of an entity
1 Do one of the following to choose Area ( ):

• On the ribbon, choose Tools > Area (in Inquiry).

• On the menu, choose Tools > Inquiry > Area.

• On the Inquiry toolbar, click the Area tool.

• Type area and then press Enter.

2 Choose Entity.

3 Select the entity.

The following type of information is displayed:

Area = 62.3837, Perimeter = 27.9989

Select the points (A, B, C) that form a polygon. The area and 
perimeter are then calculated.

A

C

B



374 C H A P T E R  9
Calculating combined areas  
You can find the total area of several entities or defined areas. You can also subtract 
the areas of entities or polygons from a running total.

To calculate the total area of entities
1 Do one of the following to choose Total Area ( ):

• On the ribbon, choose Tools > Total Area (in Inquiry).

• On the menu, choose Tools > Inquiry > Total Area.

• On the Inquiry toolbar, click the Total Area tool.

• Type totalarea and then press Enter.

2 Select the entities you want to calculate the area for.

The following type of information is displayed:

Total area = 62.3837 sq. units

3 Continue selecting (or deselecting) entities to display the running total area.

4 When finished, press Enter.

To add areas to calculate a combined area    
1 Do one of the following to choose Area ( ):

• On the ribbon, choose Tools > Area (in Inquiry).

• On the menu, choose Tools > Inquiry > Area.

• On the Inquiry toolbar, click the Area tool.

• Type area and then press Enter.

2 Choose Add.

3 Using one of the following methods, identify the first area:

• Specify points defining a polygon, and then press Enter. Continue to specify 
points to define more areas to include in calculations.

• Choose Entity, select the entities you want to add, and then press Enter to 
complete the calculations.

4 To complete the command, press Enter.
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To subtract areas when calculating a combined area    
1 Do one of the following to choose Area ( ):    

• On the ribbon, choose Tools > Area (in Inquiry).

• On the menu, choose Tools > Inquiry > Area.

• On the Inquiry toolbar, click the Area tool.

• Type area and then press Enter.

2 Choose Add.

3 Using one of the following methods, identify the total area to subtract from:

• Specify points defining a polygon, and then press Enter. Continue to specify 
points to define more areas to include in calculations

• Choose Entity, select the entities you want to add to the total running area, and 
then press Enter to complete the calculations.

4 Choose Subtract.

5 Using one of the following methods, identify the area to be subtracted:

• Specify points defining a polygon, and then press Enter. Continue to specify 
points to define more areas to subtract from the total running area.

• Choose Entity, select the entities you want to subtract, and then press Enter to 
complete the calculations.

6 To complete the command, press Enter.

To calculate the area of the gasket using the Area command, first add 
the area of the entire gasket (A), and then subtract the areas of the two 
circles (B and C).

A
B

C
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Calculating distances and angles            

You can calculate the distance between any two points you select to determine the 
following information:      

• The distance between the points, measured in drawing units.

• Their angle in the xy plane.

• Their angle measured from the xy plane.

• The change (delta) in the x, y, and z distances between the two points.

You can also determine the running total length of entities in a selection set.     

Calculating the distance between two points or entities
When calculating the distance between points using the Distance command, it is often 
helpful to use entity snaps to specify precise points.     

To calculate the distance between two points and their angle
1 Do one of the following to choose Distance ( ):    

• On the ribbon, choose Tools > Distance (in Inquiry).

• On the menu, choose Tools > Inquiry > Distance.

• On the Inquiry toolbar, click the Distance tool.

• Type distance and then press Enter.

2 Specify the first point.

3 Specify the second point.
 

Use the Distance command to calculate the distance (A) between two points (B 
and C), the angle in the xy plane (D), the angle from the xy plane, and the delta 
x (E), delta y (F), and delta z distances between the two points.

A

B D

E

F

C
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Calculating the total length of entities
You can calculate the length of any selected entities using the Total Length com-
mand.  

To calculate the total length of entities
1 Do one of the following to choose Total Length ( ):

• On the ribbon, choose Tools > Total Length (in Inquiry).

• On the menu, choose Tools > Inquiry > Total Length.

• On the Inquiry toolbar, click the Total Length tool.

• Type totallength and then press Enter.

2 Select the entities you want to calculate the length for. The total length displays in 
the command bar.

3 Continue selecting entities to display the running total length.

4 When finished, press Enter.

Viewing calculated distance details
As you select entities, the program displays the calculations. If the command bar is 
displayed, the information appears there. If the command bar is not displayed, the 
program opens the Prompt History window and displays the calculations. The follow-
ing type of information is an example of what is displayed:

Distance = 13.2850, Angle in XY Plane = 31º, Angle from XY Plane = 0º

Delta X = 11.3878, Delta Y = 6.8418, Delta Z = 0.0000 
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Displaying information about your drawing      

You can display a variety of information about a drawing and the entities it contains, 
including:    

• Information in the drawing database about selected entities.

• The current drawing status.

• The time spent working on the drawing.

This information is displayed in the Prompt History window and in the command bar.    

Displaying information about entities
You can display information about the selected entities. The information varies, 
depending on the type of entities you select. All of the listings display the following 
information:    

• Entity type.     

• Layer.

• Color.

• Linetype.   

• The location of the entity (its xyz-coordinates relative to the current user 
coordinate system [UCS]).     

• The current space (model space on the Model tab or paper space on a Layout tab).     

• The size of the entity (the information varies, depending on the entity type).    

To display information about an entity
Advanced experience level     

1 Do one of the following to choose List Entity Info ( ):

• On the ribbon, choose Tools > List Entity Info (in Inquiry).

• On the menu, choose Tools > Inquiry > List Entity Info.

• On the Inquiry toolbar, click the List Entity Info tool.

• Type list and then press Enter.

2 Select one or more entities.

3 Press Enter.

Use a shortcut.  
To return to the drawing window, press F2.
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The following type of information is displayed:

------ Circle ---------------------------------------------------

Handle: 2C

Current space: Model

Layer: 0

Color: BYLAYER

Linetype: CONTINUOUS

Handle: 4C

Current space: Model

Center point: X= -5.8583 Y= 7.2752 Z= 0.0000

Radius: 4.4562

Circumference: 27.9989

Area: 62.383y

Displaying property information about external references and 
blocks
You can display property information about a selected external reference or block. 
All of the listings display the following information:   

• Entity type

• Name

• Color  

• Layer 

• Linetype and linetype scale   

• Print style

• Lineweight

• Material

• Transparency

• Thickness

To display property information about an external reference or block
1 Do one of the following to choose List Xref/Block Properties ( ):

• On the ribbon, choose Express Tools > List Xref/Block Properties (in Blocks).

• On the menu, choose Express Tools > Blocks > List Xref/Block Properties.

• Type xlist and then press Enter.

2 Select an external reference or block.
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Displaying the drawing status
You can display information about the current status of a drawing, including:    

• Drawing name.

• Limits.     

• Insertion base point.     

• Snap and grid settings.

• Current layer, color, and linetype.     

• Current settings for various modes (fill, grid, orthogonal, snap, blips, and so on).    

To display the drawing status
Advanced experience level

Do one of the following to choose Drawing Status ( ):    

• On the ribbon, choose Application button > Drawing Utilities > Drawing Status or 
choose Tools > Drawing Status (in Inquiry).

• On the menu, choose Tools > Inquiry > Drawing Status.

• On the Inquiry toolbar, click the Drawing Status tool.

• Type status and then press Enter.
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The following type of information is displayed:    
Current drawing name: Site Plan

Drawing limits are: X=0.0000 Y=0.0000 Z=0.0000

X=12.0000 Y=9.0000 Z=0.0000

Paper space limits are: X=0.0000 Y=0.0000 Z=0.0000

X=12.0000 Y=9.0000 Z=0.0000

Screen width (pixels): 971

Screen height (pixels): 569

Insertion base is: X=0.0000 Y=0.0000 Z=0.0000

Snap resolution is: X=0.5000 Y=0.5000 Z=0.0000

Grid spacing is: X:0.5000 Y:0.5000 Z=0.0000

Current layer: 0

Current color: BYLAYER

Current linetype: BYLAYER

Current elevation: 0.0000

Current thickness: 0.0000

Fill: on

Grid: off

Ortho: off

Snap: off

Blips: off

Drag: on

Command echo: on

Positive angle direction: Counterclockwise

Angular units: Decimal degrees

Dimension units: Decimal

Pick box height: 3

Entities in drawing: 288
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Tracking time spent working on a drawing
You can display information about the amount of time you have spent working on a 
drawing, including:    

• The date and time the drawing was created.

• The date and time the drawing was most recently saved.    

• The total amount of time spent working on the drawing.

• The time spent working on the drawing during the current editing session.    

You can turn the elapsed-time timer on and off or reset it to zero.   

To display the timer information
Advanced experience level    

1 Do one of the following to choose Time Variables ( ):

• On the ribbon, choose Tools > Time Variables (in Inquiry).

• On the menu, choose Tools > Inquiry > Time Variables.

• On the Inquiry toolbar, click the Time Variables tool.

• Type time and then press Enter.

2 Select any of the prompt box options:

• Choose Timer On to turn the elapsed timer on.

• Choose Timer Off to turn the elapsed timer off.

• Choose Display Timer to redisplay the timer information.

• Choose Reset Timer to reset the elapsed timer to zero.

3 In the prompt box, choose Cancel to exit the command.

Each time you display the timer information, the following type of information is 
displayed:

The current time is Fri Dec 19 09:58:43 1997

Drawing was created on: Wed 17 Dec 1997 at 16:17:59.8090

Drawing was last updated on: Thur 18 Dec 1997 at 09:58:43.3040

Total editing time: 1  2: 35:4.2345

Elapsed timer (on): 0  1: 21:5.6324    
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Reporting information about entities 

Information about entities can be collected from one or more drawings into reports 
such as entity lists, schedules, and parts lists. The extracted information can include 
property settings, entity area calculations, coordinate positions, and more.

First you create a report template that contains the settings for the type of report you 
need, for example, you can include only block entities with annotative properties and 
control the order in which the columns display. Then the report template can be used 
to create a report for any drawing file.

Reports are created as tables in the current drawing or as external .xls or .csv files. If 
you create a table in the drawing with report data, the table contents can later be 
updated to include the latest information about referenced entities.

Creating a report
When you create a report, entity information is extracted from one or more drawings 
and can be included in the drawing as a new table or in an external .xls or .csv file.

To create a report
1 Do one of the following to choose Extract Data ( ):

• On the ribbon, choose Insert > Extract Data (in Data) or Annotate > Extract Data 
(in Tables).

• On the menu, choose Insert > Extract Data.

• Type dataextraction and then press Enter.

2 Choose one of the following:

• Create New Report Template Creates a report based on a new report template 
that you save as an .idxe file. To optionally create the new report template based 
on an existing one, mark Start with Existing Report Template, then click [...] to 
select the report template (.idxe) file.

• Edit Existing Report Template Creates a report based on an existing report 
template that you can modify. Click [...] to select the report template (.idxe) file.

• Reuse Existing Report Template Creates a report for the current drawing based 
on an existing report template without modifications. Click [...] to select the 
report template (.idxe) file.

3 Click Next and make your selections. Click [?] for more details about each option.
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Updating report data
Tables created with the Extract Data command contain data that is linked to the enti-
ties used to create them. As entities and drawings change, you can automatically 
update the contents of tables that contain report data.

To update report data in a table
1 Select any cell of a table that contains report data.

2 Right-click the cell.

3 Choose Data Extraction > Update Data Extraction.

Table contents can also be unlinked.
To remove the link between a table that contains report data and referenced entities, 
select any cell of the table, right-click the cell, then choose Data Extraction > Detach 
Data Extraction.
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Modifying entities

IntelliCAD provides many editing tools for modifying a drawing. You can easily 
move, rotate, or stretch drawing entities, or change their scale. When you want to 
remove an entity, you can delete it with a few clicks of the mouse. You can also make 
multiple copies of any entity and copy entities from one drawing to another. 

You can modify most entities using general-purpose editing commands. Some com-
plex entities require special commands. This section explains how to:

• Select entities using entity-selection methods and grips.

• Change the properties of entities.

• Hiding, isolating, and deleting entities.

• Rearrange entities by moving, rotating, or changing the display order.

• Resize entities by stretching, scaling, extending, trimming, or editing their lengths.

• Split and combine entities by breaking, joining, exploding, and grouping them.

• Edit polylines.

• Create chamfers and fillets.

Topics in this chapter

Selecting entities............................................................................................... 386

Modifying the properties of entities................................................................... 406

Hiding and isolating entities .............................................................................. 414

Deleting entities ................................................................................................ 415

Copying entities ................................................................................................ 415

Rearranging entities.......................................................................................... 430

Resizing entities................................................................................................ 436

Splitting and combining entities ........................................................................ 444

Editing polylines................................................................................................ 454

Chamfering and filleting entities........................................................................ 460
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Selecting entities       

You can create a selection set that consists of one or more entities for modification. 
Use any of the following methods to create a selection set:    

• Choose a command or tool first, and then select entities.

• Select entities first, and then choose a command or tool (most entities).

• Select entities by clicking while not in a command, and then use grips to modify 
them.

Understanding when to select entities
You can select entities before or after you choose a command. 

Selecting entities first
When you select entities and then issue a command, the program immediately acts on 
the entities you’ve selected. For example, you can select an entity and its properties 
automatically display in the Properties pane or you can right-click the selection set to 
display a prompt box with various options to choose from. 

After you select one or more entities, you can choose an entity-modification com-
mand, such as the Copy or Move command or use grips to modify the entities. You 
can also click the right mouse button to display a shortcut menu containing the entity-
modification commands appropriate for the selected entities, and then choose the 
command from the menu.

You can control whether selection is allowed before using commands. 
Choose Tools > Drawing Settings, click the Coordinate Input tab then the Entity 
Selection tab, and mark Pre-pick to allow selection before using commands.

If grips are turned on, grips also display for entities that are selected before issuing a 
command. For more information, see “Using grips” on page 401 in this chapter. 

Choosing a command first    
When you choose an entity-modification tool or command first, the program prompts 
you to select entities and displays a prompt box from which you can choose a selec-
tion method. You can select individual entities or use other techniques such as selec-
tion windows to select multiple entities.

When you select entities, you add them to the selection set. After you select at least 
one entity, you can remove entities from the selection set. To finish adding entities to 
the selection set, press Enter. Most entity-modification commands then act on the 
entire selection set.    
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Understanding entity-selection methods    
When you choose a command that requires you to select entities (when you’re delet-
ing or modifying entities, for example), you can use any of the following selection 
methods by choosing them in the prompt box or entering them in the command bar:    

Entity-selection methods
Selection method Command bar Description
Select all 
entities

ALL Selects all entities in the current drawing.  

Add to set + or A Adds one or more entities to the selection set.   

Subtract from set - or R Removes one or more entities from the selection set.   

Previous selection P Selects entities included in the previous selection set.   

Last entity in 
drawing

L Selects the entity most recently added to the drawing.    

Window-Inside W Selects entities contained entirely within a rectangular 
selection window.    

Crossing window C Selects entities contained within or crossing the boundary of 
a rectangular selection window.    

Outside window O Selects entities falling completely outside a rectangular 
selection window.   

Window polygon WP Selects entities contained entirely within a polygon selection 
window.    

Crossing polygon CP Selects entities contained within or crossing the boundary of 
a polygon selection window.   

Outside polygon OP Selects entities falling completely outside a polygon selection 
window.    

Window circle WC Selects entities contained entirely within a circular selection 
window.   

Crossing circle CC Selects entities contained within or crossing the boundary of 
a circular selection window.   

Outside circle OC Selects entities falling completely outside a circular selection 
window.    

Point PO Selects any closed entities that surround the selected point.   

Fence F Selects entities crossing a line or line segments.   

Quick Select QSELECT Selects entities by type according to a specified value or 
range of values.   

Select by 
Properties

PRO Selects entities that match a particular set of properties—for 
example, all entities on a particular layer or drawn in a certain 
color.   
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You can also use a few selection methods automatically, without displaying the 
prompt box: 

• Click one or more entities to select them.

• Shift+ click to add or remove an entity from the selection set.

• Click an entity to select it, then Ctrl + click to cycle through the entities below the 
cursor, selecting one at a time.

• Click two opposite corners of a rectangular selection window. The direction in 
which you define the points of the rectangle (left-to-right or right-to-left) deter-
mines which type of window you create.

Selecting multiple entities can be affected by the PICKADD setting.
If you select one or more additional entities while entities are already selected, the 
additional entities can either replace or add to the existing selection set. Click ( ) 
on the Properties pane or use the PICKADD system variable to toggle what happens 
when selecting multiple sets of entities.

Selecting entities by clicking them
You can click entities to select them. 

To select entities by clicking them
1 Click an entity. 

Selecting entities by drawing a selection window
You can draw a selection window to include the entities contained within the win-
dow.

To create a selection window from left to right
1 Click to select a point in the drawing.    

2 Click to the right of the first point to select a second point in the drawing.
 

Window-Inside by selecting the first (A) and second (B) 
points.

Resulting selection.

A

B
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To create a selection window from right to left
1 Click to select a point in the drawing.    

2 Click to the left of the first point to select a second point in the drawing.  
 

In addition to a rectangular window, you can define a selection window using other 
shapes such as a polygon or circle.

To select entities using a polygon selection window 
1 Activate an entity-modification command.    

2 In the prompt box, choose Window Polygon.

3 Specify the vertices of the polygon.

4 To complete the selection polygon, press Enter. 

Crossing Window by selecting the first (A) and second 
(B) points.

Resulting selection.

A

B

Window Polygon by specifying the vertices of the 
polygon (A, B, and C).

Resulting selection.

A

C

B
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Selecting entities using a fence
A selection fence is a multisegmented line that selects entities it crosses.

To select entities using a fence 
1 Activate an entity-modification command.

2 In the prompt box, choose Fence.

3 Specify the endpoints of the Fence segments.

4 To complete the Fence, press Enter.  
  

Filtering entity selection
Filtering a selection is an efficient way to select a set of entities that have something 
in common. For example, you can select all entities with the same property such as 
color, all entities that are proxies, or all entities with the same value, block name, or 
type. You can even add or remove more filters to a set of entities to further customize 
the selection.

Selecting entities by property
IntelliCAD makes it easy to select entities according to their common properties, 
allowing you to modify large sets of entities quickly and efficiently. When selecting 
entities, simply use a filter to add or remove entities according to these common prop-
erties: color, layer, linetype scale, linetype, lineweight, thickness, and width.

Use the List command to get more information for filtering. 
If you are unsure what properties are available for filtering, type list to select an area 
of the drawing and list the selected entities and their properties.

Fence by specifying the endpoints of the fence segments 
(A, B, and C).

Resulting selection.

A

B

C
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To select entities by property using a properties filter
1 Activate an entity-modification command, or type select.

2 Choose Filter.

3 Choose a filter option: 

• Color — Enter the color of entities you want to select.

• Layer — Enter the layer name of entities you want to select.

• LinetypeScale — Enter the linetype scale of entities you want to select.

• Linetype — Enter the linetype of entities you want to select.

• Lineweight — Enter the lineweight of entities you want to select.

• Thickness — Enter the thickness of entities you want to select. Note that some 
entities have thickness, however, lines, circles, arcs, and polylines all have 
thickness.

• Width — Enter the width of entities you want to select. Note that only polylines 
have width.

Names of properties are case sensitive.
For example, a drawing with layers SAMPLE Layer 1, sample Layer 2, and SAM-
PLE Layer 3 will return no selection if you specify “SAMPLE” for the layer name. 
Specifying “SAMPLE*” returns two layers, “*Layer*” returns all layers, and 
“sample*” returns one layer.

4 If desired, add or remove more entities using a filter:

• Choose any other filter option to add more entities to the selection set.

• Choose Remove to remove entities from the selection set according to the filter 
you choose next.

A prompt displays the total number of entities in the selection set.

5 To complete the selection, press Enter.
 

Selection by specifying the smaller of two lineweight 
properties.

Resulting selection.
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Selecting proxy entities using a filter
Proxy entities are entities or custom objects that IntelliCAD does not support. When a 
drawing containing proxy entities is loaded into IntelliCAD, a message displays indi-
cating that some entities will not display, however, the entities reappear when you 
open the drawing later in a CAD application that supports those entities. 

Proxy entities can be selected using  typical selection methods, but they can also be 
selected using a filter, for example, you might want to select all proxies and place 
them on a hidden layer or delete them if you know they won’t be needed in the future.

To select proxy entities using a filter
1 Activate an entity-modification command, or type select.

2 Choose Filter.

3 Choose Proxy. 

4 If desired, add or remove more entities using a filter:

• Choose any other filter option to add more entities to the selection set.

• Choose Remove to remove entities from the selection set according to the filter 
you choose next.

A prompt displays the total number of entities in the selection set.

5 To complete the selection, press Enter. 

Selecting blocks of the same name
Some drawings contain many of the same blocks, which are easy to select as a set 
using a filter.

Use the List command to get block names. 
If you are unsure what blocks are available for filtering, type list to select an area of 
the drawing and list the selected entities and their block names.

To select entities by block name
1 Activate an entity-modification command, or type select.

2 Choose Filter.

3 Choose Block.

4 Enter the block name of the entities you want to select.

5 If desired, add or remove more entities using a filter:

• Choose any other filter option to add more entities to the selection set.

• Choose Remove to remove entities from the selection set according to the filter 
you choose next.

A prompt displays the total number of entities in the selection set.

6 To complete the selection, press Enter. 
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Selecting entities by type
You can filter entities in a selection set according to their type, for example, a circle, 
line, text, attribute, or block type.

Use the List command to get type names. 
If you are unsure what entity types are available for filtering, type list to select an 
area of the drawing and list the selected entities and their types.

To select entities by type using the filter option
1 Activate an entity-modification command, or type select.

2 Choose Filter.

3 Choose Type. 

4 Enter the type name (a string value) of the entities you want to select.

5 If desired, add or remove more entities using a filter:

• Choose any other filter option to add more entities to the selection set.

• Choose Remove to remove entities from the selection set according to the filter 
you choose next.

A prompt displays the total number of entities in the selection set.

6 To complete the selection, press Enter. 

Use the Selection pane and the Quick Select command to select entities by type. 
You can also type selfilter or qselect to select entities by type.
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Selecting entities by value
You can filter entities in a selection set according to common properties and their val-
ues. For example, you can filter a selection set to include all the entities that are the 
color red and use the Dashed2 linetype, and then change the value of the linetype.

To select entities by value using the Selection Filter pane
1 Do one of the following to choose Selection Filter ( ):

• On the ribbon, choose Edit > Selection Filter (in Selection) or View > Selection 
Filter (in Panes).

• On the menu, choose Edit > Selection > Selection Filter or View > Display > 
Selection Filter.

• Type selfilter and then press Enter.

• Press Ctrl+2.

2 Click the Layer, Color, Entity Type, or Linetype tab.

The Selection Filter pane lists all layers, colors, entity types, and linetypes that are 
available in the drawing.

3 In the On column, select a corresponding cell to either include or exclude all enti-
ties with the corresponding value. The clicked cell then displays blank (selection 
is off) or with a black circle (selection is on), depending on its status before click-
ing it. 

This can affect the On status of other values on other tabs. The On column for all 
tabs indicates the following:

• Blank — No entities with the corresponding value are selected in the drawing.

• Black circle — All entities with the corresponding value are selected in the 
drawing. 

• Gray circle — Only some entities with the corresponding value are selected in 
the drawing (due to specified values on other tabs or your entity selections in the 
drawing).
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A Click to include a new entity in the current 
selection set.

B Click to start a new selection. After you select 
an entity, the previous selection is cleared.

C Displays all layers, colors, entity types, or 
linetypes that are available in the drawing 
depending on the selected tab.

D Click to change the selection to include or 
exclude all entities with the corresponding 
value.

E Click a tab to view and select entities in the 
drawing according to their assigned layer, 
color, entity type, linetype, or lineweight.

F Click to deselect all entities.
G With entities selected, click then window-

select the currently selected entities and the 
additional entities you want to invert selection 
for.

H Click to exclude an entity from the selection 
set.

A

C D

B
E
F
G
H
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To select entities by value using Quick Select
1 Do one of the following to choose Quick Select ( ):

• On the ribbon, choose Home > Quick Select (in Utilities) or Edit > Quick Select 
(in Selection).

• On the menu, choose Edit > Selection > Quick Select or Tools > Quick Select.

• On the Properties pane or Save Block to Disk dialog box, click the Quick Select 
tool.

• Type qselect.

2 In Apply To, specify which entities to consider for selection. For example, select 
Entire Drawing to consider all entities in the drawing. To specify a portion of the 
drawing to consider for selection, click ( ) and make your selection directly in 
the drawing.

3 In Entity Type, specify the type of entity you want to select.

4 Specify the property to filter for selection, its operator, and value. The options 
vary by entity type. 

5 Select one of the following:

• Include in New Selection Set Creates a new selection that includes only those 
entities that meet the selected options.

• Exclude from New Selection Set Creates a new selection set that includes all of 
the entities except those that meet the selected options.

6 To add the newly selected entities to a current selection set (available if entities 
were selected before using the Quick Select command), mark Append to Current 
Selection Set.

7 Click OK.
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To select entities by value using the filter option
1 Activate an entity-modification command, or type select.

2 Choose Filter.

3 Choose Value. 

4 Enter the value (a string) of the entities you want to select.

5 If desired, add or remove more entities using a filter:

• Choose any other filter option to add more entities to the selection set.

• Choose Remove to remove entities from the selection set according to the filter 
you choose next.

A prompt displays the total number of entities in the selection set.

6 To complete the selection, press Enter. 

Use the List command to get values. 
If you are unsure what values are available for filtering, type list to select an area of 
the drawing and list the selected entities and their values.

A Choose which entities to consider for 
selection.

B Choose the type of entity to select.
C Choose the desired property.
D Choose how to compare the value and 

property.
E Choose the desired value.

F Choose whether to include or exclude 
selected entities in the new selection set.

G Select to add the newly selected entities to a 
previously specified selection set (if available).

H Click to specify a portion of the drawing to 
consider for selection. The option Current 
Selection will appear in Apply To.

A

C

H
B

D
E

F

G
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Selecting entities that match the properties of other entities
You can select all entities in a drawing that have the same color, layer, linetype, line-
type scale, lineweight, print style, entity style, name, entity type, or any combination 
of these properties. First you select one or more entities that have the properties you 
want to match, then you specify which properties to search for and match. The 
matched entities are then added to the selection set.

The selection set can be reused in other commands either through the pick-first selec-
tion or by selecting the previous selection.

To select entities that match one or more properties of other entities
1 Do one of the following to choose Select Similar ( ):

• On the ribbon, choose Edit > Select Similar (in Selection) or Express Tools > 
Select Similar (in Tools).

• On the menu, choose Edit > Selection > Select Similar or Express Tools > Tools 
> Select Similar.    

• Type selectsimilar and then press Enter.

2 Select one or more entities that have the properties you want to match.

3 Choose Settings.

4 In the Select Similar Settings dialog box, mark the properties of the selected enti-
ties that you want to match.

The SELECTSIMILARMODE system variable also controls the dialog box settings.
See the System Variables online help for details about using this system variable.

5 Click OK. 

Entities with matched properties are added to the selection set.
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Creating filters used to select entities
Creating a filter that you can reuse is helpful if you regularly filter entities using the 
same parameters. Reusable filters are as easy to create even for complicated selection 
sets. 

To create a filter used to select entities
1 Do one of the following to choose Filter ( ):

• On the ribbon, choose Edit > Filter (in Selection).

• On the menu, choose Edit > Selection > Filter.    

• Type filter and then press Enter.

2 In Select Filter, select an item for the filter list. For example, choose Line to 
include line entities in the selection set.

3 Specify the item’s parameters if necessary. For example, if you chose Linetype, 
click Select to choose the linetype; if you chose Line End, enter the x-, y-, and z-
coordinates.

4 Click Add to List.

5 Repeat for additional filter items, and include operators as necessary:

• AND — Add BEGIN AND before one or more items to add them; add END 
AND after the items.

• OR — Add BEGIN OR before one or more items to compare them and include 
only one; add END OR after the items.

• XOR — Add BEGIN XOR before multiple items to specify exclusions; add 
END XOR after the items.

• NOT — Add BEGIN NOT before one item to specify an exclusion; add END 
NOT after the item.

6 In Save As, enter a filter name.

7 Click Save As.

To select entities using a filter you created
1 Do one of the following to choose Filter ( ):

• On the ribbon, choose Edit > Filter (in Selection).

• On the menu, choose Edit > Selection > Filter.    

• Type filter and then press Enter.

2 In Current, select the desired filter.

3 Click Apply.
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A Lists the parameters that define the filter.
B Select an item to include in the filter.
C Enter the x-, y-, and z-coordinates if applicable 

to the filter item.
D Click to add the specified item to the filter.
E Click to add the currently selected entity in the 

drawing to the filter.
F Click to replace the currently selected line in 

the filter list with the currently specified item.
G Click to specify a value for the selected filter 

item.

H Click to delete the named filter that is selected 
in Current.

I Click to save the filter.
J Enter a name for the filter.
K Select a previously saved filter to load it.
L Click to edit the settings of the currently 

selected line in the filter.
M Click to remove all line items from the filter.
N Click to remove the currently selected line item 

from the filter.

B

A

M

C

D
E

H

J
I

K

F G

L

N
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Deselecting entities
If an entity is no longer needed in a selection set, you can deselect it to remove it from 
the selection set.

To remove an entity from the selection set
1 Press Shift, and then select the entity again.

Use a shortcut. 
Pressing Shift while selecting entities using a crossing window removes all entities 
from the specified selection set.

To remove all entities from the selection set
1 Press Escape.

Using grips
To use grips for editing, you select one or more entities to display the grips, and then 
click a grip to make it active and use it. You do not need to enter a command to use 
grips.    

Grips have different shapes which indicate different behaviors. For example, moving 
a line’s arrow grip changes the line length but not the angle, and moving a line’s 
square grip changes the endpoint — both the line length and angle. 

There are two types of grips: 

• Entity grips — Grips that display for each selected entity and allow you to quickly 
move and scale entities one-by-one.

• Selection set grips — Grips that display for an entire selection set and allow you to 
quickly move, scale, and rotate all selected entities. This type of grip can be help-
ful for schematic drawings where precise scale or sizing is not required.

The grip you select depends on the type of grips that are active, the type of entity 
you’re modifying, and the editing operation you’re performing. For example, to move 
a line entity with entity grips active, drag it by its midpoint grip. To stretch the line, 
drag one of the endpoint grips. With selection grips active, however, you move a line 
entity by repositioning the base point grip. 
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Changing grip settings
You can turn the use of grips on and off, control the size and color of grips, and deter-
mine how grips display for blocks, groups, and selection sets.

To change grip settings
1 Do one of the following to choose Drawing Settings ( ):

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type ddgrips and then press Enter.

2 In the Drawing Settings dialog box, click the Display tab.

3 Click the Grips tab.

4 Mark Display Grips to activate grips.

• In Block Grips, choose from the following:

• Insertion point grip — Choose to enable a single grip that displays at the 
insertion point of the block.

• Grips within blocks — Choose to enable grips for each entity within the block.

• Advanced grips — Choose to enable a set of advanced grips to move, rotate and 
scale the whole block. Use side grips for non-uniform scaling; use corner grips 
for uniform scaling.

5 In Group Grips, choose from the following:

• Grips within groups Choose to enable grips for each entity within the group.

• Center point grip Choose to display a single grip at the center of the group.

• Center point grip and bounding box Choose to display a single grip at the center 
of the group and a bounding box.

• Advanced grips Choose to enable a set of advanced grips to move, rotate and 
scale the whole group.

6 Mark Advanced Selection Set Grips if you want to display a single set of advanced 
grips for all selected entities. These grips can be helpful for schematic drawings 
where precise scale or sizing is not required.

7 In Grip Size, specify the size of the grip square.

8 In Grip Color, select the color for grips.

9 Click OK. 
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Using entity grips for editing 
You can select entities while not in a command and then modify the entities using 
grips, which are small squares and arrows that display on each entity. Grips appear at 
strategic points on the entity according to the selected entity.       

The locations of entity grips depend on the type of entity selected. For example, grips 
appear at the endpoints and midpoint of a line, at the quadrant points and center point 
of a circle, and at the endpoints, midpoint, and center of an arc. 

Arrow grips are different from square grips. For example, the arrow grips on a line 
allow you to change the line length but at the same angle. Square grips at the end of 
lines allow you to change the endpoints, that is, the length and the angle. 

Depending on your grip settings, blocks and groups can have unique grips that allow 
you to edit each entity within the block or group, or the entire block or group, includ-
ing uniform and non-uniform scaling. 

A Select to turn on the display of grips.
B Select how you want grips to display for 

selected blocks.
C Select how you want grips to display for 

selected groups.

D Select to turn on the display of advanced grips 
for selection sets.

E Click to choose the color of grips.
F Enter the size of the grip box.
G Displays a preview of grips.

A

E

F

GB

C
D
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To edit while using entity grips
1 Make sure entity grips are turned on. For details, see “Changing grip settings” on 

page 402. 

2 Click an entity to select it and display grips.

3 Click a grip to make it active. 

4 Do any of the following:

• Drag the grip to move it.

• Choose a command, such as Base Point or Move.

Using selection grips for editing 
With selection grips you can quickly move, scale and rotate all selected entities. 
Selection grips are particularly useful for schematic drawings where precise scale or 
sizing is not required. In addition, this standard interface for manipulating images and 
objects in Windows applications, can be helpful to  users who may not be familiar 
with precision CAD editing interfaces.

Selection grips are similar to entity grips, but they display as a single set of grips for 
all entities in the selection set.

The locations of selection grips are uniform for the selection set. Grips at the corners 
of the selection set are for scaling, the bottom center grip is for moving, the top grip is 
for rotating, and the center grip is for positioning the base point. When a single block 
is selected, additional grips appear for non-uniform scaling for all three axis. 

Examples of entity grip locations.
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To edit using selection grips
1 Make sure selection grips are turned on. For details, see “Changing grip settings” 

on page 402. 

2 Click an entity to select it and display selection grips. If you select more than one 
entity, a single set of selection grips displays for the entire selection set.

3 Click a grip to make it active. 

4 Drag the grip to move it.

Customizing the display of selected entities
You can make selections easier to see by specifying whether to display selected enti-
ties with a dashed line or highlighted. By default, selected entities are highlighted.    

To customize the display of selected entities
1 Do one of the following to choose Drawing Settings ( ):     

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the Display tab.

3 Click the secondary Display tab.

4 Select or clear the Highlight Item When Selected check box.

5 Click OK. 

Example of selection grip locations. The rotation grip is located at the top and the move grip is located at the 
bottom center.
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Modifying the properties of entities    

You can change the layer, thickness, linetype, color, and linetype scale of one or 
more entities. Depending on the type of entity or entities you select, you can also 
change other properties, such as the start point and endpoint of lines, the center point 
and radius of circles, and the vertices of polylines.    

The typical way to change entity properties is using the Properties and Quick Proper-
ties panes. You can also change general properties using the Entity Properties toolbar. 
Note that the Entity Properties toolbar settings that display when no entities are 
selected determine the properties of new entities when you draw them.

Modifying entity properties by using the Properties pane
Use the Properties pane to select properties for any entity. The options that display in 
the Properties pane depend on the type of entity that is selected and whether more 
than one entity is selected.

If no entities are selected, the Properties pane displays various default settings for the 
drawing that you can also modify.

To use the Properties pane to modify properties of entities 
1 Do one of the following to choose Properties ( ):

• On the ribbon, choose View > Properties (in Panes).

• On the menu, choose View > Display > Properties or Modify > Properties.    

• On the Modify toolbar, click the Properties tool.

• Type entprop and then press Enter.

• Press Ctrl +1.

The Properties pane displays.

2 Select the desired entities.

3 Make changes to the properties. The available properties vary according to the 
entities you selected.
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A Displays the types of entities in the selection 
set.

B Click to display entity types as a flat list or a 
hierarchical list.

C Specify properties that are common for most 
entities.

D Specify properties for 3D visualization.
E Specify properties specific to the selected 

geometry.

F Click to clear any previous selection and start 
selecting entities in the drawing.

G Click to select entities by type according to 
specified values.

H Click to display or hide the Selection Filter 
pane.

I Click to determine whether the current 
selection set is replaced by or added to 
subsequent entities that you select.

G
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Modifying entity properties by using the Quick Properties pane
Compared with the Properties pane which typically displays in a large size and 
remains open until you close it manually, the Quick Properties pane displays in a 
smaller size and opens and closes dynamically. This allows you to access entity-spe-
cific properties dynamically when you need them without crowding available screen 
space. The pane displays automatically when you double-click an entity that does not 
have a double-click action assigned to it (for example, multiline text), and it closes 
automatically when you choose a subsequent command or action, or press Esc. The 
pane can also be set up to display automatically when you select an entity using a sin-
gle-click, crossing window, etc. when a command is not active.

The Quick Properties pane generally doesn’t display all properties of an entity, but 
you can easily open the Properties pane directly from the Quick Properties pane to 
work with all properties, if needed. The list of properties available in the Quick Prop-
erties pane for each entity type is customizable using the Customize UI command. 
For more details, see “Customizing the Quick Properties pane” on page 914. 

To use the Quick Properties pane to modify properties of entities 
1 Do one of the following to display the Quick Properties pane:

• Double-click an entity.

• Select entities using any selection method. The Quick Properties pane displays 
if it is turned on for selection; press Ctrl + Shift + P, choose Quick Properties 
On/Off in the status bar when no entities are selected, or type dsettings and use 
the Quick Properties tab.

• Type quickproperties, select entities, then press Enter.

2 Make changes to the properties. The available properties vary according to the 
entities you selected and the properties specified to display in the Quick Properties 
pane for each entity type.
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To change the behavior of the Quick Properties pane
1 Do one of the following to choose Drawing Settings ( ):

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

• On the status bar, right-click Quick Properties On/Off, then choose Settings.

2 Click the Quick Properties tab.

3 To turn on the display of the Quick Properties pane when an entity is selected in 
the drawing (in addition to double-clicking):

• Mark Display the Quick Properties Pane on Selection.

• Choose All Entities to display the pane when any entity is selected or choose 
Only Entities with Specified Properties to display the pane only for entities that 
are specified in the Customize User Interface dialog box. For more details, see 
“Customizing the Quick Properties pane” on page 914. 

A Displays the types of entities in the selection 
set. Select from the list to change properties 
for an entity type.

B Click to display a menu of options, including 
pane location and settings that determine how 
quick properties work.

C Specify properties specific to the selected 
geometry.

D Specify properties that are most common.
E Click to open the Properties pane and view a 

complete set of properties for selected entities. 
Available only if the Properties pane is not 
displayed.

F Click to open the Customize User Interface 
dialog box to manage the properties that 
display in this pane for each entity type. 

FA

C

E
B

D
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Use a shortcut.
To change whether the Quick Properties pane displays on selection, press 
Ctrl + Shift + P or click Quick Properties On/Off in the status bar when no enti-
ties are selected.

4 To specify the default position of the Quick Properties pane when it displays, 
choose one of the following:

• Cursor-dependent — Displays relative to the cursor location, below and to the 
right of the cursor.

• Static — Displays in a fixed location without reference to the cursor. To specify 
a new location, click and drag the pane. The next time the pane opens, it displays 
at the same location.

5 To display a collapsed version of the Quick Properties pane until the cursor hovers 
over it, when it then automatically expands to display all defined quick properties 
for the selected entity, do the following:

• Mark Collapse Pane Automatically.

• In Minimum Number of Rows, enter the number of properties to display when 
the pane displays as collapsed.

6 Click OK.
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A Select to turn on the display of the Quick 
Properties pane when selecting entities.

B Choose whether the pane displays when any 
entity is selected or only for assigned entities. 
Available only when displaying the pane on 
selection is turned on.

C Select to display the pane relative to the 
cursor location or in a fixed location.

D Select to display a collapsed version of the 
pane until the cursor hovers over it.

E Enter the number of properties to display when 
the pane displays as collapsed. Available only 
when displaying the pane as collapsed is 
turned on.

A

E

B

C

D
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Modifying the properties of multiple entities
You can modify all the properties of all selected entities simultaneously. For exam-
ple, using the entprop command, select all entities on a particular layer, and then 
move the entities to another layer by simply selecting a name from the Layer text box. 
Additionally, using the select command and the Select by Properties option, select all 
blue entities and change their color to green.

In the Properties pane, changes that you make in the Layer, Color, Thickness, Line-
weight, Linetype, Linetype Scale, and Print Style (if using named print style tables) 
fields affect all selected entities. To change the properties of a single entity in the 
selection set, choose the entity from the list at the top of the Properties pane. 

You can select the entities to be changed using any entity-selection method.    

Changing multiple properties to ByLayer
The Set to ByLayer command sets properties of selected entities to ByLayer. Proper-
ties that can be changed using the Set to ByLayer command include: color, linetype, 
lineweight, material, print style, and transparency.
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To modify properties of entities 
1 Do one of the following to choose Set to ByLayer ( ):

• On the ribbon, choose Home > Set to ByLayer (in Layers).

• On the menu, choose Format > Layer Tools > Set to ByLayer.    

• On the Layer Tools toolbar, click the Set to ByLayer tool.

• Type setbylayer and then press Enter.

2 Press Enter.

3 In the SetByLayer Settings dialog box, make your selections for the properties you 
want to change:

• Color — Resulting entities will have a Color property set to ByLayer.

• Linetype — Resulting entities will have a Linetype property set to ByLayer.

• Lineweight — Resulting entities will have a Lineweight property set to 
ByLayer.

• Material — Resulting entities will have a Material property set to ByLayer.

• Print Style — Resulting entities will have a Print Style property set to ByLayer.

• Transparency — Resulting entities will have a Transparency property set to 
ByLayer.

4 Click OK.

5 At the prompt, select the desired entities.

6 Choose Yes to change any found ByBlock properties to ByLayer. Otherwise, 
choose No.

7 Choose Yes to change the properties of blocks that are selected. Blocks must be on 
unlocked layers. Otherwise, choose No.
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Hiding and isolating entities

You can temporarily hide selected entities or isolate selected entities so that all 
remaining entities are temporarily hidden. When you’re ready to view all entities 
again, use the Unisolate Entities command.    

You can also hide and isolate entities by assigning them a layer that you hide or iso-
late. For more details about layers, see “Organizing information on layers” on page 
275. 

To hide a selection set    
1 Do one of the following to choose Hide Entities ( ):

• On the status bar, click Isolate/Unisolate Entities, and then choose Hide Entities.

• Type hideobjects, and then press Enter.

2 Select the entities you want to make invisible, and then press Enter.

All selected entities are hidden.

To isolate a selection set    
1 Do one of the following to choose Isolate Entities ( ):

• On the status bar, click Isolate/Unisolate Entities, and then choose Isolate 
Entities.

• Type isolateobjects, and then press Enter.

2 Select the entities you want to remain visible, and then press Enter.

All other entities are hidden.

To unhide and unisolate entities    
1 Do one of the following to choose Unisolate Entities ( ):

• On the status bar, click Isolate/Unisolate Entities, and then choose Unisolate 
Entities.

• Type unisolateobjects, and then press Enter.
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Deleting entities

You can remove entities from a drawing. You can delete entities using any of the 
entity-selection methods.    

To delete a selection set    
1 Do one of the following to choose Delete ( ):

• On the ribbon, choose Home > Delete (in Modify) or choose Edit > Delete (in 
Modify).

• On the menu, choose Edit > Delete.

• On the Standard (or Modify) toolbar, click the Delete tool.

• Type delete and then press Enter.

2 Select the entities, and then press Enter.

Typing the Undelete command restores the most recently deleted selection set. 
If you have made additional modifications since deleting the entities, use Undelete 
rather than Undo to restore those entities without reversing those modifications.    

The Overkill command deletes extra entities all at once. 
If a drawing has overlapping or duplicate entities that you want to delete or combine, 
for example polylines with too many vertices, use the Overkill command to clean up 
the drawing.

Copying entities    

You can copy one or more entities, making one copy or multiple copies within the 
current drawing. You can also copy entities between drawings.    

Use any of the following methods to copy entities within the current drawing:

• Create a copy at a location referenced from the original.

• Create a copy aligned parallel to the original.

• Create a copy as a mirror image of the original.

• Create several copies in a rectangular or circular pattern.
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Copying entities within a drawing
You can duplicate entities within the current drawing. The default method is to create 
a selection set and then specify a starting point, or base point, and an endpoint, or dis-
placement point, for the copy. You can also make multiple copies or copy the selec-
tion set to a location you specify, using a direction vector. You can also create an 
array of copied entities; for more details, see “Arraying entities” on page 423 in this 
chapter.      

In addition to copying regular entities in a drawing, you can also copy entities that are 
contained within blocks, external references, and underlays. 

To copy a selection set    
1 Do one of the following to choose Copy ( ):

• On the ribbon, choose Edit > Copy (in Modify).

• On the menu, choose Modify > Copy.

• On the Modify toolbar, click the Copy tool.

• Type copy and then press Enter.

2 Select the entities, and then press Enter.

3 Specify the base point.

4 Specify the insertion point. 

5 Continue specifying insertion points to place additional copies.

6 To complete the command, press Enter.  
     

To make a single copy of an entity, select the 
entity to copy (A), base point (B), and then 
displacement point (C).

Result.

A B

C
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Use a shortcut. 
Press and hold Ctrl, then click and drag the left mouse button to copy a selected 
entity.

Use a system variable. 
The COPYMODE system variable controls whether you are prompted for multiple 
copies.

Use the Move/Copy/Rotate command.
You can move, copy, rotate, and scale selected entities using a single command. 
Choose the Move/Copy/Rotate express tool or type mocoro.

To copy nested entities within blocks, external references, or underlays   
1 Do one of the following to choose Copy Nested Entities ( ):

• On the ribbon, choose Express Tools > Copy Nested Entities (in Blocks).

• On the menu, choose Express Tools > Blocks > Copy Nested Entities.

• Type ncopy and then press Enter.

2 Select the entities nested within blocks, external references, or underlays, and then 
press Enter.

3 Specify the base point.

4 Specify the insertion point. 

5 Continue specifying insertion points to place additional copies.

6 To complete the command, press Enter.  

To make multiple copies of an entity, select the 
entity to copy (A), specify the base point (B), and 
then specify the displacement points (C, D, and 
E).

Result.

A

B
C

D
E
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Copying between drawings
You can use the Clipboard to cut or copy entities from one drawing to another. 
Cutting removes the selected entities from a drawing and stores them on the 
Clipboard. Copying duplicates the selected entities from a drawing and places them 
on the Clipboard. Pasting places the Clipboard contents in a drawing, and depending 
on the command you choose, at the same or different coordinates as the entities in the 
original drawing.    

To cut entities to the Clipboard
1 Select the entities you want to cut.

2 Do one of the following to choose Cut ( ):   

• On the ribbon, choose Edit > Cut (in Modify).

• On the menu, choose Edit > Cut.

• On the Standard toolbar, click the Cut tool.

• Type cutclip and then press Enter.

To copy entities to the Clipboard
1 Select the entities you want to copy.

2 Do one of the following to choose Copy to Clipboard ( ):

• On the ribbon, choose Home > Copy to Clipboard (in Clipboard).

• On the menu, choose Edit > Copy to Clipboard.

• On the Standard toolbar, click the Copy to Clipboard tool.

• Type copyclip and then press Enter.

Anything that you can copy to the Clipboard can be pasted into a drawing. The format 
in which the program adds the Clipboard contents to the drawing depends on the type 
of information in the Clipboard. For example, if you copy IntelliCAD drawing enti-
ties to the Clipboard, the program pastes them into the drawing as IntelliCAD enti-
ties. If you copy items to the Clipboard from other programs, they are pasted into the 
current drawing as embedded ActiveX® objects. 

Sometimes the format you want to paste is not available on the Clipboard.
This is mostly likely due to the settings on the Clipboard tab in Tools > Options. For 
details, see “Changing the options on the Selection Cycling tab” on page 863. 
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To paste entities from the Clipboard
1 Do one of the following to choose Paste ( ):     

• On the ribbon, choose Home > Paste (in Clipboard) or choose Edit > Paste (in 
Modify).

• On the menu, choose Edit > Paste.

• On the Standard toolbar, click the Paste tool.

• Type pasteclip and then press Enter.

2 Specify the insertion point. 

To paste entities from the Clipboard to their original coordinates
1 Do one of the following to choose Paste to Original Coordinates ( ):     

• On the ribbon, choose Edit > Paste to Original Coordinates (in Modify).

• On the menu, choose Edit > Paste to Original Coordinates.

• Type pasteorig and then press Enter.

Clipboard contents can also be inserted as a block.
Type pasteblock to convert Clipboard contents into a block upon insertion.

Copying between spaces
You can copy entities from model space to paper space or from paper space to model 
space. You must be viewing a Layout tab that has at least one layout viewport in 
order to copy entities between spaces. You can also move entities between spaces 
using the same Change Space command.  

For more details about model space and paper space, see “Understanding paper space 
and model space” on page 616. 

To copy entities between spaces
1 Click a Layout tab.

2 Select the entities you want to copy.

3 Do one of the following to choose Change Space ( ):   

• On the ribbon, choose Edit > Change Space (in Modify).

• On the menu, choose Modify > Change Space.

• On the Modify toolbar, click the Change Space tool.

• Type chspace and then press Enter.

4 Choose Copy.
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If using the command bar, the Copy option can get confused with crossing selections.
To use the Crossing selection method, type the full keyword “crossing”. Typing “c” 
calls the Copy option.

Cloning entities
Cloning an entity is similar to copying it, except you draw the new entity with its own 
geometric values. The entity type and properties (such as layer, color, linetype, line-
weight, transparency, thickness) are copied and are the same as the entity that you ini-
tially select.

To clone an entity    
1 Do one of the following to choose Clone ( ):

• On the ribbon, choose Home > Clone (in Draw) or Edit > Clone (in Modify).

• On the menu, choose Modify > Clone.

• Type addselected or clone and then press Enter.

2 Select the entity that you want to clone. The current properties are set to match the 
selected entity, and the corresponding entity-creation command starts.

3 Follow the prompts to create a new entity. The prompts vary depending on the 
type of selected entity.

When the command is finished, properties such as layer, color, etc., are reset to 
their default values.
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Making parallel copies
You can use the offset feature to copy selected entities and align them parallel to the 
original entities at a specified distance. You can make parallel, offset entities using 
arcs, circles, ellipses, elliptical arcs, lines, two-dimensional polylines, rays, and infi-
nite lines.    

Making parallel, offset copies of curved entities creates larger or smaller curves, 
depending on which side of the original entity you place the copy. For example, plac-
ing a parallel copy of a circle outside the circle creates a larger concentric circle; posi-
tioning the copy inside the circle creates a smaller concentric circle.

To make a parallel copy by specifying the distance 
1 Do one of the following to choose Offset ( ):

• On the ribbon, choose Edit > Offset (in Modify).

• On the menu, choose Modify > Basic Editing > Offset.

• On the Modify toolbar, click the Offset tool.

• Type offset and then press Enter.

2 Specify the distance by selecting two points or by entering a distance.

3 Select the entity to copy.

4 Specify on which side of the entity to place the parallel copy.

5 Select another entity to copy, or press Enter to complete the command. 
 

To make a parallel copy, specify the distance between copies 
by entering a distance or selecting two points (A and B), select 
the entity to copy (C), and specify on which side to place the 
copy (D).

Result.

A

B

C

D
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To make a parallel copy passing through a point
1 Do one of the following to choose Offset ( ):     

• On the ribbon, choose Edit > Offset (in Modify).

• On the menu, choose Modify > Basic Editing > Offset.

• On the Modify toolbar, click the Offset tool.

• Type offset and then press Enter.

2 In the prompt box, choose Through Point.

3 Select the entity to copy.

4 Specify the point for the entity to pass through.

5 Repeat steps 3 and 4, or press Enter to complete the command. 
  

Use additional offset options.
When first starting the Offset command, you can choose Erase to determine whether 
the source entity is deleted after it is offset and Layer to determine on which layer the 
offset entities are created.

To make a parallel copy passing through a point, select the entity to copy (A) and then specify the through 
point (B).

A

B
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Mirroring entities    
You can create a mirror image of an entity. You mirror the entity about a mirror line, 
which you define by specifying two points in a drawing. You can delete or retain the 
original entities.    

To mirror entities
1 Do one of the following to choose Mirror ( ):     

• On the ribbon, choose Edit > Offset (in Modify).

• On the menu, choose Modify > Mirror.

• On the Modify toolbar, click the Mirror tool.

• Type mirror and then press Enter.

2 Select the entity, and then press Enter.

3 Specify the first point of the mirror line.

4 Specify the second point of the mirror line.

5 In the prompt box, choose one of the following:

• Yes, Delete Entities – deletes the original entities.

• No, Keep Entities – retains the original entities.
   

Arraying entities
You can copy an entity in a pattern that creates an array. There are several ways to 
create arrays:

• Linear array — Use the Copy command to control the number of copies in the 
array and the line along which the copies are placed.

• Rectangular array — Use the Rectangular Array command to control the number 
of copies in the array by specifying the number of rows and columns. You also 
specify the distance between each row and column. 

• Polar (circular) array — Use the Polar Array command to control the number of 
copies that compose the array and whether to rotate the copies.     

To mirror an entity, select it (A), and then specify the 
first point (B) and second point (C) of the mirror line.

Result.

A B

C
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• Path array — Use the Path Array command to control the number of copies that 
compose the array and whether to rotate the copies.    

Rectangular, polar, and path arrays can be associative, which means the individual 
entities contained in the array relate to one another and behave more like a block or 
group. Associative arrays can be easily edited using the Edit Array command. 

To create a linear array    
1 Do one of the following to choose Copy ( ):

• On the ribbon, choose Edit > Copy (in Modify).

• On the menu, choose Modify > Copy.

• On the Modify toolbar, click the Copy tool.

• Type copy and then press Enter.

2 Select the entities, and then press Enter.

3 Specify the start point of the line along which you want to place entities.

4 Choose Array.

5 Enter the number of items in the array, then press Enter.

6 Specify the second point of the line along which you want to place entities; this is 
the point where the first entities in the array will be placed. Or if you choose Fit, it 
is the point where the last entities in the array will be placed.

7 Continue specifying points to place additional copies if desired, or press Enter 
when done.

To create a rectangular array
1 Do one of the following to choose Rectangular Array ( ):     

• On the ribbon, choose Home > Rectangular Array (in Modify) or Edit > Rectan-
gular Array (in Modify).

• On the menu, choose Modify > Rectangular Array.

• On the Modify toolbar, click the Rectangular Array tool.

• Type arrayrect and then press Enter.

2 Select the entities to include in the array, and then press Enter.

3 Accept the default settings by pressing Enter again or continue with the next steps.

4 If you want to create an array with associative entities, choose Associative, then 
choose Yes.

5 To specify a new base point for the array, choose Base Point, then specify a new 
base point for the array in the drawing.
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6 To specify the number of rows and columns (a rectangular array must have at least 
two rows or two columns), do any of the following:

• Choose Count, enter the number of columns, then enter the number of rows.

• Choose Columns, enter the number of columns, then specify the amount of 
horizontal space you want between each column in the array.

• Choose Rows, enter the number of rows, then enter the amount of vertical space 
you want between each row in the array, then enter the increasing or decreasing 
elevation for each subsequent row.

7 To specify spacing between columns or rows directly in the drawing, do the fol-
lowing:

• Choose Spacing.

• Choose Unit cell.

• Select two corners of a rectangle that represents the vertical and horizontal 
distance between rows and columns.

8 To specify the number of levels, choose Levels, enter the number of levels, then 
enter the amount of space you want between each level in the array. Positive and 
negative values create levels in opposite directions along the z-axis.

  

To create a rectangular array, select the entity to copy (A), type the number of rows and columns, and then 
specify the distance between each row (B) and column (C).

A

B

C
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To create a polar array    
1 Do one of the following to choose Polar Array ( ):

• On the ribbon, choose Home > Polar Array (in Modify) or Edit > Polar Array 
(in Modify).

• On the menu, choose Modify > Polar Array.

• On the Modify toolbar, click the Polar Array tool.

• Type arraypolar and then press Enter.

2 Select the entities to include in the array, and then press Enter.

3 Select the center point around which you want the entities arrayed.

4 Accept the default settings by pressing Enter again or continue with the next steps.

5 If you want to create an array with associative entities, choose Associative, then 
choose Yes.

6 To specify a new base point for the array, choose Base Point, then specify a new 
base point for the array in the drawing.

7 Specify two of the following values:

• Items — Enter the number of items to create in the array, including one for the 
original selection set.

• Fill angle — Enter the angle the array will fill: 0 to 360 degrees. The default 
setting for the angle is 360 degrees. Positive values create the array in a counter-
clockwise direction; negative values create the array in a clockwise direction.

• Angle between — Enter the angle between the arrayed items. The default setting 
is 90 degrees.

8 To specify the number of rows, do the following:

• Choose Rows.

• Enter the number of rows.

• Enter the amount of vertical space you want between each row in the array.

• Enter the incrementing elevation between rows. The default value 0 creates a 
two-dimensional array. Positive values create each subsequent row with an 
increasing elevation; negative values create each subsequent row with a 
decreasing elevation.

9 To set automatic orientation of items in the array, choose Rotate, then choose Yes. 
Automatic rotation orients subsequent items to match the angle of the path curve.

10 To specify the number of levels, choose Levels, enter the number of levels, then 
enter the amount of space you want between each level in the array. Positive and 
negative values create levels in opposite directions along the z-axis.
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To create a path array
1 Do one of the following to choose Path Array ( ):     

• On the ribbon, choose Home > Path Array (in Modify) or Edit > Path Array (in 
Modify).

• On the menu, choose Modify > Path Array.

• On the Modify toolbar, click the Path Array tool.

• Type arraypath and then press Enter.

2 Select the entities, and then press Enter.

3 Select a line, polyline, three-dimensional polyline, spline, helix, arc, circle, or 
ellipse to use for the path of the array.

4 Accept the default settings by pressing Enter again or continue with the next steps.

5 To specify a new base point for the array, choose Base Point, then specify a new 
base point for the array in the drawing.

6 To specify the distribution of array items along the path, choose Method, then do 
one of the following:

• Choose Divide to place a specified number of copies that are evenly distributed 
along the entire length of the path. 

• Choose Measure to place copies along the path at a specified distance between 
them.

7 To specify the alignment of arrayed items relative to the start direction of the path, 
choose Tangent Direction, then do the following: 

• Specify the first point on the entity. Or choose Normal to align the z- direction 
of the first item with the starting direction of the path.

• Specify the second point on the entity.

To create a polar array, select the entity to copy (A), specify the center point of the array (B), and then 
specify other options.

A

B
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8 To specify the number of items in the array, choose Items. The prompts that fol-
low depend on the setting selected in Method:

• Specify number of items: Specify the number of copies of selected entities you 
want in the array. Displays if Divide is the Method setting.

• Specify the distance between items: Enter the distance to use between arrayed 
entities. Displays if Measure is the Method setting.

• Enter number of items: The maximum number of items required to fill the entire 
length of the path is automatically calculated. You can specify a smaller number 
of items if needed.

9 To specify the number of rows, do the following:

• Choose Rows.

• Enter the number of rows.

• Enter the amount of vertical space you want between each row in the array.

• Enter the incrementing elevation between rows. The default value 0 creates a 
two-dimensional array. Positive values create each subsequent row with an 
increasing elevation; negative values create each subsequent row with a 
decreasing elevation.

10 To specify the alignment of arrayed items relative to each other, choose Align 
Items, then choose Yes to make all items follow the alignment of the path, or 
choose No to specify a parallel alignment of arrayed items.

11 To maintain the z-direction of arrayed items, choose Z Direction, then choose Yes 
to make all items follow the z-direction of the path, or choose No to specify a par-
allel alignment of arrayed items in the z- direction.

12 To specify the number of levels, choose Levels, enter the number of levels, then 
enter the amount of space you want between each level in the array. Positive and 
negative values create levels in opposite directions along the z-axis.

  

To create a path array, select the entity to copy (A), select the path (B), and then specify other options.

A B
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To edit an associative array
1 Do one of the following to choose Edit Array ( ):     

• On the ribbon, choose Home > Edit Array (in Modify) or Edit > Edit Array (in 
Modify).

• On the menu, choose Modify > Edit Array.

• On the Modify toolbar, click the Edit Array tool.

• Type arrayedit and then press Enter.

2 Select the array you want to edit. 

3 To edit the array by modifying one of its arrayed items, do the following:

• Choose Edit Source.

• Select one of the items in the array. 

• Modify the item as you would modify any entity in the drawing. You can also 
create new entities to include them in the source array item. 

4 To edit the array by replacing its items with other entities, do the following:

• Choose Replace Item.

• Select new source entities to use as a replacement.

• Specify a base point for placing each replacement entity in the array.

• Select the array item that you want to replace with the new source entities. 
Continue selecting array items for replacement. Or choose Source entities to 
replace all array items with the new source entities.

5 To reverse modifications, choose Reset Array, which reverses edits one by one.

6 Continue editing the array. The options vary depending on the type of array you 
are editing, and most editing options are the same as the array creation options 
described previously.

7 When finished, click Close Array ( ) on the ribbon (if the ribbon is supported in 
your program version) or choose Exit.
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Rearranging entities    

You can move one or more entities, and you can also rotate entities about a specified point. 
If you have entities that overlap, you can also change the display order. 

Moving entities    
You can move entities around within the current drawing or from one drawing to 
another. The default method is to create a selection set and then specify a starting 
point, or base point, and an endpoint, or displacement point, to define the relocation 
of the entities. You can also relocate the entities using a direction vector.    

To move a selection set
1 Do one of the following to choose Move ( ):     

• On the ribbon, choose Edit > Move (in Modify).

• On the menu, choose Modify > Move.

• On the Modify toolbar, click the Move tool.

• Type move and then press Enter.

2 Select the entities, and then press Enter.

3 Specify the base point.

4 Specify the displacement point. 
  

Use shortcuts. 
Press Ctrl + arrow keys to move selected entities. 

Click and drag the left mouse button to move selected entities. If you often move enti-
ties accidentally using the mouse, you can turn off this feature by unmarking Use 
Click-Drag to Move Selected Entities on the Display tab of the Drawing Settings dia-
log box.

To move an entity, select it (A), and then specify the 
base point (B) and the displacement point (C).

Result.

A

B

C
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Use additional commands to move entities.
You can move, copy, rotate, and scale selected entities using a single command. 
Choose the Move/Copy/Rotate command or type mocoro.

You can move entities interactively using a three-dimensional visual aid, which also 
works for two-dimensional entities. Choose the 3D Positioner command or type 
3dpositioner.

You can also move entities using grips. To move an entity using grips, select the 
entity to display its grips, and then click a grip and drag it. The grip you select 
depends on the type of entity you’re modifying. For example, to move a line entity, 
select the midpoint grip. To move a curved entity, such as an arc, circle, or ellipse, 
select the center point grip. Not all entities can be moved using grips.    

To move an entity using grips
1 Select the entity.

2 Click a grip to select it.

3 Drag the entity to where you want to relocate it.

4 Click to release.

Moving entities between spaces
You can move entities from model space to paper space or from paper space to model 
space. You must be viewing a Layout tab that has at least one layout viewport in 
order to move entities between spaces. You can also copy entities between spaces 
using the same Change Space command. 

For more details about model space and paper space, see “Understanding paper space 
and model space” on page 616. 

To move entities between spaces
1 Click a Layout tab.

2 Select the entities you want to move.

3 Do one of the following to choose ( ):   

• On the ribbon, choose Edit > Change Space (in Modify).

• On the menu, choose Modify > Change Space.

• On the Modify toolbar, click the Change Space tool.

• Type chspace and then press Enter.

4 Choose Move.
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Rotating entities    
You can rotate entities about a specified point at a specified rotation angle or by an 
angle referenced to a base angle. The default method rotates the entities using a rela-
tive rotation angle from their current orientation.    

To rotate a selection set
1 Do one of the following to choose Rotate ( ):     

• On the ribbon, choose Edit > Rotate (in Modify).

• On the menu, choose Modify > Rotate.

• On the Modify toolbar, click the Rotate tool.

• Type rotate and then press Enter.

2 Select the entities, and then press Enter.

3 Specify the rotation point.

4 If desired, choose Copy to rotate a copy of selected entities.

5 Specify the rotation angle. 
  

To rotate a selection set in reference to a base angle
1 Do one of the following to choose Rotate ( ):

• On the ribbon, choose Edit > Rotate (in Modify).

• On the menu, choose Modify > Rotate.

• On the Modify toolbar, click the Rotate tool.

• Type rotate and then press Enter.

2 Select the entities, and then press Enter.

3 Specify the rotation point.

4 If desired, choose Copy to rotate a copy of selected entities.

5 In the prompt box, choose Base Angle.

6 Specify the base angle, then specify the new angle. 

To rotate an entity, select the entity to rotate (A), and then specify the rotation point (B) and the rotation angle 
(C).

A
B

C
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There are other ways to rotate entities too.
You can move, copy, and rotate selected entities using a single command. Choose the 
Move/Copy/Rotate command or type mocoro.

You can move entities interactively using a three-dimensional visual aid, which also 
works for two-dimensional entities. Choose the 3D Positioner command or type 
3dpositioner.

You can rotate single-line text, multiline text, attribute definitions, and block attribute 
text using an express tool, which has a convenient option for choosing the rotation 
that is easiest to read. Choose the Rotate Text command or type torient.

Reordering entities 
When multiple entities overlap, you can change the order in which they are displayed 
and printed. You can move entities to the front, back, or on top or below of another 
entity.

You can also change the draw order of hatches so that they are drawn and printed 
behind all other entities in a drawing. 

And for text, dimensions, and leaders, it is easy to move them to the front of other 
entities. If they are part of a block or external reference though, they are not moved to 
the front.

To reorder entities:      
1 Do one of the following to choose Draw Order ( ):

• On the ribbon, choose Home > Modify expander > Front, Back, Above, or 
Under; Edit > Front, Back, Above, or Under (in DrawOrder).

• On the menu, choose Modify > Draw Order > Front, Back, Above, or Under.

• On the Draw Order toolbar, click Front, Back, Above, or Under.

• Type draworder and then press Enter.

2 Select the entity you want to reorder, and then press Enter.

To rotate an entity in reference to a base angle, select the entity (A), specify the rotation point (B), select the 
base angle and pick point (B) again (or type the @ symbol), specify the second point (C), and then specify 
the point representing the new angle (D).

A

B C

D
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3 In the prompt box, specify the new drawing order, and then press Enter.

4 If you are reordering above or under, select the entity you want the first entity to 
be above or below, and then press Enter.

The SORTENTS system variable automatically turns on. 
The SORTENTS system variable automatically turns on, which may affect system per-
formance.

To reorder hatches to the back:      
1 Do one of the following to choose Send Hatches Back ( ):

• On the ribbon, choose Home > Modify expander > Send Hatches Back (in Draw 
Order tools) or choose Edit > Send Hatches Back (in Draw Order).

• On the menu, choose Modify > Draw Order > Send Hatches Back.

• On the Draw Order - Annotation toolbar, click the Send Hatches Back tool.

• Type hatchtoback and then press Enter.

The number of hatches affected is reported in the command bar.

To reorder text, dimensions, or leaders to the front: 
1 Do one of the following to choose Text to Front ( ):

• On the ribbon, choose Home > Modify expander > Bring Text Front, Bring 
Leaders Front, Bring Dimensions Front, Bring All Annotations Front (in Draw 
Order tools); or Edit > Bring Text Front, Bring Leaders Front, Bring Dimen-
sions Front, Bring All Annotations Front (in Draw Order).

• On the menu, choose Modify > Draw Order > Bring Text Front, Bring Leaders 
Front, Bring Dimensions Front, Bring All Annotations Front.

• On the Draw Order - Annotation toolbar, click the Bring Text Front, Bring 
Leaders Front, Bring Dimensions Front, or Bring All Annotations Front tool.

• Type texttofront and then press Enter.
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Reversing the direction of entities
You can reverse the direction of lines, polylines, splines and helixes. The entity posi-
tion and size does not change; only the vertices of the selected segments are swapped. 
This can be helpful if segments are assigned linetypes that include text or if polylines 
have varying start and end widths. If text is specified as upright, the text orientation is 
not changed.

To reverse the direction of entities:      
1 Do one of the following to choose Reverse ( ):

• On the ribbon, choose Home > Reverse (in Modify); Edit > Reverse (in 
Modify).

• On the menu, choose Modify > Reverse.

• On the Modify toolbar, click Reverse.

• Type reverse and then press Enter.

2 Select the entities you want to reverse, and then press Enter.
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Resizing entities    

You can change the size of an entity or set of entities by stretching, scaling, extend-
ing, trimming, or editing their lengths.     

Stretching entities    
You can change the size of entities by stretching them. When you stretch entities, you 
must select the entities using either a crossing window or a crossing polygon. You 
then specify a displacement distance or select a base point and a displacement point. 
Entities that cross the window or polygon boundary are stretched; those completely 
within the crossing window or crossing polygon are simply moved.    

To stretch an entity
1 Do one of the following to choose Stretch ( ):

• On the ribbon, choose Home > Stretch (in Edit); Edit > Stretch (in Modify).

• On the menu, choose Modify > Stretch.    

• On the Modify toolbar, click the Stretch tool.

• Type stretch and then press Enter.

2 In the prompt box, choose Crossing Window or Crossing Polygon.

3 Select the entities, and then press Enter.

4 Specify the base point.

5 Specify the second point of displacement. 
   

To stretch an entity using grips, you select it to display its grips and then select a grip 
to make it the active grip. This becomes the base point. Then you move the active 
grip to a new location. The grip you select depends on the type of entity you’re modi-
fying. For example, to stretch one corner of a rectangle, select the corner point grip. 
To stretch a line, select an endpoint grip. Not all entities can be stretched using grips.     

To stretch entities, select them using a crossing window (A) or crossing polygon, and then specify the base 
point (B) and displacement point (C).

A

B

C
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To stretch an entity using grips
1 Select the entity.

2 Click a grip to activate it.

3 Drag the grip.

4 Click to release. 
   

Scaling entities
You can change the size of a selected entity by scaling it in relation to a base point. 
You can change the size of an entity by specifying a base point and a length, which is 
used as a scale factor based on the current drawing units, or by specifying a scale fac-
tor. You can also use a scale factor referenced to a base scale factor, for example, by 
specifying the current length and a new length for the entity.    

To scale a selection set by a scale factor
1 Do one of the following to choose Scale ( ): 

• On the ribbon, choose Edit > Scale (in Modify).

• On the menu, choose Modify > Scale.

• On the Modify toolbar, click the Scale tool.

• Type scale and then press Enter.

2 Select the entities, and then press Enter.

3 Specify the base point.

4 Specify the scale factor. 
   

To stretch an entity using grips, select the entity 
(A), select a grip (B), and drag the grip to its new 
location (C).

Result.

A
B

C

To scale an entity by a scale factor, select the entity (A), and then 
specify the base point (B) and the scale factor.

Result.

A
B
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You can also scale some entities using grips. To scale an entity, you select the entity, 
and then click a grip. You then change the size of the entity by moving the grip. The 
grip you select depends on the type of entity you’re modifying. For example, to scale 
a circle, select a quadrant point grip.

To scale an entity using grips
1 Select the entity.

2 Click a grip to select it.

3 Drag the grip.

4 Click to release.
  

Use the Move/Copy/Rotate command.
You can move, copy, rotate, and scale selected entities using a single command. 
Choose the Move/Copy/Rotate express tool or type MOCORO.

To scale selected text entities use the Scale Text express tool or type SCALETEXT.

Extending entities    
You can extend entities so that they end at a boundary defined by other entities. You 
can also extend entities to the point at which they would intersect an implied bound-
ary edge. When extending entities, you first select the boundary edges, and then spec-
ify the entities to extend, selecting them either one at a time, using the fence selection 
method, or the projection selection method.    

You can extend arcs, lines, two-dimensional polylines, and rays. Arcs, circles, 
ellipses, lines, splines, polylines, rays, infinite lines, and viewports on a Layout tab 
can act as boundary edges.

To scale using grips, select the entity (A), click a grip (B), and 
scale the entity by dragging the grip to its new location (C).

Result.

A

B

C
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To extend an entity
1 Do one of the following to choose Extend ( ):

• On the ribbon, choose Edit > Extend (in Modify).

• On the menu, choose Modify > Extend.

• On the Modify toolbar, click the Extend tool.

• Type extend and then press Enter.

2 Select one or more entities as boundary edges, and then press Enter.

3 Select the entity to extend.

4 Select another entity to extend, or press Enter to complete the command.

  

To extend an entity to an implied boundary    
1 Do one of the following to choose Extend ( ):

• On the ribbon, choose Edit > Extend (in Modify).

• On the menu, choose Modify > Extend.

• On the Modify toolbar, click the Extend tool.

• Type extend and then press Enter.

2 Select one or more boundary edges, and then press Enter.

3 In the prompt box, choose Edge Mode.

4 In the prompt box, choose Extend.

5 Select the entity to extend.

6 Select another entity to extend, or press Enter to complete the command. 

To extend entities, select the boundary edge (A), and then 
select the entities to extend (B).

Result.

A

B
B
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To extend several entities using the fence selection method    
1 Do one of the following to choose Extend ( ):

• On the ribbon, choose Edit > Extend (in Modify).

• On the menu, choose Modify > Extend.

• On the Modify toolbar, click the Extend tool.

• Type extend and then press Enter.

2 Select one or more boundary edges, and then press Enter.

3 In the prompt box, choose Fence.

4 Specify the first point of the fence.

5 Specify the second point of the fence.

6 Specify the next fence point, or press Enter to complete the command.

  

Select the boundary edge (A), and then select the entities to 
extend (B).

Result.

A
B

B

Select the boundary edge (A), and then specify the first point (B) 
and second point (C) of the fence. 

Result.

A

B

C
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When you extend a wide polyline, its centerline intersects the boundary edge. 
Because the end of the polyline is always cut at a 90-degree angle, part of the polyline 
may extend past the boundary edge. A tapered polyline continues to taper until it 
intersects the boundary edge. If this would result in a negative polyline width, the 
ending width changes to 0.        

Trimming entities    
You can clip, or trim, entities so they end at one or more implied cutting edges 
defined by other entities. You can also trim entities to the point at which they would 
intersect an implied cutting edge. When trimming entities, you first select the cutting 
edges and then specify the entities to trim, selecting them either one at a time or using 
the fence selection method.    

You can trim arcs, circles, lines, open two-dimensional and three-dimensional 
polylines, and rays. Arcs, circles, lines, polylines, rays, infinite lines, and viewports 
on a Layout tab can act as cutting edges. An entity can be both a cutting edge and one 
of the entities being trimmed.

To trim an entity
1 Do one of the following to choose Trim ( ):

• On the ribbon, choose Edit > Trim (in Modify).

• On the menu, choose Modify > Trim.

• On the Modify toolbar, click the Trim tool.

• Type trim and then press Enter.

2 Select one or more cutting edges, and then press Enter.

3 Select the entity to trim.

4 Select another entity to trim, or press Enter to complete the command. 

A tapered polyline (A) continues to taper until it intersects the 
boundary edge (B).

Result.

A

A

B
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To trim an entity to an implied boundary
1 Do one of the following to choose Trim ( ):     

• On the ribbon, choose Edit > Trim (in Modify).

• On the menu, choose Modify > Trim.

• On the Modify toolbar, click the Trim tool.

• Type trim and then press Enter.

2 Select one or more cutting edges, and then press Enter.

3 In the prompt box, choose Edge Mode.

4 In the prompt box, choose Extend.

5 Select the entity to trim.

6 Select another entity to trim, or press Enter to complete the command. 
   

To trim several entities using the fence selection method
1 Do one of the following to choose Trim ( ):     

• On the ribbon, choose Edit > Trim (in Modify).

• On the menu, choose Modify > Trim.

• On the Modify toolbar, click the Trim tool.

• Type trim and then press Enter.

2 Select one or more cutting edges, and then press Enter.

3 In the prompt box, choose Fence.

4 Specify the first point of the fence.

5 Specify the second point of the fence.

6 Specify the next fence point, or press Enter to complete the command.  

To trim entities, select the cutting edge (A), and then select 
the entities to trim (B).

Result.

A

B

Select the implied boundary edge (A), and then select 
the entities to trim (B).

Result.

A

B
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Use the Quick Trim command.
You can trim all entities to the edge of a cutting entity in a single operation. Choose 
the Quick Trim express tool or type extrim.

Editing the length of entities   
You can change the length of entities or the included angle of arcs. Use any of the fol-
lowing methods to change the length of an entity:    

• Dynamically drag the endpoint or angle.

• Specify an incremental length or angle measured from an endpoint.

• Specify the new length as a percentage of the total length or angle.

• Specify a new length or included angle.

You can change the length of arcs, lines, and open polylines.

To change the length of an entity by dragging
1 Do one of the following to choose Edit Length ( ):     

• On the ribbon, choose Edit > Edit Length (in Modify).

• On the menu, choose Modify > Edit Length.

• On the Modify toolbar, click the Edit Length tool.

• Type editlen and then press Enter.

2 In the prompt box, choose Dynamic.

3 Select the entity you want to change.

4 Specify the new endpoint or included angle. 

Select the boundary edge (A), and then specify the first 
point (B) and second point (C) of the fence.

Result.

A B

C
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Splitting and combining entities    

You can break and combine entities using the following methods:

• Break — Separate a single entity into two parts, removing a portion of the entity in 
the process. 

• Break at Point — Separate a single entity into two parts at a single point, without 
removing a portion of the entity in the process. 

• Join  —  Combine two entities into a single entity.    

• Explode —  Separate a complex entity, such as a block or polyline, into its various 
component parts.

• Group — Combine multiples entities to behave as a single unit.

Breaking entities
Use the Break command to split, or remove the ends from, lines, arcs, circles, 
ellipses, rays, infinite lines, polylines, and donuts. By default, the point you use to 
select the entity becomes the first break point; however, you can use the First option 
to select a break point different from the one that selects the entity.   

When breaking entities, the original entity is split by removing the portion between 
the two points you specify. If the two points are the same or if you use the Split 
option, the entity is split without a gap between the resulting entities. 

You can also use the Break at Point command to break an entity into two without 
removing a portion of the entity.

Select the entity (A), and then select the new 
endpoint (B).

Result.

A
B

A B
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To break an entity by removing a portion of it
1 Do one of the following to choose Break ( ):     

• On the ribbon, choose Home > Break (in Modify) or Edit > Break (in Modify).

• On the menu, choose Modify > Break.

• On the Modify toolbar, click the Break tool.

• Type break and then press Enter.

2 Select the entity.

3 Specify the second break point. 
   

To select an entity and then specify the two break points
1 Do one of the following to choose Break ( ):

• On the ribbon, choose Home > Break (in Modify) or Edit > Break (in Modify).

• On the menu, choose Modify > Break.

• On the Modify toolbar, click the Break tool.

• Type break and then press Enter.

2 Select the entity.

3 In the prompt box, choose First.

4 Specify the first break point.

5 Specify the second break point.

  

Select the entity (A), and then specify the second break 
point (B).

Result.

A

B

Select the entity (A), and then specify the first (B) and 
second (C) break points.

Result.

A
B

C
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To split an entity without removing a portion of it using the Break command
1 Do one of the following to choose Break ( ):

• On the ribbon, choose Edit > Break (in Modify).

• On the menu, choose Modify > Break.

• On the Modify toolbar, click the Break tool.

• Type break and then press Enter.

2 Specify the entity at the desired break point.

3 Do one of the following:

• Choose Split.

• Specify the same point for the second break point by typing the at sign (@) and 
pressing Enter.  

To break an entity without removing a portion of it using the Break at Point com-
mand
1 Do one of the following to choose Break at Point ( ):   

• On the ribbon, choose Home > Break at Point (in Modify) or Edit > Break at 
Point (in Modify).

• On the menu, choose Modify > Break at Point.

• On the Modify toolbar, click the Break at Point tool.

• Type breakatpoint and then press Enter.

2 Select an entity, such as a line, arc, polyline, infinite line, ray, or spline.

3 Select the point at which to break the selected entity.

Joining entities
You can join two entities into a single entity.   

When you join two lines, they must be col-linear and the farthest endpoints remain at 
their existing locations; the program draws a new line between these points. Arcs 
must share the same center point and radius, and they are joined counterclockwise, 
from the first arc you select to the second.

Use the Edit Polyline command to join entities and polylines.
For more details, see “Joining polylines” on page 456 in this chapter. 
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To join two entities
1 Do one of the following to choose Join ( ):

• On the ribbon, choose Edit > Join (in Modify).

• On the menu, choose Modify > Join.

• On the Modify toolbar, click the Join tool.

• Type join and then press Enter.

2 Select the first entity.

3 Select the second entity.
  

The Overkill command can also combine entities. 
If a drawing has overlapping or duplicate entities that you want to combine, for 
example polylines with too many vertices, you can use the Overkill command to clean 
up the drawing.

Select the first arc or line (A), and then select the 
second arc or line (B).

Result.

A

A

B

B



448 C H A P T E R  1 0
Exploding entities    
You can convert a complex entity, such as a block or polyline, from a single entity 
into its component parts. Exploding a polyline, rectangle, donut, polygon, dimension, 
or leader reduces it to a collection of individual line and arc entities that you can then 
modify individually. 

Blocks are converted to the individual entities, possibly including other, nested 
blocks that composed the original entity. When exploding blocks, you can also use 
the Explode Attributes command to ungroup blocks, creating separate entities for 
each element and converting attributes to text. The resulting exploded entities are 
placed on the block layer (not the layer of the original entities) while the exploded 
attributes are placed on the layer of the original attribute. The Explode Attributes 
command is best used if you want to explode a block with attributes and have it retain 
the same visual appearance for properties and text. However, if you want to explode 
the block to modify the block definition and redefine it, you should use the Explode 
command, not Explode Attributes.                                              

Exploding remote text (rtext) entities from drawings created in another CAD program 
converts them to multiline text entities.

Exploding multiline text or single-line text using the Text Explode command reduces 
the text to polylines.

With the following exceptions, exploding an entity usually has no visible effect on a 
drawing:

• If the original polyline had a width, the width information is lost when you explode 
it. The resulting lines and arcs follow the centerline of the original polyline.    

• If you explode a block containing attributes, the attributes are lost, but the original 
attribute definitions remain.    

• Colors, linetypes, lineweights, and print styles assigned BYBLOCK may be dif-
ferent after exploding an entity, because they will adopt the default color, linetype, 
lineweight, and print style until inserted into another block.    

To explode an entity
1 Do one of the following to choose Explode ( ):

• On the ribbon, choose Home > Explode (in Modify) or choose Edit > Explode 
(in Modify).

• On the menu, choose Modify > Explode.

• On the Modify toolbar, click the Explode tool.

• Type explode and then press Enter.

2 Select the entities to explode.

3 Press Enter.
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To explode multiline text or single-line text 
1 Do one of the following to choose Explode Text ( ):

• On the ribbon, choose Express Tools > Explode Text (in Text).

• On the menu, choose Express Tools > Text > Explode Text.

• Type txtexp and then press Enter.

2 Select the text to explode.

3 Press Enter.

To explode a bock and its attributes 

1 Do one of the following to choose Explode Attributes ( ):

• On the ribbon, choose Express Tools > Explode Attributes (in Blocks).

• On the menu, choose Express Tools > Blocks > Explode Attributes.

• Type burst and then press Enter.

2 Select the blocks that have attributes you want to explode.

3 Press Enter.

To explode an entity and specify properties of the resulting entities 

1 Do one of the following to choose Xplode ( ):

• On the ribbon, choose Edit > Xplode (in Modify).

• On the menu, choose Modify > Xplode.

• On the Modify toolbar, click the Xplode tool.

• Type xplode and then press Enter.

2 Select the entities to explode.

3 Choose an option:

• All — Displays prompts for specifying all available properties: color, layer, 
linetype, and lineweight.

• Color — Enter a color. You can enter an index color, true color, or color from a 
colorbook.

• Layer — Enter a layer for the resulting entities.

• LType — Enter a linetype for the resulting entities.

• LWeight — Enter a lineweight for the resulting entities.

• Inherit — Explodes selected entities and assigns the same color, layer, linetype, 
and lineweight properties to sub-entities as the parent entity if the sub-entity 
layer is 0 and other properties are BYBLOCK.

• Explode — Explodes selected entities in the same way as the Explode 
command.
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Grouping entities   
A group is a collection of entities saved together as one unit. After you select the enti-
ties that belong in the group, you can later add more entities, remove entities, and 
reorder the entities. If necessary, you can also ungroup the entities at any time to 
work with the entities separately.

Group selection can be customized.
You can control whether a group is selected when a sub-entity within the group is 
selected. On the ribbon if your program version includes one, choose Home > Group 
Selection (in Groups), on the menu choose Modify > Groups > Group Selection, or 
type togglepickstyle.

Creating groups
The easiest way to create a group is to use the Quick Group command and simply 
select the entities that you want to belong in the group. If you want to specify more 
options for the group such as a group name, description, and selectability, use the 
Group Manager command. 

To create a group using the Quick Group command
1 Do one of the following to choose Quick Group ( ):

• On the ribbon, choose Home > Quick Group (in Groups).

• On the menu, choose Modify > Groups > Quick Group.

• On the Groups toolbar, click the Quick Group tool.

• Type qgroup and then press Enter.

2 Select the entities for the group, and then press Enter. 

An unnamed group is created.

By default, groups created with Quick Group are unnamed.
If you later use the Group Manager command to work with unnamed groups, be 
sure to mark Display unnamed groups.

To create a group using the Group Manager command
1 Do one of the following to choose Group Manager ( ):

• On the ribbon, choose Home > Group Manager (in Groups).

• On the menu, choose Modify > Groups > Group Manager.

• On the Groups toolbar, click the Group Manager tool.

• Type group and then press Enter.

2 Under Create New Group, enter the name and description of the group.
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3 Click Selectable if you want all entities in the group to be selected in the drawing 
when you select one entity of the group. If turned off for a group, the group selec-
tion setting has no affect.

Groups can also have grips.
To set how grips work when selecting groups, choose Drawing Settings > Display 
> Grips and choose an option in Group grips. For more details, see “Using 
grips” on page 401 in this chapter. 

4 Click Select Entities and Create Group.

5 Select the entities for the group, and then press Enter.

6 In the Group Manager dialog box, click OK.

You can select entities using groups.
Enter the name of a group in the command bar when selecting entities.

The Group Manager dialog box controls the settings for all groups in a drawing. 

Modifying groups
There are two commands that allow you to modify a group:
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• Group Edit command — Adds and removes entities from a group. You can also 
rename a group using this command. 

• Group Manager command — Displays the Group Manager dialog box where you 
can work with more than one group, add and remove entities from a group,  
rename a group, determine selectability, change the entity order, and more.

You can also modify a group using the Ungroup command. For more details, see 
“Ungrouping entities” on page 453 in this chapter. 

To modify a group and its entities using the Group Edit command
1 Do one of the following to choose Group Edit ( ):

• On the ribbon, choose Home > Group Edit (in Groups).

• On the menu, choose Modify > Groups > Group Edit.

• On the Groups toolbar, click the Group Edit tool.

• Type groupedit and then press Enter.

2 Select the group you want to modify.

To modify a group and its entities using the Group Manager command
1 Do one of the following to choose Group Manager ( ):

• On the ribbon, choose Home > Group Manager (in Groups).

• On the menu, choose Modify > Groups > Group Manager.

• On the Groups toolbar, click the Group Manager tool.

• Type group and then press Enter.

2 Select the group you want to modify.

3 Under Modify Selected Group, do one or more of the following:

• Enter a new name, and then click Rename Group.

• Enter a new description, and then click Change Group Description.

• For Selectable, mark whether you want the group to be selected in the drawing 
when you select one entity of the group.

Groups can also have grips.
To set how grips work when selecting groups, choose Drawing Settings > Display 
> Grips and choose an option in Group grips. For more details, see “Using 
grips” on page 401 in this chapter. 

• Click Add Entities to Group, select the entities to add to the group, and then 
press Enter.

• Click Remove Entities from Group, select the entities to remove from the group, 
and then press Enter.

4 In the Group Manager dialog box, click OK.
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To change the order of entities in a group
1 Do one of the following to choose Group ( ):

• On the ribbon, choose Home > Group (in Utilities).

• On the menu, choose Tools > Group.

• On the Tools toolbar, click the Group tool.

• Type group and then press Enter.

2 Under Modify Selected Group, click Reorder Entities.

3 In the Reorder Grouped Entities dialog box, select the group you want to reorder.

4 To see the order of entities in the group, click Highlight. Follow the prompts that 
display to view the entities one by one.

5 To reverse the order of all entities in the group, click Reverse Order.

6 To change the order of specific entities or a range of entities:

• In Remove from Position, enter the current position of the entity. 

• In Place to Position, enter the new position of the entity. 

• In Number of Entities, enter the number of entities or range of entities to reorder. 
For example, if you are changing the order of only one entity, enter 1. 

• Click Reorder.

The entities in a group are numbered 0, 1, 2, 3, and so on.

7 Click OK, and then click OK again.

Ungrouping entities
When you ungroup entities, the group breaks apart into separate entities. The entities 
remain in the drawing but the group is removed.

To ungroup entities
1 Do one of the following to choose Ungroup ( ):

• On the ribbon, choose Home > Ungroup (in Groups).

• On the menu, choose Modify > Groups > Ungroup.

• On the Groups toolbar, click the Ungroup tool.

• Type ungroup and then press Enter.

2 Select the group that you want to break into separate source entities.

3 If the selected entity belongs to more than one group, do one of the following at 
the prompt that displays:

• Choose Accept to break up the group at the highest level. 

• Choose Next to cycle through nested groups. When the group that you want to 
break up is highlighted, press Enter. 
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Editing polylines    

You can modify any type of two-dimensional or three-dimensional polyline. Entities 
such as rectangles, polygons, and donuts, as well as three-dimensional entities such as 
pyramids, cylinders, and spheres, are all variations of polylines that you can edit.    

You can edit a polyline by opening or closing it, by changing its overall width or the 
widths of individual segments, and by converting a polyline with straight line seg-
ments into a flowing curve or an approximation of a spline. In addition, you can use 
the Edit Polyline tool to edit individual vertices, adding, removing, or moving verti-
ces. You can also add new segments to an existing polyline, change the linetypes of a 
polyline, and reverse the direction or order of the vertices.    

Converting an entity to a polyline
To modify a polyline, you first select the polyline, and then select a polyline editing 
option. The available options vary depending on whether the selected polyline is a 
two-dimensional or three-dimensional entity. If the selected entity is not a polyline, 
the Edit Polyline tool provides the option of turning it into one. You can convert only 
arcs and lines into polylines. If several arcs or lines are joined endpoint to endpoint, 
they can all be selected and turned into one polyline.    

To convert an entity into a polyline
1 Do one of the following to choose Edit Polyline ( ):

• On the ribbon, choose Edit > Edit Polyline (in Modify).

• On the menu, choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool.

• Type editpline and then press Enter.

2 Select the entity.

3 In the prompt box, choose Yes-Turn Into Polyline.

4 In the prompt box, choose another option, or choose Done to complete the 
command.

Opening and closing polylines
When you close a polyline, the program draws a straight polyline segment from the 
last vertex of the polyline to the first vertex. Opening a polyline removes the closing 
segment. When you select a polyline for editing, the prompt box displays either the 
Open or Close option, depending on whether the polyline you select is closed or 
open.    
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To close an open polyline
1 Do one of the following to choose Edit Polyline ( ):

• On the ribbon, choose Edit > Edit Polyline (in Modify).

• On the menu, choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool.

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Close.

4 In the prompt box, choose another option, or choose Done to complete the com-
mand. 

   

Curving and decurving polylines   
You can convert a multisegment polyline into a smooth curve using either the Fit or 
Spline option. The Fit option creates a smooth curve connecting all the vertices. The 
Spline option computes a smooth curve that is pulled toward the vertices but passes 
through only the first and last vertices. The Decurve option removes Fit or Spline 
curves and arcs, leaving straight segments between the vertices.    

To fit a curve to a polyline
1 Do one of the following to choose Edit Polyline ( ):    

• On the ribbon, choose Edit > Edit Polyline (in Modify).

• On the menu, choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool.

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Fit.

4 In the prompt box, choose another option, or choose Done to complete the 
command.

Closing an open polyline adds a straight 
polyline segment between the first (A) and last 
(B) vertices.

Result.

A B
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Joining polylines    
You can add an arc, line, or polyline entity to an existing open polyline, forming one 
continuous polyline entity. To join an entity to a polyline, that entity must already 
share an endpoint with an end vertex of the selected polyline.    

When you join an entity to a polyline, the width of the new polyline segment depends 
on the width of the original polyline and the type of entity you are joining to it:

• A line or an arc assumes the same width as the polyline segment for the end vertex 
to which it is joined.

• A polyline joined to a tapered polyline retains its own width values.

• A polyline joined to a uniform-width polyline assumes the width of the polyline to 
which it is joined.    

Use the Join command to join arcs and lines.
For more details, see “Joining entities” on page 446 in this chapter. 

To join an arc, line, or polyline to an existing polyline 
1 Do one of the following to choose Edit Polyline ( ):

• On the ribbon, choose Edit > Edit Polyline (in Modify).

• On the menu, choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool.

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Join.

4 Select the arc, line, or polyline to join.

5 In the prompt box, choose another option, or choose Done to complete the 
command.

Original polyline. After applying Fit curve. After applying Spline.
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Changing the polyline width    
You can change the width of an entire polyline, applying a uniform width to the entire 
entity or tapering the polyline uniformly along its entire length.    

To apply a uniform width to an entire polyline    
1 Do one of the following to choose Edit Polyline ( ):

• On the ribbon, choose Edit > Edit Polyline (in Modify).

• On the menu, choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool.

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Width.

4 Specify the new polyline width.

5 In the prompt box, choose another option, or choose Done to complete the 
command.

To taper a polyline uniformly along its length
1 Do one of the following to choose Edit Polyline ( ):     

• On the ribbon, choose Edit > Edit Polyline (in Modify).

• On the menu, choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool.

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Taper.

4 Specify the starting width.

5 Specify the ending width.

6 In the prompt box, choose another option, or choose Done to complete the 
command.
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Editing polyline vertices    
You can use the Edit Vertices option to modify individual polyline vertices. When 
you select this option, the program switches into a special vertex editing mode and 
places an x on the first vertex. The x indicates the vertex you are editing. The Next 
and Previous options move the x to the next or previous vertex. You can edit only one 
vertex at a time.    

When editing vertices, you can modify the polyline in the following ways:

• Convert a polyline segment into a curve by specifying a new tangent angle.

• Break a polyline into two separate polylines.

• Insert a new vertex after the current vertex.

• Move the current vertex.

• Straighten the polyline segment between two vertices.

• Change the width of the polyline segment between two vertices.

You can also reverse polyline vertices.
To reverse the direction of polyline segments, use the Reverse command. For more 
details, see “Reversing the direction of entities” on page 435 in this chapter. 

To move a polyline vertex    
1 Do one of the following to choose Edit Polyline ( ):

• On the ribbon, choose Edit > Edit Polyline (in Modify).

• On the menu, choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool.

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Edit Vertices.

4 In the prompt box, choose Next Vertex.

Repeat until the x reaches the vertex you want to move.

5 In the prompt box, choose Move.

6 Specify the new location for the vertex.

7 In the prompt box, choose another option, or choose Exit to stop editing vertices.

8 In the prompt box, choose another option, or choose Done to complete the com-
mand. 
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To taper the width of an individual polyline segment
1 Do one of the following to choose Edit Polyline ( ):     

• On the ribbon, choose Edit > Edit Polyline (in Modify).

• On the menu, choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool.

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Edit Vertices.

4 In the prompt box, choose Next Vertex.

Repeat until the x reaches the first vertex of the segment you want to taper.

5 In the prompt box, choose Width.

6 Specify the starting width.

7 Specify the ending width.

8 In the prompt box, choose another option, or choose Exit to stop editing vertices 
and update the display.

9 In the prompt box, choose another option, or choose Done to complete the com-
mand. 

   

Select the polyline (A), move the current vertex 
marker to the vertex you want to move (B), and then 
specify the new vertex location (C).

Result.

A

B

C

Select the polyline (A), move the current vertex 
marker to the first vertex of the segment you want to 
taper (B), and then specify the new starting and 
ending widths for that segment.

Result.

A B
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Chamfering and filleting entities             

You can chamfer or fillet entities. A chamfer connects two nonparallel entities with a 
line to create a beveled edge. A fillet connects two entities with an arc of a specified 
radius to create a rounded edge. If both entities you are working with are on the same 
layer, the chamfer or fillet is drawn on that layer. If they are on different layers, the 
chamfer or fillet is drawn on the current layer.                                     

Modifying the chamfer and fillet settings
The Chamfer/Fillet settings in the Drawing Settings dialog box control the chamfer 
and fillet settings. The portions of the entities that extend beyond the chamfer or fillet 
are normally deleted when you create the chamfer or fillet. You can retain these 
original entities, however, by changing the settings in the dialog box.  

To modify the chamfer and fillet settings
1 Do one of the following to choose Drawing Settings ( ):

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 In the Drawing Settings dialog box, click the Entity Modification tab.

3 Click the Chamfer/Fillet tab and choose from the following:

• Corners — Select to remove or retain portions of entities that extend beyond the 
chamfer or fillet.

• Fillet radius — Specify the fillet radius or click Select to specify it by selecting 
two points in the drawing.

• Chamfer Distances and Angles  — Choose to use the distance-distance method 
or distance-angle method when creating chamfers. The distance-distance 
method creates a chamfer using two chamfer distances that you specify. The 
distance-angle method creates a chamfer using a chamfer length and angle that 
you specify.

4 Click OK. 

Chamfering entities    
You can connect two nonparallel entities by extending or trimming them and then 
joining them with a line to create a beveled edge. You can chamfer lines, polylines, 
rays, and infinite lines. When creating a chamfer, you can specify how far to trim the 
entities back from their intersection (distance-distance method), or you can specify 
the length of the chamfer and the angle it forms along the first entity (distance-angle 
method).    
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When chamfering a polyline, you can chamfer multiple segments between two 
selected polyline segments, or you can chamfer the entire polyline.

Chamfering two entities using the distance-distance method

To chamfer two entities using the distance-distance method
1 Do one of the following to choose Chamfer ( ):

• On the ribbon, choose Modify > Chamfer (in Modify).

• On the menu, choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool.

• Type chamfer and then press Enter.

2 In the prompt box, choose Chamfer Settings.

3 In the Drawing Settings dialog box, click the Entity Modification tab.

4 Under Chamfer Distances And Angles, click Distance-Distance.

5 Under Chamfer Distances And Angles, specify the first and second chamfer
distances.

6 Click OK.

7 Select the first entity.

8 Select the second entity. 
   

Select the first (A) and second (B) entities. The chamfer is drawn, based on the first (C) and second (D) 
chamfer distances.

A

B

C

D
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Chamfering two entities using the distance-angle method

To chamfer two entities using the distance-angle method
1 Do one of the following to choose Chamfer ( ):

• On the ribbon, choose Modify > Chamfer (in Modify).

• On the menu, choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool.

• Type chamfer and then press Enter.

2 In the prompt box, choose Chamfer Settings.

3 In the Drawing Settings dialog box, click the Entity Modification tab.

4 Under Chamfer Distances And Angles, click Distance-Angle.

5 Under Chamfer Distances And Angles, specify the chamfer distance and angle.

6 Click OK.

7 Select the first entity.

8 Select the second entity.

  

Chamfering all vertices in a polyline

To chamfer all vertices in a polyline
1 Do one of the following to choose Chamfer ( ):     

• On the ribbon, choose Modify > Chamfer (in Modify).

• On the menu, choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool.

• Type chamfer and then press Enter.

2 In the prompt box, choose Polyline.

3 Select the polyline.  

Select the first (A) and second (B) entities. The chamfer is drawn, based on the distance measured along the 
first entity (C) and the angle (D) formed with the first entity.

A

B

C

D
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Chamfering selected vertices in a polyline

To chamfer selected vertices in a polyline
1 Do one of the following to choose Chamfer ( ):

• On the ribbon, choose Modify > Chamfer (in Modify).

• On the menu, choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool.

• Type chamfer and then press Enter.

2 Select the polyline along the segment where you want to begin the chamfer.

3 Select the polyline along the segment where you want to end the chamfer.  
  

Original polyline. Result after chamfering.

Select the polyline along the (A) and (B) 
segments.

Result after chamfering.

A B
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Filleting entities    
You can connect two entities with an arc of a specified radius to create a rounded 
edge. You can fillet pairs of line segments, straight polyline segments, arcs, circles, 
rays, and infinite lines. You can also fillet parallel lines, rays, and infinite lines. When 
filleting a polyline, you can fillet multiple segments between two selected segments, 
or you can fillet the entire polyline.    

Filleting two entities

To fillet two entities
1 Do one of the following to choose Fillet ( ):

• On the ribbon, choose Modify > Fillet (in Modify).

• On the menu, choose Modify > Fillet.

• On the Modify toolbar, click the Fillet tool.

• Type fillet and then press Enter.

2 In the prompt box, choose Fillet Settings.

3 In the Drawing Settings dialog box, specify the fillet radius.

4 Click OK.

5 Select the first entity.

6 Select the second entity. 
   

Filleting an entire polyline

To fillet an entire polyline
1 Do one of the following to choose Fillet ( ):

• On the ribbon, choose Modify > Fillet (in Modify).

• On the menu, choose Modify > Fillet.

• On the Modify toolbar, click the Fillet tool.

• Type fillet and then press Enter.

2 In the prompt box, choose Polyline.

3 Select the polyline. 

Select the first (A) and second (B) entities. Result after filleting.

A

B
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Filleting selected vertices in a polyline

To fillet selected vertices in a polyline
1 Do one of the following to choose Fillet ( ):    

• On the ribbon, choose Modify > Fillet (in Modify).

• On the menu, choose Modify > Fillet.

• On the Modify toolbar, click the Fillet tool.

• Type fillet and then press Enter.

2 Select the polyline along the segment where you want to begin the fillet.

3 Select the polyline along the segment where you want to end the fillet. 
   

When you fillet circles and arcs, more than one fillet can exist between the entities. 
The point at which you select the entities determines the fillet. 

Select the polyline (A). Result after filleting.

A

Select the polyline along the (A) and (B) 
segments.

Result after filleting.

A B
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You can fillet parallel lines, rays, and infinite lines. The first entity must be a line or 
ray; the second entity can be a line, ray, or infinite line. The diameter of the fillet arc 
is always equal to the distance between the parallel entities. The current fillet radius is 
ignored.     
    

Select entities (A and B). Results after filleting.

Original entities. Result after filleting.

B

A

B

A

B

A

B

A
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Working with text

You can insert text into your drawing and control its appearance, allowing you to pro-
vide additional information for your IntelliCAD drawings. This section explains how 
to:

• Create line text, including along an arc.

• Create paragraphs.

• Create text styles.

• Format text.

• Change line text and paragraph text.

• Convert line text to paragraph text.

• Working with fields.

• Check the spelling of text.

• Use an alternate text editor.

• Working with text written in different languages.

• Working with missing fonts.

Topics in this chapter

Creating line text ..............................................................................................468

Creating paragraph text....................................................................................470

Working with text styles....................................................................................474

Formatting text .................................................................................................475

Changing text ...................................................................................................481

Working with fields ...........................................................................................486

Using an alternate text editor ...........................................................................493

Working with text written in different languages ...............................................494

Working with missing fonts...............................................................................496
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Creating line text       

Most commonly, lines of text are created using the Text command which creates sin-
gle-line text entities. A line of text can also be created along an arc using the Arc-
Aligned Text command. 

When creating and editing single-line text, the text is checked for spelling automati-
cally and incorrectly spelled words display with a dashed red underline.

Creating a line of text
When you create single-line text, you end each line of text by pressing Enter. Each 
line of text is created as a separate entity that you can modify.

To create a line of text 
1 Do one of the following to choose Text ( ):           

• On the ribbon, choose Home > Text (in Annotation) or choose Annotate > Text 
(in Text).

• On the menu, choose Draw > Text.

• On the Draw toolbar, click the Text tool.

• Type text and then press Enter.    

2 Specify the insertion point for the first character.    

3 Specify the height of the text.

4 Specify the text rotation angle.     

5 Type the text, and then press Enter at the end of each new line.

6 To complete the command, press Enter again.

If you’ve already created text, new text can appear immediately below the previous text.  
Choose Insert > Text. When prompted for an insertion point, press Enter. The new 
text will keep the same height and rotation angle as the previous text.
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Creating a single line of text along an arc
You can create a single line of text positioned along an arc. Arc-aligned text is its 
own special type of text entity; it is not exactly the same as a single-line text entity.

To create a line of text along an arc 
1 Do one of the following to choose Arc-Aligned Text ( ):       

• On the ribbon, choose Express Tools > Arc-Aligned Text (in Text).

• On the menu, choose Express Tools > Text > Arc-Aligned Text.

• Type arctext and then press Enter.    

2 Select the arc along which you want to align text.

3 In Text, type the text.

4 Select arc-aligned text options.

5 Click OK.
      

A Click to maintain the arrangement of text relative 
to the arc while moving the arc.

B Click to reverse the text flow direction.
C Click to align text to the left, right, fit (text fills the 

length of the arc), or center.
D Select a text style.
E Type the text to display along the arc.
F Type the text font height.
G Type the font width factor.
H Type the spacing between characters.
I Enter the spacing between text and the right 

edge of the arc. This option is not available when 
alignment is set to the right and to the center of 
the arc.

J Enter the spacing between text and the left edge 
of the arc. This option is not available when 
alignment is set to the left and to the center of the 
arc.

K Enter the spacing between arc and text.
L Displays a sample of the text.
M Click to orient text characters either outward from 

or inward to the center of the arc. 
N Click to set the text color to BYLAYER, 

BYBLOCK, one of the standard colors, or choose 
Select Color for more options.

O Click to apply bold, italics, and underline to the 
text.

P Click to place text either on the convex side of 
the arc or on the concave side of the arc.

E

N

O

L

A
B
C
D

F
G
H

P

M

K
J
I
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Creating paragraph text    

Paragraph text consists of one or more lines of text or paragraphs that fit within a 
boundary width that you specify. Each paragraph text entity you create is treated as a 
single entity regardless of the number of individual paragraphs or lines of text it 
contains.    

When you create paragraph text, you first determine the paragraph’s boundary width 
by specifying the opposite corners of a rectangle. The paragraph text automatically 
wraps so that it fits within this rectangle. The first corner of the rectangle determines 
the default attachment point of the paragraph text. You can determine the direction in 
which text flows within the rectangle, and you can also select the text and paragraph 
format, text style, text height, and the rotation angle of the entire paragraph text 
entity.    

When creating and editing paragraph text, the text can be checked for spelling auto-
matically and incorrectly spelled words display with a dashed red underline.

To create paragraph text 
1 Do one of the following to choose Multiline Text ( ):

• On the ribbon, choose Home > Multiline Text (in Annotation) or Annotate > 
Multiline Text (in Text).

• On the menu, choose Draw > Multiline Text.

• On the Draw toolbar, click the Multiline Text tool.

• Type mtext and then press Enter.    

2 Select the first corner of the text area.

3 In the command bar or context menu, optionally choose the properties you want to 
set, or proceed directly to the next step. You can also choose these properties later 
for the resulting multiline text entity.

4 Select the second corner of the text area.

5 Type the text you want.

To create paragraphs, press Enter and continue typing.

6 On the ribbon (or floating toolbar if not viewing the ribbon), use the Text Editor  
tools to make your selections for highlighted text, or if no text is highlighted, the 
changes affect new text when you type it.

Text Editor tools display on the ribbon or a floating toolbar. 
By default, the floating toolbar displays only if the ribbon is turned off, however, 
some users prefer to always use the floating toolbar. To enable the floating tool-
bar even when the ribbon displays, type cui, and on the Customize tab, select 
AcTextEditorInProgress in Contextual Ribbon States. On the right, choose True 
for the Disabled option, then click OK.
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7 Click Close Editor to accept your changes and close the editor.

Tool Name Description
Text Style Select a text style.

Text Height Select or type the text font height.

Annotative Select or type the text font height.

 Bold and Italics Click to bold and/or italicize text.

Strikethrough Click to strikethrough text. 

 Underline and 
Overline

Click to underline and/or overline text.

 Uppercase and 
Lowercase

Click to make text uppercase or lowercase.

 Superscript and 
Subscript

Click to make text superscript or subscript. 

Text Font Select the text font. 

Text Color Select BYBLOCK, BYLAYER, the color of 
your choice, or choose Select Color to 
select from additional colors.

Background Mask Click to set the background settings for text. 
For more details, click Help in the dialog box 
that displays.

 Oblique Angle Select or type the angle of text characters.

 Tracking Select or type the factor representing 
spacing between characters.

 Width Factor Select or type the font width factor.

Clear Formatting Choose whether to remove character 
formatting from selected characters, 
paragraph formatting or all formatting from a 
selected paragraph.

Combine 
Paragraphs

Click to combine selected paragraphs into a 
single paragraph.

Justification Select the text box justification.

List Select the type of list for the text. You can 
also specify to continue or restart numbered 
lists.

Line Spacing Select the spacing between lines.
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Access more options by right-clicking the text editor. 
Right-click the text editor to access additional options, including Select All, Cut, 
Copy, Paste, and Paste Special. You can also use typical shortcuts such as Ctrl + V to 
paste text from the clipboard.   

 

 Paragraph Click to specify tab, indent, alignment, and 
line spacing settings. For more details, click 
Help in the dialog box that displays.

  Default, Left, and 
Center

Click to set the paragraph justification to 
default, left, or center.

  Right, Justify, and 
Distribute

Click to set the paragraph justification to 
right, justify, or distribute.

 Undo and Redo Click to redo or undo the previous action.

Symbol Click to insert a symbol character where the 
cursor is located in the text editor.

Insert Field Click to insert a field where the cursor is 
located in the text editor. For more details, 
click Help in the dialog box that displays.

Columns Click to specify columns for the text, and 
options for the columns. For more details, 
click Help in the program.

Find and Replace Click to find and replace text in the text 
editor.

Import Text Click to select a file that contains text to 
import.

AutoCAPS Click to turn on or off capitalizing text 
automatically as you type.

Check Spelling Click to check text for spelling automatically. 
Incorrectly spelled words display with a 
dashed red underline; right-click to choose a 
correctly spelled word. 

Ruler Click to show or hide the ruler in the text 
editor.

Stacked Text Click to stack or unstack selected text, for 
example, fractions can display as stacked 
text.

More Click to display a menu of additional options, 
including the character set, settings for the 
text editor, and online help.

Done Accepts your changes and closes the editor.

Tool Name Description
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There are two multiline text editors. 
To switch to a dialog box version of the multiline text editor, set the MTEXTED sys-
tem variable to “oldeditor”.

A Click to accept your changes and close the 
editor.

B Type and select text.
C Click and drag to resize the editor vertically.

D Click and drag to resize the editor horizontally.
E Displays the ruler.

A

B

D

C

E
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Working with text styles    

When you add text to a drawing, it uses the current text style. Text style determines 
the font, size, angle, orientation, whether the text is annotative by default, and other 
characteristics.           

Every drawing has a default text style, named Standard, which initially uses the Arial 
font. You cannot delete the Standard style, but you can rename it or modify it. You 
can change the font, the size of the font, and the obliquing angle applied to it. If you 
change the font or orientation of an existing style, all existing text entities created 
using that style are automatically updated to reflect the new font or orientation. 
Changing any other characteristic has no effect on existing text. You also can create 
and use an unlimited number of additional text styles.        

The text style determines the characteristics shown in the following table.                   

To create a text style     
1 Do one of the following to choose Text Styles Manager ( ):     

• On the ribbon, choose Home > Text Styles Manager (in Annotation) or 
Annotate > Text Styles Manager (in Text).

• On the menu, choose Format > Text Styles Manager.

• On the Format or Styles toolbar, click the Text Styles Manager tool.

• Type style and then press Enter.

2 Click New.

Style characteristic Default Description
Style name Standard The name of the style, up to 255 characters.

Font file Arial The font file on which the style is base, and whether Asian language big font files are used (for 
.SHX file fonts only).

Language Western The character height. A value of 0 prompts for text height upon insertion. 

Annotative No Determines whether text is annotative by default and therefore its display and print is affected by 
annotation scaling. If annotative by default, also determines whether the text, when displayed in 
paper space, is oriented automatically according to the layout viewport.

Text height 0 The character height. A value of 0 prompts for text height upon insertion. The text height is the 
paper text height if the text style is annotative.

Width factor 1 The horizontal expansion or compression of the text. Values less than 1 compress the text; 
values greater than 1 expand the text.

Obliquing angle 0 The slant of the text, in degrees. Negative values slant the text to the left; positive values slant 
the text to the right.

Backward No Determines whether text appears backward.

Upside down No Determines whether text appears upside down.

Vertical No Determines whether text has a vertical orientation.
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3 Type a new text style name, then click OK.

4 Under Text Font, select the name, style, and language of the font you want to use.      

5 Under Text Measurements, select the check boxes if you want annotative text; you 
can also enter a Fixed Text Height (Paper Text Height if annotative), Width Fac-
tor, or Oblique Angle measurement.    

6 Under Text Generation, select the check boxes you want to indicate the direction 
for printed text to appear.

7 Click OK.

8 To begin using the new style, choose Draw > Text. 

9 In the prompt box, select Use Defined Style.

Formatting text    

When you create text, you choose the text style and set the alignment. The style deter-
mines the font characteristics for the text. For single-line text, the alignment point 
determines how the text aligns with the text insertion point. For paragraph text, the 
alignment point determines the location of the attachment point in relation to the 
paragraph text boundary and the direction in which text flows within the boundary.        

You can also use the Express Tools > Text area for commands that scale text, justify 
text, enclose text in shapes, and more. All of these options are described in the online 
help.

Setting the line text style
You can set the text style before you specify the insertion point. You select the text 
style by typing the name of a previously defined style.       

To specify a line text style
1 Do one of the following to choose Text ( ):     

• On the ribbon, choose Home > Text (in Annotation) or choose Annotate > Text 
(in Text).

• On the menu, choose Draw > Text.

• On the Draw toolbar, click the Text tool.

• Type dtext and then press Enter.

2 In the prompt box, choose Use Defined Style.

3 Type the name of a previously defined text style, and then press Enter.        

To display a list of available text styles, type a question mark (?), and then press 
Enter.    

4 Specify the text insertion point.     
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5 Specify the text height.     

6 Specify the rotation angle.    

7 Type the text line, and then press Enter.

8 To complete the command, press Enter again.

Setting the paragraph text style
You can set the paragraph text style before you specify the insertion point. You select 
the text style by typing the name of a previously defined style.

To specify a paragraph text style
1 Do one of the following to choose Multiline Text ( ):

• On the ribbon, choose Home > Multiline Text (in Annotation) or Annotate > 
Multiline Text (in Text).

• On the menu, choose Draw > Multiline Text.

• On the Draw toolbar, click the Multiline Text tool.

• Type mtext and then press Enter.

2 Specify the first point of the text box.

3 In the prompt box, choose Text Style.

4 Type the name of a previously defined text style, and then press Enter.

5 Specify the text height.

6 Specify the rotation angle.

7 Specify the opposite corner of the text box.

8 Type the text.

9 To complete the command, click Close Editor.
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Setting the line text alignment    
When you create text, you can set the text alignment before you specify the insertion 
point. You set the alignment by choosing it in the prompt box. By default, text is left 
justified. You can align text at the left, center, or right and at the top, middle, or base-
line of the text or at the bottom of descending letters.                
  

You can also align text so that it fits or aligns between two points. The Align option 
creates text that scales up or down while maintaining a constant height/width ratio; 
the Fit option expands or compresses the text to fit between the two points.        

To specify the line text alignment before entering text
1 Do one of the following to choose Text ( ):       

• On the ribbon, choose Home > Text (in Annotation) or choose Annotate > Text 
(in Text).

• On the menu, choose Draw > Text.

• On the Draw toolbar, click the Text tool.

• Type dtext and then press Enter.    

2 In the prompt box, choose an alignment option, or choose Justification Options to 
display all the justification options.

A Top left
B Middle left
C Left
D Bottom left
E Center
F Bottom center
G Bottom right

H Baseline
I Right
J Middle right
K Top right
L Middle
M Middle center
N Top center

Text aligned between two points maintains a 
constant height/width ratio.

Text fit between two points expands or compresses 
to fit.

J

KL

GD

A

B

C

M

H
FE

I

N
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3 Specify the text insertion point, and then continue creating the line text.

To specify the justification for existing line text entities
1 Do one of the following to choose Justify Text ( ):       

• On the ribbon, choose Express Tools > Justify Text (in Text > Modify Text).

• On the menu, choose Express Tools > Text > Justify Text.

• Type tjust and then press Enter.    

2 Select text entities. In addition to single-line text, you can also choose multiline 
text and attribute text.

3 Choose one of the following:

• Center Justification point of the text is center aligned.

• Middle Justification point of the text is middle aligned (left/right and top/
bottom).

• Right Justification point of the text is right aligned.

• TL Justification point of the text is top-left aligned.

• TC Justification point of the text is top-center aligned.

• TR Justification point of the text is top-right aligned.

• ML Justification point of the text is middle-left aligned.

• MC Justification point of the text is middle-center aligned.

• MR Justification point of the text is middle-right aligned.

• BL Justification point of the text is bottom-left aligned.

• BC Justification point of the text is bottom-center aligned.

• BR Justification point of the text is bottom-right aligned.

To fit existing line text within two points
1 Do one of the following to choose Text Fit ( ):       

• On the ribbon, choose Express Tools > Fit Text (in Text > Modify Text).

• On the menu, choose Express Tools > Text > Fit Text.

• Type textfit and then press Enter.    

2 Select single-line text entities.

3 Specify a new desired ending point or choose Start Point to specify a new starting 
point and then specify the ending point.

The Text Fit command works with single-line text only.
To fit multiline text within two points, first use the Explode command to convert it to 
single-line text.
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To change the scale of existing line text
1 Do one of the following to choose Scale Text ( ):       

• On the ribbon, choose Express Tools > Scale Text (in Text > Modify Text).

• On the menu, choose Express Tools > Text > Scale Text.

• Type scaletext and then press Enter.    

2 Select single-line text entities.

3 Choose a base point option for scaling.

4 Choose one of the modes of scaling text and follow the prompts. Refer to online 
help for more details.

Setting the paragraph text alignment
When you create paragraph text, you can set the text alignment by specifying the 
direction in which text flows within the boundary. You can set the paragraph text 
alignment either in the prompt box displayed after you specify the first corner of the 
paragraph text boundary, from the Properties pane, or using the Justify Text express 
tool command. You can specify the attachment point at the top left, top center, top 
right, middle left, middle center, middle right, bottom left, bottom center, or bottom 
right. The paragraph text can flow left to right, right to left, top to bottom, or bottom 
to top. You can change the scale of existing paragraph text using the Scale Text 
express tool command.

Including special text characters    
You can use control codes to overscore or underscore text or to include special char-
acters. Both overscore and underscore can be active at the same time. To include con-
trol codes, as you type text, type two percent symbols (%%) followed by the special 
control code or character. A single percent sign is treated as a normal text character. 
A triple-percent control code is provided for those instances where a control-code 
sequence must follow a percent sign in the text.                       
  

Special text characters   
Control code Function
%%o Toggles overscore mode on and off.

%%u Toggles underscore mode on and off.

%%d Draws a degree symbol (º).

%%p Draws the plus-or-minus symbol (±).

%%c Draws the circle diameter symbol (Ø).

%%% Forces a single percent sign.

%%nnn Draws special character number nnn.



480 C H A P T E R  1 1
Creating a frame around text
You can draw a frame around each selected line text, paragraph text or attribute text, 
that is enclose text with shape. Frames can be in the shape of a circle, rectangle or a 
slot.                        

To draw a frame around text
1 Do one of the following to choose Enclose Text with Shape ( ):     

• On the ribbon, choose Express Tools > Enclose Text with Shape (in Text > 
Modify Text).

• On the menu, choose Express Tools > Text > Enclose Text with Shape.

• Type tcircle and then press Enter.    

2 Select line text, paragraph text or attribute text.

3 Specify which shape you want to draw around text. Refer to online help for more 
details.

Text created using special text characters: Ut wisi %%uenim%%d ad%%p%%u minim %%c %%oveniam.
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Changing text    

You can change line and paragraph text in your drawing.

Changing line text
You can edit and modify the text as you would any other drawing entity. That is, you 
can delete, move, rotate, and scale text.                      

To edit text and its properties     
1 Do one of the following to choose Edit Text ( ):               

• On the ribbon, choose Home > Edit Text (in Annotation) or Annotate > Edit 
Text (in Text).

• On the menu, choose Modify > Entities > Text.

• On the Modify toolbar, click the Edit Text tool.

• Type textedit and then press Enter.

2 Select the text entity.

3 In the Text dialog box, edit the text.

4 Change the text properties you want.

The Text dialog box displays when TEXTED is set to 3 (the default).
If the TEXTED system variable is set to 1 or 2, line text is edited in the command bar 
or Properties pane respectively instead of the Text dialog box.

Changing paragraph text
You can modify the text as you would any other drawing entity. That is, you can 
delete, move, rotate, and scale text.

To edit paragraph text and its properties
1 Do one of the following to choose Edit Text ( ):

• On the ribbon, choose Home > Edit Text (in Annotation) or Annotate > Edit 
Text (in Text).

• On the menu, choose Modify > Entities > Text.

• On the Modify toolbar, click the Edit Text tool.

• Type textedit and then press Enter.

2 Select the text entity.

3 In the text editor, edit the text.

4 Change the text properties you want.

5 Click Close Editor.
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Finding and replacing text
You can search and optionally replace text throughout a drawing, within a layout, or 
within selected entities. 

IntelliCAD searches and displays a list of matching text. Each found text item has an 
associated entity type to help you identify its location in the drawing. Entity types can 
include single-line text, multiline text, dimension leaders, hyperlinks, alternate text, 
paperspace, and modelspace. Note that sometimes dimension text is listed as multi-
line text because of the way dimensions are created.         

To find and optionally replace text    
1 Do one of the following to choose Find and Replace ( ):     

• Choose Edit > Find and Replace.

• On the Standard toolbar, click the Find and Replace tool.

• Type find and then press Enter.

2 In Find What, type the text you want to search for, or select previously entered text 
from the list.

3 In Find Where, select the location where you want to search:

• Entire drawing Searches the entire drawing.

• Current layout Searches the current layout only.

• Selected entities Searches selected entities only. You can click ( ) to switch 
to the drawing temporarily and select entities.

4 In Text Types, select the text types you want to include in the search.

5 In Search Options, select the desired search options.

6 Click Find to displays a list of all matching text.

7 To replace text, do the following:

• In Replace With, enter or select the new text.

• In the list of found text, select the text to replace.

• Click Replace.

Use a shortcut for replacing text.
Click Replace All to replace all matching text without finding it first.

8 Click Done.
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A Type or select the text to find.
B Type or select the text to replace found text with 

(optional).
C Displays all found text.
D Select to find only text that matches the upper and 

lower case specified in Find What.
E Select to find only whole words that match the text in 

Find What.
F Select to allow the use of wildcards in the search.
G Select to include external references in the search.
H Select to include blocks in the search.
I Select to exclude hidden items (such as text on 

layers that are frozen or turned off and text in block 
attributes created in invisible mode) from the search.

J Click to replace selected text in the Location list with 
text from Replace With.

K Click to replace all matching text without searching 
first.

L Click to find matching text.
M Click when finished.
N Select to search hyperlink descriptions.
O Select to search hyperlinks.
P Select to search tables.
Q Select to search both single-line and multiline text.
R Select to search both dimension and leader text.
S Select to search block attribute values.
T Click to zoom to the selected found text in the 

drawing.
U Click to create a selection set that includes the 

selected found text in model space or a single layout.
V Click to create a selection set that includes all found 

text in model space or a single layout.
W Select where to search for text: the entire drawing, 

the current layout, or selected entities. 
X Click to switch to the drawing and select entities to 

search.

A
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Changing capitalization of letters
You can quickly change the capitalization of single-line and multiline text entities to 
these capitalization methods: sentence case, all lower case, all uppercase, title case, 
and toggle case.

To set capitalization formatting
1 Do one of the following to choose Change Text Case ( ):       

• On the ribbon, choose Express Tools > Change Text Case (in Text > Modify 
Text).

• On the menu, choose Express Tools > Text > Change Text Case.

• Type tcase and then press Enter.    

2 Select text entities.

3 Choose one of the following:

• Sentence case The first letter of the first text character is upper case.

• lowercase All text characters are lower case letters.

• UPPERCASE All text characters are upper case letters.

• Title The first letters of all text characters are upper case.

• tOGGLE cASE The first letters of all text characters are lower case and the rest 
of the letters are upper case.

Converting line text to paragraph text
When converting line text to paragraph text, one or more text entities created with the 
Text command are combined into one multiline text entity. During the conversion, 
the selected text entities are removed from the drawing and a multiline text entity is 
created.

To convert line text to paragraph text 
1 Do one of the following to choose Text to Multiline Text ( ):     

• On the ribbon, choose Home > Text to Multiline Text (in Annotation), 
Annotate > Text to Multiline Text (in Text) or Express Tools > Text to Multiline 
Text (in Text).

• On the menu, choose Draw > Text to Multiline Text or choose Express Tools > 
Text > Text to Multiline Text.

• On the Text toolbar, click the Text to Multiline Text tool.

• Type txt2mtxt and then press Enter.

2 Select one or more text entities.

3 When finished with selection, press Enter.
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To customize options while converting line text to paragraph text
1 Do one of the following to choose Text to Multiline Text ( ):     

• On the ribbon, choose Home > Text to Multiline Text (in Annotation), 
Annotate > Text to Multiline Text (in Text) or Express Tools > Text to Multiline 
Text (in Text).

• On the menu, choose Draw > Text to Multiline Text or choose Express Tools > 
Text > Text to Multiline Text.

• On the Text toolbar, click the Text to Multiline Text tool.

• Type txt2mtxt and then press Enter.

2 Press Enter.

3 Select one of the following:

• Selection set order Select to add single-line text to multiline text  in the order 
that you select.

• Top-down order Select to add single-line text to multiline text in the order that 
they appear in the drawing, from the top downwards.

4 Mark Create Word-Wrap MText to add spaces within individual lines of text, 
which helps balance multiple lines of text.

5 Click OK.

6 Select one or more text entities.

7 When finished with selection, press Escape.

All text entities are combined into a single multiline text entity.

A Choose to add text in the order selected or in top-
down order.

B Click to add spaces within text lines to balance 
multiple lines of text.

A

B
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Working with fields

Fields contain expressions that can be updated automatically to generate new field 
content as drawing values change. For example, a the filename field displays text 
with the name of drawing file. If the name of the drawing file changes, you can use 
the Update Field command to automatically update the field with the correct file-
name.

Inserting a field
Fields can be inserted as multiline text entities directly in the drawing.  

Fields also can be inserted in existing paragraph text and table cells. For more details 
about editing text, see “Changing paragraph text” on page 481 in this chapter. For 
more details about editing text in tables, see “Editing table text” on page 182.  

To insert a field directly in the drawing  
1 Do one of the following to choose Field ( ):     

• On the ribbon, choose Insert > Field (in Data).

• On the menu, choose Insert > Field > Field.

• Type field and then press Enter.

2 In Field Names, select the field you want to insert. 

The fields that display depend on the selected category.

3 Choose additional options, which vary according to the field you selected.

4 Click OK.

5 In the drawing, specify the insertion point.

Fields display with a gray background color.
To turn off the background color, set the FIELDDISPLAY system variable to off (0).
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Updating fields
Use the Update Field command to automatically regenerate field content in all enti-
ties you select.

To update fields 
1 Do one of the following to choose Update Field ( ):     

• On the ribbon, choose Insert > Update Field (in Data).

• On the menu, choose Insert > Field > Update Field.

• Type updatefield and then press Enter.

2 Select entities that contain fields, then press Enter.

A Select a category to filter the Field Names list, or 
select All to display all available fields.

B Select the field you want to insert.
C Displays the expression, similar to a formula, 

that is used to generate content for the selected 
field.

D Select format options for the selected field 
(varies according to the selected field).

E Displays additional options, if applicable for the 
selected field.

F Displays a preview of the field content, if 
available.

A

C

D

E

B
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Checking the spelling

You can check the spelling of text in your drawing, customize the dictionary to recog-
nize new words, and use a different spelling dictionary that supports another lan-
guage.

When editing text, the text is checked for spelling automatically and incorrectly 
spelled words display with a dashed red underline.

Checking the spelling of text
You can use the Check Spelling command to check the spelling of single-line text, 
multiline text, paragraph text, attributes, attribute definitions, and dimension text.          

To check the spelling of text     
1 Do one of the following to choose Check Spelling ( ):     

• On the ribbon, choose Annotate > Check Spelling (in Text).

• On the menu, choose Tools > Check Spelling.

• On the Standard toolbar, click the Check Spelling tool.

• Type spell and then press Enter.

2 Select one or more text entities.

3 In the Check Spelling dialog box, misspelled words display one at a time. Do one 
of the following for each found word:

• Keep text unchanged — Click Ignore to keep the found word unchanged in the 
drawing, or click Ignore All to keep all instances of the found word unchanged 
in the drawing.

• Change text — Select or type a word in the Suggestions box, then click Change 
to change the found word in the drawing to the new text, or click Change All to 
change all instances of the found word in the drawing.

4 Click Add if you want to add the currently found word to a list of custom spelling 
words. The Check Spelling dialog will recognize the added word as spelled cor-
rectly the next time the word is checked for spelling.
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Customizing the spelling words
Most drawings contain text that is not recognized as spelled correctly, even though it 
is spelled correctly. For example, if your company name Zaffer, Inc. appears in all of 
your drawings, the company name will appear as misspelled every time you check the 
spelling of drawing text. You can easily add words to a custom dictionary so that any 
word in the custom dictionary is recognized as spelled correctly. 

The custom dictionary is independent of any spelling dictionary you have chosen to 
use. You can check the spelling of text using one dictionary, check the spelling of the 
same or other text using a different dictionary, and in both cases your custom diction-
ary is used.

A Displays the current dictionary.
B Displays the misspelled word and its context in the 

drawing.
C Displays (or you can type) a new word to replace the 

misspelled word in the drawing.
D Click to select a new word to replace the currently 

found misspelled word.
E Click to select a new dictionary or modify a custom 

dictionary.
F Click to add the suggested word to the custom 

dictionary.

G Click to suggest additional words based on the 
selected word in the Suggestions list.

H Click to change all instances of the misspelled word 
to the suggested word.

I Click to change a single instance of the misspelled 
word to the suggested word.

J Click to skip all instances of the misspelled word.
K Click to skip a single instance of the misspelled word 

without changing it.

A

C

D

E
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To create and manage a custom dictionary
1 Do one of the following to choose Check Spelling ( ): 

• On the ribbon, choose Annotate > Check Spelling (in Text).

• On the menu, choose Tools > Check Spelling.

• On the Standard toolbar, click the Check Spelling tool.

• Type spell and then press Enter.

2 Select one or more text entities.

3 In the Check Spelling dialog box, click Change Dictionaries.

4 To add a custom word, type a word in Custom Dictionary Words, then click Add.

5 To delete a custom word, select a word in Custom Dictionary Words, then click 
Delete.

6 Click OK.

You can also add custom words to the custom dictionary during spell checking of text. 
In the Check Spelling dialog box, click Add to add the currently found word to the 
custom dictionary.

A Type a word for the custom dictionary.
B Displays the words in the custom dictionary.
C Click to delete the currently selected word from the 

custom dictionary.
D Click to add the current word in the edit box (A) to the 

custom dictionary.

E Click to select a different custom dictionary.
F Displays the custom dictionary filename. You can 

type a new path and filename or click Browse to 
select a file.

A
B

D

E
F

C
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Changing the dictionary
The Check Spelling command compares text found in the drawing with correctly 
spelled words in an installed dictionary (.dic file). There are many different dictionar-
ies that can be used with IntelliCAD, including dictionaries in different languages. 
You can download and install a new dictionary or use a dictionary already installed 
on your computer. 

To download and install a new dictionary 
1 Do one of the following to choose Check Spelling ( ): 

• On the ribbon, choose Annotate > Check Spelling (in Text).

• On the menu, choose Tools > Check Spelling.

• On the Standard toolbar, click the Check Spelling tool.

• Type spell and then press Enter.

• On the ribbon, choose Annotate > Check Spelling (in Text).

2 Select one or more text entities, then in the Check Spelling dialog box, click 
Change Dictionaries.

3 Click Download.

4 From the web page that displays (or from a different web page), download the 
desired dictionary.

5 Unzip the contents of the downloaded file to \MyDocuments\Spelling, or the loca-
tion where you installed spelling dictionaries for IntelliCAD.

6 Click Change Dictionaries again, which will load the newly installed dictionary.

7 In Main Dictionary, select the desired dictionary.

8 Click OK.
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To use a dictionary already installed on your computer 
1 Do one of the following:

• Copy the existing dictionary (.dic file) to \MyDocuments\Spelling, or to the 
location where you install spelling dictionaries for IntelliCAD.

• Add the folder of the existing dictionary to the list of folders where IntelliCAD 
searches for dictionaries. Choose Tools > Options, click Paths/Files and add the 
folder location to the Dictionary paths. For more details, see “Changing the 
options on the Paths/Files tab” on page 829.  

2 Choose Tools > Check Spelling, select one or more text entities, then in the 
Check Spelling dialog box, click Change Dictionaries.

3 In Main Dictionary, select the desired dictionary.

4 Click OK.

A Select the desired spelling dictionary. B Click to open the default Internet browser to a web 
page where you can download spelling dictionaries in 
different languages.

A
B
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Using an alternate text editor

IntelliCAD includes a built-in text editor for creating paragraph text using the Multi-
line Text command. You can also specify an alternate text editor for the Multiline 
Text command. 

Selecting an alternate text editor    
Before you can use an alternate text editor, you must specify the editor by setting the 
MTEXTED system variable. 

To select an alternate text editor     
1 Type mtexted and then press Enter.

2 Enter the path and name of the executable file for the text editor you want to use to 
create or edit multiline text. For example, to use Microsoft® Wordpad, you would 
type something similar to the following (adjusting the path name as necessary):

C:\Program Files\Windows\Accessories\Wordpad.exe

Creating paragraph text in an alternate text editor    
After you set up IntelliCAD to use an alternate text editor, you can start using it to 
include text in your drawings. 

To use an alternate text editor     
1 Do one of the following to choose Multiline Text ( ):

• On the ribbon, choose Home > Multiline Text (in Annotation) or Annotate > 
Multiline Text (in Text).

• On the menu, choose Draw > Multiline Text.

• On the Draw toolbar, click the Multiline Text tool.

• Type mtext and then press Enter. 

2 Select the first and second corners of the text area.

3 In the text editor, type the text you want, using the special characters from the 
table shown next to achieve special formatting. Enter \P to end a paragraph and 
start a new paragraph on the next line. For example, to use an alignment value of 1 
and stack two numbers to display them as a fraction:

{\A1;\S1/2;}\P 

4 When your text is complete, save the changes and exit the text editor. 

Special format character Function
\0...\o Toggles overscore mode on and off.

\L...\l Toggles underscore mode on and off.

\~ Inserts a nonbreaking space.
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Working with text written in different languages

You can include text in your drawings that is written in different languages.

Using Unicode characters
IntelliCAD supports the Unicode character encoding standard, which enables you to 
display and write text in different languages using different letters. Unicode fonts 
contain many more characters than typically defined in a system. The following table 
describes only a small set that is available 

\\ Inserts a backslash.

\{...\} Inserts an opening and closing brace.

\Cvalue; Sets the color to a specified value.

\File name; Sets the font based on a specified font file name.

\Hvalue; Sets the text height to a specified value.

\Hvaluex; Sets the text height to a multiple of the current text height.

\S...^...; Stacks the subsequent text at the /, #, or ^ symbol.

\Tvalue; Adjusts the space between characters, from 0.75 to 4 times.

\Qangle; Changes obliquing angle.

\Wvalue; Changes width factor to produce wide text.

\A Sets the alignment value.

\P Ends paragraph.

\p[i],[l],[tX1,X2,...,X32] Formats paragraph: i = first line indent; l = paragraph offset; t = tab 
positions.

Special format character Function

Unicode control code Function
\U+00B0 Draws a degree symbol (º).

\U+00B1 Draws the plus-or-minus symbol (±).

\U+0394 Draws the delta symbol (Δ). 

\U+2205 Draws the circle diameter symbol (Ø).

\U+03A9 Draws the omega symbol (Ω).

\U+2260 Draws the not equal symbol (≠).
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For details about using other special characters, see “Including special text charac-
ters” on page 479 in this chapter. You can also use a different text editor; see “Using 
an alternate text editor” on page 493 in this chapter. 

Specifying character sets for drawings
The character set used to display text in drawings typically depends on the character 
set specified by your operating system, for example, ANSI_1252 is Latin 1, 
ANSI_1253 is Greek, and ANSI_1254 is Turkish. This is also called the code page.

IntelliCAD allows you to manage which code page is assigned to a drawing. This 
unique feature is usually not necessary if you distribute drawings within the same 
geographic region, but it can be very helpful when sharing or distributing drawings 
between different geographic regions. Changing the code page is highly desirable 
especially in geographic regions where several languages are used that require differ-
ent character sets to display text properly.

Setting the code page doesn’t change the language of your text; instead it specifies 
the character set in which the text displays. Some fonts can display its characters sev-
eral different ways depending on the code page setting.

There are two system variables that relate to the code page of a drawing:

• SYSCODEPAGE — Character set defined for your operating system.

• DWGCODEPAGE — Character set defined for an individual drawing that over-
rides the operating system code page.

To select a code page for the current drawing
1 Type codepage and then press Enter.

The Code Page Manager dialog box opens.

2 If you want to convert the drawing to use a code page that is different from the 
operating system code page, in Drawing Code Page, select the new code page for 
the drawing.

3 Click OK.

A Displays the code page for the operating system. B Select the code page for the current drawing. 

B
A
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Working with missing fonts

When you open a drawing, the program displays text using fonts that are available on 
your computer: TrueType fonts installed when you started the program and SHX font 
files located, by default, in the \Fonts folder of your program installation.

If you open a drawing that contains text assigned a font that cannot be found, the pro-
gram attempts to substitute an alternate font for displaying the text. The following 
table describes the order in which the program searches for an alternate font, depend-
ing on the font type.

To add a search folder for where additional SHX files are stored
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Paths/Files tab.

3 In the upper half of the dialog box, in Support Paths > Fonts, click Add.

4 Enter a path for the folder where SHX font files are located, then press Enter. Or 
click Browse, select the folder, and then click Open.

5 Click OK.

To edit the default font mapping file
1 Open the program’s .fmp file in a text editor, such as Notepad.

By default, the .fmp file is located in the folder where you installed the program.

2 Enter font file names in pairs on a separate line using the following format:

missing_font.shx;alternate_font.shx

Font files can be .ttf or .shx font files.

3 When finished editing, click Save and close the text editor.

TrueType font SHX font
Font mapping file Font mapping file

Font defined for the text style Font defined for the text style

Similar font determined by Windows FONTALT system variable

User prompted to select font
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To specify a different font mapping file
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Paths/Files tab.

3 In the lower half of the dialog box, in Font Mapping, do one of the following:

• Enter a path and filename for the font map file, then press Enter.

• Click Browse, select the font map file you want, then click Open.

4 Click OK.

To change the FONTALT system variable
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Paths/Files tab.

3 In the lower half of the dialog box, in Alternate Font, do one of the following:

• Enter the SHX font file name, then press Enter.

• Click Browse, select the SHX font file you want, and then click Open.

4 Click OK.
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Dimensioning your drawing

The IntelliCAD dimensioning tools let you add measurements to a drawing. You can 
quickly add dimensions by simply pointing to entities. You can also add tolerance 
symbols to your drawings. 

The program’s many dimensioning variables let you control the appearance of the 
dimensions. With dimension styles, you can save dimension variable settings so you 
can reuse them without having to re-create them.

This section explains how to:

• Create dimensions as linear, angular, arcs, diametral, radial, and ordinate.

• Create leaders and annotations.

• Create center marks and center lines.

• Edit dimensions.

• Use dimension styles and variables.

• Add geometric tolerances.

• Control dimension tolerance.

• Control alternate dimension units.

Topics in this chapter

Understanding dimensioning concepts............................................................. 500

Creating dimensions ......................................................................................... 502

Creating center marks and center lines............................................................ 514

Editing dimensions............................................................................................ 516

Using dimension styles and variables............................................................... 523

Adding geometric tolerances ............................................................................ 538
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Understanding dimensioning concepts 

You can create five basic types of dimensions: linear, angular, radial, diametral, and 
ordinate. You can create dimensions for existing entities by selecting them, or you 
can create dimensions by selecting points within a drawing. For example, you can 
create a linear dimension either by selecting the entity to be dimensioned or by speci-
fying the first and second extension line origins.        
     

When you create a dimension, the program draws it on the current layer, using the 
current dimension style. Each dimension has a corresponding dimension style, which 
controls the appearance of the dimension, such as the types of arrowheads, text style, 
and colors of various components. You can modify existing dimension styles by 
changing one of the dimension variable settings and then updating the dimension 
style to reflect the new settings.    

Each dimension you create consists of several parts. A dimension line shows where a 
dimension begins and ends. When you create an angular dimension, the dimension 
line is a dimension line arc that subtends the measured angle.    

A Radial dimension.
B Vertical linear dimension.
C Angular dimension.
D Linear continued dimensions.

E Aligned dimension.
F Diametral dimension.
G Horizontal linear dimension.
H Linear baseline dimension.

A

B

C

D

E
F

H

G
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Extension lines, also called projection lines, are lines that extend away from the entity 
for which you are creating a dimension, so that you can place the dimension line 
away from the entity. Arrowheads form the termination at each end of the dimension 
line.   

Dimension text contains the measured dimension and can also include prefixes, suf-
fixes, tolerances, and other optional text. As you insert dimensions, you can control 
the dimension text and specify its position and orientation.      
  

Dimensions can also contain other optional components. A leader is a line leading 
from a feature of the drawing to an annotation. Leaders begin with an arrowhead, and 
you can use them to place a dimension away from the dimension line or to add notes. 
When you create a radial dimension, using its dimension style you can add a non-
associative center mark, which is a small cross that marks the center of a circle or an 
arc, or you can add center lines, which are crossing lines that extend out from the cen-
ter of a circle or an arc. Center marks and center lines can also be created as associa-
tive entities.

Dimensions can be one of three types:

• Associative — A dimension is linked with the entities it measures. If the entities 
being measured by the dimension are modified, the dimension is updated automat-
ically. Newly created dimensions are associative when DIMASSOC is set to 2 
(default) and created using entity snaps.

A Extension line.
B Arrowhead.

C Dimension line.
D Dimension text.

Leader. Center mark. Center mark with centerlines.

A
B

C D
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• Non-associative — A dimension is not linked with the entities it measures. If the 
entities being measured by the dimension are modified, the dimension is not 
updated automatically. Newly created dimensions are non-associative when 
DIMASSOC is set to 1.

• Exploded — Dimensions are created as separate entities, not a single dimension 
entity. Newly created dimensions are exploded when DIMASSOC is set to 0.    

Creating dimensions  

You can create dimensions by:    

• Selecting the entity to dimension and specifying the dimension line location.

• Specifying the extension line origins and the dimension line location.

When you create dimensions by selecting an entity, the program automatically places 
the extension line origins at the appropriate definition points based on the type of 
entity you select. For example, the definition points are located at the endpoints of 
arcs, lines, and polyline segments. When you create dimensions by specifying the 
extension line origins, the points you specify determine the definition points. To 
establish these points precisely, use entity snaps.    

You can create dimensions in model space or paper space.

There are many commands for creating dimensions, described next. Additionally, 
you can use the Quick Dimension command to quickly create a series of dimensions 
of the same type, simply follow the prompts.

Creating linear dimensions 
Linear dimensions annotate linear distances or lengths and can be oriented horizon-
tally, vertically, or aligned parallel to an existing entity or to the selected extension 
origin points. After you create a linear dimension, you can add a baseline dimension 
or a continued dimension. A linear baseline dimension inserts an additional dimen-
sion from a common first extension line origin of a previous linear dimension. A lin-
ear continued dimension continues a linear dimension from the second extension line 
of a previous linear dimension.    

Selecting exact points is important when creating dimensions. 
Use entity snaps to select precise ordinate points.
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To create a horizontal or vertical dimension
1 Do one of the following to choose Linear ( ):     

• On the ribbon, choose Home > Linear (in Annotation) or Annotate > Linear (in 
Dimensions).

• On the menu, choose Dimensions > Linear.

• On the Dimensioning toolbar, click the Linear tool.

• Type dimlinear and then press Enter.    

2 Press Enter, and then select the entity to dimension.    

Or, you can insert the dimension by specifying the first and second extension line 
origins.

3 Specify the dimension line location.     
       

To insert a linear dimension by selecting the entity, select 
the entity (A) to dimension, and then specify the 
dimension line location (B).

Result.

To insert a linear dimension by selecting the extension 
line origins, select the first extension origin (A), select the 
second extension origin (B), and then specify the 
dimension line location (C).

Result.

A

B

A

BC
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To create an aligned dimension    
1 Do one of the following to choose Aligned ( ):     

• On the ribbon, choose Home > Aligned (in Annotation) or Annotate > Aligned 
(in Dimensions).

• On the menu, choose Dimensions > Aligned.

• On the Dimensioning toolbar, click the Aligned tool.

• Type dimaligned and then press Enter.    

2 Press Enter, and then select the entity to dimension.

Or, you can insert the dimension by specifying the first and second extension line 
origins.

3 Specify the dimension line location.  
      

To insert an aligned dimension by selecting the entity, select 
the entity (A) to dimension, and then select the dimension line 
location (B).

Result.

To insert an aligned dimension by selecting the extension line 
origins, select the first extension origin (A), select the second 
extension origin (B), and then specify the dimension line location 
(C).

Result.

A

B

A

C B
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To create a linear baseline dimension
1 Create a dimension.

2 Do one of the following to choose Baseline ( ):    

• On the ribbon, choose Annotate > Baseline (in Dimensions).

• On the menu, choose Dimensions > Baseline.

• On the Dimensioning toolbar, click the Baseline tool.

• Type dimbaseline and then press Enter.    

3 To select a starting dimension, press Enter.

4 Select the next extension line origin, and then press Enter.

Or press Enter, and then select an existing dimension for the baseline. Select the 
origin of the next extension line, and then press Enter.

The program automatically places the new baseline dimension above or below the 
previous dimension line. The distance between the two dimension lines is determined 
by the Baseline Offset value in the Dimension Styles dialog box.    
     

To add a baseline dimension to an existing linear dimension, select the existing dimension (A), select the 
next extension line origin (B), and select as many additional points as you want (C).

Result.

A B

C
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To create a linear continued dimension
1 Create a dimension.

2 Do one of the following to choose Continue ( ):    

• On the ribbon, choose Annotate > Continue (in Dimensions).

• On the menu, choose Dimensions > Continue.

• On the Dimensioning toolbar, click the Continue tool.

• Type dimcontinue and then press Enter.     

3 To select a starting dimension, press Enter.

4 Select the next extension line origin, and then press Enter.

Or press Enter, and then select an existing dimension to continue.

5 To add continued dimensions, continue selecting extension line origins.

6 To end the command, press Enter twice. 
       

To add a continued dimension to an existing linear dimension, select the existing dimension (A), select the 
next extension line origin (B), and select another extension line origin (C).

Result.

A B

C
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Creating angular dimensions   
Angular dimensions annotate the angle measured between two lines. You can also 
dimension an angle by selecting an angle vertex and two endpoints. After you create 
an angular dimension, you can add a baseline dimension or a continued dimension. 
An angular baseline dimension inserts an additional dimension from a common first 
extension line origin of a previous angular dimension. An angular continued dimen-
sion continues an angular dimension from the second extension line of a previous 
angular dimension.       

To dimension an angle encompassed by an arc    
1 Do one of the following to choose Angular ( ):     

• On the ribbon, choose Home > Angular (in Annotation) or Annotate > Angular 
(in Dimensions).

• On the menu, choose Dimensions > Angular.

• On the Dimensioning toolbar, click the Angular tool.

• Type dimangular and then press Enter.    

2 Select the arc.

3 Specify the dimension arc location.        
  

To dimension the angle subtended by an arc, select 
the arc (A), and then specify the dimension arc 
location (B).

Result.

A

B
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To dimension an angle between two lines
1 Do one of the following to choose Angular ( ):    

• On the ribbon, choose Annotate > Angular (in Dimensions).

• On the menu, choose Dimensions > Angular.

• On the Dimensioning toolbar, click the Angular tool.

• Type dimangular and then press Enter.

2 Select one line.

3 Select the other line.

4 Specify the dimension line location. 
   

Creating arc dimensions   
Arc dimensions annotate the length of an arc or arc segment. You can also dimension 
a portion of an arc by selecting two points. After you create an arc dimension, you 
can change its text to the arc angle or to any other text.   

To dimension an arc length    
1 Do one of the following to choose Arc ( ):     

• On the ribbon, choose Home > Arc (in Annotation) or Annotate > Arc (in 
Dimensions).

• On the menu, choose Dimensions > Arc.

• On the Dimensioning toolbar, click the Arc tool.

• Type dimarc and then press Enter.    

2 Select the arc or arc segment.

3 Specify the dimension arc location.

Select one line (A), select the other line (B), and then 
specify the dimension line location (C).

Result.

A

B
C
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To dimension part of an arc length
1 Do one of the following to choose Arc ( ):     

• On the ribbon, choose Home > Arc (in Annotation) or Annotate > Arc (in 
Dimensions).

• On the menu, choose Dimensions > Arc.

• On the Dimensioning toolbar, click the Arc tool.

• Type dimarc and then press Enter.    

2 Choose Partial.

3 Select the start point of the arc length you want to measure.

4 Select the end point.
  

Creating diametral and radial dimensions  
Diameter and radius dimensions annotate the radii and diameters of arcs and circles. 
You can optionally include centerlines or center marks.    

To dimension the length of an arc, select the arc (A), 
and then specify the dimension arc location (B).

Result.

A

B

To dimension part of an arc length, select the arc (A), 
select the start point (B) and end point (C) of the 
portion to measure, then specify the dimension arc 
location (D).

Result.

A

D

B

C
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To create a diametral dimension    
1 Do one of the following to choose Diameter ( ):    

• On the ribbon, choose Home > Diameter (in Annotation) or Annotate > 
Diameter (in Dimensions).

• On the menu, choose Dimensions > Diameter.

• On the Dimensioning toolbar, click the Diameter tool.    

• Type dimdiameter and then press Enter.    

2 Select the arc or circle.

3 Specify the dimension line location.  
   

To create a radial dimension
1 Do one of the following to choose Radius ( ):     

• On the ribbon, choose Home > Radius (in Annotation) or Annotate > Radius (in 
Dimensions).

• On the menu, choose Dimensions > Radius.

• On the Dimensioning toolbar, click the Radius tool.

• Type dimradius and then press Enter.    

2 Select the arc or circle.

3 Specify the dimension line location.  
   

Select the circle (A), and then specify the dimension 
line location (B).

Result.

A B

Select the circle (A), and then specify the dimension line 
location (B).

Result.

A B
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Creating ordinate dimensions
An ordinate dimension annotates the perpendicular distance from an origin or base 
point (the origin of the current user coordinate system [UCS]). Ordinate dimensions 
consist of an x- or y-coordinate and a leader. An x-ordinate dimension measures dis-
tances along the x-axis; a y-ordinate dimension measures distances along the y-axis.    

As you select ordinate points, the program automatically determines whether the 
point is an x- or y-ordinate based on which direction you drag the second point. You 
can also specify whether the ordinate represents an x- or y-ordinate. Ordinate dimen-
sion text is always aligned with the ordinate leader lines, regardless of the text orien-
tation specified by the current dimension style.     

To create an ordinate dimension
1 Do one of the following to choose Ordinate ( ):     

• On the ribbon, choose Annotate > Ordinate (in Dimensions).

• On the menu, choose Dimensions > Ordinate.

• On the Dimensioning toolbar, click the Ordinate tool.

• Type dimordinate and then press Enter.    

2 Select the point for ordinate dimension.

3 Specify the ordinate leader endpoint.   

Ordinate dimensions measure the distance along the x- or y-axis from an origin to a selected ordinate point.
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Selecting exact points is important when creating dimensions. 
Use entity snaps to select precise ordinate points.

Creating leaders and annotations
Leaders consist of a line or series of lines that connects a feature in a drawing to an 
annotation. Generally, you place an arrowhead at the first point. An annotation, cre-
ated as dimension text, is placed immediately adjacent to the last point. By default, 
the text placed at the end of the leader line consists of the most recent dimension. You 
can also type an annotation as a single line of text.    

To create a leader and an annotation
1 Do one of the following to choose Leader ( ):     

• On the ribbon, choose Annotate > Leader (in Dimensions).

• On the menu, choose Dimensions > Leader.

• On the Dimensioning toolbar, click the Leader tool.

• Type dimleader and then press Enter.    

2 Specify the starting point of the leader.

3 Specify the endpoint of the leader line segment.

4 Specify additional leader line segment endpoints.

5 After you specify the last endpoint, press Enter.

6 Type the annotation, or press Enter to accept the most recent dimension as the 
default annotation.  

Select the ordinate point (A), and then specify the ordinate leader endpoint (B).

A B
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Dimensioning model space entities in paper space
To increase efficiency, you can separate your drawing model from annotations using 
the Model and Layout tabs. 

It takes time to display dimensions, title blocks, keynotes, and other annotations. If 
you draw these on a Layout tab, display-time and visual clutter are reduced when you 
work on your model (on the Model tab). IntelliCAD allows you to dimension model 
space entities on either the Model tab or a Layout tab — you can make the choice 
depending on the method that works best for your needs. 

To dimension model space entities in paper space
1 Click a Layout tab.

2 Create at least one layout viewport. For details, see “Creating layout viewports” 
on page 623. 

3 Select the edge of the layout viewport that you want to use for creating dimensions 
and lock the layout viewport by doing one of the following:

• Click Viewport Lock/Unlock in the status bar.

• Right-click the edge of the layout viewport, choose Properties, then choose 
Lock Viewports.

Locking the viewport is not required, but it is extremely helpful when you zoom or 
pan in the layout viewport; it prevents the viewport scale and view center from 
changing.

Specify the starting point of the leader (A) 
and the endpoint of the leader line segment 
(B).

Result.

A

B
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You can work in a layout viewport without having it clutter your display or selections. 
Place layout viewports on their own layer, and after locking the layout viewports, 
hide the layer that contains them.

4 Make sure you are working in paper space by verifying that Model or Paper Space 
in the status bar begins with “P.” If necessary, switch to paper space by double-
clicking Model or Paper Space in the status bar.

5 Create a dimension. You can select the model space entities directly, specify defi-
nition points, or use entities snaps to help accurately select the definition points.

The dimension is created in paper space.

For more details about using paper space and model space, see “Understanding paper 
space and model space” on page 616. 

Creating center marks and center lines

Center marks and center lines are associative dimensioning references that do not 
contain measurement data. A center mark is a small cross that marks the center of a 
circle or an arc. Center lines are linear entities drawn between two lines or two linear 
segments of polylines.

Both are associative, meaning that when the associated entity changes, so does the 
center mark or center line entity. This is different than the non-associative center 
marks and lines that can be drawn with dimension styles.

Creating center marks
Center marks can be added to a circle or arc, for example, marking a hole in a 
mechanical part. When you move or resize the associated entity, the center mark 
entity also moves or resizes.

Center mark.
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To create a center mark
1 Do one of the following to choose Center Mark ( ):     

• On the ribbon, choose Annotate > Center Mark (in Center Lines).

• On the menu, choose Dimensions > Center Mark.

• On the Dimensioning toolbar, click the Center Mark tool.

• Type centermark and then press Enter.    

2 Select the circle or arc that you want to add a center mark to. 

3 Continue to select circles or arcs, or press Enter to end the command.

You can change the appearance of center marks. 
To change the appearance of existing center marks, use the Properties pane or 
grips. To change the appearance of new center marks, before you draw them mod-
ify the CENTERCROSSSIZE, CENTERCROSSGAP, CENTEREXE, CENTERL-
TYPE, CENTERLTSCALE, and CENTERMARKEXE system variable values.

Creating center lines
A center line is an associative linear entity drawn between two lines or two linear seg-
ments of polylines. The center line is drawn using the apparent midpoints between the 
two start points and the two endpoints of the selected lines or segments. If selected 
lines or segments are not parallel, the center line is drawn using the intersection 
point—real or imaginary—and the midpoint between the endpoints of the selected 
lines.

To create a center line
1 Do one of the following to choose Center Line ( ):     

• On the ribbon, choose Annotate > Center Line (in Center Lines).

• On the menu, choose Dimensions > Center Line.

• On the Dimensioning toolbar, click the Center Line tool.

• Type centerline and then press Enter.    

2 Select the first line or linear polyline segment. 

3 Select the second line or linear polyline segment.

If specifying linear polyline segments, only the segment you pick, not the whole 
polyline, is used to calculate the location of the center line.

You can change the appearance of center lines. 
To change the appearance of existing center lines, use the Properties pane or 
grips. To change the appearance of new center lines, before you draw them modify 
the CENTERLTYPE, CENTERLTSCALE, and CENTEREXE system variable val-
ues.
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Editing dimensions 

The easiest way to edit dimensions is by using grips. Some tasks require an additional 
command though, such as the Dimension Break command for adding space around 
dimension and extension lines where they intersect other entities. This helps prevent 
dimensions from looking as if they are part of drawn entities. You might also want to 
quickly distribute equal space between the dimension lines of several dimensions. 
You can also use the Edit Dimension Text command to modify the dimension text 
and reposition it anywhere along the dimension line or the Make Oblique command 
to rotate dimension lines and dimension text at any angle. 

Spacing dimension lines
If your drawing contains several dimensions, you can distribute equal space between 
their dimension lines. The dimension must be linear or angular with dimension lines 
that are parallel.

To distribute equal space between dimension lines
1 Do one of the following to choose Adjust Spacing ( ):     

• On the ribbon, choose Annotate > Adjust Spacing (in Dimensions).

• On the menu, choose Dimensions > Adjust Spacing.

• On the Dimensioning toolbar, click the Adjust Spacing tool.

• Type dimspace, then press Enter.    

2 Select a linear or angular dimension from which dimension lines of other dimen-
sions are to be equally spaced.

3 Select the parallel linear or angular dimensions to adjust, and press Enter when 
done.

4 Enter a value for the spacing distance, or press Enter to adjust the distance auto-
matically to two times the text height of the base dimension.
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Breaking dimensions
A dimension break is a space on either side of an entity that intersects a dimension or 
extension line. Adding a break keeps the dimension from looking as if it is a part of 
drawn entities, and it can add clarity where dimension, extension, or leader lines 
intersect.

Dimension breaks can be applied to multileaders too.

After a break is added, it is updated automatically when the dimension, multileader, 
or intersecting entity is modified.

The size of a break gap is determined by the assigned dimension style.
To specify the break size, use the Dimension Styles Manager command. For more 
details, see “Using dimension styles and variables” on page 523 in this chapter. 

To break a dimension (or multileader)
1 Do one of the following to choose Dimension Break ( ):     

• On the ribbon, choose Annotate > Dimension Break (in Dimensions).

• On the menu, choose Dimensions > Dimension Break.

• On the Dimensioning toolbar, click the Make Oblique tool.

• Type dimbreak, then press Enter.    

2 Select the dimension or multileader that you want to break. To break or restore 
more than one dimension or multileader, choose Multiple, then select them.

3 Do one of the following:

• Select the entity that crosses the dimension or multileader where the break is 
needed.

• Choose Auto to place breaks at each point where the selected dimension inter-
sects with other entities.

• Choose Manual to add a break to the selected dimension or multileader 
manually, then specify two break points (not available when Multiple is 
selected).

4 When finished, press Enter.
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To remove breaks from a dimension (or multileader)
1 Do one of the following to choose Dimension Break ( ):     

• On the ribbon, choose Annotate > Dimension Break (in Dimensions).

• On the menu, choose Dimensions > Dimension Break.

• On the Dimensioning toolbar, click the Make Oblique tool.

• Type dimbreak, then press Enter.    

2 Select the dimension or multileader that you want to break. To break or restore 
more than one dimension or multileader, choose Multiple, then select them.

3 Choose Remove to remove all existing breaks from the selected dimensions or 
multileaders.

Specify the dimension (A) and 
the intersecting entity (B).

Result.
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Making dimensions oblique    
Extension lines are normally created at a perpendicular angle to the dimension line. 
You can change the angle of the extension lines, however, so that they tilt relative to 
the dimension line.    

To make oblique extension lines
1 Do one of the following to choose Make Oblique ( ):     

• On the ribbon, choose Annotate > Make Oblique (in Dimensions).

• On the menu, choose Dimensions > Make Oblique.

• On the Dimensioning toolbar, click the Make Oblique tool.

• Type dimedit, press Enter, and then in the prompt box, choose Oblique Lines.    

2 Select the linear dimension, and then press Enter.

3 Type the obliquing angle, and then press Enter.      
  

You can align the oblique angle if you don’t know the exact measurement. 
Use entity snaps to pick two points on the entity.

Select the dimension to be made oblique (A), and then type 
the obliquing angle.

Result.

A



520 C H A P T E R  1 2
Editing dimension text
You can rotate the text of an existing dimension, move the dimension text to a new 
position, or replace selected dimension text with new text. You can also restore 
dimension text to its original position as defined by the current dimension style.

When you rotate or replace selected text, you specify the change first, and then select 
one or more dimensions to which to apply the change. All the selected dimensions are 
updated simultaneously.

To rotate dimension text
Advanced experience level      

1 Do one of the following to choose Rotate Dimension Text ( ):

• On the ribbon, choose Annotate > Rotate Dimension Text (in Dimensions).

• On the menu, choose Dimensions > Rotate Dimension Text.

• On the Dimensioning toolbar, click the Rotate Dimension Text tool.

• Type dimedit, press Enter, and then in the prompt box, choose Rotate Text.

2 Type the new dimension text angle, and then press Enter.

3 Select the dimension to be rotated, and then press Enter. 
   

The dimension text angle is relative to the dimension line.  
If the dimension text rotation is set to zero, the text angle is defined by the dimension 
type and the dimension style.   

Select the dimension to be rotated (A), and then 
type the rotation angle.

Result.

A
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To move dimension text
Advanced experience level    

1 Do one of the following to choose Reposition Dimension Text ( ):

• On the ribbon, choose Annotate > Reposition Dimension Text (in Dimensions).

• On the menu, choose Dimensions > Reposition Dimension Text.

• On the Dimensioning toolbar, click the Reposition Dimension Text tool.

• Type dimtedit and then press Enter.

2 Select the dimension to reposition text.

3 Select the new text position.  
    

To restore dimension text to its home position    
Advanced experience level     

1 Do one of the following to choose Restore Text Position ( ):

• On the ribbon, choose Annotate > Restore Text Position (in Dimensions).

• On the menu, choose Dimensions > Restore Text Position.

• On the Dimensioning toolbar, click the Restore Text Position tool.

• Type dimedit, press Enter, and then in the prompt box, choose Restore Text.

2 Select the dimension text to restore, and then press Enter.

To replace existing dimension text with new text    
Advanced experience level    

1 Do one of the following to choose Edit Dimension Text ( ):

• On the ribbon, choose Annotate > Edit Dimension Text (in Dimensions).

• On the menu, choose Dimensions > Edit Dimension Text.

• On the Dimensioning toolbar, click the Edit Dimension Text tool.

• Type dimedit and then in the prompt box, choose Edit Text.

2 Type the new dimension text, and then press Enter.

3 Select the dimension to be replaced, and then press Enter.

Select the dimension to be moved (A), and then select 
the new text position (B).

Result.

A
B



522 C H A P T E R  1 2
To restore dimension text to its original text value    
1 Do one of the following to choose Reset Dimension Text ( ):

• On the ribbon, choose Express Tools > Reset Dimension Text (in Dimension).

• On the menu, choose Express Tools > Dimensions > Reset Dimension Text.

• Type dimreassoc and then press Enter.

2 Select the dimension text to restore, and then press Enter.

To reassociate dimension text with a new entity or point on an entity   
1 Do one of the following to choose Reassociate Dimensions ( ):

• On the ribbon, choose Annotate > Reassociate Dimensions (in Dimensions).

• On the menu, choose Dimensions > Reassociate Dimensions.

• Type dimreassociate and then press Enter.

2 Select the dimensions you want to reassociate with a different entity or point, and 
then press Enter.

3 Follow the prompts to select a new entity or point on an entity. The prompts that 
display vary according to the type of dimensions you selected.
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Using dimension styles and variables  

Dimensions that you insert are created using the current dimension style. You can 
create, save, restore, and delete named dimension styles.  

To display information about the current dimension style and compare it with other 
style names, you can use the dimstyle command.

Creating a dimension style
Dimension styles provide a way for you to change various settings that control the 
appearance of dimensions. You can then save those settings for reuse. If you don’t 
define a dimension style before creating dimensions, the program uses the Standard 
dimension style, which stores the default dimension variable settings. Each option in 
the Dimension Styles dialog box relates to a variable that you can set manually. See 
the online Command Reference for more information.

To create a dimension style
1 Do one of the following to choose Dimension Styles Manager ( ):    

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).

• On the menu, choose Dimensions > Dimension Styles Manager or choose 
Format > Dimension Styles Manager.

• On the Dimensioning toolbar, click the Dimension Styles tool.

• Type setdim and then press Enter.

2 In the Dimension Styles Manager dialog box, click New.

3 Type the name of the new dimension style.

4 Click Continue.

5 In the Dimension Styles dialog box, make your selections for the dimension style 
as necessary.

6 When finished, click OK.
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Selecting a dimension style

To select a dimension style
1 Do one of the following to choose Dimension Styles Manager ( ):

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).

• On the menu, choose Dimensions > Dimension Styles Manager or choose 
Format > Dimension Styles Manager.

• On the Dimensioning toolbar, click the Dimension Styles tool.

• Type setdim and then press Enter.

2 In the Dimension Styles Manager dialog box, select a dimension style from the 
list.

3 Click Set Current.

4 Click Close.

Renaming a dimension style

To rename a dimension style
1 Do one of the following to choose Dimension Styles Manager ( ):    

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).

• On the menu, choose Dimensions > Dimension Styles Manager or choose 
Format > Dimension Styles Manager.

• On the Dimensioning or Styles toolbar, click the Dimension Styles Manager 
tool.

• Type setdim and then press Enter.

2 In the Dimension Styles Manager dialog box, click Rename.

3 In the Rename list, select the dimension style you want to rename.

4 Type the new dimension style name.

5 Click Rename.

6 Click OK.
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Deleting a dimension style

To delete a named dimension style
1 Do one of the following to choose Dimension Styles Manager ( ):    

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).

• On the menu, choose Dimensions > Dimension Styles Manager or choose 
Format > Dimension Styles Manager.

• On the Dimensioning or Styles toolbar, click the Dimension Styles Manager 
tool.

• Type setdim and then press Enter.

2 In the Dimension Styles dialog box, select the dimension style to delete.

3 Click Delete.

4 To confirm the deletion, click OK.

5 Click OK.

To display information about the current style
1 Type dimstyle and then press Enter.   

2 Type v and then press Enter to display information about the variables.

3 Type the dimension style name, and press Enter.

Controlling line settings  
You can control settings affecting dimension lines, extension lines, and center marks. 
Any changes you make affect the current dimension style. The image tile on the right 
side of the Dimension Styles dialog box shows the appearance of the dimensions 
based on the current dimension style settings.        

A Extend past dimension.
B Baseline offset.

C Offset from origin.

A

B

C
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To set the color for dimension lines    
1 Do one of the following to choose Dimension Styles Manager ( ):     

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).

• On the menu, choose Dimensions > Dimension Styles Manager or choose 
Format > Dimension Styles Manager.

• On the Dimensioning or Styles toolbar, click the Dimension Styles Manager 
tool.

• Type setdim and then press Enter.

2 Click the Lines tab.

3 Make your selections.

4 Click OK.
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A Select the dimension line color.
B Select the dimension linetype.
C Select the dimension lineweight.
D Type or select the distance that dimension lines 

extend beyond tick marks.
E Type or select the baseline offset distance (the 

distance to offset successive dimension lines 
when creating baseline dimensions) and the 
offset from origin (the distance extension lines 
are offset from their origin points).

F Click to prevent the creation of the first or second 
dimension line.

G Select the extension line color.
H Select the first extension line linetype.
I Select the second extension line linetype.
J Select the extension lineweight.
K Click to prevent the creation of the first or second 

extension line.
L Click to set the length of extension lines to 

always be a set length, then type or select the 
extension line length.

M Type or select the distance to offset extension 
lines from dimension lines.

N Type or select the distance to offset extension 
lines from their origin.

A
B
C

G
H

F

I

D
E

K L
M
N

J
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Controlling dimension arrows   
You can control the appearance and size of arrowheads or tick marks placed at the 
ends of dimension lines. Any changes you make affect the current dimension style. 
The arrowheads you choose display in the image tile on the right side of the Dimen-
sion Styles dialog box.    

You can choose from a number of arrowhead types. You can specify different arrow-
heads for each end of a dimension line and for leader lines. The Starting arrow corre-
sponds to the first extension line; the Ending arrow corresponds to the second 
extension line. Blocks defined in the drawing also display in the three Arrowhead 
lists as user-defined arrows. You can use these blocks to create and assign your own 
arrowheads.

The Arrow Size value determines the size of the arrowhead, measured in drawing 
units. You can also use tick marks instead of arrowheads.    

To choose an arrowhead
1 Do one of the following to choose Dimension Styles Manager ( ):

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).

• On the menu, choose Dimensions > Dimension Styles Manager or choose 
Format > Dimension Styles Manager.

• On the Dimensioning or Styles toolbar, click the Dimension Styles Manager 
tool.

• Type setdim and then press Enter.    

2 Click the Symbols and Arrows tab.   

3 In the Starting Arrowhead or Ending Arrowhead list, click to select the starting or 
ending arrowhead, respectively. If necessary, mark Allow Separate Arrowheads if 
you want to use different starting and ending arrowheads.

4 In the Leader Arrowhead list, click to select a leader arrowhead for leader lines.

5 Click OK.

Use the system variable.  
The DIMLDRBLK system variable also specifies leader arrow types. 
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A Select to enable the ability to use different 
starting and ending arrowheads.

B Click to select a starting arrowhead, or click the 
arrowhead picture to scroll the list automatically.

C Click to select an ending arrowhead, or click the 
arrowhead picture to scroll the list automatically.

D Click to select a leader arrowhead, or click the 
arrowhead picture to scroll the list automatically.

E Type or select arrowhead size.
F Select to enable tick marks instead of 

arrowheads, then type or select tick mark size.

G Enter the size of dimension breaks.
H Select the symbol for center marks.
I Type or select center mark size. Positive values 

create a center mark. Negative values create 
centerlines.

J Type or select the angle for the jog of radius 
dimensions.

K Type or select the scale factor for the jog height 
of linear dimensions.

L Select where to position arc symbols for arc 
dimensions.

H
I

A

B

C

F

E

D

J
K

L
G
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Controlling dimension text 
You can control the settings affecting the appearance of dimension text. Any changes 
you make affect the current dimension style. The image tile on the right side of the 
Dimension Styles dialog box shows the appearance of the dimensions based on the 
current dimension style settings.         

To align dimension text with the dimension line    
1 Do one of the following to choose Dimension Styles Manager ( ):     

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).

• On the menu, choose Dimensions > Dimension Styles Manager or choose 
Format > Dimension Styles Manager.

• On the Dimensioning or Styles toolbar, click the Dimension Styles Manager 
tool.

• Type setdim and then press Enter.     

2 Click the Text tab.     

3 Make your selections.

4 Click OK.

Text between extension lines aligned 
horizontally.

Text between extension lines 
aligned with dimension line.
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A Click to select the text style used for dimension 
text. Click [...] to manage text styles.

B Select the dimension text color.
C Select none, drawing color, or user color for the  

dimension text background color.
D Select the color for dimension text backgrounds 

(available if User Color is selected for Text 
Background).

E Type or select the text height, measured in 
drawing units.

F Select the vertical justification of dimension text.

G Type or select the vertical text offset distance.
H Select the horizontal justification of dimension text.
I Select the view direction of dimension text.
J Select the alignment when dimension text is 

outside extension lines.
K Select the alignment when dimension text is inside 

extension lines.
L Type or select the distance around the dimension 

text.
M Click to include a frame around dimension text.

A
B
C
D
E

F
G
H
I

J
K L

M
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Controlling dimension fit 
You can control the way dimension text and arrowheads are placed in relation to the 
dimension lines. You can also control how the dimension scales by choosing whether 
it is annotative by default or whether it scales according to a specific scale or accord-
ing to the layout. Any changes you make affect the current dimension style. The 
image tile on the right side of the Dimension Styles dialog box shows the appearance 
of dimensions based on the current dimension style settings.       

The program determines whether both dimension text and arrowheads will fit 
between the extension lines by comparing the distance between the extension lines to 
the size of the dimension text, the size of the arrowheads, and the amount of space 
required around dimension text. The program applies the best fit method based on the 
available space. If possible, both the dimension text and arrowheads are placed 
between the extension lines. If both will not fit between the extension lines, you can 
determine how text and arrowheads are placed using the Fit Method settings on the 
Dimension Styles dialog box.     

To format the fit of dimensions     
1 Do one of the following to choose Dimension Styles Manager ( ):    

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).

• On the menu, choose Dimensions > Dimension Styles Manager or choose 
Format > Dimension Styles Manager.

• On the Dimensioning or Styles toolbar, click the Dimension Styles Manager 
tool.

• Type setdim and then press Enter.    

2 Click the Fit tab.

3 Click the options that you want.

4 Click OK. 

Use the system variables. 
The DIMATFIT system variable specifies how dimension text and arrows are 
arranged. The DIMTMOVE system variable specifies how dimension text is moved.

Text and arrowheads placed 
outside extension lines.

Text placed between extension 
lines and arrowheads outside 
extension lines.

Text placed above 
dimension line with a leader 
connecting the text to the 
dimension line.
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A Select how to fit text and arrows if they both do 
not fit inside extension lines.

B Select to always place text inside extension 
lines.

C Select to prevent the creation of arrows if they 
don’t fit inside extension lines.

D Select to draw dimension lines between 
extension lines when text and arrows are placed 
outside extension lines.

E Select how to position text relative to dimension 
lines and whether to include a leader.

F Select to be prompted for text placement when 
creating dimensions.

G Select to scale the dimension according to the 
layout or enter a specific scale to apply to all 
dimension style settings (available only if 
Annotative is not selected.)

H Select to make the dimension support annotative 
scaling by default.

A

B
C

D

E

F

H
G
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Controlling primary dimension units 
You can determine the appearance and format of the primary dimension units. The 
image tile on the right side of the Dimension Styles dialog box shows the appearance 
of the dimensions based on the current dimension style settings.         

To set the primary units of dimensions        
1 Do one of the following to choose Dimension Styles Manager ( ):     

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).

• On the menu, choose Dimensions > Dimension Styles Manager or choose 
Format > Dimension Styles Manager.

• On the Dimensioning or Styles toolbar, click the Dimension Styles Manager 
tool.

• Type setdim and then press Enter.    

2 Click the Primary Units tab.

3 Make your selections.

4 Click OK. 

Use the system variables. 
The DIMLUNIT system variable specifies units for linear dimensions. The DIMFRAC 
system variable specifies fraction formats.

Round off distance set to .0100 
(original dimension before 
rounding).

Round off distance set to 
0.2500.

Round off distance set 
to 1.0000.
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A Select the linear dimension unit format.
B Type or select the number of decimal places for 

text of linear dimensions.
C Select the format for text fractions of linear 

dimensions.
D Enter the marker symbol used for decimals.
E Type or select the nearest value to round to for 

linear distances.
F Type a prefix to be appended to linear dimension 

text.
G Type a suffix to be appended to linear dimension 

text.
H Select to prevent the inclusion of trailing zeros 

for linear dimension text.
I Select to prevent the inclusion of leading zeros 

for linear dimension text.

J Select to prevent the inclusion of inches or feet  
in dimension text when the corresponding 
number of inches or feet is zero.

K Select to prevent the inclusion of leading zeros 
for angular dimensions.

L Select the angular dimension unit format.
M Type or select the number of decimal places for 

angular dimensions.
N Select to prevent the inclusion of trailing zeros 

for angular dimensions.
O Type or select the linear scale factor applied to 

all lengths measured by dimensioning 
commands.

P Type or select the scale factor applied to all 
dimensions.

A
B
C
D
E

G
H
I

J

F

K
PL

M
N

O
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Controlling alternate dimension units   
You can include alternate dimensions in addition to the primary dimension text. You 
can also determine the appearance and format of the alternate dimensions, including 
the scale factor applied to generate alternate dimensions. The image tile on the right 
side of the Dimension Styles dialog box shows the appearance of the dimensions 
based on the current dimension style settings.    

To control alternate dimension units
1 Do one of the following to choose Dimension Styles Manager ( ):

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).

• On the menu, choose Dimensions > Dimension Styles Manager or choose 
Format > Dimension Styles Manager.

• On the Dimensioning or Styles toolbar, click the Dimension Styles Manager 
tool.

• Type setdim and then press Enter.

2 Click the Alternate Units tab.

3 Select Display Alternate Units.

4 Make your selections.

5 Click OK.

Alternate dimension created using a scale factor of 25.4, with an appended suffix.
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A Select to include alternate units with dimension 
text.

B Click to select the format for alternate dimension 
text.

C Type or select the number of decimal places 
displayed in alternate dimension text.

D Type or select the scale factor applied to 
measured dimensions to generate the alternate 
dimension text.

E Type or select any rounding for alternate 
dimension text.

F Type a prefix to be appended to alternate 
dimension text.

G Type a suffix to be appended to alternate 
dimension text.

H Select the placement of alternate dimension text.
I Select to prevent the inclusion of trailing zeros 

for alternate dimension text.

J Select to prevent the inclusion of leading zeros 
for alternate dimension text.

K Select to prevent the inclusion of inches or feet  
in alternate dimension text when the 
corresponding number of inches or feet is zero.

L Select to prevent the inclusion of leading zeros 
for tolerances included as part of alternate 
dimensions.

M Select to prevent the inclusion of trailing zeros 
for tolerances included as part of alternate 
dimensions. 

N Select to prevent the inclusion of inches or feet 
for tolerances included as part of alternate 
dimensions when the corresponding number of 
inches or feet is zero.

O Type or select the number of decimal places 
displayed in limits or tolerances included as part 
of alternate dimensions.

A

B
C
D
E

H
I

J

F

L
M

O

G

NK
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Adding geometric tolerances    

Geometric tolerances indicate the maximum allowable variations in the geometry 
defined by a drawing. IntelliCAD draws geometric tolerances using a feature control 
frame, which is a rectangle divided into compartments.    

Understanding geometric tolerances
Each feature control frame consists of at least two compartments. The first compart-
ment contains a geometric tolerance symbol that indicates the geometric characteris-
tic to which the tolerance is applied, such as location, orientation, or form. For 
example, a form tolerance may indicate the flatness or roundness of a surface. The 
geometric tolerance symbols and their characteristics are shown in the following 
table.                                                                   

Geometric tolerance symbols
Symbol Characteristic Type

Position Location

 Concentricity or coaxiality Location

 Symmetry Location

 Parallelism Orientation

 Perpendicularity Orientation

 Angularity Orientation

 Cylindricity Form

 Flatness Form

 Circularity or roundness Form

 Straightness Form

 Profile of a surface Profile

 Profile of a line Profile

 Circular runout Runout

 Total runout Runout
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The second compartment contains the tolerance value. When appropriate, the toler-
ance value is preceded by a diameter symbol and followed by a material condition 
symbol. The material conditions apply to features that can vary in size. The material 
condition symbols and their meanings are shown in the following table.      

The tolerance value can then be followed by primary, secondary, and tertiary datum 
reference letters, along with the material conditions of each datum. Datum reference 
letters are generally used as reference tolerances to one of up to three perpendicular 
planes from which a measurement is made, although datum reference letters can also 
indicate an exact point or axis.       

When two tolerances apply to the same geometry, you can also add a composite toler-
ance consisting of a primary tolerance value followed by a secondary tolerance value. 
To make a tolerance even more specific, it can also contain a projected tolerance con-
sisting of a height value followed by a projected tolerance symbol. For example, you 
can use a projected tolerance to indicate the perpendicularity of an embedded part.       

Material conditions
Symbol Definition

At maximum material condition (MMC), a feature contains the maximum amount of 
material stated in the limits.

At least material condition (LMC), a feature contains the minimum amount of 
material stated in the limits.

Regardless of feature size (RFS) indicates that the feature can be any size within 
the stated limits.

A Geometric characteristic symbol.
B Diameter symbol.
C Tolerance value.

D Material condition symbol.
E Datum reference.

A B C D E
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Adding a geometric tolerance

To add a geometric tolerance
1 Do one of the following to choose Tolerance ( ):     

• On the ribbon, choose Annotate > Tolerance (in Dimensions).

• On the menu, choose Dimensions > Tolerance.

• On the Dimensioning toolbar, click the Tolerance tool.

• Type tolerance and then press Enter.    

2 To display the geometric tolerance symbols, on the first line, click the Sym box.

3 Click to select a geometric tolerance symbol.

4 Under Tolerance 1, click the Dia box to add a diameter symbol.

5 In the field, type the first tolerance value.

6 To display the material condition symbols, click the M.C. box.

7 Click to select a material condition.

8 Under Tolerance 2, repeat steps 4 through 7 to add a secondary tolerance value, if 
appropriate.

9 Under Datum 1, type the primary datum reference letter.    

10 To display the material condition symbols, click the M.C. box.

11 Click to select a material condition.

12 Repeat steps 9 through 11 to add secondary and tertiary datum, if appropriate.

13 In the second row, repeat steps 2 through 12 to add composite tolerances, if 
appropriate.

14 In the Height box, type a projected tolerance zone height value, if appropriate.

15 To insert a projected tolerance zone symbol, click the Projected Tolerance Zone 
box, if appropriate.

16 Click OK.

17 In the drawing, specify the location of the feature frame.
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Controlling dimension tolerances   
You can create dimensions as either tolerance or limits dimensions. When creating a 
tolerance dimension, you can control the upper and lower tolerance limits as well as 
the number of decimal places of the dimension text. The image tile on the right side 
of the Dimension Styles dialog box shows the appearance of tolerance and limits 
dimensions based on the current dimension style settings.    

A Use this row to include composite tolerances.
B Type a projected tolerance height value.
C Type a datum identifier.
D Click to include a projected tolerance symbol.
E Click to select the material condition symbol for tertiary 

data.
F Type the tertiary datum reference letter.
G Click to select the material condition symbol for 

secondary datum.
H Type the secondary datum reference letter.
I Click to select the material condition symbol for primary 

datum.

J Type the primary datum reference letter.
K Click to select the material condition symbol for the 

second tolerance value.
L Type the second tolerance value.
M Click to include a diameter symbol for the second 

tolerance value.
N Click to select the material condition symbol for the first 

tolerance value.
O Type the first tolerance value.
P Click to include a diameter symbol for the first tolerance 

value.
Q Click to select a geometric tolerance symbol.

A

B
C

D

EFGHIJKLMNOPQ

Tolerance dimension. Limits dimension.
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The display of zero tolerance values depends on the measurement units.
Metric drawings follow the Metric ISO Dimension Standards and display zero toler-
ance values without a plus or minus sign (0.0). For Imperial drawings, zero tolerance 
values display with a plus or minus sign (+0.0 or -0.0). To check the drawing mea-
surement type, use the MEASUREMENT system variable.

To control dimension tolerances
1 Do one of the following to choose Dimension Styles Manager ( ):

• On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).

• On the menu, choose Dimensions > Dimension Styles Manager or choose 
Format > Dimension Styles Manager.

• On the Dimensioning or Styles toolbar, click the Dimension Styles Manager 
tool.

• Type setdim and then press Enter.

2 Click the Tolerance tab.

3 Make your selections.

4 Click OK.
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A Select to insert a plus and minus tolerance value 
with dimension text.

B Select to insert upper and lower tolerance limits 
with dimension text.

C Type or select the number of decimal places 
displayed in limits or tolerance dimension text.

D Type or select the minimum tolerance or lower 
limit value.

E Type or select the maximum tolerance or upper 
limit value.

F Type or select the scale factor applied to the 
height of limits or tolerance dimension text.

G Select the vertical justification of limits or 
tolerance dimension text.

H Select to prevent the inclusion of trailing zeros in 
limits or tolerance dimension text.

I Select to prevent the inclusion of leading zeros in 
limits or tolerance dimension text.

J Select to prevent the inclusion of inches or feet  
in limits or tolerance dimension text when the 
corresponding number of inches or feet is zero.

A
B

C
D
E
F
G
H

I

J
K
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13

Working with other files in your drawings

Blocks, attributes, and external references provide mechanisms for managing entities 
in your drawings and for including additional information with the standard drawing 
entities. With blocks, you can combine numerous entities into a single entity, and 
then reuse it, inserting multiple copies. With attributes, you can associate text, such as 
part numbers or prices, with blocks, and then extract the text-attribute information to 
a separate file, such as a database, for further analysis. With external references, you 
can link separate reference drawing files to a drawing to combine information without 
adding the contents of the reference drawings to the current drawing. If you make 
changes to the referenced file, all references are updated automatically.

This section explains how to:

• Create, insert, and redefine blocks.

• Create, edit, and insert attributes.

• Extract attribute data to a separate file.

• Attach and work with external references and underlays.

• Link and update data between drawings and spreadsheets.

• Use images in your drawings.

• Use a geographic location in your drawings.

Topics in this chapter

Working with blocks .......................................................................................... 546

Working with attributes ..................................................................................... 563

Working with external references...................................................................... 571

Attaching underlays created in other file formats.............................................. 585

Working with data links ..................................................................................... 590

Working with images......................................................................................... 596

Working with geographic locations ................................................................... 606
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Working with blocks    

Usually, blocks are several entities combined into one that you can insert into a draw-
ing and manipulate as a single entity. A block can consist of visible entities such as 
lines, arcs, and circles, as well as visible or invisible data called attributes. Blocks are 
stored as part of the drawing file.    

Understanding blocks
Blocks can help you better organize your work, quickly create and revise drawings, 
and reduce drawing file size. Using blocks, you can create a library of frequently used 
symbols. Then you can insert a symbol as a block rather than redraw the symbol from 
scratch.    

After you create a block from multiple entities, you save it once, which also saves 
disk space. You insert only multiple references to a single block definition. You can 
change the block definition to quickly revise a drawing, and then update all instances 
of the block.    

If you insert a block that contains entities originally drawn on layer 0 and assigned 
color and linetype BYLAYER, it is placed on the current layer and assumes the color 
and linetype of that layer. If you insert a block that contains entities originally drawn 
on other layers or with explicitly specified colors or linetypes, the block retains the 
original settings.    

If you insert a block that contains entities originally assigned color and linetype 
BYBLOCK, and the block itself has the color and linetype BYLAYER, those entities 
adopt the color and linetype of the layer onto which they are inserted. If the block is 
assigned an explicit color or linetype, such as red or dashed, those entities adopt those 
qualities.    

A procedure called nesting occurs when you include other blocks in a new block that 
you are creating. Nesting is useful when you want to combine and include small com-
ponents, such as nuts and bolts, into a larger assembly and you need to insert multiple 
instances of that assembly into an even larger drawing.    

Some blocks are called dynamic and have associated parameters and actions. You 
can’t create dynamic blocks using IntelliCAD, but  you can insert any dynamic block 
that was created using a different CAD application.

The quickest way to create and save blocks is using the Block Editor. It allows you to 
draw and save the block in-place, directly in the drawing area. You can also create 
blocks using individual block commands. A third way of creating blocks is using 
IntelliCAD’s Explorer. For details about creating blocks using the Explorer, see 
“Working with blocks” on page 345. 
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Creating and saving a block using the Block Editor      
When you create a block using the Block Editor, you specify its name and then draw 
the entities that compose the block directly in the drawing area. While creating the 
block in-place, you can save the block with its existing name or a new name. 

The insertion point of the created block is automatically defined relative to the UCS.

To create a block using the Block Editor
1 Do one of the following to choose Block Editor ( ):

• On the ribbon, choose Home > Block Editor (in Block Definition) or choose 
Insert > Block Editor (in Block Definition).

• Type bedit and then press Enter.

2 In the Edit Block Definition dialog box, enter a name and description for the new 
block.    

3 Click OK.

4 Draw the entities that make up the block.

5 Do one of the following to choose Save Block :

• On the ribbon, choose Block Editor > Save Block.

• On the floating toolbar (if the ribbon is not displayed), choose Save Block.

• Type bsave and then press Enter.

6 Do one of the following to choose Close Block Editor ( ):

• On the ribbon, choose Block Editor > Close Block Editor.

• On the floating toolbar (if the ribbon is not displayed), choose Close Block 
Editor.

• Type bclose and then press Enter.

The program adds the new block to the blocks list, with the name you entered for 
it.

If you often include blocks in your drawings, you can create a tool palette that con-
tains the blocks you use most often. For details, see “Creating tool palettes and add-
ing commands and blocks” on page 864. 

An existing block instance can easily be used to create a new block. 
Use the Rename Block command to create a new block by renaming a single block 
instance. Use the Change Block command to change the name of a single block 
instance and then open the Block Editor where you can modify it.
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Creating and saving a block using individual commands
When you create a block using the Block command, you specify its name, its inser-
tion point, and the entities that compose the block. The insertion point is the base 
point for the block and serves as the reference point when you later insert the block 
into a drawing.    

The new block you create exists only in the current drawing, unless you save it sepa-
rately using the Save Block to Disk command.

Creating a block for use within the current drawing

To create a block for use within a current drawing
Advanced experience level    

1 Do one of the following to choose Create Block ( ):

• On the ribbon, choose Home > Create Block (in Block) or choose Insert > Create 
Block (in Block Definition).

• On the menu, choose Draw > Block > Create Block.

• On the Tools toolbar, click the Create Block tool.

• Type block and then press Enter.

2 In the Block definition dialog box, enter a name and description for the new block.    

3 Specify the insertion point for the block by doing one of the following:

• Specify on Screen Mark this check box to select the base point in the drawing 
after you click OK.

• Pick Base Point Click ( ) to temporarily close the dialog box immediately, 
select the base point in the drawing, then return to the dialog box. This option is 
available only if Specify on Screen is not marked.

• X, Y, and Z Enter the x-, y-, and z-coordinates of the base point. This option is 
available only if Specify on Screen is not marked.

4 Select the entities to be combined into the block by doing one of the following:

• Specify on Screen Mark this check box to select the entities in the drawing after 
you click OK.

• Select entities Click ( ) to temporarily close the dialog box immediately, 
select the entities in the drawing, then return to the dialog box. Or you can click  
( ) to select entities by type or value. This option is available only if Specify 
on Screen is not marked.

5 Select what to do with the entities after the block is created:

• Retain entities Entities selected for the block remain in the drawing.

• Convert to block Entities selected for the block are converted to the block, 
which remains in the drawing.

• Delete entities Entities selected for the block are removed from the drawing.
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6 Select any of the following options for the block:

• Annotative Determines whether the block is annotative by default. The display 
and printing of annotative blocks is affected by annotation scaling. If annotative 
by default, you can determine whether the block, when located in paper space, 
is oriented automatically according to the layout viewport.

• Scale uniformly Mark this check box to retain the aspect ratio if the block is 
scaled. Annotative blocks must be scaled proportionately.

• Allow exploding Mark this check box to allow the block to be exploded into 
separate entities.

• Unit Defines the unit of the block, for example inches or millimeters.

7 Click OK.

The program adds a new block to the blocks list, with the name you entered for it.

 

If you often include blocks in your drawings, you can create a tool palette that con-
tains the blocks you use most often. For details, see “Creating tool palettes and add-
ing commands and blocks” on page 864. 

A Enter the name of the block.
B Enter a description of the block.
C Select to pick the base point in the drawing after 

you click OK.
D Select to pick the base point now in the drawing.
E Displays the base point coordinates or you can 

enter them manually.
F Select to select entities to include in the block 

after you click OK.
G Click to select entities now in the drawing. 
H Select whether to keep, convert, or delete 

entities after the block is created.

I Click to select entities by type or value.
J Choose block units.
K Select to allow the block to be exploded into 

entities.
L Select to maintain aspect ratio if the block is 

scaled.
M Select to make the block, when located in paper 

space, oriented according to the layout viewport 
(available only if Annotative is marked).

N Mark to make the block annotative by default.
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C
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Some users frequently restore original entities after defining a block. 
To restore the original entities to the drawing while retaining the new block, type 
undelete or oops. You might also want to add the Undelete command to a menu or 
toolbar by choosing Tools > Customize.  

An existing block instance can easily be used to create a new block. 
Use the Rename Block command to create a new block by renaming a single block 
instance. Use the Change Block command to change the name of a single block 
instance and then open the Block Editor where you can modify it.

Saving blocks
You can create a block as a separate drawing file that you can insert into other drawings. 
The Save Block to Disk command includes the most options for saving blocks, and the 
Quick Block Save command includes only the essential steps: selecting entities and 
naming the block.

To quickly save entities as a separate drawing file    
1 Do one of the following to choose Quick Block Save ( ):

• On the ribbon, choose Insert > Quick Block Save (in Block Definition).

• On the menu, choose Tools > Quick Block Save.

• On the Tools toolbar, click the Quick Block Save tool.

• Type quickwblock and then press Enter.

2 Select the entities you want to save as a block, and then press Enter.

3 Enter a name for the destination drawing file.

4 Click Save.

To save a block as a separate drawing file    
Advanced experience level    

1 Do one of the following to choose Save Block To Disk ( ):

• On the ribbon, choose Insert > Save Block to Disk (in Block Definition).

• On the menu, choose Tools > Save Block To Disk.

• On the Tools toolbar, click the Save Block To Disk tool.

• Type wblock and then press Enter.

2 In Source, choose Block, then select the desired block from the list.

3 In File Name and Path, type the name and path of the destination drawing file you 
want to create, or click [...] to browse for it.

4 In Insert Units, select the units used for inserting the separate drawing file.

5 Click OK.
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The program assigns the 0,0,0 coordinate as the insertion base point.
You can change the base point by opening the drawing and redefining the block.

To save the current drawing as a separate drawing file    
Advanced experience level    

1 Do one of the following to choose Save Block to Disk ( ):

• On the ribbon, choose Insert > Save Block to Disk (in Block Definition).

• On the menu, choose Tools > Save Block To Disk.

• On the Tools toolbar, click the Save Block To Disk tool.

• Type wblock and then press Enter.

2 In Source, choose Entire Drawing.

3 In File Name and Path, type the name and path of the destination drawing file you 
want to create, or click [...] to browse for it.

4 In Insert Units, select the units used for inserting the separate drawing file.

5 Click OK.

The program assigns the 0,0,0 coordinate as the insertion base point.
You can change the base point by opening the drawing and redefining the block.
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To select entities and save them as a separate drawing file    
Advanced experience level    

1 Do one of the following to choose Save Block to Disk ( ):

• On the ribbon, choose Insert > Save Block to Disk (in Block Definition).

• On the menu, choose Tools > Save Block To Disk.

• On the Tools toolbar, click the Save Block To Disk tool.

• Type wblock and then press Enter.

2 In Source, choose Entities.

3 In Base Point, enter the x,y,z coordinates of the base point to save with the sepa-
rate drawing file, or click ( ) to select it directly in the current drawing.

4 Click ( ) and then select the source entities directly in the current drawing. Or 
you can click ( ) to select entities by type or value.

5 Choose what action to take with selected entities in the current drawing after the 
separate drawing file is created:

• Retain Keeps the selected source entities in the current drawing.

• Convert to block Converts the selected source entities to a block in the current 
drawing.

• Delete from drawing Deletes the selected source entities from the current 
drawing.

If no entities are selected, a separate drawing file is not created.

6 In File Name and Path, type the name and path of the destination drawing file you 
want to create, or click [...] to browse for it.

7 In Insert Units, select the units used for inserting the separate drawing file.

8 Click OK.

If you often include blocks in your drawings, you can create a tool palette that con-
tains the blocks you use most often. For details, see “Creating tool palettes and add-
ing commands and blocks” on page 864. 
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A Select what content to save to a separate drawing 
file. If Entities is selected, the Base Point and 
Entities options are available.

B Click to select in the current drawing the x,y,z 
coordinates of the base point to save with the 
separate drawing file.

C Enter the x,y,z coordinates of the base point to 
save with the separate drawing file.

D Enter the path and filename of the new drawing 
file, or click [...] to browse to it.

E Select the insertion units for the new drawing file.

F Displays the number of entities currently selected 
to save to a separate drawing file. If no entities are 
selected, a separate drawing file is not created.

G Select what action to take with selected entities in 
the current drawing after the separate drawing file 
is created. 

H Click to select entities by type or value.
I Click to select in the current drawing the entities to 

save to a separate drawing file.
J Select the block to save to a separate drawing file. 

Available only if Block is selected as the source.

A

B

C G

F

D

E

H

J

I



554 C H A P T E R  1 3
Inserting blocks   
You can insert blocks and other drawings into the current drawing. When you insert a 
block, it is treated as a single entity. When you insert a drawing, it is added to the cur-
rent drawing as a block. You can then insert multiple instances of the block without 
reloading the original drawing file. If you change the original drawing file, those 
changes have no effect on the current drawing unless you redefine the block by rein-
serting the changed drawing.      

You can insert dynamic blocks that were created in a different CAD program. When 
inserting a dynamic block, press Ctrl to cycle through the block insertion points 
defined by its dynamic parameters.  

When you insert a block or drawing, you must specify the insertion point, scale, and 
rotation angle. The block’s insertion point is the reference point specified when you 
created the block. When you insert a drawing as a block, the program takes the speci-
fied insertion point as the block insertion point. You can change the insertion point, 
however, by first opening the original drawing and redefining the block.        

Block settings can also be set before block insertion. 
You can specify the insertion point, scale factors, and rotation angle before inserting 
a block by unmarking Specify on Screen for any of these options in the Insert Block 
dialog box, and then specifying the appropriate details. You can also control whether 
a block is exploded into its original component entities immediately after insertion by 
marking Explode.        

To insert a block    
1 Do one of the following to choose Insert Block ( ):    

• On the ribbon, choose Home > Insert Block (in Block) or choose Insert > Insert 
Block (in Block).

• On the menu, choose Insert > Block.

• On the Draw toolbar, click the Block tool.

• Type insert or ddinsert and then press Enter.

2 Choose Block Name, then select the name of the block you want to insert.

3 Click Insert.

4 Specify the insertion point for the block. 

If inserting a dynamic block, you can press Ctrl while left-clicking the mouse to 
cycle through block insertion points defined by its dynamic parameters.

5 Specify the x, y, and z scale factors and the rotation angle, or press Enter to accept 
the default values.
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To insert an entire drawing into the current drawing
1 Do one of the following to choose Insert Block ( ):     

• On the ribbon, choose Home > Insert Block (in Block) or choose Insert > Insert 
Block (in Block).

• On the menu, choose Insert > Block.

• On the Draw toolbar, click the Block tool.

• Type insert or ddinsert and then press Enter.

2 Choose From File, then type or click Browse to specify the path and the drawing 
file name.

3 Click Insert.

4 Specify the insertion point for the block.

5 Specify the x, y, and z scale factors and the rotation angle, or press Enter to accept 
the default values.

The scale can easily be changed after insertion.
To change the scale of a block after insertion, choose Express Tools > Blocks > 
Block Scale. You can also change the position, scale, and rotation using the Proper-
ties pane.

You can also insert drawings while browsing files on your computer. 
If the DRAGOPEN system variable is set to 0, you can drag a .dwg file to the drawing 
area in IntelliCAD to insert it as a block. If DRAGOPEN is set to 1 (the default), the 
drawing opens in IntelliCAD.
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A Choose to insert a block from a file and type or 
click Browse to specify the path and file name; or 
choose to insert a block from the current drawing 
and select its name from the list.

B Click to position the block when inserting and 
optionally insert multiple block instances.

C Specify the x-, y-, and z-coordinates of the 
insertion point (if Specify on screen is unmarked 
for insertion point).

D Click to pick an insertion point directly in the 
drawing area and return to the dialog box to 
specify additional options.

E Click to explode the block on insertion.

F Click to scale the block when inserting and 
optionally insert multiple block instances.

G Specify the scale factor for the x, y, and z 
directions (if Specify on screen is unmarked for 
scale).

H Mark to scale the block uniformly in the x, y, and z 
directions.

I Displays the scale factor defined for the block.
J Displays the insertion units defined for the block.
K Enter the rotation angle for the block (available if 

Specify on screen is unmarked for rotation).
L Click to rotate the block when inserting and 

optionally insert multiple block instances.
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Modifying blocks
There are several ways you can modify a block. After you modify it, all blocks in the 
drawing are updated automatically.

Editing blocks using the Block Editor 
You can redefine all instances of a block within the current drawing. To redefine a 
block that was created in the current drawing, you create a new block using the same 
name. You can update all the blocks in the current drawing by redefining the block. If 
the block was inserted from a separate drawing file that was subsequently updated, 
reinsert that block to update all other instances in the current drawing.    

To redefine a block in the current drawing
Advanced experience level    

1 Do one of the following to choose Block Editor ( ):

• On the ribbon, choose Home > Block Editor (in Block Definition) or choose 
Insert > Block Editor (in Block Definition).

• Type bedit and then press Enter.

Use a shortcut.
Double-click a block to open it in the Block Editor. Note that the 
BLOCKEDITLOCK system variable controls the double-click action for blocks: if 
set to 0, the Block Editor opens; if set to 1, the Properties pane opens.

2 In the Edit Block Definition dialog box, select the block you want to edit.    

3 Click OK.

4 In the drawing area, make changes to the block.

5 Do one of the following to choose Save Block :

• On the ribbon, choose Block Editor > Save Block.

• On the floating toolbar (if the ribbon is not displayed), choose Save Block.

• Type bsave and then press Enter.

You can also choose Save Block As ( ) to save the block with a new name.

6 Do one of the following to choose Close Block Editor ( ):

• On the ribbon, choose Block Editor > Close Block Editor.

• On the floating toolbar (if the ribbon is not displayed), choose Close Block 
Editor.

• Type bclose and then press Enter.

The program updates all instances of the block.

You can update all instances of a block inserted from a separate drawing by reinsert-
ing the drawing.
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Redefining blocks    
You can redefine all instances of a block within the current drawing. To redefine a 
block that was created in the current drawing, you create a new block using the same 
name. You can update all the blocks in the current drawing by redefining the block. If 
the block was inserted from a separate drawing file that was subsequently updated, 
reinsert that block to update all other instances in the current drawing.    

To redefine a block in the current drawing
Advanced experience level    

1 Do one of the following to choose Create Block ( ):

• On the ribbon, choose Home > Create Block (in Block) or choose Insert > Create 
Block (in Block Definition).

• On the menu, choose Draw > Block > Create Block.

• On the Tools toolbar, click the Create Block tool.

• Type block and then press Enter.

2 In Name, select the name of the block you want to redefine from the list.

3 Specify the insertion point for the block.

4 Select the entities for the block.

5 Make selections about the behavior.

6 Click OK.

7 When prompted, choose Yes to redefine the block.

The block is redefined, and all instances of the block in the drawing are updated. 

8 To restore the original entities to the drawing while retaining the new block, type 
undelete or oops.    

You can update all instances of a block inserted from a separate drawing by reinsert-
ing the drawing.
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Editing blocks in-place
After a block is inserted in a drawing, it can be edited directly in IntelliCAD, and the 
source block in the drawing (not on disk) and all references to the block are updated 
automatically. Editing in-place is an easy way to make changes to a block without 
having to locate and load it.

To edit blocks in-place
1 Do one of the following:

• On the ribbon, choose Insert > Edit Reference in Place (in Reference).

• On the menu, choose Tools > Edit Block or X-Ref In-Place > Edit In-Place.

• Type refedit and then press Enter.

2 At the prompt, select the block you want to edit.

The Reference Edit dialog box displays.

3 In Reference Name, select the block you want to edit.

4 Select any of the following options:

• Automatically Select All Nested Entities Select to automatically include all 
nested entities for editing in-place.

• Prompt to Select Nested Entities Select to enable editing of individual nested 
entities.

5 Select the Settings tab and select from the following options:

• Create Unique Layer, Style and Block Names Select to create unique names for 
layers, styles, and blocks that you change. A prefix is added to the original name 
of a changed layer, style, or block. Names of unchanged layers, styles, and 
blocks do not change.

• Display Attribute Definitions for Editing Select to hide attributes and display 
attribute definitions while editing. After saving, changed attribute definitions 
affect new block insertions only. Existing blocks are not affected.

6 Click OK.

7 Make changes to the contents of the block.

8 To add an entity from the drawing to the block, select the entity and do one of the 
following:

• Choose Tools > Edit Block or X-Ref In-Place > Add to Working Set.

• Type refset, press Enter, then choose Add.

9 To remove an entity from the block, select the entity and do one of the following:

• Choose Tools > Edit Block or X-Ref In-Place > Remove from Working Set.

• Type refset, press Enter, then choose Remove.
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10 When you’re finished editing the block, do one of the following:

• Choose Tools > Edit Block or X-Ref In-Place > Close Reference.

• Type refclose and then press Enter.

11 Choose Save to save changes or Discard to cancel changes.

If changes are saved, all instances of the block are updated in the current drawing.

Exploding blocks
You can explode an inserted block to its original component entities. When you 
explode a block, only that single instance of the block is affected. The original block 
definition remains in the drawing, and you can still insert additional copies of the 
original block. If you explode a block that contains attributes, the attributes are lost, 
but the original attribute definitions remain.    

Exploding dissociates component entities to their next simplest level of complexity; 
blocks or polylines in a block become blocks or polylines again

To explode a block
1 Do one of the following to choose Explode ( ):

• On the ribbon, choose Home > Explode (in Modify) or choose Edit > Explode 
(in Modify).

• On the menu, choose Modify > Explode.

• On the Modify toolbar, click the Explode tool.

• Type explode and then press Enter.

2 Select the block.

3 Press Enter.
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Replacing blocks with other blocks
Use the Replace Block command to replace each occurrence of a block with a differ-
ent block. Select the block to replace and the replacement block from a list of all 
blocks available in the current drawing, and then choose whether to purge the unused 
block definition from the drawing.

To replace a block
1 Do one of the following to choose Replace Block ( ):

• On the ribbon, choose Express Tools > Replace Block (in Blocks).

• On the menu, choose Express Tools > Blocks > Replace Block.

• Type blockreplace and then press Enter.

2 In Select Original Block, select the block that you want to replace. Or click Pick to 
select the block directly in the drawing.

3 In Select Replacement Block, select the block that you want to use as a replace-
ment block. Or click Pick to select it directly in the drawing.

4 Click OK.

5 To remove the unreferenced block definition from the drawing, choose Yes. To 
keep the block definition in the drawing, choose No.

Converting blocks to external references
There are two ways you can convert and replace blocks with external references in 
the current drawing:

• Replace all block occurrences with a new external reference that is created from 
the block.

• Replace all block occurrences with an existing external reference.

To convert and replace a block with a new external reference
1 Do one of the following to choose Convert Block to Xref ( ):

• On the ribbon, choose Express Tools > Convert Block to Xref (in Blocks).

• On the menu, choose Express Tools > Blocks > Convert Block to Xref.

• Type blocktoxref and then press Enter.

2 In Block to Convert, select the block that you want to convert, or click Pick to 
select the block directly in the drawing area.

3 Choose Convert Block to Xref.

4 Click OK.

5 In the Save Block to File dialog box, enter the file name for the external reference, 
then click Save. 
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To convert and replace a block with an existing external reference
1 Do one of the following to choose Convert Block to Xref ( ):

• On the ribbon, choose Express Tools > Convert Block to Xref (in Blocks).

• On the menu, choose Express Tools > Blocks > Convert Block to Xref.

• Type blocktoxref and then press Enter.

2 In Block to Convert, select the block that you want to convert, or click Pick to 
select the block directly in the drawing area.

3 Choose Replace Block with Existing Xref.

4 Click OK.

5 In the Select Xref File dialog box, select the drawing file for replacing the selected 
block, then click Open.

6 To remove the unreferenced block definition from the drawing, choose Yes. To 
keep the block definition in the drawing, choose No.
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Working with attributes    

An attribute is a particular entity that you can save as part of a block definition. Attri-
butes consist of text-based data. You can use attributes to track such things as part 
numbers and prices. Attributes have either fixed or variable values. When you insert a 
block containing attributes, the program adds the fixed values to the drawing along 
with the block, and you are prompted to supply any variable values.        

After you insert blocks containing attributes, you can extract the attribute information 
to a separate file and then use that information in a spreadsheet or database to produce 
a parts list or bill of materials. You can also use attribute information to track the 
number of times a particular block is inserted into a drawing. And if changes are 
made to block attributes, you can easily update block instances in the drawing with 
the changes.    

Attributes can be visible or hidden. Hidden attributes are neither displayed nor 
printed, but the information is still stored in the drawing and written to a file when 
you extract it.        

Defining attributes    
You add an attribute to a drawing by first defining it and then saving it as part of a 
block definition. To define an attribute, you specify the characteristics of the attri-
bute, including its name, prompt, and default value; the location and text formatting; 
and optional modes (hidden, fixed, validate, predefined, and locked).        

To define an attribute          
Advanced experience level

1 Do one of the following to choose Define Attributes ( ):

• On the ribbon, choose Insert > Define Attributes (in Block Definition).

• On the menu, choose Draw > Block > Define Attributes.

• On the Tools toolbar, click the Define Attributes tool.

• Type ddattdef and then press Enter.

2 In the Define Attribute dialog box, type the name, prompt, and default value.

3 Under Insert Coordinates, specify the location of the attribute, or click Select to 
select a point in the drawing.

4 Under Attribute Flags, select the optional attribute modes.

5 Under Text, specify the text characteristics.

6 To add the attribute to the drawing, do one of the following:

• Click Define to add the attribute and keep the dialog box active so you can 
define another attribute.

• Click Define And Exit to add the attribute and end the command.
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A Type the name you want to assign to the 
attribute.         

B Enter the identifying prompt information 
displayed when you insert a block containing the 
attribute.

C Enter the default or constant value. For variable 
attributes, the default value is replaced by the 
actual value when you later insert a block 
containing the attribute.

D Specify the x-, y-, and z-coordinates for the 
attribute insertion point.

E Select to create a hidden attribute.
F Select to create a fixed-value attribute.
G Select to create an attribute whose value must 

be validated when you later insert a block 
containing the attribute.    

H Select to create an attribute whose value is 
defined and not requested when you later insert 
a block containing the attribute, but that you can 
edit after the block is inserted. 

I Select to create an attribute whose position is 
locked.

J Select to create an attribute whose default text 
contains multiple lines of text.

K Click to add the attribute and keep the dialog box 
active so you can define another attribute.

L Click to add the attribute and end the command.
M Specify the text rotation angle, or click to specify 

the rotation angle by selecting two points in the 
drawing.    

N Specify the text height, or click to specify the 
height by selecting two points in the drawing.

O Choose the text justification.
P Choose the text style from those styles already 

defined in the drawing.
Q Select to create an attribute that is annotative by 

default.
R Click to specify the attribute insertion point by 

selecting a point in the drawing.
S Click to enter multiple lines of default text. 

Available only if Multiple line is selected.
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Editing attribute definitions    
You can edit an attribute definition before you associate it with a block and before it 
is saved as part of a block definition.         

To edit an attribute definition           
Advanced experience level

1 Select the attribute definition text to edit.

2 Do one of the following to choose Properties ( ):

• On the ribbon, choose View > Properties (in Panes).

• On the menu, choose View > Display > Properties or Modify > Properties.

• Right-click the attribute definition text, then choose Properties.

• Type entprop and then press Enter.

3 Modify the properties, including name, prompt, default value, and other attribute-
specific properties.

Attaching attributes to blocks
You can attach attributes to a block after you define it and select it as one of the enti-
ties to include. Include the attributes when the program prompts you for the entities to 
include in the selection set for a block. After the attribute is incorporated into a block, 
the program prompts you each time you insert the block, so you can specify different 
values for the attributes each time you insert it into a new drawing.    
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Editing attributes attached to blocks
You can edit the attribute values of a block that has been inserted into a drawing.           

To edit an attribute attached to a block     
Advanced experience level

1 Do one of the following to choose Edit Attributes (Single) ( ):

• On the ribbon, choose Insert > Edit Attributes > Single (in Block Definition).

• On the menu, choose Modify > Entities > Attributes > Edit Attributes > Single.

• On the Tools toolbar, click the Edit Single Attributes tool.

• Type eattedit and then press Enter.

2 Select the block to edit.

The Edit Attributes dialog box displays all the attributes attached to the block you 
select.

3 Edit the attribute values as necessary.

4 Click OK. 

To edit an attribute associated with multiple blocks     
1 Do one of the following to choose Global Attribute Edit ( ):

• On the ribbon, choose Express Tools > Global Edit Attributes (in Blocks).

• On the menu, choose Express Tools > Blocks > Global Edit Attributes.

• Type gatte and then press Enter.

2 Do one of the following:

• Select the attribute you want to edit.

• Select the block you want to edit, then select or type the name of the attribute 
you want to edit.

• Choose Block name, then enter the name of the block that is associated with the 
attribute you want to edit.

3 Enter a new attribute value.

4 Choose Yes to change the values of all attributes with the specified name, or 
choose No to select them in the drawing one by one.
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Extracting attribute information    
You can extract attribute information from a drawing and save it to a separate text file 
for use with a database program. You can save the file in any of the following for-
mats:      

• Comma Delimited Format (CDF) Contains one line for each instance of a block, 
with individual attribute fields separated by commas. Character string fields are 
enclosed with single quotation marks. You must specify a template file when 
extracting to a CDF file.       

• Space Delimited Format (SDF) Contains one line for each instance of a block. 
Each attribute field has a fixed length; there are no separators or character string 
delimiters. You must specify a template file when extracting to a SDF file.       

• Drawing Exchange Format (DXF) Creates a subset of a standard DXF file (a *.dxx 
file) containing all the information about each block, including the insertion 
points, rotation angles, and attribute values. No template file is required.       

Before extracting attributes to a CDF or SDF file, you must create a template file. The 
template file is an ASCII text file that specifies the attribute data fields to be written 
in the extract file. Each line of the template file specifies one attribute field. 
IntelliCAD recognizes 15 different fields, which contain elements such as the block 
name, the x-, y-, and z-coordinates of its insertion point, the layer on which it is 
inserted, and so on. You can include any of these fields. The template file must 
include at least one attribute name.        

Each line in the template file must start with the field name. Block name and inser-
tion-point values must begin with BL:. The next nonblank character must be either a 
C (indicating a character string field) or an N (indicating a numeric field). This char-
acter is then followed by three digits indicating the width of the field (in characters). 
The final three digits indicate the number of decimal places (for numeric fields). In 
the case of character fields, the last three digits must be zeros (000). A typical tem-
plate file is similar to the one shown here:             
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To create a template file
1 Create a template file using any ASCII text editor (such as Microsoft® Notepad or 

Microsoft® WordPad) or a word-processing program such as Microsoft® Word.

2 Include the necessary fields in the template file.

3 Save the template file in ASCII text format.

To extract attribute information 
1 Do one of the following to choose Extract Attributes ( ):

• On the ribbon, choose Insert > Extract Attributes (in Block Definition).

• On the menu, choose Tools > Extract Attributes.

• On the Tools toolbar, click the Extract Attributes tool.

• Type ddattext and then press Enter.

2 Click Select, specify the entities from which to extract attributes, and then press 
Enter.

3 Specify the format of the extracted file.

4 For CDF and SDF formats, specify the template file.

5 Specify the extract output file. 

6 Click Extract.

  

A Field name.
B Block name. Block names must begin with BL:.
C Insertion point. Insertion-point values must begin 

with BL:.
D Attribute tags.

E Number of decimal places for numeric fields or 
000 for character fields.

F Field width for character or numeric fields.
G C for character fields; N for numeric fields.
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G
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A Click to select blocks in the drawing containing 
attributes you want to extract.

B Click to specify the format of the extracted file.
C Specify the template file for CDF and SDF 

extracts.
D Specify the extract output file.

E Click to extract attributes.
F Click to specify the output file using a file dialog 

box.
G Click to specify the template file using a file 

dialog box.
H Indicates the number of blocks with attributes 

selected for extraction.
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Synchronizing attributes and blocks
If changes are made to block attributes with the Create Block or Block Editor com-
mand, you can automatically apply those changes to block instances using the Syn-
chronize Attributes command.

This command doesn't affect values assigned to attributes.          

To synchronize a block with updated attributes     
1 Do one of the following to choose Synchronize Attributes ( ):

• On the ribbon, choose Home > Synchronize Attributes (in Blocks); Insert > 
Synchronize Attributes (in Block Definition).

• On the menu, choose Modify > Entities > Attributes > Synchronize Attributes.

• Type attsync and then press Enter.

2 Choose Select.

3 Select a block definition in the drawing to be updated.

4 Choose Yes to update the block, or choose No to cancel.
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Working with external references           

You can link entire drawings to the current drawing as external references. Unlike 
inserting a drawing as a block, in which you add all the entities from the separate 
drawing into the current drawing, external references attach a pointer to the external 
file. The entities in the external reference appear in the current drawing, but the enti-
ties themselves are not added to the drawing. Thus, attaching an external reference 
does not significantly increase the size of the current drawing file.        

Understanding external references
External references provide additional capabilities not available when you insert a 
drawing as a block. When you insert a drawing as a block, the entities are stored in 
the drawing. Any changes you make to the original drawing are not reflected in the 
drawing in which you inserted it. When you attach an external reference, however, 
any changes you make to the original drawing file are reflected in the drawings that 
reference it. These changes appear automatically each time you open the drawing 
containing the external reference. If you know that the original drawing was modi-
fied, you can reload the external reference anytime you’re working on the drawing.    

External references are useful for assembling master drawings from component draw-
ings. Use external references to coordinate your work with others in a group. External 
references help reduce drawing file size and ensure that you are always working with 
the most recent version of a drawing. However, if you send or receive drawings that 
contain external references, it is important to include with the master drawing all of 
the external references attached to it. When you open a drawing that contains external 
references, the source external reference files must be accessible for the external ref-
erences to display in the drawing.     

The Xref Manager helps you easily attach and work with external references.
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Attaching external references
Attaching a separate drawing to the current one creates an external reference. The 
external reference appears in the drawing as a block definition, but the drawing enti-
ties are linked rather than added to the current drawing. If you modify the linked 
drawing, the current drawing that contains the external reference is updated automati-
cally when you open it, or you can reload the external reference manually so it 
reflects the latest version of the external reference.            

When you attach an external reference, its layers, linetypes, text styles, and other ele-
ments are not added to the current drawing. Rather, these elements are also linked 
from the referenced file. 

A Click to display a detailed list or hierarchical tree. 
B Select an external reference to modify its 

attachment.
C Type or click Browse to specify the external 

reference location. 
D Type or click Browse to specify other search 

directories where external references may be 
located.

E Click to open the source drawing for the external 
reference.

F Click to make the external reference a permanent 
part of the drawing.

G Click to remove the external reference, but keep 
elements and path information for easy reloading.

H Click to update with changes from the external 
reference.

I Click to completely remove the external reference.
J Click to link a drawing.
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There are two ways you can attach an external reference:

• An attachment is an inserted drawing that contains a link to the original file. 
Attachments can themselves contain other, nested reference files. When you 
attach an external reference, any nested references contained in the file also appear 
in the current drawing.  

• An overlay is an inserted drawing that contains a link to the original file. Overlays 
allow you to lay a drawing on top of another drawing, similar to the way you work 
manually with transparencies. When a drawing that contains overlaid external ref-
erences is itself attached or overlaid as an external reference in another drawing, 
the overlays do not appear as part of the external reference. Use overlaying when 
you want to see reference geometry in a drawing but you do not need to include 
that geometry in drawings that will be used by others (nested external references).         

You can attach as many copies of an external reference file as you want. Each copy 
can have a different position, scale, and rotation angle.      

To attach an external reference           
1 Do one of the following to choose Xref Manager ( ):

• On the ribbon, choose Insert > Xref Manager (in Reference).

• On the menu, choose Insert > Xref Manager.

• On the Tools toolbar, click the Xref Manager tool.

• Type xref and then press Enter.

2 Click Attach. 

3 Specify the drawing file to attach as an external reference, and then click Open.

4 In Reference Type, choose how you want to insert the drawing:

• Attachment – inserts a copy of the drawing and includes any other drawings that 
are externally referenced within the referenced drawing.

• Overlay – lays a copy of a drawing over your original drawing; it does not 
include any nested external references from the externally referenced drawing. 

5 Make any additional selections.

6 Click OK.

7 If you marked Specify On-Screen for any items, follow the prompts to attach the 
external reference.

After an external file is attached, the Manage Xrefs icon displays in the status bar, 
notifying that the drawing contains a linked external reference file.
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Viewing the list of external references
You can view a list of the external references that are linked to the current drawing 
two different ways using the Xref Manager:    

• List View displays the external references in a list, which allows you to sort the list 
of references by name, status, size, type, date, or saved path.

• Tree View displays a hierarchical representation of the external references and the 
relationships between them. The tree view shows the level of nesting relationships 
of the attached external references.

A Displays the external reference to attach, or select 
one from the list. 

B Click Attachment to link a drawing, including any of 
its own external references. Click Overlay to link a 
drawing, omitting any of its own nested external 
references.

C Choose to specify the insertion point in the 
drawing, or enter x-, y-, and z-coordinates.

D Choose to specify the scale in the drawing, or enter 
x-, y-, and z-scale factors.

E Choose to specify the rotation angle in the drawing, 
or enter a rotation angle.

F Select to save the folder location of the referenced 
drawing. If not selected, the referenced drawing 
must be located in the same folder as the current 
drawing.

G Click to locate and select a different external 
reference.
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To view a list of external references
1 Do one of the following to choose Xref Manager ( ):     

• On the ribbon, choose Insert > Xref Manager (in Reference).

• On the menu, choose Insert > Xref Manager.

• On the Tools toolbar, click the Xref Manager tool.

• Type xref and then press Enter.

• On the status bar, click Manage Xrefs, which displays when external references 
are linked to the drawing.

2 Click List View ( ) or Tree View ( ).

Opening external references
From the Xref Manager you can quickly open the source drawing for any external 
reference. This is especially helpful if you are working with nested external refer-
ences, which you cannot bind or detach. From the Xref Manager, open the source 
drawing, make changes, and then save and close the source drawing. When the Xref 
Manager displays again, simply reload the external reference.

To open an external reference
1 Do one of the following to choose Xref Manager ( ):     

• On the ribbon, choose Insert > Xref Manager (in Reference).

• On the menu, choose Insert > Xref Manager.

• On the Tools toolbar, click the Xref Manager tool.

• Type xref and then press Enter.

• On the status bar, click Manage Xrefs, which displays when external references 
are linked to the drawing.

2 Select the external reference to open.

3 Click Open.

Use a shortcut.
Type xopen to open an external reference without using the Xref Manager. To see any 
changes that you make to the external reference while it is open, reload it.
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Removing external references 
Removing external references from the current drawing is easy with the Xref Man-
ager. You can unload an external reference, which keeps some information about the 
external reference in the current drawing for easy reloading later, or you can detach 
the external reference entirely.  

When you unload an external reference, you remove it from the current drawing. 
However, its elements, such as layers and linetypes, remain in the drawing and it is 
still listed in the Xref Manager. By detaching an external reference you remove it and 
all of its elements from the current drawing, and it is no longer listed in the Xref Man-
ager.

To unload an external reference
1 Do one of the following to choose Xref Manager ( ):     

• On the ribbon, choose Insert > Xref Manager (in Reference).

• On the menu, choose Insert > Xref Manager.

• On the Tools toolbar, click the Xref Manager tool.

• Type xref and then press Enter.

• On the status bar, click Manage Xrefs, which displays when external references 
are linked to the drawing.

2 Select the external reference to unload.

3 Click Unload.

To detach an external reference
1 Do one of the following to choose Xref Manager ( ):     

• On the ribbon, choose Insert > Xref Manager (in Reference).

• On the menu, choose Insert > Xref Manager.

• On the Tools toolbar, click the Xref Manager tool.

• Type xref and then press Enter.

• On the status bar, click Manage Xrefs, which displays when external references 
are linked to the drawing.

2 Select the external reference to detach.

3 Click Detach.

Nested external references cannot be detached. 
Only the external references that are attached directly to the current drawing can be 
detached.
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Reloading external references
When you open or print a drawing, any external references in the drawing are updated 
automatically. 

If a drawing is already open and a referenced drawing is modified, you can update the 
current drawing manually to display the latest version of the referenced drawing. The 
program checks for modified external references every five minutes.     

You may also want to reload an external reference that has been unloaded temporar-
ily.

To reload an external reference
1 Do one of the following to choose Xref Manager ( ):     

• On the ribbon, choose Insert > Xref Manager (in Reference).

• On the menu, choose Insert > Xref Manager.

• On the Tools toolbar, click the Xref Manager tool.

• Type xref and then press Enter.

• On the status bar, click Manage Xrefs, which displays when external references 
are linked to the drawing.

2 Select the external reference to reload.

3 Click Reload.

Use a shortcut.
By default, when an external reference is modified outside of IntelliCAD, a notifica-
tion appears in a balloon message and in the Event Log. Click Reload in the balloon 
message to reload the external reference. To turn off these notifications, set the 
XREFNOTIFY system variable to 0; to turn on notifications, set it to 2. To change 
how often the program checks for modified external references, set the number of 
minutes using the XNOTIFYTIME system variable.

Changing the path for external references
If the file associated with an external reference is moved to a different directory or 
renamed, the program displays a message indicating that it cannot load the external 
reference. You can re-establish the link to the file by doing any of the following:

• Change the path for the external reference.          

• Specify additional directories for IntelliCAD to search. This is especially helpful 
if you have several external references that have moved to a new directory.
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To change the path for a single external reference
1 Do one of the following to choose Xref Manager ( ):     

• On the ribbon, choose Insert > Xref Manager (in Reference).

• On the menu, choose Insert > Xref Manager.

• On the Tools toolbar, click the Xref Manager tool.

• Type xref and then press Enter.

• On the status bar, click Manage Xrefs, which displays when external references 
are linked to the drawing.

2 Select the external reference whose path you want to change.

3 In Xref Path, do one of the following:

• Enter a new filename or location. 

• Click Browse to locate and select the referenced drawing.

IntelliCAD reloads the specified external reference automatically.

External references cannot be recursive. 
You cannot recursively reference a drawing from the same original drawing.

To change the search paths for all external references in the drawing
1 Do one of the following to choose Xref Manager ( ):     

• On the ribbon, choose Insert > Xref Manager (in Reference).

• On the menu, choose Insert > Xref Manager.

• On the Tools toolbar, click the Xref Manager tool.

• Type xref and then press Enter.

• On the status bar, click Manage Xrefs, which displays when external references 
are linked to the drawing.

2 In Additional Xref Search Paths, do one of the following:

• Enter a new directory and its path. Separate multiple paths with a semicolon, for 
example, c:\My Drawings;d:\My Drawings\Backup.

• Click Browse to locate and select a directory. 

IntelliCAD searches the specified directories; any found external references are 
reloaded automatically.
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Binding external references to drawings
External references are not part of the drawing. Rather, they are links to an externally 
referenced file. To provide a copy of a drawing containing external references to 
someone else, you must also provide all the external reference files. In addition, the 
person receiving the drawings must either re-create the same paths you used when 
linking the external references or change the paths for the external references.            

To provide a copy of a drawing that contains external references, it is often easier to 
first bind the external references to the drawing. Binding the external references 
makes them a permanent part of the drawing, which is similar to inserting a separate 
drawing as a block.

You can bind external references that are attached directly to the current drawing; you 
cannot bind nested external references.

To bind an existing external reference to a drawing
1 Do one of the following to choose Xref Manager ( ): 

• On the ribbon, choose Insert > Xref Manager (in Reference).

• On the menu, choose Insert > Xref Manager.

• On the Tools toolbar, click the Xref Manager tool.

• Type xref and then press Enter.

• On the status bar, click Manage Xrefs, which displays when external references 
are linked to the drawing.

2 Select the external reference to bind.

3 Click Bind. 

4 Choose one of the following:

• Bind Binds the external reference and creates a unique name for each named 
entity, such as a layer or block, that is located in the external reference. For 
example, a layer named Electric in the external reference will be named 
Xref$0$Electric in the current drawing. If the current drawing already has a 
layer or block with the same name, the name is changed incrementally, for 
example, Xref$1$Electric.

• Insert Binds the external reference, but does not change the names of any named 
entities in the external reference. For example, a layer named Electric in the 
external reference will have the same name, Electric, in the current drawing. If 
the current drawing has a layer or block with the same name, the named entity 
in the external reference takes on the properties of the named entity in the 
current drawing.

5 Click OK.
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Clipping external references 
When you attach a drawing as an external reference, all of the referenced drawing 
displays in the current drawing. However, after you attach an external reference, you 
can define a clipping boundary that determines which portion of the referenced draw-
ing is visible or hidden.

You can edit, move, or copy clipped external references the same way you modify 
unclipped external references. The boundary moves with the reference. If an external 
reference contains nested clipped external references, they also appear clipped in the 
drawing. 

In addition to clipping external references, you can also partially hide blocks using 
clipping boundaries.

Example of an external reference clipped using a clipping boundary. The clipping boundary is the rectangle 
in the top window.
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Adding clipping boundaries
When you create a clipping boundary, it affects only the display of the referenced 
drawing; it does not affect the original referenced drawing or any referenced geome-
try. The portion of the external reference within the clipping boundary is visible and 
the remainder of the external reference becomes hidden.

To define a rectangular clipping boundary
1 Do one of the following:

• On the ribbon, choose Insert > Clip Xref (in Reference).

• On the menu, choose Modify > Xref Clip.

• Type xclip and then press Enter.

2 Select the external references to clip. If desired, you can also select blocks.

3 Press Enter.

4 Press Enter to create a new clipping boundary.

5 If prompted, press Enter to delete any existing boundaries.

6 Choose Rectangular.

7 Define the first corner of the clipping rectangle.

8 Define the second corner of the clipping rectangle.

The selected external references are clipped by the rectangle.

Use the shortcut.
You can first select all external references, right-click the selection, and then select 
Xref Clip from the shortcut menu.

To define a clipping boundary using a polyline
1 Draw a polyline where you want to clip external references.

2 Do one of the following:

• On the ribbon, choose Insert > Clip Xref (in Reference).

• On the menu, choose Modify > Xref Clip.

• Type xclip and then press Enter.

3 Select the external references to clip. If desired, you can also select blocks.

4 Press Enter.

5 Press Enter to create a new clipping boundary.

6 If prompted, press Enter to delete any existing boundaries.

7 Choose Select Polyline.

8 Select the polyline to use as clipping boundary.
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Turning clipping boundaries on and off
You can turn xref clipping on or off. When a clipping boundary is turned off, the 
boundary does not display and the entire external reference is visible, provided that 
the geometry is on a layer that is on and thawed. When a clipping boundary is turned 
off, it still exists and can be turned on. However, deleting a clipping boundary is per-
manent.  

To turn clipping boundaries on and off
1 Do one of the following:

• On the ribbon, choose Insert > Clip Xref (in Reference).

• On the menu, choose Modify > Xref Clip.

• Type xclip and then press Enter.

2 Select the desired external references.

3 Press Enter.

4 To turn off clipping boundaries, choose Off. To turn on existing clipping boundar-
ies, choose On.

5 Press Enter. 

If you are turning off a clipping boundary, click the clipped portion of the external 
reference to view the previously hidden portion of the referenced drawing.

Use the XCLIPFRAME system variable. 
When the XCLIPFRAME system variable is on (set to 1), you can select and print the 
clipping boundary frame.

Deleting clipping boundaries
If you no longer need a clipping boundary for an external reference, you can delete it.

To delete a clipping boundary
1 Do one of the following:

• On the ribbon, choose Insert > Clip Xref (in Reference).

• On the menu, choose Modify > Xref Clip.

• Type xclip and then press Enter.

2 Select the desired external references.

3 Press Enter.

4 Choose Delete, and then press Enter.

5 Click the clipped portion of the external reference. 

The previously hidden portion of the referenced drawing displays.    
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Editing external references in-place
After an external reference is inserted in a drawing, it can be edited directly in Intelli-
CAD, and the source drawing file is updated automatically. Editing in-place is an 
easy way to make changes to the source file without having to locate the file and load 
it.

To edit an external reference in-place
1 Do one of the following:

• On the ribbon, choose Insert > Edit Reference in Place (in Reference).

• On the menu, choose Tools > Edit Block or choose X-Ref In-Place > Edit In-
Place.

• Type refedit and then press Enter.

2 At the prompt, select the external reference you want to edit.

The Reference Edit dialog box displays.

3 In Reference Name, select the external reference you want to edit.

4 Select the Settings tab and select from the following options:

• Create Unique Layer, Style and Block Names Select to create unique names for 
layers, styles, and blocks that you change. A prefix is added to the original name 
of a changed layer, style, or block. Names of unchanged layers, styles, and 
blocks do not change.

• Display Attribute Definitions for Editing Select to hide attributes and display 
attribute definitions while editing. After saving, changed attribute definitions 
affect new insertions only.

5 Click OK.

6 Make changes to the contents of the external reference. Any new entities created 
during edit in-place are automatically added when the external reference is closed 
and saved.

7 To add an existing entity from the drawing to the external reference, select the 
entity and do one of the following:

• Choose Tools > Edit Block or X-Ref In-Place > Add to Working Set.

• Type refset, press Enter, then choose Add.
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8 To remove an entity from the external reference, select the entity and do one of the 
following:

• Choose Tools > Edit Block or X-Ref In-Place > Remove from Working Set.

• Type refset, press Enter, then choose Remove.

9 When you’re finished editing the external reference, do one of the following:

• Choose Tools > Edit Block or X-Ref In-Place > Close Reference.

• Type refclose and then press Enter.

10 Choose Save to save changes or Discard to cancel changes.

11 The external reference is updated and the current drawing displays the changes.

You can also type xopen to open an external reference directly.
To see any changes that you make to the external reference while it is open, reload it.
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Attaching underlays created in other file formats

When you attach an underlay, a picture representation of the file’s contents is inserted 
into the drawing. An underlay is similar to an image and different from an external 
reference in that it cannot be linked and automatically updated.

You can attach underlays using files that have the following formats:

• PDF format — Portable document format viewable using Adobe® Acrobat® 
Reader® and Adobe® Acrobat. The PDF format uses the .pdf file extension.

• Autodesk® DWF format — Autodesk Design Web Format (used with .dwf 
files) is used to distribute a drawing for others to view in a Web browser, review, 
and edit using free Autodesk software and tools. The DWF format uses the .dwf 
file extension.

• DGN format — Drawing files used with Bentley Microstation. The DGN for-
mat uses the .dgn file extension.

• PCG format — Point cloud files used by Autodesk® software and tools. The PCG 
format uses the .pcg file extension.

• RCP/RCS format — Point cloud files. The RCP/RCS format uses the .rcp or .rcs 
file extension.

• IFC format — BIM files in the Industry Foundation Classes format for building 
and construction data.

• RVT/RFA format — BIM files used by Autodesk Revit® for building and con-
struction data.
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Attaching a PDF underlay
Attaching a .pdf file is similar to attaching an image file. 

To attach a PDF underlay 
1 Use one of the following methods: 

• On the ribbon, choose Insert > PDF Underlay (in Data).

• On the menu, choose Insert > PDF Underlay. 

• Type pdfattach and then press Enter. 

2 Choose the .pdf file you want to attach. 

3 Click Open.

4 Specify which page of the .pdf file to attach.

5 Select an insertion point.

6 Enter the scale in which to insert the .pdf file.

7 Enter the rotation to use for the insertion.

Attaching a DWF underlay
Attaching a .dwf file is similar to attaching an image file.

To attach a DWF underlay 
1 Use one of the following methods: 

• On the ribbon, choose Insert > DWF Underlay (in Data).

• On the menu, choose Insert > DWF Underlay. 

• Type dwfattach and then press Enter. 

2 Choose the .dwf file you want to attach. 

3 Click Open.

4 Select an insertion point.

5 Enter the scale in which to insert the .dwf file.

6 Enter the rotation to use for the insertion.
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Attaching a DGN underlay
Attaching a .dgn file is similar to attaching an image file.

To attach a DGN underlay 
1 Use one of the following methods: 

• On the ribbon, choose Insert > DGN Underlay (in Data).

• On the menu, choose Insert > DGN Underlay. 

• Type dgnattach and then press Enter. 

2 Choose the .dgn file you want to attach. 

3 Click Open.

4 Select an insertion point.

5 Enter the scale in which to insert the .dgn file.

6 Enter the rotation to use for the insertion.

Attaching a point cloud underlay
A point cloud is a set of 3D points that represents the surface of an entity in three 
dimensions. Point cloud files are typically created by 3D-scanners.

Attaching a point cloud file (.pcg, .rcp, or .rcs file) is similar to attaching an image 
file.

To attach a point cloud underlay 
1 Do one of the following to choose Point Cloud Underlay ( ):

• On the ribbon, choose Insert > Point Cloud Underlay (in Data).

• On the menu, choose Insert > Point Cloud Underlay. 

• Type pointcloudattach and then press Enter. 

2 Choose the .pcg, .rcp, or .rcs file you want to attach. 

3 Click Open.

4 In the Attach Point Cloud dialog box, select an insertion point.

5 Enter the scale in which to insert the point cloud file.

6 Enter the rotation to use for the insertion.

7 If you want to lock the point cloud so it cannot be moved or rotated after insertion, 
mark Lock Point Cloud.

8 If you want to zoom in to the point cloud automatically after insertion, mark Zoom 
to Point Cloud.

9 Click OK.
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Attaching a BIM underlay
A Building Information Modeling (BIM) file is a drawing that typically contains a 3D 
model of a building that can be used for visualization, design, analysis, and to gener-
ate building construction documents. You can attach the following types of BIM 
files:

• RVT format — Drawing files used by Autodesk Revit® for building and construc-
tion data. You can attach .rvt files only using a 64-bit version of the program.

• RFA format — Family files used by Autodesk Revit® typically for storing build-
ing and construction elements. You can attach .rfa files only using a 64-bit version 
of the program. 

• IFC format — Files in the IFC (Industry Foundation Classes) format used for 
building and construction data.

Attaching a BIM file is similar to attaching an image file. 

After you attach a BIM underlay, note the following:

• Layers Even though BIM files do not contain layers, you can control visibility by 
enabling/disabling floors or categories using the pane that displays for the BIM 
file. Use the BIMPROP command to open the corresponding pane (and use BIM-
PROPCLOSE to close the pane).

• Entity snapping BIM underlays support entity snapping if you enable snapping 
using the UOSNAP system variable (or RVTOSNAP for only .rvt and .rfa files or 
IFCOSNAP for only .ifc files). You can also use the Options command, Snapping 
tab.

• Exploding The BIM Explode command breaks apart an attached BIM underlay 
into polyface meshes and polylines that can be edited. BIM Explode is similar to 
using the Explode command for a BIM underlay except all BIM underlay intelli-
gence is kept intact and each resulting entity is placed on its own layer. 

Import an .ifc file to retain its entities.
When importing an .ifc file, all entities are available and construction and architec-
tural entities are converted to AEC entities. For more details, see “Importing an IFC 
format file” on page 790. 
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To attach a BIM underlay 
1 Do one of the following to choose BIM Underlay ( ):

• On the ribbon, choose Insert > BIM Underlay (in Data).

• On the menu, choose Insert > BIM Underlay. 

• Type bimattach and then press Enter. 

2 Choose the .rvt, rfa, or .ifc file you want to attach. 

3 Click Open.

4 Select an insertion point.

5 Enter the scale in which to insert the file, then press Enter.

6 Enter the rotation to use for the insertion, then press Enter.
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Working with data links

Data links allow you to share data between CAD drawings and spreadsheets. First 
you create a data link to a spreadsheet (.xls or .xlsx file), and then you select the data 
link when inserting a table in a drawing.

When content in the linked source .xls/.xlsx file changes, you can update the table in 
your drawing to include the modified data. And vice versa, you can update the exter-
nal source .xls/.xlsx files to include the modified data from your drawing.

Using data links is different than importing an .xls/.xlsx file.
Importing an .xls or .xlsx file creates and fills a table with the data contained in the 
file, but the external source file is not linked to the drawing so future changes in 
either the drawing or source file cannot be updated automatically. For more details 
about importing, see “Importing an XLS format file” on page 794. 

Creating a data link
Each data link corresponds to a single sheet in an .xls or .xlsx file. You can link to the 
whole spreadsheet, a named range, or a custom range that you specify.

To create a data link, Microsoft Excel or another spreadsheet program that works 
with .xls or .xlsx files must be installed on your computer.

Once the data link is created, you can include the referenced data in your drawing by 
inserting a table and selecting the data link. The data link can also be created at the 
same time you draw tables. For more details about tables, see “Drawing an empty 
table” on page 176. 

To create a data link
1 Do one of the following to choose Data Link Manager ( ):

• On the ribbon, choose Insert > Data Link Manager (in Data); Annotate > Data 
Link Manager (in Tables).

• On the menu, choose Insert > Data Link > Data Link Manager. 

• Type datalink and then press Enter. 

2 Click New Data Link ( ).

3 In Name, enter a name for the data link.

4 In Choose an Excel File, click [...] to browse for an .xls, .xlsx file, or choose a file 
from the list of files that are linked to from the current drawing.

5 In Path Type, choose whether you want to use a full path, relative path, or no path 
to find the specified file.

6 In Select Excel Sheet to Link To, choose the sheet from the list of all sheets con-
tained in the specified Excel file. 
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7 Choose one of the following:

• Link Entire Sheet Select to include data from the entire specified sheet within 
the Excel file.

• Link to a Named Range Select to include data from a named range of cells within 
the Excel file. Available only when the specified file contains named ranges.

• Link to Range Select to include data from a custom range of cells. You can 
specify an entire column (e.g., A:A), a set of entire columns (e.g., A:D), or a 
rectangular area (e.g., A1:D10).

8 Click OK.

9 Click OK again.

A Enter a name for the data link.
B Select an Excel file to link to, or select Browse for a 

File to select a different file.
C Choose whether to use a full path, relative path, or 

no path to find the specified file.
D Choose the sheet in the Excel file that contains the 

content you want to link to.

E Choose to link to all content in the sheet, a named 
range (if defined in the source file), or a custom 
range that you specify.

F Turns the preview on or off. For large source files, 
turning off the preview can improve performance.

G Click to update the preview. (Available if Link to 
Range is selected.)

H Click to browse for an .xls or .xlsx file to link to.

A

G

B

E

H

C

D

F
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Opening the source file of a data link
If you need to open a source file to edit its content and then update its linked data in 
your drawing, you can easily open the source file by using the Data Link Manager 
command.

To open the source file of a data link
1 Do one of the following to choose Data Link Manager ( ):

• On the ribbon, choose Insert > Data Link Manager (in Data); Annotate > Data 
Link Manager (in Tables).

• On the menu, choose Insert > Data Link > Data Link Manager. 

• Type datalink and then press Enter. 

2 Select a data link.

3 In Details, confirm that the referenced file is the one you want to open.

4 Click Open Source File.

Managing data links
Data links can be renamed and deleted, and their settings can be changed, including 
the files they link to. 

If a source file is moved, deleted, or renamed, the link becomes broken. You can rees-
tablish the link to the same file in a new location or a different file altogether.

To modify a data link or fix a broken one
1 Do one of the following to choose Data Link Manager ( ):

• On the ribbon, choose Insert > Data Link Manager (in Data); Annotate > Data 
Link Manager (in Tables).

• On the menu, choose Insert > Data Link > Data Link Manager. 

• Type datalink and then press Enter. 

2 Select the data link you want to modify.

Broken data links are indicated in the Links list ( ).

3 Click Modify Data Link ( ).

4 If the data link is broken or for any other reason, click [...] to select a different file 
to link to. 

5 Select any additional options you want to change. Click [?] for more details.

6 Click OK.

7 Click OK again.
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To rename a data link
1 Do one of the following to choose Data Link Manager ( ):

• On the ribbon, choose Insert > Data Link Manager (in Data); Annotate > Data 
Link Manager (in Tables).

• On the menu, choose Insert > Data Link > Data Link Manager. 

• Type datalink and then press Enter. 

2 Select the data link you want to rename.

3 Click Rename Data Link ( ).

4 Type a new name, and then press Enter.

5 Click OK.

6 Click OK again.

To delete a data link
1 Do one of the following to choose Data Link Manager ( ):

• On the ribbon, choose Insert > Data Link Manager (in Data); Annotate > Data 
Link Manager (in Tables).

• On the menu, choose Insert > Data Link > Data Link Manager. 

• Type datalink and then press Enter. 

2 Select the data link you want to delete.

3 Click Delete Data Link ( ).

4 Click OK to confirm the deletion, or click No to cancel.

5 Click OK.

6 Click OK again.



594 C H A P T E R  1 3
A Displays a list of all data links in the drawing. Right-
click for more options.

B Mark to turn the preview display on or off.
C Displays details about the selected data link.
D Click to create a data link.

E Click to modify the selected data link.
F Click to rename the selected data link.
G Click to delete the selected data link.
H Click to open the source file associated with the 

selected data link.
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Updating data link content
If you make changes to linked data in the drawing or referenced source file, you can 
automatically synchronize the linked content.

To apply changes made in the source file to linked data in your drawing
1 Do one of the following to choose Update from Source ( ): 

• On the ribbon, choose Insert > Update from Source (in Data); Annotate > 
Update from Source (in Tables).

• On the menu, choose Insert > Data Link > Update from Source. 

• Type datalinkupdate, press Enter, and then choose Update Data Link. 

2 Select the tables you want to update with modified data from external source files, 
or do one of the following: 

• Choose Data Link to enter the name of a data link to update.

• Choose All Data Links to update all data links in the drawing.

To update the source file with changes made to linked data in your drawing
1 Do one of the following to choose Save to Source ( ): 

• On the ribbon, choose Insert > Save to Source (in Data); Annotate > Save to 
Source (in Tables).

• On the menu, choose Insert > Data Link > Save to Source. 

• Type datalinkupdate, press Enter, and then choose Write Data Link. 

2 Select the tables that contain modified linked data you want to save to correspond-
ing external source files, then press Enter.

Get notified about modified or missing data links.
By default, the status bar indicates when a table in the drawing is linked to data and a 
balloon message displays when a data link is modified or missing. Use the 
DATALINKNOTIFY system variable to change this setting.
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Working with images

You can modify and view raster images directly inside of IntelliCAD. You can load, 
edit, and modify multiple images as overlays or underlays to your IntelliCAD draw-
ings. The images can be selected for use with IntelliCAD commands by selecting the 
image frame, which can be turned on or off for printing or selection purposes.

IntelliCAD supports numerous image file formats, including BMP, JPG, GIF, EMF, 
TIF, PNG, WMF, SID, and many more.

Attaching images
When you attach an image to a drawing, the image displays in the drawing but is not 
saved in the drawing. Similar to an external reference, the image file remains saved in 
its original location on your computer, network, or other media. 

If you send or receive drawings that contain images, it is important to include with the 
drawing all of the image files attached to it. When you open a drawing that contains 
images, the source image files must be accessible for the images to display in the 
drawing.

To attach an image
1 Do one of the following to choose Attach Image:

• On the ribbon, choose Insert > Attach Image (in Data).

• Choose Insert > Image > Attach Image.

• On the Image toolbar, click the Attach Image tool.

• Type imageattach and then press Enter.

2 Specify a file to attach, and then click Open.

3 In Image Path will be Saved As, enter a different image file location, if necessary. 
You can click [ > ] to choose how you want to save the image path:

• Full Path — The image is referenced using its full path, for example, c:\My 
Pictures\MyImage.jpg. Use this option if the image is saved in a folder unrelated 
to the current drawing folder.

• Relative Path — The image is referenced using a path relative to the current 
drawing folder, for example, ..\My Pictures\MyImage.jpg. Use this option if the 
image is stored in a subfolder of the current drawing folder.

• File Name Only — The image is referenced using its file name in the current 
drawing folder, for example, MyImage.jpg. Use this option if the image is saved 
in the same folder as the current drawing.

4 In the Attach Image dialog box, specify the position, scale, rotation, transparency, 
and clipping options, and then click OK. 
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NOTE Transparency works for images that support alpha transparency, that is, 
images that have at least one color that can be viewed as a transparent color.

5 In the drawing, specify an insertion point, scale, and rotation if you chose to spec-
ify those on the screen.

 

You can also attach images using the Image Manager or Explorer
Choose Insert > Image > Image Manager, and then click Attach to specify an 
image and then attach it, or if you want to quickly add another occurrence of an 
image already located in the drawing, select the image in the Image Manager and 
then click Add. Or, choose Tools > Explorer and attach an image as an externally 
reference file.

A Enter a different image file location, if necessary.
B Choose to place the image automatically in the 

drawing using specifications located in a positioning 
file. Enter the TWF file associated with the image or 
click [...] to select it.

C Enter a name for the image.
D Choose to specify the insertion point in the drawing 

upon insertion, or enter coordinates.
E Choose to specify the size of the image in the 

drawing upon insertion, or enter the size values.
F Choose whether to turn clipping display on or off for 

the image.

G Choose whether entities located under the image are 
visible (for images that support alpha transparency).

H Choose to specify rotation in the drawing upon 
insertion, or enter how many degrees to rotate the 
image to the left.

I Click to view image information, including color depth 
and resolution. 

J Choose to save the image path as its full path, 
relative path to the current drawing folder, or file 
name in the current drawing folder.
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Modifying images
You can modify an image by changing its brightness, contrast, fade, size, rotation, or 
transparency. These changes affect the image in the drawing only — not the original 
external image file.

In addition to modifying a single image or multiple images that you select, you can 
also modify all occurrences of an image within a drawing. For example, if your com-
pany logo appears in multiple locations throughout a drawing, you can use the Image 
Manager to specify the changes once and apply them to all occurrences of the logo.

You can use other IntelliCAD commands for typical modifications, such as Delete, 
Move, Copy, Rotate, and more. 

To modify images
1 Do one of the following to choose Image Manager ( ):

• On the ribbon, choose Insert > Image Manager (in Data).

• On the menu, choose Insert > Image > Image Manager.

• On the Image toolbar, click the Image Manager tool.

• Type image and then press Enter.

TIP You can also modify images by selecting one or more images in a drawing, 
and then choosing Modify > Properties.

2 In the Images list, select the image you want to modify. If there is more than one 
occurrence of the image in the drawing, do one of the following:

• To modify all occurrences of the image, select a top-level image in the list.

• To modify a single occurrence of the image, expand a top-level image in the list, 
and then select the individual image.

3 Adjust the Brightness, Contrast, and Fade by moving the slider to the setting you 
want or by entering an exact number. The image preview shows how your changes 
will affect the image. 

TIP If you want to restore the image to the default brightness, contrast, and fade 
settings, click Reset.

4 Adjust the Size by making changes to the width (X) and height (Y) in drawing 
units. Mark Keep Aspect Ratio if you want the width and height to change 
together to retain the aspect ratio of the image.

5 Adjust the Rotation by entering the number of degrees you want to rotate the 
image to the left. Zero degrees indicates no rotation.

6 Mark Use Transparency if you want entities located under the image to be visible 
(for images that support alpha transparency, that is, images that have at least one 
color that can be viewed as a transparent color).
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7 Mark Show Clipping Boundary if you want to show the image clipped, if a clip-
ping boundary is defined for the image. Unmarking this option displays the whole 
image, even if a clipping boundary is defined.

8 Click OK.
 

A Click a top-level image to modify all occurrences 
located in the drawing. Expand a top-level image and 
click an individual image to modify that occurrence 
only.

B Move the slider or enter an exact number for image 
brightness.

C Move the slider or enter an exact number for image 
contrast.

D Move the slider or enter an exact number for image 
fade, which fades the image without displaying 
entities located under the image.

E Click to return to the default brightness, contrast, and 
fade settings.

F Choose whether all image frames in the drawing 
display and print.

G Choose whether all images in the drawing display in 
high quality (requires more system resources).

H Enter the width (X) and height (Y) in drawing units. 
Mark Keep Aspect Ratio to change width and height 
together.

I Choose whether to turn clipping display on or off for 
the image.

J Choose whether entities located under the image are 
visible (for images that support alpha transparency).

K Enter how many degrees to rotate the image to the 
left.

L Click to view details about the selected image.
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Changing the display of images
You can change the following for how all images display in a drawing:

• Image quality — Images can display in high or low resolution.

• Image frames — Images can display and print with or without frames on their 
edges.

Changing the display quality for all images
High quality displays images in high resolution and requires more system resources. 
Draft quality displays images in low resolution and consumes fewer system 
resources. Changing the quality setting affects all images in the drawing.

To change the display quality for all images
1 Do one of the following to choose Image Quality ( ): 

• On the ribbon, choose Insert > Image Quality (in Data).

• On the menu, choose Insert > Image > Image Quality.

• On the Image toolbar, click the Image Quality tool.

• Type imagequality and then press Enter.

2 Choose High or Draft.

TIP This feature is also available in the Image Manager. Type image, then in the 
Image Manager dialog box, choose your selection for High-quality image display.
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Turning image frames on or off for all images
When image frames are turned on, a frame displays and prints on the edge of all 
images in the drawing. When image frames are turned off, none of the images display 
or print with a frame. Each image frame displays with the properties (layer, color, 
linetype, etc.) that are assigned to the image.

Turning image frames off may be helpful, for example, if the images are part of a 
background in the drawing.

To turn image frames on or off for all images
1 Do one of the following to choose Display Image Frame ( ): 

• On the ribbon, choose Insert > Display Image Frame (in Data).

• On the menu, choose Insert > Image > Display Image Frame.

• On the Image toolbar, click the Display Image Frame tool.

• Type imageframemode and then press Enter.

2 Choose On or Off.

3 If you chose On, choose whether to print image frames.

Image frames can be turned on an off using various methods. 
Type image, then in the Image Manager dialog box, make your selection in Image 
Frames. Or use the IMAGEFRAME system variable. Additionally, type tframe to turn 
on or off all image and wipeout frames in the drawing.
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Clipping images
You can clip images so that only a portion of the image is visible in a drawing. The 
visible portion (or the invisible portion for inverted clips) can be in the shape of a 
rectangle, polygon, or existing polyline.

Image clipping can be turned on and off. If you turn off clipping for an image, the 
entire image is visible provided that the image is on a layer that is on and thawed. The 
clipping information is retained however, and you can turn clipping back on at any 
time. 

If you delete clipping from an image, the clipping is removed permanently but the 
image itself remains in the drawing.

Clipping images in the shape of a polygon or rectangle

To clip an image in the shape of a polygon or rectangle
1 Do one of the following to choose Clip Image ( ):

• On the ribbon, choose Insert > Clip Image (in Data).

• On the menu, choose Insert > Image > Clip Image.

• On the Image toolbar, click the Clip Image tool.

• Type imageclip and then press Enter.

2 Select the edge of the image you want to clip.

3 Choose New Boundary to create a new clipping boundary.

4 By default, only the portion of the image located within the clipping polygon will 
be visible. If you want to invert the clip, that is, hide the area inside the boundary 
and make the outer portion visible, choose Invert Clip before the next step.

5 Choose one of the following:

• Polygonal, then select the points for the polygon, and press Enter when the 
polygon is complete. 

• Rectangular, then select the first and opposite corners of the clipping rectangle.
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Clipping images in the shape of an existing polyline

To clip an image in the shape of an existing polyline
1 Do one of the following to choose Clip Image ( ):

• On the ribbon, choose Insert > Clip Image (in Data).

• On the menu, choose Insert > Image > Clip Image.

• On the Image toolbar, click the Clip Image tool.

• Type imageclip and then press Enter.

2 Select the edge of the image you want to clip.

3 Choose New Boundary.

4 By default, only the portion of the image located within the clipping polygon will 
be visible. If you want to invert the clip, that is, hide the area inside the boundary 
and make the outer portion visible, choose Invert Clip before the next step.

5 Choose Select Polyline.

6 Select an existing polyline to use as the clipping boundary, then press Enter. If the 
polyline is not closed, the clipping boundary is formed as if the start and end 
points connect.

Turning clipping on or off for images

To turn clipping on or off for an image
1 Do one of the following to choose Clip Image ( ):

• On the ribbon, choose Insert > Clip Image (in Data).

• On the menu, choose Insert > Image > Clip Image.

• On the Image toolbar, click the Clip Image tool.

• Type imageclip and then press Enter.

2 Select the edge of the image for which you want to turn clipping on or off.

3 Choose On or Off.

Removing clipping from images

To remove clipping from an image
1 Do one of the following to choose Clip Image ( ):

• On the ribbon, choose Insert > Clip Image (in Data).

• On the menu, choose Insert > Image > Clip Image.

• On the Image toolbar, click the Clip Image tool.

• Type imageclip and then press Enter.

2 Select the edge of the image for which you want to remove clipping.

3 Choose Delete.
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Unloading and reloading images
If you find that including an image affects system performance, you can unload it so 
only the image frame displays to mark its location. If you want an unloaded image to 
print, reload it before printing. You may also want to reload an image if the original 
file contains new content.

To unload and reload an image
1 Do one of the following to choose Image Manager ( ): 

• On the ribbon, choose Insert > Image Manager (in Data).

• On the menu, choose Insert > Image > Image Manager.

• On the Image toolbar, click the Image Manager tool.

• Type image and then press Enter.

2 In the Images list, select the desired image. If there is more than one occurrence of 
the image in the drawing, do one of the following:

• To unload or reload all occurrences of the image, select a top-level image in the 
list.

• To unload or reload a single occurrence of the image, expand a top-level image 
in the list, and then select the individual image.

3 Do one of the following: 

• To unload the image so only its outer edge displays, click Unload.

• To reload the image so its contents display and print, click Reload.
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Changing the path for images
If the file associated with an image is renamed or moved to a different location, the 
program displays a message indicating that it cannot load the image. You can re-
establish the link to the file by changing the path for the image.

To change the path for an image
1 Do one of the following to choose Image Manager ( ): 

• On the ribbon, choose Insert > Image Manager (in Data).

• On the menu, choose Insert > Image > Image Manager.

• On the Image toolbar, click the Image Manager tool.

• Type image and then press Enter.

2 In the Images list, select the desired image. If there is more than one occurrence of 
the image in the drawing, do one of the following:

• To change the path for all occurrences of the image, select a top-level image in 
the list.

• To change the path for a single occurrence of the image, expand a top-level 
image in the list, and then select the individual image.

3 Click the [...] button.

4 Select the file with its new name or in its new location, and then click Open.

5 Click Set Path.

Deleting images
Once an image is no longer required in the drawing, you can delete it from the draw-
ing. Deleting an image removes it from the drawing, and from the list of images in the 
Image Manager dialog box. 

To delete an image
1 Do one of the following to choose Image Manager ( ): 

• On the ribbon, choose Insert > Image Manager (in Data).

• On the menu, choose Insert > Image > Image Manager.

• On the Image toolbar, click the Image Manager tool.

• Type image and then press Enter.

2 In the Images list, select the image you want to delete. If there is more than one 
occurrence of the image in the drawing, do one of the following:

• To delete all occurrences of the image, select a top-level image in the list.

• To delete a single occurrence of the image, expand a top-level image in the list, 
and then select the individual image.

3 Click Detach. 
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Working with geographic locations

Adding a geographic location to a drawing allows you to draw entities that corre-
spond to specific locations on a map, which can be especially helpful when working 
with drawings that contain survey, civil, and architectural data.

A geographic location is commonly specified by entering latitude, longitude, and ele-
vation values with a coordinate system, but the location can also be specified using 
your current location or a Keyhole Markup Language map file (.kml or .kmz). Note 
that an Internet connection is required.

Once a geographic location is specified, an online map displays in the background of 
the drawing along with a red geographic location marker, which IntelliCAD uses to 
compute all relative geographic coordinates in the drawing. It is common to zoom 
and pan the map next, so you can view a specific area of the map. You may want to 
create position markers, which indicate and annotate geographic locations on the 
online map. Or you may want to capture an area as a map image, which creates a 
static image in the drawing. Then you can turn off the online map, and draw entities 
at specific geographic coordinates on top of the map image, updating the map image 
as needed and changing between hybrid, road, and satellite map types.

Adding a geographic location
Geographic locations can be added using latitude and longitude coordinates, your 
current location, or a Keyhole Markup Language map file (.kml or .kmz). After you 
specify a geographic location, a map displays with a red geographic location marker, 
which indicates the coordinates used to insert the online map and used to calculate all 
relative geographic coordinates.

An Internet connection is required.

To specify a geographic location
1 Do one of the following to choose Set Location ( ): 

• On the ribbon, choose Insert > Set Location (in Geolocation).

• On the menu, choose Insert > Geolocation > Set Location.

• Type geo and then press Enter.

Only one geographic location can be specified in a drawing at a time.
If the Set Location command is unavailable, a location is already set in the draw-
ing. Use the Geographic Map command (type geomap) to check whether the dis-
play is turned off.

2 If prompted, click Yes to allow the program to use the Internet. Or click No to can-
cel the command.
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3 Do one of the following, depending on how you want to specify the location:

• Use your current location — If necessary, turn on location access for your 
computer, then click Load Current Location.

• Load a map file — Click Load Map File, select a .kml or .kmz file, then click 
Open. The first location mark defined in the selected file is used to place the 
geographic location marker.

• Enter location values  — Enter the latitude, longitude, and optional elevation.

4 In Coordinate System, select a coordinate system or choose Select Coordinate 
System.

The dialog box that displays may require extra time to open as it scans the entire 
coordinate database to find coordinate systems appropriate for the specified loca-
tion.

5 Select a coordinate system. 

The list displays coordinate systems that are referenced by the latitude and longi-
tude previously determined in the Geographic Location - Set Location dialog box.

6 Click OK.

7 Click OK again.

8 In model space of the drawing, specify the location of the geographic location 
marker, which corresponds to the location on the Earth surface that you specified 
in the Geographic Location - Set Location dialog box.

9 Specify the angle of deviation from the x-axis that indicates the north direction. 
Or, to determine the north direction using a line, choose First Point, specify the 
start point of the line, then specify the end point of the line to set the angle.

An online map and a red geographic marker display in the drawing. You may need 
to zoom or pan to view the map precisely.

Changing how a geographic location map displays
You can display online maps in these ways:

• Aerial  — Displays aerial satellite imagery.

• Road — Displays the road view.

• Hybrid — Displays aerial satellite imagery overlaid with roads.

• Off — Hides the online map in the current viewport. The map display is turned 
off, but the map and its data remain in the drawing.

An Internet connection is required.



608 C H A P T E R  1 3
To change the display of a geographic location map
1 Do one of the following to choose Geographic Map ( ), which is available only 

if an online map was added using the Set Location command and the map service 
is turned on using the Map Service command:

• On the ribbon, choose Geolocation > Map Aerial, Map Road, Map Hybrid, or 
Map Off (in Online Map).

• On the menu, choose Insert > Geolocation > Map Aerial, Map Road, Map 
Hybrid, or Map Off.

• Type geomap and then press Enter.

2 If you entered the command at the command prompt, choose the map display type, 
then press Enter.

Removing a geographic location
When you remove a geographic location from a drawing, you remove all associated 
data, including the coordinate system details, online map, and the red geographic 
location marker.

If you need to hide the online map temporarily, you can simply turn off its display 
using the Geographic Map command. For more details, see “Changing how a geo-
graphic location map displays” on page 607 in this chapter. 

If you need to turn off Internet access temporarily for the online map, use the Map 
Service command. For more details, see “Turning the map service on and off” on 
page 611 in this chapter. 

To remove a geographic location
1 Do one of the following to choose Remove Location ( ), which is available 

only if an online map was added using the Set Location command:

• On the ribbon, choose Geolocation > Remove Location (in Location).

• On the menu, choose Insert > Geolocation > Remove Location.

• Type georemove and then press Enter.

2 Choose Yes to confirm deletion.

Adding markers and annotations to a geographic location map
Position markers indicate and annotate a location on an online map. Each position 
marker has a point, leader, and multiline text.

An Internet connection is required.
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To add a position marker to an online map
1 Do one of the following to choose Mark Position ( ), which is available only if 

an online map was added using the Set Location command and the map service is 
turned on using the Map Service command:

• On the ribbon, choose Geolocation > Mark Position (in Tools).

• On the menu, choose Insert > Geolocation > Lat-Long, My Location, or Point.

• Type geomarkposition and then press Enter.

2 Choose one of the following, depending on how you want to define the position 
marker:

• Lat-Long  — Places the position marker by specifying its latitude and longitude. 
Enter the latitude and longitude values at the prompts that display.

• My Location — Places the position marker at the point that corresponds to your 
current location. An Internet connection is required and location access must be 
turned on for your computer.

• Point — Places the position marker by specifying its location in the drawing. At 
the prompt that displays, select the location in the drawing.

3 To specify an annotation at the position marker location, press Enter, and type 
multiline text. Or to specify another location for the annotation, click the desired 
point in the drawing, then type multiline text.

4 When finished typing text, click Close Editor to accept your changes and close the 
text editor.

You can change the size of position markers.
At the command prompt, type geomarkpositionsize and enter the desired size.

Working offline with images of geographic map areas
You can create a raster image, or map image, of a geographic map area. This is espe-
cially helpful when you need to work offline. Each map image can display with a type 
— aerial, road, or hybrid — and at a specific resolution.

An Internet connection is not required after a map image is created, but it is required 
while creating or updating it.

To create a map image
1 Do one of the following to choose Capture Area ( ), which is available only if 

an online map was added using the Set Location command and the map service is 
turned on using the Map Service command:

• On the ribbon, choose Geolocation > Capture Area (in Online Map).

• On the menu, choose Insert > Geolocation > Capture Area.

• Type geomapimage and then press Enter.
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2 Specify the first corner of the rectangle to define the map image, or choose Center 
to use the map's center point.

3 Specify the opposite corner of the rectangle to define the map image.

To change the display type of a map image
1 Select a map image.

2 Do one of the following to choose Map Image Type ( ):

• On the ribbon, choose Map Image > Map Aerial, Map Road, Map Hybrid (in 
Properties).

• Type geomapimagesetmaptype and then press Enter.

3 If you entered the command at the command prompt, choose the display type for 
the map image:

• Aerial  — Displays aerial satellite imagery.

• Road — Displays the road view.

• Hybrid — Displays aerial satellite imagery overlaid with roads.

To change the resolution of a map image
1 Select a map image.

2 Do one of the following to choose Map Image Resolution ( ):

• On the ribbon, choose Map Image > Very Fine, Fine, Optimal, Coarse (in 
Properties).

• Type geomapimagesetresolution and then press Enter.

3 If you entered the command at the command prompt, choose the resolution.

To reload or reset a map image
1 Select a map image.

2 Do one of the following to choose Reload Image ( ), which is only available if 
the map service is turned on using the Map Service command:

• On the ribbon, choose Map Image > Reload Image (in Update).

• Type geomapimageupdate and then press Enter.

3 Choose one of the following:

• Optimize  — Resets the map image to display with an optimal resolution for 
viewing.

• Reload — Updates the map image to include data from the latest online map.

Use a shortcut.
Right-click a map image and choose Geolocation to select commands for working 
with map images.
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Turning the map service on and off
If Internet privacy or bandwidth is a concern while working with a drawing, turning 
off the map service prevents the program from accessing the Internet to display the 
online map and prevents use of the Mark Position, Capture Area, and Reload Image 
commands. Then when you’re ready, it’s easy to turn on the map service again.

You might also need to turn the map service on if you previously chose to not allow 
the program to access the Internet when starting various geographic location com-
mands.

If you need to hide the online map temporarily, you can simply turn off its display 
using the Geographic Map command. For more details, see “Changing how a geo-
graphic location map displays” on page 607 in this chapter. 

To turn the map service on or off
1 Do one of the following to choose Map Service ( ), which is available only if 

an online map was added using the Set Location command:

• On the ribbon, choose Geolocation > Map Service (in Location).

• On the menu, choose Insert > Geolocation > Map Service.

• Type geomapservice and then press Enter.

2 Do one of the following:

• Choose Yes to turn on the map service, and if prompted, click Yes to allow 
internet use. 

• Choose No to turn off the map service.
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Printing drawings

You can print a copy of your drawing exactly as you created it, or you can add 
formatting and specify print controls to change how your drawing looks when it is 
printed.

Sometimes you may require multiple printed drawings, each with a different look or 
layout. For example, you may need one printed drawing for a client presentation, 
along with several other variations for production contractors. For each type of 
printed drawing that you require, you can create a layout that defines its 
characteristics, including scale, area to print, print style tables, and more.

This section explains how to:

• Start printing right away.

• Set up a drawing to print multiple layouts from paper space on a Layout tab.

• Customize how you want your drawing to look when it is printed.

• Define how to print your drawing further using print styles.

• Print or plot your drawing.

• Publish your drawing using sheet sets or sheet lists. 

Topics in this chapter

Getting started printing......................................................................................614

Defining layouts for printing...............................................................................615

Customizing and reusing print settings .............................................................629

Using print styles...............................................................................................648

Printing or plotting your drawing........................................................................660

Publishing sheet sets ........................................................................................665
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Getting started printing

When you create a drawing, you do most of your work on the Model tab. At any time 
you can print your drawing to see how it looks on paper. It’s easy to get started print-
ing, and then later create layouts and custom print settings to enhance your printed 
output.

To start printing
1 From the Model tab, do one of the following to choose Print ( ):

• On the ribbon, choose the Application button then choose Print, or choose 
Output > Print (in Print).

• On the menu, choose File > Print.

• On the Standard toolbar, click the Print tool.

• Type print and then press Enter.

2 Click Print.

There are many print options detailed in this section, such as the scale of the drawing, 
print area, print style tables, and more.

Type qprint and then press Enter to print the current viewport.  
The Print dialog box is bypassed and the drawing is sent directly to the selected 
printer.
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Defining layouts for printing

You can print your drawing directly from the Model tab where you created it, or you 
can create custom layouts for printing on Layout tabs. 

When printing from the Model tab, you can print your drawing exactly the way it 
appears, or you can modify the drawing before printing by adding dimensions, a leg-
end, or a title block.

You typically use the Layout tabs for printing if you require multiple print layouts. 
You may also want to use a Layout tab for printing even if you want your drawing 
printed only one way. For example, if you want to include large amounts of text on 
your printed drawing, you can add the text to a Layout tab so it does not clutter your 
drawing while you work on the Model tab.

Understanding layouts
When you create a drawing, you do most of your work on the Model tab. Each draw-
ing that you create can contain numerous layouts that simulate the paper on which 
you will print a copy of the drawing. Each of these layouts is created on a Layout tab.

You can prepare a separate layout for each way you want to print your drawing. The 
layout allows you to organize different views to control which portion of your draw-
ing prints and at what scale. 

Before you print, you can also include additional entities and layout settings that con-
trol how your drawing prints. Additional items only appear on the Layout tab, not on 
the Model tab. For example, a layout can contain dimensions, title blocks, legends, or 
keynotes that print with your model, but do not clutter the screen when you work with 
your model on the Model tab.

Use these general steps to prepare your drawing for printing multiple layouts:

1 On the Model tab, create your drawing.

2 Create a new layout. You can use an existing Layout1 or Layout2 tab, or you can 
create a new Layout tab. For details, see “Creating a new layout” on page 619 in 
this chapter. 

3 Create at least one layout viewport on the Layout tab. Use each viewport to help 
control which portion of the drawing prints and at what scale. For details, see 
“Working with layout viewports” on page 622 in this chapter. 

4 Include any additional items that may be required for the specific layout, such as 
dimensions, a legend, or a title block.

5 Specify additional settings for the layout, such as the scale of the drawing, print 
area, print style tables, and more. For details, see “Customizing and reusing print 
settings” on page 629 in this chapter. 

6 Print or plot your drawing. For more details, see “Printing or plotting your draw-
ing” on page 660 in this chapter. 
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Understanding paper space and model space
When you start a drawing session, your initial working area is called model space. 
Model space is an area in which you create two-dimensional and three-dimensional 
entities based on either the World Coordinate System (WCS) or a user coordinate 
system (UCS). You view and work in model space while using the Model tab.

Your view of this area is a single viewport that fills the screen. You can create addi-
tional views on the Model tab, called viewports, which can show the same or differ-
ent two-dimensional or three-dimensional views, all of which are displayed in a tiled 
manner. You can work in only one of these viewports at a time on the Model tab, and 
you can print only the current viewport.                     
  

IntelliCAD provides an additional work area, called paper space. The contents of 
paper space represent the paper layout of your drawing. In this work area, you can 
create and arrange different views of your model similar to the way you arrange detail 
drawings or orthogonal views of a model on a sheet of paper. You can also add 
dimensions, keynotes, annotations, borders, title blocks, and other print-related 
entities in paper space, which reduces clutter when you work with your model in 
model space.              

You view and work in paper space while using a Layout tab. Each view, or layout 
viewport, that you create in paper space provides a window of your drawing in model 
space. You can create one layout viewport or several. You can place layout viewports 
anywhere on the screen; their edges can be touching or not; and you can print them all 
at the same time. 

Model space with two viewports.
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You do not need to use paper space to print your drawing, but it offers several advan-
tages: 

• Print the same drawing with different print settings that you save with each layout, 
for example, printer configuration files, print style tables, lineweight settings, 
drawing scale, and more.

• Add print-related entities that are not essential to the model itself, such as key-
notes or annotations, to reduce clutter when you work with your model in model 
space on the Model tab.

• For a single layout, create multiple layout viewports that print the model at differ-
ent views and scales.

     

You can copy and move entities between model space and paper space.
Choose Modify > Change Space, then select the entities you want to copy or move 
from paper space to model space or from model space to paper space.

Paper space with layout viewports.
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Viewing drawings in paper space and model space
When you work in paper space on a Layout tab, you can still view your drawing in 
model space. First you need to create a layout viewport in paper space; this allows 
you to view your model space entities from paper space. 

Within a layout viewport you can modify and snap to model space entities while 
working in model space and even snap to model space entities from paper space. 
Snapping to model space entities from paper space allows you to accurately dimen-
sion model space entities in paper space. And although it is generally more conve-
nient to modify entities on the Model tab, there are often times when it is convenient 
to make modifications from a layout viewport on a Layout tab.

Zooming or panning the drawing in model space or paper space affects the entire 
drawing, unless you use multiple windows or viewports. Additionally, if you are 
working from paper space, you can lock the layout viewport so the viewport scale and 
view center do not change while panning and zooming in the layout viewport.

To view a drawing in model space on the Model tab       
Do one of the following:

• Click the Model tab.

• Right-click a Layout tab and choose Activate Model Tab.

• Right-click Model or Paper Space in the status bar, and then choose Model.

• While using a layout tab, type model.

• Type ctabnext or press Ctrl+Page Down to switch to the next tab; type ctabprev or 
press Ctrl+Page Up to switch to the previous tab.

To view a drawing in paper space on a Layout tab   
Do one of the following:    

• Click one of the Layout tabs.

• Click the navigation arrows at the beginning of the row of Layout tabs to view 
Layout tabs in the order in which they appear.

• Click ( ) at the end of the row of Layout tabs, then choose a layout from the list.

• Right-click a Model or Layout tab and choose Activate Previous Layout.

• Type layout and then press Enter. In the prompt box, choose Set. Type a name for 
the layout you want to make current, and then press Enter.

• Double-click Model or Paper Space in the status bar. For example, double-click 
“Model” or “M:Tab Name” in the status bar to switch to paper space.

• While using a Layout tab, type pspace and then press Enter. 

• While using a Layout tab, double-click outside of the layout viewport.

• Type ctabnext or press Ctrl+Page Down to switch to the next tab; type ctabprev or 
press Ctrl+Page Up to switch to the previous tab.
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To view a drawing in model space on a Layout tab       
Do one of the following:

• Click the desired Layout tab, and then create and view a layout viewport. For more 
details, see “Working with layout viewports” on page 622 in this chapter. 

• Double-click Model or Paper Space in the status bar. For example, double-click 
“P:Tab Name” in the status bar to switch to model space on the current Layout tab.

• Type mspace and then press Enter.

• While using a Layout tab, double-click inside of the layout viewport.

Displaying the Model and Layout tabs
The Model and Layout tabs can be hidden, if desired. You may want to hide the tabs 
if you only work on the Model tab or if you use the command bar and status bar to 
switch between tabs.      

To turn the Model and Layout tabs display on or off
Do one of the following:

• On the ribbon, choose View > Model and Layout tabs (in Display).

• Choose View > Display > Model and Layout tabs.

• Choose Tools > Options > Display tab, and choose Show Tabs.

Creating a new layout
In IntelliCAD, you can create multiple layouts for a single drawing. Each layout rep-
resents a sheet of paper. For each layout you can specify the print area, print styles, 
print scale, lineweight scale, pen mappings, and add viewports, dimensions, a title 
block, and other geometry specific to the layout.

The entities you add to a layout in paper space do not appear in model space.

Each layout requires at least one layout viewport, which is created automatically 
when you create a new layout. This viewport displays the drawing’s model space 
entities. 

When you create a new drawing, the drawing automatically contains two default lay-
outs: Layout1 and Layout2. You can start by using one of the default layouts, you can 
create your own, or your can create a new layout from another template (.dwt) file, 
drawing (.dwg) file, or drawing interchange (.dxf) file. You can also use IntelliCAD’s 
Explorer to create and manage layouts.

Each drawing can contain up to 255 layouts.

To create a new layout using the Layout1 or Layout2 tab
1 Click the Layout1 or Layout2 tab.

2 If necessary, set up at least one layout viewport. For details, see “Working with 
layout viewports” on page 622 in this chapter. 
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3 If desired, rename the layout. For details, see “To rename a layout” on page 622 in 
this chapter. 

To create a new layout using a new Layout tab 
1 Do one of the following to choose New Layout ( ):

• On the ribbon, choose View > New Layout (in Layouts).

• Choose Insert > Layout > New Layout.

• On the Layouts toolbar, click the New Layout tool.

• Type layout, press Enter, and choose New. 

• Right-click a Layout tab and choose New.

2 Type a unique name for your layout and then press Enter.

The name can be up to 255 characters in length and can contain letters, numbers, 
the dollar sign ($), hyphen (-), and underscore (_), or any combination.

3 Set up at least one layout viewport. For details, see “Working with layout view-
ports” on page 622 in this chapter. 

To create a new layout from an existing file
1 Do one of the following to choose Layout from Template ( ):

• On the ribbon, choose View > Layout from Template (in Layouts).

• On the menu, choose Insert > Layout > Layout from Template.

• On the Layouts toolbar, click the Layout from Template tool.

• Type layout, press Enter, and choose Template. 

• Right-click a Layout tab and choose From Template.

2 Select the desired template, drawing, or drawing interchange file that contains the 
layout you want, and then click Open.

3 Select the layout(s), and then click OK. You can choose multiple layouts by hold-
ing down Ctrl while selecting layout names.

Reusing layouts from other files
Save time by re-using layouts that you have already created. Within the same draw-
ing, you may want to make a copy of a layout that contains most of the settings you 
want, and then make changes to the new copy. If you created layouts that you want to 
use again when you create new drawings, you can save the layouts as a drawing tem-
plate. 

To make a copy of a layout
1 Do one of the following:

• Right-click the Layout tab you want to copy, then choose Copy.

• Type layout and then press Enter. Then choose Copy and type the name of the 
layout you want to copy, and then press Enter.
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2 Type a name for the new layout, and then click OK or press Enter, depending on 
how you started the command.

To save a layout as a drawing template
1 Do one of the following:

• Right-click the Layout tab you want to save, then choose Save As.

• Type layout and then press Enter. Then choose Save and type the name of the 
layout you want to save, and then press Enter.

2 Specify the file name and location for the template, and then click Save.

After you save a layout as a template, you can use the template when you create new 
drawings. You can also import the template’s layouts into another drawing.

Exporting layouts to model space of a new drawing
Any layout can be exported to model space of a new drawing. During the export, enti-
ties might be modified by trimming, scaling, or exploding in order to visually repre-
sent the layout contents in model space.

To export a layout to model space of a new drawing
1 Click the Layout tab you want to export.

2 Do one of the following to choose Export Layout to Model ( ):

• On the ribbon, choose View > Export Layout to Model (in Layouts).

• On the menu, choose Insert > Layout > Export Layout to Model.

• On the Layouts toolbar, click the Export Layout to Model tool.

• Type exportlayout and then press Enter.

• Right-click the Layout tab and choose Export Layout to Model.

3 Specify the name of the file you want to create, and then click Save. 

Managing layouts in a drawing
You can rename layouts, delete layouts, and view a list of all layouts available in a 
drawing. You can also change the order in which the Layout tabs appear; the Model 
tab is always stationary. 

If you want to rename, delete, or reorder a layout when the Layout tabs are hidden, 
you can type layout to make your changes or choose View > Display > Model and 
Layout Tabs to display the tabs.
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To rename a layout 
1 Right-click the Layout tab you want to rename.

2 Choose Rename.

3 Type a new name for the layout.

4 Click OK.

The name can be up to 255 characters in length and can contain letters, numbers, 
the dollar sign ($), hyphen (-), and underscore (_), or any combination.

To delete a layout 
1 Right-click the Layout tab to delete.

2 Choose Delete.

3 Click OK to confirm the deletion.

You cannot delete the Model tab or the last remaining Layout tab. 
To delete all geometry from the Model tab or a Layout tab, first select all geometry 
and then use the Erase command.

To reorder the Layout tabs  
1 Right-click the Layout tab you want to move.

2 Do one of the following:

• Choose Move Right, and then choose a new location.

• Choose Move Left, and then choose a new location.

To view a list of all layouts 
1 Type layout and then press Enter.

2 In the prompt box, choose ? to list all layouts.

3 Type s or press Enter to scroll through the layouts.

Working with layout viewports
A layout viewport is a window in a Layout tab (paper space) that displays all or a por-
tion of a drawing’s model space entities.

Understanding layout viewports
When you begin working in a drawing on the Model tab, it consists of a single view 
of your model. You may have created additional views by dividing the drawing space 
into multiple windows; each window is a separate viewport on the Model tab.       
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Similarly, when you begin working in a drawing on a Layout tab, it consists of a sin-
gle view from paperspace of your model. You can also create multiple layout view-
ports that display unique views of your model. Each layout viewport functions as a 
window into your model space drawing — with each window looking different from 
the next. You can customize the view center, scale, layer visibility, and contents of 
each layout viewport. Each layout viewport is created as a separate entity that you can 
move, copy, or delete.     

Click any layout viewport to make it the current viewport, and then add or modify 
model space entities in that viewport, even while snapping to model space entities 
from paper space. Any changes you make in one layout viewport are immediately 
visible in the other viewports (if the other layout viewports are displaying that portion 
of the drawing). Zooming or panning in the current viewport affects only that view-
port.               

This section focusses on working with layout viewports in paper space on a Layout 
tab. For additional information about viewports in model space, see “Dividing the 
current window into multiple windows” on page 243. 

Creating layout viewports
The first time you switch to a Layout tab, your model displays in a default layout 
viewport. You can create other layout viewports anywhere inside the drawing area. 
You can control the number of viewports created and the arrangement of the view-
ports.            

To create layout viewports
1 Do one of the following to choose Layout Viewports ( ):

• On the ribbon, choose View > Layout Viewports (in Layouts or in Viewports).

• On the menu, choose View > Viewports > Layout Viewports.

• On the Viewports toolbar, click the Layout Viewports tool.

• Type mview and then press Enter.

2 Specify two opposing corners to create a custom rectangular viewport, or in the 
prompt box, choose one of the following:

• Fit To View — Creates a layout viewport that fills the screen.

• Entity — Converts a closed entity to a layout viewport. You can convert a circle, 
ellipse, closed polyline, spline, or region.

• Polygonal — Creates a non-rectangular layout viewport.

• Create 2 Viewports, Create 3 Viewports, Create 4 Viewports — Creates two, 
three, or four layout viewports using an orientation that you specify. You can 
select whether to arrange the viewports to fill the current graphic area or a 
rectangular area that you specify.  
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The border of a new layout viewport is created on the current layer.  
You can make layout viewport borders invisible by creating a new layer before you 
create layout viewports and then turning off that layer after you create the layout 
viewports. To select a layout viewport’s borders, you must turn that layer back on 
before you can rearrange or modify the layout viewport.

You can create a single layout viewport, or you can divide the graphic area into two viewports arranged 
vertically (A) or horizontally (B); three viewports arranged left (C), right (D), above (E), below (F), vertically 
(G), or horizontally (H); or four viewports (I).

A B C

D E F

G H I
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Viewing and scaling layout viewports
If you have created numerous layout viewports, your system performance may be 
affected. If necessary, you can turn a layout viewport on or off. Turning off a layout 
viewport does not delete the viewport or its contents; it simply turns off its display. 

You can also change how you view items within a layout viewport by specifying a 
scale factor, which changes how large or small model space entities appear within the 
layout viewport. Another helpful tool is the Align Space command, which changes 
the pan and zoom magnification of model space entities in a layout viewport so they 
align with entities in paper space or in other layout viewports.

While working in a layout viewport, you can use the Maximize Viewport command 
to enlarge the view to full size and emulate model space, allowing you to easily work 
on the geometry in that view. When done, use the Minimize Viewport command to 
switch back to the original scale and center point of the layout viewport.

To turn layout viewports on or off 
1 Click the desired Layout tab.

2 Do one of the following to choose Layout Viewports ( ):

• On the ribbon, choose View > Layout Viewports (in Layouts or in Viewports).

• On the menu, choose View > Viewports > Layout Viewports.

• On the Viewports toolbar, click the Layout Viewports tool.

• Type mview and then press Enter.

3 Choose On or Off.

4 Select the edge of the layout viewport to turn on or off, and then press Enter.

To maximize a layout viewport
1 On a Layout tab, select a layout viewport. Or, skip this step to maximize the cur-

rent layout viewport.

2 Do one of the following:

• On the ribbon, choose View > Maximize Viewport (in Viewports).

• On the menu, choose View > Viewports > Maximize Viewport.

• On the status bar, click Maximize Viewport ( ).

• Type vpmax and then press Enter.

The layout viewport is enlarged.
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To minimize a layout viewport (if it is maximized)
1 Do one of the following:

• On the ribbon, choose View > Minimize Viewport (in Viewports).

• On the menu, choose View > Viewports > Minimize Viewport.

• On the status bar, click Minimize Viewport ( ).

• Type vpmin and then press Enter.

The layout viewport returns to its original scale and center point.

To change the layout viewport scale 
1 Do one of the following to choose Properties ( ):

• On the ribbon, choose View > Properties (in Panes).

• On the menu, choose View > Display > Properties or Modify > Properties.    

• On the Modify toolbar, click the Properties tool.

• Type entprop and then press Enter.

2 Select the edge of the layout viewport. 

3 In Custom Scale, enter the scale at which you want to view model space entities 
from within the layout viewport.

4 Click OK.

To report the scale of a layout viewport scale 
1 Do one of the following to choose List Viewport Scale ( ):

• On the ribbon, choose Express Tools > List Viewport Scale (in Layout).

• On the menu, choose Express Tools > Layout > List Viewport Scale. 

• Type vpscale and then press Enter.

2 Select the edge of the layout viewport, then press Enter.

The viewport scale (paperspace to model space) displays in the command bar.

To change the scale of model space entities relative to paper space  
1 Click the Model tab. 

2 Click a viewport to make it current.

3 Choose View > Zoom > Zoom.

4 Type the zoom scale factor relative to paper space by appending the suffix xp to 
the scale factor, and then press Enter. 

For example, to increase the scale of the entities in the viewport on the Model tab 
to twice the size of paper space units, type 2xp. To decrease the scale to half the 
size of paper space units, type .5xp.
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To change the zoom and pan of a layout viewport relative to paper space or 
another layout viewport
1 Click a Layout tab. 

2 Do one of the following to choose Align Space ( ):

• On the ribbon, choose Express Tools > Align Space (in Layout).

• On the menu, choose Express Tools > Layout > Align Space. 

• Type alignspace and then press Enter.

3 Specify the first alignment point in model space of a layout viewport.

4 Specify the second alignment point in model space of the same layout viewport, or 
press Enter if you do not need to specify a second point.

5 Specify the first alignment point in paper space or another layout viewport.

6 If you previously specified a second alignment point in model space, specify the 
second alignment point in paper space or another layout viewport.

7 Select the layout viewport to align by changing its pan and zoom magnification, 
then press Enter.

To synchronize layout viewports 
1 Do one of the following to choose Synchronize Viewports ( ):

• On the ribbon, choose Express Tools > Synchronize Viewports (in Layout).

• On the menu, choose Express Tools > Layout > Synchronize Viewports. 

• Type vpsync and then press Enter.

2 Select the master layout viewport that has the desired zoom factor.

3 Select one or more viewports to align with the master viewport, then press Enter.
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Modifying layout viewports
After you create layout viewports, you can modify them as needed. On the Layout 
tab, you can snap to the viewport borders using entity snaps. You can copy, delete, 
move, scale, and stretch layout viewports as you would any other drawing entity. 

Additionally, you can lock a layout viewport so the viewport scale and view center do 
not change in model space while panning or zooming in the layout viewport. If you 
are working on model space entities from a Layout tab, locking the layout viewport 
prevents you from constantly changing the layout viewport scale and view center.

And assigning a UCS to each viewport allows you to quickly switch between layout 
viewports and immediately draw in a different UCS. This can greatly increase pro-
ductivity, especially when creating complex 3D models.

Modifying a layout viewport on a Layout tab does not affect the model space entities 
within the layout viewport.

To modify layout viewport properties 

1 Click the desired Layout tab.

2 Do one of the following to choose Properties ( ):

• On the ribbon, choose View > Properties (in Panes).

• On the menu, choose View > Display > Properties or Modify > Properties.    

• On the Modify toolbar, click the Properties tool.

• Type entprop and then press Enter.

3 Select the edge of the layout viewport you want to modify.

4 Adjust the center point, width, or height of the viewport.

5 In Custom Scale, enter the scale at which you want to view model space entities 
from within the layout viewport.

6 In Display Locked, choose True to lock the viewport scale and view in model 
space while panning or zooming in the layout viewport.

7 Mark UCS per Viewport if you want to use a unique UCS for each layout view-
port.

8 Click OK.

You can select only layout viewports for modification.  
If you click a viewport on the Model tab, it makes that viewport active, not available 
for modification.

Clipping layout viewports
You can clip layout viewports so that only a portion of the viewport is visible on a 
Layout tab. You can clip layout viewports in the shape of a new polygon or an exist-
ing circle, ellipse, closed spline, closed polyline, or region.
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If you delete clipping from a layout viewport, the clipping is removed permanently 
but the viewport itself and its contents remain in the drawing.

To clip a layout viewport in the shape of an existing entity 

1 Click a Layout tab, and select the desired layout viewport.

2 Type vpclip and then press Enter.

3 In the drawing, select an existing circle, ellipse, closed spline, closed polyline, or 
region to use as a clipping boundary.

To clip a layout viewport in the shape of a new polygon
1 Click a Layout tab, and select the desired layout viewport.

2 Type vpclip and then press Enter.

3 Press Enter to create a new clipping boundary.

4 Define the first point of the clipping polygon.

5 Define additional points.

6 Press Enter when done.

To delete a clipping boundary
1 Click a Layout tab, and select the desired layout viewport.

2 Type vpclip and then press Enter.

3 Choose Delete, and then press Enter.

Customizing and reusing print settings

Most drawings require adjustments to print settings in order to print the way you 
want. You can make adjustments to the print settings each time you print, but you can 
also create page setups, which save the print settings and assign them to different lay-
outs in your drawing. If you have several perspectives of your drawing that require 
printing, using page setups is the most efficient way to print.
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Working with page setups
Page setups store printer information for specific models or layouts, which eliminates 
the need to completely reconfigure your print settings each time you print a drawing 
and helps ensure that each perspective of a drawing prints as planned. 

Assigning a page setup to a model or layout
Because the main model on the Model tab and the various layouts for printing on the 
Layout tabs all may require unique print settings, the model and each layout can be 
assigned a separate page setup. If some layouts use the same print settings, those 
layouts can be assigned the same page setup.

Assigning a page setup to a model or layout doesn’t mean it will always print with the 
specified settings. All of the print settings specified for a page setup can be overrid-
den at print time.

To assign a page setup to a model or layout
1 Click the Model tab or Layout tab that you want to assign a page setup.

2 Do one of the following to choose Page Setup Manager ( ):

• On the ribbon, choose the Application button then choose Page Setup Manager, 
or choose Output > Page Setup Manager (in Print).

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool.

• Type pagesetup and then press Enter.

3 Select the desired page setup.

4 Click Set Current.

5 Click OK.

You can also choose a page setup at print time.
In the Print dialog box, select a different page setup from the Page Setup list before 
you click Print.
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Creating a page setup
There are two types of page setups: 

• Model page setup — Contains print settings available for the model on the Model 
tab.

• Layout page setup — Contains print settings available for one or more layouts on 
the Layout tabs.

IntelliCAD comes with two default page setups — one model page setup and one lay-
out page setup. You can create as many additional page setups, of either type, as 
required for any drawing. Each page setup specifies many aspects of printing, includ-
ing page size, default printer or plotter, page orientation, print scale, and more. 

A Displays the name of the model or layout to which 
the current page setup is assigned. 

B Displays a list of all model page setups or layout 
page setups, depending on whether you were 
viewing the Model tab or a Layout tab before 
opening the dialog box.

C Displays details about the currently selected page 
setup.

D Click to delete the currently selected page setup.
E Click to import a page setup from a different 

drawing.
F Click to modify the settings for the currently 

selected page setup.
G Click to create a new page setup.
H Click to assign the currently selected page setup to 

the current layout.

A

B

C

G
F
E
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D
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To create a page setup
1 To create a model page setup, click the Model tab. To create a layout page setup, 

click any Layout tab.

2 Do one of the following to choose Page Setup Manager ( ):

• On the ribbon, choose the Application button then choose Page Setup Manager, 
or choose Output > Page Setup Manager (in Print).

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool.

• Type pagesetup and then press Enter.

3 Click Add.

You can create a new page setup based on the print settings of an existing page setup.
Select an existing page setup in the list, then click Add. The new page setup uses 
the print settings of the existing page setup as a starting point.

4 Enter a name for the page setup, then click OK.

5 Select the desired print options. 

6 Click OK.
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A Displays “Layout” if creating a layout page setup or  
“Model” if creating a model page setup.

B Enter any changes to page setup name.
C Click to specify options for the selected printer or 

printer configuration (.pc3) file.
D Select the printer or printer configuration file and 

view its details.
E Select a paper size supported by the selected 

printer.
F Select a predefined print scale, or choose Custom 

to specify your own.
G Select to fit the specified print area to the current 

paper size.
H Specify the custom scale for the print area by typing 

the ratio of drawing units to printed inches or printed 
millimeters.

I Click to specify drawing units and paper size in 
millimeters or inches.

J Select to center the print area on the printed page.
K Type x- and y-coordinates to specify the origin of 

the print area.
L Click to select the area of the drawing that you want 

to print.

M Type the x- and y-coordinates of the two opposing 
corners of the rectangular area to print, or click 
Select Print Area to specify coordinates in the 
drawing window. (Available only if Window is 
selected for What to print.)

N Select to print the drawing upside down on your 
printer.

O Select portrait (vertical) or landscape (horizontal) 
orientation.

P Select whether to print lineweights and print styles.
Q Select to print entities with their assigned 

transparency.
R Select to prevent paperspace entities from printing.
S Select to print paperspace entities after printing 

modelspace entities.
T Select to show print styles when viewing the layout.
U Select to print entities with their assigned 

lineweights. If you turn off lineweight printing, 
entities print with a default outline. 

V Select options for shaded viewports. Quality and 
DPI are not currently implemented.

W Select a print style table to apply during printing, or 
select None. Click [...] to modify the selected print 
style table.
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Modifying an existing page setup
You can change any of the print settings associated with a page setup, which elimi-
nates the need to override the settings when it comes time to print the model or each 
layout that is assigned the page setup. 

If you change the settings for a layout print setup, all layouts assigned that print setup 
will print using the new settings.

To modify an existing page setup
1 To modify a model page setup, click the Model tab. To modify a layout page 

setup, click any Layout tab.

2 Do one of the following to choose Page Setup Manager ( ):

• On the ribbon, choose the Application button then choose Page Setup Manager, 
or choose Output > Page Setup Manager (in Print).

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool.

• Type pagesetup and then press Enter.

3 Select the page setup you want to change.

4 Click Modify.

5 Select the desired print options. 

6 Click OK.

Importing page setups from a different drawing
If you have a different drawing file that contains one or more page setups defined 
with the print settings you need for your current drawing, you can import the page 
setups from the other file instead of re-creating them in the current drawing.

To import a page setup from a different drawing
1 Do one of the following to choose Page Setup Manager ( ):

• On the ribbon, choose the Application button then choose Page Setup Manager, 
or choose Output > Page Setup Manager (in Print).

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool.

• Type pagesetup and then press Enter.

2 Click Import.
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Use a shortcut.
Type psetupin.

3 Select the drawing that contains the page setups you want to import, then click 
Open.

4 Select the model and layout page setups to import.

5 Click OK.

All page setups from the specified drawing file are imported, even though they might 
not all display in Page Setup Manager. Imported model page setups display if you’re 
working on a Model tab, and layout page setups display if you’re working on a Lay-
out tab.

Deleting a page setup
If you delete a page setup that is assigned to the model or a layout, that model or lay-
out will no longer be assigned a page setup.

To delete a page setup 
1 To delete a model page setup, click the Model tab. To delete a layout page setup, 

click any Layout tab.

2 Do one of the following to choose Page Setup Manager ( ):

• On the ribbon, choose the Application button then choose Page Setup Manager, 
or choose Output > Page Setup Manager (in Print).

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool.

• Type pagesetup and then press Enter.

3 Select the page setup you want to delete.

4 Click Delete.

5 Click Yes to confirm the deletion.
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Setting the paper size and orientation
You can specify a paper size and paper orientation for all drawings. You can also 
adjust the orientation by printing a drawing upside down on the paper. Each layout in 
your drawing can specify whether to print upside down.      

To select the paper size and orientation   
1 Click the Layout tab or Model tab for which you want to set paper size and orien-

tation.

2 Do one of the following to choose Page Setup Manager ( ):

• On the ribbon, choose the Application button then choose Page Setup Manager, 
or choose Output > Page Setup Manager (in Print).

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool.

• Type pagesetup and then press Enter.

3 Select the desired page setup, then click Modify.

4 In Paper size, select a paper size supported by the currently selected printer.

5 In Orientation, select the following settings:

• Portrait or Landscape — Select Portrait for vertical paper orientation or 
Landscape for horizontal paper orientation.

• Print upside down — Select to print the drawing upside down on your printer.

6 Click OK.

7 Click OK.
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Selecting a printer or plotter
You can specify a printer or plotter to be used when printing any drawing. You can 
print your drawing on any printer or plotter that is compatible with Windows, includ-
ing raster printers. 

Instead of a physical printer, you can choose to print directly to a file, including .pdf, 
dwf, .png, and .jpg. Printing to a file is not the same as exporting. If you need to 
export a drawing to one of the various file formats available, see “Exporting draw-
ings” on page 799. 

To select a printer or plotter               
1 Click the Layout tab or Model tab for which you want to select a printer.

2 Do one of the following to choose Page Setup Manager ( ):

• On the ribbon, choose the Application button then choose Page Setup Manager, 
or choose Output > Page Setup Manager (in Print).

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool.

• Type pagesetup and then press Enter.

3 Select the desired page setup, then click Modify.

4 From the Printer Name list, select a printer or plotter.

5 If desired, click Properties to choose options for the currently selected printer.

6 Click OK.

7 Click OK.

The printer or plotter you select for a page setup is also used when you publish sheet 
lists. For details, see “Publishing a sheet list to the printer named in page setup” on 
page 677 in this chapter. 

Setting the scale and view
You can print or plot the entire drawing or a selected portion of a drawing. You can 
choose to print what is visible on the screen, or you can specify to print an area of the 
drawing.

You can control the position of the drawing on the paper by specifying the origin of 
the print area, the location of the lower left corner of the print area, in relation to the 
lower left corner of the paper. The origin is normally set to 0,0, which places the 
lower left corner of the print area as close to the lower left corner of the paper as the 
printer or plotter will allow. You can specify a different origin, however, by 
specifying different coordinates.

When you create a drawing, you generally draw entities full-size. When you print the 
drawing, you can specify the scale of the resulting print or let the program adjust the 
size of the drawing to fit the paper. To print the drawing at a specific scale, specify 
the scale as a ratio of drawing units to printed units.
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If you are printing from a Layout tab, the scale and view options you specify can be 
different for each layout that you create.

To automatically scale the drawing for printing
1 Click the Layout tab or Model tab for which you want to set to scale automati-

cally.

2 Do one of the following to choose Page Setup Manager ( ):

• On the ribbon, choose the Application button then choose Page Setup Manager, 
or choose Output > Page Setup Manager (in Print).

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool.

• Type pagesetup and then press Enter.

3 Select the desired page setup, then click Modify.

4 In Print Scale, select Fit to Paper to scale the drawing to fit on one printed page.

5 Click OK.

6 Click OK.

To specify the scale factor yourself
1 Click the Layout tab or Model tab for which you want to specify the scale factor.

2 Do one of the following to choose Page Setup Manager ( ):

• On the ribbon, choose the Application button then choose Page Setup Manager, 
or choose Output > Page Setup Manager (in Print).

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool.

• Type pagesetup and then press Enter.

3 Select the desired page setup, then click Modify.

4 In Print Scale, do one of the following:

• Select a pre-defined scale in the Scale list. For example, choose 1:2 if you want 
1 printed unit (inch or millimeter) to equal 2 drawing units. The list of available 
scales is set up using the Scales List command. For more details, see “Custom-
izing the scales list” on page 64. 

• Type the ratio of printed units of measure (inches or millimeters) to drawing 
units.

5 To specify the printed units of measure, choose Inches or Millimeters.

6 Click OK.

7 Click OK.
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To specify a portion of the drawing to print 
1 Click the Layout tab or Model tab for which you want to specify the area to print.

2 Do one of the following to choose Page Setup Manager ( ):

• On the ribbon, choose the Application button then choose Page Setup Manager, 
or choose Output > Page Setup Manager (in Print).

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool.

• Type pagesetup and then press Enter.

3 Select the desired page setup, then click Modify.

4 In What to Print, click one of the following:

• Display — Prints the view on the screen.

• Extents — Prints the area that contains entities in the drawing.

• Limits — Prints to the limits defined for the  drawing. (Available for model page 
setups only.)

• Layout — Prints to the edge of the layout. (Available for layout page setups 
only.)

• View — Prints the selected saved view. (Available for drawings that have saved 
views.)

• Window — Prints the portion of the drawing contained in the specified window, 
maintaining the aspect ratio of the windowed area to the drawing.

If you clicked Window, you must specify the window. Under Windowed Print 
Area, enter the diagonal x- and y-coordinates of the window, or select the area on 
the screen. 

5 Click OK.

6 Click OK.
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To specify the print area origin
1 Click the Layout tab or Model tab for which you want to setting paper size and ori-

entation.

2 Do one of the following to choose Page Setup Manager ( ):

• On the ribbon, choose the Application button then choose Page Setup Manager, 
or choose Output > Page Setup Manager (in Print).

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool.

• Type pagesetup and then press Enter.

3 Select the desired page setup, then click Modify.

4 Under Print Offset, do one of the following:

• To center the specified print area on the printed page, select Center on Page.

• To specify an origin for the print area, type the x- and y-coordinates.

5 Click OK.

6 Click OK.

Specifying print options specifically for layouts
Each layout in your drawing can specify certain print settings that apply only to lay-
outs: lineweight scaling, print style display, and paperspace print options.

To set print options for only layouts 
1 Click a Layout tab.

2 Do one of the following to choose Page Setup Manager ( ):

• On the ribbon, choose the Application button then choose Page Setup Manager, 
or choose Output > Page Setup Manager (in Print).

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool.

• Type pagesetup and then press Enter.

3 Select the desired page setup, then click Modify.

4 In the Model/Layout Tab Options area, choose the desired print settings:

• Scale lineweights — Select to print lineweights in proportion to the specified 
Print Scale settings; if not selected, lineweights print at their assigned size.   
Note that print styles can also affect how lineweights print.

• Display print styles — Select to show print styles when viewing the layout.
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• Print paperspace last — Select to print paperspace entities after printing model-
space entities. By default, paperspace entities print first.

• Hide paperspace entities —  Select to prevent paperspace entities from printing.

5 Click OK.

6 Click OK.

Specifying shaded viewport print options
Each model page setup can specify how to print shaded viewports: as displayed, wire-
frame, hidden, or rendered. Note that Quality and DPI are not currently implemented.

To set print options for shaded viewports 
1 Click the Layout tab or Model tab for which you want to set shaded viewport set-

tings.

2 Do one of the following to choose Page Setup Manager ( ):

• On the ribbon, choose the Application button then choose Page Setup Manager, 
or choose Output > Page Setup Manager (in Print).

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool.

• Type pagesetup and then press Enter.

3 Select the desired page setup, then click Modify.

4 In the Shaded Viewport Options area, choose the desired settings:

• Shade — Select how to print shaded viewports

• Quality — Select the resolution to use for the printed viewport. (Not currently 
implemented.)

• DPI — Enter the custom dots per inch to use for printing the viewport shading. 
Available only if Quality is set to Custom. (Not currently implemented.)

5 Click OK.

6 Click OK.
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Specifying pen and line printing options
Each layout in your drawing can specify certain print settings that apply only to lay-
outs: lineweight scaling, print style display, and paperspace print options.

To set pen and line printing options 
1 Click the Layout tab or Model tab for which you want to set pen and line printing 

options.

2 Do one of the following to choose Page Setup Manager ( ):

• On the ribbon, choose the Application button then choose Page Setup Manager, 
or choose Output > Page Setup Manager (in Print).

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool.

• Type pagesetup and then press Enter.

3 Select the desired page setup, then click Modify.

4 Choose the desired settings:

• Print style table — Select a print style table to apply during printing, or select 
None. If you select a print style table, you can click [...] to modify its settings.

• Print transparency — Select to print entities with their assigned transparency. 
Note that turning on this option can slow printing. Also note that the 
PLOTTRANSPARENCYOVERRIDE system variable can override trans-
parency print settings for all layout viewports at once.

A print style table and print transparency cannot be used at the same time.

• Print entity lineweights — Select to print entities with their assigned 
lineweights. If you turn off lineweight printing, entities print with a default 
outline.

• Print with print styles — Select to print according to the print style settings in 
the currently selected print style table.

5 Click OK.

6 Click OK.
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Using printer configuration files
Printer configuration files store the printer information you use for specific drawings 
or layouts, which eliminates the need to completely reconfigure your print settings 
each time you print a drawing. Printer configuration files also allow you to share and 
reuse print settings between different drawings and layouts.

IntelliCAD supports the printer configuration files (PCP and PC3 files) used by Auto-
CAD. This feature makes it possible to use existing PCP files saved in AutoCAD, as 
well as to save your IntelliCAD print configuration settings to the PC3 format.

You can convert an AutoCAD PC2 or PCP file using the AutoCAD PCINWIZARD 
command.

Selecting a printer configuration file for printing
You can specify that a printer configuration file be used when printing any drawing. 

To select a printer configuration file for printing
1 Click the Layout tab or Model tab for which you want to print.

2 Do one of the following to choose Print ( ):

• On the ribbon, choose the Application button then choose Print, or choose 
Output > Print (in Print).

• Choose File > Print.

• On the Standard toolbar, click the Print tool.

• Type print and then press Enter.

3 From the Printer Name list, select a .pc3 or .pcp file.

4 Click OK to print.

Modifying and saving printer settings in a .pc3 file
Each .pc3 file stores the following printer settings, depending on the destination 
printer or file:

• Standard paper sizes and margins

• Graphics settings for vectors, rasters, and text

• Custom properties for colors, scaling, layers, fonts, and more

Paper sizes and margin settings are customizable and saved in .pmp files, not .pc3 files.
When you customize paper sizes and margins, a .pmp file is saved and attached to the 
.pc3 file automatically. You can also attach an existing .pmp file. For more details, 
see “Working with paper sizes and .pmp files” on page 645. 
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To modify and save printer settings in a .pc3 file
1 Do one of the following to choose Print ( ):

• On the ribbon, choose the Application button then choose Print, or choose 
Output > Print (in Print).

• Choose File > Print.

• On the Standard toolbar, click the Print tool.

• Type print and then press Enter.

2 From the Printer Name list, select a .pc3 file.

3 Click Properties.

4 In the Printer Configuration Editor dialog box, click the Settings tab.

5 Expand Media in the list to view and select the default paper size for the printer. 
Select Source and Size, then in Media Source and Size, select a new default paper 
size for the printer configuration.

6 Expand Graphics in the list and choose from the following options: 

• Vector Graphics — Displays settings for printing vector graphics. In Color 
Depth, select whether to use color or monochrome output and then the color or 
grayscale bit depth.

• Raster Graphics — Displays settings for printing raster graphics. When printer 
resources are limited, you can move the sliders to balance printing speed and 
image quality for raster images, OLE objects, and general trade-offs.

• TrueType Text — Select whether to print text that is assigned TrueType fonts as 
text (faster but may print with a different font) or graphics (slower but ensures 
text is printed as displayed).

• Merge Control — To retain the colors of lines that overlap, choose Lines 
Overwrite. The visible color is of the line that was most recently added to the 
drawing. To merge colors together, choose Lines Merge.



P R I N T I N G  D R A W I N G S 645
7 Select Custom Properties in the list to specify additional settings for printing, 
which vary according to the selected printer:

• Standard printers and drivers — The standard dialog box opens for your 
printer.

• DWF .pc3 files — The Custom Properties dialog box opens. Click [?] for more 
details about each available option.

• PDF .pc3 files — The Custom Properties dialog box opens. Click [?] for more 
details about each available option.

• JPG and PNG .pc3 files — In Custom Properties, select the background color 
and mark whether to rotate raster scan lines by 90 degrees.

8 Click Save As.

9 Specify a name and location for the .pc3 file, which can be new or the existing 
.pc3 file, then click Save. 

10 Click OK.

11 Click OK to print, or click Cancel.

You can also modify and save printer configuration files using the Options command.
Choose Options, click the Printing tab, click Add or Configure Printers, then make 
your selections. For more details, see “Setting up printer configuration files” on 
page 859. 

Working with paper sizes and .pmp files
Each .pc3 file stores a list of standard paper sizes and margins, which determine the 
printable area. If your print jobs often require different settings, you can create your 
own paper sizes with margins.

User-defined paper sizes and margins are stored in a PMP (Plotter Model Parameter) 
format file. You can attach a .pmp file to any .pc3 file, allowing you to reuse the 
paper size definitions that you create for multiple .pc3 files and on multiple comput-
ers. Each .pmp file includes the following:

• Modifications you make to standard paper sizes

• Custom paper sizes

• Calibration settings, if your .pmp file was created with another CAD program
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To modify the margins of a standard paper size
1 Do one of the following to choose Print ( ):

• On the ribbon, choose the Application button then choose Print, or choose 
Output > Print (in Print).

• Choose File > Print.

• On the Standard toolbar, click the Print tool.

• Type print and then press Enter.

2 From the Printer Name list, select a .pc3 file.

3 Click Properties.

4 In the Printer Configuration Editor dialog box, click the Settings tab.

5 Expand User-defined Paper Sizes in the list, then choose Standard Paper Sizes 
(Printable Area).

A list displays the standard paper sizes defined for the .pc3 file.

6 Select the standard paper size you want to modify with new margins.

7 Click Edit.

8 Enter new values for the top, bottom, left, and right margins, which determine the 
printable area of the paper, then click Next.

9 Enter a name for the .pmp file where the custom settings will be saved, then click 
Next.

If a .pmp file is already attached to the .pc3 file in the Printer Configuration Editor 
dialog box, you are not prompted for a .pmp file name; the modified settings are 
stored automatically in the attached .pmp file.

10 Click Finish.

If a .pmp file was not previously attached to the .pc3 file, a .pmp file is created and 
attached automatically.

To create a custom paper size
1 In the Printer Configuration Editor dialog box, click the Settings tab.

2 Expand User-defined Paper Sizes in the list, then choose Custom Paper Sizes.

3 Click Add.

4 Choose whether to create an entirely new paper size or to start with an existing 
paper size that you select, then click Next.

5 Enter the width and height of the paper, in millimeters or inches, then click Next.

6 Enter values for the top, bottom, left, and right margins, which determines the 
printable area of the paper, then click Next.

7 Enter a name for the paper size that will display in the list of custom paper sizes, 
then click Next.
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8 Enter a .pmp file name where the paper size is to be saved, then click Next.

If a .pmp file is already attached to the .pc3 file in the Printer Configuration Editor 
dialog box, you are not prompted for a .pmp file name; the new paper size is stored 
automatically in the attached .pmp file.

9 Click Finish.

If a .pmp file was not previously attached to the .pc3 file, a .pmp file is created and 
attached automatically.

You can modify and delete custom paper sizes.
To modify a custom paper size, select it in the Manage Custom Paper Sizes list, then 
click Edit and follow the prompts. To delete a custom paper size, select it in the list 
and click Delete.

To attach a .pmp file to a .pc3 file
1 In the Printer Configuration Editor dialog box, click the Settings tab.

2 Expand User-defined Paper Sizes in the list, then choose PMP File Name.

3 Click Attach PMP.

4 Select a .pmp file.

5 Click Open.

The name and path of the attached .pmp file displays for the PMP File Name in the 
list.

To save and attach user-defined paper sizes in a new .pmp file
1 In the Printer Configuration Editor dialog box, click the Settings tab.

2 Expand User-defined Paper Sizes in the list, then choose PMP File Name.

3 Click Save PMP.

4 Specify a name for the .pmp file.

5 Click Save.

The new .pmp file is automatically attached to the .pc3 file.

To detach a .pmp file from a .pc3 file 
1 In the Printer Configuration Editor dialog box, click the Settings tab.

2 Expand User-defined Paper Sizes in the list, then choose PMP File Name.

3 Click Detach PMP.

Modifications to standard paper sizes and all custom paper sizes are removed from 
the Printer Configuration Editor dialog box.
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Using plotter drivers
To print your drawing, the program sends the output to any printer driver in up to 256 
colors, but with no width specified. Initially, the printed output will have a uniform 
fine width that is the finest line that the plotter device can produce.

The driver then passes colored vectors to the printer, which creates color output on 
color printers and grayscale output on laser printers. (Color output that converts to 
grayscale on a laser printer usually is unacceptable by CAD users for final printing.)

With print style tables, you can map all colors to black and set all lineweights to a 
width you choose. You must use a value appropriate to your printing capabilities. 
With these features, you can meet most non-presentation print needs.

Using print styles

IntelliCAD uses print styles to change the appearance of your printed drawing with-
out modifying the actual entities in your drawing. Assigning print styles allows you to 
customize the color, pen width, linetype, and lineweight that are used to print your 
drawing.  

Print styles help you control what your drawing looks like when it is printed. Rather 
than describe what an entity looks like on your screen, print styles describe what an 
entity will look like when you print it. For example, you can map all yellow entities in 
your drawing to print in blue without modifying the actual entities. You could also 
map all yellow entities to print with whatever lineweight, linetype, or pen width that 
you specify.

Because print styles are saved in print style tables, which are files located on your 
computer, disk, or server, you can reuse them to help eliminate the need to reconfig-
ure your print settings each time you print a drawing. For example, you may have 
multiple clients who have their own printing preferences. You can save print styles in 
a named file for each of your clients. You can even share the file with co-workers, or 
store the files on a network to ensure that everyone in your office uses the same stan-
dards.
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Understanding print style tables
A print style table is a collection of print styles that allows you to change the appear-
ance of your printed drawing without modifying the actual entities in your drawing. 
Each print style table is saved in a file that can be located on your computer, disk, or 
server.  

A drawing can use one type of print style table at a time. There are two types of print 
style tables:

• Color-dependent print style tables (CTB) contain a collection of print styles based on 
each of the 255 index colors available in a drawing. True colors and color books 
are not applicable to color-dependent print style tables. 

• Named print style tables (STB) contain a collection of print styles that you define. 
They can vary regardless of color. 

With color-dependent print style tables, you cannot assign print styles to individual 
entities or layers. To use these print styles, you assign a specific color to an entity or 
layer. When you specify a color-dependent print style table at printing time, the entity 
colors and layer colors map to color-based print styles in the print style table that you 
specify.

With named print style tables, you can assign named print styles to individual entities 
and layers. Entities and layers assigned print styles are printed according to the print 
style table that you specify at printing time. If you specify a print style for a specific 
entity, that print style overrides any print style assigned to the layer on which the 
entity resides. 

Sometimes a named print style assigned to an entity or layer is not located in the print 
style table that is assigned to a layout or drawing. This can happen if the print style 
has been deleted from the named print style table or if you assign a different named 
print style table to the drawing that does not contain the named print style. In this 
case, the entity is printed using its default properties, which is similar to assigning the 
Normal print style to an entity or layer. If you plan on interchanging named print style 
tables within the same drawing, it’s a good idea to coordinate the tables to use the 
same print style names.
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If a new drawing is based on a template, the new drawing uses the same type of print 
style table as the template. If a new drawing is created without a template, the type of 
print style table is specified in the New Drawing Wizard; by default, the new drawing 
uses the print style table type specified in Tools > Options on the Printing tab. Every 
drawing is designed to use print style tables, but you decide whether to implement 
them.  

Implementing print style tables
Every drawing is designed to use print style tables, but you decide whether to imple-
ment them. Even if you use one of the default print style tables available with Intelli-
CAD, using print style tables requires planning ahead of time to ensure that your 
drawing prints as planned.

Comparison of print style table types
Color-dependent print 
style table (CTB) Named print style table (STB)

Description Contains pre-defined print styles 
according to color; there is one print style 
for each of the 255 index colors available 
in the drawing. Entities with the same 
color are printed the same way. 

Contains unique print styles that you 
create. Entities with the same color can 
have different print settings. 

Example All blue entities print with a .5 millimeter 
lineweight.

One entity prints with a .7 millimeter 
lineweight; a second blue prints with a .5 
millimeter lineweight.

Number of 
print styles

255 (fixed). At least one (varies).

Print style 
names

Print style names range from “Color_1” 
to “Color_255”. You cannot rename print 
styles. 

You define new print style names. You 
can rename all print styles except the 
Normal print style.

Add, delete, 
and modify 
print styles

You can modify the existing print styles, 
but you cannot add or delete print styles.

You can add and delete print styles. You 
can modify all print styles except the 
Normal print style, which uses the 
default characteristics of the entity.

Create 
additional 
tables

Yes. Yes.

Assignment Current print style: New entities always 
assigned BYCOLOR.

Print styles: Assigned to colors in the 
print style table.

Print style tables: Assigned to a Layout 
tab or the Model tab.

Current print style: Assigned to new 
entities.

Print styles: Assigned to entities and 
layers.

Print style tables: Assigned to a Layout 
tab or the Model tab.

Legacy file 
support

You can import existing printer 
configuration files (PCP) files into the 
print style table. CTB files are similar to 
PCP files primarily used in previous 
versions of IntelliCAD. 

Not applicable.
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For example, a single drawing of a floor plan might require the printing of the follow-
ing drawing sheets:

• Main Floor Plan Walls print with thick, black lines.

• Electrical Plan Walls print with normal gray lines, indicating that they are not the 
focus.

• HVAC Plan Walls print with normal gray lines, indicating that they are not the 
focus.

• Roof Plan Walls print with thin, gray lines and a hidden linetype, indicating that 
they are hidden under the roof in a plan view.

In this example, you can create four named print style tables, each containing a print 
style named “WallPstyle”. Each print style table contains its own settings for 
“WallPstyle” to control how the walls print. Assign WallPstyle to either the wall enti-
ties or to a wall layer. Then, assign a different named print style table each time you 
print, or create four layouts and assign a different print style table to each layout.

The following table describes, in order, the steps to get you started using both color-
dependent and named print style tables.

Getting started using print style tables
Color-
dependent Named Task Command Where to get details

X X Create a new drawing. Select a drawing 
template that uses the desired print style 
table type or choose it in the New Drawing 
Wizard.

File > New Creating a new drawing, page 46

X X (Optional) Create a new print style table. File > Print Styles Manager Creating new print style tables, 
page 653

X Assign colors to entities and layers that 
correspond with print style table settings.

Modify > Properties
Tools > Explorer

Setting the current entity color, 
page 52; Modifying the properties 
of entities, page 406; Setting the 
layer color, page 294

X Set the current print style assigned to new 
entities.

Tools > Drawing Settings > 
Entity Creation tab; status 
bar; printstyle

Setting the current print style, 
page 57

X Assign print styles to entities. Modify > Properties; Entity 
Properties toolbar; printstyle

Modifying the properties of 
entities, page 406

X Use the Explorer to assign print styles to 
layers.  

Tools > Explorer Setting the layer print style, page 
299

X X Assign a print style table to the Model tab, 
a layout, or to all layouts in the drawing.

File > Print > Advanced tab Assigning print style tables, page 
652

X X (Optional) Make changes to the assigned 
print style table.

File > Print Styles Manager
File > Print > Advanced tab

Modifying print style tables, page 
654

X X Print the drawing. File > Print Printing or plotting your drawing, 
page 660
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The following table describes how to further customize how print styles work within 
your drawings.

Assigning print style tables
Select a print style table before printing if you want to change how your drawing 
appears when you print it. Print style tables can modify how colors, pen widths, line-
types, and lineweights look when they are printed.

You can assign print style tables globally for all layouts (including the Model tab), or 
individually for the Model tab or a Layout tab. Assigning a print style table to an indi-
vidual layout allows you to further customize the layouts you use to print a drawing. 

However, assigning different named print style tables to various layouts may result in 
mismatched print style names; a named print style assigned to an entity or layer may 
not be located in the assigned print style table at print time. In this case, entities are 
printed using their default properties, which is similar to assigning the Normal print 
style to an entity or layer.

To assign a print style table at the same time you print
1 If necessary, click the desired Layout tab, or click the Model tab.

2 Do one of the following to choose Print ( ):

• On the ribbon, choose the Application button then choose Print, or choose 
Output > Print (in Print).

• On the menu, choose File > Print.

• Type print and then press Enter.

Further customizing print style tables
Task Command Where to get details
Copy, rename, or delete print style 
tables.

File > Print Styles Manager Copying, renaming, or 
deleting print style tables, 
page 657

Change a drawing to use another type 
of print style table, for example, change 
a drawing that uses color-dependent 
print style tables to one that uses 
named print style tables. 

convertpstyles Changing the print style 
table type of a drawing, 
page 657

Convert a color-dependent print style 
table to a named print style table.

convertctb Converting print style 
tables, page 658

Change the default location where print 
style tables are stored.

Tools > Options > Paths/Files 
tab

Changing the options on 
the Paths/Files tab, page 
829

Customize how print styles work with 
new drawings that you create and older 
drawings that you open.

Tools > Options > Printing tab Changing the options on 
the Printing tab, page 855
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You can assign a print style table to a page setup.
Use the Page Setup Manager to assign a print style table to a page setup that you 
use for printing. For more details, see Specifying pen and line printing options.

3 Under Print Style Table (Pen Assignments), select a print style table that you cre-
ated or one of the following:

• None — Applies no print style table. Entities print according to their own 
properties.

• Icad — Uses the default print style table and its color assignments.

• Monochrome — Prints all colors as black.  

4 Select Save Changes to Layout, and then click OK.

When a drawing is first created it is assigned to use either color-dependent or named print 
style tables. 
For details on converting a drawing to use a different type of print style table, see 
“Understanding print style tables” on page 649 in this chapter. 

Creating new print style tables
IntelliCAD offers several print style tables to help you get started. If you want to cus-
tomize your print output further, you can create your own print style table. You can 
create a new print style table entirely from scratch, based on IntelliCAD registry set-
tings, or by importing a printer configuration file (PCP file).         

To create new print style tables
1 Do one of the following to choose Print Styles Manager ( ):

• On the ribbon, choose the Application button then choose Print > Print Styles 
Manager, or choose Output > Print Styles Manager (in Print).

• On the menu, choose File > Print Styles Manager or choose Format > Print 
Styles Manager.

• On the Format toolbar, click the Print Styles Manager tool.

• Type stylesmanager and then press Enter.

2 Click Add.

3 Complete the setup wizard. 

On the last wizard page, you can click Print Style Table Editor to set up the print 
styles for the table. For more details about the Print Style Table Editor options, see 
the next section.
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Modifying print style tables
When your drawing was created, it was set up to use color-dependent or named print 
style tables:  

• Color-dependent print style tables (.ctb files) — You can modify individual print 
styles within the table, but you cannot add, rename, or delete print styles. Color-
dependent print style tables always have 255 print styles, each named for a spe-
cific color. Your changes affect all entities and layers assigned that color.  

• Named print style tables (.stb files) — You can add, modify, rename, and delete 
individual print styles within the table. However, you cannot modify, rename, or 
delete the Normal print style. Your changes affect all entities and layers that are 
assigned that print style name.  

Use a system variable to determine the type of print style table your drawing uses.
If you can’t remember what type of print style table is assigned to your drawing, use 
the PSTYLEMODE system variable to determine the print style table type.

Each print style within a print style table specifies a color, pen numbers, linetype, and 
lineweight. IntelliCAD recognizes additional characteristics for compatibility with 
AutoCAD only, including: dither, grayscale, screening, adaptive, line end style, line 
join style, and fill style.        

When specifying print style characteristics, be sure to consider the limitations of your 
output device.

A Displays the location where print style tables are 
located. 

B Displays a list of all print style tables available in the 
named folder.

C Click to delete the currently selected print style 
table.

D Click to modify the settings for the currently 
selected print style table.

E Click to create a new print style table.

A

B

E

D

C
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It is recommended that you only modify print style tables that you have created.  
If you modify a default print style table that came with IntelliCAD, you overwrite the 
original information which is then lost.

To modify print style tables
1 Do one of the following to choose Print Styles Manager ( ):

• On the ribbon, choose the Application button then choose Print > Print Styles 
Manager, or choose Output > Print Styles Manager (in Print).

• On the menu, choose File > Print Styles Manager or choose Format > Print 
Styles Manager.

• On the Format toolbar, click the Print Styles Manager tool.

• Type stylesmanager and then press Enter.

2 Select the print style table you want to modify.

3 Click Modify.

4 Click the General tab, and then do any of the following:

• Enter a new table description.

• Select Apply Global Scale Factor to Non-ISO Linetypes to apply the scale factor 
to non-ISO linetypes used for any print style in the current print style table. This 
also applies to fill patterns, which are not used in IntelliCAD, but are recognized 
for compatibility with AutoCAD.

• Enter a scale factor to apply to non-ISO linetypes used for any print style in the 
current print style table.

5 Click the Form View tab, and then do any of the following:

• Make format changes to a print style by selecting it in the Print Styles list, then 
make color, pen map, linetype, or lineweight changes for the print style. Your 
changes are saved automatically for the selected print style.

• Add a new print style by clicking Add Style. Enter a new name, and then click 
OK. Select the options for the print style. (Available for named print styles 
only.)

• Rename a print style by selecting it in the Print Styles list. Single-click the print 
style again, and then enter a new name. (Available for named print styles only.)

• Delete a print style by selecting it in the Print Styles list. Click Delete Style. 
(Available for named print styles only.)
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6 Click OK.

A Select a print style to modify it. 
B Enter a description for the selected print style.
C Click to create a new print style. (Named print 

style tables only.)
D Click to delete the selected print style. (Named 

print style tables only.)
E Click to modify the list of available lineweights for 

the current print style table.
F Click to save the print style table with a new name 

or in a new location.
G Choose a fill style for the selected print style.
H Choose a line join style for the selected print 

style.
I Choose a line end style for the selected print 

style.
J Choose a lineweight for the selected print style.

K Choose whether to adjust the linetype scale 
automatically to complete the linetype pattern 
when necessary.

L Choose a linetype for the selected print style.
M Select the level of color intensity for the selected 

print style: 100 is full intensity, 0 is white. (Dither 
must be on.)

N Type or scroll to the width of the virtual pen for the 
selected print style (for printers that don’t have 
physical pens, such as laser or inkjet printers).

O Type or scroll to the width of the physical pen for 
the selected print style.

P Choose whether to print the selected print style in 
grayscale.

Q Choose whether to turn on dithering for the 
selected print style.

R Choose a color for the selected print style.

A

B

C
D E

F

K

M
N
O

R

G
H
I
J

L

P
Q
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Copying, renaming, or deleting print style tables
Copy, rename, or delete a print style table just as you would any other file on your 
computer. Regardless of which print style table type your drawing uses, you can use 
the Print Style Manager to manage both color-dependent and named print style tables.

To delete print style tables
1 Do one of the following to choose Print Styles Manager ( ):

• On the ribbon, choose the Application button then choose Print > Print Styles 
Manager, or choose Output > Print Styles Manager (in Print).

• On the menu, choose File > Print Styles Manager or choose Format > Print 
Styles Manager.

• On the Format toolbar, click the Print Styles Manager tool.

• Type stylesmanager and then press Enter.

2 Select a print style table, then click Delete.

Color-dependent print style tables are .ctb files and named print style tables are 
.stb files.

To copy, rename, or delete print style tables
1 On your computer, open the folder that stores print style tables, for example, 

\CompanyName\ProductVersion\Print Styles.

2 Copy, rename, or delete the print style table just as you would any other file on 
your computer.

Changing the print style table type of a drawing
When your drawing was created, it was set up to use color-dependent print style 
tables (.ctb files) or named print style tables (.stb files). A drawing can use one type 
of print style table at a time. If necessary, after a drawing is created you can convert 
the drawing to use the other type of print style table.     

If you can’t remember what type of print style table is assigned to your drawing, use 
the PSTYLEMODE system variable to determine the print style table type.

To change a drawing to use named print style tables
1 If you want to reuse any of the existing print style information, convert your color-

dependent print style tables to named print style tables. For details, see “To con-
vert a color-dependent print style table to a named print style table” on page 659 in 
this chapter. 

2 Open the drawing that uses color-dependent print style tables (.ctb files).

3 Type convertpstyles, and then press Enter.
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4 If you have already converted your individual color-dependent print style tables to 
named tables, click OK in the prompt that displays. 

If you have not converted the tables, click Cancel. First use convertctb to convert 
your color-dependent print style tables to named tables. If you do not, all of the 
print style information you specified in your drawing will be lost. 

5 Select a named print style table (.stb file) that you want to use with the drawing.

6 Click Open.

Errors will occur if you have not converted print style tables. 
If you have not converted a color-dependent print style table to a named print style 
table, you will be warned that the table you have selected does not contain color map-
ping and the drawing cannot be converted.

To change a drawing to use color-dependent print style tables
1 Open the drawing that uses named print style tables (.stb files).

2 Type convertpstyles, and then press Enter.

3 If you are sure you want to convert the drawing and lose all print style assign-
ments, click OK in the prompt that displays. 

If you do not want to lose the print style assignments, click Cancel.

Converting a drawing to use color-dependent print style tables will remove all of the 
named print style information from entities and layers. 
However, the named print style tables are not deleted from your computer.

Converting print style tables
You can convert a color-dependent print style table to a named print style table. You 
cannot convert a named print style table to a color-dependent print style table because 
color-dependent tables contain only print styles that are named after the 255 colors to 
which they map.        

Converting a color-dependent print style table to a named print style table can be 
helpful in the following situations:

• You don’t want to create a named print style table from scratch.

• You want to create a named print style table that has the same settings as a color-
dependent print style table, but with some new print styles or other custom set-
tings.

• You want to convert a drawing to use named print style tables and you want to 
reuse most of print styles already defined in a color-dependent print style table.
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To convert a color-dependent print style table to a named print style table
1 Type convertctb, and then press Enter.

2 Select the color-dependent print style table (.ctb file) that you want to convert.

3 Click Open.

4 Enter a name for the new named print style table (.stb file).

5 Click Save. 

The print styles in the new table are named Style 1, Style 2, and so on. If want to use 
different print style names, rename the print styles before you assign them to entities 
and layers in your drawing. If you rename the print styles after assigning them, they 
will not match when you print your drawing. For information about renaming print 
styles, see “Modifying print style tables” on page 654 in this chapter. 

Turning print style tables on or off
When you turn off print style tables, entities print according to their own properties. 
However, all of the print style information is saved so you can easily turn on print 
styles again. Actual print style table files are not deleted, and for drawings that use 
named print style tables, entities and layers retain their assigned print styles.  

To turn off print style tables
1 Click the Layout tab or Model tab for which you want to turn on or off print style 

tables.

2 Do one of the following to choose Page Setup Manager ( ):

• On the ribbon, choose the Application button then choose Page Setup Manager, 
or choose Output > Page Setup Manager (in Print).

• On the menu, choose File > Page Setup Manager. 

• On the Format toolbar, click the Page Setup Manager tool.

• Type pagesetup and then press Enter.

3 Select the desired page setup, then click Modify.

4 In Print style table, select a print style table to turn on print style tables, or select 
None to turn off print style tables. 

5 Click OK.

6 Click OK.
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Printing or plotting your drawing

After you have configured your drawing and any layouts for printing, you are ready 
to print. If desired, you can preview your page before printing.

Previewing a drawing before printing
Viewing a drawing before printing gives you a preview of what your drawing will 
look like when it is printed. This helps you see if there are any changes you want to 
make before actually printing the drawing.

If you are using print style tables, the preview shows how your drawing will print 
with the assigned print styles. For example, the preview may display different colors 
or lineweights than those used in the drawing because of assigned print styles.

To preview a drawing before printing          
1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following to choose Print Preview ( ):

• On the ribbon, choose the Application button then choose Print > Print Preview, 
or choose Output > Print Preview (in Print).

• On the menu, choose File > Print Preview.

• On the Standard toolbar, click the Print Preview tool.

• Type ppreview and then press Enter.

3 Do any of the following to browse the preview image:

• To zoom in or out, click Zoom In, click Zoom Out, or spin the center mouse 
wheel.

• To pan, press and hold the center mouse wheel while moving the mouse.

4 After checking the preview image, do one of the following:

• To print the drawing, click Print.

• To return to the drawing, click Cancel.
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A Click to zoom in.
B Click to zoom out. If you have zoomed in 

several times, click multiple times to restore 
the entire preview image. 

C Click to print the drawing.
D Click to close the preview and return to the 

drawing.

A B C D
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Printing a drawing    
The Print dialog box has print settings described in the previous sections for page set-
ups. 

You cannot print a rendered image directly to a printer.  
To print a rendered image, you must first save the drawing to a different format and 
then print it from another graphics program.

To print a drawing
1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following to choose Print ( ):

• On the ribbon, choose the Application button then choose Print, or choose 
Output > Print (in Print).

• On the menu, choose File > Print.

• On the Standard toolbar, click the Print tool.

• Type print and then press Enter.

3 In Page Setup Name, select the page setup to apply for printing. The print options 
in the Print dialog box change to reflect the settings of the selected page setup. For 
details about importing page setups, see “Importing page setups from a different 
drawing” on page 634 in this chapter. 

4 Make any necessary adjustments, including for the following options that are 
available only at print time (not when setting up a page setup):

• Print to file — Select to print to a file instead of a printer.

• Number of copies — Enter the number of copies to print.

• Print transparency —  Select to print entities with their assigned transparency. 
Note that turning on this option can slow printing. Also note that the 
PLOTTRANSPARENCYOVERRIDE system variable can override trans-
parency print settings for all layout viewports at once.

• Print in background — Print in the background of other tasks being performed 
by the computer.

• Print stamp on — Select to print with a header and footer. When enabled, you 
can click [...] to modify the text of the print stamp.

• Save changes to layout — Select to save the print settings for the model or 
layout.

5 Click Print.
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A Select to print to a file instead of a printer.
B Enter the number of copies to print.
C Select to save the print settings for the model or 

layout.
D Click to modify the text of the print stamp (available 

if print stamps are turned on).

E Select to print with a header and footer.
F Select to print in the background of other tasks 

being performed by the computer.
G Select to print entities with their assigned 

transparency.

B
F

A

C
D

G

E
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Saving print settings for a model or layout
All print settings can be saved with a model or layout, which can be particularly help-
ful if you don’t use page setups. The next time you print the model or layout, the 
saved print settings automatically load in the Print dialog box. 

Saved print settings are also used when publishing.
If you’re publishing drawings using sheets that don’t have a page setup assigned, the 
print settings saved for the model or layout are used by default.

To save print settings with a model or layout
1 Click the desired Layout tab or the Model tab for which you want to save print set-

tings.

2 Do one of the following to choose Print ( ):

• On the ribbon, choose the Application button then choose Print, or choose 
Output > Print (in Print).

• On the menu, choose File > Print.

• On the Standard toolbar, click the Print tool.

• Type print and then press Enter.

3 Make your print selections.

4 Click Apply to Layout.

5 Do one of the following:

• Click OK to print and close the dialog box.

• Click Cancel to close the dialog box without printing.
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Publishing sheet sets

With sheets sets, you can collect and organize sheets (layouts) from various drawings 
in one location, which makes it easy to open, view, print, and distribute numerous 
layouts that are related to a single project. You can publish sheet sets to a printer or 
plotter and to the following file formats: PDF, DWF, and DWFx.

Sheet sets are saved in .dst files and are managed and published using the Sheet Set 
Manager pane. If you move a .dst file to another computer, its referenced .dwg files 
should also be moved.

Some projects benefit from using sheet set information in fields that are inserted in 
the drawing. For example, you can include the current sheet name and description in 
fields, which update automatically when using the Update Field command. For more 
details, see “Working with fields” on page 486. 

Sheet sets are typically used for large multi-drawing projects, but another way to pub-
lish drawings is using sheet lists which are saved in .dsd file and published using the 
Publish command. For more details, see “Publishing sheet lists” on page 674 in this 
chapter. 

Displaying the Sheet Set Manager pane
The Sheet Set Manager pane is used to collect, organize, and publish collections of 
sheets (layouts) that are located in multiple drawings.

To display or hide the Sheet Set Manager pane
1 Do one of the following to choose Sheet Set Manager ( ):

• On the ribbon, choose the Application button, then choose Sheet Set Manager; 
choose Output > Sheet Set Manager (in Print); or choose View > Sheet Set 
Manager (in Panes).

• On the menu, choose File > Sheet Set Manager or View > Display > Sheet Set 
Manager.

• Type sheetset and then press Enter.
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A Select a sheet set from the list of opened 
sheet sets.

B Click to close the pane.
C Click to automatically hide the pane.
D Click to display a menu of options: close, 

dockable, fix to left, fix to right, autohide, and 
transparency.

E Displays the sheets and subsets of the sheet 
set. Drag-and-drop sheets and subsets to 
reorder them.

F Click and drag to move the pane to a new 
location. Right-click for more options.

G Double-click to dock the pane. Right-click for 
more options.

H Click to publish the displayed sheet set.
I Click to open a sheet set.
J Click to create a sheet set.

I

B
A

C

E
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Creating a sheet set
You can create a sheet set (.dst file) by selecting drawings that contain the sheets (lay-
outs) that you want to include. If you have an existing sheet set that contains the gen-
eral structure you need, you can use the existing sheet set as a template for the new 
one.

To create a new sheet set using layouts from existing drawings
1 Do one of the following:

• In the Sheet Set Manager pane, click New ( ).

• Type newsheetset, then press Enter.

2 Select Existing Drawings, then click Next.

3 Enter the name, optional description, and folder for the sheet set, then click Next.

4 Click Import Options and do the following:

• To automatically add the drawing file name as a prefix to sheet titles, mark 
Prefix Sheet Titles with File Name.

• To create and organize subsets for the sheet set based on the folder hierarchy on 
your computer, mark Create Subsets Based on Folder Structure. If marked, 
choose whether to omit the top folder when creating the subsets in the resulting 
sheet set structure.

• Click OK.

5 Click Browse, select the folder that contains drawings with layouts you want to 
use for sheets, then click OK.

6 Uncheck any drawings or layouts you don’t want added to the sheet set, then click 
Next.

7 Review the details, then click Finish.

To create a new sheet set based on a template
1 Do one of the following:

• In the Sheet Set Manager pane, click New ( ).

• Type newsheetset, then press Enter.

2 Select An Example Sheet Set, then click Next.

3 Specify the path and name of the sheet set you want to use as a template or click 
Browse to locate it, then click Next.

4 Enter the name, optional description, and folder for the sheet set, then click Next.

5 Review the details, then click Finish.
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Opening a sheet set
When you open a sheet set (.dst file), its sheets and subsets display in the Sheet Set 
Manager pane.

To open a sheet set
1 Do one of the following:

• In the Sheet Set Manager pane, click Open ( ).

• Type opensheetset, then press Enter.

2 Choose the folder containing the desired sheet set (.dst) file.

3 Do one of the following:

• Choose the file you want to open, then click Open.

• Double-click the file you want to open.

Close a sheet set.
To close a sheet set but keep the Sheet Set Manager pane open, right-click the name 
of the sheet set and choose Close Sheet Set.

Modifying sheet set properties
You can change a sheet set’s name, description, file path, and more.

To change the properties of a sheet set
1 In the Sheet Set Manager pane, right-click the sheet set, then choose Properties.

2 Make your selections. Click [?] for more details about each option.

3 Click OK.

Working with sheets
Each sheet in a sheet set corresponds to a single layout in a drawing. You can open a 
sheet’s corresponding layout directly from the Sheet Set Manager pane, add sheets, 
reorganize sheets, and change the properties of sheets.

Opening a sheet
Open any sheet in a sheet set by simply double-clicking it in the Sheet Set Manager 
pane. As long as the referenced drawing is found and the layout exists, IntelliCAD 
opens the drawing and activates the layout.
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To open a sheet in the program
1 In the Sheet Set Manager pane, do one of the following:

• Double-click a sheet.

• Right-click a sheet and choose Open. If Open is unavailable, the referenced 
drawing is not found.

The sheet opens in the program.

2 If the sheet cannot be found, choose one of the following options:

• Locate drawing Allows you to navigate to the folder where the referenced 
drawing is located and choose the layout.

• Remove the sheet Deletes the sheet from the sheet set.

• Associate a different layout Allows you to navigate to the folder where the 
referenced drawing is located and choose a different layout.

Adding sheets to a sheet set
From the Sheet Set Manager pane with a sheet set open, you can add existing sheets 
(layouts) from a drawing or create and add new ones.

To create a new sheet and add it to a sheet set
1 In the Sheet Set Manager pane, right-click the item located above where the new 

sheet is to be added, then choose New Sheet.

2 Make your selections.

3 Click OK.

A Indicates the sheet number. It is 
recommended that you don't change the sheet 
number until after you've create the sheet.

B Mark to open the new sheet in the drawing 
window after you click OK.

C Displays the default template that will be used 
for the new sheet.

D Displays the default folder path where the new 
drawing will be stored.

E Enter the name of the new .dwg file to create 
for this sheet.

F Enter the name of the new layout you want to 
create for this sheet.

B

A

C

D

E

F
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To add a sheet by selecting one or more existing layouts
1 In the Sheet Set Manager pane, right-click the item located above where the new 

sheet is to be added, then choose Import Layout as Sheet.

2 Click Browse and select the folder that contains drawings you want to browse for 
layouts, then click OK.

3 Mark each layout you want to add to the sheet set.

4 Click Import Checked.

A Click to select drawings that contain layouts 
you want to use for sheets.

B Displays all layouts in the selected drawings 
that are not already in the sheet set.

C Mark each layout you want to import as a 
sheet.

D Click to add the drawing file name as a prefix 
to sheet titles.

E Click to import all layouts that are marked.
F Displays the status of the layout.
G Displays the name of the layout.

E

B

A

F
G

C

D
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Modifying sheets
Sheets can be renamed, renumbered, reordered, and deleted. Sheets also have proper-
ties which can be changed.

To rename or renumber a sheet
1 In the Sheet Set Manager pane, right-click the desired sheet, then choose Rename 

and Renumber.

2 In Title, enter a new sheet name.

3 In Number, enter a new sheet number.

4 Click OK.

To reorder sheets in a sheet set
• In the Sheet Set Manager pane, select and drag a sheet to its new location in the 

list.

To delete a sheet from a sheet set
• In the Sheet Set Manager pane, right-click the desired sheet, then choose Remove 

Sheet.

To change the properties of a sheet
1 In the Sheet Set Manager pane, right-click the desired sheet, then choose Proper-

ties.

2 Make your selections. Click [?] for more details about each option.

3 Click OK.

Working with subsets
Sheet sets can contain various subsets, which help organize individual sheets into cat-
egories, similar to a folder name. For example, a sheet set might have subsets named 
Architectural, Civil, Electrical, and Structural. Subsets can also be nested, similar to 
folders.
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To create a subset
1 In the Sheet Set Manager pane, right-click the sheet set or subset, then choose 

New Subset.

2 In Name, enter the name of the subset.

3 In Description, enter an optional description for the subset.

4 In Publish Sheets in Subset, choose one of the following:

• Do Not Publish Sheets Prevents sheets in this subset from being published or 
sent via eTransmit.

• Publish by Sheet “Include for Publish” Setting Includes sheets in this subset for 
publishing or eTransmit according to each sheet's “Include for Print/Publish” 
setting.

5 In Prompt for Template, choose whether to prompt for a layout to use as a tem-
plate when adding new sheets to the subset. 

6 Click OK.

7 Drag-and-drop existing sheets to the subset, or right-click the Subset and choose 
New Sheet to add new sheets.

To move a subset and its contents
• In the Sheet Set Manager pane, select and drag a subset to its new location in the 

list.

To rename a subset or change its properties
1 In the Sheet Set Manager pane, right-click the desired subset, then choose Proper-

ties.

2 In Name, enter a new name for the subset.

3 Make additional selections. Click [?] for more details about each option.

4 Click OK.

Publishing a sheet set
You can publish sheet sets to a printer or plotter and to the following file formats: 
PDF, DWF, and DWFx.

Sheet sets are saved in .dst files and are managed and published using the Sheet Set 
Manager pane. Another way to publish drawings is using sheet lists which are saved 
in .dsd file and published using the Publish command. For more details, see “Publish-
ing sheet lists” on page 674 in this chapter. 
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To publish a sheet set or part of it
1 In the Sheet Set Manager pane, do one of the following depending on what you 

want to publish:

• To publish the entire sheet set, click Publish ( ) in the Sheet Set Manager 
pane or right-click the sheet set name in the list.

• To publish only the content of a subset, right-click the subset name in the list.

• To publish only a single sheet, right-click the sheet name in the list.

2 If you need to specify options for publishing, choose Publish, then one of the fol-
lowing:

• Sheet Set PDF Publish Options Allows you to specify options for publishing to 
a .pdf file. Click [?] to see details about each option.

• Sheet Set DWF Publish Options Allows you to specify options for publishing to 
a .dwf or .dwfx file. Click [?] to see details about each option.

3 If you specified publish options, right-click the item again.

4 Choose Publish, then choose one of the following:

• Publish to PDF Publishes to a .pdf file. In the dialog box that displays, specify 
the location and file name of the .pdf file, then click Save.

• Publish to DWF Publishes to a .dwf file. In the dialog box that displays, specify 
the location and file name of the .dwf file, then click Save.

• Publish to DWFx Publishes to a .dwfx file. In the dialog box that displays, 
specify the location and file name of the .dwfx file, then click Save.

• Publish to Printer Publishes to a printer. In the dialog box that displays, specify 
the desired settings. Click [?] to see details about each option. When finished, 
click Print.

To publish a sheet set via eTransmit
1 In the Sheet Set Manager pane, right-click one of the following:

• The sheet set name if you want to publish the entire sheet set.

• A subset name if you want to publish only the content of the subset.

• A sheet name if you want to publish only the single sheet. 

2 Choose eTransmit.

3 Specify the desired options, then click OK. Click [?] to see details about each 
option or see “Packaging drawings and files for use on another computer” on page 
809. 
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Publishing sheet lists

A sheet list is a collection of sheets that you want to publish using the Publish com-
mand. Each sheet in the list references a model or layout tab from any drawing.

First you create a sheet list by specifying the drawing and which of its model and lay-
out tabs that you want to publish. For each sheet, you can assign a page setup and 
layer state. Save the sheet list, then publish it. You can publish sheet lists to a printer 
or plotter and to the following file formats: PDF, DWF, and DWFx.   
Sheet lists are saved as Drawing Set Description files (.dsd files). If you move a .dsd 
file to another computer, its referenced .dwg files should also be moved.

Another way to publish drawings is using sheet sets which are saved in .dst files and 
published from the Sheet Set Manager pane. For more details, see “Publishing sheet 
sets” on page 665 in this chapter. 

Creating a sheet list
A sheet list is saved in a .dsd file and contains references to the model and layout tabs 
of the drawings you want to publish. Each sheet can be assigned a page setup and 
layer state, and can be placed in the order you want it to appear among other sheets 
when published.

To create a sheet list to publish
1 Do one of the following to choose Publish ( ):

• On the ribbon, choose the Application button, then choose Publish > Publish, or 
choose Output > Publish.

• On the menu, choose File > Publish.

• On the Standard toolbar, click the Publish tool.

• Type publish and then press Enter.

2 Depending on the dialog box settings, the sheet list that displays first in the dialog 
box might have too many or too few sheets for your needs. To quickly clear or add 
sheets, choose one of the following options, then click Close and open the dialog 
box again:

• Load Select which drawing files to include when adding sheets automatically 
the next time the dialog box opens: all open drawings, the current drawing only, 
or none (empty sheet list).

• Include Select which tabs to add as sheets automatically the next time the dialog 
box opens: model tabs only, layout tabs only, or both model and layout tabs.

3 Click Add ( ) to add sheets to the list. You can also press Insert when a sheet is 
selected or drag drawing files from the Windows Explorer window and drop them 
in the list.
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4 Choose which drawings you want to add new sheets from:

• Drawings already in the publish list Select to display layouts or models that are 
missing from drawings that are already listed in the Publish dialog box. The list 
is empty if all layouts and models are already included in the sheet list. 

• Other drawings Select to display models and layouts from other drawings, then 
click Browse to select one or more drawing files.

5 Mark the layouts and models that you want to include in the sheet list.

6 Click OK.

7 To remove unwanted sheets from the sheet list, select a sheet, then click Remove 
( ) or press Delete.

8 To move sheets up or down in the list, select the sheet and click Move Up ( ) or 
click Move Down ( ). You can also click Reverse ( ) to reverse the order of 
all sheets. Sheets are published in the order in which they display.

9 To assign a different page setup to sheets, in the Page Setup column, select a sheet 
(or Ctrl+click to select multiple) and select a page setup from the list.

The page setup you select for a sheet is assigned to all other selected sheets if they 
have the same type (for a model or layout) and are located in the same drawing.

For details about importing page setups, see “Importing page setups from a differ-
ent drawing” on page 634 in this chapter. For details about using Page Setup Man-
ager, see “Working with page setups” on page 630 in this chapter. 

10 To edit page setup settings, do the following:

• Select a sheet for a model or layout in the drawing that contains the page setup 
you want to edit. The page setups that display in the Page Setup Manager dialog 
box depend on whether a model or layout sheet is currently selected.

• Click Edit Page Setup ( ). You can also double-click a sheet.

• Select the page setup to change, then click Modify.

• Make your selections, then click OK.

• Click Close.

11 To publish a sheet using a specific layer state, in the Layer State column, select a 
sheet (or Ctrl+click to select multiple) and select a layer state from the list. The list 
displays all layer states created for a drawing. Choose Layer States Manager in the 
list to modify and create layer states.

The layer state you select for a sheet is assigned to all other selected sheets if they 
are in the same drawing.

12 Click Save ( ).

13 In the Save DSD File dialog box, enter a name for the sheet list, then click Save.
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A Click to edit page setup settings in the Page Setup 
Manager. The page setups that display for editing 
depend on whether the currently selected sheet is 
for a model or layout.

B Click to delete the currently selected sheet from the 
sheet list.

C Click to add sheets from drawings that you select.
D Displays the sheets to publish with each sheet’s 

settings.
E Displays details about the currently selected sheet.

F Click to move the currently selected sheet down 
one position.

G Click to reverse the order of sheets.
H Click to move the currently selected sheet up one 

position.
I Choose whether to add sheets for the model tab, 

layout tabs, or both when automatically loading 
sheets when the dialog opens.

J Choose which drawings (if any) to load sheets from 
automatically when the dialog displays.

K Click to save the list of sheets in a .dsd file.

D
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Modifying an existing sheet list
Open, or load, an existing sheet list (.dsd file) to modify it. During loading, drawings 
that are specified in the sheet list must be accessible in the referenced folder location.

To modify a sheet list
1 Do one of the following to choose Publish ( ):

• On the ribbon, choose the Application button, then choose Publish > Publish, or 
choose Output > Publish.

• On the menu, choose File > Publish.

• On the Standard toolbar, click the Publish tool.

• Type publish and then press Enter.

2 Click Open ( ).

3 Locate and select the .dsd file to modify.

4 Click Open.

5 Make any necessary changes. The options are the same as creating a new sheet. 
For details, see “Creating a sheet list” on page 674 in this chapter. 

6 Click Save ( ).

Publishing a sheet list to the printer named in page setup
Publishing a sheet list prints all referenced sheets at the same time. The sheets are 
printed to the printer named in the assigned page setup for each sheet. If the Page 
Setup column indicates None for a sheet, the sheet is published using the print options 
specified for the layout.
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To publish a sheet list to the printer named in page setup
1 Do one of the following to choose Publish ( ):

• On the ribbon, choose the Application button, then choose Publish > Publish, or 
choose Output > Publish.

• On the menu, choose File > Publish.

• On the Standard toolbar, click the Publish tool.

• Type publish and then press Enter.

2 Open the desired sheet list:

• Click Open ( ).

• Locate and select the .dsd file to publish.

• Click Open.

For details about creating a sheet list, see “Creating a sheet list” on page 674 in 
this chapter. 

3 In Publish To, select Printer Named in Page Setup.

4 If you regularly publish to the page setup’s printer instead of other formats, 
optionally click Set as Default.

5 Verify the status of each sheet in the list:

• No Errors — The sheet is ready for publishing.

• Layout Not Initialized — The sheet’s layout is not assigned a valid printer. If 
the sheet is assigned a page setup, choose File > Page Setup and specify a valid 
printer for the page setup. If no page setup is assigned, open the source drawing 
file, click the referenced Model or Layout tab, choose File > Print, specify a 
printer, then click Apply to Layout. 

6 Specify any of the following options:

• Number of copies — Enter the number of copies to print.

• Include print stamp — Select to print with a header and footer. Click ( ) to 
modify the text of the header and footer.

• Publish in background — Select to print in the background of other tasks being 
performed by the computer.

7 Click Publish.
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A Click to open a sheet list.
B Select a sheet list to publish.
C Select to print to the page setup named for each 

sheet. Click Set as Default to make this the default 
setting each time you open the dialog box. 

D Displays the sheets to publish with each sheet’s 
settings.

E Displays details about the selected sheet.
F Enter the number of copies to print.
G Mark to publish in the background of other tasks 

being performed by the computer.

H Click to modify the text of the print stamp (available 
if print stamps are included).

I Mark to publish with a header and footer.
J Click to change the page setup for the currently 

selected sheets.
K Click to change the layer state for the currently 

selected sheets.
L Displays the location of the currently selected 

printer settings. Click [...] to specify a different 
folder.

D
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Publishing a sheet list to PDF
Publishing a sheet list to PDF prints all referenced sheets at the same time to a .pdf 
file. PDF format files allow you to distribute your drawing to others for viewing in 
Adobe® Acrobat® Reader®, which is free software that users can download. PDF 
format files can also be viewed, reviewed, and edited in Adobe Acrobat.

If the Page Setup column indicates None for a sheet, the sheet is published using the 
print options specified for the layout.

To publish a sheet list to a .pdf file
1 Do one of the following to choose Publish ( ):

• On the ribbon, choose the Application button, then choose Publish > Publish, or 
choose Output > Publish.

• On the menu, choose File > Publish.

• On the Standard toolbar, click the Publish tool.

• Type publish and then press Enter.

2 Open the desired sheet list:

• Click Open ( ).

• Locate and select the .dsd file to publish.

• Click Open.

For details about creating a sheet list, see “Creating a sheet list” on page 674 in 
this chapter. 

3 In Publish To, select PDF.

4 If you regularly publish to PDF instead of other formats, optionally click Set as 
Default.

5 In PDF Preset, choose the printer configuration (*.pc3) file that contains the pre-
defined settings for creating the .pdf file.

6 Click Publish Options and do any of the following:

• Select options for the published .pdf file.

• Click Advanced Options to select additional options, then click OK when done.

• Click [?] to see details about each option.

7 Click OK when done setting PDF options.

8 Verify the status of each sheet in the list:

• No Errors — The sheet is ready for publishing.

• Layout Not Initialized — The sheet’s layout is not assigned a valid printer. If 
the sheet is assigned a page setup, choose File > Page Setup and specify a valid 
printer for the page setup. If no page setup is assigned, open the source drawing 
file, click the referenced Model or Layout tab, choose File > Print, specify a 
printer, then click Apply to Layout. 
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9 Select Include Print Stamp to print with a header and footer, then click ( ) to 
modify the text of the header and footer.

10 Click Publish.

A Click to open a sheet list.
B Select a sheet list to publish.
C Select to publish to PDF. Click Set as Default to 

make this the default setting each time you open the 
dialog box. 

D Choose the printer configuration (*.pc3) file that 
contains the predefined PDF options for creating 
the .pdf file. Available only when publishing to PDF.

E Displays the sheets to publish with each sheet’s 
settings.

F Displays details about the currently selected sheet.

G Click to modify the text of the print stamp (available 
if print stamps are included).

H Mark to publish with a header and footer.
I Click to change the page setup for the currently 

selected sheets.
J Click to change the layer state for the currently 

selected sheets.
K Click to set options for publishing to PDF.
L Displays details about the currently selected PDF 

publish options. 
M Click to specify a different output folder.
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Publishing a sheet list to DWF or DWFx
Publishing a sheet list to DWF or DWFx prints all referenced sheets at the same time 
to a .dwf or .dwfx file, depending on the format you choose. DWF and DWFx format 
files allow you to distribute your drawing to others for online viewing, reviewing, and 
editing.

If the Page Setup column indicates None for a sheet, the sheet is published using the 
print options specified for the layout.

To publish a sheet list to a .dwf or .dwfx
1 Do one of the following to choose Publish ( ):

• On the ribbon, choose the Application button, then choose Publish > Publish, or 
choose Output > Publish.

• On the menu, choose File > Publish.

• On the Standard toolbar, click the Publish tool.

• Type publish and then press Enter.

2 Open the desired sheet list:

• Click Open ( ).

• Locate and select the .dsd file to publish.

• Click Open.

For details about creating a sheet list, see “Creating a sheet list” on page 674 in 
this chapter. 

3 In Publish To, select DWF or DWFx.

4 If you regularly publish to DWF or DWFx instead of other formats, optionally 
click Set as Default.

5 Click Publish Options and select options for the published .dwf or .dwfx file. 
Click [?] to see details about each option.

6 Click OK when done setting publish options.

7 Verify the status of each sheet in the list:

• No Errors — The sheet is ready for publishing.

• Layout Not Initialized — The sheet’s layout is not assigned a valid printer. If 
the sheet is assigned a page setup, choose File > Page Setup and specify a valid 
printer for the page setup. If no page setup is assigned, open the source drawing 
file, click the referenced Model or Layout tab, choose File > Print, specify a 
printer, then click Apply to Layout. 

8 Click Publish.
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A Click to open a sheet list.
B Select a sheet list to publish.
C Select to publish to DWF or DWFx. Click Set as 

Default to make this the default setting each time 
you open the dialog box. 

D Displays the sheets to publish with each sheet’s 
settings.

E Displays details about the currently selected sheet.

F Click to change the page setup for the currently 
selected sheets.

G Click to change the layer state for the currently 
selected sheets.

H Click to set options for publishing to DWF/DWFx.
I Displays details about the currently selected DWF/

DWFx publish options. 
J Click to specify a different output folder.
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Publishing a sheet list automatically
Drawings can be automatically published whenever they are saved or closed, with or 
without prompting. During automatic publishing, .dwf, dwfx, or .pdf files are saved 
according to predefined options that you specify. By default, automatic publishing is 
turned off, so don’t forget to turn it on after you set it up.

To set up auto publishing
1 Do one of the following to choose Auto Publish ( ):

• On the ribbon, choose the Application button, then choose Publish > Auto 
Publish.

• On the menu, choose File > Auto Publish.

• Type autopublish and then press Enter.

2 Choose Settings.

3 Make your selections, then click OK.

4 To publish, for example a test publish with your new settings, press Enter. To skip 
publishing, press Esc.

A Select when to auto publish: when the file is saved 
or closed, and with or without a prompt.

B Select whether to save published files to the same 
folder as the drawing, a subfolder of the drawing 
folder, or a different folder.

C Select the folder where you want to save published 
files. (Available only if User Location is selected in 
Location.)

D Select whether the model, layouts or both the model 
and layouts are published.

E Select whether to publish the drawing to a .dwf, 
.dwfx or .pdf file.

F Select whether to publish all sheets to a single file 
or each sheet to its own file.

G Select whether to include layer information.
H Select whether overlapping lines include only the 

last line or are merged together.
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To turn automatic publishing on or off
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Printer Options (in 
Print), or choose Tools > Options (in Manage) then click the Printing tab.

• On the menu, choose Tools > Options then click the Printing tab or choose 
File > Printer Options.

• Type options, press Enter, then click the Printing tab.

2 Mark or unmark Automatic Publish on Save or Close.

3 Click OK.
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Drawing in three dimensions

Paper drawings typically represent two-dimensional views of three-dimensional 
objects. With IntelliCAD, you can create three-dimensional models of three-dimen-
sional objects.

This section explains how to:

• View entities in three dimensions.

• Create three-dimensional entities.

• Convert three-dimensional entities to surfaces or meshes.

• Edit entities in three-dimensional space.

• Edit three-dimensional solids.

• Display hidden-line, shaded, and rendered views of three-dimensional entities.

The tools and commands for many of the functions described in this section appear 
on the Draw 3D toolbar and the Insert menu, respectively, when you set the program 
to the Advanced experience level.

Topics in this chapter

Viewing entities in three dimensions .................................................................688

Creating three-dimensional entities...................................................................706

Editing in three dimensions ...............................................................................747

Editing three-dimensional solids .......................................................................756

Hiding, shading, and rendering .........................................................................767
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Viewing entities in three dimensions 

You can view an IntelliCAD drawing from any position in three-dimensional space. 
From any selected viewing position, you can add new entities and modify existing 
entities. You can also generate hidden-line and shaded views from any viewing posi-
tion.  

You view three-dimensional drawings by setting the viewing direction. The viewing 
direction establishes the viewing position, the Cartesian coordinate corresponding to 
the viewpoint looking back at the origin point, the 0,0,0 coordinate. When you view a 
drawing from the default viewpoint (0,0,1), you see a plan view of the drawing.     

Changing the viewing direction can be affected by smooth view transitions.
Type vtoptions to specify whether smooth view transitions are used when changing 
the viewing direction (rotation), and to specify speed and performance settings.

Switching to a preset viewing direction
Using preset views, you can quickly change the viewing direction to look at the draw-
ing from a different vantage point or to work on a three-dimensional model from a 
different orientation.

To switch to a preset viewing direction    
1 Do one of the following:

• On the ribbon, go to the Views area of the View tab.

• On the menu, choose View > 3D Views.

• Go to the View toolbar.

• Type view.

• Click the view control in the upper left corner of the drawing window.

2 Select or type the name of one of the following:

• Top, Front, Right Side, Left Side, Back, Bottom

• Above, Left Front; Above, Right Front; Above, Right Rear; Above, Left Rear

• Below, Left Front; Below, Right Front; Below, Right Rear; Below, Left Rear

The view cube also has preset views.
Click a preset view on the view cube to switch the viewing direction. For more 
details, see “Using the view cube to switch the view” on page 694 in this chapter. 
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To switch to a preset viewing direction using the Preset Viewpoints command    
1 Do one of the following to choose Preset Viewpoints ( ):

• On the ribbon, choose View > Preset Viewpoints (in Views).

• On the menu, choose View > Preset Viewpoints.

• On the View toolbar, click the Preset Viewpoints tool.

• Type setvpoint and then press Enter.

2 Click the preset view you want to use. 

A Click to select an isometric viewpoint. B Click to select an orthographic viewpoint.

A

B
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Creating and switching to named views
As you work on a drawing, you may find that you frequently switch among different 
portions of it. For example, if you are drawing the floor plan of a house, you may 
zoom in to particular rooms of the house and then zoom out to display the entire 
house. Although you can repeat the Pan and Zoom commands to do this, it is much 
easier to save various views of the drawing. You can then quickly switch among these 
views. 

These custom views that you create, called named views, can control more settings 
than just view direction and location — they can also include the visual style, UCS, 
background, perspective and lens length, clipping, etc.    

Creating a named view 
Named views can be saved and displayed in the current window.    

To create a named view for the current view in the drawing
1 Do one of the following to choose View Manager ( ):     

• On the ribbon, choose View > View Manager (in Views).

• Choose View > View Manager.

• On the View toolbar, click the View Manager tool.

• In the View element of the Explorer, click the View Manager tool.

• Type view and then press Enter.

2 Click New.

3 In Name, type a name for the view.

4 Choose the desired options. If you want to see your changes directly in the draw-
ing as you specify them, mark Update drawing display.

5 Click OK when done.
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A Lists the current view, model views (named views and 
cameras), and preset views.

B Enter the x-, y- and z- coordinates of the selected 
view's target location, to which the view is oriented.

C Mark to update the drawing display automatically as 
you change settings.

D Click to create a new view.
E Click to delete the selected view.
F Click to select the boundaries of the view directly in 

the drawing.
G Enter the front and back distances of the selected 

view's clipping planes, or move the slider. Available 
only when clipping is turned on to the appropriate 
setting.

H Enter the lens length (millimeters) of the selected 
view, or move the slider. Available only when 
Perspective is turned on.

I Enter the twist angle for the selected view.

J Enter the height of the selected view.
K Enter the width of the selected view.
L Enter the x- and y-coordinates of the selected view's 

center point.
M Enter the x-, y- and z-coordinates of the selected 

view's camera location, from which the view is 
oriented.

N Select the user coordinate system for the selected 
view.

O Select where to locate boundary clipping of the 
selected view.

P Select Off (orthographic) or On (perspective) for the 
selected view. (Then specify the lens length.)

Q Select a background for the selected view.
R Select a visual style for the selected view.
S Enter a new name for the selected view.
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To create a named view for a portion of the current view in the drawing
1 Do one of the following to choose View Manager ( ):     

• On the ribbon, choose View > View Manager (in Views).

• Choose View > View Manager.

• On the View toolbar, click the View Manager tool.

• In the View element of the Explorer, click the View Manager tool.

• Type view and then press Enter.

2 Click New.

3 In Name, type a name for the view.

4 Make any additional changes to the view. And if you want to see your changes 
directly in the drawing as you specify them, mark Update drawing display.

5 Click OK when done.

To create a named view from an existing view
1 Do one of the following to choose View Manager ( ):     

• On the ribbon, choose View > View Manager (in Views).

• Choose View > View Manager.

• On the View toolbar, click the View Manager tool.

• In the View element of the Explorer, click the View Manager tool.

• Type view and then press Enter.

2 In the list of views, select the view that has the settings you want to use as a base 
for the new view.

3 Click New.

4 In Name, type a name for the new view.

5 Make any additional changes to the view. And if you want to see your changes 
directly in the drawing as you specify them, mark Update drawing display.

6 Click OK when done.

View Manager is not a transparent command.
For example, you cannot use View Manager during the Preset Viewpoints or Define 
View commands, or when zooming or panning the drawing.

Setting the background for a named view   
For each named view that you create, you can assign a solid-color, gradient, or image 
background. Whenever you switch to that view, the background displays if the view 
is also assigned any visual style other than 2D Wireframe.



D R A W I N G  I N  T H R E E  D I M E N S I O N S 693
To set the background for a named view
1 Do one of the following to choose View Manager ( ):

• On the ribbon, choose View > View Manager (in Views).

• On the menu, choose View > View Manager.

• On the View toolbar, click the View Manager tool.

• Type view and then press Enter.

• In the View element of the Explorer, click the View Manager tool.

2 Select the model view for which you want to set a background.

3 In Visual style, select Conceptual, Hidden, or Realistic.

4 In Background, choose one of the following:

• Solid

• Gradient

• Image

5 In the Background dialog box, make your selections. Click [?] to see details about 
each option.

6 Click OK.

Use the Background command to set a background for the current view.
To specify a solid-color, gradient, or image background for the current view, type 
background and make your selections.

Switching to a named view   
After you save one or more named views, you can restore any of those views in the 
current window using either the View command or IntelliCAD’s Explorer.    

To switch to a named view
1 Do one of the following to choose View Manager ( ):

• On the ribbon, choose View > View Manager (in Views).

• On the menu, choose View > View Manager.

• On the View toolbar, click the View Manager tool.

• Type view and then press Enter.

• Click the view control in the upper left corner of the drawing window.

2 Select the view you want to switch to.

3 Click OK.
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You can also switch between named views using the Explorer.
Choose Tools > Explore Views (in Explorer), then double-click the desired named 
view.

Modifying named views   
Once you create a named view, you can modify any of its settings or simply fine-tune 
it as you drawing changes. Only named views that you create can be changed; preset 
views cannot be modified.

To change the settings of a named view
1 Do one of the following to choose View Manager ( ):     

• On the ribbon, choose View > View Manager (in Views).

• Choose View > View Manager.

• On the View toolbar, click the View Manager tool.

• In the View element of the Explorer, click the View Manager tool.

• Type view and then press Enter.

2 To see your changes directly in the drawing as you make them, mark Update 
drawing display.

3 Change the desired settings.

4 Click OK when done.

Using the view cube to switch the view
The view cube is a navigation tool that indicates the current viewing direction and 
allows you to switch between preset views and custom viewing directions. You can 
also use the view cube to change the coordinate system and switch between ortho-
graphic and perspective projections. 

The view cube displays in the current viewport when working in 2D model space or a 
3D visual style. It becomes active when you move the mouse over it, and it can dis-
play with transparency or not at all when inactive.        

Turning the display of the view cube on or off
The view cube is a convenient way to view a drawing from various directions. When 
you aren’t using it, you can turn the display off. 

The view cube can be transparent when inactive.
Instead of turning the view cube display off, you might want to make it transparent, 
all or partially, when it is inactive. For details, see “Changing view cube settings” on 
page 696 in this chapter. 
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To display or hide the view cube   
1 Do one of the following to choose View Cube:

• On the ribbon, choose View > View Cube (in Interface).

• On the menu, choose View > Display > View Cube.

• Type navvcube, press Enter, then choose On or Off.

Changing the view using the view cube
Use the view cube to view a drawing using the following: 

• Home view

• Orthographic and isometric preset views

• Custom views

• Orthographic and perspective projections

• Coordinate systems
 

A Click to switch to the home view saved with the 
drawing.

B Click an arrow to change to an orthogonal preset 
view, orienting from that direction.

C Click a face to switch to the named orthographic 
preset view.

D Click a corner to switch to an isometric preset 
view.

E Click to choose the coordinate system.
F Click to switch to the home view, set the home 

view, switch between Parallel and Perspective 
projections, and access view cube settings.

G Click an edge to switch to a custom view, 
orienting the view from that direction.

H Click to rotate the view 90 degrees, or click and 
drag to rotate the view in real-time.

E
F

B
G

D
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To change the view direction using the view cube
1 Do one of the following:

• Click Activate Home View to return to the home view that is saved with the 
drawing. To set the current view as the home view, right-click the view cube, 
and then choose Set Current View as Home.

• Click a face of the cube to switch to the Top, Front, Left Side, Right Side, Back, 
and Bottom preset orthographic views.

• Click a corner of the cube to switch to the Above, Left Front; Above, Right 
Front; Above, Right Rear; Above, Left Rear, Below, Left Front; Below, Right 
Front; Below, Right Rear; and Below, Left Rear preset isometric views.

• Click an edge of the cube to switch to a custom view, orienting the view from 
that direction.

• Click an arrow to switch to the orthographic view, orienting the view from that 
direction. The arrows display if you already are viewing the drawing with an 
orthographic view (for example, after clicking a face of the cube).

• Click the rotation arrows (available when viewing orthographically) to rotate 
the view 90 degrees, or click and drag the view cube or rotation arrows to rotate 
the view in real-time.

To switch between parallel (orthographic) and perspective projections using the 
view cube
1 Do one of the following: 

• Click the drop-down arrow in the lower right of the view cube, and then choose 
Parallel or Perspective.

• Right-click the view cube, and then choose Parallel or Perspective.

The perspective projection changes all preset views to perspective views.
When using the perspective projection, all views become perspective views and are 
no longer orthographic or isometric views.

To change the coordinate system using the view cube
1 Click the Activate Coordinate System menu.

2 Choose WCS or the name of the user coordinate system. You can also choose 
New UCS to create a new user coordinate system.

 

Changing view cube settings
You can change the location and appearance of the view cube, such as which corner 
of the viewport it is located and how transparent it is when inactive. Additionally, you 
can specify various options for using it. For example, you may want to prevent the 
model from turning upside down when rotating the view.
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To change view cube settings
1 Do one of the following to choose View Cube Settings:

• Click the drop-down arrow in the lower right of the view cube, and then choose 
View Cube Settings.

• Right-click the view cube and choose View Cube Settings.

• Type navvcube, press Enter, then choose Settings.

2 To change the appearance and location of the view cube, select from the following 
options:

• On-screen Position Select the corner where to display the view cube in the 
current viewport.

• Size Select the size of the view cube. If Automatic, the size adjusts automati-
cally depending on the drawing window size and number of viewports.

• Inactive Opacity Move the slider to set the opacity percentage for the view cube 
when it is inactive. The lower the number, the more transparent the view cube is. 

• Show UCS Menu Mark to display the active coordinate system drop-down menu 
below the view cube.

3 Select any of the following options, depending on your preferences for using the 
view cube:

• Snap to Closest View When Dragging Mark to adjust the current view to the 
closest preset view when dragging the view cube to rotate the view.

• Zoom to Extents after View Change Mark to automatically zoom the model to 
fit the current viewport after a view change.

• Use View Transitions When Switching Views Mark to turn on smooth view 
transitions when switching between views using the view cube.

• Orient View Cube to Current UCS Mark to orient the view cube to reflect the 
current user coordinate system. When unmarked, it is oriented to reflect the 
WCS.

• Keep Scene Upright Mark to prevent turning the viewpoint of the model upside 
down.

4 Click OK.
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Walking and flying through a drawing
Drawings can be viewed as though you are walking or flying through them

To walk through a drawing   
1 Do one of the following to choose 3D Walk ( ) or 3D Fly ( ):

• On the ribbon, choose Visualize > 3D Walk (in Animations) or 3D Fly (in 
Animations).

• On the menu, choose View > Walk and Fly > 3D Walk or 3D Fly.

• On the Walk and Fly toolbar, click the 3D Walk or 3D Fly tool.

• Type 3dwalk or 3Dfly and then press Enter.

2 Click and drag in the drawing to walk or fly through the model, or use the arrow 
keys on the keyboard. When finished, release the mouse button. 

3 Repeat to walk or fly again.

4 When finished, press Enter, right-click the drawing, or press Esc.

To customize walk and fly settings    
1 Do one of the following to choose Walk and Fly Settings ( ):

• On the ribbon, choose Visualize > Walk and Fly Settings (in Animations).

• On the menu, choose View > Walk and Fly > Walk and Fly Settings.

• On the Walk and Fly toolbar, click the Walk and Fly Settings tool.

• Type 3dwalkflysettings and then press Enter.

2 In Step Size, enter the value for the step size in drawing units, then enter the speed 
in steps per second.

3 Mark Prevent Clipping if you want to disable clipping.

4 In Lens Length, enter the value for the lens length you want to use. This value 
applies only when using the 3D Walk and 3D Fly commands; it does not change 
the default lens length that is determined by the LENSLENGTH system variable.

5 In Walk Elevation, specify the elevation to apply to walk mode during the 3D 
Walk command.

6 Click OK.
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Setting a viewpoint
You can dynamically rotate the viewpoint within the xy plane and relative to the xy 
plane, and you can pan and zoom the drawing. As you change the viewpoint settings, 
the drawing display automatically updates.    

To dynamically set a view direction    
1 Do one of the following to choose Dynamic View Control ( ):

• On the ribbon, choose View > Dynamic View Control (in Views).

• On the menu, choose View > Dynamic View Control.

• On the View toolbar, click the Dynamic View Control tool.

• Type viewctl and then press Enter.

2 Make your selections to change the viewpoint.

3 To complete the command, click OK.

A Select whether the viewing direction is relative to 
the World Coordinate System or User 
Coordinate System.

B Displays the current viewing direction settings. 
Click to select a new viewing direction.

C Enter the angle from the x-axis.
D Click to set the viewing direction to the plan view.

E Enter the angle from the xy-plane.
F Click to open the Preset Viewpoints dialog box 

and set the viewing direction using predefined 
settings.

G Click to open the View Control dialog box and set 
the viewing direction interactively with the 
drawing.

H Indicates the current viewpoint.

A

B

C
D

G

E

F

H
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To set a view direction interactively with the drawing
1 Do one of the following to choose Dynamic View Control ( ):

• On the ribbon, choose View > Dynamic View Control (in Views).

• On the menu, choose View > Dynamic View Control.

• On the View toolbar, click the Dynamic View Control tool.

• Type viewctl and then press Enter.

2 Click Adjust.

3 Make your selections to change the 3D viewing direction within the drawing.

4 Click OK.

5 To complete the command, click OK.

A Indicates the current viewpoint.
B Click to pan the drawing.
C Click to zoom extents.
D Click to zoom out.

E Click to zoom in.
F Shows the current viewpoint orientation.
G Click to rotate the view about a predefined axis.
H Type or select the rotation angle increment.

A

B
C

G

H

F

E
D
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Using a section plane to view a drawing
Section planes are used to visualize cross-sections of two- and three-dimensional 
entities and point clouds. For example, you can move a horizontal section plane that 
cuts through a multi-level building to interactively view inside the building under the 
roof, then under the top floor, etc.

A single drawing can contain multiple section planes, allowing you to create cross-
sections of different model areas. 

Section planes only apply when the graphics device is set to OpenGL ES.

Section planes are used for visualization, not documentation, of a model.
Sections and section lines (if your program version supports them) can be used to 
document a model. For more details about sections, see “Sectioning and slicing sol-
ids” on page 757 in this chapter. For details about section lines, see “Drawing a sec-
tion line” on page 173. 

Drawing section planes
You can draw section planes aligned orthographically with the current UCS or by 
specifying points.

To draw an orthographic section plane
1 Do one of the following to choose Section Plane ( ):

• On the ribbon, choose Visualize > Section Plane (in Live Sections); AEC > 
Section Plane (in Sections, if your program version supports AEC entities).

• On the menu, choose View > Live Sections > Section Plane; AEC > Section 
Planes > Section Plane (if your program version supports AEC entities).

• Type sectionplane and then press Enter.

2 Choose Orthographic.

3 Choose the orthographic orientation (relative to the UCS) that you want the sec-
tion plane to align with.

To draw a section plane by specifying points
1 Do one of the following to choose Section Plane ( ):

• On the ribbon, choose Visualize > Section Plane (in Live Sections); AEC > 
Section Plane (in Sections, if your program version supports AEC entities).
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• On the menu, choose View > Live Sections > Section Plane; AEC > Section 
Planes > Section Plane (if your program version supports AEC entities).

• Type sectionplane and then press Enter.

2 Specify a first point.

3 Specify a second point.

4 Do one of the following:

• To draw a section plane that is automatically aligned with the current view 
direction, press Enter.

• To draw a section plane with a different orientation, pick a third point to define 
its vertical direction.

You can specify the elevation and exact location of a selected section plane.
Type entprop to open the Properties pane. In Vertex, specify which vertex to change, 
then enter the x-, y-, and z-coordinates of the vertex.

Viewing a model using section planes
Use the center grip of a section plane to reposition the section plane and change the 
view of intersecting entities. Also if needed, you can turn live sectioning on or off for 
any section plane. This allows to you change whether the cross sections of intersect-
ing entities are displayed.

If the visualization of an entity is unchanged by a section plane, check that the entity 
is on a sectionable layer. For more details, see “Controlling whether a layer is sec-
tionable” on page 294. 

Section planes render with the current visual style. 
Using shaded visual styles makes it easier to see and select a section plane.

To view a model interactively using a section plane
1 Select the section plane.

2 Click and drag the double-arrow grip in the center of the section plane to move it 
and interactively visualize different areas of the model.

3 Click and drag other grips to resize the section plane, if necessary.

Section planes are infinite.
Although you can use grips to change the size of the section plane, the section plane 
is infinite. Resizing the plane helps with selecting and visualizing the plane entity.
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To turn live sectioning on or off for a section plane
1 Do one of the following to choose Live Section On/Off ( ):

• On the ribbon, choose Visualize > Live Section On/Off (in Live Sections); AEC 
> Live Section On/Off (in Sections, if your program version supports AEC 
entities).

• On the menu, choose View > Live Sections > Live Section On/Off; AEC > 
Section Planes > Live Section On/Off (if your program version supports AEC 
entities).

• Type livesection and then press Enter.

2 Select the section plane for which you want to turn live sectioning on or off.

Changing display options for the intersection area of section planes
The appearance of the intersection area where the section plane intersects entities is 
customizable. The display settings you choose apply to all section planes in the draw-
ing.

To change display options for the intersection area of section planes
1 Do one of the following to choose Section Plane Settings ( ):

• On the ribbon, choose Visualize > Section Plane Settings (in Live Sections); 
AEC > Section Plane Settings (in Sections, if your program version supports 
AEC entities).

• On the menu, choose View > Live Sections > Section Plane Settings; AEC > 
Section Planes > Section Plane Settings (if your program version supports AEC 
entities).

• Type sectionplanesettings and then press Enter.

• Choose Settings when using the Section Plane command.

2 To display the intersection area with a color or pattern that is different than the rest 
of the section plane, do the following:

• Mark Display Section Fill.

• In Fill Color, select the color used to fill the intersection area.

3 To display the intersection area with a pattern and fill, do the following:

• Mark Display Section Pattern.

• In Pattern Type, select the pattern.

• In Pattern Color, select the color for the pattern.

4 Click OK.
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Using a camera to view the drawing
Cameras define settings for 3D views of drawings according to a location and target. 
You can also specify the camera height, clipping boundaries for the view, and other 
options.

To modify a camera, select it in the drawing and move its grips or change its proper-
ties in the Properties pane. Cameras are named views that can also be changed using 
the View Manager. For more details about the Properties pane, see “Modifying the 
properties of entities” on page 406.  For more details about View Manager, see 
“Working with named views” on page 333.  

To create a camera   
1 Do one of the following to choose Create Camera ( ):

• On the ribbon, choose View > Create Camera (in Views).

• On the menu, choose View > Create Camera.

• On the View toolbar, click the Create Camera tool.

• Type camera and then press Enter.

2 Specify the camera location.

3 Specify the target point of the view.

4 Choose one of the following to specify more options:

• Name Enter a new name for the camera, then press Enter.

• Location Specify a new camera location, then press Enter.

• Height Specify the height of the camera, then press Enter.

• Target Specify a new target point for the camera view, then press Enter. The 
target location is the center of the view.

• Lens Enter the length of the lens. The greater the value, the more narrow the 
view. The value must be 600 or less millimeters.

• Clipping There are two clipping planes that help define the view. Anything 
between the camera and the front clipping plane is hidden, and anything 
between the back clipping plane and the target is hidden. Choose Yes to specify 
a front (or back) clipping plane, enter a distance, and then press Enter. Choose 
No for either option to disable the clipping plane.

• View Choose Yes to switch the current view to the camera settings when the 
camera is created. Choose No to keep the current view the same when the 
camera is created.

5 When done, press Enter.
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To switch to a camera view 
1 Do one of the following to choose View Manager ( ):     

• On the ribbon, choose View > View Manager (in Views).

• On the menu, choose View > View Manager.

• On the View toolbar, click the View Manager tool.

• Type view and then press Enter.

2 Select a camera view.

3 Click OK.

Displaying a plan view of the current drawing
You can set the current viewing direction to the plan view of the current user coordi-
nate system (UCS), a previously saved UCS, or the World Coordinate System 
(WCS).

To display a plan view of the current drawing
1 Do one of the following to choose Plan View ( ):    

• On the ribbon, choose View > Plan View (in Views).

• On the menu, choose View > Plan View.

• On the View toolbar, click the Plan View tool.

• Type plan and then press Enter.

2 In the prompt box, choose one of the following:

• Current displays the plan view of the current UCS.

• UCS displays the plan view of a saved UCS. The program prompts you for the 
name of the UCS.

• World displays the plan view of the WCS.
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Creating three-dimensional entities   

IntelliCAD supports the following types of three-dimensional models:   

• Wire-frame models, which consist of lines and curves that define the edges of a 
three-dimensional entity. You can create a wire-frame model by drawing lines, 
arcs, polylines, and other two-dimensional entities anywhere in three-dimensional 
space. Wire-frame models have no surfaces; they always appear as outlines. 
Because you must individually draw and position each entity that makes up a 
wire-frame model, creating one can be exacting and time-consuming.       

• Surface models, which consist of both edges and the surfaces between those 
edges. You can create a surface model by applying elevation and thickness to two-
dimensional planar entities or by using specific three-dimensional entity-creation 
commands. Surface models consist of individual planes forming a faceted, polyg-
onal mesh.

• Facet model meshes, which are smart surface model entities that can be combined 
into composite meshes and rendered more like solids. 

• 3D solids, which are three-dimensional ACIS entities that consist of faces and 
edges. 3D solids appear to have volume and are easier to work with than wire-
frame and surface models. IntelliCAD supports viewing and limited editing of 3D 
solids, including moving, rotating and scaling. Additionally, some versions of 
IntelliCAD allow you to create and more completely edit 3D solids. 

Applying elevation and thickness
By default, the program creates new two-dimensional entities with a zero elevation 
and thickness. The easiest way to create a three-dimensional entity is to change the 
elevation or thickness property of an existing two-dimensional entity.        

The elevation of an entity is its z-coordinate position in relation to the xy plane in 
which the entity is drawn. An elevation of 0 indicates that the entity is drawn on the 
xy plane of the current UCS. Positive elevations are above this plane; negative eleva-
tions are below it.    
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The thickness of an entity is the distance it is extruded above or below its elevation. A 
positive thickness extrudes the entity upward in the positive z direction of the entity; 
a negative thickness extrudes it downward in the negative z direction. The thickness 
is applied uniformly to the entire entity. You can extrude any two-dimensional entity 
into a three-dimensional entity by changing the thickness of the entity to a nonzero 
value. For example, a circle becomes a cylinder, a line becomes a three-dimensional 
plane, and a rectangle becomes a box.      

You can create three-dimensional entities using any of the following methods:

• Draw two-dimensional entities in three-dimensional space.    

• Convert two-dimensional planar entities into three-dimensional entities by apply-
ing elevation and thickness.

• Convert two-dimensional planar entities into three-dimensional entities by revolv-
ing or extruding.

• Create three-dimensional entities such as boxes, cylinders, cones, domes, spheres, 
and wedges. 

Three-dimensional solids are drawn as true solids with versions of IntelliCAD that support 
three-dimensional ACIS solids. 
Three-dimensional solids that you can create include: box, cone, cylinder, dish, 
dome, pyramid, sphere, torus, and wedge.

You can change the default elevation and thickness values to create new entities with 
an elevation and thickness already applied.

To set the current elevation    
1 Do one of the following to choose Elevation ( ):

• On the ribbon, choose Draw > Elevation (in Settings).

• On the menu, choose Format > Elevation.

• On the Format toolbar, click the Elevation tool.

• Type elev and then press Enter.

2 Specify the New Current Value For Elevation, and then press Enter. 

Two-dimensional entities. Two-dimensional entities with thickness added.
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To set the current thickness    
1 Do one of the following to choose Thickness ( ):

• On the ribbon, choose Draw > Thickness (in Settings).

• On the menu, choose Format > Thickness.

• On the Format toolbar, click the Thickness tool.

• Type thickness and then press Enter.

2 Specify the New Current Value For Thickness, and then press Enter.

To set the current elevation and thickness using a dialog box    
1 Do one of the following to choose Drawing Settings ( ):

• On the ribbon, choose Application button > Drawing Utilities; Home > Drawing 
Settings (in Utilities); or Tools > Drawing Settings (in Manage).

• On the menu, choose Tools > Drawing Settings.

• On the Tools toolbar, click the Drawing Settings tool.

• Type dsettings and then press Enter.

2 Click the 3D Settings tab.

3 Click the Surfaces tab.

4 To change the current thickness, in the Current 3D Thickness box, type a new 
thickness value or click the arrows to select a new thickness.

5 To change the current elevation, in the Current 3D Elevation box, type a new ele-
vation value or click the arrows to select a new elevation.

6 Click OK.



D R A W I N G  I N  T H R E E  D I M E N S I O N S 709
  

To change the thickness and elevation of an existing entity    
1 Do one of the following to choose Properties ( ):

• On the ribbon, choose View > Properties (in Panes).

• On the menu, choose View > Display > Properties or Modify > Properties.

• On the Modify toolbar, click the Properties tool.

• Type entprop and then press Enter.

2 Select the entity, and then press Enter.

IntelliCAD displays the Properties palette (its exact appearance depends on the 
type of entity you select).

3 To change the thickness, in the Thickness box, type a new thickness value or click 
the arrows to select the new thickness.

4 To change the elevation, in the Z coordinate box (or some entities have an Eleva-
tion box), type a new elevation value or click the arrows to select the new eleva-
tion.    

5 Click OK.

A Type or select the current three-dimensional 
thickness.

B Type or select the current three-dimensional 
elevation.

A
B
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When you change the thickness of an entity, you do not change the entity type. 
If you want to extrude an entity and convert it to a three-dimensional solid, use the 
Extrude command. If you want to thicken a surface or mesh entity and convert it to a 
three-dimensional solid, use the Thicken command.    

 

A Type or select the new thickness. B Type or select the new elevation.   

A

B
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Creating three-dimensional faces 
You can create a three-dimensional face, which consists of a section of a plane in 
three-dimensional space. You define a three-dimensional face by specifying the x,y,z 
coordinates of three or more corners. After you specify the fourth point, the program 
continues to prompt you for additional faces by alternating prompts for the third point 
and fourth point to allow you to build a complex three-dimensional entity. Each 
three- or four-sided plane is created as a separate three-dimensional face entity.    

To create a three-dimensional face    
Advanced experience level

1 Do one of the following to choose Face ( ):

• On the ribbon, choose Draw 3D > 3D Face (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Face.

• On the Draw 3D Meshes  toolbar, click the Face tool.

• Type face and then press Enter.

2 Specify the first point of the three-dimensional face.

3 Specify the second, third, and fourth points.

4 Specify the third and fourth points for additional faces. 

5 To complete the command, press Enter.

Any or all edges of a three-dimensional face can be invisible to allow you to more accu-
rately model entities with holes in them. 
As the program prompts you for the corner points, in the prompt box, choose Invisi-
ble Edge to make the next edge invisible. Or after the 3D face is drawn, use the Edge 
command. For details about the Edge command,      

 

An example of a three-dimensional model created using three-dimensional faces.
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Creating rectangular meshes
You can create a three-dimensional rectangular mesh consisting of four-sided poly-
gons. You determine the size of the mesh by specifying the number of vertices along 
the primary (M-direction) and secondary (N-direction) mesh axes and then specifying 
the coordinates for each vertex.    

To create a rectangular mesh    
Advanced experience level

1 Do one of the following to choose Mesh ( ):

• On the ribbon, choose Draw 3D > Meshes (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Mesh.

• On the Draw 3D Meshes toolbar, click the Mesh tool.

• Type mesh and then press Enter.

2 Specify the number of vertices along the primary mesh axis.

3 Specify the number of vertices along the secondary mesh axis.

4 Specify the coordinates for each vertex.

Specifying the coordinates for the last vertex completes the mesh and ends the 
command. 

Although creating rectangular meshes manually can be exacting, they are useful for repre-
senting complex surfaces such as three-dimensional terrain models. 
The Mesh tool is most useful when combined with scripts or LISP programs that 
mathematically calculate the coordinates of the vertices.     

 

An example of a three-dimensional terrain model created using rectangular meshes.
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Creating polyface meshes
You can create a polygon mesh consisting of faces connecting three or more vertices. 
You first determine the coordinates of each vertex and then define each face by enter-
ing the vertex numbers for all the vertices of that face. As you create each face, you 
can control the visibility and color of each edge and assign each edge to specific lay-
ers.    

To create a polyface mesh    
Advanced experience level

1 Do one of the following to choose Polyface Mesh ( ):    

• On the ribbon, choose Draw 3D > Polyface Mesh (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Polyface Mesh.

• On the Draw 3D Meshes toolbar, click the Polyface Mesh tool.

• Type pface and then press Enter.

2 Specify the coordinates of each vertex.

After each vertex that you specify, the next vertex number is displayed, and you 
are prompted for the coordinates of the vertex. Specify the coordinates, and then 
press Enter. Continue to specify the coordinates for each numbered vertex.

3 To finish specifying vertex coordinates, press Enter.

4 Specify the vertex numbers that define the first face. 

You specify the face by entering the vertex numbers that were defined when you 
specified coordinates in step 2. Each face can be composed of three or more num-
bered vertices.

5 To finish defining the first face, press Enter.

6 Specify the next face by entering its vertex numbers.

7 To complete the command, press Enter.

Edges can be made invisible. 
Type the vertex number as a negative value.    
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Creating ruled surface meshes
You can create a ruled surface, which is a three-dimensional polygon mesh that 
approximates the surface between two existing entities. You select the two entities 
that define the ruled surface. These entities can be arcs, circles, lines, points, or 
polylines.

To create a ruled surface mesh   
Advanced experience level

1 Do one of the following to choose Ruled Surface ( ):

• On the ribbon, choose Draw 3D > Ruled Surface (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Ruled Surface.

• On the Draw 3D Meshes toolbar, click the Ruled Surface tool.

• Type rulesurf and then press Enter.

2 Select the first defining entity.

3 Select the second defining entity.

The value of the Number of M-Direction Surfaces controls the density of the mesh.
Choose Tools > Drawing Settings, click the 3D Settings tab. click the Surfaces tab, 
then under Surface Settings, change the Number Of M-Direction Surfaces value.

Creating extruded meshes
You can create an extruded mesh, which is a three-dimensional polygon mesh that 
approximates the surface generated by extruding a profile curve along a path. You 
select the two entities that define the path curve and direction vector. The length of 
the direction vector determines the distance the path curve is moved along the direc-
tion vector. The extruded entity can be an arc, circle, line, or polyline. You can 
choose a line or open polyline as the direction vector. The resulting mesh consists of 
a series of parallel polygonal planes running along the specified path. 

You can create two types of extruded meshes:

• Facet model meshes are smart meshes that can be modified with advanced features 
such as boolean operations. They are similar to solids but are more lightweight 
and don’t have mass properties.

• Surface meshes are simple meshes.

Select the first (A) and second (B) defining entities. The resulting ruled surface mesh.

A

B
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To create an extruded facet model mesh      
1 Do one of the following to choose Extrude ( ):

• On the ribbon, choose Draw 3D > Extrude (in Facet Model Meshes).

• On the menu, choose Draw > Facet Model Meshes > Extruded.

• On the Facet Model Meshes toolbar, click the Extrude tool.

• Type fmextrude and then press Enter.

2 Select the entity to extrude.

3 Select the extrusion path, specify the direction, or specify the height.

To create an extruded surface mesh      
1 Do one of the following to choose Extruded Surface ( ):

• On the ribbon, choose Draw 3D > Extruded Surface (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Extruded Surface.

• On the Draw 3D Meshes toolbar, click the Extruded Surface tool.

• Type ai_tabsurf and then press Enter.

2 Select the entity to extrude.

3 Select the extrusion path.

The value of the Number of M-Direction Surfaces controls the density of the mesh. 
Choose Tools > Drawing Settings, click the 3D Settings tab, click the Surfaces tab, 
then under Surface Settings, change the Number Of M-Direction Surfaces.

An extruded mesh is different from an extruded solid. 
If you want to extrude an entity and convert it to a three-dimensional solid, use the 
Extrude command. Note that you can also use the Extrude command to create an 
extruded surface. For more details, see “Creating extruded solids or surfaces” on 
page 735 in this chapter. 

Select the entity to extrude (A) and the extrusion 
path (B).

The resulting extruded 
surface mesh.

A B
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Creating revolved meshes
You can create a revolved mesh, which is a three-dimensional polygon mesh that 
approximates the surface generated by rotating a two-dimensional profile around an 
axis. You select the two entities that define the profile and the axis. You also specify 
the starting angle and the number of degrees to revolve the profile.

Revolving the profile 360 degrees creates a closed three-dimensional mesh. 

You can create two types of revolved meshes:

• Facet model meshes are smart meshes that can be modified with advanced features 
such as boolean operations. They are similar to solids but are more lightweight 
and don’t have mass properties.

• Surface meshes are simple meshes. Note that the Number Of M-Direction Sur-
faces value determines the mesh density (the number of mesh segments) in the M-
direction (around the axis of revolution). The N-Direction Mesh Density value 
determines the mesh density (the number of mesh segments) in the N-direction 
(along the axis of revolution).

To create a revolved facet model mesh    
1 Do one of the following to choose Revolve ( ):

• On the ribbon, choose Draw 3D > Revolve (in Facet Model Meshes).

• On the menu, choose Draw > Facet Model Meshes > Revolve.

• On the Facet Model Meshes toolbar, click the Revolve tool.

• Type fmrevolve and then press Enter.

2 Select the entity to revolve.

3 Do one of the following to define the axis of revolution:

• Specify a start point and an end point.

• Choose Entity and press Enter to select an entity that determines the axis.

• Choose Xaxis to select the x-axis.

• Choose Yaxis to select the y-axis.

4 Specify the angle of revolution.
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To create a revolved surface mesh    
1 Do one of the following to choose Revolved Surface ( ):

• On the ribbon, choose Draw 3D > Revolved Surface (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Revolved Surface.

• On the Draw 3D Meshes toolbar, click the Revolved Surface tool.

• Type revsurf and then press Enter.

2 Select the entity to revolve.

3 Select the entity to be used as the axis of revolution.

4 Specify the starting angle.

5 Specify the number of degrees to revolve the entity.

The values of the Number of M-Direction Surfaces and N-Direction Mesh Density control 
the density of the mesh.
Choose Tools > Drawing Settings, click the 3D Settings tab, click the Surfaces tab, 
then under Surface Settings, change the Number Of M-Direction Surfaces and N-
Direction Mesh Density values. 

Revolved surfaces can also be created using the Revolve command.
The Revolve command is typically used for creating revolved three-dimensional sol-
ids, but it can also be used to create a revolved surface. For more details, see “Creat-
ing revolved solids or surfaces” on page 736 in this chapter. 

Select the entity to be revolved (A) and the 
axis of revolution (B).

The resulting revolved surface 
mesh.

A

B
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Creating edge-defined Coons surface patch meshes
You can create a surface called a Coons surface patch, which is a mesh connecting 
four edges. You select the entities that define the edges. Edge entities can be arcs, 
splines, lines, or polylines. The four edge entities must be touching and form a closed 
loop. A patch is a bicubic surface (one curve extends in the M-direction and the other 
in the N-direction) interpolated between the four adjoining edges. You can select the 
edges in any order. The first edge you select determines the M-direction of the mesh.

To create an edge-defined Coons surface patch mesh    
Advanced experience level

1 Do one of the following to choose Coons Surface ( ):

• On the ribbon, choose Draw 3D > Coons Surface (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Coons Surface.

• On the Draw 3D Meshes toolbar, click the Coons Surface tool.

• Type edgesurf and then press Enter.

2 Select the first edge.

3 Select the second, third, and fourth edges.

The values of the Number of M-Direction Surfaces and N-Direction Mesh Density control 
the density of the mesh. 
Choose Tools > Drawing Settings, click the 3D Settings tab, click the Surfaces tab. 
then under Surface Settings, change the Number Of M-Direction Surfaces and N-
Direction Mesh Density values.

Select the entities to be used as the four 
edges (A, B, C, and D).

The resulting Coons surface patch mesh.

A
B

C

D
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Creating boxes     
You can create rectangular boxes, or cubes. A box consists of six rectangular surface 
planes. The base of the box is always parallel with the xy plane of the current UCS. 
You position the box by specifying either a corner or the center of the box. You deter-
mine the size of the box by either specifying a second corner and the height; defining 
the box to be a cube and then providing its length; or specifying the length, width, and 
height.   

To create a box as an ACIS solid 
1 Do one of the following to choose Box ( ):

• On the ribbon, choose Draw 3D > Box (in Draw 3D Solids).

• On the menu, choose Draw > 3D Solids > Box.

• On the Draw 3D Solids toolbar, click the Box tool.

• Type box and then press Enter.

2 Specify the first corner of the base.

3 Specify the opposite corner of the base.

4 Specify the height. 

To create a box as a Facet Model mesh 

1 Do one of the following to choose Box ( ):

• On the ribbon, choose Draw 3D > Box (in Facet Model Meshes).

• On the menu, choose Draw > Facet Model Meshes > Box.

• On the Facet Model Meshes toolbar, click the Box tool.

• Type fmbox and then press Enter.

2 Specify the first corner of the base.

3 Specify the opposite corner of the base.

4 Specify the height.  

To create a box as a 3D mesh 

1 Do one of the following to choose Box ( ):

• On the ribbon, choose Draw 3D > Box (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Box.

• On the Draw 3D Meshes toolbar, click the Box tool.

• Type ai_box and then press enter.

2 Specify the first corner of the base.

3 Specify the opposite corner of the base.

4 Specify the height.  
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Creating wedges
You can create three-dimensional wedges consisting of five surface planes. The base 
of the wedge is always parallel with the xy plane of the current UCS with the sloped 
face opposite the first corner. The height is always parallel with the z-axis. You posi-
tion the wedge by specifying either a corner or the center of the wedge. You deter-
mine the size of the wedge by either specifying a second corner and the height; 
defining the wedge based on a cube having a given length; or specifying the length, 
width, and height.    

To create a wedge as an ACIS solid 
1 Do one of the following to choose Wedge ( ):

• On the ribbon, choose Draw 3D > Wedge (in Draw 3D Solids).

• On the menu, choose Draw > 3D Solids > Wedge.

• On the Draw 3D Solids toolbar, click the Wedge tool.

• Type wedge and then press Enter.

2 Specify the first corner of the base.

3 Specify the opposite corner of the base.

4 Specify the height. 

To create a wedge as a 3D mesh

1 Do one of the following to choose Wedge ( ):

• On the ribbon, choose Draw 3D > Wedge (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Wedge.

• On the Draw 3D Meshes toolbar, click the Wedge tool.

• Type ai_wedge and then press Enter.

2 Specify the first corner of the base.

3 Specify the opposite corner of the base.

4 Specify the height. 

First corner of the base (A), the opposite corner of the base (B), and the height (C).

A

C

B
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Creating cones
You can create three-dimensional cones defined by a circular base and tapering to a 
point perpendicular to the base. The base of the cone is always parallel with the xy 
plane of the current UCS; the height of the cone is always parallel with the z-axis. 
You position the cone by specifying the center of the base. You determine the size of 
the cone by specifying either the radius or the diameter of the base and the height.    

To create a cone as an ACIS solid 
1 Do one of the following to choose Cone ( ):

• On the ribbon, choose Draw 3D > Cone (in Draw 3D Solids).

• On the menu, choose Draw > 3D Solids > Cone.

• On the Draw 3D Solids toolbar, click the Cone tool.

• Type cone and then press Enter.

2 Specify the center of the base of the cone.

3 Specify the radius or diameter.

4 Specify the height by doing one of the following:

• Enter the height of the cone, or select a point to indicate the height.

• Choose Apex to draw a cone with an offset top, and then select a point for the 
tip of the cone.

• Choose 2Point to specify the height by picking two points, and then select the 
two points.

First corner of the base (A), the opposite corner of the base (B), and the height (C).

A

C

B
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To create a cone as a Facet Model mesh
1 Do one of the following to choose Cone ( ):

• On the ribbon, choose Draw 3D > Cone (in Facet Model Meshes).

• On the menu, choose Draw > Facet Model Meshes > Cone.

• On the Facet Model Meshes toolbar, click the Cone tool.

• Type fmcone and then press Enter.

2 Specify the center of the base of the cone.

3 Specify the base radius or diameter.

4 Specify the height.

To create a cone as a 3D mesh
1 Do one of the following to choose Cone ( ):

• On the ribbon, choose Draw 3D > Cone (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Cone.

• On the Draw 3D Meshes toolbar, click the Cone tool.

• Type ai_cone and then press Enter.

2 Specify the center of the base of the cone.

3 Specify the radius or diameter.

4 Specify the height.

Creating pyramids
You can create tetrahedrons (three-sided pyramids) or four-sided pyramids. The sides 
of the resulting pyramid can meet at a point (the apex) or can form a three- or four-
edged top. The sides of a four-sided pyramid can also meet along a ridge defined by 
two points. The base of the pyramid is always parallel with the xy plane of the current 
UCS. You position the pyramid by specifying a corner of the base. You determine the 
size of the pyramid by specifying the base points and either the apex, the corners of 
the top surface, or the endpoints of the ridge.       

Center of the base (A), the radius of the base (B), and the height (C).

A

C

B
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To create a tetrahedron as an ACIS solid   
1 Do one of the following to choose Pyramid ( ):

• On the ribbon, choose Draw 3D > Pyramid (in Draw 3D Solids).

• On the menu, choose Draw > 3D Solids > Pyramid.

• On the Draw 3D Solids toolbar, click the Pyramid tool.

• Type pyramid and then press Enter.

2 Specify the first point for the base of the pyramid.

3 Specify the second and third points.

4 In the prompt box, choose Tetrahedron.

5 Specify the apex of the tetrahedron.

To create a tetrahedron as a 3D mesh
1 Do one of the following to choose Pyramid ( ):

• On the ribbon, choose Draw 3D > Pyramid (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Pyramid.

• On the Draw 3D Meshes toolbar, click the Pyramid tool.

• Type ai_pyramid and then press Enter.

2 Specify the first point for the base of the pyramid.

3 Specify the second and third points.

4 In the prompt box, choose Tetrahedron.

5 Specify the apex of the tetrahedron.

The first point (A), second point (B), and third point (C) of the base, and the apex (D).

A

B

C

D
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To create a pyramid as a Facet Model mesh 
1 Do one of the following to choose Pyramid ( ): 

• On the ribbon, choose Draw 3D > Pyramid (in Facet Model Meshes).

• On the menu, choose Draw > Facet Model > Pyramid.

• On the Facet Model Meshes toolbar, click the Pyramid tool.

• Type fmpyramid and then press Enter.

2 Specify the center point for the base of the pyramid.

3 Specify the radius for the base of the pyramid.

4 Specify the height.

To create a pyramid with a planar top as an ACIS solid 
1 Do one of the following to choose Pyramid ( ): 

• On the ribbon, choose Draw 3D > Pyramid (in Draw 3D Solids).

• On the menu, choose Draw > 3D Solids > Pyramid.

• On the Draw 3D Solids toolbar, click the Pyramid tool.

• Type pyramid and then press Enter.

2 Specify the first point for the base of the pyramid.

3 Specify the second, third, and fourth points.

4 In the prompt box, choose Top Surface.

5 Specify the first point on the top surface of the pyramid.

6 Specify the second, third, and fourth points.

To create a pyramid with a planar top as a 3D mesh 
1 Do one of the following to choose Pyramid ( ): 

• On the ribbon, choose Draw 3D > Pyramid (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Pyramid.

• On the Draw 3D Meshes toolbar, click the Pyramid tool.

• Type ai_pyramid and then press Enter.

2 Specify the first point for the base of the pyramid.

3 Specify the second, third, and fourth points.

4 In the prompt box, choose Top Surface.

5 Specify the first point on the top surface of the pyramid.

6 Specify the second, third, and fourth points.



D R A W I N G  I N  T H R E E  D I M E N S I O N S 725
.

Creating cylinders
You can create cylinders defined by a circular base. The base of a cylinder is always 
parallel with the xy plane of the current UCS; the height of a cylinder is always paral-
lel with the z-axis. You position a cylinder by specifying the center of the base. You 
determine the size of a cylinder by specifying either the radius or diameter of the base 
and the height.

To create a cylinder as an ACIS solid 

1 Do one of the following to choose Cylinder ( ):

• On the ribbon, choose Draw 3D > Cylinder (in Draw 3D Solids).

• On the menu, choose Draw > 3D Solids > Cylinder. 
• On the Draw 3D Solids toolbar, click the Cylinder tool.

• Type cylinder and then press Enter.

2 Specify the center of the base of the cylinder.

3 Specify the radius or diameter.

4 Specify the height by doing one of the following:

• Enter the height of the cylinder, or select a point to indicate the height.

• Choose Center of Second End to draw a cylinder with a slanted wall, and then 
specify the center point for the second end.

• Choose 2Point to specify the height by picking two points, and then select the 
two points.

The first point (A), second point (B), third point (C), and fourth point (D) of the base, and the first point (E), 
second point (F), third point (G), and fourth point (H) of the top surface.

A

B

C

D

E

F
G

H
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To create a cylinder as a Facet Model mesh
1 Do one of the following to choose Cylinder ( ):

• On the ribbon, choose Draw 3D > Cylinder (in Facet Model Meshes).

• On the menu, choose Draw > Facet Model > Cylinder. 
• On the Facet Model Meshes toolbar, click the Cylinder tool.

• Type fmcylinder and then press Enter.

2 Specify the center of the base of the cylinder.

3 Specify the radius or diameter.

4 Specify the height.

To create a cylinder as a 3D mesh
1 Do one of the following to choose Cylinder ( ):

• On the ribbon, choose Draw 3D > Cylinder (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Cylinder. 
• On the Draw 3D Meshes toolbar, click the Cylinder tool.

• Type ai_cylinder and then press Enter.

2 Specify the center of the base of the cylinder.

3 Specify the radius or diameter.

4 Specify the height.

Creating spheres
You can create spheres. The latitude lines of a sphere are always parallel with the xy 
plane of the current UCS; the central axis is always parallel with the z-axis. You posi-
tion a sphere by specifying its center point. You determine the size of a sphere by 
specifying either its radius or its diameter.

Center of the base (A), radius of the base (B), and the height (C).

A

B

C
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To create a sphere as an ACIS solid 

1 Do one of the following to choose Sphere ( ):

• On the ribbon, choose Draw 3D > Sphere (in Draw 3D Solids).

• On the menu, choose Draw > 3D Solids > Sphere.   
• On the Draw 3D Solids toolbar, click the Sphere tool.

• Type sphere and then press Enter.

2 Specify the center of the sphere.

3 Specify the radius or diameter.

To create a sphere as a Facet Model mesh
1 Do one of the following to choose Sphere ( ):

• On the ribbon, choose Draw 3D > Sphere (in Facet Model Meshes).

• On the menu, choose Draw > Facet Model > Sphere.   
• On the Facet Model Meshes toolbar, click the Sphere tool.

• Type fmsphere and then press Enter.

2 Specify the center of the sphere.

3 Specify the radius or diameter.

To create a sphere as a 3D mesh
1 Do one of the following to choose Sphere ( ):

• On the ribbon, choose Draw 3D > Sphere (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Sphere.   
• On the Draw 3D Meshes toolbar, click the Sphere tool.

• Type ai_sphere and then press Enter.

2 Specify the center of the sphere.

3 Specify the radius or diameter.

4 Specify the number of longitudinal sections that are perpendicular to the xy plane.

5 Specify the number of latitudinal sections that are parallel to the xy plane.

Center (A) and radius (B) of the sphere. The resulting sphere.

A

B
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Creating dishes
You can create a three-dimensional dish. The latitude lines of a dish are always paral-
lel with the xy plane of the current UCS; the central axis is always parallel with the z-
axis. You position a dish by specifying its center point. You determine the size of a 
dish by specifying either its radius or its diameter.

To create a dish as an ACIS solid 

1 Do one of the following to choose Dish ( ):

• On the ribbon, choose Draw 3D > Dish (in Draw 3D Solids).

• On the menu, choose Draw > 3D Solids > Dish.     
• On the Draw 3D Solids toolbar, click the Dish tool.

• Type dish and then press Enter.

2 Specify the center of the dish.

3 Specify the radius or diameter.

To create a dish as a 3D mesh
1 Do one of the following to choose Dish ( ):

• On the ribbon, choose Draw 3D > Dish (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Dish.

• On the Draw 3D Meshes toolbar, click the Dish tool.

• Type ai_dish and then press Enter.

2 Specify the center of the dish.

3 Specify the radius or diameter.
.

Creating domes
You can create a three-dimensional dome. The latitude lines of a dome are always 
parallel with the xy plane of the current UCS; the central axis is always parallel with 
the z-axis. You position a dome by specifying its center point. You determine the size 
of a dome by specifying either its radius or its diameter.

Center (A) and radius (B) of the dish.

A

B
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To create a dome as an ACIS solid 

1 Do one of the following to choose Dome ( ):

• On the ribbon, choose Draw 3D > Dome (in Draw 3D Solids).

• On the menu, choose Draw > 3D Solids > Dome.

• On the Draw 3D Solids toolbar, click the Dome tool.

• Type dome and then press Enter.

2 Specify the center of the dome.

3 Specify the radius or diameter.

To create a dome as a 3D mesh
1 Do one of the following to choose Dome ( ):

• On the ribbon, choose Draw 3D > Dome (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Dome.

• On the Draw 3D Meshes toolbar, click the Dome tool.

• Type ai_dome and then press Enter.

2 Specify the center of the dome.

3 Specify the radius or diameter.

Creating tori
You can create a three-dimensional donut or ring-shaped entity known as a torus. The 
diameter of a ring is always parallel with the xy plane of the current UCS. A torus is 
constructed by revolving a circle about a line drawn in the plane of the circle and par-
allel with the z-axis of the current UCS. You position a torus by specifying its center 
point. You determine the size of a torus by specifying its overall diameter or radius 
and the diameter or radius of the tube (the circle being revolved).

Center (A) and radius (B) of the dome.

A

B
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To create a torus as an ACIS solid 

1 Do one of the following to choose Torus ( ):

• On the ribbon, choose Draw 3D > Torus (in Draw 3D Solids).

• On the menu, choose Draw > 3D Solids > Torus. 
• On the Draw 3D Solids toolbar, click the Torus tool.

• Type torus and then press Enter.

2 Specify the center of the whole torus.

3 Specify the radius or diameter of the whole torus.

4 Specify the radius or diameter of the body of the torus.

To create a torus as a Facet Model mesh
1 Do one of the following to choose Torus ( ):

• On the ribbon, choose Draw 3D > Torus (in Facet Model Meshes).

• On the menu, choose Draw > Facet Model Meshes > Torus. 
• On the Facet Model Meshes toolbar, click the Torus tool.

• Type fmtorus and then press Enter.

2 Specify the center of the whole torus.

3 Specify the radius or diameter of the whole torus.

4 Specify the radius or diameter of the body (tube) of the torus.

To create a torus as a 3D mesh
1 Do one of the following to choose Torus ( ):

• On the ribbon, choose Draw 3D > Torus (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Torus. 
• On the Draw 3D Meshes toolbar, click the Torus tool.

• Type ai_torus and then press Enter.

2 Specify the center of the whole torus.

3 Specify the radius or diameter of the whole torus.

4 Specify the radius or diameter of the body of the torus.

5 Specify the number of longitudinal sections that are perpendicular to the xy plane.

6 Specify the number of latitudinal sections that are parallel to the xy plane.
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Creating pipes
You can create a three-dimensional pipe, which is a hollow cylinder or tube. Pipes are 
created by specifying the base center, radius or diameter, wall thickness, and length. 
Pipes are created as Facet Model meshes.

To create a pipe as a Facet Model mesh
1 Do one of the following to choose Pipe ( ):

• On the ribbon, choose Draw 3D > Pipe (in Facet Model Meshes).

• On the menu, choose Draw > Facet Model Meshes > Pipe. 
• On the Facet Model Meshes toolbar, click the Pipe tool.

• Type fmpipe and then press Enter.

2 Specify the base center of the pipe.

3 Do one of the following:

• Enter the radius, or specify a second point to indicate the radius. 

• Choose Diameter, and then enter the diameter, or specify a second point to 
indicate the diameter.

4 Enter the thickness of the pipe wall, or choose 2Point to specify two points that 
indicate the thickness.

5 Enter the length, or specify a point to indicate the length.

Center (A) and radius of the whole torus (B), and the radius of the body (C).

A

B C
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Creating helices
You can create a three-dimensional helix, which is a spiral-shaped entity, as a facet 
model mesh. Helices are created by specifying the base, top, turns, and height or axis 
endpoint.

To create a helix as a Facet Model mesh
1 Do one of the following to choose Helix ( ):

• On the ribbon, choose Draw 3D > Helix (in Facet Model Meshes).

• On the menu, choose Draw > Facet Model Meshes > Helix. 
• On the Facet Model Meshes toolbar, click the Helix tool.

• Type fmhelix and then press Enter.

2 Specify the radius of the helix body (tube).

3 Specify the center point of the helix base.

4 Do one of the following to specify the bottom of the helix:

• Enter the radius, or specify a second point to indicate the radius.

• Choose Diameter, and then enter the diameter or specify a second point to 
indicate the diameter.

5 Do one of the following to specify the top of the helix:

• Enter the radius, or specify a second point to indicate the radius. 

• Choose Diameter, and then enter the diameter or specify a second point to 
indicate the diameter.

6 Optionally define the turns of the helix:

• Choose Turns, then enter the number of full turns. The maximum is 500.

• Choose turn Height, then specify the height of one full turn.

• Choose tWist, then specify the direction of helix turns, which can be clockwise 
(CW) or counterclockwise (CCW).

7 Do one of the following:

• Specify the height of the helix.

• Choose Axis endpoint, then specify the endpoint of the helix, which determines 
the position and direction of the helix.
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Creating regions   
You can convert a closed entity into a two-dimensional region. After you create a 
region, you can modify it using the various three-dimensional tools. For example, you 
can create a region from a square, and then extrude the square to create a three-
dimensional cube.

You can create regions from closed entities, such as polylines, polygons, circles, 
ellipses, closed splines, and donuts. You can also select open entities such as lines 
and arcs, if they have common endpoints and they form a closed area.       

Creating regions typically has no visible effect on a drawing. However, if the original 
entity had a width or lineweight, that information is lost when you create the region.    

To create a region
1 Do one of the following to choose Region ( ):

• On the ribbon, choose Draw 3D > Region (in Draw 3D Solids).

• On the menu, choose Draw > 3D Solids > Region.

• On the Draw 3D Solids toolbar, click the Region tool.

• Type region and then press Enter.

2 Select the entities to create the region.

3 Press Enter.

The command bar displays a message that describes how many regions were cre-
ated.

The Boundary command can also be used to create regions.
For more details, see “Defining boundaries” on page 209. 
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Creating planar surfaces   
You can create planar surfaces by drawing a rectangle or selecting existing closed, 
planar entities such as polylines, polygons, circles, ellipses, closed splines, and 
donuts. You can also select open entities such as lines and arcs, if they have common 
endpoints and they form a closed area.

To create a rectangular planar surface
1 Do one of the following to choose Planar Surface ( ):

• On the ribbon, choose Draw 3D > Planar Surface (in Surfaces).

• On the menu, choose Draw > Surfaces > Planar Surface.

• On the Draw 3D Surfaces toolbar, click the Planar Surface tool.

• Type planesurf and then press Enter.

2 Specify a point for the first corner.

3 Specify a point for the opposite corner. 

To create a planar surface from existing entities
1 Do one of the following to choose Planar Surface ( ):

• On the ribbon, choose Draw 3D > Planar Surface (in Surfaces).

• On the menu, choose Draw > Surfaces > Planar Surface.

• On the Draw 3D Surfaces toolbar, click the Planar Surface tool.

• Type planesurf and then press Enter.

2 Choose Entity.

3 Select closed, planar entities, then press Enter.
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Creating extruded solids or surfaces
You can create three-dimensional solids or surfaces by extruding closed entities, such 
as polylines, polygons, circles, ellipses, closed splines, donuts, and regions. You can 
extrude the entity along a selected path, or you can specify its height and taper angle.

To create an extruded solid or surface   
1 Do one of the following to choose Extrude ( ) ( ):

• On the ribbon, choose Draw 3D > Extrude (in Draw 3D Solids or in Surfaces).

• On the menu, choose Draw > 3D Solids > Extrude or Draw > Surfaces > 
Extrude.

• On the Draw 3D Solids or the Draw 3D Surfaces toolbar, click the Extrude tool.

• Type extrude and then press Enter.

2 Select the entity to extrude.

If you want to create an extruded surface instead of a solid, choose Mode. If an 
open profile is selected, a surface is created even if Mode is set to Solid.

3 Select the extrusion path, or specify the height.

Select the entity to extrude (A) and the extrusion 
path (B).

The resulting extruded 
solid.

A B
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Creating revolved solids or surfaces
You can create three-dimensional solids or surfaces by revolving closed entities, such 
as polylines, polygons, circles, ellipses, and regions. You can revolve the entity about 
a defined axis, line, polyline, or two points.

To create a revolved solid or surface    
1 Do one of the following to choose Revolve ( ) ( ):

• On the ribbon, choose Draw 3D > Revolve (in Draw 3D Solids or in Surfaces).

• On the menu, choose Draw > 3D Solids > Revolve or Draw > Surfaces > 
Revolve.

• On the Draw 3D Solids or the Draw 3D Surfaces toolbar, click the Revolve tool.

• Type revolve and then press Enter.

2 Select the entity to revolve.

If you want to create a revolved surface instead of a solid, choose Mode. If an 
open profile is selected, a surface is created even if Mode is set to Solid.

3 Do one of the following to define the axis of revolution:

• Specify a start point and an end point.

• Type e and press Enter to select an entity that determines the axis.

• Type x and press Enter to select the x-axis.

• Type y and press Enter to select the y-axis.

4 Specify the angle of revolution.

Select the entity to revolve (A) and the 
axis (B) about which to revolve it, 
followed by the angle of revolution.

The resulting revolved 
solid.
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Creating lofted solids and surfaces
Creates a three-dimensional solid or surface between two or more cross sections. 
Cross sections can be open or closed entities. Open cross sections create three-dimen-
sional surfaces. Closed cross sections create three-dimensional solids or surfaces, 
depending on the specified mode. 

Cross sections can be 2D polylines, lines, arcs, circles, ellipses, elliptical arcs, 2D 
splines, helices, traces, edges of entities, faces of a solid or surface, points of the first 
or last cross section, regions, and 2D solids. 

Guides can be 2D polylines with a single segment, 3D polylines, lines, arcs, elliptical 
arcs, 2D and 3D splines, and edges of entities.

Paths can be 2D and 3D polylines, lines, arcs, circles, ellipses, elliptical arcs, 2D and 
3D splines, helices, and edges of entities.

To create a lofted solid or surface    
1 Do one of the following to choose Loft ( ) ( ):

• On the ribbon, choose Draw 3D > Loft (in Draw 3D Solids or in Surfaces).

• On the menu, choose Draw > 3D Solids > Loft or Draw > Surfaces > Loft.

• On the Draw 3D Solids or the Draw 3D Surfaces toolbar, click the Loft tool.

• Type loft and then press Enter.

2 Select the cross sections in the order you want them to loft. You must select at 
least two cross sections. 

3 If desired, choose Point to taper the loft entity. Select the taper point on a cross 
section, then press Enter.

4 If desired, choose Join multiple edges to create a cross section from edges. Select 
the edges, which must share start and end points, to be considered as a cross sec-
tion. When done selecting edges, press Enter.

5 If needed, choose Mode to change whether a three-dimensional solid or surface is 
created, then press enter.

6 Press Enter to continue.

7 Choose one of the following:

• Guides — Creates the loft entity using guide curves which help shape the entity. 
Select the guide curves for the loft entity. Guide curves must intersect each cross 
section and begin and end at the first and last cross section. You can also 
combine multiple edges to form a guide.

• Path — Creates the loft entity along a path. Select the path for the lofted entity. 
The path must intersect the solid or surface on all planes.

• Cross sections only — Creates the loft entity between the cross sections without 
using guides or paths.

• Settings — Opens the Loft Settings dialog box to specify various settings.
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Creating swept solids and surfaces
You can create three-dimensional solids or surfaces by sweeping an entity along a 
path. 

Entities that you can sweep include 2D polylines, lines, arcs, circles, ellipses, ellipti-
cal arcs, 2D and 3D splines, 3D solid faces, and 2D solids.

Entities that can be the path include 2D and 3D polylines, lines, arcs, circles, ellipses, 
elliptical arcs, 2D and 3D splines, helices, and edges of solids, surfaces, or meshes.

To create a swept solid or surface    
1 Do one of the following to choose Sweep ( ) ( ):

• On the ribbon, choose Draw 3D > Sweep (in Draw 3D Solids or in Surfaces).

• On the menu, choose Draw > 3D Solids > Sweep or Draw > Surfaces > Sweep.

• On the Draw 3D Solids or the Draw 3D Surfaces toolbar, click the Sweep tool.

• Type sweep and then press Enter.

2 Select one or more entities to sweep.

You can choose Mode to change whether a three-dimensional solid or surface is 
created.

3 Select the path.

4 If desired, choose any of the following options:

• Alignment — Aligns the sweep entity to be perpendicular (normal) to the 
tangent direction of the sweep path. 

• Base point — Determines the base point of the sweep entity.

• Scale — Determines the scale factor for the sweep entity. If there are multiple 
sweep entities, the scale factor is applied to each entity. You can also choose 
Reference to select reference points in the drawing for scaling.

• Twist — Determines the degrees in which to rotate the sweep entity along the 
path. If there are multiple sweep entities, the twist angle is applied to each entity. 
You can also choose Bank to determine whether the sweep entity being swept 
rotates along a 3D path such as a 3D polyline, spline, or helix.
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Creating polysolids
You can create three-dimensional solids with a rectangular profile from a new 
polyline that you draw or from an existing line, arc, polyline, or circle.

To create a polysolid without converting any entities    
1 Do one of the following to choose Polysolid ( ):

• On the ribbon, choose Draw 3D > Polysolid (in Draw 3D Solids).

• On the menu, choose Draw > 3D Solids > Polysolid.

• On the Draw 3D Solids toolbar, click the Polysolid tool.

• Type polysolid and then press Enter.

2 Select the start point of the polysolid.

3 Continue selecting points. You can choose Arc to create an arc segment. You can 
also choose Undo to erase the previous point.

4 Choose Height and specify the height of the polysolid. The default height is speci-
fied by the PSOLHEIGHT system variable. 

5 Choose width and specify the width of the polysolid. The default height is speci-
fied by the PSOLWIDTH system variable.

6 Choose Justify to specify whether the width and height should be justified to the 
left, center, or right. Justification orientation is determined according to the direc-
tion of the first profile segment.

To create a polysolid from an existing entity   
1 Do one of the following to choose Polysolid ( ):

• On the ribbon, choose Draw 3D > Polysolid (in Draw 3D Solids).

• On the menu, choose Draw > 3D Solids > Polysolid.

• On the Draw 3D Solids toolbar, click the Polysolid tool.

• Type polysolid and then press Enter.

2 Choose Entity, then press Enter.

3 Select the entity you want to convert to a polysolid. You can select a line, arc, 
polyline, or circle.

4 Choose Height and specify the height of the polysolid. The default height is speci-
fied by the PSOLHEIGHT system variable. 

5 Choose width and specify the width of the polysolid. The default height is speci-
fied by the PSOLWIDTH system variable.

6 Choose Justify to specify whether the width and height should be justified to the 
left, center, or right. Justification is determined according to the direction of the 
first profile segment.
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Creating composite three-dimensional entities
You can create composite three-dimensional facet model meshes by combining, sub-
tracting, and finding the intersection of two or more facet model meshes.

Composite three-dimensional entities can also be created using 3D solids.

Combining three-dimensional entities
Combine two or more facet model meshes to create one facet model mesh.

You can also combine two or more 3D solids.

To combine facet model meshes
1 Do one of the following to choose Union ( ):

• On the ribbon, choose Draw 3D > Union (in Facet Model Meshes).

• On the menu, choose Draw > Facet Model Meshes > Union.

• On the Facet Model Meshes toolbar, click the Union tool.

• Type fmunion and then press Enter.

2 Select the facet model meshes to combine.

To combine solids    
1 Do one of the following to choose Union ( ):

• On the ribbon, choose Draw 3D > Union (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Union.

• On the Solids Editing toolbar, click the Union tool.

• Type union and then press Enter.

2 Select the 3D solids to combine.

Subtracting three-dimensional entities
Subtract two or more facet model meshes to create one facet model mesh.

You can also subtract two or more 3D solids.

Select the entities to combine (A and B). The resulting combined 
entity.

A

B
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To subtract facet model meshes
1 Do one of the following to choose Subtract ( ):

• On the ribbon, choose Draw 3D > Subtract (in Facet Model Meshes).

• On the menu, choose Draw > Facet Model Meshes > Subtract.

• On the Facet Model Meshes toolbar, click the Subtract tool.

• Type fmsubtract and then press Enter.

2 Select the facet model meshes to subtract from one another.

To subtract solids    
1 Do one of the following to choose Subtract ( ):

• On the ribbon, choose Draw 3D > Subtract (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Subtract.

• On the Solids Editing toolbar, click the Subtract tool.

• Type subtract and then press Enter.

2 Select the 3D solids to subtract from one another.

Intersecting three-dimensional entities
Create a composite three-dimensional entity from the intersection of two or more 
facet model meshes. Areas outside of the intersection are removed.

You can also intersect two or more 3D solids.

To intersect facet model meshes    
1 Do one of the following to choose Intersect ( ):

• On the ribbon, choose Draw 3D > Intersect (in Facet Model Meshes).

• On the menu, choose Draw > Facet Model Meshes > Intersect.

• On the Facet Model Meshes toolbar, click the Intersect tool.

• Type fmintersect and then press Enter.

2 Select the facet model meshes to intersect.

Select the entities to subtract (A and B). The resulting entity.

A

B
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To intersect solids    
1 Do one of the following to choose Intersect ( ):

• On the ribbon, choose Draw 3D > Intersect (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Intersect.

• On the Solids Editing toolbar, click the Intersect tool.

• Type intersect and then press Enter.

2 Select the 3D solids to intersect.

Select the entities to combine (A and B). The resulting combined 
entity.
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Creating three-dimensional entities from extracted curves
You can create curves from the contours of three-dimensional surfaces—and from 
solids if your program version supports them—and use those curves to experiment 
with non-mesh shapes. The resulting curves depend on the original entity's shape and 
can be lines, polylines, arcs, circles, or splines.

When finished experimenting with the resulting curves, you can use the Loft com-
mand to create a solid or surface from the revised curves.

To extract curves
1 Do one of the following to choose Extract Isolines ( ):

• On the ribbon, choose Draw 3D > Extract Isolines (in Curves).

• On the menu, choose Modify > 3D Operations > Extract Isolines.

• Type surfextractcurve and then press Enter.

2 Select the surface, solid, or solid face that you want to extract curves from. To 
select a solid face, press Ctrl + click.

3 Optionally choose any of the following:

• Chain Extracts curves from adjacent faces of the entity you select.

• Direction Changes the direction of the extracted curves. By default, curves are 
created in the U direction.

4 Move the mouse over the selected entity, and then click to create the curve that is 
being previewed.

5 Continue creating curves, and press Enter when done.

To extract splines that pass through all specified points on the surface
1 Do one of the following to choose Extract Isolines ( ):

• On the ribbon, choose Draw 3D > Extract Isolines (in Curves).

• On the menu, choose Modify > 3D Operations > Extract Isolines.

• Type surfextractcurve and then press Enter.

2 Select the surface, solid, or solid face that you want to create a custom curve from. 
To select a solid face, press Ctrl + click.

3 Choose Spline points.

4 Specify a point for the spline to pass through.

5 Continue specifying points, and then press Enter when done.
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Converting three-dimensional entities

Various types of three-dimensional entities can be converted into other entity types:

• Convert to 3D surfaces — Select closed 2D entities, 3D solids, regions, lines, arcs 
and open polylines with thickness, mesh entities and 3D faces to convert to 3D 
surfaces. 

• Convert to 3D meshes — Select 3D solids, 3D faces, polyface meshes and poly-
gon meshes, regions, and closed polylines to convert to 3D meshes.

• Convert to polyface meshes — Select 3D solids to convert to polyface meshes.

• Convert to 3D solids — Select various entity types and convert to 3D solids.

Converting three-dimensional entities to surfaces
You can convert the following entities into three-dimensional surfaces: closed 2D 
entities, 3D solids, regions, lines, arcs and open polylines with thickness, mesh enti-
ties and 3D faces.

To convert a three-dimensional entity to a surface
1 Do one of the following to choose Convert to Surface ( ):

• On the ribbon, choose Draw 3D > Convert to Surface (in Convert).

• On the menu, choose Modify > 3D Convert > Convert to Surface.

• Type convtosurface and press Enter. 

2 Select the entities you want to convert, then press Enter when done. 

Converting three-dimensional entities to meshes
You can convert the following entities into three-dimensional surfaces: 3D solids, 3D 
faces, polyface meshes and polygon meshes, regions, and closed polylines.

To convert a three-dimensional entity to a mesh
1 Do one of the following to choose Convert to Mesh ( ):

• On the ribbon, choose Draw 3D > Convert to Mesh (in Convert).

• On the menu, choose Modify > 3D Convert > Convert to Mesh.

• Type convtomesh and press Enter. 

2 Choose Settings to view or change settings for the conversion:

• Show Edges Click this check box to display the edges that form the mesh. 

• Subdivide Level Enter a value from 0 to 3 to determine the level of detail. The 
higher the number, the greater the detail applied to the converted mesh.

3 Click OK.

4 Select the entities you want to convert, then press Enter when done.
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Converting solids to polyface meshes
You can convert three-dimensional solids to polyface meshes using the 3D Convert 
command.

To convert a solid
1 Do one of the following to choose 3D Convert ( ):

• On the ribbon, choose Draw 3D > 3D Convert (in Convert).

• On the menu, choose Modify > 3D Convert > 3D Convert.

• On the Solids Editing toolbar, click the 3D Convert tool.

• Type 3dconvert and press Enter. 

2 Select the entities you want to convert. 

Converting surfaces and solids to NURBS surfaces
Use the Convert to NURBS command to convert solids and surfaces that are created 
with the Convert to Surface command to NURBS surfaces.

Meshes created with the Convert to Mesh command can also be converted to NURBS 
surfaces if you use the Convert to Surface or Convert to Solid command first.

Select a line to convert it to a spline.
The Convert to NURBS command is typically used to convert solids and surfaces to 
NURBS surfaces, but it can also be used to convert two-dimensional entities (for 
example, lines, polylines, arcs, circles, etc.) to splines.

To convert entities to NURBS surfaces
1 Do one of the following to choose Convert to NURBS ( ):

• On the ribbon, choose Draw 3D > Convert to NURBS (in Convert).

• On the menu, choose Modify > 3D Convert > Convert to NURBS.

• On the Solids Editing toolbar, click the Convert to NURBS tool.

• Type convtonurbs and press Enter. 

2 Select the entities you want to convert.

NURBS surfaces can display with control vertices.
Use the Show CV command to display control vertices; use the Hide CV command to 
hide them.

Converting entities to solids
The Convert to Solid command converts several types of entities to solids: closed 
mesh entities, closed 3D surfaces, and closed circles and polylines with thickness.



746 C H A P T E R  1 5
You can also apply thickness to surface and mesh entities and convert them to three-
dimensional solids using the Thicken command.

To convert closed entities to a solid using Convert to Solid
1 Do one of the following to choose Convert to Solid ( ):

• On the ribbon, choose Draw 3D > Convert to Solid (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Convert to Solid.

• On the Solids Editing toolbar, click the Convert to Solid tool.

• Type convtosolid and press Enter. 

2 Select the entities that you want to convert to solids, which can include:

• Closed meshes

• Closed 3D surfaces

• Circles with thickness

• Closed polylines with thickness and a non-changing width

3 When you are finished selecting entities, press Enter.

To convert a surface or mesh to a solid using Thicken
1 Do one of the following to choose Thicken ( ):

• On the ribbon, choose Draw 3D > Thicken (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Thicken.

• On the Solids Editing toolbar, click the Thicken tool.

• Type thicken and press Enter. 

2 Select the surface or mesh entity you want to convert and apply thickness to.

3 If you selected a mesh entity, choose Facet Surface. The mesh is converted to a 
facet surface first.

4 Enter the thickness value.
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Editing in three dimensions

You can copy, move, rotate, array, mirror, and align two-dimensional and three-
dimensional entities in both two-dimensional and three-dimensional space. You can 
also change and edit properties of three-dimensional entities much like you change 
and edit properties for two-dimensional entities. When you modify three-dimensional 
entities in two-dimensional space, you modify the entity in relation to the current 
UCS. 

Moving and rotating in three dimensions
Use the 3D Positioner command to move and rotate entities interactively in three 
dimensional space.

A visual aid, or gizmo, displays. Click one of its arrows to move entities along the 
corresponding x, y, or z-axis, or click one of its orbits to rotate entities relative to the 
corresponding axis. Movement is restricted to the axis you select.

To move or rotate entities in three dimensions
1 Do one of the following to choose 3D Positioner ( ):

• On the ribbon, choose Home > 3D Positioner (in Modify); Edit > 3D Positioner 
(in Modify).

• On the menu, choose Modify > 3D Operations > 3D Positioner.

• On the Modify toolbar, click the 3D Positioner tool.

• Type 3dpositioner and then press Enter.

2 Select the entities you want to move or rotate, and then press Enter.

3 Specify a point relative to which the selected entities are moved or rotated.

4 To move selected entities, click the arrow that corresponds to the axis you want to 
move along. To rotate selected entities, click the orbit that corresponds to the axis 
you want to rotate around.

5 Specify a new location.

A Click and drag an arrow to move selected 
entities along the corresponding axis. 

B Click and drag an orbit to rotate selected entities 
relative to the corresponding axis.

A

B
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Another way to rotate entities about a specified axis in three dimensional space is 
using the 3D Rotate command. First you select the entities to rotate and then define 
the axis of rotation either by specifying two points; selecting an existing entity; align-
ing the axis with the x-, y-, or z-axis of the current UCS; or aligning the axis with the 
current view.

To rotate an entity in three dimensions using the 3D Rotate command  
1 Do one of the following to choose 3D Rotate ( ):

• On the ribbon, choose Edit > 3D Rotate (in Modify).

• On the menu, choose Modify > 3D Rotate.

• On the Modify toolbar, click the 3D Rotate tool.

• Type rotate3D and then press Enter.

2 Select the entities to rotate, and then press Enter.

3 Choose from one of the following options: Entity, Last, View, Xaxis, Yaxis, 
Zaxis.

4 Specify the rotation angle.

5 Specify the reference angle.

Select the entities to rotate (A), specify the 
endpoints of the axis of rotation (B and C), and then 
specify the rotation angle (D).

Result after rotating the entities.

B

D
CA
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Arraying in three dimensions
You can copy selected entities and arrange them in a three-dimensional rectangular or 
polar (circular) pattern. For a rectangular array, you control the number of copies in 
the array by specifying the number of rows and columns and the number of levels. 
You also specify the distance between each. For a polar array, you specify the axis 
around which to array the entities, the number of copies of the entities to create, and 
the angle subtended by the resulting array.

To create a three-dimensional rectangular array   
1 Do one of the following to choose 3D Array:

• On the ribbon, choose Edit > 3D Array (in Modify).

• On the menu, choose Modify > 3D Array.

• On the Modify toolbar, click the 3D Array tool.

• Type 3Darray and then press Enter.

2 Select the entities, and then press Enter.

3 In the prompt box, choose Rectangular.

4 Type the number of rows in the array.

5 Type the number of columns.

6 Type the number of levels.

7 Specify the vertical distance between the rows.

8 Specify the horizontal distance between the columns.

9 Specify the depth between the levels.

To create a three-dimensional rectangular array, select the entity to copy (A), type the number of rows, 
columns, and levels, and then specify the distance between each row (B), column (C), and level (D).

AB

C

D
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To create a three-dimensional polar array         
1 Do one of the following to choose 3D Array ( ): 

• On the ribbon, choose Edit > 3D Array (in Modify).

• On the menu, choose Modify > 3D Array.

• On the Modify toolbar, click the 3D Array tool.

• Type 3Darray and then press Enter.

2 Select the entities, and then press Enter.

3 In the prompt box, choose Polar.

4 Type the number of copies to make, including the original selection set.

5 Specify the angle the array is to fill, from 0 to 360 degrees.

The default setting for the angle is 360 degrees. Positive values create the array in 
a counterclockwise direction; negative values create the array in a clockwise 
direction.

6 In the prompt box, choose one of the following:

• Yes-Rotate Entities to rotate entities as they are arrayed.

• No-Do Not Rotate to retain the original orientation of each copy as it is arrayed.

7 Specify the center point of the array.

8 Specify a second point along the central axis of the array.

To create a three-dimensional polar array, select the entity to copy (A), type the number of copies to make, 
specify the angle the array is to fill (B), and then specify the center point of the array (C) and a second point 
along the central axis of the array (D).

A

B

C

D
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Mirroring in three dimensions
You can create a mirror image of selected entities in three-dimensional space. You 
mirror the entities about a mirror plane that you define by either specifying three 
points; selecting an existing two-dimensional planar entity; aligning the plane parallel 
with the xy, yz, or xz plane of the current UCS; or aligning the plane with the current 
view. You can delete or retain the original entities.

To mirror an entity about a three-dimensional plane     
1 Do one of the following to choose 3D Mirror ( ):

• On the ribbon, choose Edit > 3D Mirror (in Modify).

• On the menu, choose Modify > 3D Mirror.

• On the Modify toolbar, click the 3D Mirror tool.

• Type mirror3D and then press Enter.

2 Select the entities, and then press Enter.

3 In the prompt box, choose 3 Points, or press Enter to select the default.

4 Specify the first point on the mirror plane.

5 Specify the second and third points on the plane.

6 In the prompt box, choose one of the following:

• Yes-Delete Entities to delete the original entities.

• No-Keep Entities to retain the original entities.

Aligning in three dimensions
You can align one or more selected entities with other entities in three-dimensional 
space. First you select the entities you want to move and align, then you specify pairs 
of points to move and align the selected entities:

• One pair of points — Moves selected entities.

Select the entity to mirror (A), and then specify 
the first point (B), second point (C), and third 
point (D) defining the mirror plane.

The resulting mirrored entity.            

A
D C

B



752 C H A P T E R  1 5
• Two pairs of points — Moves then rotates selected entities. The second pair of 
points can also determine the scale of moved entities (scaling is available only 
when using two pairs of points).

• Three pairs of points — Moves, rotates, then again rotates selected entities.

To align entities by moving them     
1 Do one of the following to choose Align ( ):

• On the ribbon, choose Edit > Align (in Modify).

• On the menu, choose Modify > Align.

• On the Modify toolbar, click the Align tool.

• Type align and then press Enter.

2 Select the entities that will be moved, and then press Enter. Do not include desti-
nation entities in the selection set.

3 Specify the first source point.

4 Specify the first destination point, then press Enter.

Select one or more entities to move, and 
then specify the first source point (A) and 
the first destination point (B).

The resulting entities.

A

B
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To align entities by moving and rotating them     
1 Do one of the following to choose Align ( ):

• On the ribbon, choose Edit > Align (in Modify).

• On the menu, choose Modify > Align.

• On the Modify toolbar, click the Align tool.

• Type align and then press Enter.

2 Select the entities that will be moved and rotated, and then press Enter. Do not 
include destination entities in the selection set.

3 Specify the first source point then the first destination point.

4 Specify the second source point then the second destination point, then press 
Enter.

5 If desired, choose Yes to scale the moved entities. Otherwise, choose No. If scal-
ing, the selected entities scale proportionately so that the distance between the two 
source points is the same as the distance between the two destination points.

The scaling option is available only when selecting two pairs of points.

Select one or more entities to move and 
rotate, and then specify the first source 
point (A), the first destination point (B), the 
second source point (C), and the second 
destination point (D).

The resulting entities, not scaled.

C D

A

B
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To align entities by moving and then rotating them twice    
1 Do one of the following to choose Align ( ):

• On the ribbon, choose Edit > Align (in Modify).

• On the menu, choose Modify > Align.

• On the Modify toolbar, click the Align tool.

• Type align and then press Enter.

2 Select the entities that will be moved and rotated, and then press Enter. Do not 
include destination entities in the selection set.

3 Specify the first source point then the first destination point.

4 Specify the second source point then the second destination point.

5 Specify the third source point then the third destination point, then press Enter.

Select one or more entities to move and 
rotate, and then specify the first source 
point (A), the first destination point (B), the 
second source point (C), the second 
destination point (D), the third source point 
(E), and the third destination point (F).

The resulting entities.

C D

B

E

F

A
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Projecting and trimming entities on a solid, surface, or region
You can modify a solid, surface, or region by projecting geometry onto it. For exam-
ple, you can project holes drawn on a different plane onto a three-dimensional 
mechanical part and automatically trim the holes from the part.

You can project points, lines, arcs, circles, ellipses, 2D and 3D polylines, splines, and 
helices onto a three-dimensional solid, surface, or region using a direction that you 
specify.

To project entities onto a solid, surface, or region
1 (Optional) To trim the resulting projection from the three-dimensional entity, 

choose Auto Trim ( ):

• On the ribbon, choose Draw 3D > Auto Trim (in Curves).

• On the menu, choose Modify > 3D Operations > Auto Trim.

Use a system variable.
Set the SURFACEAUTOTRIM system variable to 1 to automatically trim projec-
tions from three-dimensional entities.

2 Do one of the following to choose Project Geometry ( ):

• On the ribbon, choose Draw 3D > Project Geometry (in Curves).

• On the menu, choose Modify > 3D Operations > Project Geometry.

• Type projectgeometry and then press Enter.

3 Select the entities that you want to project, and press Enter when done.

4 Select the surface, solid, or region onto which you want the selected entities to be 
projected, then press Enter.

5 Specify the direction by choosing one of the following:

• View — Creates a projection based on the current view.

• UCS — Creates a projection along the z-axis of the current UCS. 

• Points — Creates a projection along a path between a start and end point that 
you specify.
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Editing three-dimensional solids

You can edit three-dimensional solids in several unique ways, including: chamfer, fil-
let, section, and slice. You can also modify individual faces and edges of solids, as 
well as imprint, separate, shell, and check solids.

You can edit three-dimensional ACIS solids, including: boxes, cones, cylinders, 
dishes, domes, pyramids, spheres, tori, and wedges.

Chamfering and filleting solids
You can chamfer or fillet a three-dimensional solid much like you chamfer or fillet a 
two-dimensional entity.

To chamfer a solid
1 Do one of the following to choose Chamfer ( ):

• On the ribbon, choose Edit > Chamfer (in Modify).

• On the menu, choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool.

• Type chamfer and then press Enter.

2 Select the edge of the base surface to chamfer. (One of two surfaces adjacent to 
the selected edge will be highlighted.)

3 Do one of the following:

• To select a different surface, type n and press Enter. 

• To use the current surface, press Enter.

4 Specify the base surface distance (measured from the selected edge to the base 
surface).

5 Specify the adjacent surface distance (measured from the selected edge to the 
adjacent surface).

6 Do one of the following:

• Specify the edges to chamfer.

• To select all edges around the base surface, type l and press Enter.
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To fillet a solid   
1 Do one of the following to choose Fillet ( ):

• On the ribbon, choose Edit > Fillet (in Modify).

• On the menu, choose Modify > Fillet.

• On the Modify toolbar, click the Fillet tool.

• Type fillet and then press Enter.

2 Select the edge of the solid to fillet.

3 Specify the fillet radius.

4 Select additional edges to fillet, and press Enter to fillet.

Sectioning and slicing solids
You can section or slice a three-dimensional solid, region, or body (typically a sheet). 

When you section a solid, you obtain an “inside view” by creating a cross-section 
through the solid as a region or block. When you section a region or body, the result-
ing intersections are curves. 

When you slice a solid, region, or body, you create a new entity by cutting the origi-
nal entity and removing a specific side.

To section an entity
1 Do one of the following to choose Section ( ):

• On the ribbon, choose Draw 3D > Section (in Draw 3D Solids).

• On the menu, choose Draw > 3D Solids > Section.

• On the Draw 3D Solids toolbar, click the Section tool.

• Type section and then press Enter.

2 Select the entities to cross-section.

3 Do one of the following:

• Specify three points to define the cross-section plane. (The first point defines the 
origin, while the second point defines the x-axis and the third point defines the 
y-axis.)

• Type o and press Enter to select an entity that defines the cross-sectional plane.

• Specify an axis by typing the appropriate letter and pressing Enter.
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To slice an entity
1 Do one of the following to choose Slice ( ):

• On the ribbon, choose Draw 3D > Slice (in Draw 3D Solids).

• On the menu, choose Draw > 3D Solids > Slice.

• On the Draw 3D Solids toolbar, click the Slice tool.

• Type slice and then press Enter.

2 Select the entities to slice.

3 Do one of the following:

• Specify three points to define the cross-section plane. (The first point defines the 
origin, while the second point defines the x-axis and the third point defines the 
y-axis.)

• Type o and press Enter to select an entity that defines the cross-sectional plane.

• Specify an axis by typing the appropriate letter and pressing Enter.

4 Specify which side to retain, or type b to retain both sides.

Modifying faces
You can edit three-dimension solids by extruding, moving, rotating, offsetting, taper-
ing, deleting, or copying individual faces. You can also change the color of individual 
faces.

Extruding solid faces

To extrude a solid face
1 Do one of the following to choose Extrude Face ( ):

• On the ribbon, choose Draw 3D > Extrude Face (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Extrude Face.

• On the Solids Editing toolbar, click the Extrude Face tool.

2 Select the entity with the face you want to extrude.

3 Select the face(s) to extrude, and press Enter.

4 Do one of the following:

• Specify the height of extrusion.

• Type p and press Enter to select a path for extrusion.

5 If you specified a height, specify a taper angle.
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Moving solid faces

To move a solid face 
1 Do one of the following to choose Move Face ( ):

• On the ribbon, choose Draw 3D > Move Face (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Move Face.

• On the Solids Editing toolbar, click the Move Face tool.

2 Select the entity with the face you want to move.

3 Select the face(s) to move, and press Enter.

4 Specify a base point.

5 Specify an end point.

Select the entity to extrude, and then specify the 
face(s) to extrude (A), and the height of 
extrusion or path.

The resulting entity with the face extruded to 
position (B).

Select the entity, and then specify the 
face(s) to move (A), the base point (B), 
and the end point (C).

The resulting entity with the face moved 
to the new position.

C

A B
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Rotating solid faces

To rotate a solid face 
1 Do one of the following to choose Rotate Face ( ):

• On the ribbon, choose Draw 3D > Rotate Face (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Rotate Face.

• On the Solids Editing toolbar, click the Rotate Face tool.

2 Select the entity with the face you want to rotate.

3 Select the face(s) to rotate, and press Enter.

4 Specify a base point.

5 Specify another point on the rotation axis.

6 Specify the rotation angle.

Offsetting solid faces

To offset a solid face 
1 Do one of the following to choose Offset Face ( ):

• On the ribbon, choose Draw 3D > Offset Face (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Offset Face.

• On the Solids Editing toolbar, click the Offset Face tool.

2 Select the entity with the face you want to offset.

3 Select the face(s) to offset, and press Enter.

4 Specify an offset distance.

Select the entity, and then specify the face(s) to 
rotate (A), the base point (B), a second point on 
the rotation axis (C), and a rotation angle.

The resulting entity with the face rotated to position 
(D).
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Tapering solid faces

To taper a solid face 
1 Do one of the following to choose Taper Face ( ):

• On the ribbon, choose Draw 3D > Taper Face (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Taper Faces.

• On the Solids Editing toolbar, click the Taper Face tool.

2 Select the entity with the face you want to taper.

3 Select the face(s) to taper, and press Enter.

4 Specify a base point.

5 Specify another point along the axis.

6 Specify a taper angle.

Select the entity, and then specify the face(s) to 
offset (A) and the distance to offset.

The resulting entity with the face offset to position 
(B).

Select the entity, and then specify the face(s) to 
taper (A), a base point, a second point along the 
taper axis, and a taper angle.

The resulting entity with the face tapered to position 
(D).
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Deleting solid faces

To delete a solid face 
1 Do one of the following to choose Delete Face ( ):

• On the ribbon, choose Draw 3D > Delete Face (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Delete Face.

• On the Solids Editing toolbar, click the Delete Face tool.

2 Select the entity with the face you want to delete.

3 Select the face(s) to delete, and press Enter.

Copying solid faces

To copy a solid face 
1 Do one of the following to choose Copy Face ( ):

• On the ribbon, choose Draw 3D > Copy Face (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Copy Face.

• On the Solids Editing toolbar, click the Copy Face tool.

2 Select the entity with the face you want to copy.

3 Select the face(s) to copy, and press Enter.

4 Specify a base point.

5 Specify an end point.

Select the entity, and then specify the face(s) to 
delete (A).

The resulting entity with the face deleted.
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Coloring solid faces

To color a face 
1 Do one of the following to choose Color Face ( ):

• On the ribbon, choose Draw 3D > Color Face (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Color Face.

• On the Solids Editing toolbar, click the Color Face tool.

2 Select the entity with the face you want to color.

3 Select the face(s) to color, and press Enter.

4 Specify a color.

Select the entity, and then specify the face(s) to 
copy (A), the base point (B), and the end point 
(C).

The resulting entity with the face copied.

Select the entity, and then specify the face(s) to 
color (A).

The resulting entity with the face colored.
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Modifying edges
In addition to modifying faces of solids, you can modify individual edges. You can 
copy individual edges or change the color of individual edges.

To copy an edge 
1 Do one of the following to choose Copy Edge ( ):

• On the ribbon, choose Draw 3D > Copy Edge (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Copy Edge.

• On the Solids Editing toolbar, click the Copy Edge tool.

2 Select the entity with the edge you want to copy.

3 Select the edge(s) to copy, and press Enter.

4 Specify a base point.

5 Specify an end point.

To color an edge 
1 Do one of the following to choose Color Edge ( ):

• On the ribbon, choose Draw 3D > Color Edge (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Color Edge.

• On the Solids Editing toolbar, click the Color Edge tool.

2 Select the entity with the edge you want to color.

3 Select the edge(s) to color, and press Enter.

4 Specify a color.

Select the entity, and then specify the edge(s) to 
copy (A), the base point (B), and the end point 
(C).

The resulting entity with the edge copied.
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Imprinting solids
You can modify the face of a solid by imprinting another entity on it. For example, 
you can imprint a line, arc, or polyline onto the face of a box.

To imprint a solid entity 
1 Do one of the following to choose Imprint ( ):

• On the ribbon, choose Draw 3D > Imprint (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Imprint.

• On the Solids Editing toolbar, click the Imprint tool.

2 Select the solid entity you want to imprint.

3 Select the entity you want to imprint on the solid.

Separating solids
You can separate solids that have been combined. After you separate them, they are 
separated into individual solids.

To separate solids 
1 Do one of the following to choose Separate ( ):

• On the ribbon, choose Draw 3D > Separate (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Separate.

• On the Solids Editing toolbar, click the Separate tool.

2 Select the solid you want to separate.

Shelling solids
You can create a shell or a hollow thin wall from your 3D solid entity. IntelliCAD 
offsets existing faces to create new faces.

To shell a solid 
1 Do one of the following to choose Shell ( ):

• On the ribbon, choose Draw 3D > Shell (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Shell.

• On the Solids Editing toolbar, click the Shell tool.

2 Select the entity you want to shell.

3 Remove any faces you don’t want to include.

4 Specify an offset distance.
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Cleaning solids
You can remove redundant edges or vertices from solids when they are not needed.

To clean a solid 
1 Do one of the following to choose Clean ( ):

• On the ribbon, choose Draw 3D > Clean (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Clean.

• On the Solids Editing toolbar, click the Clean tool.

2 Select the entity you want to clean.

Checking solids
You can check whether a selected entity is a valid three dimensional ACIS solid. If it 
is a valid 3D solid, you can modify the entity using the 3D solid editing commands; if 
not, you cannot edit the entity using these commands. 

To check a solid 
1 Do one of the following to choose Check ( ):

• On the ribbon, choose Draw 3D > Check (in Solid Editing).

• On the menu, choose Modify > Solid Editing > Check.

• On the Solids Editing toolbar, click the Check tool.

2 Select the entities to check. 

Select the entity, and then select faces to 
remove (A) and (B), then specify an offset 
distance.

The resulting shelled entity.
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Hiding, shading, and rendering

As you create three-dimensional entities, the program displays both wireframe and 
surface models in wireframe view, which makes it difficult to visualize your three-
dimensional models. To better visualize the model, you can remove all the lines that 
are hidden behind other entities or surfaces when seen from the current viewpoint.

Shading goes a step further by removing hidden lines and then assigning flat colors to 
the visible surfaces, making them appear solid. Shaded images are useful when you 
want to quickly visualize your model as a solid entity, though they lack depth and 
definition.

Rendering provides an even more realistic image of your model, complete with light 
sources, shadows, surface material properties, and reflections, giving your model a 
photo-realistic look. As shown in the following illustrations, when you render a 
model, the program removes hidden lines and then shades the surfaces as though they 
were illuminated from imaginary light sources.   

Understanding dynamic and static hiding, shading, and rendering
IntelliCAD includes two ways to hide, shade, and render drawings, each with its own 
advantages:

• Dynamic visual styles — Drawings display a hidden-line, shadowed, or rendered 
view in real time while you draw and edit. You can add materials, lights, and a 
background to the drawing, and their effects also display dynamically. Visual 
styles are based on the OpenGL and OpenGL ES graphics devices.

• Static images — Static hidden-line, shadowed, and rendered images are created 
for the current view. While not dynamic, you can create static images using more 
options than visual styles, such as sun shadows, reflections, refactoring, and the 
ability to edit materials. Static images are based on DaVinci rendering.

Using dynamic visual styles for hiding, shading, and rendering
Visual styles can change the display of a drawing in real-time as you draw and edit a 
drawing. As you work, you can also add materials to entities, lighting to the scene, 
and a background to the current view, all of which display with visual styles that 
support rendering, such as Realistic and Shaded.

Wire-frame model. Hidden-line image. Shaded image. Rendered image.
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Visual styles can be managed using the Explorer. For more details, see “Working 
with visual styles” on page 338. 

Displaying a drawing with a visual style
You can choose from a variety of styles according to your needs. For example, if 
you’re just starting a new drawing, you might want to view it using a wireframe 
mode, which looks similar to a model made out of wire and displays faster than more 
complex visual styles. Then as your drawing advances, you can switch to a more 
detailed visual style.

The following visual styles are available:

• 2D Wireframe — Drawing displays in two dimensions with all lines drawn at the 
edge of entities.

• Conceptual — Drawing displays in three dimensions with surfaces shaded in con-
ceptual colors.

• Hidden — Drawing displays in three dimensions with all lines drawn at the edge 
of entities except those behind surfaces.

• Realistic — Drawing displays in three dimensions with surfaces filled with 
assigned materials.

• Shaded — Drawing displays in three dimensions with surfaces shaded.

• Shaded with Edges — Drawing displays in three dimensions with surfaces shaded 
and lines drawn at the edge of surfaces.

• Shades of Gray — Drawing displays in three dimensions with surfaces shaded in 
monochromatic shades of gray.

• Sketchy — Drawing displays in two and three dimensions with a freehand sketch 
effect.

• Wireframe — Drawing displays in three dimensions with all lines drawn at the 
edge of entities.

• X-ray — Drawing displays in three dimensions with surfaces partially transparent.

The more detail that displays on the screen, the greater the impact on performance.

To change the visual style   
1 Do one of the following:    

• On the ribbon, choose View and in Visual Styles, make your selection.

• On the menu, choose View > Visual Styles, then make your selection.

• On the View toolbar, click your selection.

• Type vscurrent, press Enter, then make your selection.
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Adding materials that display with visual styles
Materials that display with visual styles are managed using the Explore Materials 
command. After you import materials to the drawing, you can assign them to entities 
and layers, and their effects are seen using the Realistic visual style.

Use the Realistic visual style to display materials assigned to entities.

For more details about using the Materials Explorer, see “Working with materials” on 
page 362. 

Adding lighting effects that display with visual styles
IntelliCAD applies default lighting to all models when the drawing is displayed using 
Realistic, Shaded, Shaded with Edges, and Shades of Gray visual styles.

If you want to create a specific lighting scene, you can add your own lights that spec-
ify the placement of lights, light color, and light intensity to determine how your 
drawing or scene is lit. Lights can be placed either outside the field of view or inside 
to illuminate different areas of the scene.  

There are several ways to add custom lighting to your drawing:

• Point Light command A point light shines light from its location in all directions. 
Point lights are entities in a drawing and their effects appear for shaded or ren-
dered visual styles in IntelliCAD and in third-party software such as Artisan Ren-
derer.

• Spot Light command A spot light shines light in the shape of a cone from its loca-
tion towards the direction you specify. Spot lights are entities in drawings and 
their effects appear for shaded or rendered visual styles in IntelliCAD and in third-
party software such as Artisan Renderer.

To create a point light 
1 Do one of the following to choose Point Light ( ): 

• On the ribbon, choose View > Point Light (in Lights).

• On the menu, choose View > Lights > Point Light.

• Type pointlight and then press Enter.

2 If default lighting is currently turned on, IntelliCAD prompts you to turn it off so 
you can see the effect of your new lights. Click Yes to turn off default lighting.

3 Enter the x-, y-, and z-coordinates of where to place the point light, or click the 
location in the drawing.
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To create a spot light
1 Do one of the following to choose Spot Light ( ): 

• On the ribbon, choose View > Spot Light (in Lights).

• On the menu, choose View > Lights > Spot Light.

• Type spotlight and then press Enter.

2 If default lighting is currently turned on, IntelliCAD prompts you to turn it off so 
you can see the effect of your new lights. Click Yes to turn off default lighting.

3 Enter the x-, y-, and z-coordinates of where to place the spot light, or click the 
location in the drawing.

4 Then enter the x-, y-, and z-coordinates of the location you want to shine light, or 
click the location in the drawing. 

Edit point lights and spot lights.
You can move and copy point lights and spot lights in your drawing, just as you 
would any other entity. To specify settings for the point or spot light, such as color 
and attenuation, right-click the light, choose Properties, and make your selections in 
the Properties pane. And when you select a spot light, grips display allowing you to 
change the light and target location, cone size, and fall-off size.

Lights of older file formats can be updated to the current format.
If you open a drawing that contains lights that were created in an older format, type 
CONVERTOLDLIGHTS at the command prompt to update them to the current for-
mat.

Adding a background that displays with visual styles
Backgrounds display for the current view when using any visual style except 2D 
Wireframe. You can choose a solid-color, gradient, or image background. 

Backgrounds can also be assigned to named views and displayed with the same visual 
styles. For more details, see “Setting the background for a named view” on page 692 
in this chapter. 

To set the background for the current view
1 Do one of the following to choose Background ( ):

• On the ribbon, choose View > Background (in Views).

• On the menu, choose View > Background.

• Type background and then press Enter.
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2 Choose one of the following:

• Solid

• Gradient

• Image

3 In the Background dialog box, make your selections. Click [?] to see details about 
each option.

4 Click OK.

Creating static hidden-line, shaded, and rendered images

Creating hidden-line images
Creating a hidden-line image of your drawing removes all the lines that are hidden 
behind other surfaces when seen from your vantage point. When you remove hidden 
lines or shade a model, the program treats the entities differently, depending on how 
you created them. Wireframe models always appear transparent, because they have 
no surfaces. Surface models appear filled, with surfaces applied to all visible sides. 

You can also control the hidden-line view on an entity-by-entity basis by showing 
and hiding edges of selected 3D faces, meshes, and polyface meshes.

To create a hidden-line image
• Type hide and then press Enter.  

Use a visual style.
Choosing View > Visual Styles > Hidden is similar to using the Hide command. For 
more details, see “Displaying a drawing with a visual style” on page 768. 

To hide edges of 3D faces, meshes, and polyface meshes
1 Do one of the following to choose Hide Edges ( ): 

• On the ribbon, choose Draw 3D > Hide Edges (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Hide Edges.

• Type hideedges and then press Enter.

2 Select the entities with edges that you want to hide, then press Enter when done.

Before creating a hidden-line image. After removing hidden lines.
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Individual edges can be hidden for 3D faces.
The Hide Edges command hides all edges of selected entities, but if you are working 
with 3D faces, you can also use the Edge command to hide individual edges.

To show edges of 3D faces, meshes, and polyface meshes
1 Do one of the following to choose Show Edges ( ): 

• On the ribbon, choose Draw 3D > Show Edges (in Draw 3D Meshes).

• On the menu, choose Draw > 3D Meshes > Show Edges.

• Type showedges and then press Enter.

2 Select the entities with edges that you want to show, then press Enter when done.

Individual edges can be displayed for 3D faces.
The Show Edges command shows all edges of selected entities, but if you are working 
with 3D faces, you can also use the Edge command to show individual edges.

Creating shaded images
Creating a shaded image of your drawing removes hidden lines and then applies 
shading to the visible surfaces based on their entity color. Because they are intended 
to provide a quick visualization, shaded images do not have a light source and use 
continuous colors across surfaces, causing them to appear flat and unrealistic.   

To create a shaded image
• Type shade and then press Enter. 

To control the appearance of the shaded image, choose Tools > Drawing Settings, 
and then click the 3D Settings tab and select the options you want. You can shade the 
surfaces and edges of the model in four ways: 

• Faces shaded; edges not highlighted. 

• Faces shaded; edges highlighted in the background color.

• Faces filled in the background color; edges drawn using the entity color (similar to 
a hidden-line view).

• Faces filled using the entity color; edges highlighted in the background color.

Use a visual style.
Choosing a shaded visual style (View > Visual Styles) is similar to using the Shade 
command. For more details, see “Displaying a drawing with a visual style” on page 
768. 
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Creating photo-realistic rendered images
Creating a rendered image of your drawing removes hidden lines and then shades the 
surface as though it were illuminated from multiple light sources. 

Full rendering creates a photo-realistic image of your model, complete with light 
sources, shadows, surface material properties, and reflections. You can illuminate 
your image with spotlights, distant lighting to simulate sunshine, and ambient light. If 
you choose not to customize the light sources, the program generates default light 
sources for you.

Rays from these imaginary light sources are traced as they reflect off and refract 
through the surfaces of the model, a process called ray tracing. Ray tracing deter-
mines where shadows fall and how reflections on shiny materials such as metal and 
glass appear. You can modify the reflective properties of the materials that make up 
your model to control how the light rays reflect off its surfaces. 

Full rendering automatically creates a base on which your model is displayed, if you 
don’t already have one, so it does not appear suspended in space. A background is 
also automatically added to the image. A background such as a cloudy sky or an 
imported raster graphic such as a stone wall can also be added behind the image, 
making it even more realistic.

To create a quickly rendered image
Do one of the following to choose Render ( ): 

• On the ribbon, choose View > Render Settings (in Rendering).

• On the menu, choose View > Rendering > Render.

• On the Rendering toolbar, click the Render tool.

• Type render and then press Enter.

To create a fully rendered image
Do one of the following to choose Full Render ( ):    

• On the ribbon, choose View > Render Settings (in Rendering).

• On the menu, choose View > Rendering > Full Render.

• On the Rendering toolbar, click the Full Render tool.

• Type fullrender and then press Enter.
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Use a visual style.
Choosing the Realistic visual style (View > Visual Styles) is similar to using the ren-
der commands. For more details, see “Displaying a drawing with a visual style” on 
page 768. 

Creating custom rendered images
Before you use the Full Render command to create a rendered image of a drawing, 
you can apply materials, a background, and lighting (including shadows) to 
customize your drawing:

• Materials Specify materials for different surfaces and define how the materials 
map to those surfaces. Predefined materials are available in the materials library, 
which can be customized further using the built-in editor. You can choose to use 
procedural or bitmap materials.

• Backgrounds Specify the background or backdrop for a rendered image. Several 
predefined backgrounds are available. By default, no background is used and it 
appears black. The background is an infinite, planar surface and reflects off of any 
reflective surfaces in your model. The background is not affected by lighting how-
ever, so no shadows or highlights are seen on the background.

Fully rendered image.
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• Lighting Specify the placement of lights, light color, and light intensity to deter-
mine how your drawing or scene is lit, including shadows and reflections in the 
scene. Lights can be placed either outside the field of view or inside to illuminate 
different areas of the scene. Several predefined lighting controls are available, 
including ambient lighting, diffuse lighting, specular reflections, specular high-
lights, and transparency. 

To apply materials, backgrounds, and lighting
1 Do one of the following to choose Materials ( ), Backgrounds ( ), 

or Lighting ( ): 

• On the ribbon, choose View > Materials, Backgrounds, or Lighting (in 
Rendering).

• On the menu, choose View > Rendering, and then choose Materials, 
Backgrounds, or Lighting.

• On the Rendering toolbar, click the Materials, Backgrounds, or Lighting tool.

• Type materials, backgrounds, or lighting and then press Enter.

2 Make your selections.

You can specify additional rendering options.
Choose View > Rendering > Render Settings. For more information about creating 
custom rendered images, click Help in any of the Render dialog boxes.

Saving a rendered image
You can save a rendered image to a different format — either a bitmap (.bmp), JPEG 
(.jpg), TIFF (.tif), TrueVision TGA (.tga), or Portable Network Graphic (.png). If you 
want to print the rendered image, you can print the saved image from another 
graphics program. 

To save a rendered image of your drawing
1 Create a rendered image of the drawing.

2 Do one of the following to choose Render Settings ( ):

• On the ribbon, choose View > Render Settings (in Rendering).

• On the menu, choose View > Rendering > Render Settings.

• On the Rendering toolbar, click the Render Settings tool.

• Type setrender and then press Enter.

3 On the Rendering tab, click Save Last Image.

4 Enter a file name and path.

5 In Save As Type, choose the file format.

6 Click Save.
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Rendering in Artisan Renderer
Similar to the Full Render command in IntelliCAD, Artisan Renderer allows you to 
create a photo-realistic image of your model. However, many users prefer using Arti-
san Renderer to speed up the design process with access to a wide range of pre-set 
materials and lighting setups, along with the ability to create custom realistic materi-
als.

For more details about Artisan Renderer, choose Help > Help in Artisan Renderer.

To create a rendered image in Artisan Renderer
1 Save the drawing.

2 Do one of the following to choose Artisan Render ( ): 

• On the ribbon, choose View > Artisan (in Rendering).

• On the menu, choose View > Rendering > Artisan.

• On the Artisan Rendering toolbar, click the Artisan tool.

• Type artisan and then press Enter.

3 If the Artisan Settings dialog box displays, choose from the following options:

• Units Select the units.

• Language Select the language. To use the operating system language, choose 
Use System Locale.

• Facet resolution Set the resolution of shaded three dimensional entities and 
faces when exporting to Artisan Renderer.

• Smoothing angle Set the angle of smoothing applied to crease edges when 
exporting to Artisan Renderer.

• Show on Startup Choose to display the Artisan Settings dialog each time you 
use the Artisan or Artisan Sync command in IntelliCAD.

4 Click OK.

Artisan Renderer opens and displays your model for you to add materials and 
other effects. For more details about using Artisan Renderer, choose Help > Help 
in Artisan Renderer.
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To synchronize your latest model with Artisan Renderer
1 Save the drawing.

2 Do one of the following to choose Artisan Sync ( ): 

• On the ribbon, choose View > Artisan Sync (in Rendering).

• On the menu, choose View > Rendering > Artisan Sync.

• On the Artisan Rendering toolbar, click the Artisan Sync tool.

• Type artisan-sync and then press Enter.

Artisan Renderer is updated with the latest model from IntelliCAD, which is help-
ful if you’re working in IntelliCAD and Artisan Renderer at the same time and you 
change the model in IntelliCAD.
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Working with other programs and 
computers

IntelliCAD offers great flexibility in its capability to be used with other programs. 
You can include an IntelliCAD drawing in a Microsoft® Word document or insert a 
Microsoft® Excel spreadsheet containing a parts list into an IntelliCAD drawing. To 
include IntelliCAD drawings in other programs and documents from other programs 
in IntelliCAD drawings, you either link or embed them. You can also save Intelli-
CAD drawings in other file formats that can be used directly with other programs or 
send IntelliCAD drawings to coworkers via e-mail.

This section explains how to:

• Save and view snapshots.

• Use object linking and embedding.

• Export IntelliCAD drawings to other file formats.

• Convert one or more drawings to other file formats.

• Use IntelliCAD data on other computers.

• Use IntelliCAD with the Internet.

Topics in this chapter

Saving and viewing snapshots ......................................................................... 780

Using data from other programs in IntelliCAD drawings................................... 782

Using IntelliCAD data in other programs .......................................................... 796

Using IntelliCAD data on other computers........................................................ 809

Using IntelliCAD with the Internet..................................................................... 815

Working with digital signatures ......................................................................... 818
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Saving and viewing snapshots

You can save snapshots of a drawing to view later. A snapshot saves the current 
drawing in either .emf, .wmf, or .sld files exactly as it appears on the screen. A snap-
shot is not a drawing file. You cannot edit or print the snapshot; you can only view it.

You can use snapshots in the following ways:

• Add slide (.sld) files to image tile menus.

• Make presentations by showing snapshots of your drawings.

• Reference a snapshot of a drawing while working on a different drawing.

• Present a number of snapshots as a slide show by using scripts.

For details about using slide (.sld) files with image tile menus, see “Customizing 
image tile menus” on page 912. 

Creating snapshots
You create a snapshot by saving the current view as a snapshot. A snapshot does not 
include any entities on layers that are not currently visible. The contents of the snap-
shot also depend on the current drawing space. In model space, the snapshot shows 
only the current viewport. In paper space, the snapshot contains all visible viewports.

If you are creating a slide (.sld) file to use in an image tile menu, make sure the image 
fills the screen before you create the snapshot. Image tiles display with a 3:2 ratio in 
image tile menus.

To create a snapshot 
1 Display the drawing exactly as you want to capture it as a snapshot.

2 Do one of the following to choose Make Snapshot ( ):

• On the ribbon, choose Tools > Make Snapshot (in Manage).

• On the menu, choose Tools > Make Snapshot.

• On the Tools toolbar, click the Make Snapshot tool.

• Type msnapshot and then press Enter.

3 In the dialog box that displays, specify the name of the snapshot file you want to 
create.

4 From the Files Of Types list, choose either .emf, .wmf, or .sld.

5 Click Save.

The current drawing remains on the screen, and the snapshot is saved to the directory 
that you specify. Slide (.sld) files that are used in image tile menus should be located 
in the program’s installation folder.
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Viewing snapshots
You can view previously saved snapshots, and you can also view snapshots created 
using AutoCAD.

When you view a snapshot, it temporarily replaces the current drawing with the exter-
nal snapshot file. When you refresh the display of the current drawing (by redrawing, 
panning, zooming, minimizing, maximizing, or tiling), the snapshot image disap-
pears, and you are returned to the current drawing.

To view a snapshot
1 Do one of the following: 

• On the ribbon, choose Tools > View Snapshot (in Manage).

• Choose Tools > View Snapshot.

• On the Tools toolbar, click the View Snapshot tool ( ).

• Type vsnapshot and then press Enter.

2 In the dialog box that displays, specify the name of the snapshot file you want to 
view.

3 Click Open.

IntelliCAD displays the snapshot in the current drawing window.
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Using data from other programs in IntelliCAD drawings

You can include data from other programs in IntelliCAD drawings by using either 
embedding or linking. The method you choose depends on the type of object or file 
you want to include in your IntelliCAD drawing and what you want to do with it after 
it is there.

Embedding objects into drawings
Embed an object into your IntelliCAD drawing when you want to keep all the data 
you work with in one file or if you want to transfer the file to other computers. You 
can embed data from programs that support object linking and embedding.

For example, if you want to distribute data about a department’s computer equipment 
along with an IntelliCAD drawing of the department’s floor plan, you can embed a 
Microsoft® Excel spreadsheet into the floor plan.

When you embed data from another program, IntelliCAD becomes the container for 
that data. The object embedded in the IntelliCAD drawing becomes part of the 
IntelliCAD file. When you edit the data, you open its program from within the 
IntelliCAD drawing.

Any changes you make to the embedded data exist only in the IntelliCAD drawing, so 
it is not necessary to keep that data in a separate file. If the data does exist in a sepa-
rate file, the original file does not change when you modify the embedded object in 
IntelliCAD. Also, changes to the original file do not affect the embedded object in the 
IntelliCAD drawing.

To embed another program’s object into an IntelliCAD drawing
1 Open the file that contains the data you want.

2 In the file, select the data you want to embed in the IntelliCAD drawing.

3 Choose that program’s command to place data on the Clipboard.

Usually, you choose Edit > Copy.

4 In the IntelliCAD window, display the drawing in which you want to embed the 
object.

5 Do one of the following to choose Paste ( ):

• On the ribbon, choose Home > Paste (in Clipboard) or choose Edit > Paste (in 
Modify)

• On the menu, choose Edit > Paste.

• On the Standard toolbar, click the Paste tool.

• Type paste and then press Enter.

The data on the Clipboard is pasted into the drawing as an embedded object. The 
object appears in the center of the view, but you can select and move it by moving 
the cursor.
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To embed an object from an existing file within IntelliCAD      
1 Do one of the following to choose OLE Object ( ):

• On the ribbon, choose Insert > OLE Object (in Data).

• On the menu, choose Insert > OLE Object.

• Type insertobj and then press Enter.

2 In the Insert Object dialog box, click Create From File.

3 Specify the file by doing one of the following:

• Type a path and file name in the File box.

• Click Browse to select a file.

4 Select Display As Icon if you want that program’s icon to appear in the drawing 
instead of the data.

5 Click OK.

The first page of the file appears in the IntelliCAD drawing, unless you chose to 
display it as an icon. You can select the object and drag to reposition it.

To create a new embedded object from within IntelliCAD
1 Do one of the following to choose OLE Object ( ):

• On the ribbon, choose Insert > OLE Object (in Data).

• On the menu, choose Insert > OLE Object.

• Type insertobj and then press Enter.

2 In the Insert Object dialog box, click Create New.

3 From the Object Type list, select the type of object you want to create, and then 
click OK.

The program for creating that object opens within IntelliCAD. If the program is 
compatible with ActiveX, it opens in place (within the other program) in the 
IntelliCAD drawing; otherwise, the program opens in its full window.

4 Create the object in the other program.

5 If the program is running within the other document (in place), click anywhere 
outside the embedded object to close the program.

If the program is running in its full window, choose File > Exit.

Linking objects to drawings
If another program supports ActiveX, you can link its data to IntelliCAD drawings. 
Use linking when you want to include the same data in many files. When you update 
the data, all links to other files reflect the changes.

For example, if you created your company logo in an ActiveX-compatible drawing 
program, and you want to include it in the title block of every drawing you create 
with IntelliCAD, you can link it to each IntelliCAD drawing. When you change the 
original logo in the drawing program, the IntelliCAD drawing updates automatically.
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When you link data from another program, the IntelliCAD drawing stores only a ref-
erence to the location of the file in which you created the data. You link data from a 
saved file, so IntelliCAD can find the data and display it.

Because linking adds only a reference to a file, the data does not significantly 
increase the file size of the IntelliCAD drawing. However, links require some mainte-
nance. If you move any of the linked files, you need to update the links. In addition, if 
you want to transport linked data, you must include all linked files.

You can update a linked object automatically every time you open the drawing, or 
you can do so only when you specify. Anytime a link is updated, changes made to the 
object in its original file also appear in the IntelliCAD drawing, and the changes also 
appear in the original file if they were made through IntelliCAD.

To link a file to an IntelliCAD drawing
1 Save the original file. 

Because a link consists of a reference to the original file, you must save the file 
before you can link to it.

2 In the original file, select the data you want in the IntelliCAD drawing.

3 Choose that program’s command to place data on the Clipboard.

Usually, you choose Edit > Copy.

4 Display the IntelliCAD drawing to which you want to link the file.

5 In IntelliCAD, choose Edit > Paste Special.

6 In the Paste Special dialog box, select Paste Link.

7 Click OK.
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To create a linked object from within IntelliCAD   
1 Display the IntelliCAD drawing in which you want to display the linked object.

2 Do one of the following to choose OLE Object ( ):

• On the ribbon, choose Insert > OLE Object (in Data).

• On the menu, choose Insert > OLE Object

• Type insertobj and then press Enter.

3 In the Insert Object dialog box, click Create From File.

4 Specify the file by doing one of the following:

• Type a path and file name in the File box.

• Click Browse to select the file using a file dialog box.

5 Select the Link check box.

6 Select Display As Icon if you want that program’s icon to appear in the drawing 
instead of the data.

7 Click OK.

The first page appears in the IntelliCAD drawing, unless you chose to display it as 
an icon. To reposition the object, select and drag it.

Editing an embedded or linked object from within IntelliCAD
You can modify an embedded or linked object in its original program from within 
IntelliCAD. When you modify an embedded object, you change the object only in 
IntelliCAD, not its original file (if you pasted the object from an existing file). When 
you modify a linked file, however, you open and change the original file.

Most programs include a submenu of actions you can perform on an embedded or 
linked ActiveX object. Usually, the commands for editing ActiveX objects are Edit 
and Open. If the object is embedded and its program supports in-place editing, the 
Edit command opens the object in place. The Open command opens the object in the 
full program window. In IntelliCAD, this command appears at the bottom of the Edit 
menu.

To edit an embedded or linked object 
• In the IntelliCAD drawing, double-click the object.

If the object is embedded and the program in which you created the object supports 
in-place editing, the object opens in place.

If the object is linked, or if its program does not support in-place editing, the other 
program opens in its full window and displays the object.
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Importing files created in other formats
You can import files that have the following formats:

• ACIS format — Three-dimensional Spatial Technologies ACIS solids saved as an 
.sat file. 

• DWF format — Autodesk® Design Web Format (used with .dwf files) is used 
to distribute a drawing for others to view in a Web browser, review, and edit. The 
DWF format uses the .dwf file extension.

• DWT format — Drawing templates contain predefined settings that you can reuse 
when you create new drawings. Drawing templates use the .dwt file extension.

• DXF format — Autodesk Drawing Exchange Format is an ASCII description of a 
drawing file with a .dxf file extension. 

• DXB format — Autodesk Drawing Exchange Format is a binary description of a 
drawing file with a .dxb file extension. 

• DGN format — Drawing files used with Bentley Microstation. The DGN for-
mat uses the .dgn file extension.

• DAE format — Collada files are an interactive three-dimensional graphics file for-
mat used by 3D graphics applications (three-dimensional entities are exported, 
including ACIS entities). Collada files use the .dae file extension. 

• FMB format — Facet Model Binary data used by IntelliCAD to store facet model 
mesh data.

• IFC format — Drawing files in the IFC (Industry Foundation Classes) format used 
for building and construction data.

• IGES format — Model data in the IGES (Initial Graphics Exchange Specification) 
format as an .iges or .igs file.

• Map files — Map files are .shp, .sdf and .sqlite shapefiles that store geometric 
location and attribute information of geographic features.

• OBJ format — Model data in OBJ (Wavefront Technologies object) format as an 
.obj file. 

• PDF format — Model data used with Adobe® Acrobat® Reader® and Adobe® 
Acrobat.

• STEP format — Model data in the STEP (Standard for the Exchange of Product) 
format as an .step, .ste or .stp file.

• STL format — Model data in an STL (Stereolithography) format as an .stl file, 
which is common when working with 3D printers.

• TXT or CSV format — Point data located in a text or comma-separated value for-
mat file can be imported as point entities, vertices of a polyline, or vertices of a 
spline.

• XLS format — Data in a table from an .xls or .xlsx Microsoft Excel file.
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Importing a DXF, DWF, DWT, DGN, or DAE format file
Importing .dxf files, two-dimensional .dwf files, .dwt, .dae, and .dgn files is similar to 
opening a standard drawing file.

To import a DXF, DWF, DWT, DGN, or DAE format file 
1 Do one of the following to choose Import ( ): 

• On the ribbon, choose the Application button then choose Import, or choose 
Insert > Import.

• On the menu, choose File > Import > Import. 

• On the Standard toolbar, click the Open tool.

• Type import and then press Enter. 

2 Choose the folder that contains the drawing. 

3 In Files of Type, choose the type of drawing you want to import. 

4 Choose the file you want to open. 

5 Click Open.

Importing a DXB format file
A DXB format file is a drawing file used for building and construction data.

To import a DXB format file 
1 Do one of the following to choose DXB In ( ): 

• On the ribbon, choose the Application button > Import > DXB In, or choose 
Insert > DXB In (in Import).

• On the menu, choose File > Import > DXB In or Insert > Drawing Exchange 
Binary. 

• Type dxbin and then press Enter. 

2 Choose the file you want to open. 

3 Click Open.

Importing a PDF format file or underlay
A PDF format file can contain two- and three-dimensional model data. The format is 
used to distribute models that can be viewed with Adobe® Acrobat® Reader® and 
Adobe® Acrobat.

You can import content from either a .pdf file or a .pdf underlay that already exists in 
your drawing.
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To import content from a .pdf file
1 Do one of the following to choose PDF In ( ):

• On the ribbon, choose the Application button > Import > PDF In, or choose 
Insert > PDF In (in Import).

• On the menu, choose File > Import > PDF In. 

• Type pdfin and then press Enter. 

2 Choose File, then press Enter.

3 Choose the file you want to open, then click Open.

4 In the Import PDF from File dialog box, make your selections.

5 Click OK.

6 Specify the insertion point by clicking in the drawing area or entering coordinates. 

To import content from a PDF underlay
1 Do one of the following to choose PDF In ( ):

• On the ribbon, choose the Application button > Import > PDF In, or choose 
Insert > PDF In (in Import).

• On the menu, choose File > Import > PDF In. 

• Type pdfin and then press Enter. 

2 In the drawing, select the frame of the PDF underlay you want to import. 

The PDFFRAME system variable must be set to 1 or 2 to select its frame.

3 Specify the portion of the underlay to import:

• Rectangular area — Specify two diagonal corners of the rectangular area to 
import.

• Polygonal area — Choose Polygonal, then pick at least three points to define the 
polygonal area to import.

• Entire area — Choose All to import all data contained in the .pdf underlay. 

4 Choose Settings to specify more options, then in the Import PDF from Underlay 
dialog box, make your selections, and click OK when done.

The dialog box that displays is similar to the Import PDF from File dialog box.

5 Choose what to do with the underlay:

• Keep — Keep the .pdf underlay unchanged. 

• Detach — Remove the .pdf underlay from the drawing.

• Unload — Hide the .pdf underlay temporarily.



W O R K I N G  W I T H  O T H E R  P R O G R A M S  A N D  C O M P U T E R S 789
A Displays the path and filename of the .pdf file to import.
B Enter the number of the page to import from the specified file.
C Mark to retain lineweight properties of imported entities.
D Mark to interpret entities that resemble arcs, circles, and ellipses 

as such within a tolerance.
E Mark to use RGB colors during the import. If unmarked, colors 

from the palette are used.
F Mark to enable clipping. If marked, you can also enable clipping at 

the border of the page.
G Mark to keep transparency of geometric data unchanged.
H Mark to import two-dimensional solid entities as solid-filled 

hatches.
I Mark to combine contiguous line and arc segments into a polyline.
J Mark to import the .pdf content as a block.
K Mark to combine text entities that use the same font and are 

located on the same line into a single text entity.
L Mark to import text entities that use Type3 fonts as entities that 

use TrueType fonts.

M Select how to create layers.
N Mark to import gradient fills and save them as .png files.
O Mark to save raster images as .png files and attach them.
P Mark to import text entities that use TrueType fonts. Then choose 

whether the resulting text entities are multiline text or geometry 
(polylines and solid-filled hatches).

Q Mark to import all solid-filled areas. Available only when Vector 
Geometry is selected.

R Mark to import text entities that use invalid TrueType fonts as 
polylines and solid-filled hatches.

S Mark to import vector geometry (such as linear paths, Bezier 
curves, and solid-filled areas) as polylines and two-dimensional 
solids. If unmarked, it is imported as solid-filled hatches.

T Enter the scale factor for the imported .pdf content.
U Enter the rotation angle for the imported .pdf content.
V Select to specify the insertion point for the .pdf content directly in 

the drawing.
W Click to select a .pdf file to import.

A
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Importing an IFC format file
An IFC format file typically contains a 3D model of a building that can be used for 
visualization, design, analysis, and to generate building construction documents. 

Importing an .ifc file creates separate entities for each item in the file and converts 
those items to AEC entities where possible, depending on your selections.

To import an IFC format file 
1 Do one of the following to choose IFC In: 

• On the ribbon, choose the Application button > Import > IFC In ( ), or 
choose Insert > IFC In (in Import).

• On the menu, choose File > Import > IFC In. 

• Type ifcimport and then press Enter. 

2 Choose the file you want to import. 

3 Click Open.

4 In the IFC Import Options dialog box that displays, mark the elements you want to 
import from the .ifc file. For details about each option, click [?].

5 When finished selection import options, click OK.

6 Select an insertion point in the drawing.

7 Enter the scale or specify the drawing units type in which to insert the .ifc file, 
then press Enter. 

8 Enter the rotation to use for the insertion, then press Enter.

Importing an ACIS format file
An ACIS format file contains three-dimensional solids, regions, or bodies that are 
saved as an ASCII .sat file.

To import an ACIS format file
1 Do one of the following:

• On the ribbon, choose the Application button > Import > ACIS In, or choose 
Insert > ACIS In (in Import).

• On the menu, choose File > Import > ACIS In.

• Type acisin, and then press Enter. 

2 Choose the directory containing the .sat file. 

3 Choose the .sat file you want to open. 

4 Click Open. 
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Importing an IGES format file
The IGES (Initial Graphics Exchange Specification) format is an exchange format 
that typically contains 3D surfaces saved in an .iges or .igs file. IGES data is imported 
as meshes, or it is imported as three-dimensional solids if your program version sup-
ports the Spatial® ACIS® modeler.

To import an IGES format file
1 Do one of the following to choose IGES In ( ): 

• On the ribbon, choose the Application button > Import > IGES In, or choose 
Insert > IGES In (in Import).

• On the menu, choose File > Import > IGES In. 

• Type igesimport and then press Enter. 

2 Choose the .iges or .igs file you want to import. 

3 Click Open. 

Processing begins. When the selected file is ready to be imported a balloon mes-
sage displays in the status bar. 

4 Click the file name in the balloon message to complete the import.

5 Zoom to extents to see the imported entities.

Importing a STEP format file
STEP (Standard for the Exchange of Product) is an ISO standard exchange format 
that typically contains 3D objects saved in an .step, .ste, or .stp file. STEP data is 
imported as meshes, or it is imported as three-dimensional solids if your program ver-
sion supports the Spatial® ACIS® modeler.

To import an STEP format file
1 Do one of the following to choose STEP In ( ): 

• On the ribbon, choose the Application button > Import > STEP In, or choose 
Insert > STEP In (in Import).

• On the menu, choose File > Import > STEP In. 

• Type stepimport and then press Enter. 

2 Choose the .step, .ste, or .stp file you want to import. 

3 Click Open. 

Processing begins. When the selected file is ready to be imported a balloon mes-
sage displays in the status bar. 

4 Click the file name in the balloon message to complete the import.

5 Zoom to extents to see the imported entities.
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Importing an OBJ format file
OBJ (Wavefront Technologies object) is a format that is typically used in three-
dimensional modelers and for three-dimensional printing. It contains geometry such 
as points, lines, texture vertices, faces, curves, and surfaces. 

OBJ model data is imported as mesh entities.

To import an OBJ format file
1 Do one of the following to choose OBJ In ( ): 

• On the ribbon, choose the Application button > Import > OBJ In, or choose 
Insert > OBJ In (in Import).

• On the menu, choose File > Import > OBJ In. 

• Type objin and then press Enter. 

2 Choose the .obj file you want to import. 

3 Click Open. 

Processing begins. 

4 Zoom to extents to see the imported entities.

Importing an FMB format file
FMB (Facet Model Binary) is a format that stores facet model mesh data. FMB data 
is imported as facet model mesh entities.

To import an FMB format file
1 Do one of the following to choose FMB In ( ): 

• On the ribbon, choose the Application button > Import > FMB In, or choose 
Insert > FMB In (in Import).

• On the menu, choose File > Import > FMB In. 

• Type fmbin and then press Enter. 

2 Choose the .fmb file you want to import. 

3 Click Open. 

Processing begins. 

4 Zoom to extents to see the imported entities.
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Importing an STL format file
The STL (Stereolithography) format typically contains 3D solids and meshes for 
working with 3D printers. STL format files are saved in .stl files.

To import an STL format file
1 Do one of the following to choose STL In ( ): 

• On the ribbon, choose the Application button > Import > STL In, or choose 
Insert > STL In (in Import).

• On the menu, choose File > Import > STL In. 

• Type stlin and then press Enter. 

2 Choose the .stl file you want to import. 

3 Click Open. 

Processing begins. 

4 Zoom to extents to see the imported entities.

Importing a TXT or CSV format file containing points
Point data in a text or comma-separated file can be imported as point entities, vertices 
of a polyline, or vertices of a spline.

If you import the point data as point entities, the appearance of the imported points is 
determined by the PDMODE system variable.

The following is an example of point data in a .csv file:

1.1,2.2,3.3

5.5,6.6,7.7

The first line of a file can include a text description (e.g., column titles), but all other 
lines should contain at least three numbers representing x-, y- and z-coordinates. 
Commas, semicolons, tabs, and spaces can be used to separate values.

If you import point data as polylines or splines, blank lines in the file indicate the end 
of one entity and the beginning of the next.

To import a TXT or CSV file containing points
1 Do one of the following to choose Import Points ( ): 

• On the ribbon, choose Insert > Import Points (in Data); Express Tools > Import 
Points (in Tools).

• On the menu, choose Insert > Import Points or Express Tools > Tools > Import 
Points.

• Type impoint and then press Enter. 
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2 Choose the .txt or .csv file that contains the points you want to import. 

3 Click Open. 

4 Choose one of the following:

• Points Choose Points to import points as point entities. Then press Enter to use 
the default point size or enter a new value. The point size is stored in the 
PDSIZE system variable.

• Polyline Choose Polyline to import points as polyline vertices. Then choose Yes 
to import points as vertices of a closed polyline or No to import them as vertices 
of an open polyline.

• Spline Choose Spline to import points as spline vertices. Then choose Yes to 
import points as vertices of a closed spline or No to import them as vertices of 
an open spline.

Importing an XLS format file
Data can be imported from an .xls or .xlsx file created using Microsoft Excel or 
another spreadsheet program. The imported data fills a new table that is created auto-
matically during import, and the new table is formatted automatically to match the 
format of the original spreadsheet.

To import an XLS format file
1 Do one of the following to choose XLS In ( ): 

• On the ribbon, choose Insert > XLS In (in Data).

• On the menu, choose Insert > XLS In.

• Type xlsimport and then press Enter. 

2 Choose the .xls or .xlsx file that contains the data you want to import. 

3 Click Open. 

4 If the specified file contains more than one sheet, enter the name of the sheet to 
import. If necessary, type ? and press Enter to see a list of sheet names.

5 Specify the insertion point for the upper-left corner of the table.
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Importing a map file
You can import map files that are .shp, .sdf, and .sqlite shapefiles and also map data 
from PostgreSQL, MySQL, and WFS servers. Shapefiles are used for storing geomet-
ric location and attribute information of geographic features.

To import a shapefile file
1 Do one of the following to choose Map Import ( ): 

• On the ribbon, choose Insert > Map Import (in Data).

• On the menu, choose Insert > Map Import.

• Type mapimport and then press Enter. 

2 Choose SDF, SQLITE, or SHP, depending on the shapefile you want to import. 

3 In the dialog box that displays, select the file, then click Open.

4 Specify the name of the input layer with data that you want to import, then press 
Enter.

5 Specify the name of the table to import data from, then press Enter.

6 Specify the coordinate system for the imported map data. If a coordinate system 
was already assigned to the current drawing by typing adesetcrdsys in the com-
mand bar, the imported map data is converted to the coordinate system of the 
drawing.

7 Enter coordinate system: Specify the coordinate system for the imported map data. 
If a coordinate system was assigned to the current drawing, the imported map data 
is converted to the coordinate system of the drawing.

8 Choose Yes to import non-geometry data from the source file, or choose No to 
only import geometry.

9 Specify the target layer in the drawing for imported data, then press Enter.

10 Choose Yes to import three-dimensional geometry data in three dimensions, or 
choose No to convert it to two dimensions.

11 Choose Yes to import polygons as closed polylines, or choose No to import as 
polygons.

To import data from a PostgreSQL, MySQL, and WFS server
1 Do one of the following to choose Map Import ( ): 

• On the ribbon, choose Insert > Map Import (in Data).

• On the menu, choose Insert > Map Import.

• Type mapimport and then press Enter. 

2 Choose POSTGRESQL, MYSQL, or WFS, depending on the type of server you 
want to connect to. 

3 Follow the prompts, which vary according to the server.
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Using IntelliCAD data in other programs

You can use any of the following methods to include IntelliCAD data in a document 
created in another program:

• Embedding

• Linking

• Dragging

• Exporting

• E-mailing

The method you choose depends on the capabilities of the other program and how 
you want to work with the IntelliCAD data after you’ve placed it in the other 
document.

Each method except exporting uses ActiveX to integrate data from different programs. 
With ActiveX, you can open IntelliCAD drawings from within the other program to 
modify the IntelliCAD drawings.

Embedding drawings
When you embed an IntelliCAD drawing, it becomes part of the other program’s doc-
ument file. When you edit the drawing, you edit only the version that is embedded in 
the other document.

Embedding is useful when you don’t want to maintain a link to the IntelliCAD draw-
ing for the data you include in the other document. Edits made to the new drawing do 
not affect the original drawing. To transfer the file to other computers, you can trans-
fer all the data in one file, but embedded objects increase the file size.

From within a document in a program that supports ActiveX, such as Microsoft® 
Word, you can either create a new embedded IntelliCAD drawing or embed an exist-
ing IntelliCAD drawing.

To create an IntelliCAD drawing in another document
1 In the document, choose Insert > Object (or the equivalent command for that 

program).

2 In the dialog box, click the options for creating a new file. 

3 Under Object Type, choose IntelliCAD Drawing, and then click OK.

4 Create the IntelliCAD drawing.

5 If IntelliCAD is running in its own window, choose File > Exit.

If IntelliCAD is running within the other document (in place), click somewhere in 
the document outside the IntelliCAD drawing to close IntelliCAD.
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6 To edit the IntelliCAD drawing from within the document, double-click the 
drawing.

You can also embed an existing IntelliCAD drawing from within another document. 
Follow step 1 in the preceding procedure, and then click the option for creating an 
object from an existing file.

To embed selected IntelliCAD entities
1 In IntelliCAD, select the entities you want to embed.

2 Choose Edit > Copy (or press Ctrl+C).

3 Open the document in which you want to embed the entities. 

4 Choose Edit > Paste (or the equivalent command).

To embed an entire IntelliCAD drawing
1 Open the document in which you want to embed the drawing.

2 Do one of the following to choose OLE Object ( ):

• On the ribbon, choose Insert > OLE Object (in Data).

• On the menu, choose Insert > OLE Object

• Type insertobj and then press Enter.

3 Click Create From File.

4 Click Browse, and then choose the file you want to embed.

5 Click Insert, and then click OK.

Editing an embedded IntelliCAD object in place
In many ActiveX-compatible programs you can edit an embedded IntelliCAD object 
without leaving the program (or container application). This is called in-place editing. 
A different set of IntelliCAD menus and toolbars temporarily replaces most of the 
menus and controls in the active window while you edit the IntelliCAD object.       

To edit an embedded IntelliCAD object in place
1 In the container application, double-click the embedded IntelliCAD object.

A different set of IntelliCAD menus and controls appears.

2 Edit the IntelliCAD drawing.

3 Click anywhere outside the drawing window to exit the in-place editing controls.
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Linking drawings
When you link an IntelliCAD drawing to another document, the other document con-
tains only a reference to the IntelliCAD drawing file, rather than the actual drawing. 
You link data in a saved IntelliCAD file so that the other program can find the data 
and display it.     

Linking works well when you want to include the same IntelliCAD data in more than 
one document. When you update the data, you need update it in only one location. 
The versions that are linked to other documents reflect the changes automatically.

Linking an IntelliCAD file to another document does not increase the file size the 
way embedding an IntelliCAD object does. However, links require more 
maintenance. To transport the data, you must make sure to transfer all linked files to 
the other computer.

To link an IntelliCAD file to another document
1 Open the drawing you want to link.

Because a link is a reference to a file, the referenced file must be saved on a local or 
remote disk. 
If you haven’t saved the drawing you want to link, choose File > Save.

2 In the other program, open the document in which you want to include the 
IntelliCAD drawing.

3 Choose that program’s command for inserting objects.

In Microsoft® Office programs, choose Insert > Object. In the Object dialog box, 
click the Create From File tab. Specify the name of the drawing file you want to 
link. Select the Link To File check box, and then click OK.

The drawing appears in the document, with a link to the original IntelliCAD file.
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Dragging IntelliCAD drawings into other programs
If the other program in which you want to include IntelliCAD drawings is compatible 
with ActiveX, an alternative to pasting drawings with menu commands is to drag 
drawing file icons from Windows Explorer into the other document. Dragging and 
dropping drawings does not use the Clipboard, so data on the Clipboard is not 
affected. 

When you drag an IntelliCAD drawing file from Windows Explorer, you link or 
embed the entire drawing in the other document. When you drag the file, the cursor 
changes in response to the action you take.

For easy drag-and-dropping, position the application windows side by side. 
Before you drag a drawing, position the Windows Explorer window and the other 
program’s window so you can see the file icon and the document in which you want 
to drop it.

To drag and embed drawings into another document
• Select the icon for the drawing file, and then drag the drawing into the document.

Exporting drawings
You can save or export IntelliCAD drawings in a number of different formats for use 
with other programs. When you save a drawing in a different format, the program 
saves all the entities in the drawing to the new file. Or, you can choose which entities 
are included in the new file. 

How the cursor changes
Cursor appearance Action

Drag to embed the selected file to the other 
document. 

Cannot drop drawings in that document.
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File formats that can be exported
The following table describes the file formats that can be exported.

You can also export ACIS solids, regions, and surfaces to an ASCII file (*.sat) that 
you can use in other programs.

Export formats
Format File extension Details
Bitmap .bmp Graphics file

Collaborative Design Activity 
(Collada)

.dae Interactive three-dimensional graphics file 
format used by 3D graphics applications 
(three-dimensional entities are exported, 
including ACIS entities)

Comma-Separated Values .csv Text file that stores table data without 
formatting

Design Drawing .dgn Distribute your drawing to others for review, 
editing, and markup using other CAD 
programs such as Bentley® Microstation®

Design Web Format .dwf Distribute your drawing to others for using with 
Autodesk® software and tools

Enhanced Windows Metafile .emf Graphics file

Facet Model Binary .fmb Facet model data file

Industry Foundation Classes .ifc Distribute your drawing to others for review, 
editing, and markup in other BIM applications

Portable Document Format .pdf Distribute your drawing in 2D or 3D to others 
for using with Adobe® Acrobat® Reader® and 
Adobe® Acrobat

Scalable Vector Graphics .svg Graphics file and Web development language

Stereolithography .stl Graphics file used for prototyping and 3D 
printing three-dimensional models

Wavefront Technologies 
Object Format

.obj File used for 3D modeling and 3D printing

Windows Metafile .wmf Graphics file
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Exporting to a BMP, EMF, WMF, DAE, or SVG format file
Exporting to a file is similar to saving a standard file.

To export a drawing to a .bmp, .emf, .wmf, .dae, or .svg file 
1 Do one of the following:

• On the ribbon, choose the Application button then choose Export > Export, or 
choose Output > Export (in Export).

• On the menu, choose File > Export > Export.

• Type export and then press Enter.

2 In the Export Drawing As File dialog box, under Save As Type, choose the file 
format.

3 Specify the name of the file you want to create.

4 Click Save.

5 If the selection prompt box displays, choose the entity-selection method, and then 
create the selection set. 

6 When you have finished selecting entities, press Enter.

Exporting to an STL format file
You can export three-dimensional solids to an STL (Stereolithography) file with an 
.stl extension. The STL format is commonly used when working with 3D printers.

To export to an STL format file
1 Do one of the following to choose STL Out ( ): 

• On the ribbon, choose the Application button then choose Export > STL Out or 
Output > STL Out (in Export).

• On the menu, choose File > Export > STL Out. 

• Type stlout and then press Enter. 

2 Specify the name of the file you want to create. 

3 Click Save. 

4 Choose the entity-selection method, and then create a selection set that contains 
the entities you want to export. 

5 Choose Yes to export to a binary .stl file. Choose No to export to an ASCII .stl 
file.

6 Zoom to extents to see the imported entities.
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Exporting to a PDF format file
PDF format files allow you to distribute your drawing to others for viewing in 
Adobe® Acrobat® Reader®, which is free software that users can download. PDF files 
can also be viewed, reviewed, and edited in Adobe® Acrobat.

You can export drawings to two-dimensional and three-dimensional PDF files.

To export a drawing to a .pdf file 
1 Do one of the following to choose PDF Out ( ):

• On the ribbon, choose the Application button then choose Export > PDF Out, or 
choose Output > PDF Out (in Export).

• On the menu, choose File > Export > PDF Out.

• Type pdfexport and then press Enter.

2 In Save As Type, choose Portable Document Format (pdf).

3 Specify the name of the file you want to create.

4 Click Save.

5 Mark the layouts and/or the model to export.

6 Select the page setup you want to assign to each layout or the model when 
exported.

7 Select the layer state you want to assign to each layout or the model when 
exported.

8 To create a 3D .pdf file instead of 2D, mark Include Layer Information and then 
mark Create 3D PDF File.

9 Choose additional options for how you want to export to the .pdf file. Click [?] to 
see details about each option.

10 Click Export.

You can also print and publish to .pdf files.
If instead of exporting you need to print to a .pdf file, you can print or publish directly 
to a .pdf file. One advantage of publishing is that you can print from multiple draw-
ings to a single .pdf file. For details about printing to .pdf, see “Selecting a printer or 
plotter” on page 637. For details about publishing to .pdf, see “Publishing a sheet 
list to the printer named in page setup” on page 677. 
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Exporting to a DWF format file
DWF format files allow you to publish your drawings so they can be viewed on the 
Internet using a Web browser. IntelliCAD exports your drawing to a Design Web 
Format (.dwf) file, which can be viewed in a Web browser if Autodesk Design 
Review is also installed on the computer. Design Review is a free tool from 
Autodesk.

You can export your drawing to a 2D .dwf file or a 3D .dwf file. 2D .dwf files have 
smaller file sizes, but cannot be viewed in three dimensions. 3D .dwf files can be 
viewed in three dimensions using the Autodesk® Design Review, but have larger file 
sizes.

To export a drawing to a .dwf file
1 Do one of the following to choose DWF Out ( ):

• On the ribbon, choose the Application button then choose Export > DWF Out, 
or choose Output > DWF Out (in Export).

• On the menu, choose File > Export > DWF Out.

• Type dwfout and then press Enter.

2 In Save As Type, choose Design Web Format (dwf).

3 Specify the name of the file you want to create.

4 Click Save.

5 Choose the entity-selection method, and then create a selection set that contains 
the entities you want to export. 

6 Choose how you want to export:

• DWF File Version — Choose the file version you want. Version 4.2 can export 
entities on the Model tab only (no layouts). Version 5.5 can export the current 
layout only. Version 6.0 can export the current layout or all layouts.

• DWF File Format — Choose the desired file format. Compressed binary files 
have a smaller file size than uncompressed binary files (both are 2D .dwf files). 
ASCII files have the largest file size for 2D .dwf files, but 3D .dwf files have 
larger file sized and can be viewed in three dimensions.

• Layout to Export — Choose whether to export the current layout only, or all 
layouts in the drawing.

7 Click OK.

8 When you have finished selecting entities, press Enter.
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Exporting to a DGN format file
DGN format files allow you to distribute your drawing to others for review, editing, 
and markup using other CAD programs such as Bentley®  Microstation®. Files are 
exported to DGN version 8 files. 

To export a drawing to a .dgn file
1 Do one of the following to choose DGN Out ( ):

• On the ribbon, choose the Application button then choose Export > DGN Out, 
or choose Output > DGN Out (in Export).

• On the menu, choose File > Export > DGN Out.

• Type dgnexport and then press Enter.

2 Specify the name of the file you want to create.

3 Click Save.

4 At the prompt, choose a master unit for the .dgn file such as kilometers or feet.

5 At the prompt, choose a sub unit for the .dgn file such as inches or mils.

The drawing is exported.

Exporting to an IFC format file
The IFC (Industry Foundation Classes) format is used for exchanging building and 
construction data. It typically contains a 3D model of a building that can be used for 
visualization, design, analysis, and to generate building construction documents. 

You can export AEC entities, .ifc underlays, and .rvt underlays to an IFC format file.

To export a drawing to an IFC format file
1 Do one of the following to choose IFC Out ( ):

• On the ribbon, choose the Application button then choose Export > IFC Out, or 
choose Output > IFC Out (in Export).

• On the menu, choose File > Export > IFC Out.

• Type ifcexport and then press Enter.

2 Specify the name of the file you want to create.

3 Click Save.

4 In the IFC Export Options dialog box, make your selections. Click [?] for more 
details about each option.

5 Click OK.
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Exporting to a CSV format file
Table data can be exported from a drawing to the Comma Separated Values (CSV) 
format. The resulting .csv file contains table contents only without formatting. 

To export a table to a CSV format file
1 Do one of the following to choose CSV Out ( ):

• On the ribbon, choose the Application button then choose Export > CSV Out, or 
choose Output > CSV Out (in Export).

• On the menu, choose File > Export > CSV Out.

• Type tableexport and then press Enter.

2 Select the table you want to export.

3 Specify the name of the file you want to create.

4 Click Save.

Exporting to an OBJ format file
The Wavefront Technologies OBJ format is commonly used for three-dimensional 
models and three-dimensional printing. It stores information about geometry such as 
points, lines, texture vertices, faces, curves, and surfaces. 

Color and texture information is exported to a companion .mtl (Material Template 
Library) file format which is referenced from within the .obj file.

To export a drawing to an OBJ format file
1 Do one of the following to choose OBJ Out ( ):

• On the ribbon, choose the Application button then choose Export > OBJ Out, or 
choose Output > OBJ Out (in Export).

• On the menu, choose File > Export > OBJ Out.

• Type objout and then press Enter.

2 Select the entities you want to export.

3 Specify the name of the file you want to create.

4 Click Save.
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Exporting to an FMB format file
Facet model entities can be exported from a drawing to the Facet Modeler Binary 
(FMB) format. The .fmb file that is created stores facet model data that can be shared 
with other CAD programs.

To export facet model entities to an FMB format file
1 Do one of the following to choose OBJ Out ( ):

• On the ribbon, choose the Application button then choose Export > FMB Out, 
or choose Output > FMB Out (in Export).

• On the menu, choose File > Export > FMB Out.

• Type fmbout and then press Enter.

2 Select the facet model entities you want to export.

3 Specify the name of the file you want to create.

4 Click Save.

Exporting to an ACIS format file
You can export ACIS entities such as surfaces, regions, and solids to an ACIS format 
file in ASCII (SAT) format. 

To export an ACIS format file
1 Do one of the following:

• On the ribbon, choose the Application button then choose Export > ACIS Out, 
or choose Output > ACIS Out (in Export).

• On the menu, choose File > Export > ACIS Out.

• Type acisout and then press Enter. 

2 Select the ACIS entities you want to save. 

3 Specify the name of the file you want to create. 

4 Click Save. 

Converting drawings to other file versions and formats
Several types of drawings can be converted to other file versions and formats. You 
can convert a batch of drawings in a folder or specify a single drawing to convert.

The following formats can be converted from and converted to:

• Autodesk DWG format — Autodesk Drawing Format is a drawing with a .dwg 
file extension. 

• Autodesk DXF format — Autodesk Drawing Exchange Format is an ASCII 
description of a drawing file with a .dxf file extension. 

• DGN format — Drawing files used with Bentley Microstation. The DGN for-
mat uses the .dgn file extension.
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To convert a single drawing
1 Do one of the following to choose IntelliCAD Converter ( ):

• On the ribbon, choose the Application button then choose Drawing Utilities > 
IntelliCAD Converter, or choose Tools > IntelliCAD Converter (in Manage).

• On the menu, choose File > IntelliCAD Converter.

• Type intelliconvert and then press Enter.

2 Choose Single file, then click Next.

3 Select an input file. Click [...] to browse to the location.

4 Name an output file. Click [...] to browse to the location.

5 In Convert to version, select the file format and version for the output file.

6 If you are converting to a .dgn file, select any of the following:

• Master unit — Assigns the selected master unit to the output .dgn file.

• Sub unit — Assigns the selected sub unit to the output .dgn file.

• Bind external references when possible — Makes external references a 
permanent part of the .dgn file, similar to a block, if external references are 
found in the input drawing. 

7 If you have more files to convert, mark Convert more files.

8 Click Finish.

A log file is created automatically if converting to a .dgn file and errors occur.
The file <output_dgnfilename>.log is saved in the same folder where the output .dgn 
file is created.

To convert a batch of drawings
1 Do one of the following to choose IntelliCAD Converter ( ):

• On the ribbon, choose the Application button then choose Drawing Utilities > 
IntelliCAD Converter, or choose Tools > IntelliCAD Converter (in Manage).

• On the menu, choose File > IntelliCAD Converter.

• Type intelliconvert and then press Enter.
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2 Choose Multiple files, then click Next.

3 Specify the input files by doing the following:

• Enter an input folder. Click [...] to browse to the location.

• To include files located in subfolders within the input folder, mark Process 
subfolders.

• Choose which files to include: .dwg, .dxf, and .dgn.

4 Click Next.

5 Review the list of files that are found, then click Next to proceed using all of the 
named files. You can also click Back to specify different files.

6 Enter an output folder. Click [...] to browse to the location. 

7 Mark Convert, then select the output format and file version.

8 To audit and fix files during the conversion, mark Audit files and fix errors. You 
can also choose to save audit log files, which will also be saved in the output 
folder.

9 Select what to do, if while processing, files with the same name are found in the 
output folder:

• Replace existing — Replaces existing files with the new files. To make a 
backup copy of the existing file before it is overwritten, mark Create backup 
files (*.bak), and backup files will be created in the same output folder.

• Skip existing — Skips adding a new file if an existing file is found with the same 
name.

• Add suffix to output files — Adds the specified suffix to all new files created in 
the output folder.

10 If you are converting to a .dgn file, select any of the following:

• Master unit — Assigns the selected master unit to the output .dgn file.

• Sub unit — Assigns the selected sub unit to the output .dgn file.

• Bind external references when possible — Makes external references a 
permanent part of the .dgn file, similar to a block, if external references are 
found in the input drawing. 

11 Click Next.

New files are generated based on your specifications.

A log file is created automatically if converting to a .dgn file and errors occur.
The file <output_dgnfilename>.log is saved in the output folder that was specified for 
batch file conversion.
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Using IntelliCAD data on other computers

Within IntelliCAD there are two ways to move drawings and related files to another 
computer:

• Create a package that contains all related drawings and files. This option uses the 
eTransmit command and is best for moving multiple drawings or a drawing that 
has supporting files such as external reference files and font files.

• Send a drawing through e-mail from IntelliCAD. This option uses the Send Mail 
command and is best for moving single drawings.

Packaging drawings and files for use on another computer
Use the eTransmit command to package together drawings and their related files, 
such as external references, materials from Explore Materials, and fonts. The result-
ing package can be a self-extracting .exe file, a .zip file, or a separate folder that con-
tains the files.

The eTransmit command uses transmittal setups to define how packages are created, 
with options for filenaming, password control, whether to include fonts, and more. 
The default transmittal setup is named Standard, which you can modify. Or you can 
create new transmittal setups.

Creating a package that contains drawings and related files

To package drawings and their related files
1 Do one of the following to choose eTransmit ( ):

• On the ribbon, choose the Application button then Publish > eTransmit, or 
choose Output > eTransmit (in Export).

• On the menu, choose File > eTransmit.

• Type etransmit and then press Enter.

2 Review the available files in the list. The files display in either hierarchical format 
(click the File Tree tab) or in a table (click the File Table tab).

3 Mark the files to include in the package; unmark the files to exclude from the 
package.

4 To include files that are not listed, click Add Files, navigate to and select the 
desired files, then click Open.

5 In Select a Transmittal Setup, choose the transmittal setup that defines how you 
want the package to be created. The transmittal setup specifies the package file-
type (.exe, .zip, or folder), filenaming, and more.

6 To view or create a transmittal setup, click Transmittal Setups. For more details, 
see “Working with transmittal setups” on page 811 in this chapter. 
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7 Optionally enter notes to include in the transmittal report.

8 Click OK.

The package is created.

A Click to view files in a hierarchy.
B Click to view files in a table.
C Mark the files to include in the package; unmark files 

to exclude.
D Click to add files to the list.
E Enter details to include in the package report.
F Click to view the report that will be included in the 

package.

G Displays a preview of the file selected in the list.
H Click to view, create, and modify transmittal setups.
I Displays a description of the selected transmittal 

setup.
J Select the transmittal setup that defines the options 

you want to use when creating the package.

A

C

D

G

B

E

I

H

J

F
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Working with transmittal setups
Each time you create a package using the eTransmit command, you choose a trans-
mittal setup to define how the package is created. Each transmittal setup defines the 
type of package that will be created (.exe, .zip, or folder), filenaming, password con-
trol, whether to include font files, and more.

You can create, modify, and delete transmittal setups. Creating more than one trans-
mittal setup is especially helpful if you often need to package files for different recip-
ients with different requirements. 

To create or modify a transmittal setup
1 Do one of the following to choose eTransmit ( ):

• On the ribbon, choose the Application button then Publish > eTransmit, or 
choose Output > eTransmit (in Export).

• On the menu, choose File > eTransmit.

• Type etransmit and then press Enter.

2 Click Transmittal Setups.

3 Do one of the following:

• To create a transmittal setup, click New, enter a name, in Based On select a 
transmittal setup that has the settings closest to the one you want to create, then 
click Continue.

• To modify an existing transmittal setup, select it from the list, then click Modify.

The Modify Transmittal Setup dialog box displays. 

4 In Transmittal Package Type, select the type of package to create when using this 
transmittal setup. All files can be contained in a new folder, a self-extracting .exe 
file, or a .zip file.

5 In File Format, select the file format for files packaged with this transmittal setup. 
Files in the package can keep their existing file format, or they can all be con-
verted to the same file format.

6 In Transmittal File Folder, enter the default location where this transmittal setup 
will save packages when they are created. You can type a location, select a recent 
location from the list, or click [...] to select a folder.

7 In Transmittal File Name, select how to name .exe and .zip packages that are cre-
ated with this transmittal setup. (Available for EXE and ZIP package types.) The 
following options are available:

• Prompt for a filename — Allows you to enter a filename each time you create a 
package using this transmittal setup. The prompt displays after clicking OK in 
the Create Transmittal dialog box.

• Overwrite if necessary — Uses the same filename that you enter each time you 
create a package using this transmittal setup, and overwrites existing files of the 
same name. Enter the filename in the field that becomes available.
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• Increment filename if necessary — Uses the same filename that you enter each 
time you create a package using this transmittal setup, and increments the 
filename if an existing file exists with the same name. Enter the filename in the 
field that becomes available.

8 In Path Options, select one of the following:

• Place all files in one folder — Saves all files in one folder when files are 
unpackaged.

• Keep files and folders as is — Saves all files in the original folder structure, 
which is recreated on the destination computer when files are unpackaged. This 
can help with file linking when the files are used on another computer.

9 Use any of the following options to further define the transmittal setup settings:

• Transmittal Setup Description — Enter an optional description for the trans-
mittal setup. The description will display when you select this transmittal setup 
in the Create Transmittal dialog box.

• Send E-Mail with Transmittal — Select to send the package as an email 
attachment; the default email application will open after the package is created.

• Set Print Options to Default — Select to remove local printer settings from the 
package if they will not be applicable on other systems.

• Bind External References — Select to bind or insert all .dwg file external refer-
ences in the package. Binding makes external references a permanent part of the 
original drawing file, similar to a block.

• Prompt for Password — Select to prompt for a password when the package is 
created and when it is unpackaged.

• Purge Drawings — Select to purge all drawings when the package is created.

• Include Fonts — Select to add associated font files (for example, TTF, SHX) in 
the package.

• Include Unloaded File References — Select to include in the package any 
unloaded external references, including images and underlays; unloaded files 
are listed in the Create Transmittal dialog box.



W O R K I N G  W I T H  O T H E R  P R O G R A M S  A N D  C O M P U T E R S 813
A Select the type of package the transmittal setup will 
create.

B Select a file format option.
C Specify the default folder location where to save 

packages. Enter the location, select it, or click [...].
D Select how to name packages. (Available for EXE 

and ZIP package types.) 
E Select folder options to use when unpackaging files.
F Enter a description of the transmittal setup.

G Select to include any unloaded external references in 
the package.

H Select to include font files in the package.
I Select to purge all drawings when the package is 

created.
J Select to protect the package with a password.
K Select to bind or insert all .dwg file external 

references in the package.
L Select to remove local printer settings from the 

package.
M Select to send the package as an email attachment.
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To rename a transmittal setup
1 Do one of the following to choose eTransmit ( ):

• On the ribbon, choose the Application button then Publish > eTransmit, or 
choose Output > eTransmit (in Export).

• On the menu, choose File > eTransmit.

• Type etransmit and then press Enter.

2 Click Transmittal Setups.

3 Select the transmittal setup you want to rename.

4 Click rename.

5 Enter the new name, then press Enter.

To delete a transmittal setup
1 Do one of the following to choose eTransmit ( ):

• On the ribbon, choose the Application button then Publish > eTransmit, or 
choose Output > eTransmit (in Export).

• On the menu, choose File > eTransmit.

• Type etransmit and then press Enter.

2 Click Transmittal Setups.

3 Select the transmittal setup you want to delete.

4 Click Delete, then confirm the deletion.

Sending a drawing through e-mail
You can send an IntelliCAD drawing to another user via e-mail. IntelliCAD is com-
patible with e-mail programs that support the Messaging Application Program Inter-
face (MAPI) protocol.

To include a drawing file in an e-mail message
1 While the drawing file is open, do one of the following:

• On the ribbon, choose the Application button then Publish > Send Mail.

• On the menu, choose File > Send Mail.

• Type mail and then press Enter.

If your mail program is not already running, it starts; a new e-mail message con-
taining the IntelliCAD icon and file name appears.

2 Address the e-mail, type a message, and send the e-mail message as you would 
any other message.
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To view an IntelliCAD file sent by e-mail 
• Open the e-mail message, and then double-click the IntelliCAD icon.

IntelliCAD software must be installed on the computer used to open drawings 
from e-mail.

Use the eTransmit command for e-mail if the drawing has supporting files.
If the drawing is dependent on files such as external references or font files, use the 
eTransmit command to combine the files in a single package and send it by e-mail. 
When creating the package, use a transmittal setup with the Send Mail with Transmit-
tal option turned on. For more details, see “Packaging drawings and files for use on 
another computer” on page 809 in this chapter. 

Using IntelliCAD with the Internet

You can use IntelliCAD to access the Internet and exchange drawing information and 
perform other tasks, including: 

• Add hyperlinks to a drawing.

• Publish drawings to the Internet.

• Drag drawings (.dwg files) directly from a Web site into IntelliCAD.

• Access the Internet during a drawing session.
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Adding hyperlinks to a drawing 
In your IntelliCAD drawings, you can include hyperlinks, which are pointers that 
take you to another location, such as a Web address or a file on a particular computer. 
You can attach a hyperlink to any entity in your drawing. Then, when you select that 
entity, you can open the link and jump to the specific Web address or file location. 
You can create absolute hyperlinks, which store the full path to a file, or relative 
hyperlinks, which store a partial path relative to a base folder or a Uniform Resource 
Locator (URL).

To create a hyperlink
1 Type hyperlink and then press Enter.

2 Select an entity or entities that you would like to associate with a hyperlink; then 
press Enter to display the Edit Hyperlink dialog box.

3 Do one of the following: 

• Click Browse to specify a file.

• In the Link to File or URL box, type a Web address.

4 If you want to use a common path for all hyperlinks in the drawing, mark Use rel-
ative path for hyperlinks. Relative paths are most useful for local files, providing 
flexibility if you move files to a different folder; you can change multiple hyper-
link paths at once, rather than change them all individually. 

5 Click OK.

The HYPERLINKBASE system variable defines the relative path used for all hyperlinks in 
the current drawing. 
To use the default drawing path, leave the value blank by entering a period (“.”).

To remove a hyperlink
1 Type hyperlink and then press Enter.

2 Select an entity or entities with a hyperlink; then press Enter to display the Edit 
Hyperlink dialog box.

3 Click Remove Link. 

4 Click OK to close the Edit Hyperlink dialog box.

To access a hyperlink
• Hover the mouse over an entity with a hyperlink, then press Ctrl + click.

To change display options for hyperlinks
1 Type hyperlinkoptions and then press Enter.

2 To display a cursor, tooltip, and shortcut menu for hyperlinks, choose Yes, and 
then press Enter. Or choose No to turn off the display.
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Publishing drawings to the Internet
You can publish your drawings so they can be viewed on the Internet using a Web 
browser. IntelliCAD exports your drawing to a Design Web Format (.dwf) file, which 
can be viewed in a Web browser if Design Review is also installed on the computer. 
Design Review is a free tool from Autodesk®.

For details about creating a DWF file, see “Click Export.” on page 802 in this chap-
ter. 

Inserting drawings from a Web site
Some Web sites are configured to allow you to drag drawings from the Web site 
directly into your drawing. You can drag-and-drop drawings from any Web site that 
supports the Autodesk® i-drop technology. 

To insert a drawing from a Web site
1 Open your Web browser.

2 Navigate to a Web site that supports Autodesk® i-drop. 

3 Position the Web browser and IntelliCAD windows so they are both visible.

4 Click the drawing in your Web browser and drag it to your drawing in IntelliCAD.

The drawing file is downloaded and inserted into your drawing in IntelliCAD.

Accessing the IntelliCAD Web site during a drawing session
In addition to using hyperlinks to access the Internet, you can access a company Web 
site at any time. At the Web site, you can obtain company information as well as 
product information and news.

To access the IntelliCAD Web site
1 Do one of the following: 

• On the ribbon, choose Help > IntelliCAD on the Web.

• On the menu, choose Help > IntelliCAD on the Web.

• Type onweb and then press Enter.

2 Navigate to the section of your choice on the IntelliCAD Web site.
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Working with digital signatures

Attaching a digital signature to your drawing allows you to sign the drawing and 
authenticate the signature. First you obtain a digital certificate from a third-party ven-
dor or a self-signed digital certificate, then you simply attach it to your drawings. 

Additionally, if you’re working with a drawing that has a digital signature from 
someone else, you can validate the signature.

Attaching digital signatures
Before you can digitally sign a drawing, you need to obtain a digital certificate from a 
third-party vendor or generate a self-signed digital certificate, then import it to your 
computer.

After you install your digital signature, you’re ready to attach it to one or more draw-
ings.

To attach a digital signature to the current drawing
1 Do one of the following to choose Add Digital Signatures ( ):

• On the ribbon, choose the Application button then Drawing Utilities > Add 
Digital Signatures.

• On the menu, choose File > Add Digital Signatures.

• Type digitalsign and then press Enter.

2 Select Attach Digital Signature After Saving Drawing.

3 Select a digital signature from the list of digital signatures that are available on 
your computer.

4 In Comment, add information about the selected digital certificate if needed.

5 In Time Stamp, choose a time server to add a time stamp to the drawing.

6 Click OK.
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To attach a digital signature to multiple drawings
1 From the Windows Start menu, choose the program folder where IntelliCAD is 

installed, then choose Attach Digital Signatures.

2 Select a digital signature from the list of digital signatures that are available on 
your computer.

3 Add drawing files to be digitally signed by doing any of the following:

• Click Add File, select the drawing files you want to digitally sign, then click 
Open.

• Click Add Folder, select a folder that contains the drawing files you want to 
digitally sign, then click OK. All drawings in the folder will be added to the list.

4 In Comment, add information about the selected digital certificate if needed.

5 In Time Stamp, choose a time server to add a time stamp to the drawings.

6 Click Attach.

Validating a digital signature
If you’re working with a drawing that has a digital signature from someone else, you 
can validate the signature.

To validate an open drawing’s digital signature
1 Do one of the following to choose Validate Digital Signatures ( ):

• On the ribbon, choose the Application button then Drawing Utilities > Validate 
Digital Signatures.

• On the menu, choose File > Validate Digital Signatures.

• Type digvalidate and then press Enter.

2 Check the status of the digital signature:

• Valid — The digital signature is verified by the certificate authority and no 
changes have been made to the drawing since it was digitally signed.

• Invalid — The current drawing has been modified since it was digitally signed, 
the certificate has been revoked by the certificate authority, or the drawing has 
become corrupted.

• Not found — A digital signature is not attached to the current drawing.

3 Click View Base Signature to view detailed information about the digital signature 
attached to the drawing. (Unavailable if there is no digital signature attached.)
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4 If the drawing has external references attached, do any of the following:

• Mark View Xref Drawings to display the list of all external references attached 
to the current drawing.

• Select an external reference and click View Xref Signature to view detailed 
information about its digital signature. (Unavailable if there is no digital 
signature attached to the selected external reference.)

5 Click OK.



17

Customizing IntelliCAD

You can customize IntelliCAD in a number of ways. For example, you can change 
the appearance of many aspects of the program and modify the existing menus and 
toolbars or create new ones. This section explains how to: 

• Set the program’s preferences.

• Customize the user interface, including tool palettes, menus, toolbars, and the 
Quick Properties pane.

• Customize keyboard shortcuts, aliases, double-click actions, and image tile menus 
for frequently used commands.

• Customize entities.

• Create and use scripts.

• Use add-on programs with IntelliCAD.

• Use additional pointing devices such as a 3D mouse and digitizer tablet.

• Reset the program to its default settings. 

Topics in this chapter

Setting and changing options............................................................................822

Customizing tool palettes ..................................................................................864

Customizing menus...........................................................................................869

Customizing the ribbon .....................................................................................879

Customizing toolbars.........................................................................................891

Customizing the keyboard, aliases, double-click actions, and image tile menus ....
899

Customizing the Quick Properties pane............................................................914

Working with user interface customization files.................................................916

Customizing entities ..........................................................................................935

Creating and replaying scripts...........................................................................939

Programming IntelliCAD....................................................................................944

Using specialized pointing devices....................................................................953
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Setting and changing options

You can change many of the options that control the program’s behavior and appear-
ance, such as setting the experience level, specifying file paths and default files, con-
figuring display features, and configuring how certain features work.

Changing the options on the General tab
In the Options dialog box, the General tab contains settings for experience levels, 
save and open options, and various file options. You can also set VBA security.
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A Click to save open drawings automatically. 
B Mark to save an older file version with a .bak 

extension each time drawings are saved.
C Select how to treat autosave and backup files 

when drawings close.
D Select the default file format that displays when 

saving drawings using the Save As dialog box.
E Enter the percentage of a drawing that can be 

estimated as wasted space before a full save is 
performed. Enter 0 to turn off incremental saving.

F Select to check all drawings for errors when 
opening them, and attempt recovery, as needed.

G Select to hide warning messages when opening 
drawings. (Available if recover is turned on.) 

H Click to turn off error reporting when an issue is 
encountered while running IntelliCAD.

I Click to disable VBA CommonProject macros on 
startup. (Available in some program versions.)

J Click to set filetype associations for IntelliCAD.
K Click to send a complete report of crash data. 

(Available if error reporting is turned on.)
L Type the file extension for autosaved files. 

(Available if autosave is turned on.)
M Enter the autosave frequency. (Available if 

autosave is turned on.)
N Select the experience level.

N

K

A

D

L

E

F
G

H

I

J

B
C

M



824 C H A P T E R  1 7
Setting the experience level 
You can control which menus and tools are available by setting the experience level. 
You can choose from the following experience levels: 

• Beginner Menus and toolbars display only basic commands. 

• Intermediate Menus and toolbars display most two-dimensional entity creation 
and modification commands.

• Advanced Menus and toolbars display all available commands. 

To set the experience level  
1 Do one of the following to choose Options ( ):

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the General tab.

3 Under Experience level, select Beginner, Intermediate, or Advanced.

4 When you have finished, click OK.

Saving your drawings automatically
To avoid losing data in the event of a power failure or other system error, save your 
drawing files often. You also can configure the program to periodically save your 
drawings automatically. The minutes setting determines the interval between auto-
matic saves. The program restarts this interval timer whenever you save the drawing 
file.        

When autosave is enabled, the program creates a copy of your drawing. The file is 
saved in the folder specified in Options > Paths/Files for Temporary Files, with the 
file extension specified in the File Extension box (by default, .SV$).

To set how drawings are saved automatically
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the General tab.
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3 To save your drawings automatically, do the following:

• Mark Autosave Drawing.

• In Minutes, enter the frequency that you want to save drawings. Do not use too 
brief a time if you often work with large drawings, because it can take a minute 
or more to save a very large drawing.

• If you want to change the default extension assigned to autosave files, type the 
new extension in File Extension.

4 To save an older version of drawings with a .bak file extension every time a draw-
ing is saved, mark Back Up to BAK File when Saving Drawings.

5 In When Drawings Close, choose how to treat autosave and backup files when the 
program or drawings close.

6 When you have finished, click OK.
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Setting the default Save As format and incremental save options
You can control the default file format that you want to display in the Save Drawing 
As dialog box. For example, if you use the Save As command to save most of your 
drawings in a legacy file format, you can select that file format as the default so you 
don’t have to select it each time you save a drawing using the Save As command. 
This setting has no effect on saving existing or new drawings using commands other 
than Save As — IntelliCAD always saves existing drawings in their current file for-
mat and saves new drawings with the most current file format.   

You can also enable incremental saving, which saves only the changed parts of draw-
ings instead of re-saving the entire drawing (a full save). This option makes saving 
drawings, especially large drawings with only a few changes, much faster.

To set the default Save As format and incremental save options
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the General tab.

3 In Default Format, select the default drawing format that displays when using the 
Save As command. You can always specify a different format in the Save Draw-
ing As dialog box. 

4 In Incremental Save Percentage, specify what percentage of the drawing file to 
allocate as blank space for incremental saves. When drawing changes exceed the 
allocated empty space, a full save is performed the next time a save operation is 
required. To disable incremental saves, enter 0.

Incremental saves are much faster than a full save but also increase file sizes. 
Higher values reduce the number of full saves and increase performance, but also 
increase the size of the drawing file.

5 When you have finished, click OK.
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Setting how drawings are opened 
There are several options that determine how drawings are opened in IntelliCAD. 
You can specify which file extensions are associated with IntelliCAD, allowing you 
to open files such as .dwg files automatically using IntelliCAD.

Additionally, you can set up IntelliCAD to open drawings automatically using the 
Recover command, for example, if you are a new IntelliCAD user and your original 
drawings were created using different CAD software and those drawings regularly 
contain errors or damaged data. The Open Drawings using Recover option automati-
cally checks all drawings for errors when using the Open command, and attempts 
recovery, as needed. Viewing warning messages when opening drawings allows you 
to know which files are being fixed by IntelliCAD and what errors have occurred; 
however, you can also choose to hide the warnings.

To set how drawings are opened
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the General tab.

3 To specify the file types that open automatically using IntelliCAD, click Set Files 
Association and make your selections.

4 If you want to use the Recover command automatically each time you use the 
Open command, mark the check box for Open Drawings using Recover. 

5 If you want to hide warnings when errors are found in a drawing, mark the check 
box for Hide Warnings when Opening Drawings using Recover. Errors will still 
be logged in an ASCII file with an .adt extension.

6 When you have finished, click OK.
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Setting error reporting options
Error reporting occurs when IntelliCAD encounters a crash issue. You can specify 
whether error reporting occurs and whether a full report is generated. It is recom-
mended to generate the full report only if requested for troubleshooting purposes. The 
completed report of crash data can be up to 100MB in size, and while it contains help-
ful information for troubleshooting issues, is more likely to fail during transmission 
due to its file size.

To change the options on the General tab
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the General tab.

3 If you want to turn off error reporting, mark the check box for Disable Error 
Reporting. 

4 If you want to generate a full report when error reporting is turned on, mark the 
check box for Generate Full Report.

5 When you have finished, click OK.

Disabling VBA CommonProject macros 
Each time you start IntelliCAD, macros are automatically loaded for the Visual Basic 
Application (VBA) CommonProject. If you do not plan to use VBA, disabling the 
macros may improve performance. In addition, disabling the macros can enhance 
security if you are running IntelliCAD at a low security level.

To change the options on the General tab
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the General tab.

3 If you do not want the CommonProject macros to be loaded when you start Intelli-
CAD, under VBA Security, click the check box for Disable VBA CommonProject 
Macros On Startup.

4 When you have finished, click OK.
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Changing the options on the Paths/Files tab 
You can specify locations for various file types such as those used for drawings, 
fonts, and menus in the Options dialog box on the Paths/Files tab. You can even 
specify multiple paths for the same file type. In addition, you can change the names 
of the default system files that are used for functions such as font mapping and error 
logging.

Specifying the user paths 
You can enter paths to your IntelliCAD directories by selecting them in the Options 
dialog box. This feature includes directories for drawings, fonts, help, external refer-
ences, menus, tool palettes, hatch patterns, blocks, print style tables, print output files, 
temporary files, templates, and color books. IntelliCAD searches directories for sup-
port files in the following order:

• The IntelliCAD program directory.

• The current drawing directory.

• The Windows search path.

• The search path specified in the Options dialog box. 

You can enter multiple paths for each item. 
If, for example, the Drawings item has more than one directory associated with it, 
click Add to specify additional paths. You can also separate multiple paths with a 
semicolon if typing them. IntelliCAD searches the directories in the order in which 
they are listed.

To specify a user path
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Paths/Files tab.

3 In the upper half of the dialog box, do one of the following:

• Right-click and choose from the shortcut menu of options.

• Click a category to view its search paths, then single-click the path you want to 
modify, and type the path. 

If you do not know the path or directory name, click Browse, and then browse to 
the location of the directory you want.

4 When you have finished, click OK.
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Changing the default system files 
You can change the default system files, including the log file, default template, alter-
nate font, and font mapping file.

To change a default system file
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Paths/Files tab.

3 In the lower half of the dialog box, under Program Files, do one of the following:

• Right-click and choose from the shortcut menu of options.

• Click the file name for the default system file you want to change, and type a 
new file name.

If you don’t know the file name, click Browse, and then browse to the location of 
the file you want.

4 When you have finished, click OK.
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Changing the options on the Display tab
In the Options dialog box, the Display tab contains settings for displaying the 
command bar, IntelliCAD window, menus, mouse actions, and program language.

A Click to view default paths. Click or press the F2 
key to modify a selected path. Double-click a 
path to open the path in Windows Explorer.

B Click or press the Insert key to add a new path 
for the current category.

C Click or press the Delete key to remove the 
selected path.

D Select the default file to change.

E Click to locate and specify a new default file.
F Click to move the selected path up one position 

in search order.
G Click to move the selected path down one 

position in search order.
H Click to remove custom paths and use the 

default paths for the selected category.
I Click to locate and specify a new path.
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A Type or select the maximum number of 
command lines to track.

B Select to suggest command names 
automatically when typing in the command bar.

C Select to use Up and Down arrows for scrolling 
the command history instead of panning.

D Select the look for all IntelliCAD windows.
E Displays the language used to show options 

throughout the program. Click [...] to select 
language settings.

F Select to show or hide a paper sheet in paper 
space on Layout tabs.

G Click to show or hide the Model and Layout tabs.
H Click to show or hide scroll bars.
I Click to display the drive and folder location of 

the drawing in the drawing title bar.
J Click to display all icons in the user interface in 

high-contrast grayscale instead of color.
K Click to activate any messages that were 

previously set to not display again.
L Click to show or hide grip menus.
M Click to show or hide prompt boxes.

N Click to show or hide view and visual style 
controls in the upper-left corner of the current 
viewport.

O Click to show or hide window controls in the 
upper-right corner of the drawing area.

P Type or select the percentage of transparency to 
apply to prompt boxes when they display. 

Q Type or select the number of recently used 
drawings to track.

R Click to set the graphics device and other 
performance settings.

S Click to specify options for file tabs that can 
display for each drawing in the main window.

T Click to set the fade percentage for items.
U Click to specify how tools are displayed on the 

toolbars and which toolbars display.
V Click to select mouse actions.
W Click to assign colors to various UI elements of 

the drawing window.
X Click to determine how the pointer displays.
Y Click to determine how command names are 

suggested when typing in the command bar.
Z Click to select font options for the command bar.
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Setting how the command bar works
The command bar is a dockable window in which you type IntelliCAD commands 
and view prompts and other program messages. To display the command bar, use the 
Command Bar command. To customize how the command bar works, change the 
options on the Display tab.

To set how the command bar works
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Display tab. 

3 In Command Lines to Track, enter the desired number of previous command and 
command prompts that are tracked in the command bar. The default value is 256. 
You can also display the commands in the Prompt History window by pressing 
F2. To close the window, press F2 again.

4 To select font options for displaying the command bar, click Font, then select the 
font, font style, and font size. Then click OK.

5 Mark the Use Up/Down Arrows for Command History Navigation check box if 
you want to scroll the command history text when using the Up and Down arrows 
on the keyboard. This can be a convenient way to review and even repeat previous 
commands. If unchecked, using the keyboard arrows pans your view of the draw-
ing. 

Use alternate keyboard shortcuts.
For panning, you can use Alt+arrow keys.

6 Mark the Enable AutoComplete check box to use the AutoComplete feature when 
typing commands in the command bar. For more details about AutoComplete, see 
“Customizing how suggestions display in the command bar” on page 834 in this 
chapter. 

7 When you have finished, click OK.

Colors of command bar items can be customized. 
To change the color of various parts of the command bar, use the Options command. 
For details, see “Setting colors of the main window” on page 840. 
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Customizing how suggestions display in the command bar
When you type in the command bar, IntelliCAD suggests names of matching com-
mands as you type. The suggested names appear in an AutoComplete window that 
automatically opens when you type and closes when you activate a command.

Using AutoComplete is an efficient way to select commands, and it is also a conve-
nient way to view a list of related commands. For example, if you type "LA" in the 
command bar to work with layers, all layer-related commands that begin with "LA" 
display in the AutoComplete window.

In addition to command names, suggestions can include names of external com-
mands, system variables, aliases, and LISP functions. Each name displays with a col-
ored icon that indicates its type:

• Red — IntelliCAD command

• Green — External command

• Yellow — System variable

• Blue — LISP function

To customize how suggestions display in the command bar
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Display tab. 

3 Mark the Enable AutoComplete check box to turn on automatic suggestions of 
names as you type in the command bar. 

4 Click AutoComplete Options.

Use a shortcut.
Type INPUTSEARCHOPTIONS and then press enter to access autocomplete 
options directly from the command bar.

5 In AutoComplete Delay, enter the number of milliseconds to wait between key-
strokes before displaying the AutoComplete window. The higher the number, the 
longer the delay allowed between keystrokes (the AutoComplete window displays 
less frequently).
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Fast typists usually increase the timeout setting.
If the AutoComplete window often conflicts with your typing in the command bar, 
try setting the number of milliseconds to 1,000 or more.

6 In Minimum Length of Text, enter the number of letters to be typed in the com-
mand bar before displaying the AutoComplete window.

7 In Transparency, enter the percentage of transparency, between 0 and 50, in which 
to display the AutoComplete window. The higher the number, the more transpar-
ent the window is. Enter zero for an opaque window.

8 In Suggestions List Limit, enter the number of items that can be displayed in the 
AutoComplete window.

9 Determine how selection works:

• Mark Use Recent Commands to search for and automatically select a recently 
used command, when possible.

• Mark Show Suggestions in Command Line to pre-fill the command line with the 
name as you scroll the list. If turned off, the name does not pre-fill in the 
command line, however, you can still select the desired name in the AutoCom-
plete window by clicking it or pressing CTRL + Enter.

• Mark Cycle Selection if you want to allow Arrow key scrolling from the end to 
beginning (and vice versa) in the list.

• Mark Mouse-Over Selection to allow selection by hovering the mouse, and not 
clicking it, over the desired name.

10 Mark Show Command Icons to display icons, if available, for each command in 
the list.

11 Mark Use Command Line Colors to display the AutoComplete window using the 
same background and text colors that are selected for the command bar. For more 
details about selecting command bar colors, see “Setting colors of the main win-
dow” on page 840 in this chapter. 

12 Mark which items to include in the list of suggested names: aliases, external com-
mands, system variables, and/or LISP functions. If selected, LISP functions dis-
play when you enter a parenthesis, “(“, when first typing.

13 Click OK.

14 Click OK.
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A Enter the number of milliseconds to wait 
between keystrokes before displaying the 
AutoComplete window.

B Enter the minimum number of letters to be typed 
before displaying the AutoComplete window.

C Enter the percentage of transparency in which to 
display the AutoComplete window.

D Click to search for and automatically select a 
recently used command.

E Click to pre-fill the command line with the full 
name as you scroll the list. 

F Click to allow Arrow key scrolling from the end of 
the list to the beginning (and vice versa).

G Click to allow selection by hovering the mouse 
over a desired name.

H Click to show or hide icons for commands.
I Click to use the same colors in the 

AutoComplete window as specified for the 
command bar.

J Click to include LISP function names.
K Click to include system variable names.
L Click to include external command names.
M Click to include alias names.
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Setting the main window options
The main IntelliCAD window can be customized in many ways to best accommodate 
your work style. For example, hiding window elements if you do not use them can 
help increase drawing space in the IntelliCAD window.

To set the main window options
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Display tab. 

3 In Theme, select the look you want for all IntelliCAD windows.

4 Mark the Show Paper Sheet in Paper Space checkbox if you want to display a 
bounded sheet of paper for Layout tabs. When unmarked, the paper sheet does not 
display.

5 Mark the Show Printable Area in Paper Space checkbox if you want to display a 
dashed rectangle that indicates the printable area on Layout tabs. The printable 
area is defined by the printer selected for the layout and any custom margins. 
When unmarked, the dashed line does not display.

6 Mark the Show Model and Layout Tabs checkbox if you want to display the 
Model tab and Layout tabs in the main window. When unmarked, the tabs do not 
display, which can be helpful if you only work on the Model tab or if you use the 
command bar and status bar to switch between tabs.

7 Mark the Show Scroll Bars checkbox if you want to display the scroll bars on the 
right side and bottom of the IntelliCAD window or viewport. When unmarked, the 
scroll bars do not display, which can improve performance and can also be helpful 
if you only use the Pan command to scroll drawings.

8 Mark the Show Full Drawing Path in Title Bar check box if you want to display 
the drive and folder location of the drawing in the drawing title bar in addition to 
the filename. When unmarked (the default), only the filename displays in the 
drawing title bar.

9 Mark the High-Contrast Grayscale Buttons check box if you want to display all 
icons in the user interface in high-contrast grayscale instead of color.

10 Click Toolbar Options to specify how tools are displayed on the toolbars and 
which toolbars display. Click OK when finished.

11 Click Fade Control to determine the fading percentage for entities and files:

• Xref Display Enter a value or move the slider to specify the fade percentage 
applied to .dwg file external references.

• Entities on Locked Layers Enter a value or move the slider to specify the fade 
percentage applied to entities that are located on locked layers.
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Use a shortcut.
On the ribbon, choose Locked Layer Fade Control (in Layers), type the percent-
age, then press Enter.

• In-place Edit and Annotation Representations Enter a value or move the slider 
to specify the fade percentage applied when editing an external reference in 
place. Fading is applied to the entities of the external reference that are not 
currently being edited.

12 Click OK.

13 Click File Tab Options and select options for displaying drawings on tabs in the 
main window:

• Enable File Tabs  — Select to display each drawing as its own tab in the Intel-
liCAD window. If turned off, drawings display as separate windows.

• Tab Style  — Select a style in which to display the tabs.

• Tab Close Button  — Select to display an [X] for a Close button on the active 
tab. If turned off, Close buttons do not display on drawing tabs.

• Show Icons  — Select to display an icon on each tab that indicates the type of 
drawing file. If turned off, icons do not display on the drawing tabs.

• Top Location  — Select to position the tabs at the top of drawings. If turned off, 
tabs are positioned at the bottom of drawings.

14 Click OK.

15 Click Restore Suppressed Messages if you want to reactivate any messages that 
were previously set to not display again.

16 When you have finished, click OK.
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Setting how the pointer displays
The pointer can display as a crosshairs instead of the default arrow cursor. If the 
pointer displays as a crosshairs, you can determine its size and other options.

To set colors of the main drawing window
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Display tab. 

3 Click Cursor Options to determine how the pointer displays:

• Pointer Defaults to Crosshairs Click this check box to always display the 
pointer as the crosshairs (instead of the default arrow cursor with a selection 
pick box). Note that if this check box is not selected, all subsequent options are 
unavailable.

• Crosshairs Size Enter a number for the percentage of the screen to be used by 
the crosshairs cursor, or use the up and down arrows to scroll to the number. 
Note that depending on your graphics device, a large percentage can negatively 
affect display performance.

• Gun Sight Crosshairs Click this check box to display the pointer as the gun sight 
crosshairs instead of the regular crosshairs. You can also control this option by 
clicking Gun Sight Crosshairs On/Off in the status bar.

• Crosshairs Use XOR Invert Colors Click this check box to turn on use of a 
logical XOR for the cursor color, which changes the color of the cursor as it 
moves over solid colors in the drawing so that the cursor is still visible. You can 
also control this option by clicking XOR Cursor On/Off in the status bar.

4 Click OK. 
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Setting colors of the main window
You can control the color of many aspects of the main drawing window, such as 
background color, crosshairs color, and more. You can also control the color of items 
that display in paper space, the block editor, and the command bar.

To set colors of the main drawing window
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Display tab. 

3 Click Color Scheme. 

4 In Context, select the area that contains items for which you want to specify col-
ors: Model space, Paper space, Block editor, or Command bar.

5 In Items, select the item for which you want to specify a color.

6 In Colors, select a color or choose Select Color for more options.

7 Click On/Off to show or hide the item (available only if the selected item can be 
turned off).

8 When you have finished, click Apply & Close.
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To save and open color schemes
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Display tab. 

3 Click Color Scheme.

4 Make any adjustments before you save the settings.

A Select an area of the drawing window.
B Select an item for which to change color.
C Displays an example of the current color 

selections.
D Click to save the current color settings in a color 

scheme file.
E Click to select a color scheme file and load it. 
F Click to restore color defaults for all contexts and 

items.

G Click to restore color defaults for the currently 
selected context.

H Click to restore the color default for the currently 
selected item.

I Click to show or hide the selected item (available 
only if the item can be turned off).

J Select a color for the currently selected item. 
Choose Select Color for more color options.
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5 Click Save to save the current color selections as a color scheme file.

6 Click Load to select a color scheme (.xml or .clr file) and load it.

7 Click Apply & Close.

Color schemes are an easy way to reuse favorite color settings.
If you work on more than one computer, save a color scheme to a file and load the file 
on another computer.

To restore colors to their defaults
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Display tab. 

3 Click Color Scheme.

4 Do one of the following:

• Reset a single item — Select the item you want to revert to the default color, 
then click Current Item. 

• Reset all items in a context — Select the context, then click Current Context. 
All items in the current context will be reverted to their default colors.

• Reset all colors — Click All Colors. All items in all context will be reverted to 
their default colors.

5 Click Apply & Close.
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Setting mouse options
Mouse actions can be customized to best accommodate your work style. For exam-
ple, you may prefer to repeat a recent command when right-clicking the mouse if you 
do not use shortcut menus.

A 3Dconnexion mouse is set up differently.
For more details, see “Using a specialized mouse for CAD” on page 953 in this 
chapter. 

To set mouse options
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Display tab. 

3 Mark the Reverse Mouse Wheel Zoom Direction check box if you want to reverse 
the zoom direction of the mouse wheel, that is, spin the wheel forward to zoom out 
and spin it backward to zoom in, This can be especially helpful if you use the 
mouse with your left hand. When unmarked (the default), you spin the mouse 
wheel forward to zoom in and spin it backward to zoom out.  

4 Mark the Use Mouse Wheel to Scroll Ribbon Tabs check box if you want the abil-
ity to scroll ribbon tabs using the mouse wheel when the mouse hovers over the 
ribbon.

5 To set the action to take when you right-click the mouse in a drawing, choose from 
the following options:

• Without Entities Selected — To repeat the previously used command if you 
right-click when entities are not selected, choose Repeat Last Command. To 
display a shortcut menu if you right-click when entities are not selected, select 
Show Shortcut Menu.

• With Entities Selected — To repeat the previously used command if you right-
click when entities are selected, choose Repeat Last Command. To display a 
shortcut menu that displays options specific to the selected entities if you right-
click, select Show Shortcut Menu. You can right-click anywhere in the drawing 
with entities selected and the shortcut menu for the selected entities will display.  

6 When you have finished, click OK.
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Setting the language
The list of available languages depends on which languages were installed on your 
computer. If the desired language doesn't appear in the list, repair or re-install the 
application with customized settings for the desired language.

To set the language
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Display tab.

3 In Language, click [...].

4 In Language Selection Method, choose one of the following options:

• Manual selection — Uses the language selected in the Installed Languages list. 

• Automatically match regional settings — Matches the language set for the 
geographical region 

• Automatically match system locale — Matches the language set for the 
operating system. 

5 Click OK.

6 When you have finished, click OK. 
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A Displays the language set for the geographical 
region.

B Displays the language set for the operating 
system.

C Select to choose the desired language from the 
list of installed languages. 

D Select to automatically match the language set 
for the geographical region. 

E Select to automatically match the language set 
for the operating system.

F Displays a list of languages installed for 
IntelliCAD. Click the desired language in the list; 
available only if the manual selection method is 
chosen.

G Click to open the operating system's dialog box 
for setting language options.
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Customizing graphics device options for display performance
Depending on your computer and its available graphics devices, IntelliCAD automat-
ically determines the best settings for displaying and rendering drawings. In some 
cases however, users may want to customize certain settings themselves. For exam-
ple, switching between graphics devices can sometimes resolve performance issues 
when using specific graphics cards.

To set graphics device options
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Display tab. 

3 Click Graphics Performance.

Use a shortcut.
In the status bar, right-click Switch Graphics Device and choose Settings to open 
the Graphics Performance dialog box. Or type graphicsconfig.

4 In Graphics Device, choose which graphics device to use:

• Advanced (OpenGL ES) Select for high-end graphics cards. This graphics 
device is recommended for best 3D rendering quality as it supports advanced 
visual styles and high quality transparency. Note that it can decrease 
performance.

• Intermediate (OpenGL) Select for mid-level graphics cards. This graphics 
device is recommended for best performance when working with 2D and 3D 
wireframe visual styles.

• Basic (Software) Select for entry-level graphics cards that do not support 
OpenGL.

Use a shortcut.
In the status bar, click Switch Graphics Device to switch to the next graphics 
device in the list.

5 To turn on line smoothing (anti-aliasing) for entities displayed with two-dimen-
sional visual styles, mark Line Smoothing for 2D Visual Styles. Turning on this 
option improves display quality but can decrease performance. This option is 
available only for an advanced or intermediate graphics device.

6 To turn on line smoothing (multi-sampling anti-aliasing) for entities displayed 
using three-dimensional visual styles, mark Line Smoothing for 3D Visual Styles. 



C U S T O M I Z I N G  I N T E L L I C A D 847
Turning on this option improves display quality but can decrease performance.  
This option is available only for an advanced graphics device.

7 Click OK.

Setting how menus display
The display of menus can be customized, including whether prompt menus and right-
click shortcut menus display, whether menus load automatically, and the number of 
drawing files that display on the File menu.

To set how menus display
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Display tab.

3 Mark the Display Grip Menus check box if you want grip menus to display when  
the mouse pauses over a grip that has an associated menu. For example, polyline 
grips have a menu.

4 Mark the Display Prompt Boxes check box if you want to show prompt boxes, 
which display the same options for commands that display on the status bar and 
the command bar. Turning prompt boxes off may save screen space and may min-
imize mouse clicks.  

5 Mark the Display View Controls check box if you want to display a view and 
visual style control in the upper-left corner of the viewport that is currently active.

6 Mark the Display Drawing Window Controls check box if you want to display 
minimize, maximize, and restore window controls in the upper-right corner of the 
drawing area.

7 In Recent Drawing List Size, enter how many recently opened drawings are listed 
on the File menu, and in the Recent Documents list on the Application button and 
Start Page (if your program version supports them). 

8 In Prompt Boxes Transparency, enter the percentage of transparency to apply to 
prompt boxes when they display.

9 When you have finished, click OK. 
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Customizing display options for high resolution monitors or for switching 
between monitors
IntelliCAD is designed to run at the proper size on a variety of monitors with differ-
ent display resolutions. However, if you switch between monitors that have different 
resolutions, or if you’re using a monitor with 4K or higher resolution, you might need 
to set some options manually.

These custom options are system variables available at the command prompt, not in 
the Options dialog box.

To set display options for 4K monitors or for switching between monitors
1 Type any of the following system variable names and change their settings:

• 3DORBITCTRSPHERESIZE — Controls the size of the small orbit sphere that 
displays at the rotation point when using the Constrained Orbit (3DORBIT), 
Continuous Orbit (3DCORBIT), and Free Orbit (3DFORBIT) commands. Enter 
a number from 1 to 20.

• APERTURE — Controls the entity snap selection area in pixels. Enter a number 
from 1 to 10.

• BLIPSIZE — Controls the blip marker size in pixels. A blip is the plus sign (+) 
that appears temporarily when you specify a point on the screen. Enter a number 
from 1 to 255.

• GRIPSIZE — Controls the size of the box (in pixels) used to display grips. Enter 
a number from 1 to 255.

• PDSIZE — Controls the point display size. The default value (0) specifies a point 
size 5% of the screen size. A value greater than 0 specifies the absolute size, and 
a value less than 0 specifies a percentage size. 

• PICKBOX — Controls the target height for entity selection in pixels. Enter a 
number from 0 to 50.

• SNAPSIZE — Controls the entity snap marker size in pixels. An entity snap 
marker is a temporary glyph that appears when using entity snapping and 
indicates the current snap location. Enter a number from 1 to 20.
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Changing the options on the Profiles tab
IntelliCAD allows you to customize the settings that control your drawing environ-
ment, and then save and restore those settings in a profile. For example, if you prefer 
working with custom menus and toolbars, you can save these settings as your own 
profile. 

Profiles can be helpful if you have multiple users with different preferences, or if you 
are a single user who works on various projects that require unique settings. You can 
even export your profile and bring it with you when you work on a different com-
puter. 

Understanding the settings saved in profiles
Profiles save many settings that control the drawing environment. Once you start 
using a profile, it automatically tracks and stores changes that you make to your 
drawing environment.

Some settings are saved immediately, but some require that you exit IntelliCAD and 
then start IntelliCAD again. This is because profiles save settings from your com-
puter’s registry and some settings are only saved to the registry when you exit Intelli-
CAD.  

Settings saved in profiles
Setting Location When saved
Toolbar settings Tools > Customize, Toolbars tab Exit and restart of IntelliCAD

Menu settings Tools > Customize, Menus tab Immediately

Keyboard settings Tools > Customize, Keyboard tab Immediately

Alias settings Tools > Customize, Aliases tab Immediately

Window elements on/off 
status and their various 
settings

View > Display > Command Bar
View > Display > Model and 
Layout Tabs
View > Display > Prompt History 
Window
View > Display > Scroll Bars
View > Status Bar

Exit and restart of IntelliCAD

Tablet configurations Tools > Tablet Immediately

User paths Tools > Options, Paths/Files tab Immediately

System variables Typed in command bar Varies — some saved immediately 
and some upon exit and restart of 
IntelliCAD
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Creating profiles
Create profiles if you want to save your custom drawing environment settings. This 
can be helpful if you have two or more drawing environments that you use regularly.

When you create a new profile, the current drawing environment settings are auto-
matically saved with the new profile.

To create a profile
1 Do one of the following to choose Options ( ):

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Profiles tab.

3 Click Create.

4 Enter a name, a description (optional), and then click OK.

5 In the Options dialog box, click OK.

6 Make changes to your drawing environment.

IntelliCAD automatically saves the settings to the new profile. 

Some cases require you to exit and restart IntelliCAD before settings are saved with the 
profile.  
This is because profiles save settings from your computer’s registry and some set-
tings, such as toolbar settings, are only saved to the registry when you exit Intelli-
CAD. 
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Loading a profile
While you work in IntelliCAD, you can load the custom settings of any profile. The 
current profile when you exit IntelliCAD is automatically loaded when you start 
IntelliCAD again.

To load a profile
1 Do one of the following to choose Options ( ):

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Profiles tab.

3 Select the desired profile.

A Displays the name of the currently loaded profile.
B Select a profile to load it or modify it.
C Displays a description of the profile.
D Click to restore the selected profile to the system 

default settings.
E Click to open a profile stored in an .arg file.
F Click to save the selected profile in an .arg file.

G Click to delete the selected profile.
H Click to rename the selected profile.
I Click to make a copy of the selected profile.
J Click to load the selected profile and make it the 

active profile.
K Click to create a new profile.
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4 Click Set Current.

Restoring the default profile settings
At any time you can return to the default drawing environment settings that were 
installed with IntelliCAD. 

If the Default profile is unchanged, simply load it to restore the default settings. If the 
Default profile is deleted or changed, reset an existing profile (one that you no longer 
need) to replace its contents with the default settings.

To restore default settings using an unchanged Default profile
1 Do one of the following to choose Options ( ):

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Profiles tab.

3 Select the Default profile.

4 Click Set Current.

To restore default settings without using the Default profile

Resetting a profile erases all of the profile’s custom settings.  
Do this only if you are certain you no longer need the selected profile.

1 Do one of the following to choose Options ( ):

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Profiles tab.

3 Select a profile that you no longer need; all of it’s custom settings will be erased. 

If necessary, create or copy a profile to use for restoring the default settings.

4 Click Reset. 
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Managing profiles
Once you start using profiles, you may need to rename, copy, or delete them. Copy-
ing a profile is a quick way to create a new profile based on an existing profile.

To rename a profile
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Profiles tab.

3 Select the profile you want to rename.

4 Click Rename.

5 Make any necessary changes to the name or description, and then click OK.

To copy a profile
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Profiles tab.

3 Select the profile you want to copy.

4 Click Copy.

5 Enter a new name, a description (optional), and then click OK.

To delete a profile
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Profiles tab.

3 Select the profile you want to delete.

4 Click Delete.
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Working with profiles on multiple computers
If you use multiple computers and you like to work with our own drawing environ-
ment settings, save time by bringing your profile with you.

On your computer, export your profile to an .arg file. Bring the file with you to the 
other computer using a disk, E-mail, network, or some other method. When you start 
working at another computer, simply open and load your profile instead of recreating 
your preferred drawing environment.

To export a profile to a file
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Profiles tab.

3 Select the profile to export.

4 Click Export.

5 Specify a location and name for the exported file, and then click Save.

To open a profile from a file
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Profiles tab.

3 Click Import.

4 Locate and select the profile (.arg file), and then click Open.

5 Make any necessary changes to the name or description, and then click OK.

6 (Optional) To load the imported profile, select it, and then click Set Current.
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Changing the options on the Printing tab
In the Options dialog box, on the Printing tab, you can determine several print set-
tings, including the default printer, headers, footers, printer configuration files (PC3 
files), and print styles that change the appearance of your printed drawing without 
modifying the actual entities in your drawing.

A Select a default printer to assign to new 
drawings.

B Click to specify settings that are used when 
automatically publishing drawings.

C Choose if you want drawings to be automatically 
published when they are saved or closed.

D Click to specify settings for printer configuration 
files (PC3 files).

E Click to specify a header or footer for printed 
drawings.

F Click to specify print style table settings for new 
drawings created without a template or legacy 
drawings.

A

B

C
D

E

F
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Setting the default printer
A default printer, or output device, is assigned to all new drawings. Select the device 
you use most often when printing drawings. Later, if needed, you can assign a differ-
ent printer for any existing drawing.

To set the default printer
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options then click the Printing tab or choose 
File > Printer Options.

• Type options, press Enter, then click the Printing tab.

2 In Default Output Device, select a printer to assign to new drawings.

3 When you have finished, click OK.

Setting automatic publishing options
A default printer, or output device, is assigned to all new drawings. Select the device 
you use most often when printing drawings. Later, if needed, you can assign a differ-
ent printer for any existing drawing.

To set automatic publishing options
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options then click the Printing tab or choose 
File > Printer Options.

• Type options, press Enter, then click the Printing tab.

2 Click Automatic Publish Settings to specify settings that are used when automati-
cally publishing drawings. For more details about these settings, see “Publishing a 
sheet list automatically” on page 684. 

3 To turn on automatic publishing when you save or close drawings, mark Auto-
matic Publish on Save or Close.

4 When you have finished, click OK.

You can also set up automatic publishing options using the Auto Publish command.
For more details, see “Publishing a sheet list automatically” on page 684. 
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Setting default print styles
Default print style settings affect only specific drawings: new drawings created with-
out a template and older drawings when opened (older drawings that were created 
before print styles were available, for example, before AutoCAD 2000). Drawings 
that are currently opened are not affected. 

For more details about print styles and print style tables, see “Using print styles” on 
page 648. 

To set default print style settings for new drawings
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options then click the Printing tab or choose 
File > Printer Options.

• Type options, press Enter, then click the Printing tab.

2 Click Print Style Settings.

3 Select to use color-dependent or named print style tables for new drawings created 
without a template. 

4 Select a default print style table to use with new drawings.

5 For named print style tables, select both the print style to assign to layer zero and 
to new entities. For color-dependent tables, the print style is BYCOLOR and is not 
selectable.

6 Click OK. 

7 When you have finished, click OK.
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Specifying a header and footer
You can include information such as a date and time stamp, your name and company 
name, or other information that you want to appear at the top or bottom of drawings 
when you print them. 

Header and footer settings are set globally for all drawings, although they don’t have 
to be included with each drawing you print. When printing, in the Print dialog box 
mark or unmark Print Stamp On accordingly.

To specify a header and footer for all drawings
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options then click the Printing tab or choose 
File > Printer Options.

• Type options, press Enter, then click the Printing tab.

2 Click Print Stamp Settings.

3 If you want to start with or use the header, footer, and settings from a print stamp 
settings (.pss) file, click Load, specify the file, then click Open.

4 Type the content for the header and footer, or select an optional automatic field 
from the lists. 

To align text to the left, middle, or right in a header or footer, separate the text 
with commas. 

5 Click Advanced.

6 Customize settings for any of the following:

• Orientation Select Horizontal to place the header and footer on the top and 
bottom of the drawing. Select Vertical to rotate the header and footer 90 degrees 
on the left and right of the drawing.

• Print Upside Down Mark to rotate the print stamp upside down.

• X Offset Enter the distance to offset the header and footer from the edge of the 
printable area in the x-direction.

• Y Offset Enter the distance to offset the header and footer from the edge of the 
printable area in the y-direction.

• Offset Relative To Select whether to measure the offset from the edge of the 
paper or the printable area.

• Font Select the font for the header and footer text. 

• Height Select the height for the header and footer text. 

• Color Select the color for the header and footer text in the Color dialog box that 
opens.
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• Units Select Inches or Millimeters as the unit of measure for the print stamp X 
Offset, Y Offset, and Height. 

• Add Print Event into Log File Select to include print stamp information in the 
print log file. 

7 Click OK.

8 If you want to save the header, footer, and settings in a print stamp settings (.pss) 
file, click Save As, enter a name for the file, then click Save.

9 When you have finished, click OK.

Setting up printer configuration files
Printer configuration files (PC3 files) store the printer information you use for spe-
cific drawings or layouts. You can add, modify, and delete PC3 files. 

For more details about printer configuration files, see “Using printer configuration 
files” on page 643. 

To set up printer configuration files
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options then click the Printing tab or choose 
File > Printer Options.

• Type options, press Enter, then click the Printing tab.

2 Click Add or Configure Printers.

3 To create a new PC3 file, do the following:

• Click Add. 

• In the Add Printer Configuration File dialog box, select the desired printer for 
the new PC3 file.

• Click Continue.

• Select the options you want for the PC3 file. If you don't select any custom 
options, a PC3 file will not be created.

• Click OK.

4 To modify a PC3 file, do the following:

• Select the desired file in the list. 

• Click Modify.

• Select the options you want for the PC3 file.

• Click OK.

5 To delete a PC3 file, select the desired file in the list and click Delete.

6 Click OK. 
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7 When you have finished, click OK.

Changing the options on the Snapping tab
In the Options dialog box, on the Snapping tab, you can control how entity snaps 
work, including fly-over snapping. Fly-over snapping is a visual aid to help you 
see and use entity snaps more efficiently. 

To change the options on the Snapping tab
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Snapping tab.

3 Select the options you want.

4 When you have finished, click OK. 
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A Select to display an extra icon on the cursor to 
show which entity snap is active. (Available even 
if fly-over snapping is turned off.)

B Select to turn on fly-over snapping.
C Select to turn on fly-over snap tooltips, which 

indicate the type of snap that was used to select 
the marked location.

D Select to turn on the fly-over snap aperture box. 
Entities found within the aperture box are 
available for selection, making it easier to find 
and select entity snap points.

E Type or scroll to the tolerance size for the fly-
over snap aperture box. Higher numbers 
increase the distance from the cursor in which 
entities are found.

F Click to turn on entity snapping to hatches.
G Click to turn on entity snapping to entities that 

have a negative z value when using a dynamic 
UCS.

H Select whether there is no snapping to files 
attached to drawings as underlays, snapping is 
turned on for all underlays, or snapping is turned 
on but varies according to the file type.

I Click to turn on entity snapping to .pdf files that 
are attached to drawings. (Available only if 
snapping to underlays is turned on to VARY.)

J Click to turn on entity snapping to .dwf files that 
are attached to drawings. (Available only if 
snapping to underlays is turned on to VARY.)

K Click to turn on entity snapping to .dgn files that 
are attached to drawings. (Available only if 
snapping to underlays is turned on to VARY.)

L Click to turn on entity snapping to .ifc files that 
are attached to drawings. (Available only if 
snapping to underlays is turned on to VARY.)

M Click to turn on entity snapping to .rvt and .rfa 
files that are attached to drawings. (Available 
only if snapping to underlays is turned on to 
VARY.)

N Turns on entity snapping to dimension extension 
lines.

O Type or scroll to the thickness of the fly-over 
snap marker.

P Type or scroll to the size of the fly-over snap 
marker.

Q Click to choose the color of the fly-over snap 
marker.

R Select to turn on the display of fly-over snap 
markers in all views when you are using more 
than one viewport.

S Select to turn on fly-over snap markers, which 
mark snap points on entities.
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Changing the options on the Clipboard tab
You can control what formats are supported when copying content to the clipboard 
from IntelliCAD. 

Copying all supported formats to the clipboard impacts performance—it is best to 
select only the necessary formats.

To change the options on the Clipboard tab
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Clipboard tab.

3 Select the options you want.

4 When you have finished, click OK. 

A Select which DWG format versions to copy to the 
clipboard. 

B Select to copy the formats for installed versions 
automatically.

C Select to copy EMF, BMP, embedded object, 
and linked object formats to the clipboard.

A

B

C
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Changing the options on the Selection Cycling tab
Selection cycling allows you to cycle through overlapping entities under the cursor. 
Use the Selection Cycling tab to determine how selection cycle works.

To change the options on the Selection Cycling tab
1 Do one of the following to choose Options ( ): 

• On the ribbon, choose the Application button then choose Options, or choose 
Tools > Options (in Manage).

• On the menu, choose Tools > Options.

• Type options and then press Enter.

2 Click the Selection Cycling tab.

3 Select the options you want.

4 When you have finished, click OK.

A Choose to cycle through overlapping entities by 
pressing Ctrl with a mouse click, multiple mouse 
clicks, or pressing Shift + Space.

B Select to turn on visual aids when selecting 
entities that overlap.

C Select to display an icon at the cursor when you 
hover over overlapping entities.

D Select to display a Selection Cycling list when 
you select overlapping entities.

A

B
C
D
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Customizing tool palettes

Tool palettes contain commands and blocks that are organized for easy access while 
working in drawings. Each tool palette is customizable according to your needs: add 
new palettes, delete existing palettes, and change the order in which they display on 
the pane. You can also control the transparency applied to the display of any palette, 
which is helpful if you want to view parts of a drawing that would otherwise be hid-
den by opaque tool palettes.

For details about displaying and positioning tool palettes, see “Displaying and hiding 
the Tool Palettes pane” on page 26. 

Creating tool palettes and adding commands and blocks
Each tool palette that you create can contain any combination of tools that either run a 
command or insert a block.

To create a new tool palette
1 Right-click the name of an existing tool palette.

2 Choose New Palette.

3 Type the name of the new palette, then press Enter.

To add a command to a tool palette
1 On a tool palette, right-click an existing command tool and choose Copy.

2 Right-click the tool area of the desired palette and choose Paste.

3 Right-click the pasted command and choose Properties to change its settings:

• Name Enter the name of the command. This name displays in the tool palette. 

• Description Type a one-sentence description of the tool. 

• Command Name Enter the command carried out when the tool is selected, 
which can contain a macro (one or more commands and their options), such as:
^C^C^CZOOM;E;MSNAPSHOT
For details about special characters used in macros, see “Using macros in .cui 
files” on page 931 in this chapter. 

• General Select the color, layer, linetype, linetype scale, lineweight, text style, 
and dimension style to apply when using the command. Choose Use Current to 
use the current property.

4 Click OK.
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Use a shortcut.
Right-click a tool palette and choose Customize Commands or type quickcui. Then 
drag and drop commands from the list of commands to the tool palette. 

Or, drag an entity (for example, a line) from the drawing to the tool palette, which 
adds the corresponding entity-creation command (for example, the Line command) to 
the tool palette.

To add a block to a tool palette
1 Open a drawing that contains blocks, or if necessary create and insert a block. For 

details, see “Working with blocks” on page 546. 

2 Save the drawing. For details, see “Saving your drawing” on page 108. 

3 Select the block in the drawing and drag-and-drop it to the desired tool palette.

4 Right-click the new tool and choose Properties to customize it.

Use a shortcut.
From Windows File Explorer, drag a .dwg file to a tool palette to add it as a block to 
the tool palette.

Modifying tool palettes
The Tool Palettes pane can contain multiple palettes. You can rename, reorder, and 
delete tool palettes, and you can also change the transparency in which they display.

To change the name of a tool palette
1 Right click the name of the tool palette you want to rename.

2 Choose Rename Palette.

3 Type a new name, then press Enter.

To change the order in which tool palettes display
1 Right click the name of the tool palette.

2 Choose Move Up or Move Down.

To delete a tool palette
1 Right-click the name of the tool palette you want to delete.

2 Choose Delete Palette.

3 Click Yes to confirm the deletion or No to cancel.
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To change the transparency of tool palettes
1 Right-click the Tool Palette pane title bar.

2 Choose Transparency.

3 Select the desired options:

• General Move the slider to specify the transparency in which panes display in 
the program. The lower the number, the more transparent the pane is. 

• Rollover Move the slider to specify the transparency in which panes display 
when the mouse moves over them. The lower the number, the more transparent 
the pane is. The transparency for mouse rollover cannot be less than the general 
transparency.

• Preview Click to see a preview in the program of the mouse rollover trans-
parency. You might need to move the Transparency dialog box to see a pane.

• Apply settings to all palettes Mark this check box to apply selected transparency 
options to the display of all panes in the program, including any custom panes.

• Disable transparency for all palettes Mark this check box to turn off trans-
parency options for all panes in the program, including any custom panes.

4 Click OK.

Modifying the tools on a tool palette
Individual tools on a tool palette can be modified in several ways: reorder the display 
of tools, change the image that displays for any tool, and settings such as name, com-
mand or block that is assigned, and more. You can also delete tools from any palette.

To change the name of a tool
1 Right-click the tool you want to rename, then choose Rename.

2 Type a new name, then press Enter.

To reorder tools on a tool palette
1 Click and drag a tool to move it up or down.

To add a separator between tools
1 Right-click the tool below where you want to add a separator.

2 Choose Insert Separator.

To delete a tool or separator from a tool palette
1 Right-click the tool or separator you want to delete, then choose Delete.
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To specify an image to display for a tool
1 Right-click a tool, then choose Image.

2 Do one of the following to select the image you want to display on the tool palette 
for the tool:

• Select the desired image in the Tool Image dialog box. This adds the image by 
resource ID.

• Click Browse to load a .dll external resource file that contains bitmap resources, 
a .bmp file, or a .png file. The loaded images must be 32x32 pixels.

3 When you have finished, click OK.

To change the settings of a tool on a tool palette
1 Right-click the tool and choose Properties.

2 Customize the name and description of the tool:

• Name Enter the name of the tool. This name displays in the tool palette. 

• Description Type a one-sentence description of the tool. 

3 If the tool is a command, you can customize these options:

• Command Name Enter the command carried out when the tool is selected, 
which can contain a macro (one or more commands and their options), such as:
^C^C^CZOOM;E;MSNAPSHOT 

• General Select the color, layer, linetype, linetype scale, lineweight, text style, 
and dimension style to apply when using the command. Choose Use Current to 
use the current property.

If the tool is a block, you can customize these options:

• Name Enter the name of the block to insert when using this tool.

• Source File Enter the filename and path of the drawing that contains the source 
block.

• Scale Enter the x-, y-, and z-scale of the block. 

• Rotation Enter the rotation of the block. 

• Prompt Rotation Choose Yes to prompt for the block rotation value when 
inserting the block using this tool, or choose No. 

• Explode Choose Yes to allow blocks inserted with this tool to be exploded, or 
choose No.

• General Select the color, layer, linetype, linetype scale, lineweight, text style, 
and dimension style to apply when inserting the block. Choose Use Current to 
use the current property.

4 Click OK.
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Working with groups of tool palettes
The Tool Palettes pane displays one group of palettes at a time. If you don’t create 
palette groups, all palettes display on the pane. If you organize palettes into groups, 
you can easily switch the palettes that display on the Tool Palettes pane, simply make 
a group current to view its palettes on the Tool Palettes pane. 

Palettes can be organized into groups. which can be used to quickly switch between 
groups of palettes.

Working with tool palette files
Tool palettes can be exchanged between computers by importing and exporting them 
as .xtp files. Tool palette groups can be imported and exported as .xpg files.

To export a tool palette to a file
1 Do one of the following to choose Customize:

• Type customize and then press Enter.

• Right-click anywhere on a tool palette and choose Customize Palettes.

2 Right-click the palette you want to save.

3 Choose Export.

4 Enter a name for the tool palette file (.xtp file), then click Save.

To export all tool palettes to a file
1 Do one of the following to choose Customize:

• Type customize and then press Enter.

• Right-click anywhere on a tool palette and choose Customize Palettes.

2 Right-click a palette group.

3 Choose Export All.

4 Enter a name for the tool palette group file (.xpg file), then click Save.

To import a tool palette file
1 Do one of the following to choose Customize:

• Type customize and then press Enter.

• Right-click anywhere on a tool palette and choose Customize Palettes.

2 Right-click a palette or a palette group.

3 Choose Import.

4 Select the tool palette file (.xtp file) or tool palette group file (.xpg file) to load, 
then click Open.
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Customizing menus

You can customize a current menu and save your changes as a file. Menus files can 
also be loaded. Loadable menu file formats can be any of the following: IntelliCAD 
(*.icm files), Customizations (.cui files), and AutoCAD (*.mnu, *.mns files).     

Understanding menu compatibility
CUI format menu files are created by newer versions of AutoCAD. MNU format files 
are menu files created by all AutoCAD releases, and MNS format files are included 
in AutoCAD Releases 13, 14, and 2000. IntelliCAD reads all file formats, even when 
menu macros include AutoLISP code. This feature allows you to continue using your 
existing AutoCAD menus.

IntelliCAD supports all sections of CUI format files required for customization.

For MNU and MNS format file compatibility, see the following table. 

To see how IntelliCAD reads AutoCAD menu source files
1 Type menu and then press Enter. 

2 Under Files Of Type, select AutoCAD Menu File (mnu).

3 In the Open Menu dialog box, go to the AutoCAD Support folder and select the 
Acad.mnu file (or Acad.mns for Releases 13, 14, and 2000).

4 To load the AutoCAD menu file into IntelliCAD, click Open.

The IntelliCAD menu bar now looks identical to the AutoCAD menu bar.

5 To see how it works, choose a few commands from the menu bar, such as File > 
Open or Draw > Line.

6 To restore IntelliCAD to its default user interface, choose Tools > Options, click 
the Profiles tab, and then click Reset. 

IntelliCAD support of specific sections in AutoCAD MNU and MNS format files
Menu section Definition IntelliCAD support
***POP0 Cursor menu Supported

***POPn Pull-down menus Supported

***AUXn Auxiliary menus Not supported

***BUTTONn Button menus Supported

***ICON Icon menus Not supported

***SCREEN Screen menus Not supported

***TABLETn Tablet menus Supported
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Creating new menus and adding commands
You can create a new menu by inserting a menu item at the top level of the Menus 
list. Then you can add commands to the new menu item. You can also add submenus 
and modify existing menu names and commands by adding, deleting, and rearranging 
them. 

Bullet colors indicate whether a command is available at the current experience level. 
A green bullet in front of a menu item or command indicates that the menu item or 
command is available; a red bullet in front of a menu item or command indicates that 
the menu item or command is not available for you to use at the experience level you 
have set. To change the experience level for an item, use the  property in the Proper-
ties area. To change your experience level for the user interface, choose 
Tools > Options, then the General tab.
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A Click to restore the default customization or restore from a backup.
B Click to save the customization.
C Select a menu, submenu, or a menu’s command.
D Click to show or hide the Command List area.
E Click to create a new command.
F Type a command name for which to filter the command list.
G Displays the list of commands and which source menu group they 

belong to. Select a command to change its button images in Button 
Image or its properties in Properties. Drag and drop a command to the 
Current Customization. Right-click for more options.

H Click to hide the Properties and Button Image areas.

I Click to select an image file or .dll that contains the image to assign to 
the currently selected button. If you load an image file or .dll file, you 
can click Default to reset the images that display in Bitmap Images to 
the images that were installed with IntelliCAD. 

J Select a button image for the selected small or large button.
K Displays the full path and filename of the .dll, .bmp, or .png file that 

was loaded when you clicked Browse.
L Select which button you want to customize: small or large.
M Click to show or hide the Button Image area.
N Displays properties assigned to the selected menu item in Current 

Customization or the selected command in Command List. Enter a 
new value or click [...] to select more options for each property.

O Click to show or hide the Properties area.
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To create a new menu 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Menus in the list. The menus that display 
on the menu bar in the user interface are shown in the list with a plus sign (+) next 
to each name. 

4 Right-click the menu name located below the location of the new menu.

5 Choose Insert Menu Item.

6 Type a name for the new pull-down menu, and then press Enter.

7 Add a command to the menu (see next). To see the new menu, you must add a 
command to it.

8 Click OK.

To add a command and customize a menu 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Menus in the list.

4 Expand a menu name to show the menu sub-items and commands that display on 
each menu.

5 From the Command List, drag a command to where you want it located in the Cur-
rent Customization list.

6 To further customize a menu, right-click an item located below where you want to 
add a new item, and choose one of the following:

• Insert Menu Item Inserts a command above your selection. Enter the name as 
you want it to appear on the menu in the user interfaces, then press Enter. In 
Properties, enter the command name for the menu item in Command Name.

• Insert Menu Sub-Item Inserts a sub-menu above your selection. Enter the name 
of the sub-menu as you want it to appear in the user interface, then press Enter.
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• Insert Spacer Inserts a line above your selection that visually separates groups 
of commands on the menu.

• Insert Context Menu Inserts a menu that appears when you right-click the mouse 
in the user interface.

• Insert Context Menu Sub-Item Inserts a sub-menu to the selected context menu. 
Enter the name of the sub-menu as you want it to appear in the user interface, 
then press Enter.

7 Click OK.

Setting custom images for commands on a menu
You can customize the image that appears for each command on a menu. 

Because you can configure the menu to display either large or small images and to 
display either in color or monochrome, create four different images for each com-
mand. Create custom images using the following dimensions:

• Small images: 16 x 16 pixels. 

• Large images: 32 x 32 pixels.

For best results, images should be 32-bit ARGB format with an alpha transparent 
background.

Images that do not match these dimensions are stretched or reduced by the program to fit 
the specified size.  
The resulting images may not appear as originally intended.

To customize the images for commands on a menu 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Menus in the list. 

4 Expand a menu name to show the menu sub-items and commands that display on 
each menu, then select a command.

5 In the Button Image area, in Button Bitmaps, click the button image you want to 
change: Small or Large. 

If High-Contrast Grayscale Buttons is marked on the Display tab in the Options 
dialog box, the available button images are black and white. Black and white icons 
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are used for high contrast which is used by color blind users or others with visual 
impairments. See Section 508 compliance. 

6 Do one of the following:

• In Bitmap Images, select the desired image from the display of available images. 

• Click Browse to load a .dll external resource file that contains bitmap resources, 
a .bmp file, or a .png file. The loaded images must be 16x16 pixels for small 
icons and 32x32 pixels for large icons.

7 When you have finished, click OK.

Setting properties of menu items
You can specify properties for each item on a menu, including the name as it appears 
on the menu, its , and more.

To customize the properties of menu items 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Menus in the list. 

4 Expand a menu name to show the menu sub-items and commands that display on 
each menu, then select a menu item.

The properties available for customization vary according to the menu item you select.
The Properties area of the Customize User Interface dialog box displays only 
those properties that are appropriate for the menu item you select. For example,  
settings are available for commands, not menu names. 

5 In Name, enter the name that you want to display in the user interface.

You can specify an access key by including an ampersand (&) immediately pre-
ceding the letter you want to use as the access key. Be sure not to assign the same 
access key to more than one menu or command within a menu. For example, if 
you add a command named Quick Line to the Insert menu, including an amper-
sand immediately preceding the letter Q causes that letter to appear underlined in 
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the menu. You can then select that command by displaying the menu and pressing 
the Alt+Q keys. 

6 In Command Name, enter the name of the command to carry out when the menu 
item is selected in the user interface. 

Command Name may contain a macro (one or more commands and their options), 
such as:

^C^C^CZOOM;E;MSNAPSHOT

For details about special characters used in macros, see “Using macros in .cui 
files” on page 931 in this chapter. 

7 In Description, type a one-sentence description of the item. The string appears on 
the status line for menu items.

8 In Visibility, click [...] to make your selections for the menu item:

• Experience Level Select the user levels when the item will be visible: Beginner, 
Intermediate, or Advanced. Items appear only at the experience level you 
specify. For example, if you choose Advanced, the item does not appear if the 
user selects the Beginner or Intermediate level using the Tools > Options 
command; but if you select Intermediate without also selecting Advanced, the 
item will appear only when you set the experience level to Intermediate. 
Selecting all three options sets the item to appear at all user levels.

• MDI Window Select the number of drawing windows that must be open for this  
item to appear. If you want the item to appear only when at least one window is 
open, select At Least One Open. If you want the item to appear when no 
windows are open, select No Windows Open. Checking both options means that 
the item always appears.
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• ActiveX In-Place Activation Select the type of ActiveX editing with which the  
item is to appear. If you want the item to appear during embedded server editing, 
select Server, Embedded. If you want the item to appear during in-place server 
editing, select Server, In-place. If you want the ribbon item to appear during 
container editing, select Container.

• Document Type Select whether the item displays when different types of 
documents (or drawings) are open.

• Make Item Hidden Mark to hide the item in the user interface. The next time you 
open the Customize User Interface dialog box, this item is marked with a red 
circle. 

9 In Entities Context, click [...] to define whether the menu item displays in an 
entity’s context menu. Choose from the following:

• Customize the context menu on a per-entity basis by selecting or deselecting 
entities. Checking the box next to an entity causes the selected menu item to 
appear on the context menu for that particular entity. 

• If you do not want the menu item to appear in the context menu when only one 
entity is selected, select Exclude if Single Entity is Selected. 

• If you do not want the menu item to appear in the context menu when more than 
one entity is selected, select Exclude if Multiple Entities are Selected.

10 If  of the menu item can be controlled by a system variable, specify any of the fol-
lowing:

• Grayed-State Variable Enter the system variable name and value that controls 
whether this command displays in the user interface as grayed out. When the 
specified system variable is off, the button is grayed-out or appears off. For 
example, the Zoom In command’s grayed state variable is VIEWMODE = 1 
(perspective view = on).

• Checked-State Variable Enter the system variable name and value that controls 
whether this command displays in the user interface as pressed in. When the 
specified system variable is on, the command’s button appears pressed in. For 
example, the Set Center Snap command’s pressed state variable is OSMODE = 
4 (center snap = on).

• Hidden-State Variable Enter the system variable name that controls whether this 
command is hidden in the user interface. When the specified system variable is 
on, the item is hidden. For example, some commands that require an additional 
license have a hidden-state variable.

Enter the system variable name, an ampersand, then the value, with no spaces. For 
example: "OSMODE&4".

11 When you have finished, click OK.
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You can reset the user interface to be the same as when the program was first installed. 
Use the Options command, click the Profiles tab, then click Reset.

Renaming menu items

To rename a menu item 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization list, right-click the menu item you want to rename.

4 Choose Rename.

5 Type a new name for the menu item by typing over the highlighted name, and then 
press Enter.

6 Click OK.

Copying and pasting menu items

To copy and paste a menu item 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization list, right-click the menu item you want to copy.

4 Choose Copy.

5 Right-click the menu item located above where you want to locate the copy, then 
click Paste.

6 Click OK.
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Deleting menu items

To delete a menu item 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization list, right-click the menu item you want to delete.

4 Choose Delete.

5 In the Confirmation dialog box, click Yes to delete the menu item.

6 Click OK.

Some menu items have sub-items below them. 
Deleting a menu item that has sub-items below it in the Menu Tree also deletes all of 
those sub-items.
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Customizing the ribbon

For versions of IntelliCAD that include a ribbon, several areas contain commands:

• Application button — Located in the upper left corner and contains file-related 
commands, such as New, Open, Import, Export, and more.

• Quick Access toolbar — Located to the right of the Application button and con-
tains common commands. 

• Ribbon — Located below the Application button and runs horizontally at the top 
of the drawing window. The main ribbon consist of tabs that contain related com-
mands grouped together, for example, on the tabs named Home, Edit, Draw, etc. 
Each tab has panels that contain sub-categories of commands within a tab, for 
example Draw, Modify, and Layers on the Home tab.

• Contextual ribbon states — Located temporarily when working with certain enti-
ties: multiline text, raster images, and external references.

All of these areas can be customized with the exception of contextual ribbon states, 
which are built-in to IntelliCAD.

Ribbon settings are saved automatically in a .cui file. The CUI format is the newest 
user interface format and also supports all legacy user interface elements such as 
menus, toolbars, tablet, etc. The CUI format is the only menu format the supports the 
ribbon interface, so if you are creating a menu file that will support the ribbon, use the 
CUI format.     

Creating and customizing ribbon tabs and child panels
You can create a new ribbon tab by inserting a tab at the top level of the Ribbon list. 
Then you can add panels, or groups, to the new ribbon tab and add commands. You 
can also modify existing names and commands by adding, deleting, and rearranging 
them. 

Bullet colors indicate whether a command is available at the current experience level. 
A green bullet in front of a ribbon item or command indicates that the item is avail-
able; a red bullet indicates that the item is not available for you to use at the experi-
ence level you have set. To change the experience level for an item, use the property 
in the Properties area. To change your experience level for the user interface, use the 
Options command on the Tools menu.
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A Click to restore the default customization or restore from a backup.
B Click to save the customization.
C Select a ribbon tab, panel, or a ribbon’s command.
D Click to show or hide the Command List area.
E Click to create a new command.
F Type a command name for which to filter the command list.
G Displays the list of commands and which source menu group they 

belong to. Select a command to change its button images in Button 
Image or its properties in Properties. Drag and drop a command to the 
Current Customization. Right-click for more options.

H Click to hide the Properties and Button Image areas.

I Click to select an image file or .dll that contains the image to assign to 
the currently selected button. If you load an image file or .dll file, you 
can click Default to reset the images that display in Bitmap Images to 
the images that were installed with IntelliCAD. 

J Select a button image for the selected small or large button.
K Displays the full path and filename of the .dll, .bmp, or .png file that 

was loaded when you clicked Browse.
L Select which button you want to customize: small or large.
M Click to show or hide the Button Image area.
N Displays properties assigned to the selected ribbon item in Current 

Customization or the selected command in Command List. Enter a 
new value or click [...] to select more options for each property.

O Click to show or hide the Properties area.
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To create a new ribbon tab 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Ribbon in the list. The tabs that display on 
the ribbon in the user interface are shown in the list with a plus sign (+) next to 
each name. 

3 Right-click the ribbon tab name located below the location of the new ribbon tab.

4 Choose Insert Tab.

5 Type a name for the new tab, and then press Enter.

6 Add a panel and command to the ribbon tab (see next). To see the new ribbon tab, 
you must add a panel and command to it.

7 Click OK.

To customize a ribbon tab 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Ribbon in the list. 

4 Expand a ribbon tab then its panels to show the commands that display on each 
ribbon tab.

5 From the Command List, drag a command to where you want it located in the Cur-
rent Customization list.
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6 To further customize a ribbon tab, right-click an item located below where you 
want to add a new item, and choose one of the following:

• Insert Tab Inserts a new tab for the ribbon. Enter the name of the tab, then press 
Enter. The tab is inserted in the list above your selection.

• Insert Panel and Insert Child Panel Inserts an area on the ribbon tab used to 
group related commands. Enter the name of the panel which displays below the 
group of commands on the tab, then press Enter. The panel is inserted in the list 
above your selection, or for child panels, nested in the list under your selection 
in the list.

• Insert Row and Insert Child Row Inserts a row to a panel. Each panel can have 
one or more rows, which is a group of buttons aligned horizontally. The row is 
inserted in the list above your selection, or for child rows, nested in the list 
below your selection. Note that a set of panel rows can be broken into two parts 
(visible and collapsed) using the <PanelBreaker> element (right-click and 
choose Insert Panel Breaker).

• Insert Command Button and Insert Child Command Button Inserts a command 
button that runs a command when clicked in the user interface. The command 
button is inserted in the list above your selection, or for child command buttons, 
nested in the list below your selection.

• Insert Menu Button and Insert Child Menu Button Inserts a menu name that 
when clicked on the ribbon displays additional command buttons. The menu is 
inserted in the list above your selection, or for child menu buttons, nested in the 
list below your selection.

• Insert Row Panel and Insert Child Row Panel Inserts a group of rows that display 
on a panel. The row panel is inserted in the list above your selection, or for child 
row panels, nested in the list below your selection.

• Insert Control and Insert Child Control Inserts a standard control for selecting 
layers, colors, linetypes, lineweights, dimension styles, text styles, and print 
styles. The control is inserted in the list above your selection, or for child 
controls, nested in the list below your selection. 

• Insert Separator and Insert Child Separator Inserts a line that appears vertically 
on the ribbon to separate groups of commands. The separator is inserted in the 
list above your selection, or for child separators, nested in the list below your 
selection.

• Insert Split Button and Insert Child Split Button Inserts a button that when 
clicked on the ribbon displays additional command buttons. For example, you 
might want the Array and 3D Array commands grouped together on a split 
button. The command button that displays by default on the ribbon is the last one 
used. The split button is inserted in the list above your selection, or for child split 
buttons, nested in the list below your selection.

7 Click OK.
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You can reset the user interface to be the same as when the program was first installed. 
Use the Options command, click the Profiles tab, then click Reset. 

Creating and customizing quick access toolbars
You can create a new ribbon tab by inserting a tab at the top level of the Ribbon list. 
Then you can add panels, or groups, to the new ribbon tab and add commands. You 
can also modify existing names and commands by adding, deleting, and rearranging 
them. 

To create a new quick access toolbar 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Quick Access Toolbars in the list. The tabs 
that display on the ribbon in the user interface are shown in the list with a plus sign 
(+) next to each name. 

3 Right-click a quick access toolbar name and then choose Insert Quick Access 
Toolbar. The new quick access toolbar will be inserted above your selection in the 
list.

4 Type a name for the new quick access toolbar, and then press Enter.

5 Add a command to the quick access toolbar (see next). To see the new quick 
access toolbar, you must add a command to it.

6 Click OK.
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To customize a quick access toolbar 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Quick Access Toolbars in the list. 

4 Expand a quick access toolbar to show the commands that it displays.

5 Do one of the following to add a command to the quick access toolbar:

• From the Command List, drag a command to where you want it located in the 
Current Customization list.

• Right-click a command in the Quick Access Toolbar list and choose Insert 
Command Button. Type the name, and then press Enter. Then in Properties, 
enter the command name for the item in Command Name.

6 Click OK.

You can reset the user interface to be the same as when the program was first installed. 
Use the Options command, click the Profiles tab, then click Reset. 

Creating and customizing application buttons
You can create a new application button and modify an existing one. You can also 
modify existing names and commands by adding, deleting, and rearranging them. 

To create a new application button 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Application Buttons in the list.

3 Right-click an application button in the list, then choose Insert Application Button. 
The new application button will be inserted above your selection in the list.

4 Type the application button name, and then press Enter

5 Add a command to the application button (see next). To see the new application 
button, you must add a command to it.

6 Click OK.
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To customize an application button 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Application Buttons in the list. 

4 Expand an application button to show the commands that it displays.

5 From the Command List, drag a command to where you want it located in the Cur-
rent Customization list.

6 To further customize an application button, right-click an item located below 
where you want to add a new item, and choose one of the following:

• Insert Command Button Inserts an item that runs a command when clicked in 
the user interface. The command is inserted in the list above your selection.

• Insert Menu Button Inserts a menu item that opens a sub-menu when clicked in 
the user interface. The menu is inserted in the list above your selection.

• Insert Separator Inserts a line in the user interface that visually separates groups 
of commands.

• Insert Child Command Button Inserts an item that runs a command when 
clicked in the user interface. The command is nested under your selection in the 
list. This option displays for menu buttons (not command buttons).

• Insert Child Separator Inserts a line in the user interface that visually separates 
groups of commands. The separator is nested under your selection in the list. 
This option displays for menu buttons (not command buttons).

7 Click OK.

Setting custom images for commands on the ribbon
You can customize the image that appears for each command on the ribbon. 

Because you can configure the ribbon to display either large or small images and to 
display either in color or monochrome, create four different images for each com-
mand. Create custom images using the following dimensions: 

• Small images: 16 x 16 pixels. 

• Large images: 32 x 32 pixels. 

For best results, images should be 32-bit ARGB format with an alpha transparent 
background.



886 C H A P T E R  1 7
Images that do not match these dimensions are stretched or reduced by the program to fit 
the specified size. 
The resulting images may not appear as originally intended.

To customize the images for commands on the ribbon 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Ribbon in the list. 

4 Expand a ribbon tab name and panel names to show the commands that display on 
each ribbon tab, then select a command.

5 In the Button Image area, in Button Bitmaps, click the button image you want to 
change: Small or Large. 

If High-Contrast Grayscale Buttons is marked on the Display tab in the Options 
dialog box, the available button images are black and white. Black and white icons 
are used for high contrast which is used by color blind users or others with visual 
impairments. See Section 508 compliance. 

6 Do one of the following:

• In Bitmap Images, select the desired image from the display of available images. 

• Click Browse to load a .dll external resource file that contains bitmap resources, 
a .bmp file, or a .png file. The loaded images must be 16x16 pixels for small 
icons and 32x32 pixels for large icons.

7 When you have finished, click OK.
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Setting properties of ribbon items
You can specify properties for each item on the ribbon, including the name as it 
appears on the ribbon, its corresponding command, and more.

To customize the properties of ribbon items 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Ribbon in the list. 

4 Expand a ribbon tab name and panel name to show the commands that display on 
each ribbon tab, then select a ribbon item.

The properties available for customization vary according to the ribbon item you 
select.
The Properties area of the Customize User Interface dialog box displays only 
those properties that are appropriate for the ribbon item you select. For example, 
settings are available for commands, not ribbon panel names. 

5 In Name, enter the name that you want to display in the ribbon.

6 In Command Name, enter the name of the command to carry out when the ribbon 
item is selected in the user interface. 

Command Name may contain a macro (one or more commands and their options), 
such as:

^C^C^CZOOM;E;MSNAPSHOT

For details about special characters used in macros, see “Using macros in .cui 
files” on page 931 in this chapter. 

7 In Description, type a one-sentence description of the item. The string appears on 
the status line for ribbon items.

8 In Visibility, click [...] to make your selections for the ribbon item:

• Experience Level Select the user levels when the item will be visible: Beginner, 
Intermediate, or Advanced. Items appear only at the experience level you 
specify. For example, if you choose Advanced, the item does not appear if the 
user selects the Beginner or Intermediate level using the Tools > Options 
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command; but if you select Intermediate without also selecting Advanced, the 
item will appear only when you set the experience level to Intermediate. 
Selecting all three options sets the item to appear at all user levels.

• MDI Window Select the number of drawing windows that must be open for this 
item to appear. If you want the item to appear only when at least one window is 
open, select At Least One Open. If you want the item to appear when no 
windows are open, select No Windows Open. Checking both options means that 
the item always appears.

• ActiveX In-Place Activation Select the type of ActiveX editing with which the 
item is to appear. If you want the item to appear during embedded server editing, 
select Server, Embedded. If you want the item to appear during in-place server 
editing, select Server, In-place. If you want the item to appear during container 
editing, select Container.

• Document Type Select whether the item displays when different types of 
documents (or drawings) are open.

• Make Item Hidden Mark to hide the item in the user interface. The next time you 
open the Customize User Interface dialog box, this item is marked with a red 
circle. 
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9 In Entities Content, click [...] to define whether the ribbon item displays in an 
entity’s context menu. Choose from the following:

• Customize the context menu on a per-entity basis by selecting or deselecting 
entities. Checking the box next to an entity causes the selected ribbon item to 
appear on the context menu for that particular entity. 

• If you do not want the ribbon item to appear in the context menu when only one 
entity is selected, select Exclude if Single Entity is Selected. 

• If you do not want the ribbon item to appear in the context menu when more than 
one entity is selected, select Exclude if Multiple Entities are Selected.

10 If the ribbon item can be controlled by a system variable, specify any of the fol-
lowing:

• Grayed-State Variable Enter the system variable name and value that controls 
whether this command displays in the user interface as grayed out. When the 
specified system variable is off, the button is grayed-out or appears off. For 
example, the Zoom In command’s grayed state variable is VIEWMODE = 1 
(perspective view = on).

• Checked-State Variable Enter the system variable name and value that controls 
whether this command displays in the user interface as pressed in. When the 
specified system variable is on, the command’s button appears pressed in. For 
example, the Set Center Snap command’s pressed state variable is OSMODE = 
4 (center snap = on).

• Hidden-State Variable Enter the system variable name that controls whether this 
command is hidden in the user interface. When the specified system variable is 
on, the item is hidden. For example, some commands that require an additional 
license have a hidden-state variable.

Enter the system variable name, an ampersand, then the value, with no spaces. For 
example: “OSMODE&4”.

11 When you have finished, click OK.

You can reset the user interface to be the same as when the program was first installed. 
Use the Options command, click the Profiles tab, then click Reset.
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Renaming ribbon items

To rename a ribbon item 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization list, right-click the ribbon item you want to rename.

4 Choose Rename.

5 Type a new name for the ribbon item by typing over the highlighted name, and 
then press Enter.

6 Click OK.

Copying and pasting ribbon items

To copy and paste a ribbon item 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization list, right-click the ribbon item you want to copy.

4 Choose Copy.

5 Right-click the ribbon item located above where you want to locate the copy.

6 Choose Paste.

7 Click OK.
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Deleting ribbon items

To delete a ribbon item 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization list, right-click the ribbon item you want to delete.

4 Choose Delete.

5 In the Confirmation dialog box, click Yes to delete the ribbon item.

6 Click OK.

Some ribbon items have sub-items below them. 
Deleting a ribbon item that has sub-items below it also deletes all of those sub-items. 

Customizing toolbars

IntelliCAD provides toolbars so that you can access frequently used commands. 
When a toolbar is turned on, it is always available, or on top, and in the same location 
so it is easy to find and use. However, toolbars occupy drawing display space and 
reduce the area available for working in drawings.

You can customize these toolbars by adding or removing tools or by rearranging the 
organization of tools. You can also create custom toolbars.  

Creating and customizing toolbars
You can create a new toolbar using the Customize UI command, then you can add 
tools to the new toolbar. You can also add, delete, or modify tools on any existing 
toolbar.  
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A Click to restore the default customization or restore from a backup.
B Click to save the customization.
C Select a toolbar or a toolbar command.
D Click to show or hide the Command List area.
E Click to create a new command.
F Type a command name for which to filter the command list.
G Displays the list of commands and which source menu group they 

belong to. Select a command to change its button images in Button 
Image or its properties in Properties. Drag and drop a command to the 
Current Customization. Right-click for more options.

H Click to hide the Properties and Button Image areas.

I Click to select an image file or .dll that contains the image to assign to 
the currently selected button. If you load an image file or .dll file, you 
can click Default to reset the images that display in Bitmap Images to 
the images that were installed with IntelliCAD. 

J Select a button image for the selected small or large button.
K Displays the full path and filename of the .dll, .bmp, or .png file that 

was loaded when you clicked Browse.
L Select which button you want to customize: small or large.
M Click to show or hide the Button Image area.
N Displays properties assigned to the selected toolbar item in Current 

Customization or the selected command in Command List. Enter a 
new value or click [...] to select more options for each property.

O Click to show or hide the Properties area.
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To create a new toolbar
1 Do one of the following to choose Customize UI ( ): 

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Toolbars in the list. The toolbars are shown 
in the list with a plus sign (+) next to each name. 

4 Right-click a toolbar name located below the location of the new toolbar.

5 Choose Insert Toolbar.

6 Type a name for the new toolbar, and then press Enter.

7 Add a command to the toolbar (see next). To see the new toolbar in the user inter-
face, you must add a command to it.

8 Click OK.

To add a command to a toolbar 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Toolbars in the list. 

4 Expand a toolbar name to show the commands that display on each toolbar.

5 From the Command List, drag a command to where you want it located in the Cur-
rent Customization list.

6 To further customize a toolbar, right-click an item located below where you want 
to add a new item, and choose one of the following:

• Insert Button Inserts a toolbar button that runs a command when clicked in the 
user interface. The toolbar button is inserted in the list above your selection.

• Insert Sub-Item Inserts a toolbar button if you right-clicked a toolbar name in 
the list. If you right-clicked an item in the list located on a toolbar, inserts a 
toolbar button nested in the list under your selection, and the selection becomes 
the parent command on a flyout. 

Toolbar flyouts are a way to organize related tools and conserve space on 
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toolbars. A flyout is indicated by a small triangle in the lower right corner of a 
tool. When you click a flyout tool, a set of additional tools displays. The flyout 
tool you select then becomes the default tool on the toolbar.

• Insert Spacer Inserts a line that appears vertically on the toolbar to separate 
groups of commands. The separator is inserted in the list above your selection.

7 Click OK.

You can reset the user interface to be the same as when the program was first installed. 
Use the Options command, click the Profiles tab, then click Reset. 

Setting custom images for commands on a toolbar
You can customize the image that appears for each command on a toolbar.

Because you can configure toolbars to display either large or small tools and to dis-
play tools either in color or monochrome, create four different images for each tool. 
Create custom images using the following dimensions:

• Small images: 16 x 16 pixels. 

• Large images: 32 x 32 pixels.

For best results, images should be 32-bit ARGB format with an alpha transparent 
background.

Images that do not match these dimensions are stretched or reduced by the program to fit 
the specified size.  
The resulting tools may not appear as originally intended.

To customize the images for commands on a toolbar 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Toolbars in the list. 

4 Expand a toolbar name to show the commands that display on each toolbar, then 
select a command.

5 In the Button Image area, in Button Bitmaps, click the button image you want to 
change: Small or Large. 

If High-Contrast Grayscale Buttons is marked on the Display tab in the Options 
dialog box, the available button images are black and white. Black and white icons 
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are used for high contrast which is used by color blind users or others with visual 
impairments. See Section 508 compliance. 

6 Do one of the following:

• In Bitmap Images, select the desired image from the display of available images. 

• Click Browse to load a .dll external resource file that contains bitmap resources, 
a .bmp file, or a .png file. The loaded images must be 16x16 pixels for small 
icons and 32x32 pixels for large icons.

7 When you have finished, click OK.

Setting properties of toolbar items
You can specify properties for each item on a toolbar, including the name as it 
appears on a tooltip, a tool’s , and more.

To customize the properties of toolbar items 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Toolbars in the list. 

4 Expand a toolbar name to show the commands that display on each toolbar, then 
select a toolbar item.
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The properties available for customization vary according to the toolbar item you 
select.
The Properties area of the Customize User Interface dialog box displays only 
those properties that are appropriate for the toolbar item you select. For example,  
settings are available for commands, not toolbar names. 

5 In Name, enter the name that you want to display when you hover over a toolbar.

6 In Command Name, enter the name of the command to carry out when the toolbar 
item is selected in the user interface. 

Command Name may contain a macro (one or more commands and their options), 
such as:

^C^C^CZOOM;E;MSNAPSHOT

For details about special characters used in macros, see “Using macros in .cui 
files” on page 931 in this chapter. 

7 In Description, type a one-sentence description of the item. The string appears on 
the status line for toolbar items.

8 In , click [...] to make your selections for the toolbar item:

• Experience Level Select the user levels when the item will be visible: Beginner, 
Intermediate, and/or Advanced. Items appear only at the experience level you 
specify. For example, if you choose Advanced, the item does not appear if the 
user selects the Beginner or Intermediate level using the Tools > Options 
command; but if you select Intermediate without also selecting Advanced, the 
item will appear only when you set the experience level to Intermediate. 
Selecting all three options sets the item to appear at all user levels. 

• MDI Window Select the number of drawing windows that must be open for this  
item to appear. If you want the item to appear only when at least one window is 
open, select At Least One Open. If you want the item to appear when no 
windows are open, select No Windows Open. Checking both options means that 
the item always appears.
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• ActiveX In-Place Activation Select the type of ActiveX editing with which the  
item is to appear. If you want the item to appear during embedded server editing, 
select Server, Embedded. If you want the item to appear during in-place server 
editing, select Server, In-place. If you want the item to appear during container 
editing, select Container.

• Document Type Select whether the item displays when different types of 
documents (or drawings) are open.

• Make Item Hidden Mark to hide the item in the user interface. The next time you 
open the Customize User Interface dialog box, this item is marked with a red 
circle. 

9 In Entities Content, click [...] to define whether the toolbar item displays in an 
entity’s context menu. Choose from the following:

• Customize the context menu on a per-entity basis by selecting or deselecting 
entities. Checking the box next to an entity causes the selected toolbar item to 
appear on the context menu for that particular entity. 

• If you do not want the toolbar item to appear in the context menu when only one 
entity is selected, select Exclude if Single Entity is Selected. 

• If you do not want the toolbar item to appear in the context menu when more 
than one entity is selected, select Exclude if Multiple Entities are Selected.

10 If  of the toolbar item can be controlled by a system variable, specify any of the 
following:

• Grayed-State Variable Enter the system variable name and value that controls 
whether this command displays in the user interface as grayed out. When the 
specified system variable is off, the button is grayed-out or appears off. For 
example, the Zoom In command’s grayed state variable is VIEWMODE = 1 
(perspective view = on).

• Checked-State Variable Enter the system variable name and value that controls 
whether this command displays in the user interface as pressed in. When the 
specified system variable is on, the command’s button appears pressed in. For 
example, the Set Center Snap command’s pressed state variable is OSMODE = 
4 (center snap = on).

• Hidden-State Variable Enter the system variable name that controls whether this 
command is hidden in the user interface. When the specified system variable is 
on, the item is hidden. For example, some commands that require an additional 
license have a hidden-state variable.

Enter the system variable name, an ampersand, then the value, with no spaces. For 
example: “OSMODE&4”.

11 When you have finished, click OK.
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You can reset the user interface to be the same as when the program was first installed. 
Use the Options command, click the Profiles tab, then click Reset.

Renaming toolbar items

To rename a toolbar item 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization list, right-click the toolbar item you want to rename.

4 Choose Rename.

5 Type a new name for the toolbar item by typing over the highlighted name, and 
then press Enter.

6 Click OK.

You can also rename toolbars using the Toolbars command.
Choose View > Toolbars to open the Select Toolbars dialog box. Select the toolbar 
you want to rename, then click Rename and type the new name. 

Copying and pasting toolbar items

To copy and paste a toolbar item 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization list, right-click the toolbar item you want to copy.

4 Choose Copy.

5 Right-click the toolbar item located above where you want to locate the copy.

6 Choose Paste.

7 Click OK.
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Deleting toolbar items

To delete a toolbar item
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization list, right-click the toolbar item you want to delete.

4 Choose Delete.

5 In the Confirmation dialog box, click Yes to delete the toolbar item.

6 Click OK.

Customizing the keyboard, aliases, double-click actions, and image tile 
menus

Customizing the keyboard
IntelliCAD provides keyboard shortcuts so you can access frequently used com-
mands. You can customize these shortcuts and add new shortcuts using the Custom-
ize UI command.

Creating and customizing keyboard shortcuts
You can assign macros to special keys and certain combinations of keys to create a 
keyboard shortcut. A macro consists of one or more commands that are displayed on 
the status bar as follows:

• A single command, such as QSAVE.

• A command with options, such as ARC;\A;\\.

• More than one command, such as ^C^C^CZOOM;E;QSAVE;QPRINT.

Keyboard shortcuts are more powerful than aliases. An alias lets you abbreviate a sin-
gle command name; a keyboard shortcut contains one or more macros. To activate a 
macro, you press the shortcut key; you do not need to press Enter as you do with an 
alias. A shortcut consists of the following keys:

• The function and the cursor control keys, as well as alphanumeric keys pressed in 
combination with the Ctrl, Alt, and Shift keys. The Shift key must be used in con-
junction with the Ctrl, Alt, and/or function keys. 

• Alphanumeric keys are those labeled A through Z and 1 though 0. 
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• The cursor keys are the up, down, left, and right arrows and the Page Up, Page 
Down, Home, End, Insert, and Delete keys. 

• The function keys are those labeled F1 through F12.

    

A Click to restore the default customization or restore from a backup.
B Click to save the customization.
C Select a keyboard shortcut.
D Click to show or hide the Command List area.
E Click to create a new command.
F Type a command name for which to filter the command list.

G Displays the list of commands and which source menu group they 
belong to. Select a command to change its button images in Button 
Image or its properties in Properties. Right-click for more options.

H Click to hide the Properties and Button Image areas.
I Displays properties assigned to the selected keyboard shortcut in 

Current Customization or the selected command in Command List. 
Enter a new value or click [...] if available to select more options for 
each property.

J Click to show or hide the Properties area.
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To create a keyboard shortcut
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Keyboard Shortcuts in the list.  

4 Right-click a shortcut name located above where you want to add the new key-
board shortcut in the list.

5 Choose Insert Accelerator.

6 In the Keyboard Shortcut Keys dialog box, press the keyboard combination you 
want to add, for example, press Alt+A.

7 Click OK.

8 In Command Name, enter the name of the command to carry out when the key-
board combination is pressed in the user interface. 

Command Name may contain a macro (one or more commands and their options), 
such as:

^C^C^CZOOM;E;MSNAPSHOT

For details about special characters used in macros, see “Using macros in .cui 
files” on page 931 in this chapter. 

9 In Description, type a one-sentence description of the item.

10 To save your changes and close the dialog box, click OK. 

You can reset the user interface to be the same as when the program was first installed. 
Use the Options command, click the Profiles tab, then click Reset. 

Setting properties of keyboard shortcuts
You can specify properties for each keyboard shortcut, including the associated com-
mand, description, and key combination.

To customize the properties of keyboard shortcuts 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Keyboard Shortcuts in the list. 
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4 Select a keyboard shortcut.

5 In Command Name, enter the name of the command to carry out when the key-
board shortcut is pressed in the user interface. 

Command Name may contain a macro (one or more commands and their options), 
such as:

^C^C^CZOOM;E;MSNAPSHOT

For details about special characters used in macros, see “Using macros in .cui 
files” on page 931 in this chapter. 

6 In Description, type a one-sentence description of the item.

7 To specify a new key combination, do the following;

• In Key(s), press [...].

• Press a new key combination.

• Click OK.

8 When you have finished, click OK.

You can reset the user interface to be the same as when the program was first installed. 
Use the Options command, click the Profiles tab, then click Reset.

Copying and pasting keyboard shortcuts

To copy and paste a keyboard shortcut 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization list, right-click the keyboard shortcut you want to 
copy.

4 Choose Copy.

5 Right-click the keyboard shortcut located above where you want to locate the 
copy.

6 Choose Paste.

7 Click OK.
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Deleting keyboard shortcuts

To delete a keyboard shortcut item
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization list, right-click the keyboard shortcut you want to 
delete.

4 Choose Delete.

5 In the Confirmation dialog box, click Yes to delete the keyboard shortcut.

6 Click OK.

Customizing aliases
IntelliCAD provides aliases for many commands. You can use aliases to issue fre-
quently used commands by entering one or two letters rather than the entire command 
name. 

The program also uses aliases to maintain command-name compatibility with 
AutoCAD. You can use the same aliases and keyboard shortcuts used by AutoCAD. 
In addition, IntelliCAD has enhanced several AutoCAD commands. For example, 
IntelliCAD added two useful options to the rectangle command: you can draw a 
rectangle as a square, and you can rotate a rectangle at an angle.

You can customize aliases and add new aliases using the Customize UI command, as 
described in this section. Another method is to use the Customize Aliases command; 
for more information about it, click [?] after typing aliasedit.

Creating aliases
To create a new command alias, you first define the alias and then assign it one of the 
available IntelliCAD commands. 
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A Click to restore the default customization or restore from a backup.
B Click to save the customization.
C Select an alias.
D Click to show or hide the Command List area.
E Click to create a new command.
F Type a command name for which to filter the command list.

G Displays the list of commands and which source menu group they 
belong to. Select a command to change its button images in Button 
Image or its properties in Properties. Right-click for more options.

H Click to hide the Properties and Button Image areas.
I Displays properties assigned to the selected alias in Current 

Customization or the selected command in Command List. Enter a 
new value or click [...] if available to select more options for each 
property.

J Click to show or hide the Properties area.
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To create a new alias
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Aliases in the list.  

4 Right-click an alias name located below where you want to add the new alias in 
the list.

5 Choose Insert Alias.

6 Type the new alias, then press Enter.

7 In Command Name, enter the name of the command to carry out when the alias is 
entered in the user interface. 

Command Name may contain a macro (one or more commands and their options), 
such as:

^C^C^CZOOM;E;MSNAPSHOT

For details about special characters used in macros, see “Using macros in .cui 
files” on page 931 in this chapter. 

8 In Description, type a one-sentence description of the item.

9 To save your changes and close the dialog box, click OK. 

You can reset the user interface to be the same as when the program was first installed. 
Use the Options command, click the Profiles tab, then click Reset. 

Setting properties of aliases
You can specify properties for each alias, including the associated command and 
description.

To customize the properties of aliases 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Aliases in the list. 
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4 Select an alias.

5 In Name, enter a new name for the alias.

6 In Command Name, enter the name of the command to carry out when the alias 
name is entered in the user interface. 

Command Name may contain a macro (one or more commands and their options), 
such as:

^C^C^CZOOM;E;MSNAPSHOT

For details about special characters used in macros, see “Using macros in .cui 
files” on page 931 in this chapter. 

7 In Description, type a one-sentence description of the item.

8 When you have finished, click OK.

You can reset the user interface to be the same as when the program was first installed. 
Use the Options command, click the Profiles tab, then click Reset.

Copying and pasting an alias item

To copy and paste an alias item 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization list, right-click the alias you want to copy.

4 Choose Copy.

5 Right-click the alias located above where you want to locate the copy.

6 Choose Paste.

7 Click OK.
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Deleting an alias item

To delete an existing alias item 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization list, right-click the alias you want to delete.

4 Choose Delete.

5 In the Confirmation dialog box, click Yes to delete the alias.

6 Click OK.

Customizing double-click actions
Double-click actions allow you to start a command when double-clicking a specific 
entity.  For example, because of a double-click action, you can double-click a block 
to start the Block Editor command. 

If an entity does not have a double-click action assigned to it, double-clicking the 
entity opens the Quick Properties pane.

Creating double-click actions
To create a new double-click action, you first name it and then assign it and entity 
type and one of the available IntelliCAD commands.
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A Click to restore the default customization or restore from a backup.
B Click to save the customization.
C Select a double-click action.
D Click to show or hide the Command List area.
E Click to create a new command.
F Type a command name for which to filter the command list.

G Displays the list of commands and which source menu group they 
belong to. Select a command to change its button images in Button 
Image or its properties in Properties. Right-click for more options.

H Click to hide the Properties and Button Image areas.
I Displays properties assigned to the selected double-click action in 

Current Customization or the selected command in Command List. 
Enter a new value or click [...] if available to select more options for 
each property.

J Click to show or hide the Properties area.
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To create a new double-click action
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Double-Click Actions in the list.  

4 Right-click a double-click action located above where you want to add the new 
double-click action in the list.

5 Choose New.

6 Type the name of the new double-click action, then press Enter.

7 In Command Name, enter the name of the command to carry out when double-
clicking in the drawing. For example, MTEDIT starts the Multiline Text Editor.

Command Name may contain a macro (one or more commands and their options), 
such as:

^C^C^CZOOM;E;MSNAPSHOT

For details about special characters used in macros, see “Using macros in .cui 
files” on page 931 in this chapter. 

8 In Description, optionally type a one-sentence description of the double-click 
action.

9 In Entity Type, type the name of the entity type that when double-clicked, starts 
the command. For example, if you enter MTEXT, the action starts the command 
when you double-click multiline text.

10 To save your changes and close the dialog box, click OK. 

You can reset the user interface to be the same as when the program was first installed. 
Use the Options command, click the Profiles tab, then click Reset. 

Setting properties of double-click actions
You can specify properties for each double-click action, including the associated 
command and description.
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To customize the properties of double-click actions 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select either a workspace or a customization 
file (for example, ICAD), then expand Double-Click Actions in the list. 

4 Select a double-click action.

5 In Name, enter a new name for the double-click action.

6 In Command Name, enter the name of the command to carry out when double-
clicking in the drawing. For example, MTEDIT starts the Multiline Text Editor.

Command Name may contain a macro (one or more commands and their options), 
such as:

^C^C^CZOOM;E;MSNAPSHOT

For details about special characters used in macros, see “Using macros in .cui 
files” on page 931 in this chapter. 

7 In Description, optionally type a one-sentence description of the double-click 
action.

8 In DXF name, type the name of the entity type that when double-clicked, starts the 
command. For example, if you enter MTEXT, the action starts the command when 
you double-click multiline text.

9 When you have finished, click OK.

You can reset the user interface to be the same as when the program was first installed. 
Use the Options command, click the Profiles tab, then click Reset.
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Copying and pasting a double-click action

To copy and paste a double-click action
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization list, right-click the double-click action you want to 
copy.

4 Choose Copy.

5 Right-click the double-click action located above where you want to locate the 
copy.

6 Choose Paste.

7 Click OK.

Deleting a double-click action

To delete a double-click action 
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization list, right-click the double-click action you want to 
delete.

4 Choose Delete.

5 In the Confirmation dialog box, click Yes to delete the double-click action.

6 Click OK,
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Customizing image tile menus
Image tile menus are used to create custom dialog boxes that contain lists and images 
of frequently-used blocks or commands. A legacy user interface, image tile menus are 
used most commonly by third-party programs to display the contents of block librar-
ies and to make it easy to insert blocks in drawings. They can be added to any existing 
menu, toolbar, or ribbon tab (if supported by your program version).

Image tile menus display images from slide (.sld) files that are created with the Make 
Snapshot command. For details about creating .sld files, see “Creating snapshots” on 
page 780. 

To create a new user interface for inserting blocks or running commands, it is recom-
mended to use tool palettes instead. For more details, see “Starting commands using 
tool palettes” on page 35. For more details, see Starting commands using tool pal-
ettes.

To create an image tile menu
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select a customization file (for example, 
ICAD), then right-click Image Tile Menus in the list.

4 Choose New Image Tile Menu.

5 Type the name of the new image tile menu, then press Enter.

6 Do the following for each command you want to add to the image tile menu:

• Drag a command from the Command List to the new image tile menu.

• In the Properties area for the command, in Slide Label, enter the name of the 
slide (.sld) file, without the file extension, that you want to associate with the 
command. For details about creating .sld files, see “Creating snapshots” on page 
780. 

• Place the .sld file in the program’s installation folder.

7 Click OK.
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To add an image tile menu to the user interface
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select the image tile menu you want to add to 
the user interface.

4 In the Properties area, copy the alias that was assigned automatically to the image 
tile menu, for example IMG3001.

5 In the Current Customization area, select a customization file (for example, 
ICAD), then right-click where you want to add the image tile menu, and create a 
new item. For example, to add the image tile menu to a menu, right-click the com-
mand located below where you want to add the image tile menu, then choose 
Insert Menu Item.

6 Enter the name as you want it to appear in the user interface, then press Enter.

7 In the Properties area, enter the following for the Command Name, where 
IMG3001 is the alias of the image tile menu:

$I=IMG3001 $I=* 

8 Click OK.
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Customizing the Quick Properties pane

The Quick Properties pane opens and closes dynamically, allowing you to access 
entity-specific properties when you need them without crowding available screen 
space as with the Properties pane. It displays automatically when double-clicking an 
entity, if the entity does not have a double-click action assigned to it, and it optionally 
displays when using any selection method and a command is not active. For details 
about using the Quick Properties pane and changing its behavior, see “Modifying 
entity properties by using the Quick Properties pane” on page 408. 

The Quick Properties pane generally doesn’t display all properties of an entity, and 
the available properties is easily customizable for each entity type.

To customize the contents of the Quick Properties pane
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, select Quick Properties.

4 To specify the entity types for which the Quick Properties pane displays, do the 
following in the Quick Properties area:

• Click( ). The Edit Entity Type List dialog box displays. 

• Mark the entity types for which you want the Quick Properties pane to display. 
Your selections using the Drawing Settings command affect whether the Quick 
Properties pane displays for unmarked entity types. For more details, see 
“Modifying entity properties by using the Quick Properties pane” on page 408. 

• Click OK.

5 To specify the properties that display in the Quick Properties pane, do the follow-
ing for each entity type:

• Select an entity type.

• Mark the properties you want included in the Quick Properties pane.

You can change the properties available to choose from in the list.
Click General to temporarily display only the general properties for the selected 
entity type, then optionally click Reset Overrides to restore the display of hidden 
properties. Right-click the list of properties and choose Show Advanced Proper-
ties to show all available properties.

6 Click OK.
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A Click to restore the default customization or restore from a backup.
B Click to save the current customization.
C Select to customize the contents of the Quick Properties pane.
D Click to specify the entity types for which the Quick Properties pane 

displays.
E Click to hide the Quick Properties area.
F Click to display only the general properties for the selected entity type.

G Click to restore the display of hidden properties. Available only if 
General was previously clicked.

H Select the entity type for which you want to customize quick properties.
I Select each property you want included in the Quick Properties pane 

for the selected entity type.
J Click to show or hide the Quick Properties area.

B

I

D

J

A

E

C

F
G

H
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Working with user interface customization files

Many users customize areas of the IntelliCAD main window such as the menus and 
toolbars using the Customize UI (CUI) command. These settings are saved in a .cui/
.cuix file, which is an XML format file that contains settings for the following:

• Ribbon

• Workspaces

• Menus

• Toolbars

• Keyboard accelerators

• Aliases

• Double-click actions

You can save and load .cui/.cuix files, restore them, copy settings between .cui files, 
and even manually edit a .cui/.cuix file. 

IntelliCAD works with other legacy file types too that are used to customize the user 
interface. You can also load AutoCAD menus and toolbars  (*.mnu, *.mns), Intelli-
CAD menus and toolbars (*.icm), IntelliCAD aliases (*.ica), AutoCAD aliases 
(*.pgp), and IntelliCAD keyboard shortcuts (*.ick).

Tool palettes are part of the user interface and they can be customized too, but they 
are not saved in customization files. To customize tool palettes, see “Customizing 
tool palettes” on page 864 in this chapter. 

Saving customization files
IntelliCAD automatically saves any customizations you make to the following:

• Ribbon

• Workspaces

• Menus

• Toolbars

• Keyboard accelerators

• Aliases

• Double-click actions

Your changes are saved automatically in a .cui/.cuix file. If desired, you can save the 
settings to a new .cui/.cuix file.
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To save customization settings to a new customization file
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Transfer tab.

3 On the right, click Save As.

4 Enter a name for the .cui/.cuix file.

5 Click Save.

6 Click OK.

Loading customization files
You can replace the current customization file with a different one or you can extend 
the current customization file with additional items like custom menus. The program 
loads full customizations (*.cui, *.cuix), AutoCAD menus and toolbars (*.mnu, 
*.mns), IntelliCAD menus and toolbars (*.icm), IntelliCAD aliases (*.ica), AutoCAD 
aliases (*.pgp), and IntelliCAD keyboard shortcuts (*.ick). 

Loading a menu, alias, or keyboard shortcut file replaces only those items in the user 
interface.

You can also restore customization settings by loading the default customization file 
from when the program was installed or by loading a backup customization file. 

To load a customization file
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Transfer tab.

3 On the left, click Open.

4 From the Files Of Type list, choose the file type you want to load.

5 Select the desired file.

6 Click Open.

7 Click OK.
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To restore the default customization file
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, click Restore From ( ).

4 Choose Default Customization.

5 Click Yes to restore the default customization file or No to cancel.

6 Click OK.

You can also reset user interface changes from the command prompt.
To reverse all user interface changes made with the Customize User Interface com-
mand and reset the user interface customization to the default, type resetui to start the 
Reset User Interface command.

To restore a backup customization file
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Customize tab.

3 In the Current Customization area, click Restore From ( ).

4 Choose Daily, Weekly, Monthly, or Annual Backup.

5 Click Yes to restore the backup customization file or No to cancel.

6 Click OK.
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Creating a new .cui file and copying settings
Use the Customize UI command to quickly create a new .cui/.cuix file and copy set-
tings from one customization file to another. You choose which settings to copy, 
from a single command to all settings in a file.

To create a new .cui/.cuix file and copy settings
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Transfer tab.

3 On the right, click New.

4 On the left, click Open and select the customization file that contains the settings 
you want to copy.

5 Drag and drop settings between the two files.

6 Click OK when done.

Customizing a .cui file using an editor
A .cui file is an XML file format, which can be edited using any ASCII or Unicode 
text editor. However, it is best to edit .cui files using an XML editor such as Visual 
Studio or Notepad++. If you are developing with IntelliCAD, you already have 
Visual Studio.

Use caution when manually editing a .cui file and use the following tips about the for-
mat of the file:

• Content of .cui/.cuix files is case-sensitive. For example, the following is correct; 
no errors will be shown but ID attribute will be ignored:

<ToolTip id="123">Help</ToolTip>

The following is also correct; ID will be equal to 123:

<ToolTip ID="123">Help</ToolTip>

• Content of .cui files contains special symbols, similar to an .xml file: & (amper-
sand), ' (quote), and more. Replace these special symbols with corresponding 
escape sequence or use XML CDATA structure instead. For example, the follow-
ing is not correct:

<ToolTip id="123">&Help</ToolTip>

Correct:

<ToolTip ID="123">&amp;Help</ToolTip>

Not correct:

<Command>'_HELP</Command>
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Correct:

<Command><![CDATA['_HELP]]></Command>

• Properties of several entity types can be described in both node-style and attribute-
style. For example, the following two toolbar buttons are the same:

<ToolbarButton UID="unique-id" IsSeparator="true

="CUI_LEV_ALL,CUI_MDI_OPN,CUI_OLE_SEM"

Entity="RCM_ENT_ACS,RCM_ENT_MUL"/>

<ToolbarButton UID="unique-id">

 <IsSeparator>true</IsSeparator>

 <>CUI_LEV_ALL,CUI_MDI_OPN,CUI_OLE_SEM</>

 <Entity>RCM_ENT_ACS,RCM_ENT_MUL</Entity>

</ToolbarButton>

To customize a .cui/.cuix file using an editor
1 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and then press Enter.

2 Click the Menus tab, then click Export.

3 Specify the directory and file name you want to use to save the menu file.

4 In Save as Type, select CUI Customizations file (.cui).

5 Click Save, then Close.

6 In any ASCII or Unicode text editor, open the .cui file and make changes accord-
ing to the following format.

There are many editors, but if you are developing with IntelliCAD, you already 
have Visual Studio, which is a good XML editor for .cui files.
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Understanding versioning of a .cui file
Each .cui file has a node that controls versioning:

<FileVersion MajorVersion="1" MinorVersion="2" UserVersion="0" 

IncrementalVersion="91"/>

• IncrementalVersion Must be incremented with any change in the Icad.cui file.

• UserVersion Incremented automatically when a user customizes IntelliCAD. In 
the default Icad.cui file, this must be always equal to 0 and never edited manually.

• MinorVersion Must be incremented with a change or creation of a versioned entity 
(PopMenu, Toolbar, MenuMacro->Macro, ...).

• MajorVersion Must be incremented with the following:

• Change of Icad.cui file schema (for example, added/deleted sections or added 
new type of entities).

• Deletion of a versioned entity.

• Change of UID attribute of an existing versioned entity or change of Name 
attribute in case of a Workspace entity.

If MajorVersion is incremented, the user's .cui file will be replaced with an 
updated .cui file. 

The .cui file also contains versioned entities: Workspace, MenuMacro->Macro, Pop-
Menu, Toolbar, AppButton, QuickAccessToolbar, RibbonPanelSource, and 
RibbonTabSource. Each versioned entity also has a node:

<ModifiedRev MinorVersion="2"/>

After a versioned entity is modified or created, FileVersion->MinorVersion must be 
incremented, and then the result must be assigned to ModifiedRev->MinorVersion of 
the modified entity.
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Understanding the format of a .cui file
A .cui file can contain settings for the following areas of the IntelliCAD main win-
dow:

• Ribbon

• Workspaces

• Menus

• Toolbars

• Keyboard accelerators

• Command aliases 

CUI file format

Item
Values 
(Default Value) Required? Description

FileVersion

MajorVersion 4 byte integer Yes Major version of the .cui file. For details, see “Understanding 
versioning of a .cui file” on page 921 in this chapter. 

MinorVersion 4 byte integer Yes Minor version of the .cui file. For details, see “Understanding 
versioning of a .cui file” on page 921 in this chapter. 

IncrementalVersion 4 byte integer Yes Incremental version of the .cui file. For details, see “Understanding 
versioning of a .cui file” on page 921 in this chapter. 

UserVersion 4 byte integer Yes User version of the .cui file. For details, see “Understanding 
versioning of a .cui file” on page 921 in this chapter. 

AppButton The application button.

UID Text Yes ID of an AppButton. Unique among all UIDs.

LargeImage Text("0") No Image resource ID of AppButton’s icon or path to local image file.

LargeImageHighContrast Text("0") No Image resource ID of AppButton’s high contrast icon or path to 
local file.

Name Text("") No Name or tooltip of an AppButton.

AppButtonItem Regular command button or separator line.

UID Text Yes ID of an AppButtonItem. Unique among all UIDs.

MenuMacroID Text Yes/No ID of referenced MenuMacro. Not required in case of separator 
button. Required in all other cases.

IsSeparator true/false(false) No Determines whether an item is a separator line or regular 
command button.

AppButtonPopItem Sub-menu that contains a set of AppButtonItem items.

UID Text Yes ID of an AppButtonPopItem. Unique among all UIDs.

LargeImage Text("0") No Image resource ID of AppButtonPopItem's icon or path to local 
image file.

LargeImageHighContrast Text("0") No Image resource ID of AppButtonPopItem 's high contrast icon or 
path to local image file.
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Name Text("") No Name or tooltip of an AppButtonPopItem.

QuickAccessToolbar The Quick Access Toolbar.

UID Text Yes ID of a Quick Access toolbar. Unique among all UIDs.

QuickAccessToolbarStandardItem Regular command button.

UID Text Yes ID of a QuickAccessToolbarStandardItem. Unique among all 
UIDs.

MenuMacroID Text Yes ID of referenced MenuMacro.

Workspace Consists of the following sections: WSPopRoot, WSToolbarRoot, 
and WSRibbonRoot.

DefaultWorkspace true/false (false) No Whether a workspace is selected by default.

Name Text Yes Name of workspace.

WSPop In-workspace declaration of a pop-menu.

Display 0/1 (0) No Whether to display (1) or not to display (0) pop-menu in the 
MenuBar.

pUID Text Yes UID of a referenced pop-menu. Unique among all UIDs.

WSToolbar In-workspace declaration of a toolbar.

Display 0/1 (0) No Whether to display (1) or not to display (0) a toolbar.

pUID Text Yes UID of a referenced toolbar. Unique among all UIDs.

ToolbarOrient top/left/bottom/right 
(float)

No Toolbar orientation.

rows 4 byte integer (1) No Number of button rows for a toolbar.

xval 4 byte integer (0) No X-coordinate of a toolbar (relative in case of docked toolbar).

yval 4 byte integer (0) No Y-coordinate of a toolbar (relative in case of docked toolbar).

WSRibbonTabSourceReference In-workspace declaration of a ribbon tab. Consists of a set of 
WSRibbonPanelSourceReference items.

Show true/false (false) No Whether to show or not to show a ribbon tab.

TabId Text Yes UID of a referenced ribbon tab.

WSRibbonPanelSourceReference In-workspace declaration of a ribbon panel.

Show true/false (false) No Whether to show or not to show a ribbon panel.

PanelId Text Yes UID of a referenced ribbon panel. 

RibbonPanelSource Ribbon panel definition. Consists of a set of RibbonRow items.

UID Text Yes ID of a RibbonPanelSource. Unique among all UIDs.

Name Text Yes Name of a RibbonPanelSource.

RibbonSplitButton Ribbon button with sub-items. Consists of RibbonCommandButton 
items.

UID Text Yes ID of a RibbonSplitButton. Unique among all UIDs.

CUI file format

Item
Values 
(Default Value) Required? Description
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ButtonStyle LargeWithText/ 
SmallWithoutText/ 
SmallWithText 
(SmallWithoutText)

No Style of a button.

RibbonCommandButton Regular command button.

UID Text Yes ID of a RibbonCommandButton. Unique among all UIDs.

MenuMacroID Text Yes ID of referenced MenuMacro.

ButtonStyle LargeWithText/ 
SmallWithoutText/ 
SmallWithText 
(SmallWithoutText)

No Style of a button.

RibbonSeparator Ribbon Separator element.

UID Text Yes ID of a RibbonSeparator. Unique among all UIDs.

SeparatorStyle Line/Spacer 
(Spacer)

No Separator style can be either a line or a spacer.

RibbonControl Ribbon control. Can be of one of these predefined types: color, 
linetype, lineweight, layer, print style, text style, or dimension style.

UID rbnctrl-layer/
rbnctrl-color/
rbnctrl-linetype/
rbnctrl-lineweight/
rbnctrl-printstyle/
rbnctrl-textstyle/
rbnctrl-dimstyle

Yes Unique among all UIDs. Any other UID is not allowed.

RibbonTabSource Ribbon tab definition. Consists of a set of 
RibbonPanelSourceReference items.

UID Text Yes ID of a RibbonTabSource. Unique among all UIDs.

Name Text Yes Name of a RibbonTabSource.

MenuAccelerator

UID Text Yes ID of a MenuAccelerator. Unique among all UIDs.

MenuAccelerator.Accelerator

KeyCombo.AccelChar Text ("") Yes Virtual key code. Use letters, digits ("A", "B", "C", ... , "1", "2", "3", 
... , "0"), functional key codes ("F1", "F2", "F3", ..., "F16"), Num-
pad key codes ("NUM1", "NUM2", "NUM3", ..., "NUM0", "NUM*", 
"NUM+", "NUM-", "NUMDEL", "NUM/"), some other key codes 
("BACKSPACE", "PAUSE", "PAGEUP", "PAGEDOWN", 
"LEFTARROW", "UPARROW", "RIGHTARROW", 
"DOWNARROW", "INS", "DEL", "END", "HOME")

KeyCombo.accKeys Text ("") Yes if 
previous 
is letter or 
digit

Accelerator modifier. Following combinations are allowed: 
"CTRL", "ALT", "SHIFT", "CTRL+ALT", "ALT+CTRL", 
"SHIFT+CTRL", "CTRL+SHIFT", "ALT+SHIFT", "SHIFT+ALT", 
"CTRL+ALT+SHIFT", "CTRL+SHIFT+ALT", "ALT+SHIFT+CTRL", 
"ALT+CTRL+SHIFT", "SHIFT+CTRL+ALT", "SHIFT+ALT+CTRL"

MenuItem.MacroRef.MenuMacroID Text ("") No ID of a macro to be bound to this accelerator

CUI file format

Item
Values 
(Default Value) Required? Description
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MenuAlias

UID Text Yes ID of a MenuAlias. Unique among all UIDs.

Name Text Yes Name of an alias.

Command Text Yes Command that is to be called for the alias.

MenuGroup

Name Text ("ICAD") No Name of a menu group.

MenuMacro

UID Text Yes ID of a MenuMacro. Unique among all UIDs.

Macro.Name.ID 4 byte integer (0) No Text resource id of macro name. Used to extract localized text.

Macro.Name Text ("") No Default macro name.

Macro.ToolTip.ID 4 byte integer No Text resource id of macro tooltip. Used to extract localized text.

Macro.ToolTip Text Yes Default macro tooltip.

Macro.HelpString.ID 4 byte integer (0) No Text resource id of macro help string. Used to extract localized 
text.

Macro.HelpString Text Yes Default macro help string.

Macro.Command Text Yes Command of a macro.

Macro.SmallImage 4 byte integer (0) No Image resource id of small icon or path to local image file.

Macro.LargeImage 4 byte integer (0) No Image resource id of large icon or path to local image file.

Macro.SmallImageHighContrast 4 byte integer (0) No Image resource id of small high contrast icon or path to local 
image file.

Macro.LargeImageHighContrast 4 byte integer (0) No Image resource id of large high contrast icon or path to local 
image file.

Macro.AcadToolbarConversion Text ("") No Used to extract MenuMacro icon.

CUI file format

Item
Values 
(Default Value) Required? Description
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Macro. Text 
(CUI_DEFAULT)

No Determines the  of MenuMacro, constructed as a comma-
separated concatenation of the following values, calculated with a 
logical OR applied to all values: 
 Value Description
CUI_DOC_DWG .dwg document
CUI_DOC_DGN .dgn document
CUI_DOC_ALL All types of documents
CUI_DOC_STP Start Page document
CUI_LEV_BEG User level: Beginner
CUI_LEV_INT User level: Intermediate
CUI_LEV_EXP User level: Expert
CUI_LEV_ALL User level: Any
CUI_MDI_OPN MDI Window: At least one open
CUI_MDI_CLS MDI Window: No MDI windows
CUI_MDI_ALL MDI Window: Either MDI state
CUI_OLE_SEM OLE: Server, embedded
CUI_OLE_SIP OLE: Server, in-place
CUI_OLE_CLI OLE: Client
CUI_OLE_ALL OLE: Any OLE state
CUI_VIS_ALL CUI_LEV_ALL,CUI_MDI_ALL,CUI_OLE_ALL
CUI_SPL_RCM Context (right-click) menu only
CUI_SPL_HIDE Hide this menu or button
CUI_SPL_OSNAP Temporary osnap mode (shift right click when

command is active)
CUI_SPL_CTRL Button is a control]
CUI_SPL_NOENT Ignore all entity  flags]
CUI_DEFAULT Default :

CUI_LEV_ALL,CUI_MDI_OPN,CUI_MDI_CLS,
CUI_OLE_CLI

CUI file format

Item
Values 
(Default Value) Required? Description
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Macro.Entity

Note that this item controls  of right-
click menus, which are designed to 
display only when certain entities are 
in the right-click selection set. This 
item is only used when Macro. 
includes CUI.SPL.RCM.

Text 
(RCM_ENT_ALL)

No Determines the entity of Menu.Macro, constructed as a comma-
separated concatenation of the following values, calculated with a 
logical OR applied to all values: 
Entity 
Value Description
RCM_ENT_PNT Point
RCM_ENT_LIN Line
RCM_ENT_RAY Ray
RCM_ENT_XLN XLine
RCM_ENT_ARC Arc
RCM_ENT_CIR Circle
RCM_ENT_ELL Ellipse
RCM_ENT_SHP Shape
RCM_ENT_TRC Trace
RCM_ENT_SLD Solid
RCM_ENT_3DF 3D Face
RCM_ENT_3DS 3D Solid
RCM_ENT_2DP 2D Polyline
RCM_ENT_3DP 3D Polyline
RCM_ENT_PFM Polyface Mesh
RCM_ENT_3DM 3D Mesh
RCM_ENT_PLN All types of polylines:  

RCM_ENT_2DP,RCM_ENT_3DP,
RCM_ENT_PFM,RCM_ENT_3DM

RCM_ENT_TXT Text
RCM_ENT_INS Insert
RCM_ENT_ATD AttDef
RCM_ENT_DIM Dimension
RCM_ENT_LDR Leader
RCM_ENT_TOL Tolerance
RCM_ENT_SPL Spline
RCM_ENT_MTX Mtext
RCM_ENT_MLN Mline
RCM_ENT_GRP Group
RCM_ENT_IMG Image
RCM_ENT_VPT Viewport
RCM_ENT_HAT Hatch
RCM_ENT_RGN Region
RCM_ENT_BDY Body
RCM_ENT_XRF Xreferences
RCM_ENT_GMI Geographic Map Image
RCM_ENT_ACS All ACIS entities: RCM_ENT_3DS, 

RCM_ENT_RGN,RCM_ENT_BDY
RCM_ENT_ALL Any entity
RCM_ENT_SGL Hide this item if a single entity is selected
RCM_ENT_MUL Hide this item if multiple entities are selected

CUI file format

Item
Values 
(Default Value) Required? Description
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Macro.Entity (continued) Text 
(RCM_ENT_ALL)

No Continued: 
Entity 
Value Description
RCM_ENT_MLR Multileader
RCM_ENT_REF Refedit
RCM_ENT_BIM IFC or RVT Underlay
RCM_ENT_BED BEdit
RCM_ENT_BEL Building Elevation Line
RCM_ENT_BSL Building Section Line
RCM_ENT_2DS 2D Section or Elevation
RCM_ENT_TBL Table
RCM_ENT_ARR All array entities: RCM_ENT_ARR_POL, 

RCM_ENT_ARR_PAT,
RCM_ENT_ARR_REC)

RCM_ENT_ARR_POL  ARRAY   Polar Array
RCM_ENT_ARR_PAT  ARRAY   Path Array
RCM_ENT_ARR_REC  ARRAY  Rectangular Array

Macro.CheckedExpression Text ("") No Controls whether the button or menu item is in checked state 
based on value of the system variable.

Macro.GreyedOutExpression Text ("") No Controls whether the button or menu item is grayed-out (disabled) 
based on the value of the system variable.

Macro.HideExpression Text ("") No Controls whether the button or menu item is visible based on 
value of the system variable.

DoubleClickAction

UID Text Yes ID of a DoubleClickAction. Unique among all UIDs.

DxfName Text Yes DXF name of an entity type to be bound to this double-click action.

MenuItem.MacroRef.MenuMacroID Text ("") No ID of a macro to be bound to this double-click action.

PopMenu

UID Text Yes ID of a PopMenu. Unique among all UIDs.

Alias Text Yes Language independent tear-off-name, usually "POPNN" where 
NN is a number.

Name.ID 4 byte integer (0) No Text resource id of popup menu name. Used to extract localized 
menu name.

Name Text Yes Default popup menu name.

PopMenuItem

IsSeparator true/false (false) No Defines whether the menu item is a separator.

NameRef.ID 4 byte integer (0) No Text resource id of menu item name. Used to extract localized 
menu item name.

NameRef Text ("") No Default menu item name.

MenuItem.MacroRef.MenuMacroID Text ("") No Id of a macro to be bound to this menu item.

PopMenuRef

CUI file format

Item
Values 
(Default Value) Required? Description
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pUID Text Yes ID of a popup menu to be bound to this menu item as a sub-menu. 
Unique among all UIDs.

ToolTip.ID 4 byte integer (0) No Text resource id of menu item tooltip. Used to extract localized 
text.

ToolTip Text Yes Default menu item tooltip.

HelpString.ID 4 byte integer (0) No Text resource id of menu item help string. Used to extract 
localized text.

HelpString Text Yes Default menu item help string.

Text 
(CUI_DEFAULT)

No Determines the of PopMenuRef, constructed as a comma-
separated concatenation of values, calculated with a logical OR 
applied to all values. For details about available values, see 
“Value Description” on page 926 in this chapter. 

Entity Text 
(RCM_ENT_ALL)

No Determines the entity of PopMenuRef, constructed as a comma-
separated concatenation of the values and calculated with a 
logical OR applied to all values. For details about available values, 
see “Entity Value Description” on page 927 in this chapter. 

CheckedExpression Text ("") No Controls whether the button or menu item is in checked state 
based on value of the system variable.

GreyedOutExpression Text ("") No Controls whether the button or menu item is grayed-out (disabled) 
based on the value of the system variable.

HideExpression Text ("") No Controls whether the button or menu item is visible based on 
value of the system variable.

Toolbar

UID Text Yes ID of a Toolbar. Unique among all UIDs.

ToolbarOrient float/top/left/right/
bottom (float)

No Specifies toolbar orientation.

ToolbarVisible hide/show (hide) No Specifies whether to show or hide toolbar.

rows 4 byte integer (1) No Number of button rows for a toolbar.

xval 4 byte integer (0) No X coordinate of a floating toolbar and zero-based position index of 
a docked toolbar.

yval 4 byte integer (0) No Y coordinate of a floating toolbar and zero-based position index of 
a docking row for a docked toolbar.

Name Text Yes Name of a toolbar.

UseOwnIcon true/false (false) No Specifies whether to use single icon when toolbar is used as 
flyout.

ToolbarButton

UID Text Yes ID of a ToolbarButton. Unique among all UIDs.

IsSeparator true/false (false) No Defines whether the button is a separator.

NameRef.ID 4 byte integer (0) No Text resource id of button name. Used to extract localized button 
tooltip.

CUI file format

Item
Values 
(Default Value) Required? Description
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NameRef Text ("") No Default button name and tooltip.

MenuItem.MacroRef.MenuMacroID Text ("") No ID of a macro to be bound to this button.

ToolbarFlyout

pTargetId 8 byte integer Yes ID of a popup menu to be bound to this item as a fly-out.

ToolTip.ID 4 byte integer (0) No Text resource id of tooltip. Used to extract localized text.

ToolTip Yes Default fly-out tooltip.

HelpString.ID 4 byte integer (0) No Text resource id of help string. Used to extract localized text.

HelpString Text Yes Default fly-out help string.

SmallImage 4 byte integer (0) No Image resource id of small icon, or path to local image file.

LargeImage 4 byte integer (0) No Image resource id of large icon.

SmallImageHighContrast 4 byte integer (0) No Image resource id of small high contrast icon.

LargeImageHighContrast 4 byte integer (0) No Image resource id of large high contrast icon.

AcadToolbarConversion Text ("") No Used to extract fly-out icon.

Text 
(CUI_DEFAULT)

No Determines the of the fly-out, constructed as a comma-separated 
concatenation of values, calculated with a logical OR applied to all 
values. For details about available values, see “Value Description” 
on page 926 in this chapter. 

Entity Text 
(RCM_ENT_ALL)

No Determines the entity of the fly-out, constructed as a comma-
separated concatenation of the values and calculated with a 
logical OR applied to all values. For details about available values, 
see “Entity Value Description” on page 927 in this chapter. 

CheckedExpression Text ("") No Controls whether the button or menu item is in the checked state 
based on the value of the system variable.

GreyedOutExpression Text ("") No Controls whether the button or menu item is grayed-out (disabled) 
based on the value of the system variable.

HideExpression Text ("") No Controls whether the button or menu item is visible based on 
value of the system variable.

ToolbarControl

UID  tlbctrl-color/
 tlbctrl-linetype/
 tlbctrl-lineweight/
 tlbctrl-printstyle/
 tlbctrl-textstyle/
 tlbctrl-
dimensionstyle

Yes ID of an AppButton. Unique among all UIDs. Any other UID is not 
allowed.

HelpString.ID 4 byte integer (0) No Text resource id of help string. Used to extract localized text.

HelpString Text Yes Default control help string.

Text 
(CUI_DEFAULT)

No Determines the of the toolbar, constructed as a comma-separated 
concatenation of the values, calculated with a logical OR applied 
to all values. For details about available values, see “Value 
Description” on page 926 in this chapter. 

CUI file format

Item
Values 
(Default Value) Required? Description
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Using macros in .cui files
Macros in .cui files can run commands with custom options for tool palettes, menus, 
the ribbon (for versions that have a ribbon), toolbars, keyboard shortcuts, and aliases. 
For example:

^C^C^CZOOM;E;QSAVE;QPRINT

This example zooms to extents, saves the file, and then prints the file.

You can add macros to .cui files manually using a text editor and also in the Proper-
ties area of the Customize dialog box. For example, to add a macro to a menu item, 
see “Setting properties of menu items” on page 874 in this chapter. 

The following table describes special characters that can be included in macros that 
are used in .cui files. 

Character Description
;
^M

Equivalent to pressing the Enter key. For example, adding ; or ^M 
advances to the next prompt:
_DRAWORDER;_BACK
_DRAWORDER^M_BACK

^C Equivalent to pressing the Esc key. Adding three ^C (Ctrl+C) characters 
before a command cancels any active commands or dialog boxes. For 
example:
^C^C^C_LINE
Note that ^C is ignored if used outside of a command; it doesn't clear the 
selection.

^ Equivalent to pressing the Ctrl key. Adding a carrot before a character 
runs the equivalent shortcut, for example, to toggle entity snapping on or 
off:
^B

^^ Suppresses the display of all prompts and input for the subsequent 
command.

^Q Suppresses the display of all prompts and input for all subsequent 
commands.

blank space Equivalent to entering a space, for example, a blank space between 
commands is the same as pressing the Spacebar or the Enter key.

. Accesses the original or default command if it was undefined using the 
Undefine command. For example:
.LINE

_ Uses the default English translation for subsequent commands and 
options. This allows the macro to run on all languages. For example:
_ARC

- Runs the command line version of the command instead of the dialog box 
version. This is useful when running commands in scripts. For example:
-BOUNDARY

’ Runs the command transparently, i.e., within a running command. For 
example:
_LINE;\_’COLOR
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* Repeats the subsequent command or entire macro until another command 
is run or the user cancels it. For example:
*CIRCLE

=* Displays the current top-level user interface item.

$ Starts a DIESEL routine. For example:
$M=$(getvar,cmdnames)

@ Inputs the coordinates of the previously specified point. For example:
_CIRCLE;@_DIAMETER3

^B Turns snaps on or off by toggling the SNAPMODE system variable. For 
example:
^B_CIRCLE;

^F Forces a cancel. Can be used outside of a command to clear a selection.

^E Sets the isometric plane to the next option (Top, Right, or Left) by setting 
the SNAPISOPAIR system variable. Equivalent to F5 and Ctrl+E.

^G Turns the reference grid on or off by toggling the GRIDMODE system 
variable. Equivalent to F7 and Ctrl+G.

^O Turns orthogonal mode on or off by toggling the ORTHOMODE system 
variable. Equivalent to F8 and Ctrl+L.

^P Turns menu echo mode on or off by setting the MENUECHO system 
variable.

^T Turns tablet mode on or off by toggling the TABMODE system variable. 

^V Activates the next viewport which affects the CVPORT system variable.

Character Description
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Creating customized toolbar files manually
With IntelliCAD, the easiest way to share toolbars is to create a new .cui file using 
the Customize UI command and share that file with other IntelliCAD users. For more 
details, see “Creating a new .cui file and copying settings” on page 919 in this chap-
ter. 

You can also manually create toolbars that you can share by creating or modifying an 
.mnu file manually.

To manually create a toolbar that you can share
1 Open any ASCII or Unicode text editor.

2 Use the following toolbar syntax to type the toolbar definitions:

***MENUGROUP=group_name

***TOOLBARS

**toolbar_name

ID_toolbar_name [_Toolbar ("toolbar_name", orient, visible, xval, yval, 

rows)]

ID_button_name [_Button ("button_name", id_small, id_large)]command

***HELPSTRINGS

ID_button_name [help_string]

3 Save the file to the IntelliCAD folder with a *.mnu extension.

Toolbar syntax and explanations
Item Explanation
group_name Menu group name.

toolbar_name Toolbar name.

orient Orientation. Select Floating, Top, Bottom, Left, and Right (not case 
sensitive).

visible . Select Show or Hide (not case sensitive).

xval x coordinate, designated in pixels from left edge of screen. Suggested 
value: 200.

yval y coordinate, designated in pixels from top edge of screen. Suggested 
value: 200.

rows Number of rows

button_name Tool name. Appears as a ToolTip when user places cursor over button.

id_small Name of small (16 x 16 pixels) icon bitmap (BMP) file. This file must be 
located in the IntelliCAD folder specified in Tools > Options > Paths.

id_large Name of large (32 x 32 pixels) icon bitmap (BMP) file. This file must be 
located in the IntelliCAD folder specified in Tools > Options > Paths.

command Command string (Example: ^C^C_LINE).

help_string Help string. Appears in the status bar when cursor passes over the button.
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Example Toolbar File Contents
***MENUGROUP=example

***TOOLBARS

**NewDraw

ID_ NewDraw [_Toolbar("NewDraw ", _Bottom, _Show, 200, 200, 1)]

ID_Line_0 [_Button("Line", Iline.bmp, IL_line.bmp)]^C^C_line

ID_Hatch [_Button("Hatch", Ihatch.bmp, IL_hatch.bmp)]^C^C_hatch

ID_Dtext [_Button("Dtext", Idtext.bmp, IL_dtext.bmp)]^C^C_dtext

ID__0 [_Button("Circle Rad", Icirad.bmp, IL_cirad.bmp)]^C^Ccircle;

ID_Erase [_Button("Erase", Ierase.bmp, IL_erase.bmp)]^C^Cerase;

***HELPSTRINGS

ID_Line_0 [Creates straight line segments]

ID_Hatch [Fills an enclosed area with a nonassociative hatch pattern]

ID_Dtext [Displays text on screen as it is entered]

ID__0 [Allows user to draw a circle with a radius value]

ID_Erase [Removes objects from a drawing]

To open the file on another computer
1 Copy the toolbar (.mnu) file and all related custom bitmap (*.bmp) files to the 

IntelliCAD folder on the other computer.

2 Open IntelliCAD.

3 Do one of the following to choose Customize UI ( ):

• On the ribbon, choose Tools > Customize UI (in Manage).

• On the menu, choose Tools > Customize UI.

• Type cui and press Enter.

4 Click the Transfer tab.

5 On the left, click Open.

6 Select the new toolbar file, then click Open.

7 Click OK. 
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Customizing entities

IntelliCAD provides ways to customize entities beyond common formats, dimen-
sions, and layers. Further customization includes using custom audio notes and using 
custom shape files.

Working with audio notes
In IntelliCAD you can record and attach audio notes, which are sound clips attached 
to entities and available for playback at any time. For example, audio notes in a fac-
tory floor plan can describe maintenance activities for specific areas of the factory 
and employees can play the audio notes to hear instructions.

When you include audio notes in your drawing, they are saved in the drawing file — 
not in a separate audio file. Note that this can increase the file size of your drawing. 
Audio notes created from an existing *.wav file are also saved in the drawing file and 
the separate *.wav file remains unchanged.

You can play audio notes in IntelliCAD only. 

Attaching audio notes
Audio notes can be created from existing *.wav files. You can also record an audio 
note using any microphone that works with your computer. Many computers have a 
built-in microphone. If you do not have a microphone and you record an audio note, 
the audio note will contain no sound.

An audio note icon displays on entities that have attached audio notes. The icon is for 
display only and cannot be selected.

To record and attach an audio note to entities
1 Do one of the following to choose Audio Note ( ):    

• On the ribbon, choose Tools > Audio Note (in Manage).

• On the menu, choose Tools > Audio Note.

• On the Tools toolbar, click the Audio Note tool.

• Type audionote and then press Enter.

2 Select the desired entities, and then press Enter.

3 Choose Record.

4 Click Record to begin the audio note, and then speak into the microphone.

5 Click Stop to end the audio note.

6 To test the audio note, click Test, and then use Pause and Stop in the Test Audio 
Note area.

7 If necessary, you can record the audio note again. This overwrites the previous 
audio note for the entities you selected in Step 2.

8 Click Attach.
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You can modify an audio note after you attach it to an entity. 
Select the entity and re-record the audio note using the previous steps.

To attach an audio note to entities using a .wav file
1 Do one of the following to choose Audio Note ( ):    

• On the ribbon, choose Tools > Audio Note (in Manage).

• On the menu, choose Tools > Audio Note.

• On the Tools toolbar, click the Audio Note tool.

• Type audionote and then press Enter.

2 Select the desired entities, and then press Enter.

3 Choose Attach.

4 Select the desired *.wav file, and then click Open.

Selecting audio notes
Audio notes themselves cannot be selected. Instead, you select the entity that corre-
sponds to the desired audio note.

An audio note icon displays on entities that have attached audio notes. The icon is for 
display only and cannot be selected.   
  

To select audio notes
1 Do one of the following to choose Audio Note ( ): 

• On the ribbon, choose Tools > Audio Note (in Manage).

• On the menu, choose Tools > Audio Note.

• On the Tools toolbar, click the Audio Note tool.

• Type audionote and then press Enter.

2 Select the entity that is attached to the desired audio note, and then press Enter.

You cannot select the audio note icon that displays on the entity.

3 Choose an option to continue working with audio notes.

An audio note icon displays on an entity, signifying that an audio note 
is attached to the entity.
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Playing audio notes

To play audio notes
1 Do one of the following to choose Audio Note ( ):

• On the ribbon, choose Tools > Audio Note (in Manage).

• On the menu, choose Tools > Audio Note.

• On the Tools toolbar, click the Audio Note tool.

• Type audionote and then press Enter.

2 Select the entity that has the audio note you want to play, and then press Enter.

3 Choose Playback.

4 In the Playback dialog box, do the following:

• Click Play to begin playback.

• To pause the audio note temporarily, click Pause and then click Resume to 
continue.

• Click Stop to end playback.

5 Click OK.

Deleting audio notes
You can remove audio notes from selected entities. In some cases, you may want to 
remove extra audio notes to reduce the drawing file size. 

When you remove an audio note from an entity, the audio note is removed perma-
nently and cannot be recovered. However, if the audio note was created using an 
existing *.wav file, that *.wav file is not removed.

To delete audio notes
1 Do one of the following to choose Audio Note ( ): 

• On the ribbon, choose Tools > Audio Note (in Manage).

• On the menu, choose Tools > Audio Note.

• On the Tools toolbar, click the Audio Note tool.

• Type audionote and then press Enter.

2 Select entities that have the audio notes you want to delete, and then press Enter. 

3 Choose Delete.

Using shape files
Shapes are entities that you define for use as drawing symbols and text fonts. You can 
specify the scale and rotation to use for each shape as you add it. 

To use shape files, you first load the compiled shape file that defines the shape. Then 
you use insert shapes from the file into your drawing. 
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To load a shape file
1 Type load and then press Enter.

2 In the Load Shape File dialog box, select a shape file.

3 Click OK to close the Load Shape File dialog box.

To use a shape file
1 Type shape and then press Enter.

2 Type a shape name and press Enter.

3 Specify an insertion point.

4 Specify a height.

5 Specify a rotation angle.
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Creating and replaying scripts

IntelliCAD can record anything you type on the keyboard and any points you select 
in a drawing. You can save all of these actions to a script file (with the *.scr exten-
sion) and then repeat them by replaying the script. You can use scripts for succes-
sively repeating commands, showing snapshots in a slide show, or batch printing. 
You can also load and run script files created for use with AutoCAD.

A script is a form of text file that contains one line of text or other data for each 
action. IntelliCAD includes a Script Recorder that records both command line entries 
and screen picks you make with your mouse. For example, when you type a com-
mand and press Enter, it is recorded on a line in the script file. When you select a 
point in a drawing, the coordinate of that point is recorded on a line in the script file. 

You can also create script files outside IntelliCAD using a text editor (such as Micro-
soft® Notepad or Microsoft® WordPad) or a word-processing program (such as 
Microsoft® Word) that saves the file in ASCII format. The file type and extension 
must be .scr. 

Recording scripts
After you activate the Script Recorder, every keyboard entry you make and any 
points you select in a drawing are recorded until you stop the Script Recorder. You 
can play back your script at any time.

CAUTION
The Script Recorder does not record your use of toolbars, menus, or dialog boxes. 
Using these elements while recording a script causes unpredictable results.

To record a script 
1 Do one of the following to choose Record Script ( ):

• On the ribbon, choose Tools > Record Script (in Applications).

• On the menu, choose Tools > Record Actions > Record Script.

• On the Tools toolbar, click the Record Script tool.

• Type recscript and then press Enter.

2 Specify the name of the script file you want to create.

3 Click Save.

4 Type commands on the keyboard.

The Script Recorder records all keyboard entries and all points you select in the 
drawing, saving everything to the script file.
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To stop recording 
1 Do one of the following to choose Stop Recording ( ): 

• On the ribbon, choose Tools > Stop Recording (in Applications).

• On the menu, choose Tools > Record Actions > Stop Recording.

• On the Tools toolbar, click the Stop Recording tool.

• Type stopscript and then press Enter.

Replaying scripts
There are a number of ways you can replay scripts:

• Choose the Run Script command in IntelliCAD.

• Drag and drop the script file from Windows Explorer or the desktop onto the Intel-
liCAD drawing window.

• Run IntelliCAD with the script at startup using the Command Prompt.

To play a script in IntelliCAD
1 Do one of the following to choose ( ):

• On the ribbon, choose Tools > Run Script (in Applications).

• On the menu, choose Tools > Record Actions > Run Script.

• On the Tools toolbar, click the Run Script tool.

• Type script and then press Enter.

2 In the Run Script dialog box, specify the name of the script file you want to run.

3 Click Open.

The program immediately runs the script, performing all the actions originally 
recorded.

To start IntelliCAD and play a script using the Command Prompt
1 Open the Command Prompt window.

2 Type the following, where filename.scr is the name of the script, including the 
path to the .scr file:

icad.exe /b D:\temp\filename.scr
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Modifying scripts

To append to a script
1 Do one of the following to choose Record Script ( ):

• On the ribbon, choose Tools > Record Script (in Applications).

• On the menu, choose Tools > Record Actions > Record Script.

• On the Tools toolbar, click the Record Script tool.

• Type rescript and then press Enter.

2 In the Record Script dialog box, select the Append To Script check box.

3 Select the existing script file to append.

4 Click Save.

5 Click Yes to the prompt asking whether you want to replace the existing script.

6 Repeat the procedure to enter additional commands and steps.

Customizing script files using a text editor
The easiest way to create or customize a script file manually is to record and save a 
script in IntelliCAD that approximates the commands and actions you want, then cus-
tomize the script as necessary using a text editor. In addition to IntelliCAD com-
mands, it is also common to include standard LISP functions and commands in script 
files.

Be sure to save the script file in ASCII format with an .scr file extension. 

Understanding script syntax
The following table describes the syntax to use in script files when calling commands 
and specifying actions. For example, script files can contain comments; any line that 
begins with a semicolon is considered a comment, and the program ignores these 
lines when replaying the script.

Script syntax

Character Description
; Semicolons indicate comments. Any text after a semicolon on the 

same line is ignored.

blank space Spaces and new, empty lines in scripts are the equivalent of pressing 
the Enter key.

_ Underscores before a command or keyword run the English name of 
the subsequent command, not a localized version in a different 
language.

For example, a script with the syntax _CIRCLE can be used in other 
language versions of the program without replacing every occurrence 
of the command name CIRCLE.



942 C H A P T E R  1 7
The following is text from a sample script:

; Draw a circle (this is a comment)

_.CIRCLE 0,0,0 _DIAMETER 3 

The following shows the same script but with @ representing the location of spaces 
for clarity:

; Draw a circle (this is a comment)

_.CIRCLE@0,0,0@_DIAMETER@3@

The spaces are critical, representing the Enter key and moving the command to a new 
option or exiting the command. The space after the number 3 (the circle diameter) 
represents the user pressing Enter to submit the diameter to complete the command. 
A new blank line could also have been used in the script file and produced the same 
result as using a space.

Using common commands and system variables
The following table describes commands and system variables that are commonly 
used in scripts.

. Periods before commands run the original, standard version of the 
subsequent command. This ensures that a redefined version of a 
command is not run.

- Dashes before commands run the command line version of the 
command. For example, LAYER runs the dialog box version of the 
command, and -LAYER runs the command line version where all input 
can be entered via the script.

’ Apostrophes before commands run the command transparently, i.e., 
within another command. For example, with the LINE command 
running, change the current color without interrupting the command by 
typing 'COLOR.

Common commands and system variables used in scripts

Character Description
’DELAY Pauses the script for a specified number of milliseconds.

FILEDIA Turns off dialog boxes, which forces the input to the command line 
where the script can provide filenames and other information.

’GRAPHSCR Switches from the drawing area to the text window.

MENUECHO Turns off command prompts.

OSMODE Turns snap settings on or off to make sure selected points are at the 
correct location.

PICKBOX Adjusts the size of the entity selection pickbox to help accurately select 
entities in the drawing.

Script syntax

Character Description
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The following is a sample script that opens a drawing file without displaying a dialog 
box:

; Open a file

_.FILEDIA 0

_.OPEN C:\\Temp\\My File.dwg

; Reset FILEDIA

_.FILEDIA 1

Running IntelliCAD with command line options
Scripts can start IntelliCAD with or without custom options. These custom options 
can also be called when starting IntelliCAD from the operating system’s Command 
Prompt window.

To start IntelliCAD from the Windows Command Prompt using command line 
options
1 Open the Windows Command Prompt.

2 Run IntelliCAD with any of the available options, for example, the following 
starts IntelliCAD and automatically runs a script:

icad.exe /b filename.scr

IntelliCAD also supports several standard operating system command line options, 
such as /RegServer and /UnregServer.

RESUME Continues a script after a break or interruption.

RSCRIPT Repeats a script.

’TEXTSCR Switches from the text window to the drawing area.

Command line options for customizing the start of IntelliCAD

Character Description
? Displays the list of available options.

Nologo Prevents the splash screen from displaying during startup.

P profilename Specifies an overriding profile name.

S path1;... Specifies the full path to an overriding support path.

T templatename Creates a new drawing using the specified template.

B scriptname Specifies the full path to the script to run automatically after startup.

Ld applicationname Loads a third-party application automatically after startup.

Common commands and system variables used in scripts

Character Description
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Running custom applications from a script
Scripts can include lines that run LISP routines and entire SDS and IRX applications.

To run a custom application from a script
• Add a line in your script, where filename is the name of your custom application:

; Runs a LISP routine

load "D:\\Temp\\filename.lsp"

; Runs an SDS application

xload "D:/temp/filename.dll"

; Runs an IRX application

arxload "D:/temp/filename.irx"

Programming IntelliCAD

Another way you can customize IntelliCAD is to add custom programs written in any 
of several programming languages that run within IntelliCAD, including the follow-
ing: TX, .NET, LISP, SDS, DCL, VBA, and DIESEL.

In IntelliCAD, you can run many programs originally created for use with AutoCAD. 
Specifically, you can use programs written entirely in AutoLISP with no modifica-
tion. In addition, you can run many ADS programs originally written for use with 
AutoCAD after first recompiling them using the IntelliCAD run-time libraries. Many 
AutoCAD third-party programs are compatible with IntelliCAD.

Use the online Help. 
For information about programming for IntelliCAD, see the online Help for the Intel-
liCAD Developer’s Reference.

Using TX/IRX applications
The TX/IRX interface is available for developers to create custom entities and appli-
cations. 

To load a TX/IRX custom application 
Advanced experience level

1 Do one of the following:

• On the ribbon, choose Tools > Load Application (in Applications).

• On the menu, choose Tools > Load Application.

• Type appload and then press Enter.

• Drag and drop the TX or IRX file into IntelliCAD.
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2 In the Load Application Files dialog box, click Add File.

3 Select the TX or IRX file that you want to load, and then click Open.

4 Click OK.   

To run a TX/IRX custom application 
Advanced experience level

1 Do one of the following:

• On the ribbon, choose Tools > Load Application (in Applications).

• On the menu, choose Tools > Load Application.

• Type appload and then press Enter.

2 In the Load Application Files dialog box, choose the routine you want to run 
(make sure that it is the only one selected), and then click Load.

TX/IRX custom applications can also be run automatically when the program starts.
You can add .tx and .irx files to a startup suite or use a script. For details, see “Load-
ing custom applications automatically when IntelliCAD starts” on page 951 in this 
chapter. 

For more information
• See the sample TX and IRX applications.

• Read the online documentation for TX and IRX, available in the Developer Refer-
ence of IntelliCAD Help. 

Using .NET applications
IntelliCAD supports the .NET programming language in two ways:

• .NET Classic — More closely matches the .NET interface used by AutoCAD.

• .NET based on COM — Initial .NET interface supported by IntelliCAD. 

To prepare a .NET custom application
1 In the .NET application, inherit the IICadPlugin interface that is defined in Intelli-

CAD as:

public interface IIcadPlugin

{

    void PluginLoaded(object sender, EventArgs e);

    void PluginUnLoading(object sender, EventArgs e);

}

Where PluginLoaded() is called on plug-in load, the sender argument is a 
COM Interop model class IntelliCAD.Application for working with (storing it as a 
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class member), and PluginUnLoading()is called right before the plug-in is 
unloaded. 

To load a .NET Classic custom application 
1 Do one of the following:

• On the menu, choose Tools > Load Classic .NET Application.

• Type netload and then press Enter.

2 In the Open an Assembly dialog box, select the .NET .dll file that you want to 
load, and then click Open.    

.NET Classic custom applications can also be run automatically when the program starts.
You can add .dll files for .NET to a startup suite or use a script. For details, see 
“Loading custom applications automatically when IntelliCAD starts” on page 951 in 
this chapter. 

Using LISP routines 
IntelliCAD supports the LISP programming language and is compatible with 
AutoLISP, the implementation of the LISP language in AutoCAD. This means that 
you can load and run any AutoLISP program written for use with AutoCAD.

To load a LISP routine 
Advanced experience level

1 Do one of the following:

• On the ribbon, choose Tools > Load Application (in Applications).

• On the menu, choose Tools > Load Application.

• Type appload and then press Enter.

• Drag and drop the LISP file into IntelliCAD.

2 In the Load Application Files dialog box, click Add File.

3 Select the LISP file that you want to load, and then click Open.

4 Click OK.   

Load LISP routines from the command bar. 
In the command bar, type (load “d:/path/routine.lsp”), making sure to include the 
parentheses and the quotation marks, where d:/path is the drive and path where the 
LISP routine is located on your computer, and routine.lsp is the LISP routine file 
name. 
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To run a LISP routine 
Advanced experience level

1 Do one of the following:

• On the ribbon, choose Tools > Load Application (in Applications).

• On the menu, choose Tools > Load Application.

• Type appload and then press Enter.

2 In the Load Application Files dialog box, choose the routine you want to run 
(make sure that it is the only one selected), and then click Load.

Some LISP routines are created in such a way that you can run them by simply typing 
the name of the routine, or by typing a keyword, directly in the command bar. If noth-
ing happens when you attempt to run the LISP routine from within the Load Applica-
tion Files dialog box, turn on the display of the command bar or Prompt History 
window by choosing View > Display > Command Bar or View > Display > Prompt 
History Window, and look for an entry that is similar to the following: 

Loading D:\path\routine.lsp

C:KEYWORD

where D:\path\routine.lsp is the complete drive, path, and file name of the LISP rou-
tine. You may need to scroll back several lines in the command bar or Prompt History 
window to find the lines indicating where the LISP routine was loaded. You can run 
the LISP routine by typing the name of the routine or keyword appearing after the C 
drive designation. 

For example, if you loaded a LISP routine named drawbox.lsp and see the designa-
tion C:DRAWBOX in the command bar or Prompt History window, you can run the 
LISP routine by typing drawbox in the command bar.    

LISP routines can also be run automatically when the program starts.
You can add .lsp and .mnl files to a startup suite or use a script. For details, see 
“Loading custom applications automatically when IntelliCAD starts” on page 951 in 
this chapter. 

Using SDS applications 
To write AutoCAD applications in C or C++, Autodesk® uses the ADS (AutoCAD 
Development System). This is an API (applications programming interface) that pro-
vides a library to access AutoCAD-specific functions and drawing data. 

The equivalent in IntelliCAD is called SDS™, the Solutions Development System™. 
SDS is a C/C++ language interface compatible with the ADS interface in AutoCAD. 
Like scripts and AutoLISP, you can run your existing ADS applications in 
IntelliCAD. Simply recompile the source code using the SDS libraries provided on 
the IntelliCAD CD-ROM, or, if you use an AutoCAD program written by a third-
party vendor, contact that vendor for the IntelliCAD version.
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IntelliCAD provides the Sds.H file, which redefines ADS function names to their 
SDS equivalents. SDS supports the AutoCAD dialog control language (DCL), which 
is used by ADS to define the look of a dialog box. You can use all DCL files unmod-
ified within SDS. 

Understanding SDS compatibility
The primary difference between ADS and SDS is that all SDS functions have an sds_ 
prefix, and ADS functions have a variety of prefixes, such as ads_, acad_, and acrx_. 
The exception is dialog-related SDS functions, which have a dlg_ prefix. IntelliCAD 
accepts either prefix. Other differences include the additional SDS functions listed in 
the following table. 

Some ADS functions are not supported in SDS, including: ads_arxload, 
ads_arxloaded, ads_arxunload, ads_ssgetx, ads_ssGetKwordCallbackPtr, 
ads_ssGetOtherCallbackPtr, adsw_acadMainWnd, and adsw_acadDocWnd. 

SDS custom applications can be run automatically when the program starts.
You can add .dll files for SDS to a startup suite or use a script. For details, see 
“Loading custom applications automatically when IntelliCAD starts” on page 951 in 
this chapter. 

SDS functions with no ADS equivalent
SDS function name Description
sds_grclear Clears all graphics from the drawing window; similar to the LISP 

(grclear) function.

sds_name_clear Clears the entity name or selection set.

sds_name_equal Verifies whether two entity names or selection sets are equal.

sds_name_nil Verifies whether the entity name or selection set has been 
cleared. 

sds_name_set Copies one entity name or selection set to another drawing.

sds_pmtssget Similar to the ads_ssget function, but allows you to display a 
prompt appropriate for the specific command, rather than the 
generic “Select object” prompt.

sds_point_set Copies a point from one variable to another.

sds_progresspercent Displays the percentage done in a progress bar.

sds_progressstart Starts the progress bar.

sds_progressstop Ends the progress bar.

sds_readaliasfile Loads the PGP file into IntelliCAD.

sds_sendmessage Sends a message to the IntelliCAD command line.

sds_swapscreen Flips the off-screen device context to the display.
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For more information
• Read the online documentation for SDS functions. 

• See the \IntelliCAD\Api\Sds folder, which contains the SDS include, header, and 
library files.

• See the \IntelliCAD\Api\Dcl folder, which contains the core DCL files.

Using DDE applications
IntelliCAD supports the DDE API, which allows you to execute IntelliCAD com-
mands at the command line from an external application. IntelliCAD includes a sam-
ple command-line application that reads a script file and sends it to IntelliCAD for 
step-by-step execution.

To see a sample of DDE script execution
1 Compile the source code of the DDESample project. The sample application is 

located at:
Source\IntelliCAD\api\DDE\Samples\DDESample

2 Run IntelliCAD.

3 Run the DDESample application with the sample script file that is included in the 
VC project.

IntelliCAD shows the results.

Using DCL with IntelliCAD
IntelliCAD completely supports the AutoCAD DCL (dialog control language). DCL 
is used by AutoLISP functions to define the look of dialog boxes. You can use all 
DCL files unmodified within IntelliCAD.

Using VBA
IntelliCAD can be customized using Visual Basic for Applications (VBA) through an 
integrated interface, available from the IntelliCAD Tools menu. IntelliCAD features a 
broad range of objects, giving you the power to write your own custom applications 
that can run within IntelliCAD. 

To load a VBA project
Advanced experience level

1 Do one of the following:

• On the ribbon, choose Tools > Load VBA Project (in Applications).

• On the menu, choose Tools > Visual Basic > Load VBA Project.

• Type vbiload and then press Enter.

2 Locate and select the Visual Basic project file (.vbi file) to load, then click Open.
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To run a VBA macro        
Advanced experience level

1 Do one of the following:

• On the ribbon, choose Tools > Macros (in Applications).

• On the menu, choose Tools > Visual Basic > Macros.

• Type vbarun and then press Enter.

2 In the Run IntelliCAD VBA Macro dialog box, enter the name of an existing VBA 
macro, and then click Run.

You can also create, delete, and edit VBA macros from this dialog box.

To edit a VBA macro      
Advanced experience level

1 Do one of the following:

• On the ribbon, choose Tools > Visual Basic Editor (in Applications).

• On the menu, choose Tools > Visual Basic > Visual Basic Editor.

• Type vba and then press Enter.

2 Use the Visual Basic Editor to write or debug VBA macros.

For more information
• Read the online documentation for VBA, available from the editor Help menu and 

from the IntelliCAD Help menu. 

• Many publications are available that explain how to program in VBA.

Using DIESEL with IntelliCAD
IntelliCAD supports AutoCAD DIESEL (Direct Interactively Evaluated String 
Expression Language). DIESEL is a separate interpretive programming language that 
allows you to customize the following:

• Status bar 

• Menus 

• LISP functions 

For more information
• Read the online documentation for DIESEL, available from the IntelliCAD Help. 

• Several publications and tutorials are available online that explain how to use 
DIESEL.
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Loading custom applications automatically when IntelliCAD 
starts
If you have custom applications that you want loaded each time the program starts,  
you can add those applications to a startup suite in IntelliCAD or use an external 
script.

Using a startup suite to load applications automatically
A startup suite is a list of custom application files that load each time IntelliCAD 
starts. The applications are loaded in the order they appear in the list.

To load an application from a startup suite when IntelliCAD starts
1 Do one of the following to choose Load Application ( ):

• On the ribbon, choose Tools > Load Application (in Applications).

• On the menu, choose Tools > Load Application.

• Type appload and then press Enter.

2 Click Startup Suite.

3 Click Add ( ).

4 Select the application file you want automatically loaded when IntelliCAD starts.

5 Click Open.

6 If necessary, click Move Up ( ) or Move Down ( ) to reorder the startup 
suite list.

7 Click OK.

8 Click OK again.

Using a script to load applications automatically
Custom applications can be referenced in an external script, and then loaded each 
time IntelliCAD starts. Each application type has its own script requirements.

To run a TX/IRX custom application from a script when IntelliCAD starts 
1 Create an ASCII file named icad.rx that contains the path to the IRX files on each 

line of the file.

2 Place icad.rx in the same folder as icad.exe.

3 Run IntelliCAD. 

To load a .NET Classic custom application from a script when IntelliCAD starts
1 Create an ASCII file named icad.net that contains the path to a .NET plug-in file 

on each line of the file.

2 Place icad.net in the same folder as icad.exe.

3 Run IntelliCAD. 
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To load a LISP routine from a script when IntelliCAD starts
1 Create an ASCII file that contains the path to a LISP routine on each line of the 

file. Example file content:

(load "C:\\Users\\Documents\\username\\lisp routines\\areap.lsp")

2 Save the file with one of the following names:

• ICAD.LSP — Automatically loads the referenced LISP routines when Intel-
liCAD starts.

• ICADDOC.LSP — Automatically loads the referenced LISP routines when 
creating or opening each drawing file.

3 Place the .lsp file in the same folder as icad.exe.

4 Run IntelliCAD.

Use a system variable.
To make all drawings share the same LISP environment (variables, functions, etc.), 
set the LISPINIT system variable to 2.

To load an SDS custom application from a script when IntelliCAD starts
1 Create an ASCII file named icad.sds that contains the path to the .dll files on each 

line of the file.

2 Place icad.sds in the same folder as icad.exe.

3 Run IntelliCAD. 
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Using specialized pointing devices

In addition to traditional mouse pointers, IntelliCAD can also be used with a special-
ized mouse for CAD drawing and a digitizer tablet.

Using a specialized mouse for CAD
IntelliCAD works with specialized input devices from 3Dconnexion to streamline the 
CAD workflow and improve control and efficiency while drawing and navigating in 
two or three dimensions. Simply connect your mouse from 3Dconnexion to your 
computer, and it will automatically set up for your version of IntelliCAD.

IntelliCAD supports the following devices from 3Dconnexion:

• SpaceMouse — For details, see 3Dconnexion’s SpaceMouse 3DxWare documen-
tation online at docs.intellicad.org.

• CadMouse — For details, see 3Dconnexion’s CadMouse 3DxWare documenta-
tion at docs.intellicad.org.

Using a digitizer tablet
IntelliCAD supports tablets compatible with the TabletWorks driver and has its own 
tablet overlay. For instructions on installing the tablet driver and using the buttons on 
your pointing device, refer to your hardware documentation. 

Three options are available with the Tablet command: 

• Configure Maps the tablet overlay to the tablet itself. Configure the tablet if you 
plan to select IntelliCAD tools from the tablet overlay.

• Calibrate Maps points on the tablet, in absolute coordinates, to points on a draw-
ing. Calibrate the tablet if you intend to digitize points. This process is convenient 
for tracing paper drawings.

• Tablet ON/OFF Turns tablet calibration (digitizer mode) on and off. Use this to 
switch between tool selection and digitizer input. To use the tablet for tool selec-
tion, tablet mode must be turned off. 

Configuring the tablet
Before you begin to configure the tablet, slip the tablet overlay underneath the tab-
let’s plastic cover, and align it in accordance with the directions for your tablet. If 
your tablet does not have a plastic cover, align the overlay holes with the pegs on 
your tablet. 

IntelliCAD provides a default configuration for tablets measuring 12" by 12". If you 
choose to accept the default, be sure to verify that the commands in the grid are acti-
vated correctly. If the default alignment does not work for your tablet, you’ll need to 
begin the configuration process again and align the tablet yourself.

https://docs.intellicad.org/files/3dconnexion/10-7-2/CadMouse_3DxWare_Help.pdf
https://docs.intellicad.org/files/3dconnexion/10-7-2/SpaceMouse_3DxWare_Help.pdf
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To configure the tablet for menu input
1 Do one of the following:

• On the menu, choose Tools > Tablet > Configure.

• Type tablet, choose Configure, and then press Enter.

2 In response to the prompt to align the tablet, do one of the following:

• If your tablet is 12" by 12", choose No to accept the default alignment and 
conclude the configuration process. 

• To align the tablet yourself, choose Yes, and then continue with step 3.

3 Click the tablet pointer on the upper left alignment point of the overlay (). 

4 Click the tablet pointer on the lower left alignment point of the overlay ().

5 Click the tablet pointer on the lower right alignment point of the overlay ().

6 Click the tablet pointer on the lower left alignment point of the Workspace area of 
the overlay ().

7 Click the tablet pointer on the upper right alignment of the Workspace area of the 
overlay ().

To turn tablet mode on or off
1 Do one of the following:

• Choose Tools > Tablet > Tablet On (or Tablet Off).

• Type tablet, choose On or Off, and then press Enter.

• Press the F4 key to toggle tablet mode on or off.

• On the status bar, double-click TABLET to turn tablet mode on or off. 

Click points in the order shown to configure your tablet for menu input.

5

1

2

4

3
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Calibrating the tablet
You must specify at least two points for tablet calibration. However, the more points 
you specify, the more accurate the transformation between the tablet and the screen 
points. Specifying additional points is particularly useful if you plan to trace a paper 
drawing that is not orthogonal, such as an aerial photograph. 

Understanding transformation types
Depending on the number of points specified, you have a choice of transformation 
types to use, along with the type recommended for IntelliCAD. 

Transformation refers to the calculation of the points on the screen that correspond to 
points you digitize on the tablet.

• Orthogonal Preserves all angles between lines, preserves all relative distances, 
and, in general, preserves shapes. If you specify only two points, an orthogonal 
transformation is automatically generated. The orthogonal transformation type 
yields the most precise mapping between the digitized points on the tablet and the 
corresponding points on the screen.

• Affine Preserves parallel lines, but not necessarily the angles between intersecting 
lines. If you specified three points, IntelliCAD can no longer represent this map-
ping as an exact orthogonal transformation. Therefore, you have a choice of an 
exact affine transformation or a “best fit” orthogonal transformation.

• Projective Does not preserve parallel lines or angles. If you specify exactly four 
points, you have a choice of an exact projective transformation or a “best fit” 
orthogonal or affine transformation. 

Recommended and “best fit” transformation types

Number of points specified
Transformation type 
recommended “Best fit” (approximate)

2 Orthogonal None

3 Affine Orthogonal

4 Projective Orthogonal, Affine

5-10 None Orthogonal, Affine
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Choose the recommended type unless you know it will not be appropriate for what 
you are digitizing. The most appropriate type is not always the one with the least 
error; for example, you might digitize three points and select the orthogonal transfor-
mation, even though the affine transformation would yield a closer representation of 
your calibration entries.    

Digitizing by selecting points (1, 2, 3, and 4) on the tablet. Corresponding screen coordinates:
1 Coordinate specification X0, Y0, Z0
2 Coordinate specification X0, Y5, Z0
3 Coordinate specification X5, Y5, Z0
4 Coordinate specification X5, Y0, Z0

Screen result of orthogonal transformation after 
tracing polyline on tablet.

Screen result of affine transformation 
after tracing polyline on tablet.

Screen result of projective transformation after 
tracing polyline on tablet.

2

1 4

3

3

4

2

1
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To calibrate your tablet for digitizing points
1 Do one of the following:

• Choose Tools > Tablet > Calibrate.

• Type tablet, choose Calibrate, and then press Enter.

2 Click a point on the tablet to define as the first calibration point.

3 Specify a point within the IntelliCAD drawing window to correspond to the point 
you digitized on the tablet, or enter coordinate values in the command bar. 

4 Click a point on the tablet to define as the second calibration point.

Specify a point within the IntelliCAD drawing window to correspond to the point 
you digitized on the tablet, or enter coordinate values in the command bar. To 
specify more than the two points required, click a point on the tablet to define as 
the third calibration point. You can enter up to 10 points.

5 Choose the transformation type, and then press Enter.

Customizing the tablet interface
You can customize the digitizer tablet interface by using the LISP commands 
integrated with IntelliCAD, even if you are not familiar with LISP. For instructions, 
see “Customizing the Tablet Interface” in the IntelliCAD online Help.
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Restoring IntelliCAD to its default settings

The Restore Default Settings tool backs up program settings and files and then 
restores them to their original state as they were when IntelliCAD was installed.

Restoring the default settings can be helpful if the program isn’t working as expected. 
For example, if linetypes or print styles are no longer correct, restoring the default 
settings may help.

IntelliCAD can back up and restore IntelliCAD’s registry settings, Documents folder, 
and AppData folder, and can back up (but not restore) custom files that automatically 
load when IntelliCAD starts.

Restoring the default program settings is different than resetting the user interface, 
which include menus, the ribbon (if your program supports it), toolbars, keyboard 
shortcuts, aliases, and double-click actions. For details about resetting the user inter-
face, see “Loading customization files” on page 917 in this chapter. 

To restore and back up IntelliCAD default settings
1 Close IntelliCAD, if it is open.

2 From the Windows Start menu, choose Restore Default Settings where IntelliCAD 
appears in the program list.

3 In Backup To, choose one of the following:

• Zip archive Compresses and saves the files in a single .zip file.

• Folder (set of files) Saves individual files in a folder.

4 Click [...] to specify the location of the backup.

5 Select any of the following:

• Registry IntelliCAD’s registry settings include the paths to folders where many 
settings are stored. You can unmark this option only if Backup Only is marked.

• Documents folder IntelliCAD’s Documents folder contains linetypes, print 
styles, printer configuration (.pc3) files, textures, and more.

• AppData folder IntelliCAD’s AppData folder contains color book files, backup 
drawing files, spelling libraries, and templates.

• Autoloading files Custom applications that automatically load are located in the 
IntelliCAD installation folder, for example, icaddoc.lsp, icad.irx, icad.net, and 
icad.sds. These files can be backed up but cannot be restored.

6 To create a backup without restoring any settings, mark Backup Only.

7 Click Start.

The status displays in the Restore Status dialog box.

8 To view the backup files, click Open Folder.

9 When finished, click Exit.
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A Select whether to backup all files to a zip file or a 
folder.

B Mark to include registry settings. This option is 
available only if Backup Only is marked.

C Mark to include IntelliCAD’s Documents folder.
D Mark to include IntelliCAD’s AppData folder.

E Mark to include custom application files that 
automatically load at program startup.

F Mark to create only a backup and not restore any 
default settings.

G Click to select the location where the backup will 
be saved.

A

F

G

E
D
C
B
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Appendix

Understanding AutoCAD compatibility

IntelliCAD was designed to interface with AutoCAD as seamlessly as possible. There 
are, however, some differences for which those accustomed to working in AutoCAD 
may need to adjust. This appendix provides information specifically for that audi-
ence.   
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Using enhanced AutoCAD commands in IntelliCAD

IntelliCAD enhances several AutoCAD commands by providing more options. For 
example, if you hold down the Shift key, IntelliCAD is placed temporarily in orthog-
onal mode, which you will find to be a useful feature for drawing at right angles. The 
following table lists examples of other commands with enhanced options.    

Enhanced IntelliCAD commands

Command
Enhanced 
option name Explanation

circle Arc Converts an arc to a circle.

donut 2point Determines the outside diameter of a donut by 
two pick points.

donut 3point Determines the outside diameter of a donut by 
three pick points.

donut RadTanTan Determines the outside diameter of a donut by 
tangent points.

line Angle Draws a line by angle, followed by a length.

line Length Draws a line by a length, followed by an angle.

msnapshot (mslide) and 
vsnapshot (vslide) 

EMF Saves and views screen images in enhanced 
metafile format.

msnapshot (mslide) and 
vsnapshot (vslide)

WMF Saves and views screen images in Windows 
metafile format.

parallel (offset) Both sides Copies an entity parallel on both sides.

plane (solid) Rectangle Draws a rectangular solid at any angle.

plane (solid) Square Draws a square solid at any angle.

plane (solid) Triangle Draws an equilateral solid at any angle.

rectangle Square Draws a square rectangle.

rectangle Rotated Draws a rotated rectangle.
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Using additional selection sets

IntelliCAD has additional selection-set options not found in AutoCAD. In particular, 
in the circle selection set, the Crossing Circle (CC), Outside Circle (OC), and Win-
dow Circle (WC) options select all entities relative to the same distance (radius) of a 
central pick point.

The following table lists and describes the additional selection sets in IntelliCAD.    

Additional selection set options
Selection mode Description
CC Crossing Circle: Selects all entities within and crossing a circular area.

D Selection method: Displays the Drawing Settings dialog box.

O Outside Window: Selects all entities outside a rectangular area; this is the 
inverse of the Crossing Window option.

OC Outside Circle: Selects all entities outside a circular area.

OP Outside Polygon: Selects all entities outside a polygonal area; this is the 
inverse of the CP (Crossing Polygon) and WP (Window Polygon) options. 

Filter Filter: Selects according to properties, such as color, layer, linetype, 
lineweight, block, thickness, linetype scale, entity type, etc.

WC Window Circle: Selects all entities within a circular area.
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Using additional IntelliCAD commands 

Although you can use the AutoCAD command structure with IntelliCAD, the pro-
gram has its own set of commands. IntelliCAD has numerous command names not 
found in AutoCAD, although many of these commands have an equivalent function 
in AutoCAD. When you type the AutoCAD equivalent, the IntelliCAD alias system 
activates the correct command. 

For example, the AutoCAD offset command is mapped to the IntelliCAD parallel 
command. You can type either offset or parallel in the command bar, or you can 
choose Modify > Parallel.

The following table lists optional IntelliCAD command names that you can use in 
place of AutoCAD command names to perform the equivalent AutoCAD function.    

Command differences in IntelliCAD
IntelliCAD AutoCAD Action in IntelliCAD
audionote No equivalent Creates and plays audio notes 

attached to entities.

cmdbar No equivalent Positions the command window.

coordinate Ctrl+D or F6 Changes the display of 
coordinates on the status line.

copyedata No equivalent Copies extended entity data from 
one entity to another.

customize toolbar Displays the Customize dialog 
box.

deledata No equivalent Deletes extended entity data from 
an entity.

delete erase Removes entities from the 
drawing.

dimension dim Switches to dimension mode.

editedata No equivalent Edits extended entity data found in 
an entity.

editlen lengthen Changes the length of open 
entities.

editpline pedit Edits polylines and polymeshes.

entprop ddmodify and ddchprop Displays the Entity Properties 
dialog box.

esnap -osnap Sets entity snaps from the 
command line.

expblocks ddinsert Displays Explorer - Blocks.

expdimstyles ddim Displays Explorer - Dimension 
Styles.

expfonts style Displays Explorer - Styles.
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explayers layer Displays Explorer - Layers.

explorer ddrename Displays Explorer.

expltypes linetype Displays Explorer - Linetypes.

expucs dducs Displays Explorer - UCS.

expviews ddview Displays Explorer - Views.

face 3dface Draws three-dimensional faces 
with three or four vertices.

flatten No equivalent Sets thickness to zero at user-
specified elevation.

font -style Displays the Text Style dialog box.

freehand sketch Allows freehand sketching.

idpoint id Returns the x-, y-, and z-
coordinates of a picked point.

infline xline Draws a line of infinite length.

join pedit join Joins lines and arcs.

laymcur ai_molc Sets the current layer based on 
the selected entity’s layer.

mesh 3dmesh Draws a surface mesh.

moveedata No equivalent Moves extended entity data from 
one entity to another.

msnapshot mslide Makes an SLD, EMF, or WMF file 
of the current view.

orthogonal ortho Toggles orthogonal mode.

parallel offset Copies an entity by a parallel 
offset distance.

plane solid Draws a two-dimensional solid 
plane.

pmthist F2 Switches between the Prompt 
History window and the graphics 
screen.

polyline pline Draws a polyline.

ppreview preview Previews the print.

print plot Prints the drawing.

printstyle plotstyle Assigns a print style.

psetup No equivalent Displays the Print Setup dialog 
box.

qprint No equivalent Quickly prints the current viewport 
(window) with no options.

Command differences in IntelliCAD (continued)

IntelliCAD AutoCAD Action in IntelliCAD
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reassocapp No equivalent Reassociates extended entity data 
with an application.

recscript No equivalent Starts the Script Recorder.

rtrot 3dorbit Rotates the view of entities.

rtrotx No equivalent Rotates the view of entities while 
maintaining the x-axis.

rtroty No equivalent Rotates the view of entities while 
maintaining the y-axis.

rtrotz 3dorbit Rotates the view of entities while 
maintaining the z-axis.

saveall No equivalent Saves all currently open drawings.

setcolor color Displays the Color dialog box.

setdim ddim Displays the Dimension Styles 
Manager dialog box.

setesnap osnap Displays the Drawing Settings 
dialog box with the Coordinate 
Input tab displayed.

settings No equivalent Displays the Drawing Settings 
dialog box.

setucs dducs Displays the User Coordinate 
Systems dialog box.

setvpoint No equivalent Displays the Preset Viewpoints 
dialog box.

stopscript No equivalent Stops running the script.

tipofday No equivalent Displays the Tip of the Day.

undelete oops Restores the last deleted entity.

vba vbaide Opens the Visual Basic 
Applications editor.

viewctl ddvpoint Sets the three-dimensional 
viewing direction via an interactive 
dialog box.

viewpoint vpoint Sets the three-dimensional 
viewing direction via the command 
line.

vsnapshot vslide Displays an SLD, EMF, or WMF 
file in the current viewport.

Command differences in IntelliCAD (continued)

IntelliCAD AutoCAD Action in IntelliCAD
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Supporting AutoCAD customization

IntellICAD supports AutoCAD .cui/.cuix files which are used to control the follow-
ing aspects of the IntelliCAD user interface:

• Workspaces

• Menus

• Toolbars

• Ribbon, contextual ribbon states

• Quick Access toolbar

• Application button menu

• Keyboard shortcuts

• Aliases

• Double-click actions

Although IntelliCAD primarily utilizes .cui/.cuix files to control the user interface, 
IntelliCAD's Customize UI command also supports importing and exporting a variety 
of AutoCAD and IntelliCAD legacy interface file formats:

• MNU, MNS and ICM — Legacy file formats for storing menus.

• PGP and ICA — Legacy file formats for storing command aliases.

• ICK — Legacy file format for storing keyboard shortcuts

In addition to file formats that control the user interface, IntelliCAD supports a vari-
ety of additional external files supported by AutoCAD:

• LIN — Linetype file that contains linetype definitions, including complex line-
types with shapes and text.

• PAT — Pattern file that contains definitions for hatch patterns.

• MLN — Multiline pattern file.

• DWT — Drawing template file.

• BAK — Drawing backup file.

• FMP — Font mapping file.

• UNT — Unit translation file used by the LISP (cvunit) function.

• CFG — Graphics configuration file.

• ATC — Tool palette catalog.

• SHX, TFT — Font files.

• SHP — Shape file.

• ACB — Color book file.

• CHM — Help file.
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• SLD — Slide file.

• STB — Standard named print style tables used for printing.

• CTB — Color defined print style tables used for printing.

• PC3 — Printer configuration file used for printing.

• DST — Drawing sheet set file used to describe the file set used by the Sheet Set 
Manager command.

• DSD — Drawing set description file that describes a set of drawings to be used by 
the Publish command.

• ICO, BMP, PNG — Image files supported for icons in the user interface.

• JPG, PGN — Image files supported for materials.

• LSP — IntelliCAD provides a LISP interpreter, however, not all methods are fully 
supported. Note that IntelliCAD cannot load and run FAS compiled LISP code.

Understanding menu compatibility

MNU files are menu files created by all AutoCAD releases, and MNS files are 
included in AutoCAD Releases 13, 14, and 2000. IntelliCAD reads both file formats, 
even when menu macros include AutoLISP code. This feature allows you to continue 
using your existing AutoCAD menus 

IntelliCAD support of specific sections in AutoCAD MNU and MNS files
Menu section Definition IntelliCAD support
***POP0 Cursor menu Supported

***POPn Pull-down menus Supported

***AUXn Auxiliary menus Not supported

***BUTTONn Button menus Not supported

***ICON Icon menus Not supported

***SCREEN Screen menus Not supported

***TABLETn Tablet menus Not supported
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Importing and exporting customization files

You can continue using aliases and menu files from AutoCAD by importing the 
appropriate file. You can import AutoCAD customization files and export IntelliCAD 
formats using the Customize dialog box. All of the files listed in the following table 
are in ASCII format, which means you can view and edit them with a text editor, such 
as Notepad. 

TIP Use the Customize UI command to customize the user interface. For more infor-
mation, see “Working with user interface customization files” on page 916. 

Customizing files
Customization Import file formats Export file formats
Aliases PGP: AutoCAD aliases

ICA: IntelliCAD aliases
PGP: AutoCAD aliases

Keyboard ICK: IntelliCAD keyboard ICK: IntelliCAD keyboard

Menus MNU: All AutoCAD menus
MNS: AutoCAD R13, R14 and 2000 
menus
ICM: IntelliCAD menu

ICM: IntelliCAD menu

Toolbars MNU: All AutoCAD menus None
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Programming IntelliCAD

IntelliCAD supports several AutoCAD application programming interfaces (APIs), 
but not all of the AutoCAD APIs are available in IntelliCAD. The following table 
summarizes the AutoCAD APIs IntelliCAD supports.  

Understanding AutoLISP compatibility 
IntelliCAD adds LISP functionality that you will find useful. The following table lists 
functions that are unique to IntelliCAD LISP.  

IntelliCAD support of the AutoCAD programming interface
AutoCAD programming interface IntelliCAD support
Scripts (SCR files) Supported

AutoLISP (LSP files) Partially supported

Dialog Control Language (DCL files) Supported

AutoCAD Development System (ADS) Supported; source code must be 
recompiled

Visual Basic Applications (VBA) Supported, depending on your version 
of IntelliCAD

Direct Interactively Evaluated String Expression 
Language (Diesel)

Supported

AutoCAD SQL Interface (ASI) Not supported

Autodesk® Threaded Language Application System 
Toolkit (Atlast)

Not needed

AutoCAD Runtime Extension (ARx) IRX Runtime Extension, custom 
objects supported

Additional IntelliCAD LISP functions
Unique LISP function Definition
(log10) Returns log base 10.

(lpad) Pads a text string with spaces to the left.

(rpad) Pads a text string with spaces to the right.

(tan) Returns the tangent.

(trim) Trims spaces from a string.
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Not all IntelliCAD LISP functions are completely compatible with AutoLISP func-
tions. The following table identifies IntelliCAD LISP functions that are partially 
compatible with AutoLISP functions.

In addition, IntelliCAD LISP does not support all AutoLISP functions. The following 
areas are not supported by IntelliCAD LISP:

• (acdimenableupdate), (acet-attsync), (acet-layerpmode), (acet-layerp-mark), 
(acet-laytrans), (acet-ms-to-ps), (acet-ps-to-ms), (defun-q), (defun-q-list-ref), 
(defun-q-list-set), (entmakex), (initdia), (namedobjdict), (ssnamex), and (tablet)

• ARX-related functions that run ARX applications

• (dict)-related functions

• SQL-related functions that link AutoCAD entities with external database records. 
These functions start with ase_, for example, (ase_lsunite) and (ase_docmp)

Partially compatible LISP functions
LISP function Description
(menucmd) Supports P0 (cursor menu), P1 through P16 (the pull-down menus), 

and M (diesel expressions), but does not support A (aux menus), B 
(button menus), I (icon menus), S (screen menu), or T (tablet menus).

(print1) Does not support Unicode characters, such as \U+00B0 (the degree 
symbol) and M+Nxxxx (multi-byte Unicode sequences).

(ssget) and (ssadd) Supports additional selection modes:
CC = Crossing Circle
O = Outside
OC = Outside Circle
OP = Outside Polygon
PO = POint
PRO = Properties
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IntelliCAD and AutoCAD list of terms

  

List of terms
IntelliCAD term Meaning for AutoCAD users
command bar command prompt area

edit length lengthen

entity object

entity snap object snap

entity snap precision aperture

fixed attribute constant attribute

follow continue

freehand sketch

hidden attribute invisible attribute

infinite line XLine

insert draw

orthogonal ortho

parallel offset

plane solid (2D)

predefined attribute preset attribute

print plot

print style plot style

prompt box context menu

Prompt History window text screen

reference grid grid

point snap node snap

snapshot slide (SLD)

validate attribute verify attribute



Glossary

2D  Two-dimensional locations defined by x- and y-coordinates.

3D  Three-dimensional locations defined by x-, y-, and z-coordinates.

3D solids  Three-dimensional ACIS entity.

absolute coordinates  Coordinates defined in relation to the origin point of the cur-
rent user coordinate system. See also coordinate system, coordinates, origin, rela-
tive coordinates, user coordinate system, and World Coordinate System.

ActiveX  A mechanism for exchanging information between different programs 
whereby a copy of a source document is embedded or a pointer to a source document 
is linked to a target document. See also embed and link.

acute angles  Angles of fewer than 90 degrees.

alias  An abbreviation or alternative word for an IntelliCAD command.

aligned dimension  A dimension aligned parallel to an entity or measuring the dis-
tance between two points at any angle.

angle  The difference in direction between two nonparallel linear entities, measured 
in degrees or radians.

angular dimension  A dimension measuring the angle between two lines or sub-
tended by an arc.

angular unit  The unit of measurement for angles. Angular units can be measured in 
decimal degrees, degrees/minutes/seconds, grads, and radians.

annotation  Any text, dimensions, tolerances, or notes added to a drawing.

ANSI  Acronym for American National Standards Institute. In the context of text, a 
standard character set defined by ANSI used in computer-aided drafting.

arc  A segment of a circle or ellipse.

area  Measurement of a planar region or the calculated space within an entity. 

array  Multiple copies of selected entities in a circular or rectangular pattern.

ASCII  Acronym for American Standard Code for Information Interchange, a com-
monly used system for assigning numbers to printable alphanumeric characters, 
punctuation, and symbols.
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attribute  A component of a block containing specific text or numeric information. 
You can copy the information contained in an attribute from the drawing to an exter-
nal database.

attribute definition  An entity composed of a name, prompt for information, display 
characteristics, and default text that, when incorporated into a block, creates an attri-
bute when the block is inserted into a drawing.

attribute name  Text that identifies an attribute within a block.

attribute text  The text containing an attribute’s information within a block.

B-spline curve  See spline. 

base point  A point on an entity that serves as its reference or insertion point. A 
point of reference when specifying relative distances.    

baseline  The line on which text characters appear to sit. The descenders of individ-
ual characters drop below the baseline.

baseline dimension  Multiple parallel dimensions measured from the same baseline 
origin.

bind  To convert an externally referenced drawing into a standard block definition.

blips  Temporary screen markers displayed in a drawing when you select a point. 
Also called marker blips.

block  One or more entities grouped together to create a single entity. See also 
nested block.

block definition  The name, base point, and entities grouped together when creating 
a block.

boundary  A selected area bounded by a single closed entity or by multiple entities 
that intersect.

BYBLOCK  A property whereby an entity inherits the color, linetype, lineweight, or 
print style of any block that contains it.

BYLAYER  A property whereby an entity inherits the color, linetype, lineweight, or 
print style of its associated layer. 

CAD  Acronym for computer-aided design.

Cartesian coordinates  Coordinates defined using three perpendicular axes (x, y, 
and z) to define locations in three-dimensional space. See also cylindrical coordi-
nates, polar coordinates, and spherical coordinates.

center line  A line used to indicate the center of a circle or an arc, usually consisting 
of a center mark and lines extending slightly beyond the diameter of the circle or the 
arc.

center mark  A cross marking the center of a circle or an arc.
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chamfer  A beveled edge between two lines.

chord  A line connecting two points on a circle or an arc.

circumference  The measurement of the distance around a circle.

closed  A condition whereby the start point and endpoint of an entity are the same.

color-dependent print style table  A collection of print styles that determine how 
entities print according to their assigned color. See print style table. 

comma-delimited  Data that is separated by a comma to represent the end of a field.

command bar  A dockable window in which you type IntelliCAD commands and 
view prompts and other program messages.

cone  A three-dimensional entity where a vertex exists above or below the circular 
shape and where a surface has been applied between the vertex and the circular shape.

contiguous  Connected, unbroken, or uninterrupted. Entities that share the same 
endpoint.

continued dimension  A dimension measured from the previous extension line of 
an existing dimension, resulting in two or more dimensions positioned end to end. 

control vertex  A point used to define a spline.

Coons patch  A surface interpolated among three or four boundary curves.

coordinate filter  A function that extracts individual x-, y-, and z-coordinate values 
from different points to create a new composite point.

coordinate system  A system of points that represents the drawing space in relation 
to an origin (0,0,0) and a set of axes that intersect at the origin. In two dimensions, the 
x- and y-axes represent horizontal and vertical directions, respectively. In three 
dimensions, the z-axis represents locations above and below the two-dimensional xy 
plane. Locations in the drawing can be represented using two-dimensional and three-
dimensional rectangular (Cartesian) coordinates, two-dimensional polar coordinates, 
three-dimensional polar (cylindrical) coordinates, and three-dimensional spherical 
coordinates. See also polar coordinates, relative coordinates, spherical coordi-
nates, user coordinate system, and World Coordinate System.

coordinates  A set of values that determines a location in two-dimensional or three-
dimensional space. See also absolute coordinates, Cartesian coordinates, polar 
coordinates, relative coordinates, and spherical coordinates.

coplanar  Lying within the same plane.

crosshairs  A cursor that consists of two or three lines that intersect at the cursor 
location.

crosshatch  To fill an area with a pattern of evenly spaced perpendicular lines. See 
also hatch.



976 G L O S S A R Y
crossing circle  An entity-selection method that selects entities contained within or 
crossing the boundary of a circular selection window. 

crossing polygon  An entity-selection method that selects entities contained within 
or crossing the boundary of a polygon selection window. 

crossing window  An entity-selection method that selects entities contained within 
or crossing the boundary of a rectangular selection window. 

cube  A boxed, three-dimensional, geometric shape where length, width, and height 
are equal.

cursor  The insertion-point symbol on the screen. The appearance of the cursor 
changes based on the current task.

curve  A smooth, continuous path made up of linear and arc segments. Curve types 
include arcs, splines, circles, and ellipses. 

cylindrical coordinates  Coordinates describing a point in three-dimensional space 
based on its distance from the origin, its angle in the xy plane, and its z-coordinate 
value. See also polar coordinates and spherical coordinates.

datum-line dimensioning  See ordinate dimension.

default  An initial or predefined setting.

detach  To remove an external reference from a drawing. See also external refer-
ence.  

diameter  The distance across a circle or sphere.

digitizer tablet  A hardware input device that incorporates an electronic pad and a 
hand-held pointer similar to a mouse. A digitizer tablet serves two purposes: (1) You 
can select tools from paper representations attached to the pad (called an overlay), 
providing access to all tools at once while freeing your screen space; and (2) you can 
input digital points into the computer that correspond to points on a paper drawing, 
photograph, or blueprint attached to the pad.

dimension  A measurement, as in height or width. In the context of drafting, a set of 
lines, arrowheads, and text used to indicate a measurement. 

dimension style  A named group of dimension variable settings that determines the 
appearance of the dimension. You can save multiple dimension styles for reuse.

dimension text  The measurement value. Dimension text can include prefixes, suf-
fixes, tolerances, and other annotations.

dimension text rotation  The angle in degrees between the x-axis and the dimen-
sion text baseline.

dimension tolerance  A value specifying the allowed variation of a dimension (+ or 
– n).

dish  The lower half of a sphere. See also dome.
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displacement point  The point to which a base, or reference, point will be relocated 
when moving or copying entities.

distance  The measure of space between two points.

dock  To position a toolbar or the command bar at the edge of the drawing window, 
where it locks into place. See also float.

dome  The upper half of a sphere. See also dish.

donut  A filled circle or flat ring created as a polyline.       

drawing extents  See extents.

drawing limits  See limits.

drawing unit  The linear measurement system used in a drawing. The user deter-
mines what a drawing unit represents, such as one inch, one centimeter, one foot, or 
one meter.

DWF  Acronym for Autodesk Design Web Format, a file format for viewing two-
dimensional or three-dimensional drawings in a Web browser and distributing for 
review using free Autodesk® software and tools.

.dwg  A standard file extension used by CAD programs to store drawing files of the 
DWG format.

.dwt  A standard format used by CAD programs to store drawing templates, which 
are drawings that contain predefined settings that you can use when creating a new 
drawing. See also template.

DXF  Acronym for Drawing Exchange Format, a standard ASCII or binary file for-
mat for importing and exporting files between most CAD programs.

elevation  The z value measured from the xy plane. Positive values are above the xy 
plane; negative values are below the xy plane.

embed  A technique for exchanging information between different programs 
whereby a copy of the source document is stored in the target document. See also 
ActiveX and link.

EMF  Acronym for Enhanced Metafile, a file format with the type and extension of 
.emf. It is a native internal file format of Windows 98. EMF supports both raster and 
vector information and 24-bit RGB color. Most Windows-based programs support 
this format.

endpoint  The point at which a line or curve ends.

entity  Any single basic item in a drawing. Entities include arcs, attributes, blocks, 
circles, dimensions, ellipses, elliptical arcs, infinite lines, lines, polylines, rays, and 
text.      

entity data  Any of a variety of additional information, such as text, numbers, and 
distances, that can be attached to drawing entities.
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entity snap  A technique for accurately locating and specifying key geometric points 
on entities, such as endpoints and midpoints of lines, and center points and tangents 
of arcs and circles.

entity snap override  To disable or change an entity snap mode for a single input. 
See also entity snap and running entity snap.

Esnap  See entity snap.

explode  The conversion of a complex entity into its basic entities.

extension lines  Lines extending away from an entity being dimensioned so that 
you can place the dimension line away from the entity. Also called projection lines.

extents  The smallest rectangle that can contain all the entities in a drawing. Infinite 
lines and rays do not affect a drawing’s extents. See also limits.

external reference  A drawing that is linked to another drawing.

extrude  The process of converting a two-dimensional entity into a three-dimen-
sional entity by stretching (extruding) the two-dimensional entity along a straight 
path. Changing the thickness of a two-dimensional entity effectively extrudes it along 
its z-axis. See also tabulated surface.

face  A planar surface defined by three or four points.

fence  An entity-selection method that selects entities crossing a multisegmented 
line.

fillet  An arc that smoothly connects the end of one line to another.

fit point  A point used to define a spline.

float  To position a toolbar or the command bar away from the edges of the drawing 
window where it can be moved independently. See also dock.

freeze  To suppress the display of, and ignore the entities on, a specified layer when 
regenerating a drawing, thus accelerating the display of the drawing. See also thaw.

grid  An adjustable, regularly spaced pattern of dots on the screen, used as an aid in 
drawing and aligning entities. The grid is not printed.

grip  A small square displayed at key positions on an entity when the entity is 
selected that can be used to modify the entity by clicking and dragging.

halfwidth  The distance from the center of a wide polyline to its edge.

hatch  To fill a selected area either with lines, crosshatching, or a hatch pattern. See 
also crosshatch.

hatch pattern  A pattern, often representing a material such as steel, wood, or sand, 
for filling selected areas.
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hidden-line removal  A visualization technique in which all lines that are hidden 
behind other entities or surfaces from your viewpoint are clipped or removed, giving 
the image the appearance of a solid entity.

horizontal dimension  A linear dimension measuring a horizontal distance.

infinite line  A line extending infinitely in both directions.  

insertion point  The point where you place an entity into a particular space. A refer-
ence point by which an entity is inserted in a drawing. 

intersection  The point where two entities meet or cross.

isometric drawing  A drawing aligned with an isometric plane.

isometric plane  One of three planes representing the left, right, or top sides of an 
implied three-dimensional, orthogonal entity. Snap and grid points are aligned with 
the plane to constrain drawings.

layer  The computer equivalent of overlays used in manual drafting. A tool by which 
drawing components can be organized into related sets, such as plumbing, framing, 
and electrical systems of a house, each being drawn on its own layer.

layout  Similar to a sheet of paper, a representation of how a drawing will look when 
printed. 

layout viewport  A window in a Layout tab (paper space) that displays all or a por-
tion of a drawing’s model space entities. See also paper space and model space.

leader  A line leading from a feature of a drawing to an annotation.

limits  The user-defined boundary of a drawing, defined by its lower left and upper 
right corner coordinates. See also extents.

limits tolerance  Dimension text in which the measured dimension is replaced by 
the largest and smallest dimensions allowed, with the upper limit displayed above the 
lower limit. See also tolerance and variance tolerance.

linetype  The appearance of a line, defined as a solid (continuous) line or as a pattern 
of dashes, dots, and blank spaces.

lineweight  The width of a line, defined in millimeters or inches.

link  A technique for exchanging information between different programs whereby 
the target document maintains a pointer to the original source document. Any 
changes to the source document are reflected in all target documents containing links 
to the source. See also ActiveX and embed.

LISP  Acronym for List Processing Language, a computer language invented in the 
late 1950s by John McCarthy for use in artificial intelligence. Because it is inter-
preted rather than compiled, and is relatively straightforward, it is a convenient lan-
guage for users to write routines to extend the set of commands and functionality of 
IntelliCAD.
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lock  Prevents unauthorized access to drawing layers.

M direction  In a polygon mesh, the direction from the first to the second row. See 
also N direction.

macro  In menus and toolbars, several commands grouped together as one. Also 
Visual Basic for Applications code.

major axis  The longest distance across an ellipse, from one end to the other. See 
also minor axis.

marker blips  Temporary screen markers displayed in a drawing when you select a 
point. Also called blips.

MDI  Acronym for multiple-document interface. See multiple-document interface.

mesh  A set of connected polygon faces approximating a curved surface.

minor axis  The shortest distance across an ellipse, from one side to the other. See 
also major axis.

mirror  To create a reverse-image copy of selected entities by reflecting the entities 
symmetrically about a line or plane.

model space  The primary drawing area in which you create entities. See also paper 
space. 

multiple-document interface  The ability to view and work with different drawings 
simultaneously.

N direction  In a polygon mesh, the direction from the first to the second column. 
See also M direction.

named print style table  A collection of print styles that determine how entities 
print according to the print styles you create and assign to entities and layers. See 
print style table. 

named view  A saved view that can be recalled at a later time by specifying its name.

nested block  A block contained as part of the definition of another block. See also 
block.

nonassociative hatch  A hatch that is not associated with or linked to an entity.

oblique  Geometric lines or planes that are not parallel or perpendicular.

offset  See parallel.

OLE  Acronym for Object Linking and Embedding. See ActiveX.

ordinate dimension  A measurement of the horizontal (x-ordinate) or vertical (y-
ordinate) distance from an established reference base point or datum.
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origin  The intersection point of the coordinate system axes. In a Cartesian coordi-
nate system, the origin is the point at which the x-, y-, and z-axes intersect (the 0,0,0 
coordinate).

orthogonal  Having perpendicular slopes or tangents at the point of intersection.

orthogonal mode (ortho)  A drawing mode in which the entity creation is con-
strained to parallel the horizontal and vertical axes relative to the current snap angle.

orthographic projection  A drafting technique by which a three-dimensional item 
is described in two dimensions by showing it from various directions, most com-
monly front, top, and side views.

outside circle  An entity-selection method that selects entities falling completely 
outside a circular selection window. 

outside polygon  An entity-selection method that selects entities falling completely 
outside a polygon selection window. 

outside window  An entity-selection method that selects entities falling completely 
outside a rectangular selection window. 

pan  To shift the displayed view of a drawing without changing the magnification. 
See also zoom.

paper space  A two-dimensional work area similar to a sheet of paper, in which you 
can arrange different views of your model as layout viewports. See also model space.

parallel  Two or more coplanar lines that never intersect one another.

parallel dimension  See baseline dimension.

PDF  Acronym for Portable Document Format. PDF files can be viewed using 
Adobe® Acrobat Reader, which is free software that users can download; they can 
also be viewed, reviewed, and edited using Adobe® Acrobat.

perimeter  The distance around the boundary of an entity.

perpendicular  Entities at right angles to one another.

planar  Entities whose extents are situated entirely within a plane.

plane  Two-dimensional surface.

plan view  A view of the drawing from above, looking down the z-axis perpendicular 
to the xy plane of the current UCS.

point  A location in space specified by its x-, y-, and z-coordinates. A drawing entity 
consisting of a single x,y,z-coordinate location and represented by one of several 
symbols.        

point filter  See coordinate filter.

polar array  Multiple copies of selected entities in a circular pattern.



982 G L O S S A R Y
polar coordinates  Coordinates describing a two-dimensional point on a two-
dimensional plane based on the point’s distance from the origin and its angle in the 
plane. See also Cartesian coordinates, coordinates, cylindrical coordinates, rela-
tive coordinates, and spherical coordinates.

polygon  A closed single entity with three or more sides.  

polyline  A drawing entity composed of one or more connected line or arc segments 
treated as a single entity. 

print style  A collection of settings, including color, pen width, linetype, and line-
weight, that determine how a drawing looks when it is printed. See print style table.    

print style table  A collection of print styles that you can assign to the Model tab or 
to a Layout tab. Print style tables change how a drawing looks when you print it with-
out modifying the actual entities. See print style. 

profile  File that contains your preferred drawing environment settings. 

projection lines  See extension lines.

prompt box  A list of options displayed when a command or tool provides several 
choices.

Prompt History window  A window containing a history of the most recent com-
mands and prompts issued since you started the current session of IntelliCAD.

quadrant  One-fourth of a circle, arc, or ellipse entity. In the context of entity snaps, 
the option that snaps to points on a circle, arc, or ellipse at each quadrant.

radial dimension  A dimension that measures the radius of a circle or arc.

radian  A unit of angular measurement; 360 degrees equals 6.283185 or 2pi radians.

radius  The distance from the center of a circle or sphere to its periphery.

ray  A line that starts at a designated point and runs infinitely.

ray tracing  A visualization technique in which rays from imaginary light sources 
are traced as they refract off the surfaces of a model, determining where shadows fall 
and how reflections on shiny materials such as metal and glass appear.

rectangle  A four-sided, closed entity whereby opposite sides are equal in length.

rectangular array  Multiple copies of selected entities in a rectangular pattern con-
sisting of a specified number of columns and rows.

redo  To reverse the effect of previous undo commands. See also undo.

redraw  To quickly update or refresh the drawing screen display. See also regener-
ate.

regenerate  To update or refresh the drawing screen display by recalculating the 
drawing from its database. See also redraw. 
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region  A two-dimensional closed, surfaced, planar boundary.  

relative coordinates  Coordinates expressed in relation to a previous coordinate. 
See also absolute coordinates. 

render  A visualization technique in which all surfaces of a model are shaded as 
though they were illuminated from an imaginary light source located behind you as 
you face the screen. Rendered images are photo-realistic, having depth, shadow, 
reflection, and texture. 

revolve  Creating a three-dimensional surface entity by rotating a two-dimensional 
profile around an axis.

right-hand rule  A visual aid for remembering the relative directions of the positive 
x-, y-, and z-axes of a Cartesian coordinate system and the positive rotation direction 
about an axis.

rotate  To change the orientation of an entity, without modifying it, by repositioning 
it equidistant from, but at a new angle with respect to, a point or axis.

rotation angle  The angle by which an entity is displaced from its original location 
when rotating it about a point or axis.

rubber-band line  A ghosted image line that stretches dynamically on the screen 
with the movement of the cursor. The line extends between a fixed point and the cur-
sor position to provide dynamic feedback.

ruled surface  A three-dimensional polygon mesh that approximates a smooth sur-
face between two entities.

running entity snap  Setting an entity snap so that it continues for subsequent selec-
tions. See also entity snap and entity snap override.

scale  To resize an entity. To draw according to the proportions of an entity.

script  A set of commands stored in an ASCII script file and replayed in sequence by 
running the script.

SDS  Acronym for Solutions Development System, a C programming interface for 
developing specialized programs to run inside IntelliCAD.

segment  Any part of an entity bounded by two points.

selection set  One or more drawing entities selected on which one can operate as a 
single unit.

shade  To fill planar entities with solid colors for easier visualization.

snap angle  The angle around which the snap grid is rotated.

snap grid  An invisible grid that locks entity creation to a specified alignment and 
snap increment when Snap is enabled.

snap resolution  The spacing between points on the snap grid.
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snapshot  A raster representation of the current view of one’s drawing.

spherical coordinates  Coordinates describing a point in three-dimensional space 
based on its distance from the origin, its angle in the xy plane, and its angle up from 
the xy plane. See also Cartesian coordinates, coordinates, cylindrical coordinates, 
and polar coordinates.

spline  A curve generated along the path of three or more control points. The curve 
passes through the start point and endpoint, but does not necessarily pass through the 
intermediate control points. 

status bar  The bar at the bottom of the IntelliCAD window that displays informa-
tion about the selected command or tool as well as the cursor coordinates, the name of 
the current layer, mode settings, and other information about drawing settings.

surface model  A three-dimensional model consisting of both edges and the sur-
faces between those edges. See also wire-frame model.

surface of revolution  A three-dimensional polygon mesh that approximates the 
surface generated by rotating a two-dimensional profile around an axis.

SVG  An acronym for Scalable Vector Graphic, which is a file format for working 
with interactive graphics, including a Web development language.

system variable  A setting or value that stores operating environment and command 
information (such as the drawing limits or global linetype scale factor).

tabulated surface  A three-dimensional polygon mesh that approximates the sur-
face generated by extruding a curve along a vector. See also extrude.

tangent  A line that passes through a single point on a curve.

template  A drawing with preset layers, linetypes, and other settings (and entities) 
that can be used as the basis for creating a new drawing. Templates are saved with a 
.dwt file extension.

text style  A named, saved collection of format settings that determines the appear-
ance of text.  

thaw  To redisplay a layer that was frozen. See also freeze.

thickness  An entity’s depth, as measured along its z-axis. The distance an entity is 
extruded above or below its elevation. See also elevation and extrude.

through point  In creating a parallel entity, a point through which the new entity 
passes.

tolerance  Dimension text indicating how much the actual dimension of a manufac-
tured component can vary from the specified dimension. See also limits tolerance 
and variance tolerance.

tolerance command  A command that creates a feature-control frame used in 
mechanical geometric dimensioning and tolerancing.
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toolbar  A collection of tools arranged on a palette that can be moved and resized 
anywhere on the screen.

torus  A donut-shaped, three-dimensional entity.

transparent command  A command started while another command is already 
active. You can use a command transparently by preceding it with an apostrophe.

true color  Colors defined using 24-bit color. There are more than 16 million true 
colors from which you can choose.

UCS  Acronym for user coordinate system. See user coordinate system.

UCS icon  A user coordinate system icon that shows the orientation of the coordinate 
axes, the location of the coordinate system origin, and the viewing direction relative 
to the xy plane.

undo  To reverse the effect of previous commands. See also redo.

unit  See drawing unit.

unlock  Free access to layers in a drawing that would be otherwise locked, thus pro-
hibiting them from being viewed or edited by another user.

user coordinate system  A Cartesian coordinate system with origins and orienta-
tion defined by the user. See also World Coordinate System.

variance tolerance  Dimension text in which a plus/minus value is appended to the 
specified dimension to indicate how much the actual dimension of a manufactured 
component can vary from the specified dimension. See also limits tolerance and tol-
erance.

VBA  Acronym for Visual Basic for Applications, a macro programming language 
embedded in programs that allows the user to customize the program.

vector  A means of describing a displacement using magnitude and orientation. For 
example, you can create a line entity, or move an entity, by specifying an initial point, 
a direction, and a distance.

vertex  The point of intersection of the sides of an angle. The start points or end-
points of a line or arc segment in a polyline.

vertical dimension  A linear dimension measuring a vertical distance.

view  A representation of a drawing or portion of a drawing from a specific view-
point in three-dimensional space.

viewpoint  A location in three-dimensional space for viewing one’s drafting.

viewport  A window that displays all or a portion of a drawing’s model space entities 
while in model space on the Model tab. See also model space and paper space.             

viewport configuration  A named arrangement of windows that can be saved and 
restored.
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WCS  Acronym for World Coordinate System. See World Coordinate System.

wedge  A three-dimensional entity that resembles a box divided along one side from 
one corner to the opposite corner; for example, a doorstop or a ramp.

window circle  An entity-selection method that selects entities contained entirely 
within a circular selection window. 

window inside  An entity-selection method that selects entities contained entirely 
within a rectangular selection window. 

window polygon  An entity-selection method that selects entities contained entirely 
within a polygon selection window. 

wipeout  An entity that displays with the current background color, so the details 
behind it do not display or print.

wire-frame model  A three-dimensional model consisting of lines and curves that 
define the edges of a three-dimensional entity. See also surface model.

WMF  Acronym for Windows metafile, a format containing vector and color informa-
tion to render entities.

World Coordinate System  The fixed Cartesian coordinate system used as the basis 
for defining other coordinate systems. See also user coordinate system.

xref  See external reference.

zoom  To increase or decrease the magnification of the display of a drawing. See also 
pan.   
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Symbols
- (hyphen characters) 245, 620, 622
_ (underscore characters) 245, 620, 622
, (commas) 262
. (period characters) 263
.dwg files

creating 46
defined 977
exporting IntelliCAD files as 799–814
IntelliCAD compatibility with 3
opening 47
saving 108

.NET applications 946

.xls files 590
@ (at symbols) 446
& (ampersand character) 875
% (percent signs) 479, 480
° (degree symbols) 479, 480
± (plus or minus signs) 479, 480
< (angle brackets) 259, 261, 262
$ (dollar signs) 245, 620, 622

Numerics
0 layer 278
2D DWF files 803
2-dimensional drawings

2-dimensional coordinate systems 257
coordinate systems 254
defined 973
isometric drawings 84
point filters 263
polar coordinates 259

2-dimensional entities
See also 2-dimensional entity types; entities
arraying in columns or rows 430
extruding to create 3-dimensional entities 706–709

2-dimensional entity types
arcs 117
circles 113
construction lines 128
donuts 139
ellipses 121
elliptical arcs 122
freehand sketches 135

infinite lines 126
lines 112
planes 161
point entities 123
polygons 142
polylines 136
rays 125
rectangles and squares 140
splines 155

3D Array command or tool (3darray) 749, 750
3D DWF files 803
3D Mirror command or tool (mirror3d) 751
3D Rotate command or tool 748
3D solids 706
3Dconnexion input devices 953
3dfly command 698
3-dimensional coordinate systems 261

defined 973
specifying locations with 260

3-dimensional drawings
compared to isometric 2-dimensional drawings 84
coordinate system icons 255
coordinate systems 254, 260
defined 973
point filters 264
setting viewpoints 688–706
snapping to entity intersections 100–101
user coordinate systems 265
wire-frame and surface models 706

3-dimensional entities
3D solids 706
See also 3-dimensional entity types; entities
aligning 751–755
arraying copies of entities 749–750
creating planar surfaces 734
creating regions 733
editing 747–755, 756–766
hiding lines in drawings 767
mirroring 751
rotating entities 748
shading surfaces 772
thickness and elevation 706–711

3-dimensional entity types
boxes 719
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cones 721
cylinders 725
dishes 728
domes 728
edge-defined Coons surface patch meshes 718
extruded surface meshes 714
faces 711
pipes 731, 732
polyface meshes 713
pyramids 722
rectangular meshes 712
regions 733
revolved surface meshes 716–718
ruled surface meshes 714
spheres 726
surfaces 734
tori 729, 735, 737, 738, 739
wedges 720
wire-frame 767

3dwalk command 698
3-Point Arc tool 117
4K display issues 848

A
absolute coordinates

See also coordinate systems; user coordinate sys-
tems (UCS); World Coordinate System (WCS)

defined 973
specifying locations with 257, 260

absolute size of point entities 123
access keys for commands 875
accuracy

drawing unit display 60
IntelliCAD compared to manual drafting 7–8
precise point locations with entity snaps 376

ACIS solids
boxes 719
combining 740, 741
cones 721
cylinders 725
defined 973
dishes 728
domes 729
extruding 735, 737, 738, 739
intersecting 742
pyramids 723
regions 733

revolving 736
spheres 727
subtracting 741
tetrahedrons 723
tori 730
wedges 720

acisin command 790, 791, 792, 793, 801
acisout command 806
ActiveX

defined 973
dragging drawings into other applications 799
editing linked or embedded objects 785, 797
linking drawings to other applications 798
linking objects to drawings 783–785
sharing drawing information and data 11

acute angles 973
Add Leader Lines command or tool (aimmleaderadd) 

196
Add To Set selection method 387
adding

aliases for commands 905
areas of entities 374
commands to menus 869, 872, 873, 874, 886, 887, 

894, 895, 901, 905, 938
commands to ribbon 881, 884, 885
commands to the ribbon 879
double-click actions for commands 909
entities to selection sets 386
hyperlinks 816
image tile menus for commands 912, 913
keyboard shortcuts for commands 899
layouts for printing 615
tools to toolbars 893

ADS programs 3, 4, 944
ADT files 50
advanced experience level

changing level 3, 36, 824
aliases for commands

creating 905
defined 973
deleting 907

align command 752, 753, 754
Align command or tool (align) 752, 753, 754
Align Multileader command or tool (mleaderalign) 197
Aligned command or tool (dimaligned) 504
aligned dimensions

creating 504
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defined 973
illustrated 500

aligning coordinate systems
with current view 267
with entities 265

aligning entities 751
aligning marker blocks on entities 370, 372
aligning multileaders 197
aligning text

on dimension lines 530
options 532

alternate dimension units, controlling 536
alternate font

setting the default file 830
alternate text editor 493
ambient light 773
American National Standards Institute (ANSI) defined 

973
American Standard Code for Information Interchange 

(ASCII) defined 973
ampersand characters 875
angle brackets 259, 261, 262
angle drawing method

construction lines 128
infinite lines 126, 130
rays 125

angles
angle direction and base settings 60
calculating angle between points 376–378
defined 973
displaying instead of coordinates 256
drawing unit settings 60, 977
specifying for arcs 117, 119, 145
specifying for chamfering 460
specifying for dimension lines 507
specifying for grid 83
specifying for lines 112
specifying for rotated entities 432–436
specifying for text styles 319
specifying locations by 259
specifying text angle in text styles 317, 322, 326, 

332, 340, 361
spherical and cylindrical coordinates 261
zero angle settings 60

Angular command or tool (dimangular) 507
angular dimensions 507, 508

creating 507

defined 973
formatting dimension unit display 534

angular drawing units 973
angularity tolerance symbol 538
annotation scaling 239

adding the current scale to entities 239
assigning scales automatically 67, 239
blocks 349
dimension styles 532
linetype scaling setup 55
modifying scales assigned to entities 240
purging the scales list 66
setting up 64
styles (dimension, text, multileader) 66
text styles 319, 474
turning on an off 238

annotations
adding in paper space 616
adding to geographic maps 609
creating as dimension text 512
defined 973

ANSI character sets 495
aperture for entity snaps 92
apostrophes 37
app command modifier 37, 100, 101
Apparent Intersection Snap command (apparent) 100
appending scripts 941
appload command 944, 945, 946, 947, 951
Arc command (arc) 117
Arc command or tool (dimarc) 508
arc dimensions 508

creating 508
Arc Start-Center-Angle tool 117
Arc Start-Center-End tool 118
architectural

drawing scale ratios 62
drawing units 58

arcs
adding lines to 112
angle dimensions for 507
center marks 502
converting donuts into arc entities 161
converting polyline segments to arcs 144
converting to circles 116
defined 973
diameter dimensions for 509
direction of 122
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drawing methods 117
elliptical arcs 122
extending to boundaries 438
joining 446, 456–457
measured dimensions for 508
measuring and marking off intervals 368–372
moving with grips 431
polyline drawing methods 146
radius dimensions for 509

Area command or tool (area) 372, 973
calculating areas 372

ARG files (profiles) 854
arranging windows 242

See also views and viewports
Array command or tool (array) 430
arraying entities 423, 424, 749, 973
arrows and arrowheads 501, 528–532
Artisan command or tool (artisan) 776
Artisan Renderer

creating a rendered image 776
overview 776
synchronize with IntelliCAD 777

Artisan Sync command or tool (artisan-sync) 777
ASCII

AutoCAD files. See DXF files
defined 973
text files 567

assembling master drawings 571
assigning aliases to commands 903, 907
associative dimensions 501
at symbol 446
Attach Drawing tool (Blocks toolbar) 346
attaching

attributes to blocks 565
external references 572
raster images 596

attachment points 470
See also insertion points

attributes
after exploding blocks 448
attaching to blocks 565
data in 546
defined 345, 974
definitions 563–565
editing definitions 565
extracting values 567–568
fixed or variable values 563

flags 563
invisible data 563
names 974
overview 563–564
snapping to insertion points 98
text 974
updating values for 566, 570
visible or hidden 563

Audio Note command or tool (audionote) 935, 936, 937
audio note icon 936
audio notes

attaching 935
deleting 937
overview 935
playing 937
selecting 936

Audit command (audit) 50
AutoCAD

command name compatibility 903
exporting IntelliCAD files as AutoCAD files 799–

814
font compatibility 320
IntelliCAD compatibility 3, 961
loading .cui files 879
loading menu files 869, 917
script files 939

AutoCAD Development System programs (ADS) 3, 4, 
944

AutoComplete command 31
AutoLISP programs 3, 4, 946–947
automatically

assigning annotation scales 67
changing code pages 495
loading .NET applications 951
loading LISP routines 951, 952
loading profiles 851
loading SDS applications 952
loading TX/IRX applications 951
publishing drawings 684
reloading external references 577
saving drawings 824

automating IntelliCAD functions 824
autopublish command 684
AutoSave 824
axes

in coordinate systems 254, 257
in ellipse drawing methods 121
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in elliptical arc drawing methods 122
rotating entities around 748

B
background 773, 774
background color 840
Backgrounds command or tool (backgrounds) 775
backward text 474
base 773
base points

See also origin points
defined 974
for copying entities 416
for entities to be moved 430
for scaling entities 437
for stretching entities 436

baseline
of text 974
offset in dimensions 525
text alignment 477

Baseline command or tool (dimbaseline) 505
baseline dimensions

adding to linear dimensions 502
angular baseline dimensions 507
creating 505
defined 974
illustrated 500

basing drawings on templates 46–47
basing layouts on templates 620
beginner experience level

changing level 3, 36, 824
explained 3

best fit for dimension text and arrows 532
beveled edges on entities 460–464
binding external references 579, 974
bisect drawing method (infinite lines or rays) 125
BL notation in extracted attribute file fields 567
black-and-white

printing 653
tool icons 873, 885, 894

blipmode command 251
blips

defined 974
displaying current settings 380
marker blips 251, 980
turning on or off 251

block command 548, 557, 558

Block command (IntelliCAD Explorer) 348, 357
Block command or tool (ddinsert) 554
Block toolbar 346
blocks

See also Xref Manager command or tool (xrm)
annotative 349
as interval markers 368
attributes 546–563
Blocks list in IntelliCAD Explorer 345
BYBLOCK property 52–54
clipping 580
copying to other drawings 273
creating 348, 547–554
creating multileaders 194
definitions 563–565
deleting in IntelliCAD Explorer 274
displaying properties 379
editing definitions 565, 566, 570
entity storage in files 571
exploding 448, 554, 560
external references 571–582
inserting 350, 548, 550–552, 554–555
inserting drawings as 351
insertion points 98, 346, 351, 548, 550–552, 554–

555
instances of 554, 557, 558
listing 345
multiple instances of 546, 550, 551, 552
names in extracted attribute file fields 567
nesting 546
number of occurrences 347
overview 345, 546
redefining and updating 546, 557, 558
reusing blocks and drawings 10
rotation angle and scale 552, 554, 555
saving 547–554
saving as drawing files 352, 550, 551, 552
search path for files 829
selection filter 392
snapping to insertion points 98

BMP files 873, 885, 894
bodies

slicing and sectioning 757
borders on drawings 616
borders on images 601
borders on viewports

as available in each view 8
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setting as invisible 624
bottom-aligned text 477
boundaries

extending entities to 438–441
setting for paragraph text 470
trimming or clipping entities to 441–443
xref clipping 580

Box command or tool (box) 719
Break at Point command or tool (breakatpoint) 446
Break command or tool (break) 445
breaking entities into pieces

exploding blocks 560
exploding into components 448
splitting into two parts 444

brightness of images 598
B-Spline curves. See splines
buttons. See toolbars and tools
BYBLOCK property

after exploding 448
colors 52–53
creating blocks from entities on different layers 546
defined 974
linetypes 53–54, 306–308
lineweights 55
print styles 57

BYLAYER property
colors 294
creating blocks from entities on different layers 546
defined 974
linetypes 53, 295–319
lineweights 55

C
C character

closing entities 259
in extracted attribute file fields 567

CAD defined 974
CadMouse 953
calculating areas 372
calculations

area and perimeter 372
distances and angles 376–378
in IntelliCAD and manual drafting 11
scale factors and printed size 62–67

callout lines. See leaders in dimensions
Cartesian coordinates

See also cylindrical coordinates; polar coordinates; 

spherical coordinates
2-dimensional coordinate systems 257
3-dimensional coordinate systems 260
absolute and relative coordinates 257
defined 974
overview 7
understanding coordinate systems 254, 256

Cascade command 242, 275
CDF files 567
center command 95
center lines

defined 974
for circles and arcs 502

center marks
defined 974
for circles and arcs 502
formatting 525–530

center points of entities
arcs 145
circles 113
dishes 728
domes 728
ellipses 121
elliptical arcs 122
polygons 142
snapping to 91, 94, 95
spheres 725

center points of views 236
Center Snap command (center) 95, 99
center-aligned text 477
Center-Diameter circle method 113
Center-Radius circle method 113
chain dimensions. See continued dimensions
Chamfer command or tool (chamfer) 464
changing

workspaces 34
character sets for text display 495
character string fields in extracted attribute file fields 567
check spelling 488
checking

damaged files 50
damaged files when opening 827
solids 766

chords in arcs 117, 145, 975
Circle Center-Radius tool 113, 114, 115
Circle command (circle) 113
circle diameter symbol 479, 480
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Circle Radius-Tangent tool 115, 116
circles

See also donuts 977
center marks 502
creating from arcs 116
diameter dimensions 510
measuring and marking off intervals 368
moving with grips 431
radius dimensions 510

circular
arrays of entities. See polar arrays of entities
runout tolerance symbol 538

circularity tolerance symbol 538
circumferences, defined 975
cleaning solids 766
Clear Entity Snaps command or tool (none) 92, 102
Clipboard

copying entities into other drawings 418
embedding objects into drawings 782
embedding objects into other applications 799
linking drawings into other applications 798

clipping
entities 441
external references 580
layout viewports 628
raster images 602

Clone command or tool (clone or addselected) 420
closed (entities), defined 975
closing

polylines 144, 454
prompt boxes 33
splines 156, 157

coaxiality tolerance symbol 538
codepage command 495
Collect Multileader command or tool (mleadercollect) 

197
collecting multileaders 197
color books

creating 75, 78
current entity color 52
loading 79
selecting a color 74

Color dialog box 71, 73, 74
color-dependent print style tables

changing a drawing’s table type 657
comparing with named tables 650
converting to named 658

copying, renaming, deleting 657
creating 653
default settings 857
defined 649
modifying 654

colors
applying shading 772–775
changing in entity properties 406
color books 74
creating blocks from entities on different layers 546
current settings 380
default layer color 277
dimension lines 526
dimension text 531
displaying information about entities 378
displaying information about xrefs and blocks 379
grip color 402
index colors 71
layer settings 275, 294–295
mapping during printing 649
multiline text 471
overriding layer color 295
print styles 654
selecting entities by color 387
solid faces 763
working with 71

columns of entities. See arraying entities; rectangular ar-
rays of entities

combining entities
chamfering and filleting 460
finding area of combined entities 374–376
joining 446, 456
lines and arcs in polylines 145
solids 740, 743, 755

combining zooming and panning actions 236
Comma Delimited Format files 567, 975
command bar

Command Bar command 30
defined 975
displaying or hiding 30
moving 23, 30
navigating with arrow keys 833
starting commands with 36
using AutoComplete 31

command strings for keyboard shortcuts 899
commands

active commands 35
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adding to menus 872, 873, 874, 886, 887, 894, 895, 
901, 905

adding to ribbon 881, 884, 885
aliases 903–939
AutoCAD command name compatibility 903
deleting from menus 877, 878
deleting from ribbon 891
displaying shortcut menus 23
double-click actions 907–911
ending 35
experience levels 824, 875, 888, 896
information in status bar 32
keyboard shortcuts for 39, 899–903
loading custom programs 947
modifying commands 37
mouse shortcuts for 39
nesting several commands 37
prompt boxes 33
renaming 877, 890, 898
repeating 36
Script Recorder 40
starting 36
starting with double-click actions 910
tracking history 38, 833

commenting
scripts 941

company names on printouts 857
complex entities

See also types of entities (polylines; rectangles; do-
nuts; and so on)

defined 139
exploding into components 448

complex hatch patterns 212
complex linetypes (IntelliCAD Explorer) 311
composite solids 740, 743, 755
composite tolerances 537, 539
compressing or expanding text 474, 477
concentric entities. See donuts; tori
concentricity tolerance symbol 538
Cone command or tool (cone) 721, 722
cones 721, 975
config command 824
configuring

code pages 495
IntelliCAD 821
layouts 615
print settings 631

connecting entities
chamfering and filleting 460
joining 446, 456

constraining drawing
to drawing limits 69
to right angles 85, 86

construction lines
drawing 128

construction lines. See infinite lines
construction planes. See user coordinate systems (UCS)
contiguous (entities), defined 975
Continue command or tool (dimcontinue) 506
continued dimensions

adding to linear dimensions 502
angular continued dimensions 507
creating 507
defined 975
illustrated 500

CONTINUOUS linetype 53, 55, 306
contrast of images 598
control codes for text 479, 480
control points 155
control vertices 975
convertctb command 659
converting

2-dimensional entities to three dimensions 706
code pages 495
color-dependent print style tables 658
donut sides to arc entities 161
drawing’s print style table type 657
entities into components 448
entities to other linetypes before deleting 274
entities to other text styles before deleting 274
entities to polylines 454
line text to paragraph text 484
plane sides to line entities 162
polygon sides to line entities 144
polyline segments to curves 455–456
polyline segments to entities 144
rectangle sides to line entities 140

converting arcs to circles 116
convertpstyles command 657, 658
Coons Surface command or tool (edgesurf) 718
Coons surface patch meshes 718, 975
coordinate filters (point filters) 263, 975
coordinate systems

2-dimensional coordinate systems 257
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3-dimensional coordinate systems 260
absolute and relative coordinates 257
Cartesian coordinates 7, 254, 257, 974
copying to use in other drawings 273
cylindrical coordinates 262, 976
defined 975
deleting in IntelliCAD Explorer 274
icons for 255
listing 342–343
point filters 263, 265
polar coordinates 256, 259, 982
preset user coordinate systems 267
right-hand rule 260
spherical coordinates 261, 984
user coordinate systems 255, 265, 628
World Coordinate System 255, 267, 342, 705, 986

Coordinate Systems list in IntelliCAD Explorer 266, 342
coordinates

See also coordinate systems
defined 975
displaying for entities 378
finding point coordinates 257
in ordinate dimensions 511
of drawing limits 69, 256
viewpoints in three-dimensional drawings 688

coplanar (entities), defined 975
Copy command or tool (copy or copyclip) 416, 424
Copy command or tool (IntelliCAD Explorer) 273
copyclip command 418
copying

layers to other drawings 273
layouts 620
print style tables 657
profiles 853
ribbon items 890, 898, 902, 906
settings to other drawings 273
solid faces 762
supported formats 862
text in Prompt History window 38

copying drawings
dragging into other applications 799
with external references for distribution 579

copying entities 415–430
arrays of entities 423, 424, 749–750
mirroring entities 423, 751
parallel copies 421–423
to other drawings 246, 418

to other spaces 419, 431
copying objects

embedding IntelliCAD data into other applications 
796–798

embedding objects into drawings 782
linking drawings to other applications 798
linking objects to drawings 783

corner points
of planes 161
of rectangles 140

correcting mistakes 40
Create Block command or tool (block) 548, 557, 558
Create Snapshot dialog box 780
creating

audio notes 935
blocks 351
color books 75, 78
files in different formats 674, 800
hyperlinks 816
layout viewports 623
named views 690
print style tables 653
printed drawings 613
profiles 850
workspaces 34

cropping
entities (trimming) 441, 460–464
external references 580
raster images 602

crosshairs
defined 975
entity snap target box 91

crosshatching 212, 975
See also hatch patterns and hatching

Crossing Circle selection method 387, 976
Crossing Polygon selection method 387, 436, 976
Crossing Window selection method 387, 389, 436, 976
CTB files

assigning 652
changing a drawing’s table type 657
compared with STB files 650
converting to STB files 658
creating 653
default settings 857
defined 649
modifying 654

cubes 719–720, 976
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CUI files (ribbon files) 879
current annotation scale

customizing the scales list 64
setting with automatic annotation scaling 67

current editing session timer 382
current settings

layers 288
linetypes 307
lineweights 55
loading profiles 851
materials 364
multileader style 199
multiline style 151
print styles 57
text styles 318, 323, 332, 341
three-dimensional elevation and thickness 708
tools 272
user coordinate systems 344

Current tool (IntelliCAD Explorer) 318, 323, 326, 332, 
341, 344

cursors
coordinate information in status bar 32
current position in coordinate systems 256
defined 976
entity snap cursor decoration 860
fly-over snap cursors 103, 860
magnifying glass cursor 233

curves. See also arcs; circles; ellipses; splines
curving polyline segments 455
Customize UI command (cui)

customizing aliases 903–907
customizing double-click actions 907–911
customizing keyboard shortcuts 899–903
customizing menus 869
customizing ribbon 879–891
customizing toolbars and tools 891, 899

customizing
IntelliCAD 41
Quick Access toolbar 24, 26, 27, 864, 865, 867
ribbon 24
text editor 493
user interface using workspaces 33

customizing IntelliCAD options
aliases 903–907
coordinate systems 265
double-click actions 907–911
hatch patterns 212

keyboard shortcuts 899–903
menus 869
print settings 631
program settings 822–869
ribbon 879–891
running custom programs 944–947
scripts for 939, 944
templates 46
toolbars and tools 23, 891

Cut command or tool (cutclip) 418, 419, 431
cutting entities

moving to other drawings 246
pasting in other drawings 418

Cylinder command or tool (cylinder) 725, 726
cylinders 454, 725
cylindrical coordinates 262, 976

See also polar coordinates; spherical coordinates 
257

D
data

attaching to blocks. See attributes
attaching to drawings 11

data extraction 383
data fields for extracted attribute files 567–568
data links 590
databases

for drawing data 228
using information in drawings 11

datalink command 590
datalinkupdate command 595
dates

date stamps on printouts 857
tracking time spent on drawings 382

ddattdef command 563
ddatte command 566, 570
ddattext command 568
ddedit command 481, 488, 565
ddgrips command 402
ddinsert command 554
decimal

degrees in angular units 60
drawing units 60

decurving polyline segments 455
default profile 852
defaults

arc direction 122
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code pages 495
colors 277
defined 976
drawing environment (profiles) 852
elevation 706
entity colors 52
icad.dwt template 22
layers 274
linetypes 53, 277, 295
lineweights 55, 251, 297
print style table settings 857
print styles 57, 299
text styles 474
thickness 706
values for attributes 563

Define Attributes
command or tool (ddattdef) 563
dialog box 563

defining
complex linetypes 311–314
dimension styles 523
keyboard shortcuts 899
linetypes 309–319
lineweights 55, 251
print settings 631
text styles 320
user coordinate systems 265, 343

definition points 502
degree symbols 479, 480
Delete command or tool (delete) 415
Delete command or tool (IntelliCAD Explorer) 274
deleting

aliases 907
audio notes 937
clipping boundary 581
commands from menus 877, 878
commands from ribbon 891
dimension styles 525
double-click actions 911
elements in IntelliCAD Explorer 274–275
entities 415
external references 576
freehand sketches 136
hyperlinks 816
images 605
layouts 622
lines in 3-dimensional entities 767–773

multileader styles 200
multiline styles 152
page setups 635
print style tables 657
profiles 853
segments of polylines 144
settings 274
solid faces 762
xref clipping 582

delta distances, calculating 376
density of mesh surfaces 714, 715, 717, 718
descenders on text characters 477
deselecting entities 401
Design Web Format

exporting 585, 786, 803, 804
importing 585, 786
opening files 47

detaching external references 976
See also Xref Manager command or tool (xrm)

Details tool (Block toolbar) 346
dgnattach command 587
Diameter command or tool (dimdiameter) 510
diameter dimensions

creating 510
defined 976
illustrated 500

diameters
circles 510
donuts 159

diametral dimensions 509
DIESEL programs 950
dimaligned command 504
dimangular command 507
dimarc command 508, 509
dimbaseline command 505
dimcontinue command 506
dimdiameter command 510
dimedit command

obliquing dimensions 519
replacing dimension text with new text 521
restoring dimension text to home position 521, 522
rotating dimension text 520

Dimension Break command or tool (dimbreak) 517, 518
Dimension Break command or tool (dimspace) 516
dimension lines 530

See also dimension text; dimensions and dimension 
styles; extension line



998
aligning text on 530
defined 500, 976

Dimension Style command 523
dimension styles

annotative 532
Dimension Styles (IntelliCAD Explorer) 327
Dimension Styles command or tool (setdim)

arrows and arrowheads 528, 533
baseline dimension offset 505
creating, renaming, or deleting dimension styles 523
dimension line colors 526
formatting and positioning dimension text 530, 532
rounding off numbers 534

Dimension Styles dialog box
Arrows tab 528–532
Format tab 532
Lines tab 525
Text tab 530
Units tab 534–538

dimension text
aligning on lines 530
defined 516, 976
formatting and positioning text 521, 522, 525, 530, 

532–534
overview 501
replacing dimension text with new text 521
restoring dimension text to home position 521

dimension tolerance
controlling 541

dimension units, alternate 536
dimensions

associative 501
exploded 501
non-associative 501

dimensions and dimension styles
See also dimension text
aligned dimensions 504
angular dimensions 507–508
arc dimensions 508–509
arrows and arrowheads 528
baseline dimensions 505
breaking 517, 518
creating dimensions 502–516
creating or deleting styles 523
diameter dimensions 510
dimension styles defined 500, 523–538
dimension variables 523, 976

dimensions defined 976
extension lines 501
in paper space 513
leaders and annotations 502, 512
line colors 526
line formats 525
linear dimensions 502–507
obliquing 519
ordinate dimensions 511
overview 500–502
radius dimensions 510
renaming styles 524
spacing dimension lines 516
types of dimensions 500
units and rounding 534–538

dimleader command 199, 512, 515
dimlinear command 503
dimordinate command 511
dimradius command 510
dimtedit command 521
directory paths for files 829
Dish command or tool (dish) 728, 976
disk space requirements for IntelliCAD 20
displacement points

defined 977
for copying entities 416
for moving entities 430
for stretching entities 436

displaying
annotative entities 238
audio note icons 936
command bar 30
commands with AutoComplete

turning on
AutoComplete at the command

bar 31
drawing information 378
embedded files as icons 783
entire drawings 237
geographic locations 607
layers 289–292
lineweights 251
lists of text styles 475
memory-intensive display elements 248
menus 28
Model and Layout tabs 619, 837
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multiple views of drawings. See also views and 
viewports 242

online Help 42
point entities 123
Prompt History window 38
properties information 379
reference grid 79
ribbon 24, 26
rotated views 231, 694
scroll bars 837
shortcut menus 23
snapshots 781
text 495
text as boxes 248
toolbars 29
ToolTips 29
warning messages 827
xref clipping boundaries 582

Distance command or tool (distance) 376
Distance-Angle chamfer method 460–462
Distance-Distance chamfer method 460
distances

calculating between points 376
defined 977
displaying instead of coordinates 256
specifying in chamfering 460
specifying locations by 259
spherical and cylindrical coordinates 261, 262

distant lighting 773
Divide command (divide) 368, 371
dividing display into multiple views. See views and view-

ports
dividing entities into equal segments 368
docking

defined 977
toolbars and command bar 23–32

dollar signs 245, 620, 622
Dome command or tool (dome) 729, 977
Donut command or tool (donut) 159
donuts

3-dimensional donuts (tori) 729, 735, 737, 738, 739
converting sides to arc entities 161
defined 977
drawing 159
editing 454
filled or outlined 161

dots

in linetypes 310
point entities 123

double-click actions 907
doughnuts. See donuts 977
draft quality images 600
drafting manually compared to IntelliCAD 5–13
dragging

drawings from the Internet 817
drawings into other applications 799
moving entities with grips 431
new tools to toolbars 893

Draw Freehand tool 135
Draw Order command or tool (draworder) 433, 434
Draw Orthogonal tool 85, 86, 88
Draw Point command (point) 123
Draw toolbar 29
drawing code page 495
drawing entities

3-dimensional faces 711
arcs 117
boxes 719
cylinders 725
dishes 728
domes 729
donuts 159
edge-defined Coons surface patch meshes 718
ellipses 121
elliptical arcs 122
extruded surface meshes 715
freehand sketching 135
hatching entities 212
helices 158, 732
lines 112
multilines 147
pipes 731
planes 161
point entities 123
polyface meshes 713
polygons 142
polylines 144
pyramids 722
rays 125
rectangles 140
rectangular meshes 712
rendering 773, 776
revision clouds 190
revolved surface meshes 716
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ruled surface meshes 714
shading 772, 983
spheres 727
splines 155
squares 140
tori 730
traces 154
wedges 720
wipeouts 187

drawing environment settings 849–854
Drawing Exchange Format files 567, 799–814, 977
Drawing Settings command or tool (dsettings)

Blips display 251
coordinate display in status bar 256
drawing limits 68–79
drawing units 58–62
elevation and thickness settings 708
entity snap target box 91
freehand sketch settings 135
grid rotation 83
grid settings 79–85
grip display options 402
highlighting entities 405
highlighting settings 250
isometric snap and grid 84
linetype scale settings 54–58
linetype settings 53
lineweight settings 55
mesh surface settings 714, 715
orthogonal setting 85
point entity display 123
polar tracking setting 86, 88, 105, 106
Quick Text feature 249
shaded surface settings 772
snap angle settings 83
snap spacing settings 82
text height settings 67

Drawing Settings dialog box - 3D Settings tab
elevation and thickness settings 708
mesh surface settings 715
shaded surface settings 772

Drawing Settings dialog box - Coordinate Input tab
drawing limits 69, 256
entity snap settings 92
entity snap target box 92
grid rotation 83
grid settings 79

isometric snap and grid 84
mesh surface settings 714
orthogonal setting 85, 86
snap angle settings 83
snap spacing settings 82

Drawing Settings dialog box - Display tab
coordinate display in status bar 256
grip display options 402
highlighting entities 405
highlighting settings 250
Marker Blips display 251
Quick Text feature 250

Drawing Settings dialog box - Drawing Units tab 58
Drawing Settings dialog box - Dynamic Input tab 88
Drawing Settings dialog box - Entity Creation tab

entity color settings 52
freehand sketch settings 136
linetype scale settings 54
linetype settings 53
lineweight settings 56
point entity display 123
print style settings 57
text height settings 67–68

Drawing Settings dialog box - Entity Modification tab 
460–462

Drawing Status command (status) 380
drawing units

angular units 60–62
linear units 58
real-world units and 58
relationship to printed units 637
rounding in dimension display 534
scale factors and 62
text height and 67

drawings
See also 2-dimensional drawings; 3-dimensional 

drawings
3-dimensional and isometric drawings compared 84
adding audio notes 935
annotations, borders, and title blocks 616
blocks 351, 352, 554–563
code pages 495
copying entities to other drawings 246, 418
copying settings to other drawings 273
creating new drawings 22, 46
damaged files 49
default template 830
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displaying entire drawings 237
displaying information about 378–382
drawing limits 63, 68, 237, 380, 977
drawing units 58
embedding or linking into other applications 796–

799
etransmitting 809
exporting 799
extents 125, 229, 237, 978
external references 10, 345, 354, 357, 571
grid settings 79–82
isometric snap and grid 84
layer settings 51
layout viewports 622
linetype settings 53, 55
master and component drawings 571
moving around in 229
multiple drawings 3, 246
opening 47
orientation 636
orthogonal setting 85, 86, 88
paper size 636
passwords 109
printing 662, 674
recently used file list 847
redrawing and regenerating 228
reusability 5, 8, 10, 273
saving 43
scale factors 62–67
search path for files 829
sending through e-mail 814
snap settings 91
tracking time spent on drawings 382
views 233
writing sketches into drawings 135

drivers for printers 637
dsettings command

dimension styles 534
drawing limits 68
drawing units 60
elevation and thickness 707–709
entity snap target box 92
freehand sketches 136
grid settings 80, 83
highlighting 405
isometric snap and grid 84
linetype scale 54

linetypes 53
lineweights 56
orthogonal mode 85, 86, 88, 105, 106
point entity display 123
print styles 57
shaded surfaces 772
snap angles 83
snap spacing 82
text height 67

dtext command
adding text to drawings 468
setting text style 475
specifying alignment 469, 477, 478, 479, 480, 484

dual monitors 848
duplicating entities 415
DWF files

defined 977
exporting 803, 804
importing 585, 786
opening 47

dwfattach command 586
DWG format

supported copy formats 862
DWGCODEPAGE 495
DWT files

defined 977
importing 786
opening 47
saving 109

DXF files 567, 585, 786, 787, 806, 977
defined 977

DXX files 567
dynamic

panning 231
zooming 235

dynamic input, turning on 88
Dynamic View Control

command or tool (viewctl) 699
dialog box 699

dynamically rotating viewpoints in 3-dimensional draw-
ings 699

E
edgesurf command 718
Edit Attributes

command or tool (ddatte) 566, 570
Edit Block Attributes
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dialog box 566, 570
Edit Dimension Text command or tool (dimedit) 521
Edit Length command or tool (editlen) 443
Edit Polyline command or tool (editpline)

curving and decurving 455
joining 456
moving polyline vertices 458
opening and closing 454
tapering polyline segments 459
width and tapering 457

Edit Text command or tool (ddedit)
changing text properties 481
editing attribute definitions 565
editing text 481

editing
color book files 75, 78
layout viewports 628
linked or embedded objects 785
polylines 454–459
print style tables 654
settings, single-click (IntelliCAD Explorer) 319
sheet lists 677
VBA programs 950

editing drawings
blocks 348
embedded IntelliCAD objects in other applications 

797
in model space 623
IntelliCAD compared to manual drafting 11
keyboard shortcuts 899
layers 273, 274, 277, 288, 294
linetypes 296, 304, 308, 309
lineweights 297, 298
linking objects to drawings 783
materials 364
print styles 299, 300
text styles 320–342, 474
user coordinate systems 333, 342
views 335

editing entities
3-dimensional entities 747–755, 756–766
aligning 751–755
arraying 423, 424, 749, 750
attribute definitions 565
breaking and joining 444–447, 456
chamfering and filleting 460
changing properties 406

copying and pasting to other drawings 415
curving and decurving 455
cutting to Clipboard 418, 419, 431
deleting 414, 415
dividing 371
editing length 443
elevation and thickness settings 709
exploding into components 448, 560
extending to boundaries 438
grouping 450–453
in model space 623
measuring 369
mirroring 423, 751
moving 430
moving polyline vertices 458
offset entities 421
polylines 454
rotating 432, 748
scaling 437
selecting before editing 386
stretching 436
tapering polyline segments 457, 459
trimming 441
vertices 458–459
width of polylines 457
with grips 401

editing text
alignment settings 477
alternate text editor 493
changing character sets 495
changing text properties 481
editing attribute definitions 565
find and replace 482
formatting 481
moving dimension text 521
replacing dimension text with new text 521
restoring dimension text to home position 521
rotating dimension text 520
spelling 488
text style settings 474
unicode characters 494

editlen command 443
editpline command

curving and decurving 455
joining 456
moving polyline vertices 458
opening and closing 454



1003
tapering polyline segments 457, 459
width 457

elapsed-time timer 382
electronically mailing files 814
elements pane in IntelliCAD Explorer 271, 272
Elevation command or tool (elev) 707
elevation in 3-dimensional entities 706

defined 977
entering coordinates 264
setting default elevation 707, 708

Ellipse Axis-Axis tool 121
Ellipse command (ellipse) 121
ellipses

drawing methods 121
moving with grips 431

Elliptical Arc Axis-Axis tool 122
Elliptical Arc command (ellipse) 122
e-mailing files 814
embedding

See also ActiveX; linking
defined 977
editing embedded objects 785, 797
IntelliCAD objects into other applications 796
objects into IntelliCAD drawings 782–785

EMF files
defined 977
exporting IntelliCAD files as 799
snapshot files 780

end arrows 528
ending

commands 35
points for moving entities. See displacement points
script recording 940

Endpoint Snap command (endpoint) 93
endpoints of entities

defined 977
line entities 112
methods of drawing arcs 117, 145
snapping to 91, 93

engineering drawing
scale ratios 62
units 60

Enhanced Metafiles. See EMF files
enlarging or reducing view of drawings 233
entities

See also types of entities (lines; rays; arcs; and so on) 
977

3-dimensional entities 706–718
area and perimeter 372
arraying copies of entities 423, 424, 749
attaching audio notes 935
attributes 563–568
blocks 345, 348, 546–563
breaking and joining 444, 456
chamfering and filleting 460
color settings 294
complex entities 139
copying or duplicating 415
defined 977
deleting 414, 415
displaying information about 378
editing in viewports 623
elevation and thickness 706
embedding into other applications 796
grips 403–406
linetypes 295
lineweights 297
measuring and marking off intervals 368
moving and rotating 430–436, 747
on deleted layers 274
polylines 454
print styles 299
printing 613
properties 406
resizing 436–443
selecting 289, 386, 502, 503
simple entities 144
text as 470
viewing in 3D drawings 688–706
zooming 234

Entity Data defined 977
Entity Properties dialog box

changing entity properties 412
editing attribute definitions 565
elevation and thickness settings 708
overriding layer color 295
overriding layer linetype 296
overriding layer lineweight 297
overriding layer print style 299

entity selection methods 387
entity snap

See also entity snap tools
angle and base point 83
aperture 92
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command modifiers 37
controlling separately in multiple views 242
current settings 92, 380
defined 978
definition point locations 502
finding point coordinates with 257, 376
fly-over snapping 103, 860, 862
isometric snap and grid 84
model space from paper space 618
one-time entity snaps 37, 91
origin 83
override 978
overview 7
positioning ordinate points 511
running entity snaps 91
snap resolution defined 983
spacing 82
status bar information 32, 92
target box 91–92
turning off settings 102

entity snap tools
Apparent Intersection Snap 100
Center Snap 92, 95
Clear Entity Snaps 92, 102
Endpoint Snap 92, 93
Extension Snap 99
illustrated 92
Insertion Node Snap 92
Insertion Point Snap 98
Intersection Snap 92
Midpoint Snap 92, 94
Nearest Snap 92
Node Snap 92, 98
overview 91
Parallel Snap 99, 105
Perpendicular Snap 92, 96
Quadrant Snap 92, 97
Tangent Snap 92, 96

entprop command
changing entity properties 406, 408
layout viewports 628
setting elevation and thickness 708

erase command. See Delete command or tool (delete)
erasing

eraser tool 136
freehand sketches 136
segments of polylines 144

error reporting 828
ESNAP setting in status bar 92
Esnap. See entity snap
ETRACK setting in status bar 106
etransmit drawings 809
exiting IntelliCAD 43
expanding or compressing text 474
expblocks command

creating and saving blocks 348
inserting blocks 350
inserting drawings as blocks 351
inserting external references 354, 357
listing blocks 345, 353, 355, 362, 363, 364, 365
saving blocks as separate drawings 352

experience levels
changing level 3, 36, 824
explained 3
setting for menus or commands 824, 875, 888, 896

expfonts command
See also Explore Text Styles command or tool 984
creating new text styles 320, 474
current text style 318, 323, 332, 341
editing text styles 322, 361

explayers command
copying and pasting layers to other drawings 273
creating and naming layers 277
current layer settings 51, 288
deleting layers 274
displaying list of layers 275
hiding or freezing layers 290
layer color settings 295
layer linetype settings 295
layer lineweight settings 297
layer print settings 293, 294
layer print style settings 299
locking and unlocking layers 292

Explode Attributes command or tool (burst) 449
Explode command or tool (explode)

converting donut sides to arc entities 161
converting plane sides to line entities 162
converting polygon sides to line entities 144
converting polyline segments to entities 144
converting rectangle sides to line entities 140
exploding blocks 560
exploding entities into components 448

Explode Text command or tool (txtexp) 449
exploded dimensions 501
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exploded hatching 212
Explore Blocks command or tool (expblocks)

creating and saving blocks 348, 357
inserting blocks 350
inserting drawings as blocks 351
listing blocks 347
saving blocks as separate drawings 352

Explore Coordinate Systems command or tool (expucs) 
342

Explore Layers command or tool (explayers) 270
copying layers to other drawings 273
creating and naming layers 278, 364
current layer settings 51, 288
deleting layers 274
displaying list of layers 276
hiding or freezing layers 290
layer color settings 295
layer linetype settings 295
layer lineweight settings 297
layer print settings 293, 294
layer print style settings 299
locking and unlocking layers 292
opening IntelliCAD Explorer 270

Explore Layouts command or tool (explayouts)
listing views 359

Explore Linetypes command or tool (expltypes)
creating new linetypes 309, 311
current linetype 304, 308
listing linetypes 307
renaming linetypes 315

Explore Text Styles command or tool (expstyles)
creating new styles 474
creating new text styles 321, 360
current text style 323
editing text styles 322, 361
listing text styles 320

Explore Views command or tool (expviews)
listing views 334
saving and naming views 690, 692, 694, 705

expltypes command
creating new complex linetypes 311
creating new linetypes 309
current linetype 308
listing linetypes 307
loading additional linetypes 308
renaming linetypes 315

expmaterials command

assigning materials 364
current material 364

expmleaderstyles command 330, 331, 332
expmlinestyles command 315, 316, 317, 318
Export command or tool (export) 801, 802, 803, 804
exporting

drawings 799
layer states 305
layouts to model space 621
multiline styles 153
profiles 854

expstyles command 319
See also Explore Text Styles command or tool

exptablestyles command 324, 325, 326
expucs command 342

See also Explore Coordinate Systems command or 
tool

expviews command 333, 335, 359
See also Explore Views command or tool

expvstyles command 338, 340, 341
Extend command or tool (extend)

extending to boundaries 438, 481
extending to implied boundaries 439

extending
Apparent Intersection Snap 100
dimensions 525
entities to meet boundaries 438

extension command 99
extension lines

adding dimensions by selecting origins 502, 503
adding dimensions by specifying lines 502
arrows and arrowheads 528
defined 501, 978
formatting 525
obliquing 519

Extension Snap command (extension) 99
extension snaps 37, 100
extents

See also limits
defined 978
displaying entire drawings 237
rays and 125
scroll bar indicators 229

external references
displaying properties 379

Extract Attributes command or tool (ddattext) 568
extracting attribute data 563, 567–568
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Extruded Surface command or tool (tabsurf) 715
extruding

3-dimensional entities 710, 978
solid faces 758
surface meshes 714

F
Face command or tool (face) 711
faces 711, 772, 978
facet resolution 776
fade of images 598
feature control frames 538
fence

defined 978
extending entities with 440
illustrated 390
trimming or clipping entities with 442

Fence selection method 387
field command 486
fields in extracted attribute files 567
file formats

default Save As format 826
exporting 799
importing 585, 590, 786
IntelliCAD and AutoCAD files 3

file paths
for external references 577
for raster images 605

file size
blocks and 546
external references and 571
linked and embedded objects and 784, 798

files
aliases 903
audio 936
basing on templates 46
creating 46
damaged 49, 827
default Save As format 826
embedding into drawings 783
embedding into other applications 796, 798
etransmitting 809
exiting 43
exporting 674, 800
external references 354, 357, 571
extracted attribute data 563, 567
fonts 320

importing 585, 786
inserting as blocks 554
linking drawings into other applications 798
opening 47
passwords 109
previewing before printing 660
print style tables 649
printing drawings 662
profiles 849
publishing drawings 674
raster images 596
recently used drawing list 847
saving 43
saving blocks as drawings 550, 551, 552
search paths 829
sending through e-mail 814
shapes 937

Fill command or tool (fill)
filled or outlined lines on entities 140, 144, 161
turning fill display on or off 248

Fillet command or tool (fillet) 464
filleting

defined 460, 978
methods 464

filling entities
displaying current settings 380
donut lines 161
hatching 212
planes 161
polygon lines 144
polyline lines 144
rectangle lines 140
turning off display to improve performance 248

filtering entities during selection 391
Find and Replace command or tool (find) 482, 484, 485
find command 482
finding point coordinates 257
finding text 482
fit point 978
Fit Tolerance values for splines 155
fitting

text and arrowheads on dimensions 532
viewports to screen 623

fixed
attribute values 563
coordinate systems 255

flatness tolerance symbols 538
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flipping entities (creating mirror images) 423, 751
flipping printed page 631, 636, 654
floating toolbars and command bar 23, 35, 978
floating viewports

scale factor 626
flyouts on tools 36
font map

setting the default file 830
fonts 319

AutoCAD fonts 320
character sets 495
defined 320
font files 474
in paragraphs 471
in text styles 475
search path for files 829

footers and headers on printouts 857
forcing text to fit 477, 532
form tolerance symbols 538–539
formatting lines in dimensions 525
formatting text

dimension text 530–534
text styles 474, 475

fractional drawing units 58
frames of images 601
frames of wipeouts 188
Free Orbit command (rtrot) 231
Freehand command (freehand) 135
freehand sketches

drawing and inserting 135
erasing 136
setting as polylines or lines 136

Freeze/Thaw tool (IntelliCAD Explorer) 290, 291
freezing layers 275, 290, 291, 978
Full Render command or tool (fullrender) 773
full-size drawings 62

G
gaps in linetypes 310
gcenter command 95
geo command 606
geographic locations

adding to drawing 606
display settings 608
position markers 609
removing 608, 611

geographic maps

capturing areas 609
updating images 610

geomap command 608
geomapimage command 609
geomapimagesetmaptype command 610
geomapimagesetresolution command 610
geomapimmageupdate command 610
geomarkposition command 609
Geometric Center Snap command (gcenter) 95
Geometric Tolerance dialog box 540
geometric tolerances 538
geometry, overlaying reference geometry 573
georemove command 608, 611
global linetype scale 54
greeking text (Quick Text feature) 249
grid settings

changing settings 79
controlling separately in multiple views 242
displaying current settings 380
grid defined 978
GRID setting in status bar 80
isometric snap and grid 81, 84
rotating grid 81, 83

grips
color and size 402
editing entities with 401
moving entities with 431
resizing dimensions with 520
resizing entities with 436
scaling entities with 437–438
selecting entities with 403
stretching entities with 436
turning on or off 402

grouped entities. See blocks
grouping entities 450–453

H
hand cursor (Pan tool) 230
hand method to determine coordinates 260, 261
handles (entity grips). See grips
hardware requirements for IntelliCAD 20
hatch boundaries 212
Hatch command or tool (hatch) 212
hatch patterns and hatching

adding to entities 212
IntelliCAD compatibility with AutoCAD files 3
search path for files 829
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headers and footers on printouts 857
height of named views 334
height of text. See text height
helices

drawing 158
Help

assistance for IntelliCAD 13
displaying online Help 42
search path for files 829

hidden
attributes 563
edges on 3-dimensional polyface meshes 713
lines 771

hidden-line removal, defined 979
Hide command or tool (hide) 771
Hide Entities command or tool (hideobjects) 414
hiding

command bar 30
entities 414
entities using wipeouts 187
image frames 601
layers 289, 293
lines in 3-dimensional entities 771
menus 28
Model and Layout tabs 619, 837
Prompt History window 38
reference grid 80
ribbon 24, 26
scroll bars 837
toolbars 29
ToolTips 29
warning messages 827
wipeout frames 188
xref clipping boundaries 582

hierarchical viewing, external references 574
high quality images 600
high resolution displays 848
highlight command 250
highlighting entities

edges of shaded entities 772
turning highlighting on or off 405
when selected 250

horizontal
grid spacing 79–82
text orientation 474

horizontal dimensions
creating 502

defined 979
illustrated 500

horizontal drawing method
construction lines 128, 130
infinite lines 126
rays 125

hyperlink command 816
hyphens 245, 620, 622

I
icad print style tables 653
icad.dwt template 22, 46
icad.fnt font 474
icad.lin file 308
icad.pat library file 212
ICM files (IntelliCAD menu files) 869, 917
icons

audio notes 936
coordinate system 255
displaying embedded files as 783
large tools 30, 873, 885, 894

ID Coordinates command or tool (idpoint) 257
idpoint command 257
i-drop feature 817
IFC files

exporting 804
importing 790

IFC Out command or tool (ifcexport) 804
ifcattach command 589
image command 598, 604, 605
image tile menus 912, 913
imageattach command 596
imageframe command 601
imagequality command 600
images

attaching 596
changing paths 605
clipping 602
creating of maps 609
deleting 605
modifying 598
unloading and loading 604

Images tool (Block toolbar) 346
implied boundaries

extending entities to 439
trimming or clipping entities with 442

impoint command 793
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importing
files 585, 786
layer states 305
multiline styles 153
profiles 854

imprinting solids 765
improving performance

hatch pattern memory requirements 212
memory-intensive display elements 248

included angles in arcs 117, 119, 145
index colors

current entity color 52
selecting 71
selecting for layers 295

Infinite Line command or tool (infline) 126, 129, 130, 
131, 132, 133, 134

infinite lines
defined 979
drawing 126
filleting entities 466

infline command 126, 129, 130, 131, 132, 133, 134
Inquiry toolbar tools

coordinates 257
distances 376
drawing status 380
listing entity info 378
time variables 382

Insert Block dialog box 351, 555
Insert External file Blocks tool (Block toolbar) 346, 351
Insert Object dialog box 783, 785
Insert tool (Block toolbar) 346, 351
inserting

blocks 554
drawings from a Web site 817
hatch patterns 212
hyperlinks 816
menu items 870
menu sub-items 872, 873, 874, 886, 887, 894, 895, 

901, 905
objects 783, 785
raster images 596
ribbon items 879
ribbon sub-items 881, 884, 885
text 468
tolerances 540

inserting dimensions
aligned 504

angular 507
baseline 505
continued 506
diameter 510
horizontal or vertical 503
in paper space 513
leaders on 512
obliqued 519
ordinate 511
radius 510

inserting drawings into other drawings. See Xref Manag-
er command or tool (xrm)

insertion command 98
Insertion Point Snap command (insertion) 98
insertion points

attachment points 481
base points for drawings 380
for blocks 348, 350, 547, 548, 552, 555, 557
for external references 573
for text 468, 470, 475, 481
in attribute definitions 563, 564
in extracted attribute file fields 567
snapping to 98

insertobj command 783, 785
installing IntelliCAD 21
int command modifier 37
IntelliCAD Explorer

Blocks list 345–355
Coordinate Systems element 266, 333, 342
copying elements to other drawings 273
deleting elements 274
Dimension Styles 327–329
Layers element 275
Layouts element 345, 359
Multiline Styles element 315, 330, 338
overview 270–273
purge tool 275
single-click editing 319
Text Styles element (text styles) 319, 324–342
tools 103, 272
Views element 333–359

IntelliCAD Explorer command or tool (explayers) 270
intermediate experience level

changing 3, 875, 888, 896
explained 3

Internet
e-mailing drawings 814
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hyperlinks for 816
opening drawings from 817
publishing drawings to 817

intersection of 3-dimensional entities
defined 979
intersecting solids 742
snapping to 100

Intersection Snap command (intersection) 100
intervals on entities, marking off 368
invisible data. See attributes
invisible edges

of raster images 601
on 3-dimensional faces 710, 711
on 3-dimensional polyface meshes 713

invisible layers 275, 277, 289
Isolate Entities command or tool (isolateobjects) 414
isolating entities 414
isometric drawings

defined 979
enabling snap and grid settings 81

isometric planes
defined 979
illustrated 84
setting current plane 81

J
Join command or tool (join) 446
joining

combining solids 740, 741
entities 446, 456, 460

justification
attribute text 564
dimension line text 531

K
keyboard shortcuts

adding or deleting 901
customizing 899

KML and KMZ files 606

L
Last Entity In Drawing selection method 387
later states

applying 304
latitude lines

dishes 728
domes 728

spheres 726
layer states

creating 302
displaying 305
importing and exporting 305

layers
assigning materials to 364
blocks with entities from different layers 546
BYLAYER property 52–57
changing for text entities 481
colors and linetypes 52–54, 294–299
colors, linetypes, lineweights, and print styles 276
copying to other drawings 273–274
creating and naming 277, 288
current layer settings 51, 288, 380
defined 979
deleting in IntelliCAD Explorer 274
displaying layer information 378
displaying layer information for xrefs and blocks 

379
freezing and thawing 290, 291
hidden and visible 275, 276, 289, 293
in entity properties 412
Layers dialog box 295, 296, 297, 298
Layers element in IntelliCAD Explorer 273, 275
locking and unlocking 276, 292
overview 6–7, 275–328
print settings 293, 294
printing and nonprinting 275, 289, 293
renaming 278
selecting entities by layer 387
setting properties to ByLayer 412
status bar information 32
transparent overlays 6

layerstate command
apply settings 304
creating 302
displaying 305
displaying Layer State Manager 301
importing and exporting 305

layout command 620
Layout tabs

displaying 619, 837
print options 631
reordering 622

layout viewports
changing size 628
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clipping 628
creating 623
creating dimensions in 513
defined 979
invisible borders on 624
locking 628
maximizing 625
minimizing 626
modifying 628
scale factor 626
selecting 628
turning on and off 625
UCS per viewport 628

layouts
command or tool (layout) 618
copying 620
creating from templates 620
defined 979
deleting 622
displaying information for entities 378
exporting to model space 621
lineweights 640, 641, 642
listing and saving layouts 359
maximum number 619
model space and paper space defined 617
page setup 359
print area and origin 637
print options 631
printing 662
publishing 674
renaming 622
reordering 622
saving as templates 621
scale factor 637
viewing list of 622

Layouts list in IntelliCAD Explorer 359
Leader command or tool (dimleader) 199, 512, 515
leader format of multileader styles 201, 203
leaders in dimensions

creating 512, 515
defined 502, 979

leading zeros in dimensions 535
least material condition (LMC) 539
left-aligned text 477
length of lines

in freehand sketches 135
specifying before drawing 112

lengthening entities 436
lengthening or shortening entities. See resizing entities
levels of entities in arrays 749
levels of precision. See accuracy
libraries

of hatch patterns 212
of linetype 306, 308

light sources 767, 769, 770, 772, 775
Lighting command or tool (lighting) 775
lights 769, 770
limits

See also extents
defined 979
displaying entire drawings 237
displaying limits for drawings 380
drawing limits for printing 639
setting 63, 68

limits tolerance. See tolerances
lin files (linetype libraries) 308
Line command or tool (line) 112
Linear command or tool (dimlinear) 503
linear dimensions

aligned 504
baseline 505
continued 506
creating 502
formatting dimension unit display 535
illustrated 500
rounding in 534

linear drawing units 58–60
lines

adding to arcs 112
colors in dimensions 526
construction lines 128
converting complex entity sides to 140, 144, 162
dimensioning angles between lines 508
drawing lines 112
extending to boundaries 438
filled or outlined on complex entities 140, 144
formats in dimensions 525
freehand sketches as 136
hiding in 3D entities 771–773
in hatching 212, 259
in polylines 144
infinite lines 126
joining 446, 456
measuring and marking off intervals 368
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moving with grips 431
of text See text entities
profile tolerance symbols 538
width 141

linetype scale
changing global 54
setting current 53

linetype scales
setting up 55

linetypes
changing in entity properties 406
compatibility with AutoCAD files 3
copying to other drawings 272
creating new linetypes 309
current settings 53, 380
default linetypes 277
defined 979
deleting in IntelliCAD Explorer 274
displaying information about entities 378
displaying information about xrefs and blocks 379
drawing scale factor and 62
global scale settings 54
layer settings 275, 295
library files 308
linetype scale settings 54
loading additional linetypes 308
overriding for entities 296, 307
overview 306–307
print styles 654
setting up scaling 55
status bar information 32

Linetypes element (IntelliCAD Explorer) 308, 309
lineweights

current settings 55
defined 979
displaying 251
layer settings 297
overriding for entities 297
print settings 640, 641, 642
print styles 654
scale factor 252
set default 252

linking
See also ActiveX; embedding
defined 979
drawings into other applications 798
editing linked objects 785

external reference files 571–582
objects into drawings 783–785
raster images 596

LISP programs
calculating coordinates in rectangular meshes 712
defined 979
IntelliCAD compatibility 4
running programs 946–947

List Entity Info command or tool (list) 378
List Processing Language. See LISP Programs
listening to audio notes 937
listing

blocks and external references 345, 353, 355, 362, 
363, 364, 365

external references 574
fonts and text styles 319, 327, 475
hatch patterns 212, 213, 218, 223
layers 276
linetypes 307
materials 364
named views 333, 359
print style tables 657
user coordinate systems 342

LMC (least material condition) 539
Load Application Files dialog box 945, 946
load command 938, 946
Load LISP or SDS Application command (appload) 944, 

945, 946, 947
loading

.NET programs 946
additional linetypes 308
code pages 495
color books 79
default drawing environment settings 852
LISP programs 944, 946
menu files 917
profiles 851
raster images 604

location tolerance symbols 538
locations in drawings

absolute and relative coordinates 257, 261
coordinate systems 254
display order 433
displaying entity coordinates 378
finding point coordinates 257
moving and rotating entities 432–436
obtaining precise point locations 376
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Lock/Unlock command tool (IntelliCAD Explorer) 292
locking layers 276, 292, 980
locking layout viewports 628
log file

setting the default file 830

M
M or N direction

defined 980
in rectangular meshes 712
in surface meshes 714, 715, 716, 718

macros 931, 949, 980
See also scripts

magnification of drawings
See also scale factors
magnifying views 5
methods 233
zooming and panning in 3-dimensional drawings 

700
magnifying glass cursor 233
major axes 980
Make Oblique command or tool (dimedit) 519
Make Snapshot command or tool (msnapshot) 780
manual drafting compared to IntelliCAD 5
MAPI protocol 814
mapimport command 795
maps

adding geolocations 606
display settings 607
removing 608, 611

margins on drawings. See extents; limits
marker blips. See blips
marker blocks 368
markers, adding to geographic maps 609
marking off interval on entities 368
master drawings from component drawings 571
material condition symbols 539
materials 774
Materials command or tool (materials) 775
Maximize Viewport command or tool (vpmax) 244, 625
maximum material condition (MMC) 539
MDI (multiple-document interface) 3, 246, 980
Measure command or tool (measure) 368, 370
measurement lines. See dimensions and dimension styles
measuring and marking entities 368
memory requirements

for IntelliCAD 20

hatch pattern requirements 212
memory-intensive display elements 248

menu files
customizing menus 869
IntelliCAD compatibility with AutoCAD files 3
loading 917

Menu Item command 872
Menu Sub-Item command 872, 873, 874, 886, 887, 894, 

895, 901, 905
menus

adding commands 872, 873, 874, 886, 887, 894, 
895, 901, 905

as part of workspaces 33
changing experience levels 3, 36, 824, 875, 888, 

896
creating new menus 872
customizing 869
deleting commands from 877, 878
displaying and hiding 28
displaying with ribbon 25
menu bar illustrated 23
renaming commands 877
search path for files 829
starting commands with 36

Mesh command or tool (mesh) 712
mesh surfaces. See surface meshes
Messaging Application Program Interface (MAPI) 814
middle-aligned text 477
midpoint of two points 37
Midpoint Snap command (midpoint) 94
midpoints of entities 91, 94
Minimize Viewport command or tool (vpmin) 245, 626
minor axes 980
Mirror command or tool (mirror) 423
mirror3D command 751
mirroring entities 423, 980
mistakes, correcting 40
MMC (maximum material condition) 539
MNS files (AutoCAD menu files) 869, 917
MNU files (AutoCAD menu files) 869, 917
model space

See also paper space
copying entities to/from 419, 431
defined 980
displaying information for entities 378
overview 8, 616
print options 631
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snap from paper space 618
switching to 618, 619
switching to paper space 618
viewport scale factor 626

Model tab
cannot delete 622
displaying 619, 837
displaying information for entities 378
model space and paper space defined 616
print options 631
printing from 614, 662
publishing 674
viewports illustrated 616

Modify toolbar 29
modifying. See editing
monochrome print style tables 653
mouse from 3Dconnexion 953
mouse shortcuts 39
mouse wheel direction 843
Move command or tool (move) 430
moving

around in drawings 229
external reference files 577
profiles 854
prompt boxes 33
raster image files 604
toolbars and command bar 23

moving entities
dimension text 521
move command 430–432
solid faces 759
to other drawings 246
to other layers before layer deletion 274
vertices in polylines 458
with grips 401

msnapshot command 780
mtext command 470, 493
mtexted command 493
mtp command modifier 37
Multileader command or tool (mleader) 193
multileader styles 330

assigning 199
creating 198
deleting 200
format of content 205
format of leader structure 203
format of leaders 201

renaming 200
setting current 199

Multileader Styles element in IntelliCAD Explorer 330
Multileader Styles Manager command or tool (mleader-

style) 198
multileaders

add leader lines 196
aligning 197
collecting 197
creating 193
removing leader lines 196
styles 198

Multiline command or tool (mline) 147
multiline styles 315
Multiline Styles command or tool (mlstyle)

assigning to multiline 151
creating 149
deleting 152
exporting 153
importing 153
modifying 150
renaming 152
setting current 151

Multiline Styles element in IntelliCAD Explorer 315
multiline text

creating multileaders 193
multilines

drawing 147
justification and scale 148
styles 149

multiple commands
modifying commands 37
nesting several commands 37
repeating commands 36
using while commands are active 35

multiple copies
of entities 416
of external references 573
of layouts 620

multiple drawings 3, 246
multiple monitors 848
multiple views

See views and viewports
multiple-document interface (MDI) 3, 246, 980
mview command 625
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N
N direction. See M or N direction
N symbol in extracted attribute file fields 567
named print style tables

changing a drawing’s table type 657
comparing with color-dependent tables 650
converting to 658
copying, renaming, deleting 657
creating 653
default settings 857
defined 649
modifying 654
setting current print style 57

named text styles 474
See also text styles

named views 690, 980
See also views and viewports

navvcube command 695
Nearest Snap command (nearest) 93
negative coordinate locations 254
nested

blocks 546, 980
commands 37
external reference files 573

nested blocks
See also blocks

New command (newwiz) 46
new drawings 46
new features 14
New Item tool 103, 266, 272
newwiz command 46
node command 98
Node Snap command (node) 98
non-associative dimensions 501
nonassociative hatches 980
none command 102

See also Clear Entity Snaps command or tool
non-ISO linetypes 655
nparallel command 99, 105
numbers, rounding 534–538
numeric fields in extracted attribute file fields 567

O
OBJ files

exporting 805, 806
OBJ Out command or tool (objout) 805, 806
Object command (insertobj) 783, 785

object linking and embedding. See Active X
oblique angle

in dimension lines 519
in text styles 320, 322, 361, 474, 481

offline maps 609
Offset command or tool (offset) 421
offset copies of entities. See parallel entities
offset entities 421
offsetting

baseline dimensions 505
solid faces 760
text on dimension lines 531

OLE. See Active X
On/Off tool (IntelliCAD Explorer) 289
online Help 13, 42
onweb command 817
oops command 550
Open command or tool (open) 47
Open Drawing dialog box 48
opening

color books 75, 78
damaged files 49
drawings from a Web site 817
drawings using Recover 827
existing drawings 47
external references 575
files in other formats 585, 786
files sent through e-mail 815
IntelliCAD 22
polylines 454
profile files 854
templates for printed layouts 620

operating system code page 495
Options command (config) 824, 829, 830, 833, 834, 

837, 839, 840, 841, 842, 843, 844, 846, 847, 856, 
857, 858, 859, 860, 862, 863

Options dialog box 823
options, setting or changing 822
Ordinate command or tool (dimordinate) 511
ordinate dimensions

creating 511
defined 980
illustrated 500

organizing information
color books 75, 78
for printing 613
on layers 6, 275
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with blocks 546
orientation

of page 636
of text 319
of view 242, 243, 768
printing upside down 631, 636, 654
tolerance symbols 538

origin points
adding dimensions by selecting origins 502, 503
compared to viewpoints in 3-dimensional drawings 

688–706
defined 981
displaying distances in ordinate dimensions 511
of coordinate systems 265, 343
of extension lines 502
of print areas 640
of snap and grid 83
specifying locations by 259

ORTHO setting in status bar 85
orthogonal mode

defined 981
displaying current settings 380
overview 7
turning on 81, 85

orthogonal projection 981
osnap command. See entity snap
outlined elements in IntelliCAD Explorer 271, 272
outlining

donut lines 161
image frames 601
planes 162
polygon lines 144
polyline lines 144
rectangle lines 140
turning off fill display to improve performance 249
wire-frame models 706

output files of extracted attribute data 568
Outside Circle selection method 387, 981
Outside Polygon selection method 387, 981
Outside Window selection method 387, 981
overlaying external references 573
overlays. See layers
overscoring text 479, 480

P
page setups

deleting 635

publishing to 677
Pan command or tool (pan) 230
panels on ribbon 881, 884, 885
panning

See also zooming in or out
defined 981
in 3-dimensional drawings 700
in viewports 618
methods 230
viewing drawings by 5

paper sheet color 840
paper size 636
paper space

See also model space
copying or resizing viewports. See model space
copying entities to/from 419, 431
defined 981
dimensions 513
displaying information for entities 378
editing method 623
layout viewports 623
overview 8, 616
print options 631
printing from 359, 615
scale factor 626
snap from 618
switching to 618

paragraph text
aligning 469, 477, 478, 479, 480, 484
converting from line text 484
creating 470

parallel
dimensions. See baseline dimensions
drawing method, infinite lines and rays 125

parallel entities
defined 981
filleting parallel lines 466
parallel copies of entities 421

Parallel Snap 99, 105
Parallel Snap command (parallel) 99, 105
parallelism tolerance symbols 538
partial coordinates 263
passwords for drawings 110
Paste command or tool

IntelliCAD Explorer 273
pasteclip command 419

Paste command or tool (IntelliCAD Explorer) 103, 272
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Paste Special command and dialog box 784
pasting

embedded objects into drawings 782
entities into other drawings 246, 418
layers into other drawings 273
linked objects into drawings 784
settings into other drawings 272
text 472
text in Prompt History window 38

patch meshes 718
paths for files

color books 79
external references 577
raster images 605
search paths 829

patterned
lines. See linetypes

PDF
publishing to 680, 682

PDF files 802
pdfattach command 586
pen assignments 648–659
pen numbers 654
pencil tool 135
percent signs 479, 480
performance issues. See improving performance
perimeters 981

calculating areas 372
perpendicular distances from origin points 511
perpendicular entities

defined 981
infinite lines 126
rays 125
snapping to 91, 96

Perpendicular Snap command (perpendicular) 96
perpendicularity tolerance symbols 538
pface command 713
photo-realistic 767, 773
pipes 731, 732
plan view

coordinate system icons 255
defined 981
displaying 3-dimensional drawings 705

Plan View command or tool (plan) 705
planar entities

converting to 3D 707
defined 981

planar surfaces 734
planar tops for pyramids 724
Plane command or tool (plane) 161
planes

3-dimensional faces 711
converting sides to lines 162
defined 981
drawing 161
isometric planes 84

playing
audio notes 937
scripts 939–944

pline command. See Polyline command or tool (polyline) 
982

plotters
printing drawings 662
publishing drawings 674
selecting 637

plotting. See printing drawings
plus or minus signs 479, 480
pmspace command 618
point command 123
point filters (coordinate filters) 263, 975
Point Light command or tool (pointlight) 769
Point Selection method 387
Point Snap 98
Point tool 123
pointcloudattach command 587
points

See also base points; displacement points; endpoints 
of entities; insertion points; midpoints of entities; 
origin points; start points of entities

changing point entity appearance 123
defined 981, 982
drawing point entities 123
finding point coordinates 257
interval marker point entities 368
parallel copies passing through points 422
point locations in coordinate systems 254
snapping parallel 99, 105
snapping to point entities 98

polar
arrays of entities 426, 749–750, 981
coordinates 257, 259
See also coordinate systems

POLAR setting in status bar 86
polar tracking, turning on 86
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Polyface Mesh command or tool (pface) 713
polyface meshes 713
Polygon command (polygon) 142
polygon meshes

edge-defined Coons surface patch meshes 718
extruded surface meshes 714
revolved surface meshes 716
ruled surface meshes 714

Polygon, Center-Side tool 143
Polygon, Center-Vertex tool 142
polygons

See also polygon meshes 982
calculating area and perimeter 372
clipped images 602
converting sides to lines 144
defined 982
drawing 142
editing 454
using as selection windows 389

Polyline command or tool (polyline) 144
polylines

chamfering 462
converting entities to polylines 454
converting segments to entities 144
curving and decurving 455
defined 982
donuts 159
drawing 144
editing 454
editing vertices 458
extending to boundaries 438
filleting entities 464
freehand sketches as 135
joining 456
measuring and marking off intervals 368
opening and closing 144, 454
polygons 142
rectangles 140
tapering 144, 441
width 144, 457

position markers 609
position tolerance symbols 538
positioning

text on dimension lines 530
positioning dimensions

aligned dimensions 504
angular dimensions 507

arc dimensions 508, 509
baseline dimensions 505
diameter dimensions 510
dimension text 520
horizontal or vertical dimensions 503
leaders and annotations 512, 515
radius dimensions 510
text and arrowhead positioning 532

positioning entities 430
See also insertion points
blocks 554
moving entities 401

positive coordinate locations 254
ppreview command 660
precision. See accuracy
preferences command. See config command
prefixes on dimension text 535
presentations 780
Preset Viewpoints

command or tool (setvpoint) 688, 689
dialog box 689

previewing
block images 346
files before opening 48, 109, 240
print jobs 660

Previous Selection selection method 387
print area 639, 640
print command 662
Print command or tool (print) 662
Print dialog box 640
Print Preview command or tool (ppreview) 660
Print Style Table Editor dialog box 656
print style tables

assigning 652
changing drawing’s type 657
comparing types 650
copying, renaming, deleting 657
creating 653
default settings 857
explained 649
getting started with 650
modifying 654
search paths 829
turning off 659

print styles
changing in entity properties 412
default settings 857
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explained 649
layer settings 299
modifying 654
setting current 57

printers
printing drawings 662
publishing drawings 674
selecting 637, 643

printing
customizing the scales list 64

printing drawings
default print style settings 857
drawing limits 639
getting started 614
headers and footers 857
layer control 293, 294
layout viewports 623
lineweights 640, 641, 642
paper size and orientation 636
paper space 8
plotter drivers 637
previewing before printing 660
print styles 648–659
printing and nonprinting layers 275, 289, 293
printing drawings 662
rendered drawings 775
scale factors 62, 637
selecting printer 637
setting the scale 637
upside down 631, 636, 654

profile tolerance symbols 538
profiles 849–854

copying 853
creating 850
deleting 853
explained 849
exporting 854
importing 854
loading 851
renaming 853

profiles for revolved surface meshes 716–718
programming IntelliCAD 944–950
projected tolerances 537, 539
projection lines. See extension lines
prompt boxes

choosing command options 33
defined 982

turning off 33, 847
Prompt History window

defined 982
displaying drawing information 378
navigating with arrow keys 833
tracking history 38, 833

prompts in status bar 563
Properties command or tool (entprop)

changing entity properties 241, 406, 413, 626
changing viewport properties 628
IntelliCAD Explorer 103, 272, 295, 296, 297, 298, 

322, 361
setting elevation and thickness 709

properties, selection by 391, 396, 399
properties, setting to ByLayer 412
proxies

selecting 392
publish command 674, 678, 680, 682
Publish command or tool (publish) 674
publishing drawings

automatically 684
publishing sheet lists 674
to the Internet 817

pull-down menus 870
purge tool 275
purging 66
Pyramid command or tool (pyramid) 723, 724
pyramids

drawing 722
editing 454

Q
qtext command 249
quadrant points of entities 97, 982
Quadrant Snap command (quadrant) 97
quadrilateral filled planes 161
quality of images 600
Quick Select selection method 387
Quick Text feature 249
quitting IntelliCAD 43

R
radial dimensions 500, 502, 509
radians 982
radii of entities

arc 117
arcs 145
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circles 113, 114
cylinders 725
defined 982
dishes 728
domes 728
filleting entities 464
pipes 731, 732
spheres 726
tori 729, 735, 737, 738, 739

Radius command or tool (dimradius) 510
radius dimensions 510, 982
Radius-Tangent-Tangent circle method 113
RAM requirements. See memory requirements
raster images

attaching 596
changing paths 605
clipping 602
deleting 605
modifying 598
unloading and loading 604

Ray command or tool (ray) 125
ray tracing 773

defined 982
rays

defined 982
drawing 125
extending to boundaries 438
filleting 466

read-only files 48
Real-Time Pan command (rtpan) 231
Real-Time Zoom command (rtzoom) 234, 235, 236, 237
Record Script command or tool (recscript) 939, 941
recording audio notes 935
recording scripts 40, 939
Recover command (recover) 49
Rectangle command or tool (rectangle) 140
rectangles

converting sides to lines 140
defined 982
drawing 140
editing 454
squares 140

rectangular
arrays of entities 424, 427, 429, 749, 982
boxes 719
clipped images 602
filled planes 161

Redo tool 40
redoing actions 40, 982

See also undoing actions
redrawing screen 228, 982

See also regenerating drawings 228
reducing or enlarging view of drawings 233
reference

geometry 573
grid. See grid settings

Reference Grid tool 80
reflections 773
refreshing screen 228
regardless of feature size (RFS) condition 539
Regen command or tool (regen) 228, 249
regenall command 228
regenerating drawings

See also redrawing screen 982, 983
after editing text styles 322
after enabling Quick Text 249
compared to redrawing 228
defined 982, 983

Region command or tool (region) 733
regions 733

slicing and sectioning 757
relative coordinates

See also absolute coordinates; user coordinate sys-
tems (UCS); World Coordinate System (WCS) 
983

3-dimensional coordinate systems 260
defined 983
point filters 263
polar coordinates 259
spherical and cylindrical coordinates 261

relinking external reference files 577
reloading

external reference drawings 354, 357, 572, 577
raster images 604

Remove Leader Lines command or tool (aimmleaderre-
move) 196

removing the current scale from entities 239
removing. See deleting
Rename Command (IntelliCAD Explorer) 278
renaming

attribute definitions 565
blocks 348, 357
commands in menus 877
dimension styles 524
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layers 278
layouts 622
linetypes 315
multileader styles 200
multiline styles 152
print style tables 657
profiles 853
ribbon items 890, 898

Render command or tool (render) 769, 770, 771, 772, 
773, 776, 777

rendering 3-dimensional entities 767
reordering

entities 433
Layout tabs 622

repeating commands 36
replacing dimension text with new text 521
replacing text 482
reporting data 383
Reposition Dimension Text command or tool (dimedit) 

521
resetting timer 382
resizing

layout viewports 628
lineweights during printing 640
toolbars 29
viewports 628

resizing entities
arrowheads 529
changing length 443
extending to boundaries 438
scaling 437
stretching 436–437
trimming or clipping 441

resolution
map image 610

Restore Text Position command or tool (dimedit) 521, 
522

restoring
changed blocks to originals 558
default drawing environment settings 852
deleted entities 415
dimension text to home position 521
named views 336, 692, 693
previous view of drawing 236, 245

restricting. See constraining drawing
reusing information 5

copying settings into other drawings 273

drawing environment settings 849
IntelliCAD compared to manual drafting 8
layouts 620
reusing entire blocks and drawings 10

Reverse command or tool (reverse) 435
Revision Cloud command or tool (revcloud) 190
revision clouds

custom settings 191
drawing 190
drawing using existing entities 191
editing 190

Revolved Surface command or tool (revsurf) 716, 717
revolved surface meshes 716, 983
revolving solids 736
RFS (regardless of feature size condition) 539
ribbon

adding panels and commands 881, 884, 885
as part of workspaces 33
copying items 890, 898, 902, 906
creating new ribbon tabs 881, 883, 884
customizing 24, 879
deleting commands from 891
displaying and hiding 24, 26
displaying with menus 28
minimizing 25
renaming items 890, 898
starting commands with 35

ribbon files
customizing ribbon 879–891

right-aligned text 469, 477, 478, 479, 480, 484
right-click menus 23, 843
right-click shortcuts 39
right-hand rule to determine coordinates 260, 983
Rotate command or tool (rotate) 432
Rotate Dimension Text command or tool (dimedit) 520
rotating

3-dimensional entities 748
angles in attribute text 564
angles in elliptical arc drawing methods 122
blocks 348, 350, 552, 554–555
coordinate systems 265
creating 3D arrays 750
dimension text 520
dimensions. See aligned dimensions
entities 432, 747, 983
grid 83
images 598
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printed page 631, 636, 654
solid faces 760
text 468, 476, 481
viewpoints in 3-dimensional drawings 699
views 231, 694
visualizing rotation direction 260

rotation points
defined 983
specifying 432

rounding corners on entities. See filleting
rounding numbers in dimension display 534
roundness tolerance symbols 538
rows and columns of entities. See rectangular arrays of 

entities
rtrot command 232, 704, 705
rubber-band lines 983
Ruled Surface command or tool (rulesurf) 714
ruled surface meshes 714, 983
running

entity snaps 91, 983
IntelliCAD 22
VBA programs 950

runout tolerance symbols 538

S
SAT files

importing 786
Save As command or tool (saveas) 109
Save Block dialog box 352
Save Block to Disk

command or tool (wblock) 550, 551, 552
tool (Block toolbar) 346

Save command or tool (save) 43, 108
Save/Restore View command or tool (view) 335, 690
saving

attributes 563
blocks 348
blocks as drawing files 550, 551, 552
blocks as separate drawing files 352
color books 75, 78
default Save As format 826
drawings 43
in other formats 799
layouts as templates 621
named views 335
new complex linetypes 311–314
new linetypes 309–315

passwords with drawings 110
profile settings 849
sketches as part of drawings 135
snapshots 780
tracking last save time 382
user coordinate system 255, 265, 266
viewport configuration 245

Scale command or tool (scale) 437
scale factor

lineweights 252
scale factors

blocks 348, 350, 554
drawing to scale 5–6
drawing units 58
floating viewports 626
in dimensions 535
linetype scale 54
magnifying view by precise scale factor 236
printing lineweights 640
printing to scale 637
scaling entities 437
understanding drawing scale factors 62
viewports 626

scale lists
customizing 64

scales list 66
purging 66

scaling. See resizing entities; scale factors
scientific drawing units 60
screen display

customizing 831
magnifying 5
redrawing and regenerating 228
turning off memory-intensive display elements 248

screenshots (snapshots) 780
Script Recorder 40
script syntax 941
scripts defined 983
scroll bars 229

displaying 837
SDF files (Space Delineated Format) 567
SDS programs 4, 41, 983
search paths for files 577, 829
searching text 482
sectioning solids 757
security for drawings 110
segmented dimension lines. See continued dimensions
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segments
converting polyline segments into curves 455
defined 983
editing in polylines 144
measuring and marking off intervals on entities 368

Select All Entities selection method 387
Select Color command 295
Select Font dialog box 475
Select Layer by Entity command or tool (setlayer) 289
Select Similar command or tool (selectsimilar) 398, 399
Select Toolbars dialog box 29–30
selecting entities

adding or removing entities from sets 401
by block name 392
by filter 391
by properties 391, 396, 399
by proxy 392
by type 393
by value 397
highlighting 250, 405
matching specific properties 387
quick select 396, 399
selection methods 386
to copy or duplicate 416, 420, 424
to delete 414, 415
with audio notes 936

selection
sets 386, 983
windows 387

Selection modes 386
semicolon 941
separating solids 765
Set Z All command (setz) 50
setbylayer command 413
setdim command 327

arrows and arrowheads 528, 530, 532
baseline dimension offset 505
blocks and external references 271
creating dimension styles 523
deleting dimension styles 525
dimension line colors 526
formatting dimension text 530
renaming dimension styles 524
rounding off numbers 534
text positioning 530, 533

settings
arrows and arrowheads 528

Artisan Renderer 776
blips display 251
blocks and external references 345, 346, 351, 352, 

353, 355, 362, 363, 364, 365
colors 294
coordinate systems 271, 342
default drawing environment 852
default print style table options 857
dimension styles 149, 150, 186, 187, 198, 523
distances and angles display 256
drawing environment 849
elevation and thickness 706–711
entity snap 91
fills 248
grip display options 402
highlighting 405
layers 51, 272–299
linetypes 272
lineweights 251, 297
materials 364
mesh surfaces 714
multileader styles 330
multiline styles 315
Quick Text display 249
setting layers by selecting entities 289
shaded surfaces 772
table styles 324
text styles 271, 319, 474
user coordinate systems 265
views 271, 333, 335, 359
visual styles 338

Settings pane in IntelliCAD Explorer 271
setucs command 266, 267
setvpoint command 688, 689
Shade command or tool (shade) 772
shaded image 772
shading surfaces of 3-dimensional entities 772, 983
shadows 769, 773, 775
shape command 938
sheet lists

creating 674
modifying 677
publishing automatically 684

shelling solids 765
shortcut menus 843
shortcuts

adding access keys to commands 875
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customizing keyboard shortcuts 899
displaying shortcut menus 23
entity snaps menu 92
keyboard 39
using the mouse 39

shortening entities 436
shortening or lengthening entities. See resizing entities
SHP files (fonts) 320
SHX files (fonts) 320
sides of entities

editing polygons 144
editing polylines 144
editing rectangles 140
maximum number for polygons 142
specifying to draw polygons 144

simple entities 111
See also types of entities (lines; rays; arcs; and so on)

simulating
3-dimensional drawings 84
paper output on screen. See paper space

size
of files. See file size
of grips 402
of printed drawings 63–67
of text. See text height

size of entities
displaying size information 378
point entities 123
resizing. See resizing entities

sketch command. See freehand command 135
sketching freehand entities 135
slanted

dimensions. See aligned dimensions
text. See obliquing angle

SLD files (snapshots) 780
slicing solids 758
slide

files 780
shows 780

small tool icons 30
smoothing angle 776
snap

angle 983
grids 983
model space from paper space 618
resolution 983
settings. See entity snap

tool 82
SNAP setting in status bar 82
snapshots

defined 984
saving 780

solid
boxes 719
composites 740
cones 721
cylinders 725
dishes 728
domes 729
extruding solids 735, 737, 738, 739
filled planes 161
fills 248
pyramids 723
regions 733
revolving solids 736
spheres 727
tetrahedrons 723
tori 730
wedges 720

Solutions Development System (SDS) 4, 41, 983
sound clips 935
Space Delimited Format files 567
SpaceMouse 953
spacing

for entity snap 82
in reference grid 80

special characters 479, 480
speed of processing. See improving performance
Spelling command or tool (spell) 486, 487, 488
spelling of text 488
Sphere command or tool (sphere) 727
spheres, drawing 726
spherical coordinates 261, 984

See also coordinates
Spline command or tool (spline) 155
splines

closing entities 156, 157
drawing 155
fit tolerance 155

splitting entities 444
Spot Light (spotlight) 770
spotlights 773
squares 141
stacking entities in arrays 749
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standard
multileader style 330
multiline style 315
table style 324
text style 319, 474

Standard toolbar 29
start arrows 528
start points of entities

line entities 112
methods of drawing arcs 117, 145

starting
direction of arcs 117
IntelliCAD 22
new drawings with templates 22, 46
points for moving entities. See base points
script recording 939

starting commands
from command bar 36
from menus 36
from the ribbon 35
from tool palettes 35
from toolbars 36

status bar
assistance with IntelliCAD functions 13
displaying cursor position 256
illustrated 23, 32
prompts for commands 869
viewing model space and paper space 618

status command 380
status of drawings, displaying 50, 380
STB files

assigning 652
changing a drawing’s table type 657
compared with CTB files 650
converting to 658
creating 653
default settings 857
defined 649
modifying 654

Stop Recording command or tool (stopscript) 940
straightening curves in polylines 455
straightness tolerance symbols 538
Stretch command or tool (stretch) 436
stretching

entities 401, 436
text 477

style command (IntelliCAD Explorer) 321, 360

styles
annotative 66
dimension styles 523
multileader styles 198
multiline styles 149
print styles 648
text styles 474

stylesmanager command
copying print style tables 657
deleting print style tables 657
modifying print style tables 655
new print style tables 653
renaming print style tables 657

subtended angles 507
Subtract From Set selection method 387
subtracting areas of combined entities 375–376
subtracting solids 741
suffixes on dimension text 535
surface

material properties 773
of revolution 984
profile tolerance symbols 538
shading 772

surface meshes
density 714, 715, 717, 718
edge-defined Coons surface patch meshes 718
extruded mesh surfaces 714
polyface meshes 713
rectangular meshes 712
revolved surface meshes 716
ruled surface meshes 714

surface models
See also wire-frame models
defined 706
removing lines and applying shading 767–773

SVG files
defined 984

switching between model space and paper space 618
switching between monitors 848
symbols

datum reference letters 540
material condition symbols 539, 540
special characters in text 479, 480
symmetry tolerance 538
tolerance 538, 540

synchronizing drawing in Artisan Renderer 777
syntax
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macros in .cui files 931
scripts 941

SYSCODEPAGE 495
system requirements for IntelliCAD 20
system variables 984

T
table styles 324
Table Styles element in IntelliCAD Explorer 324
tables, mapping print settings 648
tabsurf command 715
tabulated surfaces 984
Tangent Arc tool 120
tangent command 96
tangent entities 984

drawing arcs tangent to an arc or line 120
drawing circles tangent to entities 115, 116
drawing donuts tangent to entities 160
snapping to 91, 96

tangent points on splines 156, 157
Tangent Snap command (tangent) 96
tapered polylines 144, 459

after joining 456
changing width 457
results of extending 441

tapering solid faces 761
target box for entity snaps 91
templates

basing new drawings on 46
default icad.dwt template 22
defined 984
for extracted attribute files 567–568
for printed layouts 620
importing 786
opening new drawings with 22
saving from layouts 621
setting default template 830

temporary files search path 829
terrain models 712
tetrahedrons 722
text

for multileaders 193
text annotations 512
Text command or tool (dtext)

adding text entities 468
setting text style 475
specifying alignment 477

text editor 493
text entities

See also text height; text in attributes; text on dimen-
sion lines

adding text to drawings 468
alignment 477
alternate text editor 493
attachment points 475, 481
backward or upside-down text 474
changing properties 481
character sets 495
code page 495
color 481
compressing or expanding 477
control codes and special characters 479, 480
converting line text to paragraph text 484
editing text 481
fields 486
find and replace 482
fitting between two points 477
insertion points 98, 468, 475
layer settings 481
obliquing 474
paragraph text 470
Quick Text feature 249
rotation angle 468
short lines of text 468
spelling 488
text styles 474
turning off display to improve performance 250
width 474

text files
templates for extracted attribute files 567

text height
calculating for different scale factors 62
changing height 322, 361
drawing scale factor and 62
in dimension styles 531
printed drawings and 62
short lines of text 468
specifying 67, 476, 481
text styles 474

text in attributes 564, 565
text on dimension lines

colors 531
formatting and positioning 530, 532
illustrated 500
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moving text 521
prefixes or suffixes 535
replacing with new text 521
restoring to home position 521
rotating 520
specifying text styles in dimension styles 531

text size. See text height
text styles

annotative 319, 474
applying 475
attribute text 564
changing styles 481
compatibility with AutoCAD files 3
copying to other drawings 273
creating new styles 320, 474
current text style 318, 323, 332, 341
deleting in IntelliCAD Explorer 274
editing attribute definitions 565
editing styles 320
listing available styles 475
overview 319
vertical, upside-down, or backward text 320

Text Styles dialog box 475
Text Styles element in IntelliCAD Explorer 319
text-based data. See attributes
thawing layers 290, 291, 984
Thickness command or tool (thickness) 706
thickness in 3-dimensional entities 984

See also elevation in 3-dimensional entities
changing in entity properties 406
default thickness 706

three-dimensional drawings. See 3-dimensional drawings
three-dimensional entities. See 3-dimensional entities
three-point

arc method 117
through points 422, 984
thumbnails of blocks 346
thumbnails of drawings 47
tick marks on dimension lines 528
tiers of dimensions. See baseline dimensions
Tile Horizontally command 242
Tile Vertically command 242
tiling windows 242
tilting. See obliquing angle
time stamps on printouts 857
Time Variables command or tool (time) 382
timers

for AutoSave 824
tracking drawing sessions 382

title blocks
adding in paper space 616
as available in each view 8

Tolerance command or tool (tolerance) 540
tolerances

adding geometric tolerances to drawings 538
composite tolerances 539
datum reference letters 540–541
defined 984
in Geometric Tolerances dialog box 540
limits tolerance 984
material condition symbols 537, 539
projected tolerances 539
symbols, defined 538
tolerance commands 984
variance tolerance 984

tool palettes
starting commands from 35

toolbar
customizing Quick Access toolbar 24, 26, 27, 864, 

865, 867
toolbars and tools

as part of workspaces 33
compared to manual drafting 6
creating new toolbars 893
customizing tools and toolbars 23, 891
defined 985
displaying and hiding toolbars 29
docking or floating toolbars 29
entity snaps tools 92
experience levels for toolbars 824
flyouts 36, 894
illustrated 23
IntelliCAD Explorer tools 103, 272
large tool icons 30, 873, 885, 894
size and color of tools 29
starting commands from 36
triangles on tools 894

ToolTips
adding to tools 891
assistance with IntelliCAD tools 13
turning on or off 29

top-aligned text 477
tori 729, 735, 737, 738, 739, 985
total runout tolerance symbols 538
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Trace command (trace) 154
tracking

command history 38, 833
last files used 48
number of entities 345

trailing zeros in dimensions 535
transferring drawings to other people 579
transmitting drawings 809
transparent

commands 985
images 598
overlays. See layers

triangles on tools 894
triangular filled planes 161
Trim command or tool (trim) 441
trimming

external references 580
printed drawings 639

trimming entities
chamfering 460
filleting 464

troubleshooting
drawing disappears from paper space 618
lineweight display 251
profile settings not saved 850
setting layout viewport borders as invisible 624
text display 495
wipeout display 187

true colors
current entity color 52
selecting for layers 295

turning features on and off
annotation scaling 238

turning features on or off
AutoSave 824
blips 251
entity snaps 102
grips 402
highlighting 250, 405
image frames 601
orthogonal setting 85
polar tracking setting 86, 88, 105, 106
print style tables 659
prompt boxes 33, 847
recent drawings list 847
reference grid 80
snap settings 82

solid fill display 248
text display 249
wipeout frames 188
xref clipping boundaries 582

turning off
AutoComplete at the command bar 31

two-dimensional
drawings. See 2-dimensional drawings 257
entities. See 2-dimensional entities 257

two-point circle method 113
txt2mtxt command 484
typing commands

aliases 903
entity snap commands 91, 94
in command bar 36
to load custom programs 947

U
UCS. See user coordinate systems (UCS) 265
undelete command (undelete) 415, 548
underscore characters 245, 620, 622
underscoring text 479, 480
undoing actions 40

See also redoing actions
Unicode characters 494
uniform width for polylines 457
unisolating entities 414
units. See drawing units
unloading

external references 576
print style tables 659
raster images 604

unlocking layers 292, 985
updatefield command 487
updating

all instances of blocks 546, 557, 558
attribute values 566, 570
block definitions 557, 558
drawing in Artisan Renderer 777
drawings inserted as blocks 351
external references 571, 577
file paths for external references 577
file paths for raster images 605

upside-down printing 631, 636, 654
upside-down text 474, 481
user coordinate systems (UCS)

See also coordinates, World Coordinate System 
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(WCS)
command (IntelliCAD Explorer) 266, 343
command or tool (setucs) 265
current UCS 344
defined 255, 985
defining per layout viewport 628
defining systems 265, 343
dialog box 265
listing 342
plan views of drawings 705
preset user coordinate systems 267

user levels. See experience levels

V
validated attribute values 564
values

editing attribute values 566, 570
extracting attribute values 567
variable attribute values 563

variables
dimension variables 523
system variables 984

variance tolerance
See also tolerances

variations in geometry. See tolerances
vba command 950
VBA macros command (vbarun) 950
VBA programs 4, 985
vbarun command 950
vectors 985
vertical

drawing method (construction lines) 130
drawing method (infinite lines) 126
drawing method (rays) 125
grid spacing 80
orientation for text 474
text orientation 322, 361

vertical dimensions
creating 503–504
defined 985
illustrated 500

vertical drawing method
construction lines 128

vertices
chamfering 462
defined 985
drawing polygons 142
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editing polyline vertices 458
filleting 465–466

View command (IntelliCAD Explorer) 335
View Cube command (navvcube) 694
View Snapshot

command or tool (vsnapshot) 781
dialog box 781
snapshots 781

viewing
See also views and viewports; windows 985
3-dimensional drawings 688
command bar 30
drawing thumbnails 47
dynamic view controls 699
external references 574
hiding lines in 3-dimensional entities 771
layout viewports 625
list of layouts 622
locked layers 292
Model and Layout tabs 837
panning drawings 230
plan view 705
print jobs before printing 660
print style tables 654
Prompt History window 38
redrawing screen 228
regenerating drawings 228
rotating the view 231
scroll bars 837
shading on entities 772
text 495
thawed layers 290, 291
ToolTips 29
turning layers on 289
using the view cube 694
viewpoints in 3-dimensional drawings 688
workspaces 34
zooming 233

viewpoints in 3-dimensional drawings 985
viewports

maximizing 244
minimizing 245

views and viewports
See also model space; paper space 985
arranging windows 242
changing properties 336, 628
copying views to other drawings 103, 272
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creating layout viewports 623
deleting views in IntelliCAD Explorer 274
displaying entire drawings 237
height and width of views 690
invisible borders on layout viewports 624
layout viewports overview 623
listing named views 333–335, 690
moving around in viewports 229
multiple views 242
orientation of viewports 243, 768
restoring named views 336, 693
restoring previous view of drawing 236
saving view configuration 245, 335, 690
scale factor 626
switching between model and paper space 618
turning on and off 625
viewport configuration defined 985
viewports defined 616, 985
views defined 985
zooming and panning 623

visibility of layers 275, 277, 289
visible

attributes 563
grid. See grid settings

Visual Basic Editor command (vba) 950
Visual Basic for Applications 4
Visual Basic for Applications (VBA) 4, 949, 985
visual styles 338
Visual Styles element in IntelliCAD Explorer 338
visualizing coordinate systems 260

W
walkflysettings command 698
warnings when opening drawings 827
WAV files 935
wblock command 550, 551, 552
WCS. See Word Coordinate System (WCS)
Web sites

accessing IntelliCAD 817
hyperlinks for 816
opening files from 817
publishing drawings for 817

Wedge command or tool (wedge) 720
wedges 720, 986
what’s new 14
width

after creating regions 733
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after exploding 448
after joining 456
changing the polyline width 457
lineweight settings 55
of donuts 160
of fields in extracted attribute files 567
of lines 141
of polylines 144, 459
printing lineweights 640, 641, 642

width of text
in text styles 320, 322, 361, 474
specifying 481

Window Circle selection method 387
Window Polygon selection method 387, 389
Window-Inside selection method 387, 388
Windows

metafiles. See WMF files
windows

See also views and viewports 985
arranging 242
cascading 242
displaying entire drawings 237
listing and saving named views 690
main IntelliCAD window 23
model space and paper space defined 616
moving around in 229
multiple views 242
opening new windows 242
saving arrangements 245
selection windows 387
tiling 242
unique numbers 242

Windows Clipboard
See Clipboard
embedding objects into drawings 782
embedding objects into other applications 796, 815
linking drawings into other applications 798

Wipeout command or tool (wipeout) 187
wipeouts 187–189
wire-frame models

See also surface models
defined 706, 986
removing lines and applying shading 771

witness lines. See extension lines
WMF files

defined 986
snapshots 780
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workspaces 33
World Coordinate System (WCS)

defined 986
overview 255
plan views of drawings 705
selecting 267
working with coordinate systems 342

World tool (IntelliCAD Explorer) 103, 272
Write, Then Resume option (freehand command) 135
writing sketches into drawings 135

X
x-axis

in coordinate systems 254
xclip command

deleting 582
polyline clipping boundaries 581
rectangular clipping boundaries 581
turning xref clipping on and off 582

Xlines 126
See also infinite lines

xlsimport command 794
x-ordinate dimensions 511
Xplode command or tool (xplode) 449
Xref Manager command or tool (xrm) 571, 572

attaching or detaching external references 573
binding external references 579
changing file paths 577
clipping 580
defined 345, 978
inserting drawings as 354, 357
nesting 573
overlaying 573
overview 571
reloading or updating 577
reusing entire blocks and drawings 10

xrm command
See also Xref Manager command or tool (xrm)
attaching external references 573
binding external path names 579
clipping boundaries 580
detaching external references 576
moving or changing the path name 578
opening external references 575
reloading or uploading external references 577
search path for files 829
searching for external references 578
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unloading external references 576
viewing external references 575

Y
y-axis

in coordinate systems 254
y-ordinate dimensions 511

Z
z-axis

in coordinate systems 254
z-coordinates in elevation 706, 709
zero angle settings 60
Zoom All tool 237
Zoom Center tool 237
Zoom command (alignspace) 627
Zoom command (zoom) 233, 626
Zoom In command or tool (zoom) 233, 236
Zoom Left tool 236
Zoom Out tool 233
Zoom Previous tool 236
zooming in or out

aligning viewports 627
changing mouse wheel zoom direction 843
changing viewport scale factor 626
defined 986
in 3-dimensional drawings 700
in print preview window 661
in viewports 623
overview 233
viewing drawings 5

zooming methods 233
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